Home

Thank you for downloading .netCHARTING. This document will help you work with the product and will serve as a programmers reference.

Here are some helpful links to get started.

Quick Start (Recommended Reading)

Thank you for downloading .netCHARTING. As you explore the features and functionality of this component you will find it is extremely powerful and capable of creating virtually any charts you may need. This software has also been developed to be much more flexible than the status quo, which, will enable you to push the charting envelope beyond the standards you may be used to.

This section with give a general overview of how everything works and get you started quickly. So without further ado, let's get to it.

Step 1. Installation

Please see the Illustrated QuickStart or the instructions in the installation help topic to get the component installed and able to view the accompanying samples. If you're an advanced user, simply unzip the download into a folder, make it a virtual directory and an asp.net application. Then make sure the temp folders under the directories with all the samples have full permissions for user 'aspnet'.

Step 2. Explore the samples

After the component is installed, take a look at the samples to get a grasp of the available features. You may see some interesting functionality that will give you ideas for charts you will be creating.

Step 3. Your First Chart

The best way way to get started is to take a sample that is similar to the type of chart you want and modifying the property settings.

Because many different charting applications use different terminology, it is also important to know the terminology used in .netCHARTING to get a good grasp on property names and what they do. Below is a chart image with a few basic terms.

Show Basic Terminology

More image references: Labels | Lines.

Tips

  • Make use of default properties
    There are several default instances of objects such as Chart.DefaultSeries for example. The properties of this object trickle down to all series on the chart. Using these defaults allows setting properties of many object at once instead of setting them individually. The following image specifies a few different object instances with properties that will end up affecting the given object.

    Show Properties to access objects.

  • Use Label Tokens (%Name, %Value, ...)
    Virtually all labels can show dynamic info about the parent object's values and data. For example, an element's label can show values such as the element's name and Y value.
    See also: Token Reference | Using Labels

Step 3.1. Getting/Using Data

.netCHARTING has a simple yet powerful interface for data acquisition and manipulation. Chart data is represented by SeriesCollection, Series, and Element classes. For more information on this model see this topic. When you are familiar with the general data model, you can explore the connecting to data sources and using query strings sections to learn how to populate these classes automatically.

Advanced
At this point you will be able to generate simple charts, however, this is only scratches the surface of what you can do in the data acquisition phase. You can also manipulate, group by dates, limit top x results, and do many other things with your data. When you are ready to explore the more advanced data features, take a look at the other Data Tutorials.

Step 3.2. Chart Type

An important point to remember is that the data model is independent from the chart engine itself. This means that whatever data you get, you will be able to create any chart with it. The mechanism behind chart types is also quite flexible.

Step 4. Exploring other features

You will now be able to generate basic charts and have a general idea of how to change the chart type. Most of the time, this is not enough to create the exact chart you need. Fortunately, we have covered only about 5% of the functionality available. Moving forward, there are many tutorials at your disposal. You may also visit the support section of our website to download printable PDF versions of some tutorials so that you can review them at your leisure.

Tutorials
  • Basic Tutorials
    Tutorials describing basic .net usage such as working with fonts and colors.
  • Data Tutorials
    Tutorials describing how to acquire data from different data sources and how to manipulate the chart data model.
  • General Tutorials
    Tutorials describing the functionality of .netCHARTING and its features.

If you have any questions please visit the .netCHARTING support website or contact support.

2002 - 2005 Webavail Productions Inc. & Corporate Web Solutions Ltd.. All Rights Reserved.


Illustrated QuickStart

This tutorial will illustrate the process of downloading the component to creating your first chart.

Show All Show All
Hide All Hide All

Show 1. Unzip the download

On the left is the zip file, on the right is the folder into which the bundle is copied.

TroubleShooting
- If not using Windows XP, a zip utility may be required.
- If the zip file is not saved to your HD first, you may be a message saying the zip is corrupt. Save it before opening to solve the issue.

Show 2. Create an application

This section illustrates creating an application. For more details please see the Application Creation tutorial.

Show 3. Set permissions

For detailed information on setting permissions please see the installation instructions.

The folders that require the permissions are:

  • dotnetcharting/csharp/features/temp
  • dotnetcharting/csharp/classic/temp (Shown)
  • dotnetcharting/csharp/gallery/temp
  • dotnetcharting/vbnet/features/temp
  • dotnetcharting/vbnet/classic/temp
  • dotnetcharting/vbnet/gallery/temp

..

Show 4. Setup your first chart.

Create a new folder under the dotnetcharting directory application to hold the new charts and the temp directory..

Show 5. Edit your first chart


Overview

.netCHARTING Overview

.netCHARTING combines visually stunning graphics and a comprehensive interface to bring you one of the most compelling charting solutions available.

From the very beginning our goal was clear; to produce a solution with stunning visuals that is also simple to use. No effort was spared in realizing this goal and the result is a unique web control that combines a high performance charting engine with a powerful database and data manipulation system.

.netCHARTING makes use of the most advanced technologies available on the market today including the .NET framework, introduced as a final release early in 2002, and GDI+. These are two of the many new technologies that have enabled us to step beyond existing visual charting standards and produce visuals much stronger than typical dynamic charting solutions. In fact, we hope you will agree that the .netCHARTING visuals are even superior to high end desktop charting applications!


New Features

New in Version 3.3 (7/27/2005)

Scale Break Styles
.netCHARTING’s innovative scale break feature has been enhanced to support a number of different styles including: gap, line, zigzag and none. In addition, a line object can be specified to control all aspects of the line formatting, color, size, dash style and more.

Weekend Calendar Pattern Support
Calendar patterns are unique patterns to identify specific date ranges or calendar periods. With the addition of a predefined CalendarPattern.Weekends option you can quickly and easily remove all weekends from your chart (for example) which is a common case in the financial industry.

Scale breaks based on Calendar Pattern
Now it is simple to apply scale breaks based on calendar pattern with the new Axis.ScaleBreakCalendar pattern property.

Arithmetic Expressions in Labels
Now you can perform common expressions directly within labels using values from template tokens. For example 100-%YValue to show a label calculated as 100 minus the total for that elements Y value. In addition, a new formula token has been added which enables simple addition of trend line formula in labels.

Less Intrusive Chart Mentor
The chart mentor provides usage tips based on the settings you are using in a given chart. This mentor has been enhanced to take less space and also supports a seamless ‘hide’ option. As always, the mentor is disabled when the mentor property or the debug property is set to false.

Post Render Box Positioning
.netCHARTING now exposes the exact position of any box after rendering. This enables advanced users to perform custom drawing based on the specific positioning of boxes.

Enhanced Smart Label Alignment
Smart Label Alignment support has been expanded and is now supported for all series types.

New Label Options
Labels can now be centered on elements and the label contrast for labels on top of columns has been improved.

2D Line Series Gradients
Like 3D lines and area lines before them, 2D lines now support seamless gradient transitions between colors.

New Chart Types – 3D Spline and 3D Spline Area
Support has been added for 3D spline and spline areas with enhanced visuals.

New Spline Tension Support
In addition, both 2D and 3D splines now support customizable spline tension settings on a per series basis.

New Background Mode
Brush mode enables a custom brush to be used for a background fill.

SaveState / LoadState
The chart object can now be saved to XML at any point and later restored. This powerful new feature is ideal for templating cases or for sharing a common set of properties among many charts. Options include saving to a string or file on disk. This feature can also be used to save and restore data that does not change such as last years sales data to enhance performance.

New DataField Support for ErrorData
Enhanced parsing and new mappings have been added enabling automatic population of : ErrorHighValue, ErrorLowValue, ErrorPercent, ErrorPlusPercent, ErrorMinusPercent, ErrorOffset, ErrorPlusOffset, and ErrorMinusOffset.

New TimeInterval Support
Minute (Minute by seconds) and Seconds support has been added along with corresponding samples.

Automatic DrillDown Enhancements
Enhanced to enable various international date time formats and support seconds.

Data input XML support enhanced
In addition to the previous support for XML datasets the data property now also accepts XML with attribute and node based data.

Forecasting Engine
The forecasting engine is a subset of the statistics engine and includes advanced forecasting capabilities including:
- Exponential Fitting
- General Linear Trend Line
- Logarithmic Fitting
- Non-Linear Trend Line
- Power Fitting
- Straight Line Fitting

Statistical Engine
In addition to the huge number of statistical additions added in the previous version, this new release adds the following:
- EstimateX
- EstimateY
- Simple Moving Average
- Residuals
- ResidualsAverage

Financial Indicators
Expanding the rich selection of financial indicators added in version 3.2, version 3.3 adds the following:
- ChaikinVolatility
- CommodityChannelIdxOverPeriod
- CrossingExtremeSignal
- CrossingSignal
- DStochastic
- Extreme Value D Signal
- Extreme Value K Signal
- K Fast Stochastic
- NegativeVolume Index
- OnBalanceVolume
- PositiveVolumeIndex

New in Version 3.2 (4/11/2005)

Polar Chart Type
Complete support for polar charts has been added including advanced rendering support for interpolation of data points when using a quantitative axis.

Statistical Analysis
Advanced statistical calculation support is now built in to .netCHARTING including

  • Bollinger Bands
  • C Frequency Table AOL
  • C Frequency Table AOR
  • C Frequency Table BOL
  • C Frequency Table BOR
  • Correlation Coefficient Determination
  • Exponentially Weighted Moving Average
  • Frequency Table OL
  • Frequency Table OR
  • Geometric Mean
  • Geometric Moving Average
  • IQR
  • Kairi
  • Kendall Correlation Coefficient
  • Least Squares Estimate X
  • Least Squares Estimate Y
  • Linearly Weighted Moving Average
  • Lower Bollinger Bands
  • Mean
  • Mean Deviation
  • Median
  • Median Moving Average
  • Pearson Correlation Coef
  • Percentile 25
  • Percentile 50
  • Percentile 75
  • Range
  • R Frequency Table OL
  • R Frequency Table OR
  • Simple Moving Average
  • Spearman Rank Correlation Test
  • Standard Deviation
  • Statistical Median Moving Average
  • Triangular Moving Average
  • Upper Bollinger Bands
  • Variance
  • Weighted Moving Average
  • Z Score

Financial Indicators
All major financial indicators have been integrated and samples added for advanced multiple chart area financial and stock charts. Indicators include:

  • Accumulate Distribute Over Period
  • Aroon Down
  • Aroon Down Over Period
  • Aroon Oscillator
  • Aroon Oscillator Over Period
  • Aroon Up
  • Aroon Up Over Period
  • Balance Of Power Over Period
  • Bollinger Bands
  • Chaikin Money Flow Over Period
  • Chaikin Oscillator
  • Commodity Channel Idx Over Period
  • Exponentially Weighted Moving Average
  • Financial Z Score
  • Geometric Mean
  • Geometric Moving Average
  • Inter Quartile Range
  • Kairi
  • Linear Moving Average
  • Lower Bollinger Bands
  • Mean
  • Mean Deviation
  • Median
  • Median Moving Average
  • Median Price
  • Momentum
  • Money Flow Idx Over Period
  • Percentile 25
  • Percentile 50
  • Percentile 75
  • Range
  • Simple Moving Average
  • Standard Deviation
  • Triangular Moving Average
  • Typical Price
  • Upper Bollinger Bands
  • Variance
  • Weighted Moving Average

Stacked Radar Columns
In addition to polar chart support, radars have been enhanced with support for the stacked axis scale.

Radar Axis Enhancements
Now radar charts have complete support for date and numeric x and y axis.

Radar Axis Orientation
Radar charts now supports orientation angle and XAxis markers.

Calculated Axis Ticks Shortcut
A new shortcut method has been added to enable quick and easy addition of calculated axis ticks -- for example a tick for a series average.

Axis Marker Bring to Front
A new property has been added which will enable you to bring a given axis marker to the front; automatically placing other chart elements behind it.

Radar Gridline Support Enhanced
Alternating gridline colors are now supported for radar X Axes.

DataEngine Support for xmlDoc
xmlDoc is now supported as a data source when using the Data property.

Include Grouping Data in Sub Values
A new feature has been added to automatically populate sub values based on the original values grouping calculations are made from. For example, if grouping by month a number of data points may be aggregated for that month. When enabled this feature will populate the sub values for that month so the individual values that makeup the element could be shown in addition the element total.

Automated Multiple Series Drilldown Support
A new feature has been added to support drilldown into multiple series for
all date grouping levels. This option determines if drill down occurs into
individual series or the series grouping. When drilling down into a series
grouping all available series will be shown in each hierarchy of the
drilldown chain.

Advanced Limit Support
Now limit can be bound to a specific series. When using this feature first
the series will be limited based on the specified value, then .netCHARTING
will automatically match any remaining series to that limit order rather
than limiting for each series independently.

DataEngine Enhancements
GetSeries now handles Boolean for xAxis or xAxisStart when loading from a
database. Also, GetSeries has been enhanced to support display of full
months of data when using irregular StartDate and EndDate values (mid-month
for example).

Minor Tick Control

New in Version 3.1 (2/25/2005)

Element Marker Visibility
You can now adjust the visibility of element markers with a single property setting allowing control at the chart, series or individual element level.

Minor Tick Control
The addition of Minor tick marks was well received in version 3.0, now in 3.1 complete control over minor ticks has been provided. In addition a new smart minor tick implementation has been added which automatically determines an ideal minor tick interval based on the major tick interval used. As always, automated settings can be overridden providing an high level control over the appearance and functionality of any given chart.

Smart Scale Breaks With Markers
.netCHARTING’s innovative smart scale break technology has been enhanced to work seamlessly with axis markers.

New Chart Mentor
The chart mentor offers useful tips and samples based on the chart you are creating. It can help you resolve problems and improve the implementation of your chart in the most efficient way.

Specify Line cap scale
The relative scale of the line cap (based on line thickness) can now be set.

Printer Optimized Text rendering
A new setting is available to automatically optimize text output for printing.

Multi-Color Legend Entry Support
When legend entries represent a series containing multiple elements with different colors legend entries will now show with the first 3 colors to ease identification.

Enhanced Token Support
Value tokens can now be used in axis ticks with value axes. In addition, the Xvalue token now automatically populates using Name if another value is not provided. Tokens can now be escaped or excluded by prefixing them with a forward slash.

Gridline defaults in Calculated Axes
Calculated axes now draw gridlines without alternating fills to enhance readability.

Error Bar and Error Value Support
Complete support for error bars and values has been added along with support to automatically populate element error properties from your own database. As part of a comprehensive system for representing errors in collected data, .netCHARTING now supports multiple sub values with rendering as error bars, lines and markers.

HTML Event Attributes
A complete system for adding HTML event attributes has been added. Now you can easily define custom DHTML tool tips, use JavaScript alerts and message boxes, set the status bar text and even define your own custom handling client side handling with ease.

Series Collection Saving and Loading
Enables saving a series collection to a file and later restoring it. This can be useful for reusing common sets of data and also for debugging and troubleshooting to provide test data to support.

Arbitrary Tick Addition
A new shortcut method has been added which enables you to add a list of arbitrary ticks to an axis using a single line of code.

Enhanced Range Tick Rendering
The ChartEngine has been enhanced with regards to ranged tick rendering to ensure optimal spacing and alignment regardless of usage scenario. In addition, ranged ticks can be tailored to your specific needs with advanced interval support, along with line and label customization.

Additional FormatString support
Format strings are used by .netCHARTING to take inputs, such as dates, and format them into different string representations. New custom format string support has been added for Q which returns quarter numbers and O which returns ordinal numbers (1st, 2nd, 3rd etc.) for both numeric and date values.

Axis Tick Label Angle
Axis ticks are angled if they would otherwise overlap when rendered parallel to the axis. You can now provide a custom angle for labels to use.

Duplicate Axis Support
In addition to the extensive calculation support which enables axis to be calculated and converted using hundreds of built in unit conversions, .netCHARTING now also supports duplicate axis. These axis are the same as the original and are useful when you wish to have the same axis on both sides of a wide chart. In this way, one can read values off the closest axis to the element they are interested in.

Color From Settings
Using built in palette support colors are often automatically assigned by the ChartEngine. New shortcut properties have been added to set colors of series or elements from other series or elements. This can be useful when manually adding calculated elements, for example, and wishing the color to synchronize with a given series.

Time Label Automation
A unique feature which quickly, intuitively, and with a minimum of labels, conveys time related data on the axis. For example when showing 26 months it is not necessary to repeat the year for every month. In this scenario, the automation feature will automatically render relevant data across “significant date” boundaries. Used in conjunction with ranged tick support Time Label Automation provides a stunning, easy to read, axis that elegantly handles continuous date ranges using indicator arrows.

Additional Data Engine DataType Support
The DataEngine.Data and Series.Data properties now support all objects that implement IEnumerable, ArrayList and HashTable. This enables nearly any data source to be bound to the chart with a single property setting adding to the currently supported DataTable, DataSet, DataView, DataReader, XML and Excel types.

Simple Series Creation per Column
New DataFields support enables the addition of multiple series from a single table using one line of code. With this addition, multiple YValue data definitions are supported in which case each will automatically generate its own series.

Total Series and Total Elements Support
New properties have been provided to return the total series and element counts to aid simplified paging through chart data.

New in Version 3.0 (11/18/2004)

Multiple Chart Area Support
Now you can have multiple independent chart areas within a single chart image. Advanced automatic alignment functionality enables a single axis to span multiple chart areas and automatically align with each other. Now creating perfectly aligned charts with a shared axis is quick and simple. Chart areas can be sized, relatively, by percentage and orientated within a grid layout.

Automatic Drilldown into “Other” data
.netCHARTING offers the ability to limit elements and new series created by its unique SplitBy technology. The result is the automatic creation of an “other” series which contains all data not included in the chart as a single element or new series. Now you can automatically drill down into this “other” data. New limit modes have also been added in addition to limiting the return to the Top x values you can now limit to bottom, exclude top and exclude bottom as well.

Axis Minimum and Maximum support enhanced
Now you can set minimum and maximum scales for log and time scale axis.

Log scale now supports any power
Now you can set the logarithmic base to any power in addition to the default log 10 support. For example base 2, base 5 etc.

Axis Minimum Interval
Set a minimum interval to ensure that the axis does not scale below your unit of business. For example, if you sell units which can not be divided, now you can ensure the axis will at minimum increment by one.

Inverted Scale Support
Creating inverted charts has never been easier! By selecting the inverted scale you can now draw charts from the top down.

Automatic and Custom Time interval Support
Now you can set custom axis intervals even while using the time axis. In addition, the automated interval system has now been enhanced for time axis.

Arbitrary Ticks and AxisMarkers can now affect scale range
.netCHARTING has intelligent automatic scale generation to select the best range possible based on the chart data. Occasionally you may wish axis ticks or AxisMarkers to be included in the automated scale range calculation. Now you can ensure important ticks or markers are always included in your scale with a simple setting.

Smart Scale Breaks
Often a chart has a few outlier data points which result in charts that are not legible for the bulk of the data. For example, if you had a chart of 100 values between 1 and 10 but 2 of the values were over 1,000 you could not accurately determine the values due to a compressed scale. Smart Scale Breaks automatically break the scale to cut out large unused sections so both lower and upper values can be clearly read.

Scale Breaks
In addition to Smart Scale Breaks regular scale breaks can be defined if you wish to break the scale at any arbitrary point.

Element, Axis Marker and Arbitrary Tick Support
Now you can define arbitrary tick marks on the axis with their own gridlines. In addition ticks can be defined for specific elements and axis markers.

Ranged Tick Support
An axis tick typically represents and labels a single value on an axis. Ranged ticks show a range of values on the axis, and are also known as an axis group. For example on a chart of months you could have 12 ticks, one for each month and then 4 ranged ticks showing each quarter. Ranged ticks could also be used to highlight specific data in conjunction with Axis Markers.

New Tick Formatting Options
Now you can set Color, Font / Tick Line & length and Grid Line on a per tick basis.

Axis Tick Ranged Overrides
You can also modify the settings of a range of ticks by value to affect tick formatting for a subset of individual axis ticks.

Image Tick Support
In addition to text or label based ticks you can use images in place of tick labels. For example, you could use a countries flag in place of country name on an axis.

Axis Label and Tick Alignment
New alignment options enable labels and tick alignment to be adjusted to suit your specific needs.

New Axis Orientation
Axis can now be displayed on the top of charts rather than the bottom which is the default. You can also now have multiple axis on the left, right, top of bottom of the chart!

Axis Label Token Support
Now .netCHARTING’s powerful token system can be used in Axis Labels enabling you to dynamically change axis labels based on token values.

Radar Charts Enhanced
Now with multiple radars each radar can have its own axis. In addition, time axis and bubbles are supported on radar charts.

Scatter Charts Enhanced
All series types are now allowed on scatter charts in addition to the previously included bubble and marker support.

Financial Charts Enhanced
Now financial chart types may be used in combination charts and powerful multiple area support provides increased power and flexibly for financial charts.

New Label Alignment support
Now you can adjust label alignment for labels including chart area, title, axis and axis marker labels.

Legend Box Enhancements
Massive enhancements have been made to the legend box including the ability to sort entries, show divider lines between entries, add headers, and add formal legend entries on a per entry basis. Legend boxes can now be positioned arbitrarily on the chart surface, even inside the chart area and can be orientated anywhere around the chart using predefined settings. Multiple legend boxes are now supported with the ability to add entries to any given legend box.

Custom Attribute support for Legend Boxes
In addition to the powerful new visualization options for legend boxes a new data subsystem has been added which supports tokens and custom attributes support. This means you can have your own custom data pulled from a database or set programmatically display in the legend box with ease.

Background Shading Effect
A new background specific shading effect has been added.

Calendar Pattern Support
Now you can define custom calendar patterns to implement axis markers or trim data. Calendar patterns will enable you to highlight a specific event or region of your data which re occurs including marking weekends or other recurring events.

PostDataProcessing Event
A new event has been added which enables developers to programmatically manipulate chart data after it has been processed by the DataEngine but before the chart has been rendered.

SeriesCollection.GetProcessedDataTable
A new method has been added which returns a dataTable of the processed data. This is useful to access the data for other purposes after the ChartEngine has processed it.

Start Date of Year
In addition to the ability to determine the start day of the week for automated week grouping functionality of the DataEngine, you can now use StartDateOfYear to control month start for years and quarters.

New in Version 2.5 (6/14/2004)

Custom Element Attributes
Now you can define any number of custom attributes for your chart elements.
In addition to the extensive built in element attributes such as color, font, line, transparency values, URL and many others, you can set your own custom values to be stored on a per element basis. Enhanced template support enables you to utilize your own custom data in any property that supports element templates such as annotation, URL, tool-tip, and name.

Gauge and Dial Charts
A stunning new gauge / dial chart type has been added. In addition to supporting a single chart, multiple gauges can be added for instant executive dashboard implementations. Many advanced features are supported with this new type including quarter, half or arbitrary sized gauges, with and without clipping, and 3d highlight effects.

Axis Label Marker Support
The new gauge type supports addition of a custom marker on the gauge face using this property.

Cleanup Minimum Age
Continuing the enhancement of the automated cleanup functionality available since the first version release, you can now specify minimum age to prevent deletion of specific files until they reach this age, for example, 30 minutes old.

Date Grouping Calculation Support
The date grouping functionality allows data to be easily grouped by date classes such as months, days, hours, years, quarters etc. It allows the same data to be visualized different ways with no custom programming required. Previously .netCHARTING would automatically aggregate (sum) values but now extensive arithmetic operations are supported including average, minimum, maximum and many more.

New Color Token
Building on the powerful token system a 'color' token has been added. This powerful new feature enables you to maintain color synchronization in drill down charts with ease. In addition, the built-in automated drill down now automatically supports this feature.

ImageMap and ImageMapName Exposed
For those clients that demand complete control .netCHARTING does not disappoint. Version 2.5 exposes the ImageMap text and ImageMap name which, used in conjunction with FileManager, allow you to customize images and independently assign image map data generated by the chart engine.

Per Element Hatch Style Support
Now you can customize elements with hatch styles, ideal for differentiating elements for black and white display or for those who are color blind. In addition to the specific hatch pattern used, you can also define element specific hatch coloring which can be set independent of the item color.

HatchStyle Palette and HatchStyle Palette Name Support
To complement the extensive per element hatch style support, .netCHARTING now provides the ability to define custom groups of hatch styles which are assigned, in order, to elements / series just as a color palette assigns colors. In addition, 5 predefined hatch style palette names are included to quickly and easily assign unique hatch styles using a single setting.

Series Background Support
A new background option has been added for series. This enables powerful background options for the new gauge / dial charts. For example, you could place a photograph of a real gauge in the background and have the needle be set dynamically based on the provided value. .netCHARTING will seamlessly merge the generated needle and background for photorealistic gauge renderings.

Annotation Text Alignment
New alignment support enables you to directly control the alignment of annotations in both the horizontal and vertical directions. Alignment options include left, right, center, top, bottom and middle.

Tiff Image Format Support
Now you can output 'lossless' tiff files with a simple property setting.

Vector Based Image Support
Have you wanted to print massive charts or zoom into the smallest detail without loss of quality? Now you can with native vector image support. Output charts as Enhanced Meta Files (EMF) and scale as large as you wish.

Series Collection Sorting
Now with a single method call you can sort series within the series collection. This new feature is particularly useful for 3D charts where it is advantageous to sort series in order to aid aesthetics such as a 3D area line chart (where keeping smaller series at the front enables them to be seen clearly).

Series Area Line Label Enhancements
Now series area line labels support label alignment similar to the new alignment support added to annotations.

Developer Version SmartBranding Added
The fully functional free developers version is branded not for production use. Typically this does not affect chart elements however with very small charts common in executive dashboards the branding can obscure part of the chart. With version 2.5, .netCHARTING will intelligently vary the branding transparency in such cases to ensure the chart can be visualized effectively in all scenarios.

Enhanced Annotation 'CallOut' Support
In addition to the previously supported top left, top right, bottom right and bottom left callout positioning, annotations now support callouts from the left, right, top and bottom. Combined with the new annotation text alignment features and advanced token system there are thousands of annotation variations now possible.

New in Version 2.4 (4/14/2004)

Custom Element Attributes
Now you can define any number of custom attributes for your chart elements.
In addition to the extensive built in element attributes such as color, font, line, transparency values, URL and many others, you can set your own custom values to be stored on a per element basis. Enhanced template support enables you to utilize your own custom data in any property that supports element templates such as annotation, URL, tool-tip, and name.

Date Grouping Sort
A new option for date grouping is now provided to control the sort order behavior. Date grouping is a powerful feature for grouping values into specific date ranges such as years, quarters, months, days and more.

Data Grid Header Template Support
In addition to stunning chart images, the data represented in the chart can be displayed automatically in a data grid in tabular form. This is useful for meeting accessibility requirements and easily allowing users to copy chart data as text. Now you can have the header set automatically based on chart data with new template support. This is particularly useful for drilldown charts or any chart where data changes dynamically.

Label trimming
Advanced label trimming has been added, allowing you to finely tune the visuals of labels that are too long to display well on the chart. You can now set a maximum length for labels, control the string used to terminate a truncated value e.g. "this is a long." and determine if labels will be truncated from the start, middle or end.

Simple database connectivity just got simpler
Now you can specify the file name of your access database or excel spreadsheet and .netCHARTING will be able to produce stunning charts from it directly with no complicated connection string or additional technical requirements.

Chart URL Mapping Enhanced
Define chart level URL for any surface of the chart to have a hyperlink while maintaining the functionality of any higher level hyperlinks that may be set for elements, legend entries, annotations and more.

Empty Element Handing for DataGrid Values
.netCHARTING has built in support for empty elements and can represent them in a number of different ways visually, or via labels. Now, when empty elements are included in a DataGrid view of your chart data they are seamlessly replaced with your own custom text value as defined with EmptyElementLabel.

Axis Label wrapping
Labels on both the X and Y axis can now be set to automatically wrap horizontally, display on an angle or display perpendicular to the axis.

Axis Label Separators
To make the separation between tick marks clear, particularly when the new wrapping functionality is used, label separators can be added. Options are provided to control the line, style and color for such separators.

Axis Label Rotation
Now you can rotate the Y axis label to read either bottom to top or top to bottom. The ChartEngine will also automatically select the most appropriate setting for each axis if not overridden.

New Palettes
Many new palettes have been added allowing you to chart with a variety of color schemes using one simple setting. As always, you can create your own palettes as well as set palettes at a chart or series level.

Enhanced documentation and Samples
More resources are now available to help you get the most out of .netCHARTING!

New in Version 2.3 (2/19/2004)

Advanced Empty Element Handling
Empty elements have always been handling intelligently and treated differently from 0 elements by .netCHARTING. An empty element is an element with no value which the chart will automatically render breaks for in lines and area lines. New features have been added enabling you to control how empty elements are displayed with custom markers, styles, lines, color, text notation and more! Empty elements may now also be replaced, automatically treated as zero, filled or ignored.

Multicolor Area Lines
This unique feature allows area lines with multiple colors to seamlessly blend together providing powerful visual queues in the chart image.

Annotation Support
A powerful new annotation system has been added which allows for custom messages to be displayed on the chart surface. Annotations may be attached to any element with custom orientation, made clickable and also display tool tips. Annotations accept tokens which are automatically replaced by chart data on the fly from series, axis or element information. Pure image annotations are also supported allowing for image layering with variable transparency.

Bitmap Image Access
To aid in simplified integration with reporting and PDF tools .netCHARTING now has a simple method for obtaining the entire chart as a bitmap.

Advanced Post Processing Support
You can now get the chart image in a bitmap with one simple step allowing for powerful post render operations on the chart. Calculated coordinate information is returned for chart elements allowing for powerful custom image post processing and a simple method is provided to automatically save the file for output.

Legend Image Support
Along with the chart image, you can now access the legend as a separate bitmap. This allows you to use the chart and legend images independently and reference them directly in your page for even more flexible layouts.

Fixed Column Width
By default column / bar width is automatically determined based on the number of elements and size of the chart created. You can now specify a fixed width which is useful when you want a consistent size in different charts or with drill down.

Ranged Area Line
The ranged chart type enables you to set start and end values for a chart. This powerful charting type previously available for other types is now also supported with area lines.

Enhanced Pie Labeling
With .netCHARTING Image is Essential and pie labeling has been further enhanced to ensure optimal alignment.

Enhanced Hotspot Support:
Now even the smallest values are accessible for drilldown, hyperlink or tool tip support with enhanced hotspot support.

Background Bevel Shading
A stunning new background option is supported which creates an attractive bevel on any background.

New Palettes
Additional predefined palettes have been added allowing for simple selection of attractive color schemes. Palettes can be set at a chart or series level (in which case each element takes on a palette color)

New Samples and Documentation
Many new samples have been added and documentation has been enhanced.

New in Version 2.2 (10/29/2003)

Series and Element Level Legend Entries
Now you can easily add legend entries for individual elements or series and control all aspects of legend entries individually. Legend entries can also be removed with a new visible property setting.

Legend Entry ToolTip and DrillDown Support
Legend entries may now be used for tooltip (showing additional data on mouseover) or drill down functionality.

Series Level Palette Support
A new PaletteName property at the series level allows you to have colors assigned on a per element basis within a series with one simple setting. Ideal for creating high impact single series charts the new system also automatically adds legend entries for each element rather than for the single series in such a case.

Axis Tick Label Templates
The powerful .netCHARTING template system has been extended to support full tick label templates. Now you can format and display your data in tick labels exactly as you please.

Enhanced Element Template System
The element template system has been enhanced with many more data values now available for use throughout .netCHARTING.

Format on the fly in Templates
On the fly formatting enables you to embed format string settings for a given template token to ensure the data is represented exactly as you want it without requiring manual formatting.

Automated Series Sorting
Now you can sort elements within a series with a simple method call.

Data Trimming based on set ranges
This powerful new data manipulation method enables you to remove elements outside a specific date or number range.

Series data manipulation with operators
Now series and elements can be manipulated programmatically with arithmetic operators. Add, subtract, multiple and divide any series or element with any other or fixed numbers.

Automatic axis number precision
When the tick mark interval is less than one .netCHARTING will now automatically set the appropriate level of precision for axis numbers.

Enhanced Design Time Support
Now supports declarative code generation and new properties editor GUI sections for customizing chart options. In addition, changes made to the declarative code directly will be reflected in the designer environment.

Selectable First Day Of Week
.netCHARTING's built in date grouping and DataEngine support has further been enhanced with a user definable start day of week. This new setting allows weekly data to be grouped correctly, exactly as you wish, be it Sunday to Saturday, Monday to Sunday or any other permutation.

New Clear Color Settings
New shortcut settings enable the colors to be cleared with a simple property so they may be selectively enabled in a customized fashion.

New in Version 2.1 (9/30/2003)

New Bar Visual Effects
Two stunning new visual effects have been added for 2D bars. These unique visuals add a 3D visual punch to 2D charts. Now you can satisfy your clients with a stunning 3D effect while maintaining the ease of readability you have come to expect from 2D charts.

Enhanced Image Map Support
Image map render order has been improved to more eloquently handle overlapping conditions.

New Bubble Visual Effects
Two new bubble shading options have been added to provide your charts even more visual punch.

Shaded Legend Icon Support
Legend icons are now synchronized with the chart element's shading effects allowing for quick and easy identification of an element from its legend entry.

Maximum Bubble Size Control
You can now control the maximum bubble size and have all bubbles rendered relative to this maximum size.

Per element label controls
Now labels can be controlled on a per element basis with settings for color, font, size, alignment and more!

Enhanced Smart Label Functionality
The label system has been enhanced dramatically and now supports conditional label inclusion depending on spacing, forced label rendering, set vertical rendering and control over label alignment.

Enhanced documentation and Samples
More resources are now available to help you get the most out of .netCHARTING!

New in Version 2.0 (8/11/2003)

Drill Down Support Enables "Clickable" Charts
Complete drill down support is now provided with advanced automatic drill down functionality using our own unique date grouping functionality. Now you can create multi level drill down charts from your own dynamic database in as few as 10 lines of code! Adding drill down support to a chart is as simple as one line - a single property setting! In addition to the automated drill down functionality, complete programmatic control is provided along with a template system for drill down URL to enable passing information on the selected element for subsequent drill down actions. Drill down has never been so simple, or so powerful!

ToolTip Support
Along with drill down support tool tips are now supported on a per element basis. This allows additional information to be displayed when the user rests the cursor over a given element. Through the ToolTip template you can control 30 different values which are automatically set when the chart renders. You can also set the ToolTip automatically from a field in your database with additional information or comments you wish to display to the user but don't want to clutter your chart with.

3D Chart Depth Control
This new property allows you to control the depth of charts when rendered in 3D modes. You can now control the width, length and depth of charts with ease.

Smart Label Support
The new "smart label" system ensures that labels do not collide or overlap even when chart elements are very close to each other. A small pointer is used to reference the element being labeled and the text is rendered on a portion of the chart with space for the label to be displayed. You have complete control over the indicator line color, thickness and style used along with the end cap / pointer included.

Complete Per Element Controls
Now you can control all expects of the chart down to the element level with complete per element controls. Settings include the color, marker, label, url, tooltip, transparency, labeling and much more. Now it is simple to vary colors on a per element basis or make changes to elements programmatically based on their value. For example: iterate through the elements collection and change all elements between 0 and 30 to green, 30-50 to yellow, 50-80 to orange and 80-100 to red. You have complete control over all settings providing an exceptional level of flexibility.

Alternating Axis Grids
You can now set and independently control the axis and alternating axis grids even specifying the background color / image of the axis grids.

Axis Markers
Many times a chart has a unique value which is significant but not directly represented by an element on the chart. For example, it could be a date when a specific promotion began, some other event or a special value (break even point, boiling point etc). With the new axis marker functionality you can mark specific points on any axis and even define ranges (for example weekends). With the advanced marker range background support you can also highlight such areas with any color or image background you wish. Of course you also have complete control of the axis marker line color, thickness and style.

Unlimited Axis and Axis Binding Support
Now unlimited x and y axis are supported for any given chart. Better still, each series can be independently bound to a given axis effectively allow multiple independent charts to display on the same charting surface. This feature is also very useful alongside the powerful combination charting options which allow different chart types to display at the same time in both 2D and 3D views.

New Calculate Axis Support
Along with unlimited axis support comes a powerful new concept in axis creation - the calculated axis. Often charts will display established units such as temperature, distance, weight etc. The calculate axis functionality allows you to create a new axis based on another axis with different units, all with one simple setting. Have a chart of distance in miles? Add a calculated axis with kilometers, yards or feet. Over 1000 different unit conversions are built in and you can define your own functions for unlimited flexibility. Process numeric values: 1, 2 ,3 into numeric names: one, two, three. Process your own conversions with your own custom functions - the possibilities are endless! In addition, you can calculate a new time based axis from one time interface (years) to another (quarters) with the same simple to use system.

Complete Per Axis Controls
Now every feature you can imagine is supported at the axis level with complete per axis controls. Independently set the axis line, background and alternating background, range markers, value markers, tick label overrides, cluster columns per axis, format and culture settings, grid lines, minimum, maximum, interval, padding, orientation, percentage, position (order), scale and much more.

Line Object Support
A new line object enables you to control all aspects of lines used to draw the Title Box, Chart Box, Legend Box, Chart Interior (from 3D mode), smart label pointers and many other areas.

New Background Options
Apply backgrounds to axis markers to highlight a specific range or value on the chart. In addition, backgrounds can be applied to alternating axis grids for a unique and powerful visual impact. The background object has also been enhanced offering new hatch style and hatch color support in addition to the established solid color, gradient, scaled image and tiled image options.

Legend Template Support
Now you can control the order, distribution and appearance of the legend entries with a powerful yet simple to use template system. Include the series name, the series value, and icon along with your own text.

Custom Legend Entries and Icons
Add an unlimited number of custom legend entries with independent text and marker details. This feature is useful for notes on custom markers that have been placed on the chart or to highlight a specific element with additional information. Combined with the new per element controls this functionality enables detailed information to be displayed on customized elements. You can further customize the legend appearance by defining custom legend icons.

Horizontal Cylinder Charting Type
A stunning new horizontal cylinder charting type includes support for percent complete hatching. Cylinder Gantt charts are also possible with the new range support.

Financial Charting Types
Stunning stock charts are now supported with series options for open, close, high, low, financial bar, Candlestick, and High Low Area in Volume chart areas as well as independent price / volume time intervals. New stock specific marker types have been added including split, reverse split, merger, dividend and spin-off. Of course you can specify any custom marker as well on a per element basis.

Donut Charting Type
A visually pleasing new donut charting type has been added. With complete 2D and 3D support this type also allows for transparency control for a very aesthetically pleasing chart.

Extensive New Pie Options
A powerful new labeling system, combined with smart labels, provides some of the most attractive and legible pies ever rendered. Labels can be rendered outside the pie with pointers to the representative slice, render inside the slice when there is room or automatically render inside or outside on best fit and appearance. In addition, pie slices can be individually controlled and exploded with per slice controls for exploded distance.

Range Charting Support
Now bar, cylinder, column and other charts support elements with start and end values. This enables a column that starts at a value greater than zero, for example, and allows for effective and attractive display of ranged data.

Powerful Element Templates
Along with the complete per element controls comes a new template system with 30 template containers. Templates can be controlled on a per element basis and are supported for element value, URL, and ToolTip. For example: %yValue will display the item value as a ToolTip (so when you hover your mouse over the element you will see the value). If you set %yValue for the element value you would see the actual value rendered on the chart. You can also use any number of template containers within any template along with your own text, for example, "Name: Name, ValueYValue". Template containers are automatically replaced with the elements name, value etc. when the chart is created.

New Marker System
A powerful new marker system provides an extensive set of 15 marker types in addition to support for any custom marker. Using built in markers you can control the color and size independently on a per marker basis. Markers are now used extensively throughout the product and allow for simple per series or per element customization.

Default Series and Element
A new default series and element allow you to make high level changes to default settings quickly and easily. Settings can take effect for all series on the chart, be overridden for one or more series and then be overridden for any given elements. This powerful new system enables you to have complete control down to the element level when required while maintaining ease of use and quick default settings.

Design-Time Support
Already one of the quickest and easiest solutions to get up and running, new Visual Studio .NET integration enables clients using this powerful IDE to see the chart in design time and observe the actual rendered chart and how it changes in real-time as settings are changed. A new wizard for Visual Studio .NET is also in development to further extend the products ease of use and rapid development for Visual Studio developers and will be available at no additional charge when released.

Updated DataEngine
Our unique DataEngine provides powerful data manipulation and acquisition features enabling you to chart multiple series from your own live database in as little as 8 lines of code! Now you can directly utilize the data engine to create derived series, split series, limit element or derived series returns to the top values and even aggregate "other" series or elements into a dedicated "other" series or element. Work with SQL Statements, Stored Procedures with parameters, Pass your own DataTable / DataSet, or use XML - the choices are endless and you can work with any database accessible within ASP.NET via ADO.NET. You can even chart directly from your own excel spreadsheet!

New DateGrouping Formatting:
You can now have complete control over date formatting, even for automatically generated series and elements created by the DataEngine and DateGrouping system.

Customize DataEngine Generated Series and Elements:
Now you have complete control both by series and element, even when using the advanced DataEngine functionality. Rename generated series, manipulate data, and update settings and visuals prior to creating the chart.

Improved DataGrid Display Options:
You can now control the orientation of the raw chart values for automatic display in a custom datagrid by setting columns by element or series. As always, you have complete control over the position and formatting of the datagrid.

Stock Specific DateGrouping, DataEngine and Drill Down Support:
The data engine supports all charting types from the database / datasource with mappings to any custom field names for expected values. In addition to automatically charting individual elements the DataEngine provides stock specific DateGrouping functionality. With a given element representing as many as 5 specific values (high, low, open, close, volume) the data engine automatically determines an sets the appropriate values as you group by Years, Quarters, Months, Weeks, Days, Hours and Minutes. It even allows for completely automated stock drill down charts with the addition of 1 simple setting.

Automatic Cache Subsystem
Typically charts are rendered in real-time with each request representing different data dynamically with different charts for each client request. However in some cases the same charts are displayed to many clients or the data the charts are based on is infrequently updated. A new cache duration setting can now be used in conjunction with the file name setting which enables the control to automatically determine if a new chart should be rendered or if the previously rendered image should be returned without further processing. The end result is a seamless scalable caching system that enables a given chart image to render only as required by setting one simple property.

Unclustered Cylinder & Bar Support
Clustered cylinders & bars enable values across multiple series to display clustered, in groups, on a per element basis. This allows for easy comparisons between values for a given element across multiple series. Now cylinders and bars support a new unclustered display in 3D modes showing each element behind the next.

Enhanced Transpose Functionality
Now with a single property charts can be transposed, visually exchanging series and element values, without modifying the underlying data. The result is a number of stunning and unique charts including blended transitions. Transpose now supports all available chart types and data combinations providing enhanced flexibility to meet even your most demanding needs.

Chart Area Label
A custom label can now be set for each chart area, enabling you to quickly and easily communicate additional information directly within the chart image. This is particularly useful if you have text that would normally be included in HTML on the same page as your chart, since when the user saves or forwards the chart image that plain text would be lost. Yet with the new chart area label feature it becomes part of the chart image itself. You may also control the font attributes and color used in addition to the text value to ensure the look and feel of your chart is exactly what you desire.

Independent Box Controls
A new box object allow for independent shadow, corner, label line and background customization on a per box basis. Customize the TitleBox and LegendBox to meet your exacting requirements with ease.

Enhanced Calculation Support
Now you can calculate new elements or derived series based by sum, average, median, mode, minimum and maximum. Calculations can run within a given series to product an element or within a series collection to produce a new series. For series calculations new support is added for running sum, running average, running median, running mode, running minimum and running maximum.

New in Version 1.4 (3/21/2003)

Date Scatter Support
In addition to the powerful and automated date grouping functionality, .netCHARTING now supports date scatter. This means you can plot any arbitrary dates relative to their exact position with automatic axis scaling. Choose between years, quarters, months, weeks, days, hours and even minutes with one simple setting!

Quarter & Minute Date Grouping
In addition to the extensive range of date grouping options already available, quarter and minute support has been added. Date grouping automatically aggregates values for a specific date range with no additional development or database coding required!

Gantt Charting Type
The Gantt charting type has been added with stunning 2D and 3D views. Unique to .netCHARTING is the completion indicator which provides a graphical representation of task progress and allows for visual customization.

Axis Numbering Controls
Building on the powerful automated numbering system, .netCHARTING now allows precise control over the axis numbering. Independently control the axis minimum value, maximum value and interval.

Wizard / code Generator
In addition to the extensive suite of samples provided in both C# and VB.NET the .netCHARTING wizard has been enhanced to support both C# and VB.NET code as well.

Axis Overrides
Axis mappings, or overrides, have been added which enable you to define custom labels for numeric values. For example if charting risk you may wish to use none, low, medium ,high in place of 0, 1, 2, and 3. Combined with the new axis numbering controls this feature is particularly powerful.

Excel Data Source Support
Adding to .netCHARTING's seamlessly integrated database support (no more writing database code!) for MS Access and SQL Server, Excel spreadsheets are now supported. That's right, you can now create stunning web based charts directly from your excel spreadsheets using .netCHARTING!

Title Wrapping & Legend Alignment
For long titles the system now automatically wraps to a second line if required. Bottom Legend alignment now supports left justification when more than one element is included and centering when only one element is present for ideally balanced aesthetics.

Automated Series Generation
.netCHARTING's advanced "splitby" functionality allows you to define a single series, generated from your database, and then create additional series splitting on a unique value (For example, show total sales split by customer - each customer would show with its own series). Advanced options are also provided to chart "other" elements aggregated as a single value. Now you can create a 10 series chart dynamically from your database in 6 lines of script!

Bar & Column Effect
Version 1.4 continues to push the visual fidelity of the product forward with a new effect available on bar and column chart types. .netCHARTING maintains incredible ease of use with dynamic database driven charts in a few lines of script while providing the best looking charts of any solution, on any platform!

New in Version 1.3 (2/17/2003)

Negative Value Charts
Full negative number support has been added allowing even complex charting types to display both negative and positive values at the same time. This new feature has been seamlessly integrated and takes effect automatically when negative data is included within any series.

Secondary Y Axis Support
An optional 2nd Y axis can now be added to the right side of a chart and scales as a factor of the original Y axis. For example, a sales chart could represent 2 different currencies by assigning the factor to a currency exchange rate. It would then be simple for values to be read off of the chart in either currency by examining the appropriate Y axis.

Scatter & Bubble Axis Controls
In addition to the control provided by the AxisScale property, two new properties are provided to independently control the scales for the x and y axis for scanner and bubble charts.

Bottom Legend Support
A new legend option is now available which allows for legend to be placed beneath the charting area. This allows for large series names to display cleanly without limiting the width available for the main charting surface.

Series Order Reversal
A new property has been added that enables you to reverse the order of the charted series with 1 easy step. You also have complete control over the positions with the series level position property.

Extruded Pie Support
A stunning new visual effect is available for 2D pie charts. In addition to this new effect, regular 2D pies and true 3D pies are also available.

Size Property
A new shortcut property has been added which enables you to set chart size with a single property.

Chart Level ShowValues
Show values controls if the numeric values for a given element will display on the chart. This new chart level property allows for a default value to be easily controlled. You also can override this setting on a per series basis.

DataGrid Series Name Support
The previous version added datagrid output support for the data values represented on the chart. Now you can also display the series names along with this data and control the name of the column used to display this data.

Date Axis Formatting
The specific date time format can now be controlled for axis that are date / time based.

Logarithmic Axis Scaling
The built in axis scaling options have continued to be enhanced with the addition of a logarithmic scaling option.

Data Table Field Selection
You can now control the fieldnames used when passing series data in a datatable. Options are available for which field to use for the x axis data, y axis data, splitby data, and bubble size data.

AddElement Enhanced
Two new options are available for adding elements to scatter and bubble charts with the addelement method.

New Samples
The included samples have been updated and a new sample has been added to demonstrate creating multiple chart controls programmatically.

New in Version 1.2 (1/14/2003)

Scatter Chart Type
True XY scatter support has been added. This allows both the X and Y axis to plot arbitrary decimal element values. In addition to point, scatter is supported for line and spline charts.

Bubble Chart Type
A unique new charting type which supports 3 data values per point. Bubble works like XY scatter but also supports a third value which controls the bubble size.

Scatter and Bubble Label Options
With the addition of 2 new charting types, powerful new label control options are provided including X, Y, XY, size, and XY size.

Stored Procedure Support
In addition to the built in SqlStatement support the product now allows you to call stored procedures to obtain charting data on a per series basis. Parameters for stored procedures are also supported through the new AddParameter method. A recent addition includes support for raw datatable input on a per series basis if required.

DataGrid Data Output
The included data processing engine performs grouping, aggregation and other calculations. A new DataGrid property has been provided which populates a datagrid of your choice with the tabular data represented in the chart.

Axis Scaling
This new feature ensures that small variations in charting elements are clearly visible. For example if all values were falling between 1000 and 1010 visually you would not see much separation with the axis starting at 0 and ending above 1000. Axis scaling enables the chart axis to scale to the range of the points represented in the chart so the full chart area can be used to reflect the different element values.

Cluster Property
Clustering enables columns to be easily compared by placing them next to each other in a group. This new property allows clustering to be disabled so, for example, so columns can appear behind each other.

Margin Settings
Complete margin controls are now provided for left, top, right and bottom. This allows you to control the amount of space or margin is left between the charting elements and the background. This can be particularly useful for implementing custom borders for your chart in conjunction with the new border background support.

Border Background Support
While extensive background options are already included, a new parameter has been provided to control how background images are handled. By default background images are titled if the image is not large enough to fill the chart area. Now, you can also scale the background to fit the size of the chart. This can be useful when using the background image as a charting border.

Legend and Title Box Style
New style options for the legend and titlebox enable you to control the corners independently from cut, box, or round options.

New in Version 1.1 (12/09/2002)

  • Additional chart type support including Radar and Multi-Radar in both 2D and 3D.
  • New outline controls including style and color for TitleBox, Legend, Graph
  • New line style and color settings for axis lines
  • New Percentage option for Y Axis formatting adds value cap and formatting features.
  • Dot Types are now supported on a per series level
  • Additional Dot Types have been added and now include square, triangle, circle, diamond, and 4 different star options.
  • New Dot Size option controls the size of dots used
  • New dot type option for "cycle" automatically cycles through and assigns unique dot types to any number of series with one simple setting.
  • Powerful new browser based wizard and code generator added! Create charts with point and click ease from your database. Also useful as a powerful learning tool, view the code generated by the wizard - copy and paste into your own scripts or modify further for your own custom needs.

Version 1.0

Initial Release!


Features

General Features

  • 2D and 3D rendering of charts.
  • Chart Mentor.
  • Printer Friendly Text.
  • Quarter and Ordinal (1st, 2nd) formatting .
  • HTML Hotspot Event Attributes
  • Automatic drill down support.
  • Maintain color synchronization in drill down.
  • ToolTip support.
  • Specify depth of 3D charts
  • Over 100 data related tokens for label templates.
  • Specify format strings for tokens on the fly within templates.
  • Design-Time support
  • Chart area label
  • Correction Warnings. Improper settings will be automatically corrected.
  • Default Series, Element, Axis, Shadow
  • Specify line objects for the title box, legend box, smart labels and many more.
  • Custom and random color palettes.
  • Separate shadow settings for chart areas, and boxes.
  • Image scaling makes it possible to make the smallest graphs.
  • Custom margins
  • Advanced Background class defines drawing options for virtually all chart objects.
  • Unlimited x and y axes.
  • Bind series to different x and y axes.
  • Label Trimming
  • Chart image links
  • Exposed image map.
  • Get the position and size of any box after chart is rendered
  • Save / Load chart object state in xml.
  • Smart Palette Support
    • Automatically generate a smart palette.
    • Save / Load smart palette in xml.
Advanced Empty Element Support
  • Mark with element markers, text, tool tips, colors.
  • Modes: None, Fill, TreatAsZero, and Ignore.
Output Features
  • Get a chart Bitmap.
  • Get a bitmap of the legend only.
  • Save bitmaps with the .netCHARTING system instantly.
  • Work with coordinates for each element after a bitmap is generated.
  • Output images as JPG, PNG, Tiff, WMF, EMF, and BMP.
  • Automatic cache subsystem.
Annotations
  • Attach to any element or free floating positioning.
  • Dynamic tool tips and link url.
  • Takes Series, Axis Marker or Element as data source for tokens.
  • Vertical & Horizontal text alignment.
Background Object
  • Standard Gradient
  • Angled Gradient
  • Solid Color
  • Tiled Image
  • Stretched Image
  • Hatch Style
  • Hatch Color
  • Bevel Effect
  • Use a custom brush to fill the background.
Smart Label System
  • Labels will not overlap.
  • Labels point to elements they represent.
  • Custom line pointers.
  • Force labels to be drawn when there is no room.
  • Align labels
  • Supply a list of alignments to try and find the best fit.
  • Use descriptive tokens and mathematical expressions in label strings.
Formatting Features
  • Number Precision
  • String Format
  • Culture Name
Line Object
  • Color
  • Width
  • Dash style
  • Line caps
  • Line cap scaling
Axis Features
  • Automatic axis tick calculations (i.e. average of data tick)
  • Automatic Number Precision.
  • Tick label templates.
  • Minor axis Ticks.
  • Smart minor axis ticks.
  • Axis tick angling.
  • Duplicate Axis Support.
  • Time Label Automation
    • Specific Mode
    • Smart Mode
    • Range Mode
    • AddRange Mode
  • Clear or hide the axis with a single method.
  • Alternating grid background
  • Specify axis line properties.
  • Specify grid line properties
  • AxisMarkers drawn on top of data Option
  • Axis range markers
  • Axis value markers
  • Tick label overrides.
  • Cluster columns on a per axis basis.
  • Per axis value formatting.
  • Maximum, Minimum, Interval, Time padding
  • Orient vertical axes left or right.
  • Set as a percentage axis.
  • Specify positions of the axes (order)
  • Reverse series of an axis.
  • Reverse series position of an axis.
  • Axis Scales
    • Normal
    • Range
    • Log
    • Time
      • Minutes
      • Hours
      • Days
      • Weeks
      • Quarters
      • Months
      • Years
    • Stacked
    • Full Stacked
    • Logarithmic Stacked
    • Inverted scale support
    • Scale breaks & Automatic (smart) scale breaks
    • Scale break styling
    • Calendar Pattern based Scale Breaks
  • Calculated Axes:
    • Custom method calculation
    • Convert from and to any unit. (1092 Units Available)
    • Shadow a time axis with different time intervals.
  • Control column spacing on a per axis basis.
  • Specify tick line properties including length.
  • Tick label padding.
  • Turn grid lines on or off.
  • Tick label wrapping.
  • Tick label separator.
  • Label rotation.
  • Axis label marker (Gauge chart).
Title Box
  • Intergraded legend.
  • Title & Legend wrapping
  • Left/Right/Center/Full alignment options.
  • Icon Image.
  • Box Edge Styling
  • Background and line drawing objects.
Legend
  • Multi-color legend entry icons.
  • Value and Name Templates
  • ToolTip Templates
  • Legend entry as link templates.
  • Hide legend entries.
  • Dynamic icons representing data.
  • Display the value of series.
  • Legend element template
  • Add unlimited extra legend elements
  • Custom legend icons.
  • Legend Icons mimic element shading effects.
  • Box Edge Styling
  • Positioning
    • Top Right
    • Middle Right
    • Bottom Right
    • Bottom Middle
Element Features
  • Specify per element:
    • Custom Attributes
    • Legend Entry
    • Axis Marker
    • Color
    • Explode Slice
    • Force Marker
    • Label Template with 29 tokens.
    • URL template with 29 tokens.
    • Tool Tip template with 29 tokens.
    • Marker
    • Secondary color ( stock charts )
    • Show Value
    • Transparency
    • Hatch style & color.
    • Label
      • Font
      • Color
      • Smart Label Properties
  • Multiple SubValue support
    • Types
      • Error Bars
      • Lines
      • Icons
Series Features
  • Legend Entry
  • Specify a palette for elements within.
  • Specify a hatch style palette for elements within.
  • Default element
  • Specify line properties for series which draw lines.
  • Specify x and y axes.
  • Series background support (Gauge & Radar).
  • Calculations
    • Sum
    • Mean
    • Median
    • Mode
    • Average
    • Minimum
    • Maximum
    • Running Sum
    • Running Mean
    • Running Median
    • Running Mode
    • Running Average
    • Running Minimum
    • Running Maximum
    • Trend Line
    • Scatter Trend Line
Series Collection Features
  • Calculate Series
    • (Same as series calculations above)
  • Transpose data.
  • Sort series by any element value.
Element Marker Features
  • Specify a Color
  • Custom Image
  • Specify size.
  • Built in Icons
    • None
    • Square
    • Triangle
    • Circle
    • Diamond
    • Four Point Star
    • Five Point Star
    • Six Point Star
    • Seven Point Star
    • Financial Split
    • Financial Reverse Split
    • Financial Merger
    • Financial Dividend Paid
    • Financial Spin-off
Series Types
  • Marker
  • Line
    • Multiple colors on a single line. in 2D and 3D
  • Spline
    • Multiple colors on a single spline. in 2D and 3D
    • Specify spline tension
  • Area Spline
  • Multiple colors on a single area spline.
  • Range Support
  • 2D and 3D support
  • Area Line
    • Multiple colors on a single area line.
    • Range Support
  • Column & Cylinder
    • 3 Shading Effects ( Column only )
    • Range Support
    • Percentage Complete hatch support
    • Horizontal Support
    • Advanced hotspot support.
    • Specify a fixed width.
Financial Series Types
  • Open
  • Close
  • High
  • Low
  • Financial Bar
  • Candlestick
  • High Low Area
Chart Types
  • Combo Chart
  • Side by Side Combo Chart
  • Horizontal Combo Chart
  • Pie & Donut Chart
    • Single and Multi Pies
    • Specify doughnut thickness
    • 2D Pie / Donut extruded effect
    • Explode slices per series or element.
    • Smart labels
      • Inside
      • Outside
      • Automatic
  • Radar Chart
    • Polar & Spider axis modes.
    • Single and multi radars
    • Multiple radars can have separate axes.
    • Time Y Axis scale
    • Bubble series support
    • Column Series Type Support
    • Stacked Columns
    • Stacked Area Lines
    • Quantitative X & Y axis scales
    • Radar Orientation Angle
    • Tick Label Modes
      • Normal
      • Angled
      • Next to In
      • Next to Out
  • XY Scatter
  • Bubble Chart
    • 3 Bubble shading effects.
    • Control maximum bubble size.
  • Financial Chart
    • Optional volume chart area
    • Different time intervals for price and volume
  • Gauge Chart

Statistical Analysis

  • Bollinger Bands
  • C Frequency Table AOL
  • C Frequency Table AOR
  • C Frequency Table BOL
  • C Frequency Table BOR
  • Correlation Coefficient Determination
  • EstimateX
  • EstimateY
  • Exponentially Weighted Moving Average
  • Frequency Table OL
  • Frequency Table OR
  • Geometric Mean
  • Geometric Moving Average
  • IQR
  • Kairi
  • Kendall Correlation Coefficient
  • Least Squares Estimate X
  • Least Squares Estimate Y
  • Linearly Weighted Moving Average
  • Lower Bollinger Bands
  • Mean
  • Mean Deviation
  • Median
  • Median Moving Average
  • Pearson Correlation Coef
  • Percentile 25
  • Percentile 50
  • Percentile 75
  • Range
  • R Frequency Table OL
  • R Frequency Table OR
  • Residuals
  • Residuals Average
  • Simple Moving Average
  • Spearman Rank Correlation Test
  • Standard Deviation
  • Statistical Median Moving Average
  • Triangular Moving Average
  • Upper Bollinger Bands
  • Variance
  • Weighted Moving Average
  • Z Score

Financial Indicators

  • Accumulate Distribute Over Period
  • Aroon Down
  • Aroon Down Over Period
  • Aroon Oscillator
  • Aroon Oscillator Over Period
  • Aroon Up
  • Aroon Up Over Period
  • Balance Of Power Over Period
  • Bollinger Bands
  • Chaikin Money Flow Over Period
  • Chaikin Oscillator
  • Chaikin Volatility
  • Crossing Extreme Signal
  • Crossing Signal
  • Commodity Channel Idx Over Period
  • D Stochastic
  • K Fast Stochastic
  • Exponentially Weighted Moving Average
  • Extreme Value D Signal
  • Extreme Value K Signal
  • Commodity Channel Idx Over Period
  • Exponentially Weighted Moving Average
  • Financial Z Score
  • Geometric Mean
  • Geometric Moving Average
  • Inter Quartile Range
  • Kairi
  • Linear Moving Average
  • Lower Bollinger Bands
  • Mean
  • Mean Deviation
  • Median
  • Median Moving Average
  • Median Price
  • Momentum
  • Money Flow Idx Over Period
  • Negative Volume Index
  • On Balance Volume
  • Percentile 25
  • Percentile 50
  • Percentile 75
  • Positive Volume Index
  • Range
  • Simple Moving Average
  • Standard Deviation
  • Triangular Moving Average
  • Typical Price
  • Upper Bollinger Bands
  • Variance
  • Weighted Moving Average

Data Manipulation Features

  • Sort series by any element value.
  • Trim elements within a series that are outside of a given date or numeric range.

  • Add, Subtract, Multiply, and divide any series, or elements with operators ( + - */ ).

  • Perform the same calculations between series/elements and numbers. (Element1 * 5).

  • Addition of a derived series for average or running sum calculated over all, or any specific, series.
  • Addition of a data point for any given series calculated as sum or average for that series.
  • Addition of any arbitrary data point / reference on a individual series basis.
  • Add series data automatically from a database.
  • Split data from an automatic database return to automatically create multiple series.
  • Set a maximum number elements to return / chart.
  • Automatically tabulate top x elements and aggregate others into an "other" element.
  • Seamlessly move between MS Access and SQL server databases by only changing your connection string.
  • Obtain series data from separate databases and graph multiple series on the same chart.
  • Group multiple series on one chart with missing points automatically handled and series matched out.
  • Series order reversal
  • Stored procedure support
  • DataGrid output.
  • DataGrid header template support.
  • DataGrid empty element handling.
  • DataGrid formatting.
  • Quarter & Minute Date Grouping
  • Excel Data Source Support
  • Automated Series Generation
  • Smart database connectivity (specify file names without connection strings)
  • Include grouping data in SubValues
  • Multiple Series Drill-Down
Date Handing
  • Automatically add date / date range represented on the graph to the charting header
  • Dates are treated intelligently and database data can automatically be grouped and graphed in a number of date ranges including: day by hour, week by day, month by week, month by day, year by week, and year by month.
  • Date groups automatically create x axis labels as required
  • Selectable first day of the week.
  • Date axis formatting
  • Date grouping sort.
  • Date grouping calculations.


Install Index

This section describes how to install and use the component in different situations

  • Installation
    Installing the component
    • Installation Steps
      Procedure of installing the component.
    • Application Creation
      How to create an application on the server.
    • Virtual Directory Creation
      How to create a virtual directory.
  • WinForms
    Using the component in the WinForms environment.
  • Visual Studio .net Usage
    Using .netCHARTING with Visual Studio .net
  • Visual Studio .net Help Integration
    Integrating .netCHARTING documentation with Visual Studio .net
  • WebMatrix
    Adding .netCHARTING to the WebMatrix Toolbar.
  • Upgrading
    Upgrading .netCHARTING to newer versions.


Installing .netCHARTING

This section describes how to install and use the component in different situations

  • Installation Steps
    Procedure of installing the component.
  • Application Creation
    How to create an application on the server.
  • Virtual Directory Creation
    How to create a virtual directory.

    • 2002 - 2005 Webavail Productions Inc. & Corporate Web Solutions Ltd.. All Rights Reserved.


Installation

.netCHARTING can be deployed quickly and easily without any special installation or registration requirements. It will work with a dedicated server, shared server, hosted server etc. so long as the server supports ASP.NET - as soon as you copy your files to your web server you can start using .netCHARTING!

NOTE: If you have a server license, please see the included install.txt for installation instructions.

Procedure (Website Version)

1. Unzip distribution
2. Copy / FTP web files to a directory within your web servers root directory
3. Ensure that dotnetCHARTING.dll and your purchase key are located in the /bin directory and that the /bin directory is in the root (top level) of your web site or, if not, that you have created an application for the subdirectory which contains your /bin directory. Note: a key is not required for the trial.
Ensure the temp directories have appropriate permissions set. See below.

4. You may now use the .netCHARTING samples

Using a Virtual Directory

1. Unzip distribution
2. Place files in any directory you wish.
3. Using the IIS administration (MMC), create a virtual directory under your web site pointing to the /web directory that contains the .netCHARTING samples. Click here for more information on virtual directory creation.
4. Ensure that your purchase key is located in the /bin directory along with dotnetCHARTING.dll. Note: a key is not required for the trial.
5. You may now use .netCHARTING samples

Setting Directory Permissions:

.netCHARTING creates image files dynamically to display charting data. By default, these temporary images are written to the same directory of the calling script, alternatively, the TempDirectory property can be set to a path of your choice. Either way, the ASP.NET worker process must have permissions to write to this directory. If your permissions are not already configured to allow write access, right click on the directory in question and select properties, select security, permissions and add the ASPNET user with write permissions.

Show See Image

Troubleshooting

  • If you are missing a security tab, see this article.
  • If using Windows Server 2003 and permissions don't work, see this kb.

If you are remotely hosting contact your web host and ask for write permissions on the directory of your choice. These are the same permissions required to add any data to a database or modify a text or XML file. Your host may also have created a special directory for this case such as /data. In this case you can set the TempDirectory to this directory and make no permissions changes.

Working with Visual Studio:

A step by step guide is provided for working with .netCHARTING in visual studio along with common errors and resolutions you may encounter in this environment. View Guide
See Also

Getting Started: Application Creation | Virtual Directory Creation | Using With Visual Studio.net | Upgrading | Using with WinForms


Application Creation

To create an application for a directory you should complete the following steps:

Procedure

  1. Open the MMC (Microsoft Management Console) also called the Internet Services Management or commonly referred to as the IIS administration.
    Windows XP Professional: Control Panel > Administrative Tools > Computer Management
    Node: Computer Management > Services and Applications > Internet Information Service > Web Sites > Default Website
  2. You will see a list of snap ins, one of which will be called Internet Information Server. Under this you will see your server name, select this server to view a list of sites running on the server
  3. Select the site which contains the directory you wish to create an application on, expand the site listing and you will see a listing of all directories within the site.
  4. Right click and select properties for the directory you wish to create an application for. The directory tab will open and If a directory is not yet created you will see an "application" in grey text and a create button.
  5. Click the create button and an application will be created for the directory.
  6. You are now complete and can close the MMC.


Virtual Directory Creation

To create an application for a directory you should complete the following steps:

Procedure

  1. Open the MMC (Microsoft Management Console) also called the Internet Services Management or commonly referred to as the IIS administration.
    Windows XP Professional: Control Panel > Administrative Tools > Computer Management
    Node: Computer Management > Services and Applications > Internet Information Service > Web Sites > Default Website
  2. You will see a list of snap ins, one of which will be called Internet Information Server. Under this you will see your server name, select this server to view a list of sites running on the server
  3. Select the site you wish to add a virtual directory for, right click on this site and select "new", "virtual directory"
  4. You will be prompted to enter the alias, this is the name you want to access the content through for example enter "chart" and select next
  5. You will be promoted to enter the physical path, this is the path where you unpacked .netCHARTING, for example "c:\dotnetcharting"
  6. Select "next" and "finish" on the final page.

    Your virtual directory is now setup, and you can load the samples through http://www.yoursiteaddress.com/chart


Using with WinForms

.netCHARTING Winforms Support

A winforms version has been released in conjunction with .netCHARTING 3.0. This enables usage outside of a web environment and in desktop applications. The winforms bundle (dotnetchartingwinforms.zip) contains a separate assembly dotnetcharting.winforms.dll.

The winforms control will not function in a web environment. In addition, the web version (dotnetcharting.dll) will not function outside of a web environment.

If you are already familiar with .netCHARTING the winforms version will also be familiar. When you run the provided sample application (dotnetchartingsamples.exe) you will discover the code for various charts is identical. This application provides an interface for viewing different charts along with the source for each in C# and VB.NET. You can also print the source listing or copy it to the clipboard for subsequent use.

Differences from the WebForms version:

  1. The winforms Chart control is inherited from System.Windows.Forms.userControl and you have access to all events,properties and methods of UserControl in addition to the full .netCHARTING object model.
  2. Width and Height properties are "int" type versus WebControl which are Unit type.
  3. HitTest method. This method accepts the X,Y position on the chart image and returns the corresponding object for that point of the Image. These are 3 overloaded methods for HitTest method:

    [C#]

    HitTestInfo  myObj =  HitTest(x,y);
    [Visual Basic]
HitTestInfo  myObj =  HitTest(x,y)
    x,y are int and represent the point you want to get the related object from.

    [C#]
HitTestInfo  myObj =  HitTest(myPoint);
    [Visual Basic]
HitTestInfo  myObj =  HitTest(myPoint)
    myPoint is "Point" type and represents the point you want to get the related object from.

    [C#]
HitTestInfo  myObj =  HitTest();
    [Visual Basic]
HitTestInfo  myObj =  HitTest()
    If you do not pass the cursor position, internally this method uses the position from the Chart control. This usage would be applicable when using the winforms control in a winforms project.

    Currently, the HitTestInfo Class has one property called "Object". It will hold the object clicked and can be used for drilldown or other advanced integration with the chart in a winforms environment.
  4. When you use Object.URL properties, such as Element.URL when you click on the Element, a new browser window will be launched with the URL value specified. URL target has no effect in a winforms environment.


Using With Visual Studio.net

Visual studio can be used as a development environment for projects using .netCHARTING. Below find step by step instructions for using the samples within an ASP.NET web application. Of course, you could use the sample directly just by running them through a web browser and edit the calling page directly in Visual studio instead which would require no additional setup outside of the regular install.

Installation Instructions:

  1. Create new project, ASP.NET Web Application.
  2. Copy the Database folder from the .netCHARTING bundle into your project root ( for example in c:\inetpub\wwwroot\webApplication)
  3. Copy dotnetCHARTING.dll to the bin folder within your web application (like you did for the database in step 2)
  4. Add a reference to dotnetCHARTING.dll under the References node in Solution Explorer.
  5. Select Customize Toolbox from Tools menu and then add the dll to Toolbox or right-click on the tool box > Add/Remove Items > .net tab > browse to the dll > click OK.
  6. Copy and Paste the code from any of the .netCHARTING samples included in the bundle to your aspx page (you can delete any default html code which has been created through Visual Studio .NET wizard)
  7. Create a Temp folder in the project path same as step 2 or 3 and modify the permissions to have write access (See installation for more information).
  8. Make sure the path for database is set correctly.
  9. When you start the project you should see a chart based on the sample code you added.

Copying the dotnetCHARTING.xml file to your bin folder will enable intellisense in visual studio.

Common Problems and Resolutions:

When I start the WebApplication from Visual Studio I get Empty page.
Cause: The database folder does not exist in you project folder.
When I start the WebApplication from Visual Studio I get "CreateControl: generic error occurred in GDI+".
Cause: the Temp folder does not exist or does not have Write permissions.
Error in reading Database
Cause: ConnectionString property is not pointing to right path for the database.
When I drag and drop Chart control from Toolbox to Form , I get "error in CreateChildControl"
Solution: Add a reference to dotnetCHARTING.dll and under the References node in Solution Explorer.
I do not see the Chart Control in Toolbox.
Solution: Select Customize Toolbox from Tools menu and then add the dll to Toolbox or right-click on the tool box > Add/Remove Items > .net tab > browse to the dll > click OK.

Design Time Support:
The Chart control can used in design time in Visual Studio .NET (or web matrix).
You can use this control in an ASP.NET web Application (not in desktop or winforms applications)
As with any other control first you should add it to the Toolbox as follows:

  1. From Tools menu option select "Customize Toolbox" then browse and select the dotnetCharting.dll assembly and click OK.
  2. You will now see the chart control listed in the toolboxTool
  3. You may now drag and drop the chart into the aspx page and use it.
  4. You can use the Properties browser to see all chart control properties, and any changes when made on any properties, related code will be generated in code behind file in InitializeComponent() method, you can also write your own code, overriding any properties in the Page_load section or any part of file as you please.

Note: Design time support implements automated code generation for the chart. If you are using VS.NET and do not want the design time code to generate there is a property in the Properties Browser, GenerateCode which you can set to false.


Visual Studio Help Integration

.netCHARTING supports dynamic help and IDE integrated documentation when working with Visual Studio .NET.

Installation Instructions

  1. Download the .netCHARTING Help for Visual Studio zip file (dncVShelp.zip) from http://www.dotnetcharting.com/documentation/v3_3/dncVShelp.zip.
  2. Unzip dncVShelp.zip to a permanent location of your choice, for example C:\Program Files\dncVShelp\
  3. Double-click on either 'Install for VS 2003' or 'Install for VS 2002'
    batch files depending on which visual studio version you're using.
  4. Double-click on the '.netCHARTING Help' shortcut from the install location provided in step 2 to confirm the help integration completed successfully.

    If visual studio does not show the .netCHARTING help topics in step 4 please complete the following additional steps:
  5. In Visual Studio, click on Tools > Options. Click on the Environment > Help node.
  6. In the 'Preferred Collection' drop down, select "Visual Studio .NET Combined Help Collection.

TIP: You can copy the .netCHARTING Help Shortcut from the dncSVhelp folder and place it on your desktop for quick access to .netCHARTING help documentation.

If you have any suggestions for improving the .netCHARTING documentation please email support@dotnetcharting.com


Using with Web Matrix

In order to add .netCHARTING to the Web Matrix toolbox, use the following instructions.

Instructions

  1. Select "Custom Controls" tab of the toolbox.
  2. Right-Click on the custom controls tab and select "Add Local Toolbox Components..."
  3. Click "Browse..."
  4. Navigate to the location of the dotnetcharting.dll file, select it and click ok.
  5. Finally click ok at the "Select Components" popup.
  6. When the "Install to GAC" popup appears, click no.


Upgrading

Website Version

Upgrading a website dll is a simple process.

  1. Copy the new dll into your bin folder overriding the previous version.

Server Version

  1. Delete the previous installation
  2. Follow the steps in the install.txt file to re-install the new dll.

In Visual Studio

  1. Delete the dotnetCHARTING reference in your visual studio project.
  2. Add a new reference pointing to the new dll.
  3. If you have the component in the toolbox.
    1. Remove it by right-clicking > Delete
    2. Add it again, right click on the toolbox > Add/Remove Items > .net Framework Components tab > Browse > find the new dll.
    3. Click OK.
  4. Recompile project.
    5. For troubleshooting issues, please see the Knowledge Base.
See Also

Upgrade Terms: Upgrades KB Article


Chart Tutorials

The following tutorials will get you up to speed using your data with .netCHARTING.

Dissecting the Chart

  • Labels
    Shows what properties chart labels can be controlled with.
  • Lines
    Shows what properties chart lines can be controlled with.

Working with

  • Colors
    Demonstrates how colors are created.
  • Fonts
    Demonstrates how fonts are created.


Using Colors

A color can be set simply with Color.Name e.g. Color.Red or Color.Blue.
Complete list of color names.

More advanced color creation using RGB, alpha and web color settings

Creates a Color structure from the specified 8-bit color values (red, green, and blue). The alpha value is implicitly 255 (no transparency).

[C#] Color myColor = Color.FromArgb(0, 255,125);

[Visual Basic]
Dim myColor As Color = Color.FromArgb(0, 255,125)

Creates a Color structure from the four ARGB component (alpha, red, green, and blue). Alpha is also known as transparency where 255 is totally solid and 0 is totally transparent.

[C#]
Color myColor = FromArgb(120, 0, 255,125);

[Visual Basic]
Dim myColor As Color = FromArgb(120, 0, 255,125)

Creates a Color from a 32-bit ARGB value. (alpha, red, green, and blue)

[C#]
Color myColor = Color.FromArgb(0x78FF0000);

[Visual Basic]
Dim myColor As Color = Color.FromArgb(&H78FF0000)

Creates a Color from the specified Color Name, but with the new specified alpha value, valid alpha values are between 0 through 255.

[C#]
Color myColor = Color.FromArgb(125,Color.Red);

[Visual Basic]
Dim myColor As Color = Color.FromArgb(125,Color.Red)

For converting a web color:
If the color is "bgcolor="#388B7E" , replace # with 0x(for csharp) or &H (for visual basic), and add an alpha value between 0-7F after that, then add the rest. (0x7F388B7E or &H7F388B7E)

[C#]
Color myColor = Color.FromArgb(0x7F388B7E);

[Visual Basic]
Dim myColor As Color = Color.FromArgb(&H7F388B7E)

For advanced information visit: .NET framework Color structure.


Working with Fonts

Initializes a new Font object using a specified size

[C#]
Font myFont = new Font("Arial", 10);
[Visual Basic]
Dim myFont As New Font("Arial", 10)

Initializes a new Font object using a specified size and style

[C#]
Font myFont = new Font("Arial", 10, FontStyle.Bold);
[Visual Basic]
Dim myFont As New Font("Arial", 10, FontStyle.Bold)

Available Font Styles:

  • FontStyle.Bold
  • FontStyle.Italic
  • FontStyle.Regular
  • FontStyle.Strikeout
  • FontStyle.Underline

    For advanced information visit .NET Framework Font class


Labels

Click on any property name for additional information.
See Also

Reference: Tokens Reference


Lines

Click on any property name for additional information.


Data Tutorials

The following tutorials will get you up to speed using your data with .netCHARTING.

The Basics

  • Data Objects
    Describes the the classes which contain data consumed by the chart.
  • Data Manipulation
    Shows how easily data can be manipulated using the .netCHARTING data model.
  • Analysis Engine
    Provides Statistical Calculations and Financial Indicators functionality.

Data acquisition

  • Connecting to data sources
    Shows how to use different sources of data.
  • Getting Data
    Index Page
    • Simple Queries
      How to use queries to retrieve chart ready data.
    • Getting Multiple Series
      How to acquire multiple series from a database.
  • Data field mapping
    Database column to chart data mapping.
  • Custom Attributes
    Bring additional data into chart elements.
  • Data engine features
    More data engine features explained.


Connecting to Data

Introduction

.netCHARTING provides the DataEngine object which can be used to automatically obtain data from a variety of data sources. The DataEngine returns a SeriesCollection object which contains data formatted appropriately to be consumed by the chart.

The DataEngine object is instantiated like so:
[C#]
DataEngine de = new DataEngine();

[Visual Basic]
Dim de As New DataEngine()

Using data sources.

The DataEngine object internally connects to supported data sources when a ConnectionString is specified. Supported data sources include Access, SQL, Excel, and XML.

Unsupported data sources can also be utilized by supplying the DataEngine with a data object such as a DataTable.

When connecting to supported data sources data is queried by setting the SqlStatement property of the DataEngine.

Examples

There are different methods of connecting to specific data sources. The following section demonstrates how each supported data source can be utilized.

Access Database

[C#]
de.ConnectionString = @"Provider=Microsoft.Jet.OLEDB.4.0;user id=;password=
                        ; data source=" + Server.MapPath("db.mdb");
// A connection string shortcut for access databases is also available.
de.ConnectionString = "db.mdb";
de.SqlStatement = @"SELECT OrderDate,Sum(Total) FROM Orders ";

[Visual Basic]
de.ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;user id=;password=;"_
                        & "data source=" & Server.MapPath("db.mdb")
' A connection string shortcut for access databases is also available.
de.ConnectionString = "db.mdb"
de.SqlStatement = "SELECT OrderDate,Sum(Total) FROM Orders "

SQL Database

[C#]
de.ConnectionString = @"server=server name or IP;uid=username;pwd=password;database=database name";
de.SqlStatement = @"SELECT OrderDate,Sum(Total) FROM Orders ";

[Visual Basic]
de.ConnectionString = "server=server name or IP;uid=username;pwd=password;database=database name"
de.SqlStatement = "SELECT OrderDate,Sum(Total) FROM Orders "

Stored Procedure

[C#]
de.StoredProcedure = "myProcedure";
de.AddParameter("@STARTDATE","3/10/02 12:00:00 AM",FieldType.Date);

[Visual Basic]
de.StoredProcedure = "myProcedure"
de.AddParameter("@STARTDATE","3/10/02 12:00:00 AM",FieldType.Date)

The AddParameter method is optionally used in conjunction with the StoredProcedure property to specify any number of parameters for the stored procedure. The following parameter types are supported:

  • Text
  • Date
  • Number
  • LongNumber
  • Currency
  • Double

Excel Files

[C#]
de.ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;data source= " + Server.MapPath("myData.xls")
                        + ";Extended Properties=\"Excel 8.0;\"";
de.SqlStatement= @"Select Periods,Sales from [Yearly Summary$]";

[Visual Basic]
de.ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;data source=" & Server.MapPath("myData.xls") _
                        & ";Extended Properties=\"Excel 8.0;\""
de.SqlStatement= "Select Periods,Sales from [Yearly Summary$]"

XML Files

Xml files can be used as data sources by setting the Data property of the data engine like so:

[C#]
de.Data = "Orders.xml";

[Visual Basic]
de.Data = "Orders.xml"

Other Sources

Oracle, mySQL, Firebird and other unsupported sources

.netCHARTING can also parse data objects generated from any data source in ADO.NET by using the DataEngine's Data property. If you can access your data in your .NET application you can chart it with .netCHARTING in a few simple lines of code.

Supported Data Objects

  • DataSet
  • DataTable
  • DataView
  • OleDbDataReader
  • SqlDataReader
  • IDataReader
  • String (xml file name)
  • XmlDocument

Example:

[C#]

de.Data = myDataTable;

[Visual Basic]

de.Data = myDataTable


Data Model

.netCHARTING Data Classes

The .netCHARTING data model consists of elements which collectively become a series which can be added to a SeriesCollection.

Show See Illustration

Data Class

Description

Element

Represents an element on the chart and facilitates the following.

  • Provides properties to hold different types of data such as y value, x value, % completed for Gantt charts and many more. Below Element.YValue is demonstrated.
  • Controls all other variables concerning a single element such as it's label color, marker type etc.
Series

Utilizes the ElementCollection class to hold a set of elements and facilitates the following.

  • Provides a mechanism for setting default properties of all elements within it.
  • Controls all series specific properties such as it's LegendEntry or 2D line dash style (if applicable).
  • Derives an element based on a Calculation which is performed on the elements within it.
  • Provides data manipulation methods such as sorting and trimming of it's elements.
SeriesCollection

Contains a collection of series and facilitates the following.

  • Derives series based on a Calculation which is performed on all the series within it.
  • Provides data manipulation methods such as Transpose.
ElementCollection Used by the Series class to hold a collection of elements.

Using Data Classes

The following example creates a SeriesCollection containing one Series which contains a single Element using the following steps.

  1. Instantiates an element and sets it's properties.
  2. Instantiates a series and adds the element to it.
  3. Instantiates a SeriesCollection and adds the series to it.
[C#]
Element e = new Element();    // Instantiate the element
e.Name = "Element 1";      // Name it
e.YValue = 10;             // Set the y value
Series s = new Series();     // Instantiate the series
s.Name = "Series 1";       // Name it
s.Elements.Add(e);         // Add element e to series s.
SeriesCollection sc = new SeriesCollection(); // Instantiate a series collection
sc.Add(s);                 // Add series s to the series collection sc.

//The sc object now contains data we can chart which we add here.

Chart.SeriesCollection.Add(sc);

[Visual Basic]
Dim e As New Element()    ' Instantiate the element
e.Name = "Element 1"      ' Name it
e.YValue = 10             ' Set the y value
Dim s As New Series()     ' Instantiate the series
s.Name = "Series 1"       ' Name it
s.Elements.Add(e)         ' Add element e to series s.
Dim sc As New SeriesCollection() ' Instantiate a series collection
sc.Add(s)                 ' Add series s to the series collection sc.

'The sc object now contains data we can chart which we add here.

Chart.SeriesCollection.Add(sc)

Shortcuts

.netCHARTING provides many shortcuts which can make adding data easier. The previous example can also be achieved using the following shortcuts.

Using Chart.Series shortcut.

[C#]
Element e = new Element();
e.Name = "Element 1";
e.YValue = 10;
Chart.Series.Add(e);
Chart.SeriesCollection.Add(); // Not passing parameters will add the contents of Chart.Series to the chart.

[Visual Basic]
Dim e As New Element()
e.Name = "Element 1"
e.YValue = 10
Chart.Series.Add(e)
Chart.SeriesCollection.Add() ' Not passing parameters will add the contents of Chart.Series to the chart.

Using the Chart.Element shortcut.

[C#]
Chart.Series.Element.YValue = 10;
Chart.Series.Element.Name = "Element 1";
Chart.Series.Elements.Add();
Chart.SeriesCollection.Add();

[Visual Basic]
Chart.Series.Element.YValue = 10
Chart.Series.Element.Name = "Element 1"
Chart.Series.Elements.Add()
Chart.SeriesCollection.Add()

Using all the shortcuts allows us to reduce the amount of lines necessary to achieve the same result from 8 to 4. The down side is that after the data is added using these shortcuts, it cannot be retrieved for further manipulation.

Take it to the next step

It is still possible to reduce the code even further using element constructors.

[C#]
Chart.Series.Add(new Element("Element1",10));
Chart.SeriesCollection.Add();

[Visual Basic]
Chart.Series.Add(New Element("Element1",10))
Chart.SeriesCollection.Add()

Now we took it from 8 lines to 2.


Data Manipulation

.netCHARTING facilitates numerous calculations that can be performed on your data. These calculations can be used to

  • Derive an element from a series
  • Derive a series from a SeriesCollection
  • The results can also be used in text reports or as further chart data.

Series.Calculate

First we will construct a simple series with some data we can manipulate.
[C#]
Series s = new Series();
s.Elements.Add(new Element("e 1",5));
s.Elements.Add(new Element("e 2",15));
s.Elements.Add(new Element("e 3",23));
s.Elements.Add(new Element("e 4",13));
s.Elements.Add(new Element("e 5",34));

[Visual Basic]
Dim s As New Series();
s.Elements.Add(new Element("e 1",5))
s.Elements.Add(new Element("e 2",15))
s.Elements.Add(new Element("e 3",23))
s.Elements.Add(new Element("e 4",13))
s.Elements.Add(new Element("e 5",34))

With our series populated with data, we can derive calculations using the Series.Calculate method which returns a single element.

[C#]
Element e = s.Calculate("sum",Calculation.Sum);

[Visual Basic]
Dim e As Element = s.Calculate("sum",Calculation.Sum)

The element e now has yValue of 91 which is the sum of all the element yValues in series s. If the elements of series s had other values such as BubbleSize, the resulting e.BubbleSize would contain the sum of those as well.

Series.Sort

Elements within a series can be sorted by any value in ascending or descending order.

[C#]
// Sort the series by name
s.Sort(ElementValue.Name, "DESC");
// Sort the series by YValue
s.Sort(ElementValue.YValue, "DESC");

[Visual Basic]
' Sort the series by name
s.Sort(ElementValue.Name, "DESC")
' Sort the series by YValue
s.Sort(ElementValue.YValue, "DESC")

Series.Trim

Elements with values that are within a given range can be trimmed form a series using the Series.Trim method.

[C#]
// Trim elements with y values between 15 and 20.
s.Trim(ElementValue.YValue, 15,20);

[Visual Basic]
' Trim elements with y values between 15 and 20.
s.Trim(ElementValue.YValue, 15,20)

Samples:

  • features/seriesSort.aspx
  • features/calendarPattern.aspx

SeriesCollection.Sort

Series in a SeriesCollection object can be sorted based on their respective element's values.

[C#]
// Consider a SeriesCollection sc that has multiple series, each with several elements.
// Sort the series by name.
sc.Sort(ElementValue.Name,"ASC");
// Sort the series by the sum of their element's y value.
sc.Sort(ElementValue.YValue,"ASC");

[Visual Basic]
' Consider a SeriesCollection sc that has multiple series, each with several elements.
' Sort the series by name.
sc.Sort(ElementValue.Name,"ASC")
' Sort the series by the sum of their element's y value.
sc.Sort(ElementValue.YValue,"ASC")

SeriesCollection.Calculate

We will first create another series and add it to 'sc' so that we have 2 series available for our calculations.

[C#]
Series s2 = new Series();
s2.Elements.Add(new Element("e 1",2));
s2.Elements.Add(new Element("e 2",45));
s2.Elements.Add(new Element("e 3",23));
s2.Elements.Add(new Element("e 4",41));
s2.Elements.Add(new Element("e 5",24));
SeriesCollection sc = new SeriesCollection();
sc.Add(s);
sc.Add(s2);

[Visual Basic]
Dim s2 As New Series();
s2.Elements.Add(new Element("e 1",2))
s2.Elements.Add(new Element("e 2",45))
s2.Elements.Add(new Element("e 3",23))
s2.Elements.Add(new Element("e 4",41))
s2.Elements.Add(new Element("e 5",24))
Dim sc As New SeriesCollection();
sc.Add(s)
sc.Add(s2)

Now we will use the SeriesCollection.Calculate method which returns a single series.

 [C#]
Series s3 = sc.Calculate("Sum Series",Calculation.Sum);
sc.Add(s3);

[Visual Basic]
Dim s3 As Series = sc.Calculate("Sum Series",Calculation.Sum)
sc.Add(s3)

Our derived series now contains the sums of each 'element group' or 'elements with the same name'. The values of series s3 will be '7,60,46,54,58'.

Calculation Shortcuts

You can also use shortcuts to add calculated series to the chart.
[C#]
Chart.SeriesCollection.Add(s);
Chart.SeriesCollection.Add(s2);
Chart.SeriesCollection.Add(Calculation.Sum); // This will add a sum series to the chart.

[Visual Basic]
Chart.SeriesCollection.Add(s)
Chart.SeriesCollection.Add(s2)
Chart.SeriesCollection.Add(Calculation.Sum) ' This will add a sum series to the chart.

Series and element operators ( + - * / )

Series and elements can be manipulated with operators when using c#. For example, the previous code snippet can also be achieved in this way:

[C#]

Chart.SeriesCollection.Add(s);
Chart.SeriesCollection.Add(s2);
Chart.SeriesCollection.Add(s1+s2); // This will add a sum series to the chart.

[Visual Basic]
' Visual Basic operators will be available with .net framework 2.0, however
' methods are available for this functionality.

Chart.SeriesCollection.Add(s)
Chart.SeriesCollection.Add(s2)
Chart.SeriesCollection.Add(s1.Add(s2)) // This will add a sum series to the chart.

The operators can also be used with numbers. Let's say you have a chart that shows the GDP of countries. You can do the following: mySeries *= .000000001; If the value of an element in this series was 7,000,000,000 (seven billon), after this operation the value will be 7. On the axis label we can then say 'GDP (Billions)'. Operators are also useful in situations that require complex manipulation of data such as rates.

Manually iterating elements

We can also iterate through our series collection to do custom manipulation. The following code snippet will test each element and if the value is over 35, the color of that element will become red.

[C#]
foreach(Series mySeries in sc)
  foreach(Element myElement in mySeries.Elements)
      if(myElement.YValue > 35)
          myElement.Color = Color.Red;
[Visual Basic]
Dim mySeries As Series
Dim myElement As Element
For Each mySeries In sc
   For Each myElement in mySeries.Elements
      If myElement.YValue > 35 Then
         myElement.Color = Color.Red
      End If
   Next myElement
Next mySeries

See Also

Tutorials: Analysis Engine


Analysis Engine

Introduction

The .netCHARTING analysis engine provides many statistical calculations and financial indicators allowing quick and accurate analysis of your data.

Getting Data

The first step is to get a series of data to analyze. Please see the following tutorials as a reference on data acquisition.

  • Data Tutorials
  • Financial Charts

Calculated series and financial indicators often use multiple chart areas. For more info, see:

  • Multiple Chart Areas

Analysis Engine

Three classes provide the methods used for analysis.

  • FinancialEngine
  • StatisticalEngine
  • ForecastEngine

The following code snippet demonstrates calculating the mean of a series collection.

[C#]

...
SeriesCollection mySeries = ...; // Original seriesCollection
Series resultSeries = StatisticalEngine.Mean(mySeries);

Chart.SeriesCollection.Add(resultSeries);
[Visual Basic]

...
mySeries = ...(seriesCollection)... ' Original seriesCollection
Series resultSeries = StatisticalEngine.Mean(mySeries)

Chart.SeriesCollection.Add(resultSeries)
Many samples are available under the Features / Analysis Engine section that demonstrate this functionality.

ForecastEngine

The forecast engine contains a set of simple methods to perform common forecasting operations. However, the class also contains an advanced set of methods for users familiar with the mathematical formulas.

IndicatorOptions

Both analysis classes contain a static Options class that provides additional options for use with the analysis engine.

  • PopulateSubValues
    When a series is calculated down to a single element, the element values of the original series can be included in the resulting element as SubValues.
    • A similar feature is also available in the dataEngine: PopulateDateGroupingSubValues Property
  • MatchColors
    Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
[C#]

...
SeriesCollection mySeries = ...; // Original seriesCollection

StatisticalEngine.Options.PopulateSubValues = true;
Element resultElement = StatisticalEngine.Mean(mySeries);

Chart.SeriesCollection.Add(resultElement);
[Visual Basic]

...
mySeries = ... // Original series

StatisticalEngine.IndicatorOptions.PopulateSubValues = True
Element resultElement = StatisticalEngine.Mean(mySeries)

Chart.SeriesCollection.Add(resultSeries)

See Also

Data Tutorials: Data Manipulation

SubValues: ErrorBars and other SubValues


Getting Data

  • Using Query Strings
    How to use queries to retrieve chart ready data.
  • Getting Multiple Series
    How to acquire multiple series from a database.


Using Query Strings

This tutorial describes how database queries can be used to populate chart series and elements.

Simple chart

By default, the first column returned by your query is mapped on the x axis and the second column is mapped onto the y axis.

Consider:
'SELECT name, age FROM Employees'

This query will create a chart where the names are on the x axis, ages on the y axis, and might look something like this:

Figure 1. Using a simple query

Multiple series from a single query

Returning a third column splits the data into series. This feature is referred to as 'SplitBy'.

Consider:
'SELECT name, age, division FROM Employees GROUP BY division'

This time 3 columns are returned and rows are grouped by the division column. Because the third column is supplied, two series are created, one for each unique value of the division column. The resulting chart will look something like this:

Figure 2. Multiple series using a query
Another characteristic of the splitBy functionality is the aggregation of grouped values. For this example consider a database table with 3 fields [ Date, Items_Sold, Sales_Rep ] . Each day an entry is added with the number of items sold for each sales rep. In our database there are two and they have been selling from January - May.
Consider:
'SELECT Date, Items_Sold, Sales_Rep FROM Sales GroupBy Sales_Rep'

In this case the sales of each representative are aggregated for each month.
* This sample also uses the dategrouping setting of (TimeInterval.Month), see dataEngine for more info.

Figure 3. Multiple series with date grouping.

Count occurrences of a fields value.

For this case, let's say we have a table which is a log of logins into your main company server. The table contains a 'date' column and a 'name' column and each row is a login entry. To show the number of logins for each user we can use the following query:

Query:
'SELECT name, 1 FROM Orders GROUP BY name;'

This will create a table with a name and a value (1) for each login. This method takes advantage of the DataEngine's aggregation feature and the second column will be summed.

Figure 4. Counting occurences.


Getting Multiple Series

Using Query Strings (Series based on field)

To get multiple series automatically using the data engine you must specify a third column in the query string. This feature is referred to as 'SplitBy'.

Consider:

'SELECT name, age, division FROM Employees GROUP BY division'

Three columns are returned and rows are grouped by the division column. Because the third column is supplied, two series are created, one for each unique value of the division column. The resulting chart will look something like this:

Figure 1: Returning a third column splits the data into series.

Using a single SQL Statement ( Series Per Column )

Multiple series can be automatically generated for each column using multiple YValue tokens in the DataFields property.

For example, consider the following code:

[C#]

myDataEngine.SQLStatement = "SELECT myDate, GroupA, GroupB, GroupC FROM Stats";
myDataEngine.DataFields = "XValue=myDate,YValue=GroupA,YValue=GroupB,YValue=GroupC";
[Visual Basic]

myDataEngine.SQLStatement = "SELECT myDate, GroupA, GroupB, GroupC FROM Stats"
myDataEngine.DataFields = "XValue=myDate,YValue=GroupA,YValue=GroupB,YValue=GroupC"

Assigning Series Names
This will generate three series, all of which will use the myDate column for the x values and their individual groupX columns for y values. Custom series names can also be specified in the data fields. The following code does the same as the above but will assign custom series names.

[C#]

myDataEngine.SQLStatement = "SELECT myDate, GroupA, GroupB, GroupC FROM Stats";
myDataEngine.DataFields = "XValue=myDate,YValue=GroupA=Group Alpha,YValue=GroupB=Group Beta,YValue=GroupC=Group Gamma";
[Visual Basic]

myDataEngine.SQLStatement = "SELECT myDate, GroupA, GroupB, GroupC FROM Stats"
myDataEngine.DataFields = "XValue=myDate,YValue=GroupA=Group Alpha,YValue=GroupB=Group Beta,YValue=GroupC=Group Gamma"

Using Data Fields ( Series Per Column )

If you are getting many columns from the database and would like to specify which column to use as the splitBy column you can do so using the DataFields property.
[C#]
<div>myDataEngine.DataFields = "Name=name,YValue=age,SplitBy=Division";

[Visual Basic]
<div>myDataEngine.DataFields = "Name=name,YValue=age,SplitBy=Division";</div>

Query Database Multiple Times

Another way to do this is to query your database separately for each series.

[C#]

DataEngine de = new DataEngine(connectionString);
de.SqlStatement = "SELECT name, dataOne FROM table";
Chart.SeriesCollection.Add(de.GetSeries());
de.SqlStatement = "SELECT name, dataTwo FROM table";
Chart.SeriesCollection.Add(de.GetSeries());

[Visual Basic]

Dim de As New DataEngine(connectionString)
de.SqlStatement = "SELECT name, dataOne FROM table"
Chart.SeriesCollection.Add(de.GetSeries())
de.SqlStatement = "SELECT name, dataTwo FROM table"
Chart.SeriesCollection.Add(de.GetSeries())

Avoid Querying Multiple Times

If querying the database multiple times is not desirable the same can be accomplished by using a DataTable.

[C#]

DataEngine de = new DataEngine();
DataTable dt = new DataTable();
// Populate the datatable from your database.
dt = (...);
de.Data = dt;
de.DataFields = "YAxis=name,XAxis=DataOne";
Chart.SeriesCollection.Add(de.GetSeries());
de.DataFields = "YAxis=name,XAxis=DataTwo";
Chart.SeriesCollection.Add(de.GetSeries());

[Visual Basic]

Dim de As New DataEngine()
Dim dt As New DataTable()
' Populate the datatable from your database.
dt = (...)
de.Data = dt
de.DataFields = "YAxis=name,XAxis=DataOne"
Chart.SeriesCollection.Add(de.GetSeries())
de.DataFields = "YAxis=name,XAxis=DataTwo"
Chart.SeriesCollection.Add(de.GetSeries())


Data Field Mapping

Introduction

Data fields are a very useful tool when translating your database structure to chart data. It allows you to map which column of your data table or query populates a given element property.

Show See Illustration

For example, if you have a column which represents certain information you want to use as a tool tip, it can easily be mapped using data fields. The 'DataFields' property of DataEngine and Chart.Series is a string which can be supplied as a comma delimited list of element property, to data column, relationships.

For example, in the following DataFields string

"YValue=Cost,Name=Brand,ToolTip=Description"; Cost, Brand, and Description are all columns in a data table. YValue, Name, and ToolTip are element values.

Custom tokens can also be used to populate elements with additional database columns which can be used by element tool tips, urls, within labels and so on.

The following table outlines the available element values and shortcuts which can be mapped to your data columns.

Token Name | Description
Name | Sets Element.Name
Yvalue | Sets Element.YValue or Element.YDateTime depending on the column data type.
YValueStart | Sets Element.XValue or Element.XDateTime depending on the column data type.
Xvalue | Sets Element.XValue or Element.XDateTime depending on the column data type.
XValueStart | Sets Element.XValueStart or Element.XDateTimeStart depending on the column data type.
BubbleSize | Sets Element.BubbleSize
Complete | Sets Element.Complete
Open | Sets Element.Open
Close | Sets Element.Close
High | Sets Element.High
Low | Sets Element.Low
Volume | Sets Element.Volume
tooltip | Sets Element.ToolTip
urltarget | Sets Element.URLTarget
Url | Sets Element.URL
LabelTemplate | Sets Element..LabelTample

Shortcuts and special functionality tokens

Token Name | Description
Bubble | Sets Element.BubbleSize
price | Sets Element.Close
Ganttcomplete | Sets Element.Complete
Ganttname | Sets Element.Name
Ganttenddate | Sets Element.YDateTime
Ganttstartdate | Sets Element.YDateTimeStart
Ganttend | Sets Element.YValue or Element.YDateTime if DateTime data type.
Ganttstart | Sets Element.YValueStart or Element.YStartDateTime if DateTime data type.
Splitby | Sets Element.SplitBy (Special)
Yaxis | Sets the element values associated with the y axis of the chart in use. ChartType.ComboHorizaontal sets Element.Name. All Others set Element.Yvalue, if column type is 'DateTime' Element.YDateTime will be set instead.
Xaxis | Sets the element values associated with the x axis of the chart in use. ChartType.Combo Horizontal sets Element.Yvalue, if column type is 'DateTime' Element.YDateTime will be set instead.. ChartType.Scatter sets Element.Xvalue, if column type is 'DateTime' Element.XDateTime will be set instead. All Other sets Element.Name. and/or if date it sets Element.XDateTime.

Using Data Fields

"[Token]=[Data Column],..."

Sample Data

This data will be used to demonstrate how different chart types can be achieved by mapping the appropriate element values.
Table 1 | Column | (string) Name | (double) StartValue | (double) EndValue | (double) Completed
 | Sample Data | Chris | 3 | 15 | 25
Table 2 | Column | (string) Name | (DateTime) StartValue | (DateTime) EndValue | (double) Completed
 | Sample Data | Chris | 3/5/2003 | 8/10/2003 | 25
Table 3 | Column | (string) Name | (double) Cost | (double) TopSpeed | (double) HorsePower
 | Sample Data | Chevy | 22,000 | 120 | 185
Table 4 | Column | (string) Stock | (double) Close | (double) Open | (double) Low | (double) High | (DateTime) Date
 | Sample Data | MSFT | 176 | 120 | 100 | 185 | 11/12/2003

The above tables are color coded for reference to which table the column name refers. If there is more than one example in sub sections such as 'Simple Graph', they are equivalent.

ChartType.Combo & ChartType.ComboSideBySide
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),splitBy=(3rdColumn)"
Applicable tokens | Element Data Properties YValue, YValueStart, Name, Complete, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, SplitBy Gantt Shortcuts GanttName, GanttStart, GanttEnd, GanttComplete
Examples
Simple Graph | "xAxis=Name,yAxis=EndValue" "Name=Name,yValue=EndValue"
Range (Gantt) Columns | "xAxis=Name,yValue=EndValue,yValueStart=StartValue"
Range columns /w Complete indicator | "xAxis=Name,yValue=EndValue,yValueStart=StartValue ,Complete=Completed"
Date Range columns /w complete indicator. | "xAxis=Name,yValue=EndValue,yValueStart=StartValue ,Complete=Completed"
NOTE: For this chart type "xAxis=Name" is the same as "Name=Name".

ChartType.Horizontal
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),splitBy=(3rdColumn)"
Applicable tokens | Element Data Properties YValue, YValueStart, Name, Complete, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, SplitBy Gantt Shortcuts GanttName, GanttStart, GanttEnd, GanttComplete
Examples
Simple Graph | "xAxis=Name,yAxis=EndValue" "Name=Name,yValue=EndValue"
Range (Gantt) Columns | "xAxis=Name,yValue=EndValue,yValueStart=StartValue"
Range columns /w Complete indicator | "xAxis=Name,yValue=EndValue,yValueStart=StartValue ,Complete=Completed"
Date Range columns /w complete indicator. | "xAxis=Name,yValue=EndValue,yValueStart=StartValue ,Complete=Completed"
NOTE: For this chart type "xAxis=Name" is the same as "Name=Name".

ChartType.Gantt
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "yValueStart=(1stColumn),yValue=(2stColumn)" "yValueStart=(1stColumn),yValue=(2stColumn),Name=(3rdColumn)" "yValueStart=(1stColumn),yValue=(2ndColumn),Name=(3rdColumn),Complete=(4thColumn)"
Applicable tokens | Element Data Properties YValue, YValueStart, Name, Complete, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, SplitBy Gantt Shortcuts GanttName, GanttStart, GanttEnd, GanttComplete
Examples
Range (Gantt) Bars | "yValueStart=StartValue,yValue=EndValue"
Range Columns /w Complete | "yValueStart=StartValue,yValue=EndValue, Name=Name,Complete=Completed"
Date Range Columns /w Complete | "yValueStart=StartValue,yValue=EndValue,Name=Name,Complete=Completed"

ChartType.Radar & ChartType.Pie
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),splitBy=(3rdColumn)"
Applicable tokens | Element Data Properties YValue, Name, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, SplitBy
Examples
Simple Chart | "yAxis=EndValue,xAxis=Name" Note: Though there are no x and y axes in a pie chart the fields are mapped like so: "yValue=EndValue,Name=Name" Note: The radar graph has both x and y axes.

ChartType.Scatter
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),splitBy=(3rdColumn)"
Applicable tokens | Element Data Properties YValue, XValue, Name, Complete, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, SplitBy
Examples
Simple Scatter Chart | "xAxis=HorsePower,yAxis=TopSpeed" "xValue=HorsePower,yValue=TopSpeed"

ChartType.Bubble
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),BubbleSize=(3rdColumn)"
Applicable tokens | Element Data Properties YValue, XValue, BubbleSize, Name, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, Bubble
Examples
Simple Scatter Chart | "xAxis=HorsePower,yAxis=TopSpeed,BubbleSize=Cost" "xValue=HorsePower,yValue=TopSpeed,Bubble=Cost"

ChartType.Financial
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),Volume=(3rdColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),Volume=(3rdColumn),SplitBy=(3thColumn)"
Applicable tokens | Element Data Properties Open, Close, High, Low, Volume, Name, Complete, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, SplitBy, Price
Examples
HLC Chart | "xAxis=Date,High=High,Low=Low,Price=Close"


Custom Data Attributes

Custom element attributes.

Additional information stored in databases can be extracted and used in a chart to provide further information in a tool tip, an element's label, within the element's hot spot URL, and any other related text strings.

Extracting from a database

Extracting attributes from a database can be accomplished with a single line of code using the DataFields property of a DataEngine object..

Assume the following database columns:

  • EmployeeID
  • FullName
  • Department
  • EmailAddress
  • PhoneNumber
  • AveragePerformance

Using this database we will create a chart that shows each employee's name on the x axis and they're average performance on the y axis. When we mouse over a column in the chart we want to see the employee's ID, department, and phone number. When we click a given column we want to send the employee an email.

The first step is to specify the DataFields property.

[C#]
DataEngine de = new DataEngine();
de.ConnectionString = "...";
de.SqlStatement =  "SELECT * FROM
myTable";  de.DataFields="xAxis=FullName,yAxis=AveragePerformance,id=EmployeeID,"
 + "department=Department,email=EmailAddress,phone=PhoneNumber";
[Visual Basic]
Dim de As New DataEngine()
de.ConnectionString = "..."
de.SqlStatement =  "SELECT * FROM
myTable"  de.DataFields="xAxis=FullName,yAxis=AveragePerformance,id=EmployeeID,"_
 & "department=Department,email=EmailAddress,phone=PhoneNumber"

The next step is to specify a template for the element's tooltip and url.

[C#]
Chart.DefaultSeries.DefaultElement.ToolTip = "ID: %id \n Department: %department \n Phone Number: %phone";
Chart.DefaultSeries.DefaultElement.URL = "mailto:%email";

[Visual Basic]
Chart.DefaultSeries.DefaultElement.ToolTip = "ID: %id " & vbCrLf &
" Department: %department " & vbCrLf & " Phone Number: %phone"
Chart.DefaultSeries.DefaultElement.URL = "mailto:%email"

This complex and highly functional chart is now ready.

Adding manually

Element attributes can be populated manually using the following method.

[C#]
Element e = new Element();
e.Name = "myElement";
e.YValue = 15;
e.CustomAttributes["Phone"] = "555-8593";
e.CustomAttributes["Department"] = "Marketing";

[Visual Basic]
Dim e As New Element()
e.Name = "myElement"
e.YValue = 15
e.CustomAttributes["Phone"] = "555-8593"
e.CustomAttributes["Department"] = "Marketing"

Series Level attributes

Attributes can be added at the series level to specify information common to all elements. These can be used in legend entry labels, legend entry tool tips and URLs.

Let's generate a SeriesCollection using the data engine object from the above example but we will modify it to only extract elements from a specific department.

[C#]
de.SqlStatement = "SELECT * FROM myTable WHERE department = "marketing";
SeriesCollection sc = de.GetSeries();
// The above generated 1 series with a number of employee elements.
// Now we can add some attributes for this specific to the marketing department.
sc[0].Name = "Marketing";
sc[0].DefaultElement.CustomAttributes["DepartmentPhoneNumber"] = "555-2414";
sc[0].DefaultElement.CustomAttributes["DepartmentManagerName"] = "555-2414";
sc[0].DefaultElement.CustomAttributes["DepartmentAddress"] = "555-2414";
[Visual Basic]
de.SqlStatement = "SELECT * FROM myTable WHERE department = "marketing"
Dim sc As SeriesCollection
sc = de.GetSeries();
' The above generated 1 series with a number of employee elements.
' Now we can add some attributes for this specific to the marketing department.
sc(0).Name = "Marketing"
sc(0).DefaultElement.CustomAttributes("DepartmentPhoneNumber") = "555-2414"
sc(0).DefaultElement.CustomAttributes("DepartmentManagerName") = "555-2414"
sc(0).DefaultElement.CustomAttributes("DepartmentAddress") = "555-2414"

The series now has additional information stored. Let's use it in the series' legend entry tool tip.

[C#]
Chart.DefaultSeries.LegendEntry.ToolTip = "Manager: %DepartmentManager \n "
                   + "Phone: %DepartmentPhoneNumber \n Address: %DepartmentAddress";
// Elements can also use the series level attributes
Chart.DefaultSeries.DefaultElement.ToolTip = "%Name \n Phone #: %phone \n "
 + "Department Phone #: %DepartmentPhoneNumber";
[Visual Basic]
Chart.DefaultSeries.LegendEntry.ToolTip = "Manager: %DepartmentManager \r "_
                   & "Phone: %DepartmentPhoneNumber " & vbCrLf & " Address: %DepartmentAddress";
' Elements can also use the series level attributes
Chart.DefaultSeries.DefaultElement.ToolTip = "%Name " & vbCrLf & " Phone #:  %phone "_
 & vbCrLf & " " & "Department Phone #: %DepartmentPhoneNumber";

The above may tool tips may look like this:

John Doe
Phone #: 555-5426
Department Phone #: 555-1349

Sample: features/customAttributes.aspx


Data Engine

Data Engine

The DataEngine object connects to databases or consumes data objects such as a 'DataTable' and converts them to a SeriesCollection which can then be manipulated and used to generate a chart. The DataEngine offers many data manipulation features saving countless hours of development, particularly for date specific aggregation.

We encourage you to review the following tutorials before working with the DataEngine:

  • Connecting to Data
  • Using DataFields

The basic concept of using the data engine is to specify a database, connection string and retrieve the SeriesCollection it generates. A basic example:

[C#]

DataEngine de = new DataEngine(connectionString,queryString);
SeriesCollection mySC = de.GetSeries();
[Visual Basic]

Dim de As New DataEngine(connectionString,queryString)
SeriesCollection mySC = de.GetSeries()

Filtering out date ranges

When specifying a start and end date in a database query, the following method should be used.

[C#]
DataEngine de = new DataEngine();     // Instantiate the data engine object
de.StartDate = new DateTime(2002,1,1,8,0,0);     // Specify the start date
de.EndDate = new DateTime(2002,1,1,23,59,59);      // Specify the end date.
//Specify a query.
de.SqlStatement = "SELECT names, values FROM myTable WHERE start > #StartDate# AND end < #EndDate#";

[Visual Basic]
Dim de As New DataEngine()     ' Instantiate the data engine object
de.StartDate = New DateTime(2002,1,1,8,0,0)     ' Specify the start date
de.EndDate = New DateTime(2002,1,1,23,59,59)      ' Specify the end date.
'Specify a query.
de.SqlStatement = "SELECT names, values FROM myTable WHERE start > #StartDate# AND end < #EndDate#"

Notes:

  • The #StartDate# and #EndDate# tokens can be used in SQL statements in which case the dates set for de.StartDate and de.EndDate will replace the tokens before the SqlStatement is executed.
  • StartDate and EndDate properties affects the dates listed in the title when Chart.ShowDateInTitle is used.
  • All date values in your SQL statements should be wrapped with the pound symbol: #10/25/2002#, regardless if Access or SQL server is used.
  • See also DataEngine.SqlStatement | DataEngine.StartDate | DataEngine.EndDate

Date grouping

This feature controls how the values of a given series are grouped by date. In order to use this option the first column returned by the SqlStatement must be a date/time data type.

Example 1

[C#]
de.SqlStatement = "SELECT time, unitsSold FROM sales";
de.DateGrouping = TimeInterval.Days;

[Visual Basic]
de.SqlStatement = "SELECT time, unitsSold FROM sales"
de.DateGrouping = TimeInterval.Days

The above will create an aggregated element for each day within the start and end date of your data. Similar options include:

  • Minutes
  • Hours
  • Days
  • Weeks
  • Months
  • Quarters
  • Years

Example 2

[C#]
myDataEngine.SqlStatement = "SELECT time, unitsSold FROM sales";
myDataEngine.DateGrouping = TimeInterval.Day;

[Visual Basic]
myDataEngine.SqlStatement = "SELECT time, unitsSold FROM sales"
myDataEngine.DateGrouping = TimeInterval.Day

When using day instead of days, data is grouped into 24 elements representing each hour of the day. For example, if the date range spans a week the element representing 11pm will contain the sum of all values that fall into that hour throughout the week.

Options include:

  • Hour ( 60 Minutes )
  • Day (24 Hours)
  • Week (7 Days)
  • Month (31 Days)
  • Quarter (3 Months)
  • Year ( 12 Months)

See also DataEngine.DateGrouping | TimeInterval

Limiting Data

Generated data can be limited in two ways. First, you can limit the number of elements returned for each series by using the 'Limit' property of the data engine.

[C#]
myDataEngine.Limit = "5";

[Visual Basic]
myDataEngine.Limit = "5"

Notes

  • This property is a string not a numeric value.
  • If DateGrouping is used, limit has no effect, you can limit the return with the StartDate and EndDate in such a case.
  • When data is limited, elements with the lowest y value are eliminated first.

The second way is to limit the number of series generated when using split by. For an example of SplitBy, see: Tutorials > Simple Queries > Multiple Series from a Single Query.

[C#]
myDataEngine.SplitByLimit = "2";

[Visual Basic]
myDataEngine.SplitByLimit = "2"

Notes

  • This property is a string not a numeric value.
  • SplitBy Defined - SplitBy occurs automatically based on the values returned by the SqlStatement property. When a 3rd column is returned from your SQL statement it automatically creates any number of new series based on the value provided. This value must be returned as a field in the SQL statement defined for the series. For example if you have a number of sales by customer, you could choose to graph those values by week in which case you would have 1 series with 4 values for a month or, using SplitBy, you could choose to split by customer and see the individual breakdown of sales by customer - with a separate series for each customer! See the SqlStatement property for more information.
  • Series with elements whose summed y values are the lowest are eliminated first.
  • See also DataEngine.Limit | DataEngine.SplitByLimit

Show data eliminated with Limit properties

The additional series not shown due to the use of SplitByLimit, or the additional elements not shown due to the use of Limit are aggregated into a single series or element respectively, and graphed alongside the main data when the ShowOther property is true.

[C#]
myDataEngine.ShowOther = true;
myDataEngine.OtherElementText = "The Rest";

[Visual Basic]
myDataEngine.ShowOther = True
myDataEngine.OtherElementText = "The Rest"

Notes:

  • The 'OtherElementText' property will be used as the name of the aggregated element or as the name of the aggregated series.
  • See also DataEngine.ShowOther | DataEngine.OtherElementLabel

Get data eliminated by Limit properties

If you would like to show series eliminated by Limit or SplitByLimit when drilling down or in a legend box, the LimitMode enumeration can be used. For example if you limit data to 5 and would like to see the rest, the LimitMode.ExcludeTop enumeration member can be used.

[C#]
myDataEngine.LimitMode = LimitMode.ExcludeTop;
myDataEngine.Limit = "5";

[Visual Basic]
myDataEngine.LimitMode = LimitMode.ExcludeTop
myDataEngine.Limit = "5"

Focus Limit on a specific Series

This feature allows limit to be bound to a specific series. First the series will be limited based on the specified value, then .netCHARTING will automatically match any remaining series to that limit order rather than limiting for each series independently.

[C#]

myDataEngine.Limit = "5";
myDataEngine.LimitPrimarySeries = "customers";
[Visual Basic]

myDataEngine.Limit = "5"
myDataEngine.LimitPrimarySeries = "customers"

Formatting

The data engine may populate an element's name property. The name property is a string, therefore, in order to ensure proper formatting of those values we can set the 'FormatString' and 'CultureName' properties of the data engine:

[C#]
myDataEngine.FormatString = "d";
myDataEngine.CultureName = "en-US";

[Visual Basic]
myDataEngine.FormatString = "d"
myDataEngine.CultureName = "en-US"

Notes:

  • "en-US" is the default culture name.
  • See also DataEngine.FormatString | DataEngine.CultureName


General Tutorials

These tutorials demonstrate the functionality of .netCHARTING and its features.

  • Chart Type Anatomy 101
    How to create different chart types.
    • Error Bars and other SubValues
      Shows how to use sub values such as ErrorBars.
    • Financial Charts
      Demonstrates how financial charts are created.
    • Element Layout Control
      How axes manipulate element layout.
      • Advanced (Z Axis Effect)
        Advanced element layout focusing the the z axis.

  • Coloring Elements
    Demonstrates how to color different elements.
  • Interactivity - Hotspots
    How to use image hotspots.
  • Calendar Patterns
    Using calendar patterns.
  • Using Labels
    How to use and manipulate element labels.
    • Label Alignment and Control
      Describes how to manipulate element label positions.
    • Label Tokens Reference
      A reference of dynamic content tokens used in labels on a chart.
    • Formatting Values
      How to format values on a chart.
      • Advanced
        Advanced formatting features.

  • Chart Surface Objects
    • Multiple Chart Areas
      How to use and manipulate multiple chart areas on a single image.
    • Box Tutorial
      Basic box features. Box is the base object of annotations, legend boxes and title boxes.
    • Legend Tutorial
      How to use basic legend features.
      • Advanced
        Advanced legend features.
    • Data Sources
      Data sources used for label tokens and populating custom legend boxes.

  • Axis Tutorials
    A collection of tutorials describing the many features available.
    • Axis Scales
      How different scales behave and how to manipulate them.
      • Scale Synchronization
        How axes can synchronize scales with other axes.
      • Elements & Axis Scales
        How element values determine axis scales.
    • Axis Ticks
      Using and manipulating axis ticks.
      • Minor Ticks
        Using minor axis ticks.
      • Axis Time Label Automation
        Using smart time label automation features.
      • Calculated Axis Ticks
        Automatically add axis ticks based on a calculated value.
    • Axis Markers
      Using and manipulating axis markers.
    • Multiple Axes
      Working with multiple axes.
      • Calculated Axes
        Using calculated axes to show data in different contexts.

  • File Handling
    Working with files, caching, and other related issues.
  • Shortcuts and Efficient Code
    How to improve implementation efficiency.
  • Performance
    Discusses features and how they can affect performance.


Chart Type Anatomy 101

Introduction

Chart types are constructed using several settings. Among them, the most significant are:

  • Chart Type
  • Series Type
  • Axis Scale

These properties work in concert to provide unprecedented flexibility.

Chart Types

The most fundamental property, Chart.Type, determines the generic layout of series and in the case of pie, radar, and gauge, a type of chart.

[C#]

Chart.Type = ChartType.Radar;

[Visual Basic]

Chart.Type = ChartType.Radar

Show All Show All

Hide All Hide All

Show Combo

Combo Chart Type

This chart types supports all the series types. It is vertically oriented so the y axis can only contain numeric or time values.

Supported Series Types

  • All

Element values used on the (Y Axis).

  • YValue
  • YValueStart
  • YDateTime
  • YDateTimeStart
  • BubbleSize
  • Complete
  • (Financial: Open Close High Low)

Element values used on the (X Axis).

  • XValue
  • XDateTime
  • Name

Show ComboHorizontal

ComboHorizontal Chart Type

This chart types is horizontally oriented so the x axis can only contain numeric or time values.

Supported Series Types

  • Column
  • Cylinder

Element values used on the (Y Axis).

  • XValue
  • XDateTime
  • Name

Element values used on the (X Axis).

  • YValue
  • YValueStart
  • YDateTime
  • YDateTimeStart
  • Complete

Notice that the axes values are reversed for this chart type. The reason for this is so that if you change between chart types the result will be correct.

Show ComboSideBySide

ComboSideBySide Chart Type

This chart types is similar to combo but each series is placed side by side and the x axis tick labels show each series name.

Supported Series Types

  • All

Element values used on the (Y Axis).

  • YValue
  • YValueStart
  • YDateTime
  • YDateTimeStart
  • BubbleSize
  • Complete
  • (Financial: Open Close High Low)

Element values used on the (X Axis).

  • None (Series.Name us used)

Notes

  • SideBySide does not support unclustered columns.

Show Pie & Donut

Pie Chart Type

Shows a single pie made up of all the series added to the chart.

Supported Series Types

  • N/A

Element values used on the (Y Axis).

  • YValue

Element values used on the (X Axis).

  • N/A

Related properties:

  • Element.ForceMarker
  • Element.ExplodeSlice
  • Chart.PieLabelMode
  • Chart.ExplodedSliceAmount
  • Chart.DonutHoleSize

Notice that the series are slices in using this chart type, hence, if only a single series is used, the chart will have a single 100% slice. To see each element use the plural ChartType.Pies.

Show Radar

Supported Series Types
  • Marker
  • Line
  • AreaLine
  • Bubble
  • Column

Element values used on the (Y Axis).

  • YValue
  • BubbleSize

Element values used on the (X Axis).

  • Name

Related properties:

  • Chart.RadarLabelMode
  • Axis.RadarMode

Radar Chart Type

Draws all series on a single radar. Both x and y axes are used. The x axis surrounds the radar and the y axis goes from the center to the outside.

Using this type will force each series to share a single x.
Polar Charts
The radar chart can support standard spider and polar axes. If the x axis uses a category scale, the default will be a spider chart. If the axis uses a numeric or time axis, the type will default to Polar. The type can also be specified explicitly using:
[C#]
<div>Chart.XAxis.RadarMode = RadarMode.Polar;

[Visual Basic]
<div>Chart.XAxis.RadarMode = RadarMode.Polar

Show Pies, Donuts, Radars, & Gauges

Pies, Radars, & Gauges Chart Types

All three chart types behave the same. The series are laid out in a way that allows for the maximum space usage.

Radars chart type allows different x axes to be used for each series.

Supported Series Types (Radars Only)
  • Marker
  • Line
  • AreaLine
  • Bubble

Element values used on the (Y Axis).

  • YValue
  • BubbleSize

Element values used on the (X Axis).

  • Name

Other chart types such as Bubble, Scatter, and Gantt are obsolete and they default to Combo, Combo, and ComboHorizontal respectively.

ChartType.Financial is also obsolete and shouldnt be used. It is provided only for backward compatibility.

Series Types

The next major contributor to chart types is the series type. The above chart type list includes a section on supported series types for each. Different series types can be specified for each series with the following chart types:

  • Combo
  • ComboSideBySide
  • ComboHorizontal
  • Radar(s)

This allows you to create virtually unlimited number of different chart types.

SeriesType enumeration

[C#]

mySeries.Type = SeriesType.Line;

[Visual Basic]

mySeries.Type = SeriesType.Line

  • Marker
    • In 3D markers have no depth
    • Related Properties
      • Element.Marker
  • Line
    • Each element can have a different color on the same line.
    • In 2D elements will automatically show element markers.
    • Related Properties
      • Series.Line (2D)
      • Element.Marker
  • Spline
    • Related Properties
      • Series.Line (2D)
      • Series.SplineTensionPercent
      • Element.Marker
  • AreaLine
    • Supports Stacked Axis Scales.
    • Related Properties
      • Series.Line (2D)
      • Element.Marker
  • AreaSpline
    • Supports Stacked Axis Scales.
    • Related Properties
      • Series.Line (2D)
      • Element.Marker
  • Column & Bar
    • Supports Stacked Axis Scales.
    • Supports shading effects.
    • Supports Element.Complete indicator which is useful with Gantt charts.
  • Cylinder
    • Supports Stacked Axis Scales.
  • Bubble
    • Requires Element.BubbleSize values.
    • Supports shading effects.
    • Related Properties
      • Element.BubbleSize
      • Chart.MaximumBubbleSize

SeriesTypeFinancial enumeration

[C#]

mySeries.Type = SeriesTypeFinancial.CandleStick;

[Visual Basic]

mySeries.Type = SeriesTypeFinancial.CandleStick

  • CandleStick
    • Element values used
      • Open or YValueStart
      • Close or YValue
      • High
      • Low
      • Complete
    • Supports column shading.
  • Bar
    • When a open value is not provided this bar will be an HLC bar, if provided it will be a OHLC.
  • Open
  • Close
  • High
  • Low
  • HighLowArea

Axis Scales

Further customization is achieved by specifying an axis scale. Besides controlling the quantitative scale type, scales also dictate how series behave. For example an axis scale can specify that columns are stacked.

See also: Element Values & Axis Scales | Element Layout and Axes | Z Axis effect

Conclusion

As you can see, the final chart type is fundamentally based on three settings. This mix and match concept may be more complicated than a single property, however, the flexibility it provides makes it well worth understanding.

See Also

Tutorials: ErrorBars and other SubValues | Financial Charts


ErrorBars and other SubValues

Introduction

.netCHARTING has an advanced system for handing error bars and other sub value types that are used in many statistics charts. Element and series classes have properties that quickly set sub values, however, there is a more powerful system underneath that controls and helps manage these sub elements.

SubValue Class Constructors

Each sub value is represented by a class that is instantiated by a number of sub value constructors that define its value.

SubValue offsets and percent values will be based on the element's yValue.

Constructor | Type | Description
FromHighLowValue(highValue,lowValue) | Range | Creates a range sub value from specified high and low values.
FromPlusMinusOffset(plusOffset,minusOffset) | Relative Range | Creates a range sub value from specified high and low offsets.
FromPlusMinusOffset (o) | Relative Range | Creates a range sub value from specified offset above and blow the element's yValue.
FromPlusMinusPercent (hPercent,lPercent) | Relative Range | Creates a range sub value from specified percentages above and below the element's yValue.
FromPlusMinusPercent (percent) | Relative Range | Creates a range sub value from the specified percentage above and below the element's yValue.
FromOffset(o) | Relative Single Value | Creates a subValue from the specified offset. (-2) will be below the element's yValue and (2) will be above.
FromPercent(p) | Relative Single Value | Creates a subValue from the specified percentage. (-50) will be below the element's yValue and (50) will be above.
FromValue(v) | Single Value | Creates a subValue from the specified value.

Adding SubValues

Each element contains a SubValueCollection under the Element.SubValues property. Adding a sub value can be done simply be adding it to that collection.

[C#]

Element e = new Element();
e.SubValues.Add(SubValue.FromOffset(5));

[Visual Basic]

Dim e As new Element()
e.SubValues.Add(SubValue.FromOffset(5))

The element e now contains a subValue which is equivalent to e.YValue + 5.

SubValues Appearance

There are a few options available that determine how a subVlaue will be drawn with an element. Here is a list including properties used to control their appearance:

  • ErrorBar
    A traditional error bar.
    • SubValue.Line
  • Marker
    A marker or two markers for range sub values.
    • SubValue.Marker
  • Line
    Similar to error bars but without the vertical line.
    • SubValue.Line

These options are specified with the SubValueType enumeration. Each SubValue contains a Type property which can which specifies how it is drawn.

This code snippet demonstrates how the appearance properties can be used.

[C#]

SubValue sv = SubValue.FromOffset(5);
sv.Type = SubValueType.Marker;
sv.Marker.Type = ElementMarkerType.Circle;
sv.Marker.Color = Color.Red;

SubValue sv2 = SubValue.FromOffset(5);
sv2.Type = SubValueType.Line;
sv2.Line.Color = Color.Black;
sv2.Line.DashStyle = DashStyle.Dash;

[Visual Basic]

Dim sv = SubValue.FromOffset(5)
sv.Type = SubValueType.Marker
sv.Marker.Type = ElementMarkerType.Circle
sv.Marker.Color = Color.Red

Dim sv2 = SubValue.FromOffset(5)
sv2.Type = SubValueType.Line
sv2.Line.Color = Color.Black
sv2.Line.DashStyle = DashStyle.Dash

Default Settings

SubValues can be quickly added and manipulated for all elements within a series or series collection. When a SubValue is added to a series' default element it is also added to all subsequent elements automatically.

This code snippet automatically adds a subValue to all elements on the chart.

[C#]

Chart.DefaultSeries.DefaultElement.SubValues.Add(SubValue.FromOffset(5));

[Visual Basic]

Chart.DefaultSeries.DefaultElement.SubValues.Add(SubValue.FromOffset(5))

SubValues default appearance can also be specified quickly by using the element's DefaultSubValue properties.

[C#]

Chart.DefaultSeries.DefaultElement.DefaultSubValue.Line.DashStyle = DashStyle.Dash;

[Visual Basic]

Chart.DefaultSeries.DefaultElement.DefaultSubValue.Line.DashStyle = DashStyle.Dash
Limitations
  • SubValues are not available with financial series types.
  • Time scales don't support error bars.


Financial Charts

Financial charts may create some confusion, never the less, making them works on the same principal as any other chart. There is, however, a difference in acquiring data.

Data Acquisition

First let's get data from a database which already has open, close, high, and low values using the DataEngine. In order to populate OCHL (open, close, high, low) element properties the DataEngine.GetFinancialSeries() method is used instead of GetSeris().

[C#]

DataEngine de = new DataEngine(myConnectionString);
de.QueryString = "SELECT timeCol ,openCol, closeCol, highCol, lowCol, timeCol FROM stockPrice";
de.DataFields = "open=openCol,close=closeCol,high=highCol,low=lowCol,xValue=timeCol";

SeriesCollection stockSC = de.GetFinancialSeries();
stockSC.Type = SeriesTypeFinancial.CandleStick;
Chart.SeriesCollection.Add(stockSC);
[Visual Basic]

Dim de = New DataEngine(myConnectionString)
de.QueryString = "SELECT timeCol ,openCol, closeCol, highCol, lowCol, timeCol FROM stockPrice"
de.DataFields = "open=openCol,close=closeCol,high=highCol,low=lowCol,xValue=timeCol"

Dim stockSC = de.GetFinancialSeries()
stockSC.Type = SeriesTypeFinancial.CandleStick
Chart.SeriesCollection.Add(stockSC)

For the next example, we'll get our data from a database that has only the price column where the entries represent a price snapshot for every hour of the day over several months. We'll want to create the same type of chart as the above but obviously the data is not formatted in this manner. Fortunately the DataEngine is capable of grouping the data properly and calculating the high, low, open, and close prices. The DataEngine will know that this is the result we're going for when we use GetDataFinancial() instead of GetData().

[C#]

DataEngine de = new DataEngine(myConnectionString);
de.DateGrouping = TimeInterval.Days;
de.QueryString = "SELECT timeCol, price FROM stockPrice";

SeriesCollection stockSC = de.GetFinancialSeries();
stockSC.Type = SeriesTypeFinancial.CandleStick;
Chart.SeriesCollection.Add(stockSC);
[Visual Basic]

DataEngine de = new DataEngine(myConnectionString);
de.DateGrouping = TimeInterval.Days;
de.QueryString = "SELECT timeCol, price FROM stockPrice";

SeriesCollection stockSC = de.GetFinancialSeries();
stockSC.Type = SeriesTypeFinancial.CandleStick;
Chart.SeriesCollection.Add(stockSC);

For more information on data acquisition, see: Data Tutorials.

Setting up Charts

ChartType.Financial
Please note that this chart type should not be used. It is there for backward compatibility. Using this chart type, a single series can be used where the element price properties are set as well as the volume value, however, the functionality will be limited. Instead use ChartType.Combo. The following example will show how to create the volume chart area using the newer more capable method.

[C#]

DataEngine de = new DataEngine(myConnectionString);
de.QueryString = "SELECT timeCol, volume, FROM stockVolume";
de.DateGrouping = TimeInterval.Day;
SeriesCollection volSC = de.GetData();

// Create a new chart area, add the volume data and add the area to the chart.
ChartArea vca = new ChartArea(volSC);
vca.HeightPercentage = 30;
Chart.ExtraChartAreas.Add(vca);
[Visual Basic]

Dim de As New DataEngine(myConnectionString)
de.QueryString = "SELECT timeCol, volume, FROM stockVolume"
de.DateGrouping = TimeInterval.Day
Dim volSC As de.GetData()

// Create a new chart area, add the volume data and add the area to the chart.
Dim vca As New ChartArea(volSC)
vca.HeightPercentage = 30
Chart.ExtraChartAreas.Add(vca)

For more information on using and manipulating ChartAreas, see: Multiple Chart Areas.


Element Layout Control

Element Layout Control

Introduction
This section will describe the following:

  • Sizing Columns
    How axes influence the element behavior and appearance.
  • Clustering Columns
    How axes control column and cylinder clustering.

Besides the obvious, an axis can also control how elements drawn on its scale behave. These behavioral features are determined by the axis that shows element names or x values. For a vertical combo chart this would mean the x axis and y axis for horizontal combo.

Column and Cylinder Widths

  • SpacingPercentage
    Gets or sets a percentage (0 - 100) which indicates the spacing between columns, cylinders or groups thereof.
  • StaticColumnWidth
    Gets or sets the static bar width in pixels.

Example: This code specifies the column or cylinder widths for a ChartType.Combo chart.

[C#]

Chart.XAxis.SpacingPercentage = 30; // Default is 16
// When this property is set, it takes precedence over spacing percentage.
Chart.XAxis.StaticColumnWidth = 20;

[Visual Basic]

Chart.XAxis.SpacingPercentage = 30 ' Default is 16
' When this property is set, it takes precedence over spacing percentage.
Chart.XAxis.StaticColumnWidth = 20
Tip: The column width control also defines the tool tip hotspot width of area line series types.

Clustering Columns / Cylinders
This feature enables columns in 3D modes to cluster (draw side by side) or not (draw one in front of the other). The default behavior is to cluster and column must be clustered in 2D mode.

[C#]

Chart.Use3D = true;
Chart.XAxis.ClusterColumns = false;

[Visual Basic]

Chart.Use3D = True
Chart.XAxis.ClusterColumns = False

Other options include

  • Position
    The axis positions when 2 or more axes are drawn on the same side of a ChartArea.
  • ReverseSeriesPositions
    Indicates whether the positions of series bound to this axis are reversed without reversing legend positions.
  • ReverseSeries
    Indicates whether the positions of series bound to this axis are reversed.
  • ReverseStack
    Indicates whether the order of stacked elements is reversed.
See Also

Tutorials: Element Layout Control Advanced | Elements And Axis Scales


Element Layout Control Advanced

Z-Axis Effect

Using multiple axes with series can yield some interesting results you may not be aware of. We'll explore a situation that simulates a z axis. A basic z axis can be simulated using

[C#]

Chart.XAxis.ClusterColumns = false;

[Visual Basic]

Chart.XAxis.ClusterColumns = false

This may show a chart that looks like this:

Using X Axes

This works well however if we wanted a z axis with two steps and two clustered series on each step we will have to use two X axes. This time we will also omit setting the cluster columns property to false.

[C#]

Axis a2 = new Axis();
mySC[0].XAxis = a2;
mySC[1].XAxis = a2;
a2.Clear();
[Visual Basic]

Axis a2 = new Axis();
mySC[0].XAxis = a2;
mySC[1].XAxis = a2;
a2.Clear();
We "Clear()" the second axis so that only the original one is visible.
Tip: This method also allows overlapping columns
in 2D mode which is useful in Gantt charts:

Using Y Axes
Y axes will typically not affect the z axis. For example using the following code where we give two of the four series a new y axis and set the scale to stacked:
Axis a2 = new Axis();
mySC[0].YAxis = a2;
mySC[1].YAxis = a2;
a2.Scale = Scale.Stacked;
Will yield this result:

Notice that the new y axis is stacked but still the main x axis manages the clustered - unclustered layout. Therefore if we wanted to uncluster the columns we could have multiple z axis steps and some may be stacked while other wont.

[C#]

Chart.XAxis.ClusterColumns = false;

[Visual Basic]

Chart.XAxis.ClusterColumns = false

Sample: features/AxisDualScales.aspx


Element Colors & Palettes

Introduction

This tutorial will describe how to use palettes and specify element and series colors.

Using Palettes

There are several 50 color palettes available in the Palette enumeration. These can be defined in two ways.

Through Chart.PaletteName:

[C#]

Chart.PaletteName = dotnetCHARTING.Palette.Autumn;

[Visual Basic]

Chart.PaletteName = dotnetCHARTING.Palette.Autumn

This code will color each element based on a color in this palette.

Through Series.PaletteName

[C#]

mySeries.PaletteName = dotnetCHARTING.Palette.Autumn;

[Visual Basic]

mySeries.PaletteName = dotnetCHARTING.Palette.Autumn;

Using palette properties of series will color each element in that series a unique color of the specified palette.

NOTE: (Important) By specifying series palette, the legend box will display an entry for each element instead of entries for each series.
Sample: features/ColorByElements.aspx

Custom Palettes

Custom palettes can also be specified by supplying Chart.Palette or Series.Palette with an array of color objects. They will work in the same way as pre-defined palettes.

Coloring Individual Elements

To specify a color for an individual element it needs to be set through the Element.Color property. To specify a color for an entire series, set Series.DefaultElement.Color.

In order to specify individual series or element colors, a populated Series or SeriesCollection is required. Please see this kb for more information.

Samples

  • features/iterateElements.aspx
    Color elements based on value.
  • features/InvisibleLegendEntry.aspx
    Color elements based on value.

SeriesTypeFinancial

Financial series types like candlestick and bar use Element.SecondaryColor to fill elements that have a lower close price than open price.

SeriesType.Line

A 2D line color, thickness, and style can be controlled with the Series.Line property. Each element's color is shown in the element marker. In 3D mode each element section is colored with an elements color.

Smart Palette

The SmartPalette object allows you to create a standard color scheme for charts that show related data. It does this by establishing a list of series or element names and the colors they should use. Fortunately, it does not require you to manually define all these name color pairs.

Working with the SmartPalette object

To create a smart palette that any charts can use, a populated SeriesCollection is required. Then a palette enumeration member or array of colors can be used to generate the SmartPalette based on the names of series in a series collection or element names in a series series. When the SmartPalette object is created it can be saved as XML and loaded by any chart with access to the xml file.

Manually Defining a SmartPalette

The code below demonstrates manually populating a smart palette object.

[C#]

SmartPalette sp = new SmartPalette();
sp.Add("Series 1", Color.Red);
sp.Add("Series 2", Color.Blue);
[Visual Basic]

Dim sp As SmartPalette = New SmartPalette()
sp.Add("Series 1", Color.Red)
sp.Add("Series 2", Color.Blue)

Automatically Generating a SmartPalette

This code will generate a smart palette based on the colors specified by the Palette.One enumeration and match them with element names within the mySeries series object.

[C#]
SmartPalette sp = mySeries.GetSmartPalette(Palette.One);
[Visual Basic]
Dim sp As SmartPalette = mySeries.GetSmartPalette(Palette.One)

Saving the SmartPalette

Now that the SmartPalette object is generated and ready to use, it can be used by all charts related to this information. In order to use this object in other web pages it must be saved as xml. The following code demonstrates this.

[C#]

sp.SaveState("ClientSmartPalette.xml");
[Visual Basic]

sp.SaveState("ClientSmartPalette.xml")
Sample: features/SmartPaletteSaving.aspx
At this point, everything is setup for charts that show clients to use the same colors for each client no matter what page is showing the chart.
Loading the SmartPalette
The following code initializes an instance of the SmartPalette object using the information stored in ClientSmartPalette.xml.
[C#]

SmartPalette sp = new SmartPalette("ClientSmartPalette.xml");
[Visual Basic]

Dim sp As SmartPalette = New SmartPalette("ClientSmartPalette.xml")
Sample: features/SmartPaletteLoading.aspx features/SmartPaletteSaving.aspx

Applying the SmartPalette

There are a couple ways the smart palette can be used. One way is to specify the SmartPalette for the whole chart. In this case, any element or series that matches a SmartPalette entry will inherit the associated color.

[C#]

Chart.SmartPalette = sp;
[Visual Basic]

Chart.SmartPalette = sp

The other option allows narrowing the use of the smartPalette to a chart area by means of specifying the smartPalette for the chart area's seriesCollection.

[C#]

ChartArea ca = new ChartArea();
ca.SeriesCollection.SmartPalette = sp;
Chart.ExtraChartAreas.Add(ca);
[Visual Basic]

Dim ca As ChartArea = new ChartArea()
ca.SeriesCollection.SmartPalette = sp
Chart.ExtraChartAreas.Add(ca)


Hotspots

Introduction

Hotspots are areas on the chart image that encapsulate interactive functionality. They also allow you to specify any custom HTML attributes of generated image map. The following objects all contain a Hotspot property.

  • Element
  • Annotation
  • Chart
  • EmptyElement
  • LegendEntry

Basic Functionality

To set the href, alt, or target attributes of the hotspot the following code can be used. In this case an element will be used as an example but similar code will work for other hotspots as well.

[C#]

Element el = new Element();
el.Hotspot.URL = "?elementName=%Name";
el.Hotspot.URLTarget = "_blank";
el.Hotspot.ToolTip = "%Name: %Value";
[Visual Basic]

Dim el As new Element()
el.Hotspot.URL = "?elementName=%Name"
el.Hotspot.URLTarget = "_blank";
el.Hotspot.ToolTip = "%Name: %Value"

More Options

For more advanced java script attributes the Hotspot.Attributes property exposes a number of events:

  • OnClick
  • OnMouseOver
  • OnDoubleClick

Each of these events is an HtmlAttribute class that also exposes several actions that will be created automatically:

  • Alert
  • Redirect
  • RedirectFrame
  • StatusBarMessage

This example demonstrates all the provided JavaScript attribute features:

[C#]

element.Hotspot.Attributes.OnMouseOver.StatusBarMessage = "%SeriesName - %Name: %YValue";
element.Hotspot.Attributes.OnClick.Alert= "%Name Clicked";
element.Hotspot.Attributes.OnDoubleClick.Redirect = "?name=%Name";
element.Hotspot.Attributes.OnDoubleClick.RedirectFrame = "?name=%Name";
[Visual Basic]

element.Hotspot.Attributes.OnMouseOver.StatusBarMessage = "%SeriesName - %Name: %YValue"
element.Hotspot.Attributes.OnClick.Alert= "%Name Clicked"
element.Hotspot.Attributes.OnDoubleClick.Redirect = "?name=%Name"
element.Hotspot.Attributes.OnDoubleClick.RedirectFrame = "?name=%Name";

Custom Attributes

There are several other events and JavaScript functions which are not available in the HtmlAttribute classes. For that reason, custom attributes can be specified. This code shows how to add one of the above attributes manually:

[C#]

element.Hotspot.Attributes.Custom.Add("OnClick","alert('%Name Clicked')");
[Visual Basic]

element.Hotspot.Attributes.Custom.Add("OnClick","alert('%Name Clicked')")


Using labels

Introduction

.netCHARTING label strings can be used as dynamic templates capable of evaluating mathematical expressions, embedding info about the associated object, and specifying format strings.

The following diagram demonstrates the properties used to access different labels.

Show Chart Labels Diagram

Click on any property name for additional information.

Tokens

Syntax: %{Token}
Example: %Name

Tokens can be used to embed information about the object associated with the label. For example the label of an element can contain the '\%Name' token. When parsed, the token will evaluate to the element's name. The Label Token Reference lists objects and the tokens that are available for each.

Sample: features/ElementTemplate.aspx
Custom Tokens
Custom tokens can also be used to represent miscellaneous information retrieved from a database. For more information on custom tokens see the Custom Attributes tutorial.

Expressions

Syntax: <{Expression}>
Example: <(%YValue+5)/%PercentOfTotal>

Mathematical expressions can also be evaluated within label strings. An expression must be encapsulated within '<' and '>' characters, similar to an xml tag. An example of a simple expression is '<2+2>' which would result in '4' in the final label text. If this expression string is intended to be taken literally, a preceding '\' character will prevent the expression parser from evaluating it. For example the string '\<2+2>' would result in '<2+2>'. Expressions can group parts of the expression using parentheses: (). Example: <(5+5)*3>. Expressions can also include tokens as values, for example: <%YValue/3>

Caution: Spaces are not allowed within expressions.
Wrong: <5 + %YValue>
Correct: <5+%YValue>

Expression Functions

Besides simple expressions, labels can evaluate advanced functions such as sin, cos, or sqrt.

[C#]

Chart.DefaultElement.SmartLabel.Text = "<%YValue+sin(%YValue)>";

[Visual Basic]

Chart.DefaultElement.SmartLabel.Text = "<%YValue+sin(%YValue)>"

This table lists the available functions.

abs(n) | Evaluates the absolute value of n.
acos(n) | Evaluates the arc cosine of n.
asin(n) | Evaluates the arc sine of n.
atan(n) | Evaluates the arc tangent of n.
cos(n) | Evaluates the cosine of n.
cosh(n) | Evaluates the hyperbolic cosine of n.
exp(n) | Evaluates the exponent of n.
ln(n) | Evaluates the natural logarithm of n.
log(n) | Evaluates the logarithm of n (base 10). Same as logn(n,10)
logn(n1,n2) | Evaluates the logarithm of n1 where n2 is the base of the logarithm.
sin(n) | Evaluates the sine of n.
sinh(n) | Evaluates the hyperbolic sine of n.
sqrt(n) | Evaluates the square root of n.
tan(n) | Evaluates the tangent of n.
tanh(n) | Evaluates the hyperbolic cosine of n.

Embedded Format Strings (In-Line Formatting)

Syntax: <<[expression]> | [token], [Format string]>
Example: <%YValue,Currency>

Values can be formatted in-line within the label using the above syntax.

For more information on in-line formatting see the Advanced Formatting tutorial.

Token, Expressions, and In-Line Formatting Examples

The following examples will demonstrate tokens, expressions, and embedded format strings usage.

Label Text | Result
%YValue | 5
%Name | Element 2
<%YValue+5> | 10
<(10+5)-%YValue> | 10
<sqrt(%YValue)+10> | 12.23
<%YValue,Currency> | $5.00

<<(10+5)-%YValue>,Currency>

Notice that the expression is encapsulated in <> characters inside the in-line formatting <> tags.

 $10.00

See Also

Data Tutorials: Custom Data Attributes

Tutorials: Label Alignment and Control | Formatting Values

Reference: Labels | Tokens


Label Alignment and Control

Introduction

Each element contains a SmartLabel object with properties that affect the label's behavior. To show the element labels the following code can be used. The setting will propagate to all elements within the chart.

[C#]

Chart.DefaultElement.ShowValue = true;
[Visual Basic]

Chart.DefaultElement.ShowValue = True

Dynamic Labels

Force Label Drawing
Labels that cannot fit on the chart will not be shown by default. To force them to appear, the DynamicDisplay property must be set to false.

[C#]

Chart.DefaultElement.SmartLabel.DynamicDisplay = false;
[Visual Basic]

Chart.DefaultElement.SmartLabel.DynamicDisplay = False

Prevent Label Overlap
Non-column series type elements have labels which will dynamically move out of each others way to prevent overlap. When this happens,a line is drawn to indicate which element the label pertains to. This behavior can be turned off and on using the DynamicPosition property. The following code disables this feature:

[C#]

Chart.DefaultElement.SmartLabel.DynamicPosition = false;
[Visual Basic]

Chart.DefaultElement.SmartLabel.DynamicPosition = False

The line drawn to indicate the element can be modified through the SmartLabel.Line property.

Line caps can be used to make the indicator lines look like arrow pointers.

Label Alignment

Element labels also have several other alignment options available provided by the LabelAlignment enumeration.

Alignment
A label's default alignment is controled with the SmartLabel.Alignment property.

[C#]

Chart.DefaultElement.SmartLabel.Alignment = LabelAlignment.Top;
[Visual Basic]

Chart.DefaultElement.SmartLabel.Alignment = LabelAlignment.Top

Column Labeling

Secondary Alignment
Since there may not always be enough room to place the label in desired position (Alignment). The chart engine will look at the AlignmentSecondary property which is a collection of LabelAlignment objects and find the next best one that fits. The following code clears the default secondary alignment settings and sets two options labels can use.

[C#]

Chart.DefaultElement.SmartLabel.SecondaryAlignment.Clear();
Chart.DefaultElement.SmartLabel.SecondaryAlignment.Add(LabelAlignment.OutsideTop);
Chart.DefaultElement.SmartLabel.SecondaryAlignment.Add(LabelAlignment.Bottom);
[Visual Basic]

Chart.DefaultElement.SmartLabel.SecondaryAlignment.Clear()
Chart.DefaultElement.SmartLabel.SecondaryAlignment.Add(LabelAlignment.OutsideTop)
Chart.DefaultElement.SmartLabel.SecondaryAlignment.Add(LabelAlignment.Bottom)

Vertical Label
When a label doesn't fit into a column horizontally it will try to fit vertically. If the label is too tall to fit, the label font will decrease in size until it fits. For cases where columns have both horizontal and vertical labels, column labels may be difficult to read. If this is the case, all labels can be forced to show vertically by using this code:

[C#]

Chart.DefaultElement.SmartLabel.ForceVertical = true;
[Visual Basic]

Chart.DefaultElement.SmartLabel.ForceVertical = True

Note: This feature doesn't affect horizontal charts.


Tokens

Item templates enable fixed tokens prefixed with a percentage sign to be replaced by actual data when the chart is rendered. This is particularly useful for item level properties such as Label Template, URL and ToolTip where you can mix your own text with tokens. If you wish to have template values rendered on multiple lines you can use \r where you wish a new line to begin.

Embedding Token Formatting

Format strings may be included in templates using the following syntax:

<[Token],[FormatString]>

Characters such as">" can not be used in the format string.

Example: <%Value,Currency>

Unrecognized template tokens will be replaced with "?". If you see a question mark included, check the spelling of your token.

Bypass Token Processing

Using the forward slash '/' before a token will stop the token from being processed. For example, using '%Name' will result the string '%Name'.

Show All Show All
Hide All Hide All

Show Element Tokens

Describes an Element object. These tokens are generally used by element legend entries, element labels and in annotations.

Values
Token | Description
%Value = %Yvalue | The y value of this element. Depending on the type of data being used, this will be either numeric: Element.YValue or time: Element.YDateTime.
%Xvalue | The x value of this element. Depending on the type of data being used, this will be either numeric: Element.XValue or time: Element.XDateTime.
%YValueStart = %ValueStart | The starting y value of this element. Depending on the type of data being used, this will be either numeric: Element.YValueStart or time: Element.YDateTimeStart.
%XValueStart | The starting x value of this element. Depending on the type of data being used, this will be either numeric: Element.XValueStart or time: Element.XDateTimeStart.
%BubbleSize | The bubble size value of this element (Element.BubbleSize).
%Complete | The complete value of this element (Element.Complete). This value is useful with Gantt charts.
%Close | Financial close value (Element.Close).
%Open | Financial open value (Element.Open).
%High | Financial high value (Element.High).
%Low | Financial low value (Element.Low).
%Volume | Financial volume value (Element.Volume).
Ranges
%YRange = %Range = (%YDays ,%Days if time based) | The range of this element (Element.YValue - Element.YValueStart). If the chart is time based the range will be the number of days between Element.YDateTime and Element.YDateTimeStart.
%YMinutes = %Minutes | The number of minutes between Element.YDateTime and Element.YDateTimeStart if applicable.
%YHours = %Hours | The number of hours between Element.YDateTime and Element.YDateTimeStart if applicable.
Calculations
%PercentOfSeries = %YPercentOfSeries | The percentage of the series this element represents. ( Element.YValue )
%PercentOfTotal = %YPercentOfTotal | The percentage of all the series on the chart this element represents. ( Element.YValue )
%PercentOfGroup = %YPercentOfGroup | The percentage of all the elements with the same name this element represents. ( Element.YValue )
%XPercentOfSeries | The percentage of the series this element represents. ( Element.XValue )
%XPercentOfTotal | The percentage of all the series on the chart this element represents. ( Element.XValue )
%XPercentOfGroup | The percentage of all the elements with the same name this element represents. ( Element.XValue )
%BubbleSizePercentOfSeries | The percentage of the series this element represents. ( Element.BubbleSize )
%BubbleSizePercentOfTotal | The percentage of all the series on the chart this element represents. ( Element.BubbleSize )
%BubbleSizePercentOfGroup | The percentage of all the elements with the same name this element represents. ( Element.BubbleSize )
%CompletePercentOfSeries | The percentage of the series this element represents. ( Element.Complete )
%CompletePercentOfTotal | The percentage of all the series on the chart this element represents. ( Element.Complete )
%CompletePercentOfGroup | The percentage of all the elements with the same name this element represents. ( Element.Complete )
Identification
%Name | The name of this element.
%SeriesName | The name of the series this element belongs to.
%XAxisName | The name of the x axis this element is charted on.
%YAxisName | The name of the y axis this element is charted on.

Show Series Tokens

Describes a Series object. Generally used by legend entries.

Sums
Token | Description
%Sum = %Ysum = %Yvalue = %Value | The sum of all the element's y values. (Element.YValue). If the chart is time based this token is the same as %YDays.
%Xsum = %XValue | The sum of all the element's x values. (Element.XValue). If the chart is time based this token is the same as %XDays.
%BubbleSize = %BubbleSizeSum | The sum of all the element's bubble sizes. (Element.BubbleSize)
Ranges
%Range = %YRange (= %Days & =%YDays if applicable) | The sum of all the element's ranges. (Element.YValue - Element.YValueStart). If the chart is time based this token represents the sum of days between each element's Element.YDateTime and Element.YDateTimeStart values.
%YMinutes = %Minutes | If the chart is time based this token represents the sum of minutes between each element's Element.YDateTime and Element.YDateTimeStart values.
%YHours = %Hours | If the chart is time based this token represents the sum of hours between each element's Element.YDateTime and Element.YDateTimeStart values.
%XMinutes | If the chart is time based this token represents the sum of minutes between each element's Element.XDateTime and Element.XDateTimeStart values.
%XHours | If the chart is time based this token represents the sum of hours between each element's Element.XDateTime and Element.XDateTimeStart values.
%XDays | If the chart is time based this token represents the sum of days between each element's Element.XDateTime and Element.XDateTimeStart values.
%YSpanDays = %SpanDays = %YSpan = %Span | If the chart is time based this token represents the range of days between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%YSpanMinutes = %SpanMinutes | If the chart is time based this token represents the range of minutes between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%YSpanHours = %SpanHours | If the chart is time based this token represents the range of hours between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%XSpanDays | If the chart is time based this token represents the range of days between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
%XSpanHours | If the chart is time based this token represents the range of hours between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
%XSpanMinutes | If the chart is time based this token represents the range of minutes between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
Calculations
%High = %YHigh | The highest y value of all the elements within this series. (Element.YValue)
%XHigh | The highest x value of all the elements within this series. (Element.XValue)
%Low = %YLow | The lowest y value of all the elements within this series. (Element.YValue)
%XLow | The lowest x value of all the elements within this series. (Element.XValue)
%BubbleHigh | The highest bubble size value of all the elements within this series. (Element.BubbleSize)
%BubbleLow | The lowest bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteHigh | The highest complete value of all the elements within this series. (Element.Complete)
%CompleteLow | The lowest complete value of all the elements within this series. (Element.Complete)
%CloseHigh | The highest financial close value of all the elements within this series. (Element.Close)
%CloseLow | The lowest financial close value of all the elements within this series. (Element.Close)
%Average = %Yaverage = %Mean = %YMean | The average y value of all the elements within this series. (Element.YValue)
%Xaverage = %XMean | The average x value of all the elements within this series. (Element.XValue)
%BubbleSizeAverage = %BubbleSizeMean | The average bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteAverage = %CompleteMean | The average complete value of all the elements within this series. (Element.Complete)
%CloseAverage = %CloseMean | The average financial close value of all the elements within this series. (Element.Close)
%Median = %YMedian | The median y value of all the elements within this series. (Element.YValue)
%XMedian | The median x value of all the elements within this series. (Element.XValue)
%BubbleSizeMedian | The median bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteMedian | The median complete value of all the elements within this series. (Element.Complete)
%CloseMedian | The median financial close value of all the elements within this series. (Element.Close)
%Mode = %YMode | The mode y value of all the elements within this series. (Element.YValue)
%XMode | The mode x value of all the elements within this series. (Element.XValue)
%BubbleSizeMode | The mode bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteMode | The mode complete value of all the elements within this series. (Element.Complete)
%CloseMode | The mode financial close value of all the elements within this series. (Element.Close)
Identification
%Name | The name of this series.
%YAxisName | The name of the y axis this series is charted on.
%XAxisName | The name of the x axis this series is charted on.

Show SeriesCollection Tokens

Describes a SeriesCollection object. Generally used in title box labels and chart area labels.

Sums
Token | Description
%Sum = %Ysum = %Yvalue = %Value | The sum of all the element's y values. (Element.YValue). If the chart is time based this token is the same as %YDays.
%Xsum = %XValue | The sum of all the element's x values. (Element.XValue). If the chart is time based this token is the same as %XDays.
%BubbleSize = %BubbleSizeSum | The sum of all the element's bubble sizes. (Element.BubbleSize)
Ranges
%Range = %YRange (= %Days & =%YDays if applicable) | The sum of all the element's ranges. (Element.YValue - Element.YValueStart). If the chart is time based this token represents the sum of days between each element's Element.YDateTime and Element.YDateTimeStart values.
%YMinutes = %Minutes | If the chart is time based this token represents the sum of minutes between each element's Element.YDateTime and Element.YDateTimeStart values.
%YHours = %Hours | If the chart is time based this token represents the sum of hours between each element's Element.YDateTime and Element.YDateTimeStart values.
%XMinutes | If the chart is time based this token represents the sum of minutes between each element's Element.XDateTime and Element.XDateTimeStart values.
%XHours | If the chart is time based this token represents the sum of hours between each element's Element.XDateTime and Element.XDateTimeStart values.
%XDays | If the chart is time based this token represents the sum of days between each element's Element.XDateTime and Element.XDateTimeStart values.
%YSpanDays = %SpanDays = %YSpan = %Span | If the chart is time based this token represents the range of days between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%YSpanMinutes = %SpanMinutes | If the chart is time based this token represents the range of minutes between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%YSpanHours = %SpanHours | If the chart is time based this token represents the range of hours between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%XSpanDays | If the chart is time based this token represents the range of days between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
%XSpanHours | If the chart is time based this token represents the range of hours between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
%XSpanMinutes | If the chart is time based this token represents the range of minutes between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
Calculations
%High = %YHigh | The highest y value of all the elements within this series. (Element.YValue)
%XHigh | The highest x value of all the elements within this series. (Element.XValue)
%Low = %YLow | The lowest y value of all the elements within this series. (Element.YValue)
%XLow | The lowest x value of all the elements within this series. (Element.XValue)
%BubbleHigh | The highest bubble size value of all the elements within this series. (Element.BubbleSize)
%BubbleLow | The lowest bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteHigh | The highest complete value of all the elements within this series. (Element.Complete)
%CompleteLow | The lowest complete value of all the elements within this series. (Element.Complete)
%CloseHigh | The highest financial close value of all the elements within this series. (Element.Close)
%CloseLow | The lowest financial close value of all the elements within this series. (Element.Close)
%Average = %Yaverage = %Mean = %YMean | The average y value of all the elements within this series. (Element.YValue)
%Xaverage = %XMean | The average x value of all the elements within this series. (Element.XValue)
%BubbleSizeAverage = %BubbleSizeMean | The average bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteAverage = %CompleteMean | The average complete value of all the elements within this series. (Element.Complete)
%CloseAverage = %CloseMean | The average financial close value of all the elements within this series. (Element.Close)
%Median = %YMedian | The median y value of all the elements within this series. (Element.YValue)
%XMedian | The median x value of all the elements within this series. (Element.XValue)
%BubbleSizeMedian | The median bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteMedian | The median complete value of all the elements within this series. (Element.Complete)
%CloseMedian | The median financial close value of all the elements within this series. (Element.Close)
%Mode = %YMode | The mode y value of all the elements within this series. (Element.YValue)
%XMode | The mode x value of all the elements within this series. (Element.XValue)
%BubbleSizeMode | The mode bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteMode | The mode complete value of all the elements within this series. (Element.Complete)
%CloseMode | The mode financial close value of all the elements within this series. (Element.Close)
%MaxValueElementName %MaxYValueElementName | Name of the element with the highest y value (Element.YValue).
%MinValueElementName %MinYValueElementName | Name of the element with the lowest y value (Element.YValue).
%MaxValueElementSeriesName %MaxYValueElementSeriesName | Name of the series that contains the element with the highest y value (Element.YValue).
%MaxValueElementSeriesName %MaxYValueElementSeriesName | Name of the series that contains the element with the lowest y value (Element.YValue).
%MaxValueSeriesName %MaxYValueSeriesName | Name of the series that contains the highest sum of it's element y values.
%MinValueSeriesName %MinYValueSeriesName | Name of the series that contains the lowest sum of it's element y values.

Show Element Group Tokens

Describes an Element group. Generally used by axis ticks to describe the group they represent.

Calculations
Token | Description
%PercentOfTotal = %YPercentOfTotal | The percent of all the data on the chart this element group represents. (Element.YValue)
%CompletePercentOfTotal | The percent of all the data on the chart this element group represents. (Element.Complete)
%Sum = %YSum = %Yvalue = %Value | The sum of all the elements within this element group. (Element.YValue)
%Average = %Yaverage = %Mean = %YMean | The average of all the elements within this element group. (Element.YValue)
%Median = %YMedian | The median of all the elements within this element group. (Element.YValue)
%Mode = %Ymode | The mode of all the elements within this element group. (Element.YValue)
%CompleteAverage = %CompleteMean | The average of all the elements within this element group. (Element.Complete)
%CompleteMedian | The median of all the elements within this element group. (Element.Complete)
%CompleteMode | The mode of all the elements within this element group. (Element.Complete)
Ranges
%YRange = %Range = (%YDays ,%Days if applicable) | The sum of all the ranges of elements within this group. (Element.YValue - Element.YValueStart) If this chart is time based the token will represent the sum of days between each element's Element.YDateTime and Element.YDateTimeStart values.
%YMinutes = %Minutes | If this chart is time based this token will represent the sum of minutes between each element's Element.YDateTime and Element.YDateTimeStart values.
%YHours = %Hours | If this chart is time based this token will represent the sum of hours between each element's Element.YDateTime and Element.YDateTimeStart values.
%Span = %SpanDays | If the chart is time based this token represents the range of days between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%SpanMinutes | If the chart is time based this token represents the range of minutes between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%SpanHours | If the chart is time based this token represents the range of hours between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
Identification
%Name | The name of the elements in this group.

Show Axis Marker Tokens

Describes an AxisMarker object. Generally used by the axis marker label and it's legend entry.

Values
Token | Description
%Low | The low value of this axis marker
%High | The high value of this axis marker.
%Range | The range of this marker.
%Minutes | If the marker is a time range this token will represent the minutes between the high and low time values.
%Hours | If the marker is a time range this token will represent the hours between the high and low time values.
%Days | If the marker is a time range this token will represent the days between the high and low time values.
Identification
%Name | The name of this axis marker.

Show ScaleRange Tokens

Describes a ScaleRange object. These tokens can be used with Axis.Label to describe the axis range.

Values
Token | Description
%Low | The low value of this axis marker
%High | The high value of this axis marker.
%Range | The range of this marker.
%Minutes | If the marker is a time range this token will represent the minutes between the high and low time values.
%Hours | If the marker is a time range this token will represent the hours between the high and low time values.
%Days | If the marker is a time range this token will represent the days between the high and low time values.

Show AxisTick Tokens

Axis ticks use different tokens depending on the situation.

  • If the axis tick comes from an element (Element.X/YAxisTick) then use Element Tokens.
  • If the axis tick is part of a category axis it use either Element Group or Series Tokens.
  • If the axis tick is part of a value axis use the token '%Value' and if it's a range tick, ScaleRange Tokens apply.
  • If the axis tick is part of an axis marker, use ScaleRange Tokens.

See also: Chart Labels


Formatting Values

Formatting Basics

Axes host the main format settings for themselves and related values on a chart. This means the the Y axis format string setting will affect the element's y value format in a string. The axis properties associated with formatting are Axis.FormatString and Axis.CultureName.

FormatString

The FormatString property uses the .net string format specifications to parse values.

For more information on using format strings see:

  • Standard Numeric Format Strings
  • Custom Numeric Format Strings
  • Standard DateTime Format Strings
  • Custom DateTime Format Strings
  • Formatting types

Additional shortcuts and custom format strings are also available:

Shortcuts
• 'Currency'
Formats numeric values based on the currency of the machines current or specified culture.
• 'N:x'
 Shorthand format where 'x' specifies the number of decimal places for numeric values. i.e: 'N:2'

Custom Format Strings
• 'Q'
 With dates, 'q' will represent the quarter. For example: "Quarter: <%Value,q>"

• 'O' (Numeric Values)
 An ordinal number. Adds a suffix to numbers for example: 1st 2nd 3rd etc.

• 'O' (DateTime Values)
 Day as an ordinal number. 1st 2nd 3rd etc.

[C#]

Chart.DefaultAxis.FormatString = "Currency";

[Visual Basic]
Chart.DefaultAxis.FormatString = "Currency"

Sample Settings:
{n:0}
Result: 140 (Number)

d
Result: 1/2/2005 (Date)

CultureName

The CultureName property accepts names from this list . It is used to automatically determine the type of formatting used for numbers or dates by the specified culture and format values accordingly.

[C#]

Chart.DefaultDefaultAxis.CultureName = "en-US";

[Visual Basic]

Chart.DefaultDefaultAxis.CultureName = "en-US"
Note: By default, the server's culture setting is used.

Element Value Formats

Element values on a chart are formatted based on the format settings of the axis related to the value used. This means that an element's YValue format will be based on the y axis and XValue based on the x axis format.

Assuming we have a chart where the x axis is time and y axis is numeric, the following code would properly format the element values.

[C#]

Chart.XAxis.FormatString = "d"; // A date format
Chart.YAxis.FormatString = "{n:0}"; // A numeric format

[Visual Basic]

Chart.XAxis.FormatString = "d" ' A date format
Chart.YAxis.FormatString = "{n:0}" ' A numeric format

Whenever an element or series value is used with multiple x or y axes, the format will be determined by the parent series axis.

Tips

  • Format settings are generally not required; .netCHARTING can automatically determine a suitable format for your data.
See Also

Tutorials: Formatting Advanced


Formatting Advanced

Advanced Formatting

DataEngine
When the data engine generates elements to be used in conjunction with category x axes* the element x values, despite being numeric or time based, are placed in the element.Name property as strings. To specify a format used in this process DataEngine.FormatString and DataEngine.CultureName are used.

* As opposed to a true numeric or time axis scales, category axes show elements by their name.

Note: To bypass using element names and use the actual x values you can specify "XValue=__" in the dataEngine's DataFields property instead of "XAxis=___";

Embedded in Tokens

This section demonstrates how to use different formatting in labels so they dont use the axis format.

All values shown in a chart are based on a label template string which uses tokens that specify which element value to show. For example a regular combo chart shows y values for each element and this can be specified using the following code:

Elements show values when Chart.DefaultSeries.DefaultElement.ShowValue = true
[C#]

Chart.DefaultSeries.DefaultElement.SmartLabel.Text = "%YValue";

[Visual Basic]

Chart.DefaultSeries.DefaultElement.SmartLabel.Text = "%YValue"

To imbed format strings within the element's label template, the following syntax is used:
<Token,Format>

Example element templates:

Template Text | Result
<%YValue,Currency> | $500.00
(<%YValue,Currency>, <%XValue,d>) | ($500.00, 11/18/2004)

Example: The following code will specify a currency format for the default element label template.

[C#]
Chart.DefaultSeries.DefaultElement.SmartLabel.Text = "<%YValue,Currency>";

[Visual Basic]
Chart.DefaultSeries.DefaultElement.SmartLabel.Text = "<%YValue,Currency>"

This will format the labels on the chartArea as currency but not in other places like the legend box.

For a complete list of possible tokens see: Tokens

For a reference of how to access different label on a chart see Using Labels

Advanced Axis Formatting

The axis also provides some additional settings that influence the axis format.

Percent
Setting Axis.Percent = true will format axis tick labels as percentages (in addition to snapping the scales maximum value to 100%)

Decimal Places

A shortcut for setting the number of decimals for axis formats is to specify it with the Axis.NumberPrecision property.

Format strings that specify decimal spaces override this setting.
[C#]

Chart.YAxis.NumberPrecision = 2;

[Visual Basic]

Chart.YAxis.NumberPrecision = 2


Chart Surface Objects

This section is contains a collection of tutorials describing the functionality and manipulation of objects that appear on a chart image such as a legend box or chart area.

  • Multiple Chart Areas
    How to use and manipulate multiple chart areas on a single image.
  • Box Tutorial
    Basic box features. Box is the base object of annotations, legend boxes and title boxes.
  • Legend Tutorial
    How to use basic legend features.
    • Advanced
      Advanced legend features.
  • Data Sources
    Data sources used for label tokens and populating custom legend boxes.


Multiple Chart Areas

The Concept

Multiple ChartAreas are a 'smart' feature, hence, the concept here is to have the chart engine do the thinking for you. All you have to do is create some series, specify which axes you want them to use, and which chart areas the series should be placed in. Then the chart engine will take over and lay out the chart areas based on the axis relationships between your series. The 'Layout' section will demonstrate this smart behavior.

Another approach is to specify the axes for chart areas instead of series, in which case the series will acquire the axes of the chart areas they are placed in.

Main / Default Chart Area

Every chart starts with the main chart area. It is referenced through Chart.ChartArea. Properties such as Chart.TitleBox and Chart.LegendBox refer to this area’s title and legend boxes so using Chart.ChartArea.TitleBox and Chart.ChartArea.LegendBox will have the same effect as the two previous properties. They are there simply as shortcuts. There is also a default chart area [Chart.DefaultChartArea]. Even though it is the same object as the main area, it is not used in the same manner. This object provides a vehicle for properties that will propagate to all other chart areas on a chart image automatically. If you would like to set a standard background color of all the chart areas quickly, you would set it through DefaultChartArea.

Adding Areas

Adding chart areas is simple. One must be instantiated and then added to the chart’s ExtraChartAreas collection.

[C#]

ChartArea ca1 = new ChartArea();
Chart.ExtraChartAreas.Add(ca1);

[Visual Basic]

Dim ca1 As New ChartArea()
Chart.ExtraChartAreas.Add(ca1)

This of course will give you an empty chart area. To make use of it, it will also need data to display.

[C#]

ca1.SeriesCollection.Add(mySeries);

[Visual Basic]

ca1.SeriesCollection.Add(mySeries)

At this point you may end up with a chart that looks like this.

Sizing

These 2 charts will be laid out vertically for reasons we’ll get to in a moment. At this stage you can control the layout by specifying what percentage of the full height a particular chart area should occupy. We’ll set the second area’s height to 20%.

[C#]

ca1.HeightPercentage = 20;

[Visual Basic]

ca1.HeightPercentage = 20

This will draw the second chart area at 20% and the main chart area at 80% height.

If there were three or more areas the other two would equally divide up the remaining space.

Sample: features/ChartAreaSizing.aspx

Axis Relationships

This may be the most complex concept initially but it builds on top of series-axis relationships which you may already be familiar with.

Each new chart area you add will not automatically have x and y axis instances. These axes will be provided by the series added to chart areas and since by default all series use the main x and y axis pair, all areas will share the same x and y axis pair. In the 'Adding Areas' section above you can clearly see that the x axis is shared and so it the y axis, however, it is drawn twice and even though it's the same axis, by default the scale will not remain the same. On the other hand, if the same axis is drawn once across multiple areas like the x axis in the above example then obviously the scale will remain the same.

To preserve the axis scale when it is redrawn, you must set the Axis.SynchronizeScale.PreserveScale property to true.

[C#]

Chart.YAxis.SynchronizeScale.PreserveScale = true;
[Visual Basic]

Chart.YAxis.SynchronizeScale.PreserveScale = True

One way to visualize the axis sharing concept is to pretend the two series are in a single combo chart area, you then make a carbon copy of the chart and erase one of the series from each area.

Setting a property for a new chart area's axis will instantiate a new axis for the area.

So doing:
myChartArea.YAxis.Label.Text = "New Axis";

will create a new axis for myChartArea and the series within it will inherit this new y axis unless they have axes specified already.

Simple enough right?

Layout

If we take the example above but assign a new x axis, the chart areas will be positioned horizontally.

[C#]

ca1.XAxis = new Axis();

[Visual Basic]

ca1.XAxis = new Axis()

This happens because .netCHARTING automatically tries to position chart areas based on axis relationships. In the first example both x and y axes were the same but only the x axis was drawn once across both areas. Because the axis cant be in two places at the same time, it is redrawn. The decision of which axes to draw only once was based on the setting:

[C#]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.VerticalPriority;

[Visual Basic]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.VerticalPriority

This is the default behavior. If we prefer the areas use the y axis across both areas instead of x and without assigning a new axis to the chart area, the following setting can be used:

[C#]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.HorizontalPriority;

[Visual Basic]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.HorizontalPriority

Now that we’re getting the hang of using chart areas and positioning them, let’s further explore this functionality .

Say we want two Y axes on three chart areas. Area A will contain a single series with one y axis, area b, a series with the other y axis and area c will contain two series, each with one of the y axes.

Something like this:

Area A:
Series1.YAxis = YAxisOne
Area B:
Series2.YAxis = YAxisTwo
Area C:
Series3.YAxis = YAxisOne
Series4.YAxis = YAxisTwo

The Code:

[C#]

SeriesCollection mySC = [….];
Axis a1 = new Axis();
Axis a2 = new Axis();

a1.DefaultTick.GridLine.Color = Color.Orange;
a1.Orientation = Orientation.Right;
a2.DefaultTick.GridLine.Color = Color.Green;
ChartArea ca1 = new ChartArea();
ChartArea ca2 = new ChartArea();
ca1.SeriesCollection.Add(mySC[0]);
ca2.SeriesCollection.Add(mySC[2], mySC[3]);

Chart.SeriesCollection.Add(mySC[1]);

mySC[0].YAxis = a1;
mySC[1].YAxis = a2;
mySC[2].YAxis = a1;
mySC[3].YAxis = a2;

[Visual Basic]

Dim mySC As [….] ' Some series collection
Dim a1 As New Axis()
Dim a2 As New Axis()

a1.DefaultTick.GridLine.Color = Color.Orange
a1.Orientation = Orientation.Right
a2.DefaultTick.GridLine.Color = Color.Green
Dim ca1 As New ChartArea()
Dim ca2 As New ChartArea()
ca1.SeriesCollection.Add(mySC(0))
ca2.SeriesCollection.Add(mySC(2), mySC(3))

Chart.SeriesCollection.Add(mySC(1))

mySC[0].YAxis = a1
mySC[1].YAxis = a
mySC[2].YAxis = a1
mySC[3].YAxis = a2
Sample: features/ChartAreaRelationships.aspx
Quick Note: The axis with orange grid lines was oriented on the right. If it were oriented to the left it would be placed on the left most area that uses it.
The y axes were given different grid line colors to illustrate where they are used. As you can see, the chart areas automatically placed the area that contains both axes in the middle so that no axis relationships are broken. This powerful feature can arrange areas in the best possible order no matter how complex your web of axis relationships get.

The logic behind the mechanism is as follows: Using HorizontalPriority, a group of charts is put together based on their y axis relationships and placed on the first row. Then another group of y axis related areas is placed in the next row, however, they are re-arranged to maintain the maximum x axis relationships between chart areas. So while horizontal relationships are the priority, smart logic is also involved in vertical axis relationships.

Let's go a step further, say we want another chart area with an x axis that is shared with the x axis of the middle area. We will do this by adding the area, instantiating a new x axis for it and setting the same x axis for the existing middle chart area (ca2). We could also assign the new x axis to both the series in the middle area but this way is quicker and achieves the same result.
[C#]

ChartArea ca3 = new ChartArea();
ca3.SeriesCollection.Add(mySC[4]);
ca3.XAxis = new Axis();
ca2.XAxis = ca3.XAxis;
[Visual Basic]

ChartArea ca3 = new ChartArea();
ca3.SeriesCollection.Add(mySC[4]);
ca3.XAxis = new Axis();
ca2.XAxis = ca3.XAxis;
Output:

As you can see, the areas are laid out correctly based on the axis relationships we specified.

Other modes include:

  • HorizontalSmart
  • VerticalSmart

These are similar to their ‘priority’ counterparts. The layout logic is still in use; however, all areas will be placed in a single row or column respectively.

The last mode, Custom, provides full control of chart area positioning.

[C#]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.Custom;
ChartArea.GridPosition = new Point(0,0);
ChartArea2.GridPosition = new Point(0,1);

[Visual Basic]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.Custom;
ChartArea.GridPosition = new Point(0,0)
ChartArea2.GridPosition = new Point(0,1)

Sample: features/ChartAreaCustomLayout.aspx

This system is a new concept in the charting world. To get the most out of try not to focus on the chart area layout but on the data you're charting and the chart engine will do the rest. If you stumble upon an ingenious way of using this system please let us know. We would love to hear about it and share your achievements with the masses.

Personal Legend boxes

See: LegendBox Advanced Tutorial


Box Tutorial

Default Box

A Box object is the foundation (base class) of box like objects such as annotations, legendBoxes, and title boxes. The chart control has a DefaultBox property that is a container for box properties that will be propagated to all other objects on the chart that derive from Box including annotations, legends, and title boxes.

Example: This code will make all box shadows red.

[C#]

Chart.DefaultBox.Shadow.Color = Red;

[Visual Basic]

Chart.DefaultBox.Shadow.Color = Red

Styling

Box styling consists of a background, the outline (Line) and corner types.

Background

A box'es background is accessed through its Background property, which contains properties that effect the background's visual appearance:

Box.Background.__ = __

Example: The following code sample changes the box'es background color to red.

[C#]
Box.Background.Color = Color.Red;
[Visual Basic]
Box.Background.Color = Color.Red;

See the Background class for more information.

Shadow

The shadow a box casts can also be modified. Options include color, depth, and whether the shadow is solid or soft, meaning, the edges are blurred for added realism.

[C#]

Box.Shadow.Color = Color.Orange;

[Visual Basic]

Box.Shadow.Color = Color.Orange

Outline

A Line object is used to draw the outline of a box. This enables you to specify many visual properties such as line width, color, and dash style.

Example: Changes the outline dash style.

[C#]

Box.Outline.DashStyle = DashStyle.Dash;

[Visual Basic]

Box.Outline.DashStyle = DashStyle.Dash

See also: Line Class, Chart Lines

Corners

Each of the four corners of a box can be individually styled. This code demonstrates how to specify a rounded top left corner.

[C#]

Box.CornerTopLeft = BoxCorner.Round;
[Visual Basic]

Box.CornerTopLeft = BoxCorner.Round

All four corners can be automatically set using the DefaultCorner property. This will also change the property value of each individual corner.

[C#]

Box.DefaultCorner = BoxCorner.Cut;

[Visual Basic]

Box.DefaultCorner = BoxCorner.Cut
Tip: Today's styling trends dictate the using a unique corner on opposite ends of a box while keeping the adjacent corners intact is visually pleasing. For Example TopLeft:Cut and BottomRight: Cut while TopRight and BottomLeft setting is: Box.

Padding

The padding property specifies the distance form the box edges to it's content similar to HTML cell padding. The legendBox, which inherits from Box also uses the padding property to determine spacing between legend entries.

[C#]

Box.Padding = 5;

[Visual Basic]

Box.Padding = 5
Note: Custom corners do not effect a box'es padding, hence, additional padding may be required when content is to close to a styled corner like BoxCorner.Cut.


LegendBox Tutorial Basic

Styling

Before proceeding, see the Box tutorial for basic styling options.

Fonts:
A legend entry's font can be defined by specifying a default font for all entries.

[C#]
Chart.LegendBox.DefaultEntry.LabelStyle.Font = new Font("Verdana",8);

[Visual Basic]
Chart.LegendBox.DefaultEntry.LabelStyle.Font = New Font("Verdana",8)

See also: Using Fonts

Colors:
Font colors can also be specified in a similar manner:

[C#]
Chart.LegendBox.DefaultEntry.LabelStyle.Color = Color.Black;

[Visual Basic]
Chart.LegendBox.DefaultEntry.LabelStyle.Color = Color.Black

See also: Using Colors

Template

The basic columns of a legend are Name, Value, and Icon. They are represented in the Template property as tokens. The Template property allows reordering and exclusion of any particular column.

Example: The following code reorders legend columns.

[C#]
Chart.LegendBox.Template = "%Icon%Value%Name";

[Visual Basic]
Chart.LegendBox.Template = "%Icon%Value%Name"

Example: The following code excludes the icon column.

[C#]

Chart.LegendBox.Template = "%Value%Name";
[Visual Basic]
Chart.LegendBox.Template = "%Value%Name"

Positioning

Orientation
To position a legend box, the LegendBox.Position or LegendBox.Orientation properties must be defined.

[C#]

LegendBox.Orientation = Orientation.BottomLeft;
[Visual Basic]
LegendBox.Orientation = Orientation.BottomLeft

The position property is an object type and accepts a legacy LegendBoxPosition enumeration or a Point object, which specifies the absolute position in pixels.

Tip:Using LegendBoxPosition is not recommended because Orientation has more options.
[C#]

LegendBox.Position = LegendBoxPosition.Bottom;
[Visual Basic]

LegendBox.Position = LegendBoxPosition.Bottom

Absolute Position
Using a Point object will specify an absolute position. Other elements on a chart will not be affected by the position and the legend will overlap objects beneath it.
[C#]

LegendBox.Position = new Point(200,20);
[Visual Basic]

LegendBox.Position = New Point(200,20)

Tip: When using an absolute position, it is useful to set a transparency for the box'es background color so underlying objects can still be seen if necessary.

In Title box
Another useful option is to completely eliminate the legend box and move the entries into the title box. To accomplish this, a title box position FullWithLegend is used.

[C#]
Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend;
[Visual Basic]
Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend

Note: The entries in a title box are positioned opposite to the alignment of the title (TitleBox.Label.Alignment). If the title is right-aligned the entries will position themselves on the left side of the title box.

Invisible Legend
To completely eliminate the legend from a chart set the Visibility of the legend to false.

[C#]
Chart.LegendBox.Visible = false;
[Visual Basic]
Chart.LegendBox.Visible = False

Legend Entries

Manipulating the content
Entries in a legend are for most cases generated to represent each series. However, if a Series.Palette or PaletteName is specified, each element in that series will automatically insert its entry into the legend. Legend entries specific to each series and element can be accessed through their parent object. For example, an element's legend entry is accessed through:

myElement.LegendEntry.__ = __

AxisMarker objects used with axes or elements are also automatically inserted into the legend and their entries are accessed through:

myAxisMarker.LegendEntry.__ = __

To prevent an axis marker from entering into the legend, the entry's visibility can be turned off:
[C#]

myAxisMarker.LegendEntry.Visible = false;
[Visual Basic]
myAxisMarker.LegendEntry.Visible = False

To exclude the all series entries from a legend box the following code can be used:
[C#]

Chart.DefaultSeries.LegendEntry.Visible = false;
[Visual Basic]
Chart.DefaultSeries.LegendEntry.Visible = False

Custom Entries
Custom entries can be added to the legend by instantiating and adding them to the ExtraEntries property of a LegendBox.
[C#]

LegendEntry myEntry = new LegendEntry();
myEntry.Name = "CustomName";
myEntry.Value = "CustomValue;
Chart.LegendBox.ExtraEntries.Add(myEntry);
[Visual Basic]

Dim myEntry As New LegendEntry()
myEntry.Name = "CustomName"
myEntry.Value = "CustomValue
Chart.LegendBox.ExtraEntries.Add(myEntry)

Header Entry
Each legend has a ready made header entry. These are used to describe the columns of your legend. The header entry is activated by setting the Visible property.
[C#]

LegendBox.HeaderEntry.Visible = true;
[Visual Basic]

LegendBox.HeaderEntry.Visible = true

Header text can be modified with the traditional text properties.
LegendBox.HeaderEntry.Name = "Series Name";

To change the icon text a custom attribute must be used
[C#]

LegendBox.HeaderEntry.CustomAttributes = "Icon=Icon Header";

[Visual Basic]

LegendBox.HeaderEntry.CustomAttributes.Add("Icon","Icon Header")

Attributes will be covered further in the advanced tutorial.

More Tips:
Using your own entries.
• In some cases, it is required to use your own custom entries instead of the default ones. The best way to accomplish this is to set Chart.DefaultSeries.LegendEntry.Visible = false; and add your entries as shown above.
• Moving entries to the title box may save valuable space when there are few series and chart sizes are small.

The features covered in this tutorial are the most common but only scratch the capability surface of LegendBox objects.

For more advanced features go on to the advanced tutorial.

See Also

Tutorials: LegendBox Advanced | Box Tutorial


LegendBox Advanced

Introduction

The .netCHARTING legend box is more than just a list of icon-name pairs. It is equipped with template functionality that can detail your data in a grid style form and offers many options that will allow you to modify the box as much as you need.

Legend Positions & Layout

The legend can be positioned in three different ways. It can be placed anywhere around the chart plot areas, inside the title box along with the chart title, and it can be positioned at a specified x,y or absolute position.

Around the plot chart areas
The traditional way to position the boxes used this syntax

[C#]

Chart.LegendBox.Position = LegendBoxPosition.Top;

[Visual Basic]

Chart.LegendBox.Position = LegendBoxPosition.Top

This would specify the box is placed in the upper right corner around the plot area. A more flexible setting is also available, the equivalent of the above is:

[C#]

Chart.LegendBox.Orientation = Orientation.TopRight;

[Visual Basic]

Chart.LegendBox.Orientation = Orientation.TopRight

Orientation exposes all corners and sides available for positioning.

Absolute Positioning

The legend can be placed at any specified x,y position using the same LegendBox.Position property.

[C#]

Chart.LegendBox.Position = new Position(20,20);

[Visual Basic]

Chart.LegendBox.Position = New Position(20,20)

When this method is used, the other object on the chart will not move away to make room for the legend box, however, it may be desirable to place the legend within a ChartArea in some circumstances.

Sample: features/LegendBoxAbsolute.aspx

In the title box

A legend can be placed in the title of a chart area by specifying to the title box that it should display the legend within it.

[C#]

Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend;

[Visual Basic]

Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend

When the legend entries are shown in the title box further positioning features are available. By specifying the title alignment, the legend entries will position themselves to compliment the new title’s layout.

[C#]

Chart.TitleBox.Label.Alignment = StringAlignment.Center;

[Visual Basic]

Chart.TitleBox.Label.Alignment = StringAlignment.Center

The above line will center the title in response, the legend entries will center beneath it.

NOTE: When a legend is shown in the title box, its properties are still controlled through the LegendBox object.
Sample: features/LegendBoxTitle.aspx

Layout Behavior
When a legend box is located on the left or right side of a chart the default layout will yield a single column legend if it fits. With multiple legends on one side they will be stacked. This means that if a single column configuration will not fit vertically, the legends will try to increase the number of columns to fit all the entries.

Legends positioned on top and bottom will by default create multiple columns to allow the maximum vertical space for a chart.

In either arrangement, entries will list top to bottom. This behavior can be changed by setting LegendBox.ListTopToBottom to false. This setting will list the entries left to right across columns.

Multiple Chart Areas and Legends

Main Chart Area
Every chart area has its own legend box (ChartArea.LegendBox) , however, it is not visible by default. When this is the case the chart area’s series entries are placed in the main chart legend box (Chart.LegendBox). In Figure 1, chart areas B and D send series to the main legend box. This is the default behavior.

Figure 1: Illustrates how series of a particular chart area bind to legend boxes and the default legend box settings.

Personal Chart Area Legends
A chart area can place its series in a personal legend box by instantiating a legendBox object and specifying it to the chart area's LegendBox property (Figure 1: Chart Area C). A Chart area can also place its series legend entries into the title box by setting its title box's position to TitleBoxPosition.FullWithLegend (Figure 1: Chart Area A).

[C#]

ChartAreaA.TitleBox.Position = TitleBoxPosition.FullWithLegend;

[Visual Basic]

ChartAreaA.TitleBox.Position = TitleBoxPosition.FullWithLegend
Sample: features/LegendBoxMultiple.aspx

Custom Legend Boxes
Custom legend box instances can also be added to the Chart.ExtraLegendBoxes collection. Custom entries can be added and data sources specified to populate your custom boxes.

[C#]

Chart.ExtraLegendBoxes.Add(new LegendBox());

[Visual Basic]

Chart.ExtraLegendBoxes.Add(New LegendBox())
Sample: features/LegendBoxCustom.aspx

Default Legend Box
The default legend box (Chart.DefaultLegendBox) does not appear anywhere chart image but is used to quickly specify settings all boxes appearing on chart will acquire. (Figure 1: Custom LegendBox)

The Legend Box

Legend Template

The LegendBox.Template property takes a series of tokens which define the columns of each entry. These tokens can be tokens specific to the object the entry represents or properties of the legend entry (Name, Value, and Icon).

Consider the following code.

[C#]
SeriesA.DefaultElement.CustomAttributes.Add("SeriesDescription","Data Provided by Group A.");

Chart.LegendBox.DefaultEntry.CustomAttributes.Add("EntryCustom","(Max: /%Maximum Min: /%Minimum)");

Chart.LegendBox.Template = "%Name%Icon%Value%EntryCustom%SeriesDescription%YAverage";

[Visual Basic]
SeriesA.DefaultElement.CustomAttributes.Add("SeriesDescription","Data Provided by Group A.")
Chart.LegendBox.DefaultEntry.CustomAttributes.Add("EntryCustom","(Max: %Maximum %Min: %Minimum)")
Chart.LegendBox.Template = "%Name%Icon%Value%EntryCustom%SeriesDescription%YAverage"

We add a custom attribute to a series which we want to end up in the chart’s legend box. Next we add a custom attribute named “EntryCustom” to the legend’s default entry which will propagate it to all the entries in the legend. Finally, we specify a series of tokens for the legend columns.

The following Table shows the path of each column value when the legend is rendered.

LegendBox. Template | %Name | %Icon | %Value | %EntryCustom | %SeriesDescription | %YAverage
LegendEntry source | LE.Name | LE.Marker | LE.Value | LE.CustomAttributes ("EntryCustom") | Because these tokens don't apply to any legend entry source they will be passed down to the data source.
LegendEntry value/result | %Name | LE.Marker | %YSum | (Max: %Maximum Min: %Minimum)
Series source | Series.Name | (Settings contribute to final legend entry marker) | Series Calculation | Series Calculation | Series.DefaultElement. CustomAttributes ("SeriesDescription") | Series Calculation
Final Result | Group A | LE.Marker | 503 | (Max: 40 Min: 2) | Data Provided by Group A. | 34

Table 1: Describes the path of tokens specified in LegendBox.Template

  1. First the legend box column template is examined.
  2. Next it looks at a particular legend entry for matches. The token values our legend entry can provide are %Name %Icon %Value and %custom where custom is the name of an entry’s custom attribute. We added this in the second line of the above sample.
  3. Finally the series or another object the entry represents is examined for column token matches. In this case %YAverage is a token associated with all series and %SeriesDescription a custom series attribute we added in the code above.
  4. Note: LegendBox.Template can only accept tokens. Other text and characters will be ignored.

Sample: features/LegendBoxCustom.aspx

The Legend Entry

Default Entry
The legend box contains a default legend entry LegendBox.DefaultEntry property. The setting of this entry will propagate to all entries that end up in the legend box. The exception is when a setting is explicitly set for any given entry, in that case the default entry setting will be ignored.

Custom Entries ( ExtraEntries )
Custom legend entries can be created and added to any legend. These may serve as headers or additional info you need to specify.

Custom Attributes
Legend entries contain a collection of for custom attributes which can be used to specify further tokens to use with custom legend box column tokens. Or in a case of custom entries in a box with series entries , because the entry doesn't represent a series, custom attributes can fill in the blanks. For example (“%YSum”,”n/a”).

Sample: features/LegendBoxCustom.aspx

Header specific features
Legend entries are also designed to serve as headers. To add a header to a legend box let's start with creating an entry and specify the header text. The legend sample in "The Legend" section will be the assumed legend we're working with.

[C#]

LegendEntry leHeader = new LegendEntry();
le.Header.Name = “Name”;
le.Header.Value = “Sum”;

[Visual Basic]

Dim leHeader As New LegendEntry()
le.Header.Name = “Name”
le.Header.Value = “Sum”

To specify labels for all the other column tokens they must be added to custom attributes.

[C#]
Le.CustomAttributes.Add(“%EntryCustom”,” Data Range”);
Le.CustomAttributes.Add(“%SeriesDescription”,” Description”);
Le.CustomAttributes.Add(“%YAverage”,”Average”);

[Visual Basic]
Le.CustomAttributes.Add(“%EntryCustom”,” Data Range”)
Le.CustomAttributes.Add(“%SeriesDescription”,” Description”)
Le.CustomAttributes.Add(“%YAverage”,”Average”)

We will also want to use text instead of the entry’s marker for the icon column. This can be achieved by specifying the following custom attribute:

[C#]

Le.CustomAttribute(“%Icon”,”Icon”);

[Visual Basic]

Le.CustomAttribute(“%Icon”,”Icon”)

SortOrder
The header column should be at the top of the legend. This can be done by specifying a sort order for the header entry and all other entries.

[C#]

Le.SortOrder = 0;
LegendBox.DefaultEntry.SortOrder = 1;

[Visual Basic]

Le.SortOrder = 0
LegendBox.DefaultEntry.SortOrder = 1

This will ensure the header entry with the sort order of 0 will appear before all other entries which have the sort order value of 1.

Header Mode
Another way to ensure the header appears at the top is to specify the RepeatOnEachColumn header mode.

[C#]

Le.HeaderMode = LegendEntryHeaderMode.RepeatOnEachColumn;

[Visual Basic]

Le.HeaderMode = LegendEntryHeaderMode.RepeatOnEachColumn

As the name suggests, if the legend splits into multiple columns, this entry will be repeated at the top of each.

Another useful mode is StartNewColumn, when headers are used to group entries in a multi column legend. This mode will allow each group to be placed in separate columns. Such a configuration may make the legend easier to read.

The default mode of all entries is None and doesn’t change the entry behavior.

Divider Line
Up to this point our header doesn’t stand out in any way to indicate it is one. One way to emphasize it is by specifying a DividerLine color.

[C#]
Le.DividerLine.Color = Color.Black;

[Visual Basic]
Le.DividerLine.Color = Color.Black

This line will be drawn beneath the header entry. An extra layer of padding will be added to separate the entry and the next entry evenly from this line.

Top Padding
Single column legends that contain multiple entry groups with headers should use additional padding above each header. This will improve the visual separation of each group.

[C#]

Le.TopPadding = 5;

[Visual Basic]

Le.TopPadding = 5

The following section will demonstrate more options that may improve your headers.

Sample: features/LegendBoxHeader.aspx

Styling
The header features section describes several styling features. Here we expand on this and tie up some loose ends.

The most fundamental legend entry styling customization is found in the LegendEntry.LabelStyle property. It allows you to set the font, its size, style and color. All entries can be affected by setting the LegendBox.DefaultEntry.LabelStyle property or each individual entry can be customized separately..

[C#]

Le.LabelStyle.Font  = new Font("Verdana",9);
Le.LabelStyle.Color = Color.Green;

[Visual Basic]

Le.LabelStyle.Font  = New Font("Verdana",9)
Le.LabelStyle.Color = Color.Green

Padding
The Box object which LegendBox inherits from contains a padding property. Legend boxes use this property to space entries.

Icon
A legend entry’s icon can be manipulated by a number of its properties. These include

  • Use3D
  • SeriesType
  • Marker
  • DashStyle
  • Background

These properties specify the kind of chart element the entry icon is representing. For example, setting SeriesType.Marker gives full control of the icon to the LegendEntry.Marker property.

Now an image can be used instead of the pre defined markers.

NOTE: When an image marker is drawn in the legend it’s size will be limited to twice the height of the entry’s font height. If larger, it will be scaled down. Alternatively a Marker.Size value can be specified.

Populating Legends with Entries Automatically

See: DataSource Tutorial

Tips & Tricks

  • Entry as a spacer
    An empty entry may be used to separate groups of header entries.
  • Divider Line Style
    Specifying a divider line with a subtle color for the default entry can create a cool effect by dividing each entry. Lowering the padding can bring the entries closer together which may look even better.
  • Control columns
    By adding entries with HeaderMode.StartNewColumn the columns can be controlled.


Data Sources

Introduction

The DataSource class behaves like a container for chart objects such as Series, AxisMarkers and others to provide dynamic information needed to parse tokens or populate a legend box with entries. The type of data stored in the data source will determine what type of tokens will be replaced in a string.

The class does not relate to database or any other types data sources used to populate charts.

  • Show Supported DataSource Types

    • Element
    • Element Group ( Elements grouped by name )
    • Series
    • SeriesCollection
    • AxisMarker
    • ScaleRange

Creating DataSources

Creating a DataSource
The following code instantiates a data source containing a series collection.

[C#]
LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection);

[Visual Basic]
LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection)

The DataSource class also provides implicit casts that alleviate the need to instantiate a DataSource object.

[C#]

LegendEntry.DataSource = mySeriesCollection;
This feature is not supported in VB.Net

Sample: features/AnnotationDataSource.aspx

Complex DataSources
A DataSource object can contain additional information to properly parse tokens. This information specifies the relationships of SeriesCollections to Series and to Element objects. Specifically, what element is in which series and what SeriesCollection contains that Series. For example, to specify an element with relationships to it's parents, the following code can be used:

[C#]

LegendEntry.DataSource = DataSource.FromElement(mySeriesCollection,1,2);

[Visual Basic]

LegendEntry.DataSource = DataSource.FromElement(mySeriesCollection,1,2)

The parameters of this static constructor are: (Parent SeriesCollection, parent series index in the SeriesCollection, element Index in Series)

The specific reason the token parser may use additional information about an element is so that tokens such as '%PercentOfSeries' can be correctly calculated based on the values of the complete series. If these tokens are not needed a much simpler way to specify an element is by using the implicit cast functionality of DataSource. Simply put, to just specify the element itself (C# Only):

[C#]

LegendEntry.DataSource = myElement;

In VB.Net you can specify the element using a static constructor
[Visual Basic]
LegendEntry.DataSource = DataSource.FromElement(myElement);

Using DataSources

Populating LegendBoxes

The DataSource class can also quickly populate a legend with entries by setting the LegendBox.DataSource property.

Example: This code will populate the legend entry with series entries in a SeriseCollection.
[C#]

LegendBox.DataSource = mySeriesColleciton;
// or
LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection);

[Visual Basic]

LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection)

There is however more flexibility available. The type of legend entries generated can also be specified. The series collection can be split into legend entries for each series, each element, or each element group. This option is defined by the DataSource.SplitInto property.
[C#]

LegendBox.DataSource = mySeriesColleciton;
LegendBox.DataSoruce.SplitInto = DataSourceType.ElementGroup;

// Or it can be specified in the static constructor:
LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection,DataSourceType.ElementGroup);

[Visual Basic]

' Specified in the static constructor:
LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection,DataSourceType.ElementGroup)

This functionality will enable you to show different and valuable information about your data in the same chart.

This table shows what splits are available for each data source type.

  Show This table shows what splits are available for each data source type.

SeriesCollection

  • Series
    •

  • Element Groups
    •

  • Elements

Series

  • Elements

Element Group

  • Series
    •

  • Elements

Element

  • None

Axis Marker

  • None

Scale Range

  • None

Sample: features/LegendBoxDataSource.aspx

LegendEntry DataSource

Each legend entry can have a data source which is specified through the LegendEntry.DataSource property.

Annotation DataSource

Custom annotations can take data sources to process tokens in their labels.

Sample: features/AnnotationDataSource.aspx


Axis Tutorials

This section is contains a collection of tutorials describing functionality and the many features of axes.

  • Axis Scales
    How different scales behave and how to manipulate them.
    • Scale Synchronization
      How axes can synchronize scales with other axes.
    • Elements & Axis Scales
      How element values determine axis scales.
  • Axis Ticks
    Using and manipulating axis ticks.
    • Minor Ticks
      Using minor axis ticks.
    • Axis Time Label Automation
      Using smart time label automation features.
    • Calculated Axis Ticks
      Automatically add axis ticks based on a calculated value.
  • Axis Markers
    Using and manipulating axis markers.
  • Multiple Axes
    Working with multiple axes.
    • Calculated Axes
      Using calculated axes to show data in different contexts.


Axis Scales

Axis Scales

Introduction
This section will describe the following:

  • Scale Types
    What the different axis scales offer.
  • Intervals
    Controlling numeric and time tick intervals.
  • Scale Range
    Controlling the axis scale start, end, and range.
  • Scale Breaks
    Using scale breaks.
  • Scale Influentials
    Allow axis markers and custom axis tick to influence axis scale ranges.

Scale Types

Axis scales dictate more than just the values on an axis. They also specify element behavior such as stacked, or FullStacked. The options for the Scale enumeration include:

  • Normal
  • Range
  • Logarithmic
  • Time
  • Stacked
  • FullStacked
  • LogarithmicStacked

Between numeric and time scales, .netCHARTING will automatically set the appropriate scale so it does not always need to be specified explicitly. Scales such as Stacked or FullStacked only apply to axes on which the element y values are plotted because these are the values that are stacked. For example with a combo chart, the Chart.YAxis would be the one to specify a stacked scale.

Other properties that control the scale include:

  • LogarithmicBase
    specifies the logarithmic base of intervals.
  • Percent
    A '%' sign will be added to the end of tick labels and the axis maximum will snap to 100% if the plotted data's range falls between 50 and 100.
  • InvertScale
    reverses the sequence of a scale.

Intervals

Intervals come in two flavors, numeric, and time. The latter is more complicated so we’ll tackle numeric first.

Controlling the interval is a simple concept. You can specify a numeric interval using code such as:

[C#]

Chart.YAxis.Interval = 5;

[Visual Basic]

Chart.YAxis.Interval = 5

This will force an interval every at five numeric units. Other interval related properties include:

  • MinimumInterval
    Specifies the minimum numeric interval.
    TIP: This allows you to prevent the axis scale from using intervals that are smaller than a single unit of your data. For example a chart showing votes and the maximum number being 3 may show intervals at .5 which are not desired.
  • TickNumberMaximum
    Specifies the maximum number of ticks to generate.

Time interval

The basic time interval is controlled with the Axis.TimeInterval property

[C#]

Axis.TimeInterval = TimeInterval.Week;

[Visual Basic]

Axis.TimeInterval = TimeInterval.Week

Advanced time interval

Or can be more specific using the Axis.TimeIntervalAdvanced property.

Multiplier

Using the advanced time interval version allows you to specify an interval multiplier. For example we can have an interval every 4 days or 2 weeks etc.

[C#]

Axis.TimeIntervalAdvanced.Multiplier = 2;
[Visual Basic]

Axis.TimeIntervalAdvanced.Multiplier = 2

Custom time span

A completely custom time span can be used as a time interval.

[C#]

Axis.TimeIntervalAdvanced.TimeSpan = new TimeSpan(10,5,3);

[Visual Basic]

Axis.TimeIntervalAdvanced.TimeSpan = new TimeSpan(10,5,3)

Custom start time

An interval can also start at any given time. These times can be specified through the following properties:

  • StartMonth
    The month of year at which this interval initially occurs. Value ranges from zero indicating January, to eleven, indicating December.
  • StartDayOfWeek
    The day of the week at which this interval initially occurs. Value ranges from zero indicating Sunday, to six, indicating Saturday.
  • Start
    A DateTime object representing the time instant at which this interval initially occurs. The value of this DateTime structure can be specific down to the millisecond.

Ranges

The scale’s numeric and time boundaries can be specified using the Axis.ScaleRange property.

[C#]

Chart.YAxis.ScaleRange.ValueHigh = 100;
Chart.YAxis.ScaleRange.ValueLow = 2;
//Or
Chart.YAxis.ScaleRange.ValueHigh = new DateTime(2000,12,1);
Chart.YAxis.ScaleRange.ValueLow = new DateTime(2000,1,1);

[Visual Basic]

Chart.YAxis.ScaleRange.ValueHigh = 100
Chart.YAxis.ScaleRange.ValueLow = 2
'Or
Chart.YAxis.ScaleRange.ValueHigh = New DateTime(2000,12,1)
Chart.YAxis.ScaleRange.ValueLow = New DateTime(2000,1,1)

Providing a single high or low value without its counterpart is also permitted.

[C#]

YAxis.ScaleRange.ValueLow = 2;

[Visual Basic]

YAxis.ScaleRange.ValueLow = 2;
Note: Numeric intervals start at zero, therefore, if the minimum value doesn’t land on an interval there may be a gap between the scale’s edge and the first axis tick.

Time scales can be padded with an equal amount of time on either side of the plotted data to produce the final range. This is achieved using Axis.TimePadding.

[C#]

Chart.XAxis.TimePadding = TimeSpan.FromDays(10);

[Visual Basic]

Chart.XAxis.TimePadding = TimeSpan.FromDays(10)

Scale Breaks

Scale breaks are discontinuities in an axis' scale. They are useful in the following scenarios:

  • When there is a large difference between low and high element values.
  • When element value variations are much smaller than the scale range.
  • When specific days of a week should be excluded in the scale, for example, weekends are not needed in financial charts. Scale breaks can work with a calendar pattern in this case.
    Sample: features/AxisScaleBreakCalendarPattern.aspx

For the first case, the chart engine can automatically generate a scale break by setting Axis.SmartScaleBreak to true.

Sample: features/AxisScaleBreaks.aspx

Scale breaks are added manually like so:

[C#]

Axis.ScaleBreaks.Add( new ScaleRange(0,50) );
//Or for time:
Axis.ScaleBreaks.Add( new ScaleRange(new DateTime(2000,1,1), new DateTime(2000,12,1) ) );

[Visual Basic]

Axis.ScaleBreaks.Add( New ScaleRange(0,50) )
'Or for time:
Axis.ScaleBreaks.Add( New ScaleRange(New DateTime(2000,1,1), New DateTime(2000,12,1) ) )

Sample: features/AxisScaleBreaksManual.aspx

Scale Break Styles

A number of options are available to achieve the scale break style your charts require. The style can be set with the ScaleBreakStyle enumeration at the axis level as shown below.

[C#]

Chart.YAxis.ScaleBreakStyle = ScaleBreakStyle.ZigZag;
[Visual Basic]

Chart.YAxis.ScaleBreakStyle = ScaleBreakStyle.ZigZag;
Sample: features/AxisScaleBreakStyling.aspx

Scale Influentials
Objects that inherit from ScaleRange, such as AxisMarker and AxisTicks are able to influence the axis’ scale range. For instance, a chart showing bandwidth usage over a period of time with an axis marker representing the bandwidth limit may have elements that will never reach or even come close to the quota marker’s value. Because of this, the quota marker will not be visible on the chart; however, if AxisMarker.IncludeInAxisScale is true, the marker will tell the axis scale to encompass its value.

Objects that can influence axis scales are:

  • AxisMarker
  • AxisTick
Sample: features/AxisAffectScale.aspx


Scale Synchronization

Introduction

Multiple axes of the same type (numeric or time) and orientation (X or Y) can synchronize their scales in a number of ways. They can sync their entire scale, high or low values, and the origins. This is useful if you are using many axes on a single chart that need to sync or different axes throughout chart areas that need to stay on the same scale.

The usage is simple. Simply specify which axis you want another axis to sync with.

[C#]

Chart.YAxis.SynchronizeScale.Add(myNewAxis);
[Visual Basic]

Chart.YAxis.SynchronizeScale.Add(myNewAxis)

You can add as many axes to synchronize as you'd like. By default the entire scale will sync but if you would like to change this behavior you can specify a SynchronizeScaleMode enumeration.

[C#]

Chart.YAxis.SynchronizeScale.Mode = SynchronizeScaleMode.High;
[Visual Basic]

Chart.YAxis.SynchronizeScale.Mode = SynchronizeScaleMode.High

This will cause the axes to sync only the high values.

Synchronization Chain

This system also allows for complex sync chains. The above synchronizes the main y axis high value with the high value of myNewAxis. If you would like to synchronize the low value of myNewAxis with another axis you can do this also:

[C#]

myNewAxis.SynchronizeScale.Add(myOtherAxis);
myNewAxis.SynchronizeScale.Mode = SynchronizeScaleMode.Low;
[Visual Basic]

myNewAxis.SynchronizeScale.Add(myOtherAxis);
myNewAxis.SynchronizeScale.Mode = SynchronizeScaleMode.Low

This will result in different synchronizations between different axes.


Elements And Axis Scales

Introduction

While there are many options for scales, .netCHARTING can automatically determine the appropriate scales based on your data. This tutorial will demonstrate how element data influences axis scales.

The Y Axis ( value axis )

We will call this the y axis but by 'value axis' we don't literally mean (Y) axis. With ChartType.ComboHorizontal for instance we would be referring to the x axis. For all others however it is the y axis. The element values that influence this axis are

  • YValue
  • YValueStart
  • YDateTime
  • YDateTimeStart

The automatically chosen axis scales here are either Normal or Time. It is determined by whether the YValue (numeric) or YDateTime (time) values are specified for each element.

The following table shows value settings of these element properties that the chart engine will consider not set.

  • YValue & YValueStart
    Setting: double.NaN
  • YDateTime & YDateTimeStart
    Setting: DateTime.MinValue

The X Axis (Category / Value Axis)

Y Axis using ChartType.ComboHorizontal

The x axis is very powerful, it can operate just like the y axis value axis as well as a category axis. If the elements have names (Element.Name) specified, the axis scale will be a category scale. However, if the elements have either XValue or XDateTime properties set, the appropriate value axis scale will be chosen.

The element properties that influence the x axis type are:

  • Name
  • XValue
  • XValueStart
  • XDateTime
  • XDateTimeStart

Even if all numeric or time value are provided, setting one name of the elements will yield a category axis scale and values will become names.
The data engine will always provide elements with both, names and values if the names represent numeric or time values. By default this creates a category scale. To use a value scale instead, set the axis scale property to the appropriate scale.
Setting the scale through DefaultAxis.Scale will not produce the same result.
Another simple shortcut to force elements to use a value axis instead of their names is to set ChartType.Scatter but this will only provide a Combo chart type.
Smart Category Axis
A smart category axis scale is one that contains elements with names but where the names represent values. The 'smart' part will sequence the element names appropriately based on the values they represent.
To use this axis type you must use the DataEngine and specify 'XAxis=valueDBColumn' in its DataFields property.
See Also

Scale Enumeration | Scale Property

Tutorials: Data Field Mapping | Data Engine


Axis Ticks

Axis Ticks

Introduction
This section will describe the following:

  • Tick Types
    Different axis tick types.
  • Custom Ticks
    Using custom ticks and placing them at arbitrary positions.
  • String Tokens
    Using tokens in axis ticks to describe elements or tick values.
  • Tick Overrides
    Using ticks to override the properties of a single or multiple ticks.
  • Styling
    Ticks styling.
  • Tick Alignment
    Aligning tick labels with tick marks.

The AxisTick object encapsulates information such as its value, appearance, and grid properties. It can also be used to override a single or range of ticks on an axis.

The Axis.DefaultTick property offers a tick object that will propagate it’s settings to all ticks on the axis. This provides a method of applying settings to all axis ticks quickly.

Another axis tick property is Axis.ZeroTick. This is the axis tick that is added to each numeric axis at its origin (0). This tick can be disabled by setting the property to null.

[C#]

Chart.XAxis.ZeroTick = null;

[Visual Basic]

Chart.XAxis.ZeroTick = Null

Modes
An axis tick can contain a numeric or time value as well as a string value depending on the type of axis used.

Normal Axis Ticks

[C#]

AxisTick at = new AxisTick();
At.Value = 10;

[Visual Basic]

Dim at As New AxisTick()
At.Value = 10

Range Ticks

The tick can also represent a numeric or time range.

[C#]

At.ValueHigh = 20;
At.ValueLow = 10;
[Visual Basic]

At.ValueHigh = 20
At.ValueLow = 10

Marker Ticks

Both value and range ticks can be represented by an ElementMarker instead of a label.

[C#]
At.Marker = new ElementMarker(“images/myImage.gif”);

[Visual Basic]
At.Marker = new ElementMarker(“images/myImage.gif”)

Custom / Automatic ticks

The element object contains XAxisTick and YAxisTick properties. These are null by default, however, when instantiated, they will be drawn on the axis the elements belong to and will represent the element’s value.

Sample: features/ElementTicks.aspx

The AxisMarker also contains a single AxisTick property. When instantiated, it will represent the marker’s value or range as a range tick, depending on the marker's value.

Sample: features/AxisMarkerTicks.aspx
AxisTick.AffectAxisScale can by used by custom ticks to affect the scale of the axis its added to. See Axis Scale > Scale Influentials above.

Adding Custom Ticks to an axis:

Custom axis ticks can be added to any value axis like so:

[C#]

Chart.XAxis.ExtraTicks.Add(At);

[Visual Basic]

Chart.XAxis.ExtraTicks.Add(At)

To quickly add multiple axis ticks you can also list them as parameters in the Add method.

[C#]

Chart.XAxis.ExtraTicks.Add(at1, at2, at3, at4);
[Visual Basic]

Chart.XAxis.ExtraTicks.Add(at1, at2, at3, at4)

Tokens

Tick labels on a category axis can use tokens to display information about element groups they represent. For example the default category tick’s label is “%Name” which will show the element’s name.

Ticks assigned to elements (Element.YAxisTick & Element.XAxisTick) can also use tokens to describe the elements they represent.

Sample: features/elementTemplate.aspx

(New in 3.1) Tick labels in a numeric or time axis can also use tokens. A single value tick uses the token '%Value'. A range tick can use either the value token or any tokens related to the ScaleRange object. This functionality is useful with time scales because it allows you to break the time label into multiple lines as the following sample demonstrates:

Sample: features/AxisTickToken.aspx

See also: Token Reference

Overrides

A tick added to an axis that already contains a tick with the same value will update the old tick properties with its own. For example, if an axis shows a tick at 20 we can override it to display some different text using this code:

[C#]

AxisTick at = new AxisTick();
At.Value = 20;
At.Label.Text = “Twenty”;
XAxis.ExtraTicks.Add(At);

[Visual Basic]

Dim at As New AxisTick()
At.Value = 20
At.Label.Text = “Twenty”
XAxis.ExtraTicks.Add(At)

If a tick at 20 didn’t exist, it would be added as an additional tick.

A tick can also be used to propagate its settings to a range of ticks. Consider a scale from -100 to 100. If we wanted to color all the negative values red we could do so with the following code:

[C#]

AxisTick at = new AxisTick();
At.ValueHigh = -1;
At.ValueLow = -100;
At.Label.Color = Color.Red;
At.OverrideTicks = true;
XAxis.ExtraTicks.Add(At);

[Visual Basic]

Dim at As New AxisTick()
At.ValueHigh = -1
At.ValueLow = -100
At.Label.Color = Color.Red
At.OverrideTicks = True;
XAxis.ExtraTicks.Add(At)
Notice that the AxisTick.OverrideTick setting is required so the axis knows whether to treat the tick as an override or regular range tick.

Styling

The AxisTick object can control its appearance as well as the grid line that stems from it. The TickLine property can also take advantage of the Line.Length property.

Some styling examples:

[C#]
AxisTick at = new AxisTick();

At.Label.Font = new Font(“Verdana”,10);
At.Line.Length = 8;
At.GridLine.DashStyle = Dash;

[Visual Basic]
Dim at As New AxisTick()

At.Label.Font = New Font(“Verdana”,10)
At.Line.Length = 8
At.GridLine.DashStyle = Dash

The axis contains properties that also modify the axis tick appearance.

  • TickLabelMode
    This enumeration allows you to specify the layout behavior of ticks.
  • TickLabelPadding
    A numeric value in pixels that indicates the distance between a tick line and the label.
  • TickLabelSeparatorLine
    Between each tick mark a line can be drawn to accentuate tick label separation. This line is automatically enabled when tick labels decide to wrap.

Tick Alignment
Tick marks can also be drawn between each tick label instead of above it. This is done by setting Axis.CenterTickMarks to false. When this is the case, only Axis.DefaultTick properties are used instead of individual tick line properties because not every tick mark will pertain to a label.

Tip: Centered tick marks are commonly used with category axes [ Group A , Group B, …] and sometimes with time axes [ May, June, … ]
See Also

Tutorials: Minor Ticks | Axis Time Label Automation | Axis Calculated Ticks


Minor Ticks

Introduction

Minor axis ticks are used to divide scale intervals into smaller logical intervals. This can be done automatically or specified manually.

Smart Minor Ticks (Automatic)

Smart minor ticks will automatically determine a logical minor interval considering the scale's major intervals. For example, a time interval of three months will automatically place a minor tick for every month. To use this feature simply set an axis' SmartMinorTicks property to true.

[C#]

Chart.XAxis.SmartMinorTicks = true;
[Visual Basic]

Chart.XAxis.SmartMinorTicks = True
Sample: features/AxisSmartMinorTicks.aspx
  • Smart minor ticks are only generated when the interval is determined automatically as apposed to explicitly specified .
  • If smart minor ticks are less than the specified Axis.MinimumInterval, they will not be generated.

Manual Minor Ticks

Minor tick intervals can be controlled through the following axis properties:

  • MinorInterval
    Gets or sets a numeric value that determines the interval of minor axis ticks.
  • MinorTicksPerInterval
    Gets or sets the number of minor axis ticks generated between major axis ticks.
  • MinorTimeIntervalAdvanced
    Gets or sets a TimeIntervalAdvanced object that determines the interval of minor axis ticks on a time scale.

Minor Tick Manipulation

While the minor ticks don't traditionally have labels or any special styling, in .netCHARTING terms it's just another axis tick. If needed, the minor ticks can have labels, extra long or thick lines etc. All the functionality of an axis tick is available to minor ticks. One difference is that minor ticks will not influence the grid with regards to alternating grid colors of an axis (AlternateGridBackground).

Sample: features/AxisMinorTicksTrick.aspx
Logarithmic axis scales do not support minor ticks.


Axis Time Label Automation

Introduction

This feature is yet another charting innovation brought to you only by .netCHARTING. Axis time label automation is a collection of smart features that accurately describe the time segment shown on a time axis scale. With these user friendly and automatic features, your time based charts will be more intuitive and readable.

How smart is it?

Simply put, quite. This feature is aware of things such as whether your time span crosses into another day, month, or year and will point these things out to the viewer. It is also aware of how specific your data is; meaning, whether it's describing minutes, days, months and so on. This is a complicated task with countless permutations where you may require a behavior other than the default. Fortunately, this feature is also very well equipped with plenty of options that allow meticulous customization.

If this sounds useful for your projects, let's explore the topic a bit further.

Hierarchy & API

There are two separate mechanisms involved with time label automation. One generates single value labels and the other generates range ticks. The behavior or modes of these features are controlled with two properties:

  • Axis.TimeScaleLabels.Mode (Single Value Mechanism)
    Enumeration Members: TimeScaleLabelMode
  • Axis.TimeScaleLabels.RangeMode ( Range Value Mechanism)
    Enumeration Members: TimeScaleLabelRangeMode

Additional options of these features are available through the Axis.TimeScaleLabels property.

Single Value Time Labels

Dynamic Mode

An automatically determined or specified time interval can be used with this mode. This mode will determine what the axis ticks are describing and apply the format strings and axis tick properties that correspond to the time instance of each axis tick. The format strings and axis ticks are found in the TimeScaleLabelInfo class and are covered in depth below.

Let's start with an example. This is a normal time axis without any time automation. Only the time interval is automatically determined:

Now let's see how the automation engine will handle this scale in 'dynamic' mode.

[C#]

Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Dynamic;
[Visual Basic]

Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Dynamic

As you can see, the ticks are evaluated and for the most part have been determined to represent months, therefore, they are labeled with the month's name. One of the ticks, however, represents the year and is formatted to show the four digit year.

Smart Mode

The above, 'dynamic mode' uses static formats specified in the TimeScaleLabelInfo class. The smart mode will do the same, however, only if they are specified by the user. Otherwise the formats will be determined automatically based on a number of factors, resulting in a detailed and well laid out axis. Considering all the different factors, the smart time automation engine will choose from over 100 formats and templates to produce the most appropriate result.

[C#]

Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Smart;

[Visual Basic]

Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Smart

Hidden Mode

This mode will prevent any single value axis ticks from being shown on the axis. It is useful in conjunction with range time labels when the range time labels sufficiently describe the time segment and single value ticks are not desired.

[C#]
Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Hidden;
[Visual Basic]
Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Hidden

Ranged Time Labels

Default Mode

The default mode does not generate any axis ticks, unless, the time intervals to base those axis ticks on are specified. Adding range time intervals is explained below.

Dynamic Mode

When the TimeScaleLabelRangeMode.Dynamic mode is specified, the time span is analyzed to determine what time intervals should be used to generate ranged axis ticks. The range ticks are then generated based on those intervals. If range time intervals are specified by the user this mode will not generate axis ticks based on any additional automatic time intervals. In effect, it will behave like the Default mode.

Consider the following axis scale:

The chart will be widened below so everything is shown properly.
[C#]

Chart.XAxis.TimeScaleLabels.RangeMode = TimeScaleLabelRangeMode.Dynamic;
[Visual Basic]

Chart.XAxis.TimeScaleLabels.RangeMode = TimeScaleLabelRangeMode.Dynamic

The resulting axis:

Because the axis ticks represent months and span into a different year, range axis ticks were created for both of these units of time.

Specifying Range Time Intervals

Time intervals can be added using the Axis.TimeScaleLabels.RangeIntervals property. When specified, they are always generated and the dynamically determined time intervals are omitted. This code snippet will also demonstrate a using TimeScaleLabelMode.Hidden to hide the single value ticks..

[C#]
Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Hidden;
Chart.XAxis.TimeScaleLabels.RangeIntervals.Add(TimeInterval.Month);
[Visual Basic]
Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Hidden
Chart.XAxis.TimeScaleLabels.RangeIntervals.Add(TimeInterval.Month)

TIP: Multiple range intervals can be added simultaneously using a single line of code:

Chart.XAxis.TimeScaleLabels.RangeIntervals.Add(TimeInterval.Months, TimeInterval.Years)

Custom Styling and Formatting

The time label automation mechanism will describe the time segment accurately, but, it may not describe it exactly as you'd like. This section describes the options available for this customization.

The axis property TimeScaleLabels is an Axis.TimeScaleLabelInfo class. This class contains format strings and axis tick objects that correspond to time units used by these features. Because time automation is based mainly on time instances, the generated labels can be fully controlled through objects you may already be familiar with.

For example, let's consider this is our time scale using dynamic mode:

Format Strings

The labels are long and this is causing them to angle. The day labels don't NEED to spell the whole word out, therefore, the days format string will be modified to only abbreviate the day names using the following code:

[C#]

Chart.XAxis.TimeScaleLabels.DayFormatString = "ddd d";

[Visual Basic]

Chart.XAxis.TimeScaleLabels.DayFormatString = "ddd d"

Label Templates
Now that the labels aren't angled, the there is another thing that stands out a bit, or rather, doesn't stand out enough. The February tick can be easily missed and it doesn't tell us what day it is describing. If we change its format to show all this information, this label will be long and cause the labels to angle again. To overt this problem, we will instead manipulate the month's axis tick label to show all the information we need and add a new line character to draw the label on two lines and keep it narrow.

[C#]
Chart.XAxis.TimeScaleLabels.MonthTick.Label.Text = "<%Value,ddd d>\n<%Value,MMMM>";

[Visual Basic]
Chart.XAxis.TimeScaleLabels.MonthTick.Label.Text = "<%Value,ddd d>\n<%Value,MMMM>"

Tip: It may also be useful to use a smaller font to create more room for axis ticks.

Styling

Now the scale looks much better. Still, for those of you who always give 110%, let's go a step further and make those month labels really stand out. As we've seen in the above example, an AxisTick is exposed for each time unit. This gives us complete control over its appearance. This code will modify the month label's font and color.

[C#]

Chart.XAxis.TimeScaleLabels.MonthTick.Label.Font = new Font("Arial",8,FontStyle.Bold);
Chart.XAxis.TimeScaleLabels.MonthTick.Label.Color = Color.DarkBlue;

[Visual Basic]

Chart.XAxis.TimeScaleLabels.MonthTick.Label.Font = New Font("Arial",8,FontStyle.Bold)
Chart.XAxis.TimeScaleLabels.MonthTick.Label.Color = Color.DarkBlue

Range ticks can be customized in the same manner as the single value ticks. This code modifies the YearTick's font and line color.

[C#]

Chart.XAxis.TimeScaleLabels.YearTick.Label.Font = new Font("Arial",8,FontStyle.Bold);
Chart.XAxis.TimeScaleLabels.YearTick.Line.Color = Color.Blue;

[Visual Basic]

Chart.XAxis.TimeScaleLabels.YearTick.Label.Font = new Font("Arial",8,FontStyle.Bold)
Chart.XAxis.TimeScaleLabels.YearTick.Line.Color = Color.Blue

Test your skills

Now that you're a time label automation expert, let's test your skills and see if you can figure out the code used to generate this chart axis:

Show Answer (code)

[C#]

 Chart.XAxis.FormatString = "d";

 Chart.XAxis.TimeLabelAutomation.RangeIntervals.Add(TimeInterval.Weeks, TimeInterval.Months, TimeInterval.Years);

 Chart.XAxis.TimeLabelAutomation.WeekTick.Label.Text = "Week\n<%Low,dd> - <%High,dd>";

 Chart.XAxis.TimeLabelAutomation.MonthTick.Line.Color = Color.Orange;
 Chart.XAxis.TimeLabelAutomation.YearTick.Line.Color = Color.Green;
 Chart.XAxis.TimeLabelAutomation.YearTick.Label.Font = new Font("Arial",8,FontStyle.Bold);
 Chart.XAxis.TimeLabelAutomation.MonthTick.Label.Font = new Font("Arial",8,FontStyle.Italic);

[Visual Basic]

 Chart.XAxis.FormatString = "d"

 Chart.XAxis.TimeLabelAutomation.RangeIntervals.Add(TimeInterval.Weeks, TimeInterval.Months, TimeInterval.Years)
 Chart.XAxis.TimeLabelAutomation.WeekTick.Label.Text = "Week\n<%Low,dd> - <%High,dd>"

 Chart.XAxis.TimeLabelAutomation.MonthTick.Line.Color = Color.Orange
 Chart.XAxis.TimeLabelAutomation.YearTick.Line.Color = Color.Green
 Chart.XAxis.TimeLabelAutomation.YearTick.Label.Font = new Font("Arial",8,FontStyle.Bold)
 Chart.XAxis.TimeLabelAutomation.MonthTick.Label.Font = new Font("Arial",8,FontStyle.Italic)


Axis Calculated Ticks

Introduction

Previous to version 3.2, to create an axis tick representing a value such as the average of the plotted data, the value had to be calculated, then, an axis tick was manually added to the axis. This process has now been simplified down to one simple line of code.

Calculated Axis Tick

The following code adds a calculated tick to an axis.

[C#]

Chart.YAxis.AddCalculatedTick(Calculation.Average);
[Visual Basic]

Chart.YAxis.AddCalculatedTick(Calculation.Average)

As you can see, this code does not specify any data to perform the calculation on. In this case, the data plotted on the axis is calculated.

Data Specific

A calculation based on only one series of the data shown on an axis is often desired. When this is the case, a single series or any number of series can be specified to base the calculation on.

The following code demonstrates specifying a series:

[C#]

Chart.YAxis.AddCalculatedTick(Calculation.Average, mySeries);
[Visual Basic]

Chart.YAxis.AddCalculatedTick(Calculation.Average, mySeries)
To specify multiple series, place them into a series collection which can be specified as a method parameter.

Using a template

The resulting axis tick will show the calculated value, however, if additional formatting or textual modifications are required, a template can be specified. The '%Value' token in the template will be replaced with the resulting value. The following examples demonstrate template usage.

[C#]

Chart.YAxis.AddCalculatedTick("<%Value,Currency>", Calculation.Average);
Chart.YAxis.AddCalculatedTick("Average: %Value", Calculation.Average);
// Resulting Ticks:
// $123
// Average: 123
[Visual Basic]

Chart.YAxis.AddCalculatedTick("<%Value,Currency>", Calculation.Average)
Chart.YAxis.AddCalculatedTick("Average: %Value", Calculation.Average)
' Resulting Ticks:
' $123
' Average: 123

Calculated Ticks of Shadow Axes

Calculated axis ticks can also be generated for shadow axes. Despite the data not being bound to the actual axis, a shadow axis will base it's calculations on the parent axis' data.

A common task could be to have an original axis show the scale, and a shadow axis on the other side of the chart can show the calculated axis ticks as shown below.

[C#]

Axis axisReplica = Chart.XAxis.Calculate("Replica",true,Orientation.Right);
axisReplica.AddCalculatedTick(Calculation.Average);
Chart.AxisCollection.Add(axisReplica);
[Visual Basic]

Axis axisReplica = Chart.XAxis.Calculate("Replica",True,Orientation.Right)
axisReplica.AddCalculatedTick(Calculation.Average)
Chart.AxisCollection.Add(axisReplica)

Sample: features/AxisShadowCalculatedTicks.aspx


Axis Markers

Introduction

The AxisMarker class can be used to highlight parts of a chart area along an axis. The axis marker can have a single value, a range, or even a CalendarPattern. An axis marker can also be attached to an element in cases where the marker is wanted on a category axis.

Axis markers can also be drawn on top of the chart elements when in 2D mode. This behavior can be specified by setting the AxisMarker.BringToFront property to true.

Single Value AxisMarker

An axis marker can take a number, DateTime, or string value to define it's position. This sample code snippet uses a number and string to insert markers.

[C#]

AxisMarker am1 = new AxisMarker("Marker at 45",new Line(Color.Orange),45);
Chart.YAxis.Markers.Add(am1);

AxisMarker am2 = new AxisMarker("Text marker at 'Element 0'",new Line(Color.Green),"Element 0");
Chart.XAxis.Markers.Add(am2);

[Visual Basic]

AxisMarker am1 = new AxisMarker("Marker at 45",new Line(Color.Orange),45)
Chart.YAxis.Markers.Add(am1)

AxisMarker am2 = new AxisMarker("Text marker at 'Element 0'",new Line(Color.Green),"Element 0")
Chart.XAxis.Markers.Add(am2)

Range AxisMarker

Axis markers can also highlight a range on the chart. Even a string range.

String ranges are determined by string comparison where 2 is larger than 12.
[C#]

AxisMarker am3 = new AxisMarker("20-30",new Background(Color.FromArgb(100,Color.LightBlue)),20,30);
Chart.YAxis.Markers.Add(am3);
AxisMarker am4 = new AxisMarker("'Element 1'-'Element 2'",new Background(Color.FromArgb(100,Color.LightBlue)),"Element 1","Element 2");
am4.Label.LineAlignment = StringAlignment.Near;
Chart.XAxis.Markers.Add(am4);

[Visual Basic]

Dim am3 As New AxisMarker("20-30",New Background(Color.FromArgb(100,Color.LightBlue)),20,30)
Chart.YAxis.Markers.Add(am3)
Dim am4 As New AxisMarker("'Element 1'-'Element 2'",New Background(Color.FromArgb(100,Color.LightBlue)),"Element 1","Element 2")
am4.Label.LineAlignment = StringAlignment.Near
Chart.XAxis.Markers.Add(am4)

Attached to an element

To attach an axis marker to an element simply instantiate one for the element in question.

Markers attached to an element only appear on category axes and only if one is available.

[C#]

mySC[0].Elements[3].AxisMarker = new AxisMarker("Attached to element 3",new Line(Color.Blue),0);

[Visual Basic]

mySC[0].Elements[3].AxisMarker = New AxisMarker("Attached to element 3",new Line(Color.Blue),0);

features/AxisMarkerAdvanced.aspx

Calendar Pattern AxisMarker

A calendar pattern can be used to specify sections of time the axis marker is drawn on a time axis.

This example highlights the weekdays on a time x axis:

[C#]

CalendarPattern cp = new CalendarPattern(TimeInterval.Day,TimeInterval.Week,"0111110");
cp.AdjustmentUnit = TimeInterval.Day;
AxisMarker am = new AxisMarker("",new Background(Color.FromArgb(100,Color.Orange)),0,0);
am.CalendarPattern = cp;
am.LegendEntry = new LegendEntry("Week Days","");
Chart.XAxis.Markers.Add(am);

[Visual Basic]

Dim cp As New CalendarPattern(TimeInterval.Day,TimeInterval.Week,"0111110")
cp.AdjustmentUnit = TimeInterval.Day
Dim am As New AxisMarker("",New Background(Color.FromArgb(100,Color.Orange)),0,0)
am.CalendarPattern = cp
am.LegendEntry = New LegendEntry("Week Days","")
Chart.XAxis.Markers.Add(am)

See Also: Calendar Pattern Tutorial

Sample: features/calendarPattern.aspx


Multiple Axes

Multiple Axes

.netCHARTING employs a straightforward yet effective system to utilize multiple axes. Each series can have it's own x and y axis. By default each series on a chart inherits the main x and y axis

Main Axes

  • Chart.YAxis
  • Chart.XAxis

Axes are defined for series using the following properties:

  • Series.XAxis
  • Series.YAxis

The relationships and identification of axes is maintained by axis object instances. This means instead of specifying an axis name you would specify it by using the axis object itself.

For example, here both series will use the same x axis:

[C#]

Series1.XAxis = new Axis();
Series2.XAxis = Series1.XAxis;
[Visual Basic]

Series1.XAxis = new Axis()
Series2.XAxis = Series1.XAxis

This example will show how two different axes are specified for two series.

[C#]

DataEngine de = new DataEngine();
//(... get data into the engine ...)
SeriesCollection sc = de.GetSeries();
// Let's assume the data engine generated 2 series.
// Specify different axes for each series.
sc[0].XAxis = new Axis();
sc[0].YAxis = new Axis();
sc[1].XAxis = new Axis();
sc[1].YAxis = new Axis();
// Add the series collection to the chart.
Chart.SeriesCollection.Add(sc);

[Visual Basic]

Dim de As New DataEngine()
'(... get data into the engine ...)
Dim sc As de.GetSeries()
' Let's assume the data engine generated 2 series.
' Specify different axes for each series.
sc(0).XAxis = new Axis()
sc(0).YAxis = new Axis()
sc(1).XAxis = new Axis()
sc(1).YAxis = new Axis()
' Add the series collection to the chart.
Chart.SeriesCollection.Add(sc)

Samples:

  • features/RateChart.aspx
  • features/SeriesAxisBinding.aspx
  • features/SeriesAxisBindingDB.aspx
  • features/InvisibleAxis.aspx
See also: Z Axis effect using multiple axes


Calculated Axes

Introduction

A Calculated axis is a Shadow Axis that allows you to add an axis to the chart that mimics another axis that already exists but with a change in behavior.

The different behavioral changes and forms of shadow axes are:

  • Numeric Unit Conversion
  • Time Interval Conversion
  • Custom tick label manipulation method
  • Completely custom replica axis.
Calculated axes do not fill alternating grid areas.

Unit Conversion

.netCHARTING is equipped with calculations for converting between 1092 different units. If you have an axis with a scale that represents a some measure, it can be easily converted to another unit. For example feet to inches and so on.

The process for adding a calculated axis is simple:

  • Instantiate a calculated axis by calling the Calculate method of an existing axis.
  • Add it to the Chart.AxisCollection collection.

[C#]

Axis inchAxis = Chart.YAxis.Calculate("Inches",Length.Feet, Length.Inch);
Chart.AxisCollection.Add(inchAxis);

[Visual Basic]

Dim inchAxis As Chart.YAxis.Calculate("Inches",Length.Feet, Length.Inch)
Chart.AxisCollection.Add(inchAxis)

That is all. The axis will automatically show up on the chart by the original axis.

Do not add axes to AxisCollection that are not calculated axes. See Axis Tutorial > Multiple Axes for information on how additional axes can be used.

There is another feature worth discussing. The new converted unit axis will by default take the parent axis ticks and convert them to the specified unit. The refresh scale option will allow the axis to come up with its own intervals. They will not match the parent axis tick positions exactly but will behave as if it is the original axis. This option is specified in the Calculate method as a parameter and illustrated below.

Sample: features/interactiveUnitConversion.aspx

Time Interval Conversion

This type of conversion allows the resulting axis to show different time intervals than the original axis. For example, the first axis can show days and the calculated axis can show weeks.

[C#]

Chart.XAxis.TimeInterval = TimeInterval.Days;
Chart.XAxis.Label.Text = "Days";
Chart.AxisCollection.Add(Chart.XAxis.Calculate("Weeks",TimeInterval.Weeks));

[Visual Basic]

Chart.XAxis.TimeInterval = TimeInterval.Days
Chart.XAxis.Label.Text = "Days"
Chart.AxisCollection.Add(Chart.XAxis.Calculate("Weeks",TimeInterval.Weeks))

Sample: features/CalculatedTimeAxis.aspx

Custom Tick Label Manipulation Method

The third conversion requires a custom method that takes a string and returns a processed string. This gives you full control over the axis tick label text if necessary.

Sample: features/customFunction.aspx

To only show the calculated axis on the chart and not it's parent, use ParentAxis.Clear()
to make it disappear as shown in the customFunction.aspx sample.
Replica Shadow Axis (New in 3.1)
This form of shadow axis can be very useful because it allows you to specify data related axis ticks that help describe your data. This code demonstrates how to acquire the replica axis.
[C#]

Axis axisReplica = Chart.XAxis.Calculate("Replica");
Chart.AxisCollection.Add(axisReplica);
[Visual Basic]

Axis axisReplica = Chart.XAxis.Calculate("Replica")
Chart.AxisCollection.Add(axisReplica)
Some possible uses of this type of shadow axis are shown in the following samples.
  • features/AxisShadowImportantTicks.aspx
  • features/AxisShadowSeriesNames.aspx
  • features/AxisShadowValues.aspx
  • features/AxisShadowValues2.aspx

After reviewing the above samples you will see that this feature can be useful, however, don't limit yourself to the demonstrated possibilities. The dynamic nature of this feature allows for countless different ways to better describe your data you're plotting.

See Also

Tutorials: Axis Calculated Ticks


File Handling

Overview

.netCHARTING includes advanced file handling designed to ensure your charting applications works reliably without the need for special settings. For most users, the default file handling options will meet your needs. Those with advanced requirements can go beyond the intelligent defaults and finely tune their file and image handling for their specific needs. In addition to common properties at the chart level, .netCHARTING includes a file manager class for more advanced file handling.

Cleanup management

Typically .netCHARTING creates a new chart image dynamically for each request. This image is written to disk in a temporary (temp) directory on your web server and an image reference is returned. The result is that the client (web browser) requests the aspx page from the server which renders the chart image and then returns an image reference in HTML. The browser will then request the image file which is served from the web server. This scenario outlines the highest performing option for dynamic chart deployment. Since each request generates a unique chart file which could over time result in wasted space .netCHARTING includes an automated cleanup system which will delete automatically generated files on a regular basis. The default period is 15 minutes and it can be set to any value in minutes through the Chart.CleanUpPeriod property. If set to 0 the cleanup feature will be disabled. Cleanup management is based on 2 settings and can be set independently on a per temp directory basis. As a result, each temp directory setting can have its own independent cleanup period if required. If you mistakenly set different cleanup periods for different scripts that reference the same temp directory the last setting would be used and it would not cause any problems.

Filename generation

When not specified with the Chart.FileName property a random filename is generated to ensure using .netCHARTING is a easy and seamless as possible. All file names generated by the system will be prefixed with dnc and followed by a series of letters and numbers e.g. dnc-5irim3i3.png

Temporary Directory Support
Using the Chart.TempDirectory property you can specify the relative, absolute or physical path which is used for a given charts images.

Examples:

The following examples assume you have a web site (www.site.com) located at c:\inetpub\wwwroot\site1 and an aspx page at c:\inetpub\wwwroot\site1\app1\sub\chart.aspx

Setting | Writes file to | Returns link of | Loading image from
/temp | c:\inetpub\wwwroot\site1\temp | /temp/dnc-123.png | www.site.com/temp/dnc-123.png
temp | c:\inetpub\wwwroot\site1\app1\sub\temp | temp/dnc-123.png | www.site.com/app1/sub/temp/dnc-123.png
../temp | c:\inetpub\wwwroot\site1\app1\temp | ../temp/dnc-123.png | www.site.com/app1/temp/dnc-123.png
../../temp | c:\inetpub\wwwroot\site1\temp | ../../temp/dnc-123.png | www.site.com/temp/dnc-123.png
C:\temp | C:\temp | C:\temp | C:\temp

This latter case (C:\temp) would not work in a web environment unless the
physical path is within the web root and accessible to the site. Typically
physical paths such as c:\temp should not be used.

Browser Cache Defeating

Since it is possible a fixed file name could used for dynamic content, the browser could show an older version because of image caching at the client (browser) level. To prevent this .netCHARTING defeats the browsers image cache by returning a random query string with the image reference. This ensures that clients will load the latest image generated by .netCHARTING even if the same filename is used.

Static filename support

A static filename enables you to select the name used for the chart. When setting a static filename with Chart.FileName each generation will override the last and only a single file will be used for that chart. The filename is provided without extension, which is determined based on the image format selected (see “Multiple image output formats” below for more information).

Output and Fragment caching integration

ASP.NET includes powerful caching features integrated deeply with the architecture of Internet Information Server 6.0 (web server software). .netCHARTING works seamlessly with both output and fragment caching and samples are provided working with both. Output caching enables your entire page including charts to be cached, to work with output caching you need only implement it in your page and set your charts to a specific filename with static filename support. For cases where you only wish to cache the chart and not the other page content fragment caching may be used. Please see outputcache.aspx and fragmentcache.aspx in the feature samples for usage details.

Direct streaming (no file) support

Since disk based charts offer higher performance and more flexibility they are the preferred method of chart image generation. However, in addition to advanced file handling support it is also possible to stream charts directly to the browser. In this case no physical file is written to disk.

There are differences in the way the control can be used between these two image return methods. When using a file reference, you are free to treat the page as you normally would, including HTML and any other web content on the page.

If you are streaming the image back, only the control call should exist on the page because no other HTML will render. This is not a limitation of .netCHARTING but rather specific to the way the HTTP protocol works. Each request is served separately (as such a request to a web site with 3 images is actually 4 unique requests to the web server and the browser does the job of assembling those 4 items into the single web page you see.

Because streaming images does not allow HTML, setting url and tooltip properties of elements on the chart will have no effect. See streaming.aspx for sample usage. Also see streamingusage.aspx for a page which consumes the streaming image. When you request streaming.aspx it is the same as requesting an image file directly. Streamingusage.aspx shows how this aspx page can be referenced as an image within a page so other HTML elements can be included.

Note: Disk based charts offer higher performance and more flexibility -
they are the preferred method of chart image generation. Streaming
should only be used if you have a specific need for it.

Multiple image output formats

.netCHARTING supports multiple image formats for output, set with the Chart.ImageFormat property. PNG is most commonly used as it provides high quality lossless charts. Jpg is useful when using image backgrounds as it can generate a smaller file size. When using jpg you can adjust the quality and level of compression with File Quality property of the file manager which accepts values from 0 to 100. Other supported types include vector output (wmf and emf), tif, and bmp.

Tip: PNG tends to produce the best looking output for most charts however
if your chart includes an image background , consider JPG as it will produce
a smaller file size. See sample bevel.aspx for an example.

Direct bitmap access

In addition to having the chart control return a built in reference to the generated image, you can directly access the chart bitmap for your own advanced uses. See sample postrenderdrawing.aspx which demonstrates obtaining the chart bitmap, making changes to the bitmap and saving the results with the file manager. Using the file manager enables complex tasks to be nearly as simple as using the built in file management since it handles creating a file name and returning a control referencing the newly generated chart image.

Legend and chart area image splitting

In addition to returning the entire chart image as a bitmap, you can also return just the legend with GetLegendBitmap. The advanced image map functionality even allows you to use .netCHARTING generated image maps for tool tips and URL’s on images returned independently from the control so you can place them freely in your page. See imagemaptext.aspx for a complete sample.


Calendar Patterns

Introduction

A CalendarPattern class specifies a pattern such as specific days in a week, months in a year etc. You can specify a time unit of any other time unit to form the pattern. For example: weeks of a year, seconds of a minute, days of a year, even milliseconds of a year.

Uses

Calendar patterns can be used with axis markers to highlight parts of a time scale axis and with Series.Trim to trim away elements with time values that land within the calendar pattern. They can also be used to specify a sequence of scale breaks on a time based axis.

Usage

The pattern is represented by an array of boolean values, each boolean value represents the specified PatternUnit and the whole array represents the specified CalendarUnit.

The CalendarPattern.PatternFromString method can be used to quickly create patterns using simple string of zeros (0) and ones (1). A week pattern would look like this: "0000000". A zero for each day of the week starting with saturday and ending with sunday. A pattern that flags the weekend (saturday and sunday) would look like this: "1000001".

Example:

[C#]

CalendarPattern myCalendarPattern = new CalendarPattern();
myCalendarPattern.CalendarUnit = TimeInterval.Week;
myCalendarPattern.PatternUnit = TimeInterval.Day;
myCalendarPattern.Pattern = CalendarPattern.FromString("1000001");
[Visual Basic]

Dim myCalendarPattern As CalendarPattern = new CalendarPattern()
myCalendarPattern.CalendarUnit = TimeInterval.Week
myCalendarPattern.PatternUnit = TimeInterval.Day
myCalendarPattern.Pattern = CalendarPattern.FromString("1000001")

In a pattern the __Unit properties refer to a single value (PatternUnit) and the whole pattern (CalendarUnit) like so:

"1000001" <-- CalendarUnit (Week)
^
PatternUnit of CalendarUnit (Sunday)

The above calendar pattern will flag each saturday and sunday in a given, time span.

If all the values are not provided, the pattern will assume false for the missing values. So if we used "100" for the above pattern, it would be the same as "1000000"

Calendar Patterns require a time axis scale.
When a calendar pattern is used in an axis marker, the axis marker must reside on an axis with a time scale. For more information see Elements & Axis scales.

CalendarPattern Shortcuts

There are two calendarPattern static properties that allow you to initialize an instance of the calendar pattern object quickly. The properties are Weekends and Weekdays.

The following code instantiates a weekend calendarPattern and is the equivalent of the four lines of code shown above.

[C#]

CalendarPattern myCalendarPattern = CalendarPattern.Weekends;
[Visual Basic]

CalendarPattern myCalendarPattern = CalendarPattern.Weekends

Adjustment Unit

Calendar patterns are drawn on the axis at exact time instances like the start of the day, end of the day, etc. If you use a pattern like the above and your data shows days as columns, the actual x axis time of those columns may also be the start of the day. This results in the columns being centered on the edge of the pattern. The expected behavior would be that the pattern edges fall between the day columns. To remedy this issue you may use the AdjustmentUnit. This will allow you to adjust the calendar pattern to show correctly on the axis. If your columns represent hours the correct adjustment unit would be TimeInterval.Hour.

Sample: features/calendarPattern.aspx


Shortcuts and Efficient Code

Introduction

The .netCHARTING API has been designed to allow users to dramatically cut down on the amount of code necessary to perform common tasks. This topic will demonstrate how many multi-task operations can be done very easily, usually with a single line of code. If you spend much of your time working with charts please read on.

Defaults

One of the most time saving features are the property defaults. These allow you to set properties of all similar objects with a single line of code. For example, a chart can have a large number of series and elements. To quickly set any of those series or element properties a single line of code can be used as shown here:

[C#]

Chart.DefaultSeries.Type = SeriesType.Line;
Chart.DefaultElement.ShowValue = true;
[Visual Basic]

Chart.DefaultSeries.Type = SeriesType.Line
Chart.DefaultElement.ShowValue = True

Not every single objects of the same type has to bet set using defaults. They can also be set selectively for specific groups. For example, all elements of only a particular series can be set without changing element in other series using the following code:

[C#]

mySeries.DefaultElement.ShowValue = true;
[Visual Basic]

mySeries.DefaultElement.ShowValue = True

This is a list of default properties that can be used to quickly specify settings:

  • Axis.DefaultTick
  • Box.DefaultCorner
  • Chart.DefaultAxis
  • Chart.DefaultChartArea
  • Chart.DefaultElement
  • Chart.DefaultLegendBox
  • Chart.DefaultSeries
  • Chart.DefaultShadow
  • Chart.DefaultTitleBox
  • Chart.DefaultBox
  • Chart.DefaultCultureName
  • Chart.DefaultFormatString
  • ChartArea.DefaultElement
  • ChartArea.DefaultSeries
  • Element.DefaultSubValue
  • LegendBox.DefaultEntry
  • Series.DefaultElement

Common Collection Construction

Many collection objects in .netCHARTING have methods that make it much faster and easier to create them. Let's take a look at some of these features using the ChartAreaCollection object.

Constructor
public ChartAreaCollection(params ChartArea[] chartAreaList)

This constructor allows you to create a collection with a number of chart areas using a single line of code:

[C#]

ChartAreaCollection cac = new ChartAreaCollection(ca1, ca2, ca3, ca4);
[Visual Basic]

Dim cac = new ChartAreaCollection(ca1, ca2, ca3, ca4)

Add Methods

public void Add(params ChartArea[] chartAreaList)

Objects can be added to existing collections in the same manner as the constructor

[C#]

Chart.ExtraChartAreas.Add(ca1, ca2, ca3, ca4);
[Visual Basic]

Chart.ExtraChartAreas.Add(ca1, ca2, ca3, ca4)

public void Add(ChartAreaCollection chartAreaCollection)

Adding a collection of chart areas to another chart area collection can be done like so:

[C#]

Chart.ExtraChartAreas.Add(myChartAreaCollection);
[Visual Basic]

Chart.ExtraChartAreas.Add(myChartAreaCollection)

Almost all collections contain these shortcut members.

Collection Type Specific Construction & Features

Some collections also have shortcut constructors that are specific to the type of data they represent.

AxisTickCollection

public static AxisTickCollection FromValues(params DateTime[] list)
public static AxisTickCollection FromValues(params double[] list)

This static constructor allows you to add axis ticks with specific values using a single line of code.

[C#]

Chart.YAxis.ClearValues = true;
Chart.YAxis.ExtraTicks.Add(AxisTickCollection.FromValues(1,2,3,4,5,6);
[Visual Basic]

Chart.YAxis.ClearValues = True
Chart.YAxis.ExtraTicks.Add(AxisTickCollection.FromValues(1,2,3,4,5,6)
Notice: The ExtraTicks.Add method is taking an AxisTickCollection.

Series

The Series object is not a collection. The elements are contained in the Series.Elements ElementCollection property. There are, however, features available that allow managing a series' elements simpler. Series can be populated with elements quickly using the FromYValues constructor.

public static Series FromYValues(params double[] yValues)

[C#]

Series s = Series.FromYValues(1,5,6,34,2);
[Visual Basic]

Dim s = Series.FromYValues(1,5,6,34,2)

The following method allows constructing a series from a list of elements.

public Series(string name, params Element[] elementList)

[C#]

Series s = new Series("mySeries", element1, element2,element3, element4);
[Visual Basic]

Dim s = new Series("mySeries", element1, element2,element3, element4)

There is one more series feature worth noting. As mentioned above, the series is not a collection. Nevertheless, its elements can be accessed easily using the series' indexer:

[C#]

Element myElement = mySeries[1];
// Equivalent to:
Element myElement = mySeries.Elements[1];
[Visual Basic]

Dim myElement = mySeries(1)
' Equivalent to:
Dim myElement = mySeries.Elements(1)

Using these collection object shortcuts will allow you to write code much faster and spend more time focusing on your application logic.


Performance

This section will go over a number of issues that affect the performance of chart rendering. Please note that these tips are not necessarily required in normal scenarios. They are shown here in order to improve performance when it is crucial. There are several things to consider when creating charts that require high availability and performance.

Charts with less than 200 Elements.

When there are few data elements on a chart, the data processing time is largely minimal. Drawing the image takes the majority of time. The more fancy the chart, the slower it will render. Not to say that charts render showily, however, in certain circumstances every millisecond counts. So, how can this process be sped up? Consider this, everything that is drawn on a chart requires time and the more complicated the drawing (shading effects, gradients, shadows etc.) the longer it takes.

Another very important fact to consider is the chart size. The larger the chart becomes the longer it will take for GDI to generate it. There is however an acception to this rule. When charts are so small that they have to be scaled down to fit into the image they are actually drawn at a larger size than specified, then scaled down so this will require more processing time. You'll be able to tell how much a chart is scaled by looking at text labels and compare their size to non-scaled versions of the chart.

The following chart grid demonstrates the performance impact of some settings.

Tips & Summary

  1. Dont use chart features that are not useful like element labels that are too small to read.
  2. Use less visually complex elements. (Square markers instead of circles or no shading effects.
  3. Set box background, line, and box shadow colors to Color.Empty.
  4. Use color transparency sparingly.
    A more complex algorithm is necessary to blend backgrounds with partially transparent color fills.
  5. Using Chart.PrinterOptimizedText may seem like it will improve performance because text is not anti-aliased, however, the performance gain is trivial.
  6. Chart size can make a dramatic difference in performance but the gain is lost when the chart gets too small to fit into the image in which case, it is rendered at a larger size and scaled down to the image size.

Charts with 200+ elements.

With a large number of elements the performance scale begins to tip towards data processing. Certain element features may take a few extra cpu ticks due to processing such as token replacement for element tool tips, labels and other hotspot attributes. The more tokens used in element properties the longer processing may take. Using element markers for series with thousands of elements might also be a bad idea because each marker must be drawn individually.

Memory performance.

If memory usage is a factor there are a few things to be aware of. First, memory usage can be tweaked only when charts are showing a large number of elements, otherwise, these tips will provide marginal benefits.

Element properties such as smart label, markers and hotspots are not instantiated by default. They are instantiated when the properties of those objects are used. For instance using code such as: Chart.DefaultElement.SmartLabel.Text = "%Name" will create a SmartLabel instance for the default element and eventually for each element on the chart.


See Also

dotnetCHARTING Assembly

See Also dotnetCHARTING Send comments on this topic.

dotnetCHARTING Namespace

Inheritance Hierarchy

Classes

Class | Description
Annotation | Encapsulates a Box object with a position, data source, and hot spot functionality.
AnnotationCollection | Contains a collection of Annotation objects.
Axis | Specifies smart time label automation. Similar to specific except the first tick will indicate the instance in time and take it's default value from the axis default tick. Specifies smart time label automation. Similar to specific except the first tick will indicate the instance in time and take it's default value from the axis default tick. Specifies the single value time label automation mode. time intervals are specified in RangeIntervalsRepresents an axis drawn on a ChartArea.
Axis.ScaleSync | An extension to the SynchronizeScale property. Defines the scale synchronization behavior of an axis.
Axis.TimeScaleLabelInfo | Encapsulates time scale label behavior options in addition to axis ticks and format strings used instead of the main axis ticks when they represent particular instances in time.
AxisCollection | Contains a collection of Axis objects.
AxisMarker | Defines objects used to fill a specified section or point on an axis.
AxisMarkerCollection | Contains a collection of AxisMarker objects.
AxisTick | Encapsulates an axis tick that includes a Label or ElementMarker, TickLine, and GridLine.
AxisTickCollection | Contains a collection of AxisTick objects.
Background | Defines objects used to fill the interior of chart elements such as legend boxes, annotations and other shapes.
Box | Represents a box that acts as a container for text and icons. For example a TitleBox or LegendBox.
CalendarPattern | Specifies a calendar pattern such as weekends in a week.
Chart | The .netCHARTING control.
ChartArea | Represents an area on which series and elements are plotted.
ChartAreaCollection | Contains a collection of ChartArea objects.
ChartAreaLayout | Encapsulates a set of options that control the layout of multiple chart areas in a single chart image.
DataEngine | Acquires and manipulates data from databases or other sources, then creates a SeriesCollection which is consumed by the chart control.
DataSource | Represents a single or related set of .netCHARTING data-based objects that specify a data source used to parse tokens and populate custom legend boxes with LegendEntry objects.
Element | Represents a element object or data point on the chart.
ElementCollection | Contains a collection of Element objects.
ElementMarker | Defines a graphical object with a specified shape, size, and color or an image used to mark and identify Element objects.
EmptyElement | Defines the behavior and appearance of empty elements for a given Series.
FileManager | Facilitates saving bitmap images and cleanup.
FinancialEngine | Provides a set of methods that perform financial analysis of series and series collections.
FinancialEngine.Options | Defines a set of static options used with FinancialEngine calculations.
ForecastEngine | Provides a set of methods that find the best fit curve of a data set.
ForecastEngine.Advanced | This class contains advanced methods for calculating the best fitting curve of a data set. It allows the user to construct his own function.
ForecastEngine.Options | Defines a set of static options used with FinancialEngine calculations.
Hotspot | Represents a hotspot on the image and provides events such as tool tips and redirect URL when clicked.
Hotspot.HtmlAttribute | Encapsulates a number of pre-defined javascript actions and their values.
Hotspot.HtmlAttributes | Encapsulates a set of html event attributes and their values.
HotspotCollection | Contains a collection of Hotspot objects.
Label | Represents a label consisting of text, a font, and a color.
LabelAlignmentCollection | Contains a collection of LabelAlignment objects.
LabelOverrideCollection | Contains a collection of LabelOverride objects.
LegendBox | Encapsulates a collection of LegendEntry objects.
LegendBoxCollection | Contains a collection of LegendBox objects.
LegendEntry | Represents an entry in the legend box.
LegendEntryCollection | Contains a collection of LegendEntry objects.
Line | Defines objects used to draw a line or curve.
ListCollection | A list dictionary variation that allows adding items of the string type using a string.
Parameter | Represents an SQL parameter to use with a StoredProcedure.
ParameterCollection | Contains a collection of Parameter objects.
ScaleRange | Represents a value or range of values on an axis scale. Values can be numeric, DateTime, and string types.
ScaleRangeCollection | Contains a collection of ScaleRange objects.
SerializerObject |
SerializerObjectCollection | Contains a collection of SerializerObject objects.
Series | Encapsulates a group of elements.
SeriesCollection | Contains a collection of Series objects.
Shadow | Represents a shadow cast by chart objects such as a Box or Annotation.
SmartLabel | Encapsulates a Label object with advanced alignment and collision detection options.
SmartPalette | Contains a dictionary like collection of string and color pairs where strings refer to series or element names and colors that are assigned to series or elements with those names.
StatisticalEngine | Provides a set of methods that perform statistical analysis of series and series collections.
StatisticalEngine.Options | Defines a set of static options used with StatisticalEngine calculations.
SubValue | Represents a value relative to or independent of the parent element's value.
SubValueCollection | Contains a collection of SubValue objects.
TimeIntervalAdvanced | Represents a time interval and instant at which it occurs.
TimeIntervalCollection | Contains a collection of TimeInterval objects.
Truncation | Defines properties used to shorten long labels.

Interfaces

Interface | Description
IInstanceID | Summary description for IInstanceID.

Enumerations

Enumeration | Description
AbsorbedDose |
Acceleration |
Angle |
AngularVelocity |
Area |
BackgroundMode | Specifies a background drawing mode.
BoxCorner | Specifies a box edge style.
Calculation | Specifies a calculation to be performed on a series or series collection.
Capacitance |
Charge |
ChartAreaLayoutMode | Specifies the positioning behavior of multiple chart areas on a single chart image.
ChartType | Represents the chart type of a chart.
ConcentrationMolar |
Current |
Data |
DataSourceType | Specifies a DataSource type to split the parent DataSource into.
DataTransfer |
Density |
DigitalImageResolution |
ElementMarkerType | Built in element marker icons.
ElementValue | Specifies a value of an element.
EmptyElementMode | Specifies how empty elements are handled.
Energy |
EUCurrency |
FieldType | Specifies a database field data type.
FlowMass |
FlowMolar |
FlowVolumetric |
Force |
FrequencyWavelength |
FuelConsumption |
HatchStylePalette | Specifies a pre-defined hatch style palette.
Illumination |
ImageFormat | Specifies file save format.
Inductance |
LabelAlignment | Specifies alignment of a label.
LegendBoxPosition | Specifies the position of the legend box.
LegendEntryHeaderMode | Specifies a header mode for element entries.
Length |
LimitMode | Controls the type of limitation in Limit or SplitByLimit properties.
LumberVolume |
Mass |
Orientation | Specifies the orientation of an object.
Palette | Specifies a pre-defined palette.
Permeability |
PieLabelMode | Specifies pie label behavior.
Power |
Pressure |
RadarLabelMode | Specifies how tick labels behave on a radar graph.
RadarMode | Specifies the behavior of the x axis on a circular graph such as radar.
Radiation |
Scale | Indicates the scale of an axis.
ScaleBreakStyle | Specifies how a scale break is drawn on a chart.
SeriesType | Specifies how a series will be shown on the chart.
SeriesTypeFinancial | Specifies how a financial series will be shown on the chart.
ShadingEffectMode | Specifies a shading mode.
SubValueType | Specifies the how a sub value is drawn.
SynchronizeScaleMode | Specifies an axis scale synchronization mode between two or more axes.
Telecommunications |
Temperature |
TickLabelMode | Specifies how tick labels are laid out.
Time |
TimeInterval | Specifies a time interval.
TimeScaleLabelMode | Specifies the single value time label automation mode.
TimeScaleLabelRangeMode | Specifies the range value time label automation mode.
TitleBoxPosition | Specifies the title box position.
Torque |
TruncationMode | Specifies how to trim characters from a string that exceeds a maximum number of characters.
Typography |
Velocity |
ViscosityDynamic |
ViscosityKinematic |
Volume |

Structures

Structure | Description
LabelOverride | Defines a string find and replace pair used by Axis objects to manipulate tick labels.

Delegates

Delegate | Description
ChangeValueDelegate |
PostDataProcessingEventHandler |

See Also

dotnetCHARTING Assembly


dotnetCHARTING Assembly

See Also dotnetCHARTING Send comments on this topic.

dotnetCHARTING Namespace Inheritance Hierarchy

System.Object
dotnetCHARTING.Axis
dotnetCHARTING.Axis.TimeScaleLabelInfo
dotnetCHARTING.Background
dotnetCHARTING.Box
dotnetCHARTING.Annotation
dotnetCHARTING.LegendBox
dotnetCHARTING.CalendarPattern
dotnetCHARTING.ChartArea
dotnetCHARTING.ChartAreaLayout
dotnetCHARTING.DataEngine
dotnetCHARTING.DataSource
dotnetCHARTING.Element
dotnetCHARTING.ElementMarker
dotnetCHARTING.EmptyElement
dotnetCHARTING.FileManager
dotnetCHARTING.FinancialEngine
dotnetCHARTING.FinancialEngine.Options
dotnetCHARTING.ForecastEngine
dotnetCHARTING.ForecastEngine.Advanced
dotnetCHARTING.ForecastEngine.Options
dotnetCHARTING.Hotspot
dotnetCHARTING.Hotspot.HtmlAttribute
dotnetCHARTING.Hotspot.HtmlAttributes
dotnetCHARTING.Label
dotnetCHARTING.SmartLabel
dotnetCHARTING.LegendEntry
dotnetCHARTING.Line
dotnetCHARTING.Parameter
dotnetCHARTING.ScaleRange
dotnetCHARTING.AxisMarker
dotnetCHARTING.AxisTick
dotnetCHARTING.SerializerObject
dotnetCHARTING.Series
dotnetCHARTING.Shadow
dotnetCHARTING.StatisticalEngine
dotnetCHARTING.StatisticalEngine.Options
dotnetCHARTING.SubValue
dotnetCHARTING.TimeIntervalAdvanced
dotnetCHARTING.Truncation
System.Collections.CollectionBase
dotnetCHARTING.AnnotationCollection
dotnetCHARTING.AxisCollection
dotnetCHARTING.Axis.ScaleSync
dotnetCHARTING.AxisMarkerCollection
dotnetCHARTING.AxisTickCollection
dotnetCHARTING.ChartAreaCollection
dotnetCHARTING.ElementCollection
dotnetCHARTING.HotspotCollection
dotnetCHARTING.LabelAlignmentCollection
dotnetCHARTING.LabelOverrideCollection
dotnetCHARTING.LegendBoxCollection
dotnetCHARTING.LegendEntryCollection
dotnetCHARTING.ParameterCollection
dotnetCHARTING.ScaleRangeCollection
dotnetCHARTING.SerializerObjectCollection
dotnetCHARTING.SeriesCollection
dotnetCHARTING.SubValueCollection
dotnetCHARTING.TimeIntervalCollection
System.Collections.Specialized.ListDictionary
dotnetCHARTING.ListCollection
System.Collections.Specialized.NameObjectCollectionBase
dotnetCHARTING.SmartPalette
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
dotnetCHARTING.Chart

See Also

dotnetCHARTING Namespace | dotnetCHARTING Assembly


Annotation Members | dotnetCHARTING Namespace

Language

Visual Basic

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Annotation Class

Encapsulates a Box object with a position, data source, and hot spot functionality.

For a list of all members of this type, see Annotation members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.Box
dotnetCHARTING.Annotation

Syntax

[Visual Basic]
Public Class Annotation
   Inherits Box
[C#]
public class Annotation : Box

Remarks

Annotations can either be instantiated for an Element or added to the Chart.Annotation collection. When attached to an element, the annotation will follow the element's position (unless specified) and have a spike indicating which element it's referring to.

When an annotation does not have a size or any text specified and it's Background has an image, the size is will become that of the background's image.

Example

The following code snippet demonstrates using an annotation to simulate a text link on the chart.

[Visual Basic]

Dim a2 As Annotation = New Annotation("Annotation text.")

'set the position
a2.Position = New Point(60,40)

'We'll add a link so when this text is clicked it takes us to a web site.
a2.URL = "http://www.dotnetcharting.com"

' Make sure the annotation doesn't create a rectangle for the text and wrap it.
a2.DynamicSize = False

'In order for the annotation not to draw the background, outline and so
'on... We'll use a shortcut to clear the colors.
a2.ClearColors()

'Add the annotation to a chart.
Chart.Annotations.Add(a2)

[C#]

Annotation a2 = new Annotation("Annotation text.");

//set the position
a2.Position = new Point(60,40);

// We'll add a link so when this text is clicked it takes us to a web site.
a2.URL = "http://www.dotnetcharting.com";

// Make sure the annotation doesn't create a rectangle for the text and wrap it.
 a2.DynamicSize = false;

// In order for the annotation not to draw the background, outline and so
// on... We'll use a shortcut to clear the colors.
a2.ClearColors();

// Add the annotation to a chart.
Chart.Annotations.Add(a2);

See Also

Annotation Members | dotnetCHARTING Namespace


Annotation Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Annotation Class Members

Annotation overview

Public Constructors

Public Constructor Annotation Constructor Overloaded.

Public Properties

Public Property Background (Inherited from Box) | Gets or sets a background object used to fill the interior of this box.
Public Property CornerBottomLeft (Inherited from Box) | Gets or sets the bottom left corner style.
Public Property CornerBottomRight (Inherited from Box) | Gets or sets the bottom right corner style.
Public Property CornerTopLeft (Inherited from Box) | Gets or sets the top left corner style.
Public Property CornerTopRight (Inherited from Box) | Gets or sets the top right corner style.
Public Property DataSource | Gets or sets the DataSource object used to replace tokens in this annotation's label, tool tip, and URL.
Public Property DefaultCorner (Inherited from Box) | Gets or sets the default box corner style.
Public Property DynamicSize | Gets or sets a value that indicates whether a golden rectangle is maintained as the shape of this annotation.
Public Property Hotspot | Gets or sets the Hotspot of this Annotation.
Public Property IconPath (Inherited from Box) | Gets or sets the icon path of this title box.
Public Property InteriorLine (Inherited from Box) | Gets or sets the interior line of this legend box.
Public Property Label (Inherited from Box) | Gets or sets the Label of this box.
Public Property Line (Inherited from Box) | Gets or sets the exterior line of this box.
Public Property Orientation | Gets or sets the annotation's orientation around it's Position and draws a spike to it.
Public Property Padding (Inherited from Box) | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls.
Public Property Position | Overridden. Gets or sets this annotation's position.
Public Property Shadow (Inherited from Box) | Gets or sets the Shadow cast under this box.
Public Property Size | Gets or sets the annotation's size.
Public Property TextAlignmentHorizontal | Gets or sets the horizontal StringAlignment of text in this in the annotation.
Public Property TextAlignmentVertical | Gets or sets the vertical StringAlignment of text in this in the annotation.
Public Property ToolTip | Gets or sets this annotation's tool tip.
Public Property URL | Gets or sets this annotation's hotspot url.
Public Property URLTarget | Gets or sets the target URL of this annotation's link.
Public Property Visible (Inherited from Box) | Gets or sets a value that indicates whether this box is visible.

Public Methods

Public Method ClearColors (Inherited from Box) | Serves as a shortcut to make this box invisible.
Public Method GetCoordinates (Inherited from Box) | Gets the coordinates of this box after the chart is rendered.
Public Method GetRectangle (Inherited from Box) | Gets a Rectangle object indicating this boxes position and size after the chart is rendered.

See Also

Annotation Class | dotnetCHARTING Namespace


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Annotation Constructor

Overload List

Initializes a new instance of the Annotation class.

[Visual Basic] Public Sub New()

[C#] public Annotation();

Initializes a new instance of the Annotation class with a background. Useful when using an image as the annotation.

[Visual Basic] Public Sub New(Background)

[C#] public Annotation(Background);

Initializes a new instance of the Annotation class with text.

[Visual Basic] Public Sub New(String)

[C#] public Annotation(string);

Initializes a new instance of the Annotation class with text and a tool tip.

[Visual Basic] Public Sub New(String,String)

[C#] public Annotation(string,string);

Initializes a new instance of the Annotation class with text, tool tip, and a url.

[Visual Basic] Public Sub New(String,String,String)

[C#] public Annotation(string,string,string);

See Also

Annotation Class | Annotation Members


Annotation Class | Annotation Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Annotation Constructor()

Initializes a new instance of the Annotation class.

[Visual Basic]
Public Function New()
[C#]
public Annotation();

See Also

Annotation Class | Annotation Members | Overload List


Annotation Constructor(Background)

Annotation Class | Annotation Members | Overload List

Language

Visual Basic

C#

Show All

background
Background object for the annotation.
See Also Languages dotnetCHARTING Send comments on this topic.

Annotation Constructor(Background)

Initializes a new instance of the Annotation class with a background. Useful when using an image as the annotation.

[Visual Basic]
Public Function New( _
   ByVal background As Background _
)
[C#]
public Annotation(
   Background background
);

Parameters

background
Background object for the annotation.

See Also

Annotation Class | Annotation Members | Overload List


Annotation Constructor(String)

Annotation Class | Annotation Members | Overload List

Language

Visual Basic

C#

Show All

text
Annotation text.
See Also Languages dotnetCHARTING Send comments on this topic.

Annotation Constructor(String)

Initializes a new instance of the Annotation class with text.

[Visual Basic]
Public Function New( _
   ByVal text As String _
)
[C#]
public Annotation(
   string text
);

Parameters

text
Annotation text.

See Also

Annotation Class | Annotation Members | Overload List


Annotation Constructor(String,String)

Annotation Class | Annotation Members | Overload List

Language

Visual Basic

C#

Show All

text
Annotation text.
toolTip
Annotation tool tip.
See Also Languages dotnetCHARTING Send comments on this topic.

Annotation Constructor(String,String)

Initializes a new instance of the Annotation class with text and a tool tip.

[Visual Basic]
Public Function New( _
   ByVal text As String, _
   ByVal toolTip As String _
)
[C#]
public Annotation(
   string text,
   string toolTip
);

Parameters

text
Annotation text.
toolTip
Annotation tool tip.

See Also

Annotation Class | Annotation Members | Overload List


Annotation Constructor(String,String,String)

Annotation Class | Annotation Members | Overload List

Language

Visual Basic

C#

Show All

text
Annotation text.
toolTip
Annotation tool tip.
url
Annotation url.
See Also Languages dotnetCHARTING Send comments on this topic.

Annotation Constructor(String,String,String)

Initializes a new instance of the Annotation class with text, tool tip, and a url.

[Visual Basic]
Public Function New( _
   ByVal text As String, _
   ByVal toolTip As String, _
   ByVal url As String _
)
[C#]
public Annotation(
   string text,
   string toolTip,
   string url
);

Parameters

text
Annotation text.
toolTip
Annotation tool tip.
url
Annotation url.

See Also

Annotation Class | Annotation Members | Overload List


Annotation Class Properties

Annotation Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Annotation Class Members

For a list of all members of this type, see Annotation members.

Public Properties

Public Property Background (Inherited from Box) | Gets or sets a background object used to fill the interior of this box.
Public Property CornerBottomLeft (Inherited from Box) | Gets or sets the bottom left corner style.
Public Property CornerBottomRight (Inherited from Box) | Gets or sets the bottom right corner style.
Public Property CornerTopLeft (Inherited from Box) | Gets or sets the top left corner style.
Public Property CornerTopRight (Inherited from Box) | Gets or sets the top right corner style.
Public Property DataSource | Gets or sets the DataSource object used to replace tokens in this annotation's label, tool tip, and URL.
Public Property DefaultCorner (Inherited from Box) | Gets or sets the default box corner style.
Public Property DynamicSize | Gets or sets a value that indicates whether a golden rectangle is maintained as the shape of this annotation.
Public Property Hotspot | Gets or sets the Hotspot of this Annotation.
Public Property IconPath (Inherited from Box) | Gets or sets the icon path of this title box.
Public Property InteriorLine (Inherited from Box) | Gets or sets the interior line of this legend box.
Public Property Label (Inherited from Box) | Gets or sets the Label of this box.
Public Property Line (Inherited from Box) | Gets or sets the exterior line of this box.
Public Property Orientation | Gets or sets the annotation's orientation around it's Position and draws a spike to it.
Public Property Padding (Inherited from Box) | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls.
Public Property Position | Overridden. Gets or sets this annotation's position.
Public Property Shadow (Inherited from Box) | Gets or sets the Shadow cast under this box.
Public Property Size | Gets or sets the annotation's size.
Public Property TextAlignmentHorizontal | Gets or sets the horizontal StringAlignment of text in this in the annotation.
Public Property TextAlignmentVertical | Gets or sets the vertical StringAlignment of text in this in the annotation.
Public Property ToolTip | Gets or sets this annotation's tool tip.
Public Property URL | Gets or sets this annotation's hotspot url.
Public Property URLTarget | Gets or sets the target URL of this annotation's link.
Public Property Visible (Inherited from Box) | Gets or sets a value that indicates whether this box is visible.

See Also

Annotation Class | dotnetCHARTING Namespace


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataSource Property

Gets or sets the DataSource object used to replace tokens in this annotation's label, tool tip, and URL.

[Visual Basic]
Public Property DataSource As Object
[C#]
public object DataSource {get; set;}

Remarks

Data sources include Element, Series, and AxisMarker objects. When the source is specified, any tokens associated with the source type may be used.

Example

Instantiates a series and annotation. Sets the series as the DataSource of the annotation. Specifies the '%Name' series token as for the annotation's label. Adds the annotation to a chart.

[C#]

Series mySeries = new Series();
mySeries.Name = "Test Series";
Annotation a = new Annotation();
a.DataSource = mySeries;
a.Label.Text = "%Name";
Chart.Annotations.Add(a);

// When this chart renders, the annotation will read 'Test Series'.

[Visual Basic]

Dim mySeries As New Series()
mySeries.Name = "Test Series"
Dim a As New Annotation()
a.DataSource = mySeries
a.Label.Text = "%Name"
Chart.Annotations.Add(a)

' When this chart renders, the annotation will read 'Test Series'.

See Also

Annotation Class | Annotation Members


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DynamicSize Property

Gets or sets a value that indicates whether a golden rectangle is maintained as the shape of this annotation.

[Visual Basic]
Public Property DynamicSize As Boolean
[C#]
public bool DynamicSize {get; set;}

Remarks

If false, the shape will be determined by the text and will be drawn on a single line unless Size is specified.

See Also

Annotation Class | Annotation Members


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hotspot Property

Gets or sets the Hotspot of this Annotation.

[Visual Basic]
Public Property Hotspot As Hotspot
[C#]
public Hotspot Hotspot {get; set;}

See Also

Annotation Class | Annotation Members


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Orientation Property

Gets or sets the annotation's orientation around it's Position and draws a spike to it.

[Visual Basic]
Public Property Orientation As Orientation
[C#]
public Orientation Orientation {get; set;}

Remarks

If orientation is set to Bottom or Right, BottomRight will be selected. If orientation is set to Top or Left, TopLeft will be selected. If the annotation is added to the Chart.Annotations collection, the default is BottomRight but no spike is drawn.

See Also

Annotation Class | Annotation Members


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Position Property

Gets or sets this annotation's position.

[Visual Basic]
Overrides Public Property Position As Object
[C#]
public override object Position {get; set;}

See Also

Annotation Class | Annotation Members


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Size Property

Gets or sets the annotation's size.

[Visual Basic]
Public Property Size As Size
[C#]
public Size Size {get; set;}

Remarks

If the size is not specified, it is determined by DynamicSize and the size of the specified text.

See Also

Annotation Class | Annotation Members


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TextAlignmentHorizontal Property

Gets or sets the horizontal StringAlignment of text in this in the annotation.

[Visual Basic]
Public Property TextAlignmentHorizontal As StringAlignment
[C#]
public StringAlignment TextAlignmentHorizontal {get; set;}

See Also

Annotation Class | Annotation Members


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TextAlignmentVertical Property

Gets or sets the vertical StringAlignment of text in this in the annotation.

[Visual Basic]
Public Property TextAlignmentVertical As StringAlignment
[C#]
public StringAlignment TextAlignmentVertical {get; set;}

See Also

Annotation Class | Annotation Members


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ToolTip Property

Gets or sets this annotation's tool tip.

[Visual Basic]
Public Property ToolTip As String
[C#]
public string ToolTip {get; set;}

See Also

Annotation Class | Annotation Members


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URL Property

Gets or sets this annotation's hotspot url.

[Visual Basic]
Public Property URL As String
[C#]
public string URL {get; set;}

Return Type

A string representing the url of this annotation.

Example

Usage example.

[Visual Basic]

MyAnnotation.URL = "dotnetcharting.com"

[C#]

myAnnotation.URL = "dotnetcharting.com";

See Also

Annotation Class | Annotation Members


Annotation Class | Annotation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URLTarget Property

Gets or sets the target URL of this annotation's link.

[Visual Basic]
Public Property URLTarget As String
[C#]
public string URLTarget {get; set;}

Example

Usage example

[Visual Basic]

MyAnnotation.URLTarget = "_blank"

[C#]

MyAnnotation.URLTarget = "_blank";

See Also

Annotation Class | Annotation Members


AnnotationCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AnnotationCollection Class

Contains a collection of Annotation objects.

For a list of all members of this type, see AnnotationCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.AnnotationCollection

Syntax

[Visual Basic]
Public Class AnnotationCollection
   Inherits CollectionBase
[C#]
public class AnnotationCollection : CollectionBase

See Also

AnnotationCollection Members | dotnetCHARTING Namespace


AnnotationCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AnnotationCollection Class Members

AnnotationCollection overview

Public Constructors

Public Constructor AnnotationCollection Constructor Creates a new instance of AnnotationCollection with the specified list of Annotation objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Annotation.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified Annotation in this collection.
Public Method Insert | Inserts a Annotation into this collection at a specified index.
Public Method Remove | Removes a specified Annotation from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

AnnotationCollection Class | dotnetCHARTING Namespace


AnnotationCollection Constructor

AnnotationCollection Class | AnnotationCollection Members

Language

Visual Basic

C#

Show All

annotationList
See Also Languages dotnetCHARTING Send comments on this topic.

AnnotationCollection Constructor

Creates a new instance of AnnotationCollection with the specified list of Annotation objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray annotationList() As Annotation _
)
[C#]
public AnnotationCollection(
   params Annotation[] annotationList
);

Parameters

annotationList

See Also

AnnotationCollection Class | AnnotationCollection Members


AnnotationCollection Class Methods

AnnotationCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AnnotationCollection Class Members

For a list of all members of this type, see AnnotationCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Annotation.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified Annotation in this collection.
Public Method Insert | Inserts a Annotation into this collection at a specified index.
Public Method Remove | Removes a specified Annotation from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

AnnotationCollection Class | dotnetCHARTING Namespace


AnnotationCollection Class | AnnotationCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

[Visual Basic] Overloads Public Function Add(Annotation) As Integer

[C#] public int Add(Annotation);

Adds the specified Annotation objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray Annotation())

[C#] public void Add(params Annotation[]);

Adds a specified AnnotationCollection to this collection.

[Visual Basic] Overloads Public Sub Add(AnnotationCollection)

[C#] public void Add(AnnotationCollection);

See Also

AnnotationCollection Class | AnnotationCollection Members


Add(Annotation) Method

AnnotationCollection Class | AnnotationCollection Members | Overload List

Language

Visual Basic

C#

Show All

annotation
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Annotation) Method

[Visual Basic]
Overloads Public Function Add( _
   ByVal annotation As Annotation _
) As Integer
[C#]
public int Add(
   Annotation annotation
);

Parameters

annotation

See Also

AnnotationCollection Class | AnnotationCollection Members | Overload List


Add(Annotation[]) Method

AnnotationCollection Class | AnnotationCollection Members | Overload List

Language

Visual Basic

C#

Show All

annotationList
A list of Annotation objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Annotation[]) Method

Adds the specified Annotation objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray annotationList() As Annotation _
)
[C#]
public void Add(
   params Annotation[] annotationList
);

Parameters

annotationList
A list of Annotation objects to add.

See Also

AnnotationCollection Class | AnnotationCollection Members | Overload List


Add(AnnotationCollection) Method

AnnotationCollection Class | AnnotationCollection Members | Overload List

Language

Visual Basic

C#

Show All

annotationCollection
The AnnotationCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(AnnotationCollection) Method

Adds a specified AnnotationCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal annotationCollection As AnnotationCollection _
)
[C#]
public void Add(
   AnnotationCollection annotationCollection
);

Parameters

annotationCollection
The AnnotationCollection to add.

See Also

AnnotationCollection Class | AnnotationCollection Members | Overload List


Contains Method

AnnotationCollection Class | AnnotationCollection Members

Language

Visual Basic

C#

Show All

annotation
The Annotation to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified Annotation.

[Visual Basic]
Public Function Contains( _
   ByVal annotation As Annotation _
) As Boolean
[C#]
public bool Contains(
   Annotation annotation
);

Parameters

annotation
The Annotation to find.

Return Type

true if the specified Annotation belongs to this collection; otherwise, false.

See Also

AnnotationCollection Class | AnnotationCollection Members


IndexOf Method

AnnotationCollection Class | AnnotationCollection Members

Language

Visual Basic

C#

Show All

annotation
The Annotation to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines the index of a specified Annotation in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal annotation As Annotation _
) As Integer
[C#]
public int IndexOf(
   Annotation annotation
);

Parameters

annotation
The Annotation to find.

Return Type

The zero-based index of the specified Annotation.

See Also

AnnotationCollection Class | AnnotationCollection Members


Insert Method

AnnotationCollection Class | AnnotationCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the Annotation.
annotation
The Annotation to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a Annotation into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal annotation As Annotation _
)
[C#]
public void Insert(
   int index,
   Annotation annotation
);

Parameters

index
The zero-based index into the collection at which to insert the Annotation.
annotation
The Annotation to insert into this collection.

See Also

AnnotationCollection Class | AnnotationCollection Members


Remove Method

AnnotationCollection Class | AnnotationCollection Members

Language

Visual Basic

C#

Show All

annotation
The Annotation to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified Annotation from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal annotation As Annotation _
)
[C#]
public void Remove(
   Annotation annotation
);

Parameters

annotation
The Annotation to remove.

See Also

AnnotationCollection Class | AnnotationCollection Members


AnnotationCollection Class Properties

AnnotationCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AnnotationCollection Class Members

For a list of all members of this type, see AnnotationCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

AnnotationCollection Class | dotnetCHARTING Namespace


Item Property

AnnotationCollection Class | AnnotationCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Annotation
[C#]
public Annotation this[
   int index
]; {get; set;}

Parameters

index

See Also

AnnotationCollection Class | AnnotationCollection Members


Axis Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Axis Class

Specifies smart time label automation. Similar to specific except the first tick will indicate the instance in time and take it's default value from the axis default tick. Specifies smart time label automation. Similar to specific except the first tick will indicate the instance in time and take it's default value from the axis default tick. Specifies the single value time label automation mode. time intervals are specified in RangeIntervalsRepresents an axis drawn on a ChartArea.

For a list of all members of this type, see Axis members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.Axis

Syntax

[Visual Basic]
Public Class Axis
   Implements IInstanceID
[C#]
public class Axis : IInstanceID

Remarks

The axis object is a powerful class that does the following.

  • Defines objects used to draw the axis and fill sections of a ChartArea such as grid lines.
  • Facilitates tick label text formatting and numerous manipulation mechanisms.
  • Defines data element layout and order.
  • Defines an axis Scale, range, and tick frequency.
  • Calculates copies of itself that can perform unit conversions between over one thousand defined units, mark time ranges with a specified TimeInterval, and manipulate each tick label with a specified custom method.
Axes can behave in 3 different modes.
Mode | Description
Value Axis | The value axis dynamically displays a numeric or DateTime range. Properties such as Scale, Interval, TimeInterval and others that relate to ranges apply to this type of axis. Using ChartType.Combo, the y axis is a value axis, with ChartType.Horizontal the x axis is.
Label Axis | The label axis does not display a range of values but rather the names of elements or series. Using ChartType.Combo, the x axis is a label axis and with ChartType.Horizontal the y axis is. Using the DataEngine with DateGrouping generates elements with a numeric value in Element.YValue and a DateTime value in Element.XDateTime. Because the Combo chart's x axis is a label axis the date time value cannot be shown. To remedy this, the DataEngine also populates each element's Name property with a string representation of the DateTime value. This allows the x axis to show date values but it does not allow the use of advanced options such as setting the TimeInterval for those dates. To expose this functionality ChartType.Scatter must be used because the x axis for that chart type acts as a value axis.
Calculated Axis | A calculated or shadow axis is created by using of the Axis.Calculate methods and must be added to the Chart.AxisCollection collection. It is drawn by the original axis and represents the same range but displays it in a different way.

See Also

Axis Members | dotnetCHARTING Namespace


Axis Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Axis Class Members

Axis overview

Public Constructors

Public Constructor Axis Constructor Overloaded.

Public Properties

Public Property AlternateGridBackground | Gets or sets a Background object used to fill the area between every other grid two grid lines.
Public Property CenterTickMarks | Gets or sets a value that indicates whether axis ticks are centered above tick labels or drawn between each label.
Public Property ClearValues | Gets or sets a value which indicates whether tick labels are cleared before LabelOverrides are applied.
Public Property ClusterColumns | Gets or sets a value that indicates whether columns and cylinders are drawn side by side or front to back.
Public Property CombinedElementsCalculation | Gets or sets the Calculation used when multiple elements on a quantitative x axis are located at the same x position. If the elements are columns they will be combined into a single element using this calculation, otherwise, the original elements are plotted.
Public Property CultureName | Gets or sets the culture name used for number and date formatting in conjunction with FormatString.
Public Property DefaultMinorTick | Gets or sets the default dotnetCHARTING.AxisTick used for all generated minor axis ticks.
Public Property DefaultTick | Gets or sets an AxisTick that acts as a vehicle for property settings that will propagate to all other axis ticks on this axis.
Public Property ExtraTicks | A collection of AxisTick objects added to the axis.
Public Property FormatString | Gets or sets the format string used by this axis.
Public Property GenerateElementTicks | Gets or sets a value that indicates whether an AxisTick object is generated for each element's position on this axis.
Public Property GridLine | Gets or sets this axis' grid Line.
Public Property InstanceID |
Public Property Interval | Gets or sets the numeric tick label interval for this axis.
Public Property InvertScale | Gets or sets a value that indicates whether the axis scale is inverted.
Public Property Label | Gets or sets the axis label.
Public Property LabelMarker | Gets or sets an ElementMarker object used on gauge charts in place of the axis' label.
Public Property LabelOverrides | A collection of LabelOverride objects.
Public Property LabelRotate | Gets or sets a value which indicates whether the axis label of this y axis is facing the tick labels or is facing away.
Public Property Line | Gets or sets the axis Line.
Public Property LogarithmicBase | Gets or sets the logarithmic base of logarithmic axis scales. Used only in conjunction with Logarithmic Scales.
Public Property Markers | A collection of AxisMarkers used to highlight sections of this axis.
Public Property Maximum | Gets or sets the upper bounds of this numeric axis' range.
Public Property Minimum | Gets or sets the lower bounds of this numeric axis' range.
Public Property MinimumInterval | Gets or sets the numeric minimum interval value.
Public Property MinorInterval | Gets or sets a numeric value that determines the interval of minor axis ticks.
Public Property MinorTicksPerInterval | Gets or sets the number of minor axis ticks generated between major axis ticks.
Public Property MinorTimeIntervalAdvanced | Gets or sets a TimeIntervalAdvanced object that determines the interval of minor axis ticks.
Public Property Name | Gets or sets the name of this axis.
Public Property NumberPrecision | Gets or sets the number of decimal digits of this axis' format.
Public Property Orientation | Gets or sets the orientation of this axis.
Public Property OrientationAngle | Gets or sets an angle measured in degrees clockwise from the y-axis specifying the direction a gauge axis is oriented.
Public Property OverlappingCircularLabelSeparator | Gets or sets a text label separator used when two axis ticks on a radar's x axis overlap.
Public Property Percent | Gets or sets a value that indicates whether this axis displays percent values.
Public Property Position | Gets or sets the axis positions when 2 or more axes are drawn on the same side of a ChartArea.
Public Property RadarMode | Gets or sets the RadarMode of this axis. Applies when this object is the x axis of a radar chart.
Public Property RangeAngle | Gets or sets an angle measured in degrees that is centered at the orientation angle.
Public Property ReverseSeries | Gets or sets a value that indicates whether the positions of series bound to this axis are reversed.
Public Property ReverseSeriesPositions | Gets or sets a value that indicates whether the positions of series bound to this axis are reversed without reversing legend positions.
Public Property ReverseStack | Gets or sets a value that indicates whether the order of stacked elements is reversed.
Public Property Scale | Gets or sets the scale of this axis.
Public Property ScaleBreakCalendarPattern | Gets or sets a calendar pattern object that specifies the sequence of scale breaks on a time axis.
Public Property ScaleBreakLine | Gets or sets a Line object that is used to outline scale breaks on this axis.
Public Property ScaleBreaks | A collection of ScaleRange objects that represent discontinuations in this axis' scale.
Public Property ScaleBreakStyle | Gets or set a ScaleBreakStyle enumeration member that specifies the scale break style.
Public Property ScaleRange | Gets or sets the scale's high and low values.
Public Property ShowGrid | Gets or sets a value indicating whether grid lines are drawn.
Public Property SmartMinorTicks | Gets or sets a value that indicates whether relevant minor axis ticks will be automatically determined based on major intervals.
Public Property SmartScaleBreak | Gets or sets a value that indicates whether this axis will insert a discontinuity into it's scale if appropriate.
Public Property SpacingPercentage | Gets or sets a percentage (0 - 100) which indicates the spacing between columns, cylinders or groups thereof.
Public Property StaticColumnWidth | Gets or sets the static bar width in pixels.
Public Property SweepAngle | Gets or sets an angle measured in degrees clockwise from the OrientationAngle to the other side of the axis.
Public Property SynchronizeScale | Gets a class that contains options to synchronize the scale of this axis with other scales.
Public Property TickLabel | Gets or sets the Label of all tick marks.
Public Property TickLabelAngle | Gets or sets the angle of axis tick labels when they are angled. Setting this property will not automatically angle tick labels.
Public Property TickLabelMode | Gets or sets the label mode that specifies how tick labels behave.
Public Property TickLabelPadding | Gets or sets a value in pixels indicating the padding between axis elements such as the axis label, tick labels, and ticks lines.
Public Property TickLabelSeparatorLine | Gets or sets the a tick label separator. The separator is automatically used when labels are wrapped. To disable or enable, set the this line's color to Color.Transparent or a valid color respectively.
Public Property TickLine | Gets or sets the tick Line for all ticks marks.
Public Property TickNumberMaximum | Gets or sets the maximum number of tick marks for numeric axis scales.
Public Property TimeInterval | Gets or sets the time interval between tick labels when using the time scale.
Public Property TimeIntervalAdvanced | Gets or sets a class that represents advanced time interval settings to supplement the TimeInterval property.
Public Property TimePadding | Gets or sets the time padding of this axis.
Public Property TimeScaleLabels | Gets the TimeLabelAutomationInfo class that encapsulates axis ticks, format strings, and options of the Time Label Automation features used to represent particular instances in time.
Public Property ZeroLine | Gets or sets the grid Line at the origin or 'point of zero' on this axis.
Public Property ZeroTick | Gets or sets an AxisTick that replaces automatically generated axis tick with a value of zero (0).

Public Methods

Public Method AddCalculatedTick | Overloaded. Adds an AxisTick with a value based on the specified Calculation.
Public Method AddLabelOverride | Overloaded.
Public Method Calculate | Overloaded.
Public Method Clear | Serves as a shortcut to hide this axis.

See Also

Axis Class | dotnetCHARTING Namespace


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Axis Constructor

Overload List

Initializes a new instance of the Axis class.

[Visual Basic] Public Sub New()

[C#] public Axis();

Initializes a new instance of the Axis class with a name and label.

[Visual Basic] Public Sub New(String)

[C#] public Axis(string);

Initializes a new instance of the Axis class that will process the tick values of the specified axis based on a custom method.

[Visual Basic] Public Sub New(String,ChangeValueDelegate,Axis)

[C#] public Axis(string,ChangeValueDelegate,Axis);

Initializes a new instance of the Axis class that will convert the tick labels of the specified axis to the specified units.

[Visual Basic] Public Sub New(String,Object,Object,Axis)

[C#] public Axis(string,object,object,Axis);

Initializes a new instance of the Axis class with a name, label, and scale enumeration.

[Visual Basic] Public Sub New(String,Scale)

[C#] public Axis(string,Scale);

Initializes a new instance of the Axis class that will recalculate time intervals of the specified axis.

[Visual Basic] Public Sub New(String,TimeInterval,Axis)

[C#] public Axis(string,TimeInterval,Axis);

See Also

Axis Class | Axis Members


Axis Class | Axis Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Axis Constructor()

Initializes a new instance of the Axis class.

[Visual Basic]
Public Function New()
[C#]
public Axis();

See Also

Axis Class | Axis Members | Overload List


Axis Constructor(String)

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
Sets the name and label of this axis.
See Also Languages dotnetCHARTING Send comments on this topic.

Axis Constructor(String)

Initializes a new instance of the Axis class with a name and label.

[Visual Basic]
Public Function New( _
   ByVal name As String _
)
[C#]
public Axis(
   string name
);

Parameters

name
Sets the name and label of this axis.

See Also

Axis Class | Axis Members | Overload List


Axis Constructor(String,ChangeValueDelegate,Axis)

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
The name and label of this axis.
ChangeValue
A delegate used to pass a custom method used for processing tick values.
axisToShadow
The original axis whose tick labels will be processed.
See Also Languages dotnetCHARTING Send comments on this topic.

Axis Constructor(String,ChangeValueDelegate,Axis)

Initializes a new instance of the Axis class that will process the tick values of the specified axis based on a custom method.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal ChangeValue As ChangeValueDelegate, _
   ByVal axisToShadow As Axis _
)
[C#]
public Axis(
   string name,
   ChangeValueDelegate ChangeValue,
   Axis axisToShadow
);

Parameters

name
The name and label of this axis.
ChangeValue
A delegate used to pass a custom method used for processing tick values.
axisToShadow
The original axis whose tick labels will be processed.

Remarks

This instance must be added to Chart.AxisCollection. The specified axis must appear on the chart, otherwise, the new instance will have no effect when added to Chart.AxisCollection.

See Also

Axis Class | Axis Members | Overload List


Axis Constructor(String,Object,Object,Axis)

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
The name and label of this axis.
fromUnit
Units representing the values of the original axis.
toUnits
Units to convert to.
axisToShadow
The original axis whose tick labels are converted.
See Also Languages dotnetCHARTING Send comments on this topic.

Axis Constructor(String,Object,Object,Axis)

Initializes a new instance of the Axis class that will convert the tick labels of the specified axis to the specified units.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal fromUnit As Object, _
   ByVal toUnits As Object, _
   ByVal axisToShadow As Axis _
)
[C#]
public Axis(
   string name,
   object fromUnit,
   object toUnits,
   Axis axisToShadow
);

Parameters

name
The name and label of this axis.
fromUnit
Units representing the values of the original axis.
toUnits
Units to convert to.
axisToShadow
The original axis whose tick labels are converted.

Remarks

This instance must be added to Chart.AxisCollection. The specified axis must appear on the chart, otherwise, the new instance will have no effect when added to Chart.AxisCollection.

See Also

Axis Class | Axis Members | Overload List


Axis Constructor(String,Scale)

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
Sets the name and label of this axis.
scale
Sets the scale of this axis.
See Also Languages dotnetCHARTING Send comments on this topic.

Axis Constructor(String,Scale)

Initializes a new instance of the Axis class with a name, label, and scale enumeration.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal scale As Scale _
)
[C#]
public Axis(
   string name,
   Scale scale
);

Parameters

name
Sets the name and label of this axis.
scale
Sets the scale of this axis.

See Also

Axis Class | Axis Members | Overload List


Axis Constructor(String,TimeInterval,Axis)

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
The name and label of this axis.
timeInterval
A TimeInterval enumaration that specifies the new TimeInterval for this axis.
axisToShadow
An axis to derived from.
See Also Languages dotnetCHARTING Send comments on this topic.

Axis Constructor(String,TimeInterval,Axis)

Initializes a new instance of the Axis class that will recalculate time intervals of the specified axis.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal timeInterval As TimeInterval, _
   ByVal axisToShadow As Axis _
)
[C#]
public Axis(
   string name,
   TimeInterval timeInterval,
   Axis axisToShadow
);

Parameters

name
The name and label of this axis.
timeInterval
A TimeInterval enumaration that specifies the new TimeInterval for this axis.
axisToShadow
An axis to derived from.

Remarks

This instance must be added to Chart.AxisCollection. The specified axis must appear on the chart and use Scale.Time, otherwise, the new instance will have no effect when added to Chart.AxisCollection.

See Also

Axis Class | Axis Members | Overload List


Axis Class Methods

Axis Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Axis Class Members

For a list of all members of this type, see Axis members.

Public Methods

Public Method AddCalculatedTick | Overloaded. Adds an AxisTick with a value based on the specified Calculation.
Public Method AddLabelOverride | Overloaded.
Public Method Calculate | Overloaded.
Public Method Clear | Serves as a shortcut to hide this axis.

See Also

Axis Class | dotnetCHARTING Namespace


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AddCalculatedTick Method

Adds an AxisTick with a value based on the specified Calculation.

Overload List

Adds an AxisTick with a value based on the specified Calculation.

[Visual Basic] Overloads Public Sub AddCalculatedTick(Calculation)

[C#] public void AddCalculatedTick(Calculation);

Adds an AxisTick with a value based on the specified Calculation.

[Visual Basic] Overloads Public Sub AddCalculatedTick(Calculation,Series)

[C#] public void AddCalculatedTick(Calculation,Series);

Adds an AxisTick with a value based on the specified Calculation.

[Visual Basic] Overloads Public Sub AddCalculatedTick(Calculation,SeriesCollection)

[C#] public void AddCalculatedTick(Calculation,SeriesCollection);

Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.

[Visual Basic] Overloads Public Sub AddCalculatedTick(String,Calculation)

[C#] public void AddCalculatedTick(string,Calculation);

Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.

[Visual Basic] Overloads Public Sub AddCalculatedTick(String,Calculation,Series)

[C#] public void AddCalculatedTick(string,Calculation,Series);

Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.

[Visual Basic] Overloads Public Sub AddCalculatedTick(String,Calculation,SeriesCollection)

[C#] public void AddCalculatedTick(string,Calculation,SeriesCollection);

See Also

Axis Class | Axis Members


AddCalculatedTick(Calculation) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

calculation
Calculation to perform.
See Also Languages dotnetCHARTING Send comments on this topic.

AddCalculatedTick(Calculation) Method

Adds an AxisTick with a value based on the specified Calculation.

[Visual Basic]
Overloads Public Sub AddCalculatedTick( _
   ByVal calculation As Calculation _
)
[C#]
public void AddCalculatedTick(
   Calculation calculation
);

Parameters

calculation
Calculation to perform.

Remarks

The calculation will be based on all the series using this axis.

See Also

Axis Class | Axis Members | Overload List


AddCalculatedTick(Calculation,Series) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

calculation
Calculation to perform.
series
Series to perform the calculation on.
See Also Languages dotnetCHARTING Send comments on this topic.

AddCalculatedTick(Calculation,Series) Method

Adds an AxisTick with a value based on the specified Calculation.

[Visual Basic]
Overloads Public Sub AddCalculatedTick( _
   ByVal calculation As Calculation, _
   ByVal series As Series _
)
[C#]
public void AddCalculatedTick(
   Calculation calculation,
   Series series
);

Parameters

calculation
Calculation to perform.
series
Series to perform the calculation on.

Remarks

The calculation will be based on the specified Series.

See Also

Axis Class | Axis Members | Overload List


AddCalculatedTick(Calculation,SeriesCollection) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

calculation
Calculation to perform.
series
SeriesCollection to perform the calculation on.
See Also Languages dotnetCHARTING Send comments on this topic.

AddCalculatedTick(Calculation,SeriesCollection) Method

Adds an AxisTick with a value based on the specified Calculation.

[Visual Basic]
Overloads Public Sub AddCalculatedTick( _
   ByVal calculation As Calculation, _
   ByVal series As SeriesCollection _
)
[C#]
public void AddCalculatedTick(
   Calculation calculation,
   SeriesCollection series
);

Parameters

calculation
Calculation to perform.
series
SeriesCollection to perform the calculation on.

Remarks

The calculation will be based on the specified SeriesCollection.

See Also

Axis Class | Axis Members | Overload List


AddCalculatedTick(String,Calculation) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

labelTemplate
A template for the resulting tick label.
calculation
Calculation to perform.
See Also Languages dotnetCHARTING Send comments on this topic.

AddCalculatedTick(String,Calculation) Method

Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.

[Visual Basic]
Overloads Public Sub AddCalculatedTick( _
   ByVal labelTemplate As String, _
   ByVal calculation As Calculation _
)
[C#]
public void AddCalculatedTick(
   string labelTemplate,
   Calculation calculation
);

Parameters

labelTemplate
A template for the resulting tick label.
calculation
Calculation to perform.

Remarks

The calculation will be based on all the series using this axis.

The %Value token in the template will be replaced with the resulting value.

See Also

Axis Class | Axis Members | Overload List


AddCalculatedTick(String,Calculation,Series) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

labelTemplate
A template for the resulting tick label.
calculation
Calculation to perform.
series
Series to perform the calculation on.
See Also Languages dotnetCHARTING Send comments on this topic.

AddCalculatedTick(String,Calculation,Series) Method

Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.

[Visual Basic]
Overloads Public Sub AddCalculatedTick( _
   ByVal labelTemplate As String, _
   ByVal calculation As Calculation, _
   ByVal series As Series _
)
[C#]
public void AddCalculatedTick(
   string labelTemplate,
   Calculation calculation,
   Series series
);

Parameters

labelTemplate
A template for the resulting tick label.
calculation
Calculation to perform.
series
Series to perform the calculation on.

Remarks

The calculation will be based on the specified Series.

The %Value token in the template will be replaced with the resulting value.

See Also

Axis Class | Axis Members | Overload List


AddCalculatedTick(String,Calculation,SeriesCollection) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

labelTemplate
A template for the resulting tick label.
calculation
Calculation to perform.
series
SeriesCollection to perform the calculation on.
See Also Languages dotnetCHARTING Send comments on this topic.

AddCalculatedTick(String,Calculation,SeriesCollection) Method

Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.

[Visual Basic]
Overloads Public Sub AddCalculatedTick( _
   ByVal labelTemplate As String, _
   ByVal calculation As Calculation, _
   ByVal series As SeriesCollection _
)
[C#]
public void AddCalculatedTick(
   string labelTemplate,
   Calculation calculation,
   SeriesCollection series
);

Parameters

labelTemplate
A template for the resulting tick label.
calculation
Calculation to perform.
series
SeriesCollection to perform the calculation on.

Remarks

The calculation will be based on the specified SeriesCollection.

The %Value token in the template will be replaced with the resulting value.

See Also

Axis Class | Axis Members | Overload List


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AddLabelOverride Method

Overload List

Adds a LabelOverride to the LabelOverrides collection.

[Visual Basic] Overloads Public Sub AddLabelOverride(String,String)

[C#] public void AddLabelOverride(string,string);

Adds a LabelOverride to the LabelOverrides collection.

[Visual Basic] Overloads Public Sub AddLabelOverride(String,String,Boolean)

[C#] public void AddLabelOverride(string,string,bool);

See Also

Axis Class | Axis Members


AddLabelOverride(String,String) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

Key
The string to look for.
Value
The string to replace the key with.
See Also Languages dotnetCHARTING Send comments on this topic.

AddLabelOverride(String,String) Method

Adds a LabelOverride to the LabelOverrides collection.

[Visual Basic]
Overloads Public Sub AddLabelOverride( _
   ByVal Key As String, _
   ByVal Value As String _
)
[C#]
public void AddLabelOverride(
   string Key,
   string Value
);

Parameters

Key
The string to look for.
Value
The string to replace the key with.

See Also

Axis Class | Axis Members | Overload List


AddLabelOverride(String,String,Boolean) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

Key
The string to look for.
Value
The string to replace the key with.
IgnoreCase
A Boolean value indicating whether to ignore case for strings or convert the string to a number for comparison with the key so '0' will match '0.0'
See Also Languages dotnetCHARTING Send comments on this topic.

AddLabelOverride(String,String,Boolean) Method

Adds a LabelOverride to the LabelOverrides collection.

[Visual Basic]
Overloads Public Sub AddLabelOverride( _
   ByVal Key As String, _
   ByVal Value As String, _
   ByVal IgnoreCase As Boolean _
)
[C#]
public void AddLabelOverride(
   string Key,
   string Value,
   bool IgnoreCase
);

Parameters

Key
The string to look for.
Value
The string to replace the key with.
IgnoreCase
A Boolean value indicating whether to ignore case for strings or convert the string to a number for comparison with the key so '0' will match '0.0'

See Also

Axis Class | Axis Members | Overload List


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Calculate Method

Overload List

Creates a replica axis object that shadows this axis.

[Visual Basic] Overloads Public Function Calculate(String) As Axis

[C#] public Axis Calculate(string);

Creates a replica axis object with a clear values option that shadows this axis.

[Visual Basic] Overloads Public Function Calculate(String,Boolean) As Axis

[C#] public Axis Calculate(string,bool);

Creates a replica axis object with an orientation and a value clearing option that shadows this axis.

[Visual Basic] Overloads Public Function Calculate(String,Boolean,Orientation) As Axis

[C#] public Axis Calculate(string,bool,Orientation);

Obtains a copy instance of this Axis and processes it's tick values based on the specified method.

[Visual Basic] Overloads Public Function Calculate(String,ChangeValueDelegate) As Axis

[C#] public Axis Calculate(string,ChangeValueDelegate);

Obtains a copy instance of this Axis and performs unit conversion for it's tick values based on the specified units.

[Visual Basic] Overloads Public Function Calculate(String,Object,Object) As Axis

[C#] public Axis Calculate(string,object,object);

Obtains a copy instance of this Axis and performs unit conversion for it's tick values based on the specified units.

[Visual Basic] Overloads Public Function Calculate(String,Object,Object,Boolean) As Axis

[C#] public Axis Calculate(string,object,object,bool);

Obtains a copy instance of this Axis and recalculates it's tick values based a specified TimeInterval.

[Visual Basic] Overloads Public Function Calculate(String,TimeInterval) As Axis

[C#] public Axis Calculate(string,TimeInterval);

Obtains a copy instance of this Axis and recalculates it's tick values based a specified TimeInterval.

[Visual Basic] Overloads Public Function Calculate(String,TimeIntervalAdvanced) As Axis

[C#] public Axis Calculate(string,TimeIntervalAdvanced);

See Also

Axis Class | Axis Members


Calculate(String) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the resulting axis.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate(String) Method

Creates a replica axis object that shadows this axis.

[Visual Basic]
Overloads Public Function Calculate( _
   ByVal name As String _
) As Axis
[C#]
public Axis Calculate(
   string name
);

Parameters

name
Name of the resulting axis.

See Also

Axis Class | Axis Members | Overload List


Calculate(String,Boolean) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the resulting axis.
clearValues
Removes the original (automatically generated) axis ticks.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate(String,Boolean) Method

Creates a replica axis object with a clear values option that shadows this axis.

[Visual Basic]
Overloads Public Function Calculate( _
   ByVal name As String, _
   ByVal clearValues As Boolean _
) As Axis
[C#]
public Axis Calculate(
   string name,
   bool clearValues
);

Parameters

name
Name of the resulting axis.
clearValues
Removes the original (automatically generated) axis ticks.

See Also

Axis Class | Axis Members | Overload List


Calculate(String,Boolean,Orientation) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the resulting axis.
clearValues
Removes the original (automatically generated) axis ticks.
axisOrientation
Orientation of the axis.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate(String,Boolean,Orientation) Method

Creates a replica axis object with an orientation and a value clearing option that shadows this axis.

[Visual Basic]
Overloads Public Function Calculate( _
   ByVal name As String, _
   ByVal clearValues As Boolean, _
   ByVal axisOrientation As Orientation _
) As Axis
[C#]
public Axis Calculate(
   string name,
   bool clearValues,
   Orientation axisOrientation
);

Parameters

name
Name of the resulting axis.
clearValues
Removes the original (automatically generated) axis ticks.
axisOrientation
Orientation of the axis.

See Also

Axis Class | Axis Members | Overload List


Calculate(String,ChangeValueDelegate) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the new axis instance.
ChangeValue
A ChangeValueDelegate pointing to a function that will process the tick labels of the new axis.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate(String,ChangeValueDelegate) Method

Obtains a copy instance of this Axis and processes it's tick values based on the specified method.

[Visual Basic]
Overloads Public Function Calculate( _
   ByVal name As String, _
   ByVal ChangeValue As ChangeValueDelegate _
) As Axis
[C#]
public Axis Calculate(
   string name,
   ChangeValueDelegate ChangeValue
);

Parameters

name
Name of the new axis instance.
ChangeValue
A ChangeValueDelegate pointing to a function that will process the tick labels of the new axis.

Return Type

A new calculated instance of this axis which must be added to the Chart.AxisCollection collection.

See Also

Axis Class | Axis Members | Overload List


Calculate(String,Object,Object) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the new axis.
convertFromUnit
Units to convert from.
convertToUnit
Units to convert to.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate(String,Object,Object) Method

Obtains a copy instance of this Axis and performs unit conversion for it's tick values based on the specified units.

[Visual Basic]
Overloads Public Function Calculate( _
   ByVal name As String, _
   ByVal convertFromUnit As Object, _
   ByVal convertToUnit As Object _
) As Axis
[C#]
public Axis Calculate(
   string name,
   object convertFromUnit,
   object convertToUnit
);

Parameters

name
Name of the new axis.
convertFromUnit
Units to convert from.
convertToUnit
Units to convert to.

Return Type

A new calculated instance of this axis.

See Also

Axis Class | Axis Members | Overload List


Calculate(String,Object,Object,Boolean) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the new axis.
convertFromUnit
Unit to convert from.
convertToUnit
Unit to convert to.
refreshScale
If true, the axis ticks will not necessarily match the original ticks. They will have their own appropriate interval and be easier to read in many cases.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate(String,Object,Object,Boolean) Method

Obtains a copy instance of this Axis and performs unit conversion for it's tick values based on the specified units.

[Visual Basic]
Overloads Public Function Calculate( _
   ByVal name As String, _
   ByVal convertFromUnit As Object, _
   ByVal convertToUnit As Object, _
   ByVal refreshScale As Boolean _
) As Axis
[C#]
public Axis Calculate(
   string name,
   object convertFromUnit,
   object convertToUnit,
   bool refreshScale
);

Parameters

name
Name of the new axis.
convertFromUnit
Unit to convert from.
convertToUnit
Unit to convert to.
refreshScale
If true, the axis ticks will not necessarily match the original ticks. They will have their own appropriate interval and be easier to read in many cases.

Return Type

A new calculated instance of this axis.

See Also

Axis Class | Axis Members | Overload List


Calculate(String,TimeInterval) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the derived axis.
timeInterval
A TimeInterval enumeration that specifies the new time interval for the resulting axis.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate(String,TimeInterval) Method

Obtains a copy instance of this Axis and recalculates it's tick values based a specified TimeInterval.

[Visual Basic]
Overloads Public Function Calculate( _
   ByVal name As String, _
   ByVal timeInterval As TimeInterval _
) As Axis
[C#]
public Axis Calculate(
   string name,
   TimeInterval timeInterval
);

Parameters

name
Name of the derived axis.
timeInterval
A TimeInterval enumeration that specifies the new time interval for the resulting axis.

Return Type

A new instance of the calculated axis.

See Also

Axis Class | Axis Members | Overload List


Calculate(String,TimeIntervalAdvanced) Method

Axis Class | Axis Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the derived axis.
timeIntervalAdvanced
A TimeIntervalAdvanced class that specifies the new time interval for the resulting axis.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate(String,TimeIntervalAdvanced) Method

Obtains a copy instance of this Axis and recalculates it's tick values based a specified TimeInterval.

[Visual Basic]
Overloads Public Function Calculate( _
   ByVal name As String, _
   ByVal timeIntervalAdvanced As TimeIntervalAdvanced _
) As Axis
[C#]
public Axis Calculate(
   string name,
   TimeIntervalAdvanced timeIntervalAdvanced
);

Parameters

name
Name of the derived axis.
timeIntervalAdvanced
A TimeIntervalAdvanced class that specifies the new time interval for the resulting axis.

Return Type

A new instance of the calculated axis.

See Also

Axis Class | Axis Members | Overload List


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Clear Method

Serves as a shortcut to hide this axis.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

Remarks

The axis is cleared by setting the following properties:

Axis.ClearValues = true;
Axis.TickLine.Length = 0;
Axis.Line.Color = Color.Empty;
Axis.TickLabelPadding = 0;
Axis.Label.Text = "";

See Also

Axis Class | Axis Members


Axis Class Properties

Axis Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Axis Class Members

For a list of all members of this type, see Axis members.

Public Properties

Public Property AlternateGridBackground | Gets or sets a Background object used to fill the area between every other grid two grid lines.
Public Property CenterTickMarks | Gets or sets a value that indicates whether axis ticks are centered above tick labels or drawn between each label.
Public Property ClearValues | Gets or sets a value which indicates whether tick labels are cleared before LabelOverrides are applied.
Public Property ClusterColumns | Gets or sets a value that indicates whether columns and cylinders are drawn side by side or front to back.
Public Property CombinedElementsCalculation | Gets or sets the Calculation used when multiple elements on a quantitative x axis are located at the same x position. If the elements are columns they will be combined into a single element using this calculation, otherwise, the original elements are plotted.
Public Property CultureName | Gets or sets the culture name used for number and date formatting in conjunction with FormatString.
Public Property DefaultMinorTick | Gets or sets the default dotnetCHARTING.AxisTick used for all generated minor axis ticks.
Public Property DefaultTick | Gets or sets an AxisTick that acts as a vehicle for property settings that will propagate to all other axis ticks on this axis.
Public Property ExtraTicks | A collection of AxisTick objects added to the axis.
Public Property FormatString | Gets or sets the format string used by this axis.
Public Property GenerateElementTicks | Gets or sets a value that indicates whether an AxisTick object is generated for each element's position on this axis.
Public Property GridLine | Gets or sets this axis' grid Line.
Public Property InstanceID |
Public Property Interval | Gets or sets the numeric tick label interval for this axis.
Public Property InvertScale | Gets or sets a value that indicates whether the axis scale is inverted.
Public Property Label | Gets or sets the axis label.
Public Property LabelMarker | Gets or sets an ElementMarker object used on gauge charts in place of the axis' label.
Public Property LabelOverrides | A collection of LabelOverride objects.
Public Property LabelRotate | Gets or sets a value which indicates whether the axis label of this y axis is facing the tick labels or is facing away.
Public Property Line | Gets or sets the axis Line.
Public Property LogarithmicBase | Gets or sets the logarithmic base of logarithmic axis scales. Used only in conjunction with Logarithmic Scales.
Public Property Markers | A collection of AxisMarkers used to highlight sections of this axis.
Public Property Maximum | Gets or sets the upper bounds of this numeric axis' range.
Public Property Minimum | Gets or sets the lower bounds of this numeric axis' range.
Public Property MinimumInterval | Gets or sets the numeric minimum interval value.
Public Property MinorInterval | Gets or sets a numeric value that determines the interval of minor axis ticks.
Public Property MinorTicksPerInterval | Gets or sets the number of minor axis ticks generated between major axis ticks.
Public Property MinorTimeIntervalAdvanced | Gets or sets a TimeIntervalAdvanced object that determines the interval of minor axis ticks.
Public Property Name | Gets or sets the name of this axis.
Public Property NumberPrecision | Gets or sets the number of decimal digits of this axis' format.
Public Property Orientation | Gets or sets the orientation of this axis.
Public Property OrientationAngle | Gets or sets an angle measured in degrees clockwise from the y-axis specifying the direction a gauge axis is oriented.
Public Property OverlappingCircularLabelSeparator | Gets or sets a text label separator used when two axis ticks on a radar's x axis overlap.
Public Property Percent | Gets or sets a value that indicates whether this axis displays percent values.
Public Property Position | Gets or sets the axis positions when 2 or more axes are drawn on the same side of a ChartArea.
Public Property RadarMode | Gets or sets the RadarMode of this axis. Applies when this object is the x axis of a radar chart.
Public Property RangeAngle | Gets or sets an angle measured in degrees that is centered at the orientation angle.
Public Property ReverseSeries | Gets or sets a value that indicates whether the positions of series bound to this axis are reversed.
Public Property ReverseSeriesPositions | Gets or sets a value that indicates whether the positions of series bound to this axis are reversed without reversing legend positions.
Public Property ReverseStack | Gets or sets a value that indicates whether the order of stacked elements is reversed.
Public Property Scale | Gets or sets the scale of this axis.
Public Property ScaleBreakCalendarPattern | Gets or sets a calendar pattern object that specifies the sequence of scale breaks on a time axis.
Public Property ScaleBreakLine | Gets or sets a Line object that is used to outline scale breaks on this axis.
Public Property ScaleBreaks | A collection of ScaleRange objects that represent discontinuations in this axis' scale.
Public Property ScaleBreakStyle | Gets or set a ScaleBreakStyle enumeration member that specifies the scale break style.
Public Property ScaleRange | Gets or sets the scale's high and low values.
Public Property ShowGrid | Gets or sets a value indicating whether grid lines are drawn.
Public Property SmartMinorTicks | Gets or sets a value that indicates whether relevant minor axis ticks will be automatically determined based on major intervals.
Public Property SmartScaleBreak | Gets or sets a value that indicates whether this axis will insert a discontinuity into it's scale if appropriate.
Public Property SpacingPercentage | Gets or sets a percentage (0 - 100) which indicates the spacing between columns, cylinders or groups thereof.
Public Property StaticColumnWidth | Gets or sets the static bar width in pixels.
Public Property SweepAngle | Gets or sets an angle measured in degrees clockwise from the OrientationAngle to the other side of the axis.
Public Property SynchronizeScale | Gets a class that contains options to synchronize the scale of this axis with other scales.
Public Property TickLabel | Gets or sets the Label of all tick marks.
Public Property TickLabelAngle | Gets or sets the angle of axis tick labels when they are angled. Setting this property will not automatically angle tick labels.
Public Property TickLabelMode | Gets or sets the label mode that specifies how tick labels behave.
Public Property TickLabelPadding | Gets or sets a value in pixels indicating the padding between axis elements such as the axis label, tick labels, and ticks lines.
Public Property TickLabelSeparatorLine | Gets or sets the a tick label separator. The separator is automatically used when labels are wrapped. To disable or enable, set the this line's color to Color.Transparent or a valid color respectively.
Public Property TickLine | Gets or sets the tick Line for all ticks marks.
Public Property TickNumberMaximum | Gets or sets the maximum number of tick marks for numeric axis scales.
Public Property TimeInterval | Gets or sets the time interval between tick labels when using the time scale.
Public Property TimeIntervalAdvanced | Gets or sets a class that represents advanced time interval settings to supplement the TimeInterval property.
Public Property TimePadding | Gets or sets the time padding of this axis.
Public Property TimeScaleLabels | Gets the TimeLabelAutomationInfo class that encapsulates axis ticks, format strings, and options of the Time Label Automation features used to represent particular instances in time.
Public Property ZeroLine | Gets or sets the grid Line at the origin or 'point of zero' on this axis.
Public Property ZeroTick | Gets or sets an AxisTick that replaces automatically generated axis tick with a value of zero (0).

See Also

Axis Class | dotnetCHARTING Namespace


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AlternateGridBackground Property

Gets or sets a Background object used to fill the area between every other grid two grid lines.

[Visual Basic]
Public Property AlternateGridBackground As Background
[C#]
public Background AlternateGridBackground {get; set;}

Return Type

A Background object that will fill every other grid area.

Remarks

To disable this feature, set AlternateGridBackground.Color = Color.Empty.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CenterTickMarks Property

Gets or sets a value that indicates whether axis ticks are centered above tick labels or drawn between each label.

[Visual Basic]
Public Property CenterTickMarks As Boolean
[C#]
public bool CenterTickMarks {get; set;}

Remarks

When false, Axis.DefaultTick.Line properties are used for all tick lines.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ClearValues Property

Gets or sets a value which indicates whether tick labels are cleared before LabelOverrides are applied.

[Visual Basic]
Public Property ClearValues As Boolean
[C#]
public bool ClearValues {get; set;}

Return Type

A boolean value which indicates whether tick labels are cleared before LabelOverrides are applied.

Remarks

Only the tick labels that are not overridden are cleared.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ClusterColumns Property

Gets or sets a value that indicates whether columns and cylinders are drawn side by side or front to back.

[Visual Basic]
Public Property ClusterColumns As Boolean
[C#]
public bool ClusterColumns {get; set;}

Return Type

A boolean value that indicates whether columns and cylinders are drawn side by side or front to back.

Remarks

(Applies to label axes) When true, columns and cylinders are drawn side by side.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CombinedElementsCalculation Property

Gets or sets the Calculation used when multiple elements on a quantitative x axis are located at the same x position. If the elements are columns they will be combined into a single element using this calculation, otherwise, the original elements are plotted.

[Visual Basic]
Public Property CombinedElementsCalculation As Calculation
[C#]
public Calculation CombinedElementsCalculation {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CultureName Property

Gets or sets the culture name used for number and date formatting in conjunction with FormatString.

[Visual Basic]
Public Property CultureName As String
[C#]
public string CultureName {get; set;}

Return Type

A string representing the culture name of this axis.

Remarks

The culture name is applied to tick values and data charted on this axis. See the CultureInfo class for possible names of a culture.

(This property applies to value axes)

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultMinorTick Property

Gets or sets the default dotnetCHARTING.AxisTick used for all generated minor axis ticks.

[Visual Basic]
Public Property DefaultMinorTick As AxisTick
[C#]
public AxisTick DefaultMinorTick {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultTick Property

Gets or sets an AxisTick that acts as a vehicle for property settings that will propagate to all other axis ticks on this axis.

[Visual Basic]
Public Property DefaultTick As AxisTick
[C#]
public AxisTick DefaultTick {get; set;}

Remarks

The property settings of this object will not overwrite properties explicitly set for any given AxisTick.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ExtraTicks Property

A collection of AxisTick objects added to the axis.

[Visual Basic]
Public ReadOnly Property ExtraTicks As AxisTickCollection
[C#]
public AxisTickCollection ExtraTicks {get;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FormatString Property

Gets or sets the format string used by this axis.

[Visual Basic]
Public Property FormatString As String
[C#]
public string FormatString {get; set;}

Return Type

A string representing the format used by values associated with this axis.

Remarks

Tick labels and labels of elements bound to this axis will be formatted with this format string.

(This property applies to value axes)

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GenerateElementTicks Property

Gets or sets a value that indicates whether an AxisTick object is generated for each element's position on this axis.

[Visual Basic]
Public Property GenerateElementTicks As Boolean
[C#]
public bool GenerateElementTicks {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GridLine Property

Gets or sets this axis' grid Line.

[Visual Basic]
Public Property GridLine As Line
[C#]
public Line GridLine {get; set;}

Return Type

A Line object describing grid line visual properties.

Remarks

Grid lines are drawn for each tick mark on an axis to the other side of a ChartArea. To disable grid lines set GridLine.Color = Color.Empty or Axis.ShowGrid = false.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InstanceID Property

[Visual Basic]
Public Property InstanceID As Integer
[C#]
public int InstanceID {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Interval Property

Gets or sets the numeric tick label interval for this axis.

[Visual Basic]
Public Property Interval As Double
[C#]
public double Interval {get; set;}

Return Type

A Double that specifies the numeric tick label interval for this axis.

Remarks

Tick labels will increment by this value starting at Minimum and ending at Maximum if specified. If not set, the interval is automatically determined based on the data range.

(Applies to quantitative axes with numeric scales)

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InvertScale Property

Gets or sets a value that indicates whether the axis scale is inverted.

[Visual Basic]
Public Property InvertScale As Boolean
[C#]
public bool InvertScale {get; set;}

Remarks

When true the axis ticks will be reversed.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Label Property

Gets or sets the axis label.

[Visual Basic]
Public Property Label As Label
[C#]
public Label Label {get; set;}

Return Type

The main Label of this axis.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelMarker Property

Gets or sets an ElementMarker object used on gauge charts in place of the axis' label.

[Visual Basic]
Public Property LabelMarker As ElementMarker
[C#]
public ElementMarker LabelMarker {get; set;}

Remarks

The marker will be positioned between the needle base and the center of the gauge axis.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelOverrides Property

A collection of LabelOverride objects.

[Visual Basic]
Public Property LabelOverrides As LabelOverrideCollection
[C#]
public LabelOverrideCollection LabelOverrides {get; set;}

Remarks

LabelOverrides defines a string find and replace pair used to manipulate tick labels.

Example

This example will replace each tick label value of '10' with 'High'.

[C#]

            [C#]
Axis a = new Axis();
a.LabelOverrides.Add( new LabelOverride("10","High") );

[C#]

            [Visual Basic]
Dim a As New Axis()
a.LabelOverrides.Add( new LabelOverride("10","High") )

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelRotate Property

Gets or sets a value which indicates whether the axis label of this y axis is facing the tick labels or is facing away.

[Visual Basic]
Public Property LabelRotate As Boolean
[C#]
public bool LabelRotate {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Property

Gets or sets the axis Line.

[Visual Basic]
Public Property Line As Line
[C#]
public Line Line {get; set;}

Return Type

A Line object drawn across the axis.

Remarks

When the origin or 'point of zero' is visible on the axis, this line is drawn twice and away from the origin in order for line caps to appear correctly (Line.StartCap, Line.EndCap).

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LogarithmicBase Property

Gets or sets the logarithmic base of logarithmic axis scales. Used only in conjunction with Logarithmic Scales.

[Visual Basic]
Public Property LogarithmicBase As Double
[C#]
public double LogarithmicBase {get; set;}

Remarks

This property is used in conjunction with enumeration members Scale.Logarithmic and Scale.LogarithmicStacked.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Markers Property

A collection of AxisMarkers used to highlight sections of this axis.

[Visual Basic]
Public Property Markers As AxisMarkerCollection
[C#]
public AxisMarkerCollection Markers {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Maximum Property

Gets or sets the upper bounds of this numeric axis' range.

[Visual Basic]
Public Property Maximum As Object
[C#]
public object Maximum {get; set;}

Return Type

A Double indicating the maximum value of this axis.

Remarks

Applies to value axes. When not specified, this value is set relative to the maximum range of the plotted data.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Minimum Property

Gets or sets the lower bounds of this numeric axis' range.

[Visual Basic]
Public Property Minimum As Object
[C#]
public object Minimum {get; set;}

Return Type

A Double indicating the minimum value of this axis.

Remarks

Applies to value axes. When not specified, this value defaults to 0. When the range axis scale is used, it will be set relative to the minimum range of the plotted data.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MinimumInterval Property

Gets or sets the numeric minimum interval value.

[Visual Basic]
Public Property MinimumInterval As Double
[C#]
public double MinimumInterval {get; set;}

Remarks

This allows you to prevent the axis scales from using intervals that are smaller than a single unit of your data. For example a chart showing votes where the maximum value is three may show intervals at .5, which cant represent any data for your chart. In this case setting this value to 1 will represent the chart data better.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MinorInterval Property

Gets or sets a numeric value that determines the interval of minor axis ticks.

[Visual Basic]
Public Property MinorInterval As Double
[C#]
public double MinorInterval {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MinorTicksPerInterval Property

Gets or sets the number of minor axis ticks generated between major axis ticks.

[Visual Basic]
Public Property MinorTicksPerInterval As Integer
[C#]
public int MinorTicksPerInterval {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MinorTimeIntervalAdvanced Property

Gets or sets a TimeIntervalAdvanced object that determines the interval of minor axis ticks.

[Visual Basic]
Public Property MinorTimeIntervalAdvanced As TimeIntervalAdvanced
[C#]
public TimeIntervalAdvanced MinorTimeIntervalAdvanced {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Name Property

Gets or sets the name of this axis.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Return Type

A string representing the name of this axis.

Remarks

If Axis.Label.Text is not specified this value will be used. The name is also used to identify the axis with element or series tokens.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

NumberPrecision Property

Gets or sets the number of decimal digits of this axis' format.

[Visual Basic]
Public Property NumberPrecision As Integer
[C#]
public int NumberPrecision {get; set;}

Remarks

If not specified, this value will be determined automatically.

(Applies to value axes)

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Orientation Property

Gets or sets the orientation of this axis.

[Visual Basic]
Public Property Orientation As Orientation
[C#]
public Orientation Orientation {get; set;}

Return Type

An Orientation enumeration which specifies on which side of a ChartArea the axis is rendered.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

OrientationAngle Property

Gets or sets an angle measured in degrees clockwise from the y-axis specifying the direction a gauge axis is oriented.

[Visual Basic]
Public Property OrientationAngle As Integer
[C#]
public int OrientationAngle {get; set;}

Remarks

When RangeAngle is set, the orientation is the point the middle of the axis is facing. When SweepAngle is set, the orientation is the starting angle of the sweep.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

OverlappingCircularLabelSeparator Property

Gets or sets a text label separator used when two axis ticks on a radar's x axis overlap.

[Visual Basic]
Public Property OverlappingCircularLabelSeparator As String
[C#]
public string OverlappingCircularLabelSeparator {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Percent Property

Gets or sets a value that indicates whether this axis displays percent values.

[Visual Basic]
Public Property Percent As Boolean
[C#]
public bool Percent {get; set;}

Return Type

A Boolean value indicating whether this this axis displays percent values.

Remarks

When true, a percent sign sign will be added to the end of tick labels and the Maximum will snap to 100 percent if the plotted data's range falls between 50 and 100.

(Applies to value axes not using Scale.Time)

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Position Property

Gets or sets the axis positions when 2 or more axes are drawn on the same side of a ChartArea.

[Visual Basic]
Public Property Position As Integer
[C#]
public int Position {get; set;}

Return Type

An integer specifying the position of the axis.

Remarks

Lower values will be drawn closer to the front. This will also affect the order of series bound the the axes.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RadarMode Property

Gets or sets the RadarMode of this axis. Applies when this object is the x axis of a radar chart.

[Visual Basic]
Public Property RadarMode As RadarMode
[C#]
public RadarMode RadarMode {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RangeAngle Property

Gets or sets an angle measured in degrees that is centered at the orientation angle.

[Visual Basic]
Public Property RangeAngle As Integer
[C#]
public int RangeAngle {get; set;}

Remarks

Example: If the orientation angle is 100 and the range angle is 100, the axis will begin at 50 degrees and end at 150 degrees.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ReverseSeries Property

Gets or sets a value that indicates whether the positions of series bound to this axis are reversed.

[Visual Basic]
Public Property ReverseSeries As Boolean
[C#]
public bool ReverseSeries {get; set;}

Return Type

A Boolean value that indicates whether the positions of series bound to this axis are reversed.

Remarks

(Applies to label axes)

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ReverseSeriesPositions Property

Gets or sets a value that indicates whether the positions of series bound to this axis are reversed without reversing legend positions.

[Visual Basic]
Public Property ReverseSeriesPositions As Boolean
[C#]
public bool ReverseSeriesPositions {get; set;}

Return Type

A Boolean value that indicates whether the positions of series bound to this axis are reversed without reversing legend positions.

Remarks

Applies to label axes.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ReverseStack Property

Gets or sets a value that indicates whether the order of stacked elements is reversed.

[Visual Basic]
Public Property ReverseStack As Boolean
[C#]
public bool ReverseStack {get; set;}

Return Type

A Boolean value that indicates whether the order of stacked elements is reversed.

Remarks

Applies to value axes using a stacked axis Scale.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Scale Property

Gets or sets the scale of this axis.

[Visual Basic]
Public Property Scale As Scale
[C#]
public Scale Scale {get; set;}

Return Type

The axis Scale.

Remarks

Applies to value axes.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ScaleBreakCalendarPattern Property

Gets or sets a calendar pattern object that specifies the sequence of scale breaks on a time axis.

[Visual Basic]
Public Property ScaleBreakCalendarPattern As CalendarPattern
[C#]
public CalendarPattern ScaleBreakCalendarPattern {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ScaleBreakLine Property

Gets or sets a Line object that is used to outline scale breaks on this axis.

[Visual Basic]
Public Property ScaleBreakLine As Line
[C#]
public Line ScaleBreakLine {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ScaleBreaks Property

A collection of ScaleRange objects that represent discontinuations in this axis' scale.

[Visual Basic]
Public ReadOnly Property ScaleBreaks As ScaleRangeCollection
[C#]
public ScaleRangeCollection ScaleBreaks {get;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ScaleBreakStyle Property

Gets or set a ScaleBreakStyle enumeration member that specifies the scale break style.

[Visual Basic]
Public Property ScaleBreakStyle As ScaleBreakStyle
[C#]
public ScaleBreakStyle ScaleBreakStyle {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ScaleRange Property

Gets or sets the scale's high and low values.

[Visual Basic]
Public Property ScaleRange As ScaleRange
[C#]
public ScaleRange ScaleRange {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ShowGrid Property

Gets or sets a value indicating whether grid lines are drawn.

[Visual Basic]
Public Property ShowGrid As Boolean
[C#]
public bool ShowGrid {get; set;}

Return Type

A boolean value that indicates whether grid lines are drawn.

Remarks

If false, no grid lines will be drawn.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartMinorTicks Property

Gets or sets a value that indicates whether relevant minor axis ticks will be automatically determined based on major intervals.

[Visual Basic]
Public Property SmartMinorTicks As Boolean
[C#]
public bool SmartMinorTicks {get; set;}

Remarks

This property applies to automatic major intervals, not user defined intervals.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartScaleBreak Property

Gets or sets a value that indicates whether this axis will insert a discontinuity into it's scale if appropriate.

[Visual Basic]
Public Property SmartScaleBreak As Boolean
[C#]
public bool SmartScaleBreak {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members | StaticColumnWidth Property | StaticColumnWidth Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SpacingPercentage Property

Gets or sets a percentage (0 - 100) which indicates the spacing between columns, cylinders or groups thereof.

[Visual Basic]
Public Property SpacingPercentage As Single
[C#]
public float SpacingPercentage {get; set;}

Return Type

A Single value indicating the spacing percentage between columns, cylinders or groups thereof.

Remarks

(Applies to label axes)

See Also

Axis Class | Axis Members | StaticColumnWidth Property | StaticColumnWidth Property


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StaticColumnWidth Property

Gets or sets the static bar width in pixels.

[Visual Basic]
Public Property StaticColumnWidth As Single
[C#]
public float StaticColumnWidth {get; set;}

Return Type

A Single value indicating the static width of columns, cylinders or groups thereof.

Remarks

A value of 0 = Automatic and spacing will be based on the SpacingPercentage property.

(Applies to label axes)

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SweepAngle Property

Gets or sets an angle measured in degrees clockwise from the OrientationAngle to the other side of the axis.

[Visual Basic]
Public Property SweepAngle As Integer
[C#]
public int SweepAngle {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SynchronizeScale Property

Gets a class that contains options to synchronize the scale of this axis with other scales.

[Visual Basic]
Public ReadOnly Property SynchronizeScale As Axis.ScaleSync
[C#]
public Axis.ScaleSync SynchronizeScale {get;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TickLabel Property

Gets or sets the Label of all tick marks.

[Visual Basic]
Public Property TickLabel As Label
[C#]
public Label TickLabel {get; set;}

Return Type

A Label object that specifies tick label properties.

Remarks

When the axis is a label axis, the tick label's text can be populated with tokens which represent information about the plotted data.

Example

[C#]

Chart.XAxis.TickLabel.Text = "%Name - %YValue";
// When rendered, the x axis' tick labels will read something like this: "Element's Name - 159"
// where "Element's" Name is the name of an element and "159" is it's value.

[Visual Basic]

Chart.XAxis.TickLabel.Text = "%Name - %YValue"
' When rendered, the x axis' tick labels will read something like this: "Element's Name - 159"
' where "Element's" Name is the name of an element and "159" is it's value.

See Also

Axis Class | Axis Members


Axis Class | Axis Members | TickLabelMode Property | TickLabelMode Enumeration

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TickLabelAngle Property

Gets or sets the angle of axis tick labels when they are angled. Setting this property will not automatically angle tick labels.

[Visual Basic]
Public Property TickLabelAngle As Single
[C#]
public float TickLabelAngle {get; set;}

Remarks

To force tick label angles, set Axis.TickLabelMode = Axis.TickLabelMode.Angled.

See Also

Axis Class | Axis Members | TickLabelMode Property | TickLabelMode Enumeration


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TickLabelMode Property

Gets or sets the label mode that specifies how tick labels behave.

[Visual Basic]
Public Property TickLabelMode As TickLabelMode
[C#]
public TickLabelMode TickLabelMode {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TickLabelPadding Property

Gets or sets a value in pixels indicating the padding between axis elements such as the axis label, tick labels, and ticks lines.

[Visual Basic]
Public Property TickLabelPadding As Integer
[C#]
public int TickLabelPadding {get; set;}

Return Type

An integer specifying the padding between axis elements.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TickLabelSeparatorLine Property

Gets or sets the a tick label separator. The separator is automatically used when labels are wrapped. To disable or enable, set the this line's color to Color.Transparent or a valid color respectively.

[Visual Basic]
Public Property TickLabelSeparatorLine As Line
[C#]
public Line TickLabelSeparatorLine {get; set;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TickLine Property

Gets or sets the tick Line for all ticks marks.

[Visual Basic]
Public Property TickLine As Line
[C#]
public Line TickLine {get; set;}

Return Type

A Line object applied to all tick lines of this axis.

Remarks

Setting TickLine.Length will specify the tick line's length.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TickNumberMaximum Property

Gets or sets the maximum number of tick marks for numeric axis scales.

[Visual Basic]
Public Property TickNumberMaximum As Integer
[C#]
public int TickNumberMaximum {get; set;}

Return Type

An integer specifying the maximum number of tick marks for this axis.

Remarks

. Three (3) is lowest number of tick marks possible.

(Applies to value axes with numeric scales)

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TimeInterval Property

Gets or sets the time interval between tick labels when using the time scale.

[Visual Basic]
Public Property TimeInterval As TimeInterval
[C#]
public TimeInterval TimeInterval {get; set;}

Return Type

A TimeInterval enumeration that specifies the time interval between tick labels when using the time scale.

Remarks

(Applies to quantitative axes using Scale.Time)

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TimeIntervalAdvanced Property

Gets or sets a class that represents advanced time interval settings to supplement the TimeInterval property.

[Visual Basic]
Public Property TimeIntervalAdvanced As TimeIntervalAdvanced
[C#]
public TimeIntervalAdvanced TimeIntervalAdvanced {get; set;}

Remarks

This property can be used in conjunction with TimeInterval or override it completley.

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TimePadding Property

Gets or sets the time padding of this axis.

[Visual Basic]
Public Property TimePadding As TimeSpan
[C#]
public TimeSpan TimePadding {get; set;}

Return Type

A TimeSpan object indicating the amount of time shown before and after the plotted data.

Remarks

(Applies to value axes using Scale.Time)

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TimeScaleLabels Property

Gets the TimeLabelAutomationInfo class that encapsulates axis ticks, format strings, and options of the Time Label Automation features used to represent particular instances in time.

[Visual Basic]
Public ReadOnly Property TimeScaleLabels As Axis.TimeScaleLabelInfo
[C#]
public Axis.TimeScaleLabelInfo TimeScaleLabels {get;}

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ZeroLine Property

Gets or sets the grid Line at the origin or 'point of zero' on this axis.

[Visual Basic]
Public Property ZeroLine As Line
[C#]
public Line ZeroLine {get; set;}

Return Type

A grid Line drawn at the origin of this axis.

Remarks

Applies to value axes with numeric scales except Scale.Logarithmic

See Also

Axis Class | Axis Members


Axis Class | Axis Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ZeroTick Property

Gets or sets an AxisTick that replaces automatically generated axis tick with a value of zero (0).

[Visual Basic]
Public Property ZeroTick As AxisTick
[C#]
public AxisTick ZeroTick {get; set;}

Remarks

This tick can be disabled by setting it to null or it can be overridden by adding a new AxisTick with a value of zero to the ExtraTicks collection.

See Also

Axis Class | Axis Members


Axis.ScaleSync Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Axis.ScaleSync Class

An extension to the SynchronizeScale property. Defines the scale synchronization behavior of an axis.

For a list of all members of this type, see Axis.ScaleSync members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.AxisCollection
dotnetCHARTING.Axis.ScaleSync

Syntax

[Visual Basic]
Public Class Axis.ScaleSync
   Inherits AxisCollection
[C#]
public class Axis.ScaleSync : AxisCollection

See Also

Axis.ScaleSync Members | dotnetCHARTING Namespace


Axis.ScaleSync Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Axis.ScaleSync Class Members

Axis.ScaleSync overview

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item (Inherited from AxisCollection) | Gets or sets the object at a specified index.
Public Property Mode | Gets or sets the SynchronizeScaleMode of this scale sync class.
Public Property PreserveScale | Gets or sets a value that determines whether the axis scale will change when re-drawn on another ChartArea.

Public Methods

Public Method Add (Inherited from AxisCollection) | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains (Inherited from AxisCollection) | Determines whether this collection contains a specified Axis.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf (Inherited from AxisCollection) | Determines the index of a specified Axis in this collection.
Public Method Insert (Inherited from AxisCollection) | Inserts a Axis into this collection at a specified index.
Public Method Remove (Inherited from AxisCollection) | Removes a specified Axis from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

Axis.ScaleSync Class | dotnetCHARTING Namespace


Axis.ScaleSync Class Properties

Axis.ScaleSync Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Axis.ScaleSync Class Members

For a list of all members of this type, see Axis.ScaleSync members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item (Inherited from AxisCollection) | Gets or sets the object at a specified index.
Public Property Mode | Gets or sets the SynchronizeScaleMode of this scale sync class.
Public Property PreserveScale | Gets or sets a value that determines whether the axis scale will change when re-drawn on another ChartArea.

See Also

Axis.ScaleSync Class | dotnetCHARTING Namespace


Axis.ScaleSync Class | Axis.ScaleSync Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Mode Property

Gets or sets the SynchronizeScaleMode of this scale sync class.

[Visual Basic]
Public Property Mode As SynchronizeScaleMode
[C#]
public SynchronizeScaleMode Mode {get; set;}

See Also

Axis.ScaleSync Class | Axis.ScaleSync Members


Axis.ScaleSync Class | Axis.ScaleSync Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PreserveScale Property

Gets or sets a value that determines whether the axis scale will change when re-drawn on another ChartArea.

[Visual Basic]
Public Property PreserveScale As Boolean
[C#]
public bool PreserveScale {get; set;}

See Also

Axis.ScaleSync Class | Axis.ScaleSync Members


Axis.TimeScaleLabelInfo Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Axis.TimeScaleLabelInfo Class

Encapsulates time scale label behavior options in addition to axis ticks and format strings used instead of the main axis ticks when they represent particular instances in time.

For a list of all members of this type, see Axis.TimeScaleLabelInfo members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.Axis.TimeScaleLabelInfo

Syntax

[Visual Basic]
Public Class Axis.TimeScaleLabelInfo
[C#]
public class Axis.TimeScaleLabelInfo

Example

[C#]

<%@ Page Language="C#" Description="dotnetCHARTING Component" %>
<%@ Register TagPrefix="dotnet"  Namespace="dotnetCHARTING" Assembly="dotnetCHARTING"%>
<%@ Import Namespace="System.Drawing" %>
<HTML>
    <HEAD>
        <TITLE>.netCHARTING Sample</TITLE>
        <script runat="server">

void Page_Load(Object sender,EventArgs e)
{

    Chart.Type = ChartType.Combo;//Horizontal;
    Chart.Width = 600;
    Chart.Height = 350;
    Chart.TempDirectory = "temp";
    Chart.Debug = true;
    Chart.Title = "Smart time labels.";
    Chart.DefaultSeries.Type = SeriesType.AreaLine;

    Chart.XAxis.Label.Text = "Smart time labels that describe instance in time.";

    // This sample will demonstrate using smart time labels.
    Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Smart;

    // *DYNAMIC DATA NOTE*
    // This sample uses random data to populate the chart. To populate
    // a chart with database data see the following resources:
    // - Classic samples folder
    // - Help File > Data Tutorials
    // - Sample: features/DataEngine.aspx

    // Add the random data.
    Chart.SeriesCollection.Add(getRandomData());

}

SeriesCollection getRandomData()
{
    SeriesCollection SC = new SeriesCollection();
    Random myR = new Random(1);
    DateTime dt = new DateTime(2004,8,30);
    for(int a = 0; a < 1; a++)
    {
        Series s = new Series();
        s.Name = "Series " + a;
        for(int b = 0; b < 20; b++)
        {
            Element e = new Element();
            e.YValue = myR.Next(100);
            e.XDateTime = dt = dt.AddDays(10);
            s.Elements.Add(e);
        }
        SC.Add(s);
    }
    return SC;
}
        </script>
    </HEAD>
    <BODY>
        <DIV align="center">
            <dotnet:Chart id="Chart" runat="server" Width="568px" Height="344px">
            </dotnet:Chart>
        </DIV>
    </BODY>
</HTML>

[Visual Basic]

<%@ Page Language="VB" Description="dotnetCHARTING Component" %>
<%@ Register TagPrefix="dotnet" Namespace="dotnetCHARTING" Assembly="dotnetCHARTING"%>
<%@ Import Namespace="System.Drawing" %>
<HTML>
    <HEAD>
        <TITLE>.netCHARTING Sample</TITLE>
        <script runat="server">
Sub Page_Load(sender As [Object], e As EventArgs)

   Chart.Type = ChartType.Combo
   Chart.Width = Unit.Parse(600)
   Chart.Height = Unit.Parse(350)
   Chart.TempDirectory = "temp"
   Chart.Debug = True
   Chart.Title = "Smart time labels."
   Chart.DefaultSeries.Type = SeriesType.AreaLine

   Chart.XAxis.Label.Text = "Smart time labels that describe instance in time."

   ' This sample will demonstrate using smart time labels.
   Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Smart

   ' *DYNAMIC DATA NOTE*
   ' This sample uses random data to populate the chart. To populate
   ' a chart with database data see the following resources:
   ' - Classic samples folder
   ' - Help File > Data Tutorials
   ' - Sample: features/DataEngine.aspx
   ' Add the random data.
   Chart.SeriesCollection.Add(getRandomData())
End Sub 'Page_Load

Function getRandomData() As SeriesCollection
   Dim SC As New SeriesCollection()
   Dim myR As New Random(1)
   Dim dt As New DateTime(2004, 8, 30)
   Dim a As Integer
   For a = 0 To 0
      Dim s As New Series()
      s.Name = "Series " + Convert.ToString(a)
      Dim b As Integer
      For b = 0 To 19
         Dim e As New Element()
         e.YValue = myR.Next(100)
         e.XDateTime = dt.AddDays(10)
         dt=dt.AddDays(10)
         s.Elements.Add(e)
      Next b
      SC.Add(s)
   Next a
   Return SC
End Function 'getRandomData

</script>
    </HEAD>
    <BODY>
        <DIV align="center">
            <dotnet:Chart id="Chart" runat="server" Width="568px" Height="344px">
            </dotnet:Chart>
        </DIV>
    </BODY>
</HTML>

See Also

Axis.TimeScaleLabelInfo Members | dotnetCHARTING Namespace


Axis.TimeScaleLabelInfo Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Axis.TimeScaleLabelInfo Class Members

Axis.TimeScaleLabelInfo overview

Public Constructors

Public Constructor Axis.TimeScaleLabelInfo Constructor

Public Properties

Public Property DayFormatString | Gets or sets the format string used with DateTime values that represent the instance in time wher%%%(Shortcut to: Element.Hotspot.URL)e the day changes.
Public Property DayTick | Gets or sets the AxisTick used to represent the instance in time where the day changes.
Public Property HourFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the hour changes.
Public Property HourTick | Gets or sets the AxisTick used to represent the instance in time where the hour changes.
Public Property MillisecondFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the millisecond changes.
Public Property MillisecondTick | Gets or sets the axis tick used to represent the instance in time where the millisecond changes.
Public Property MinuteFormatString | Gets or sets the format string used with DateTimevalues that represent the instance in time where the minute changes.
Public Property MinuteTick | Gets or sets the AxisTick used to represent the instance in time where the minute changes.
Public Property Mode | Gets or sets the time label automation mode for single value labels.
Public Property MonthFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the Month changes.
Public Property MonthTick | Gets or sets the AxisTick used to represent the instance in time where the Month changes.
Public Property PercentEdgeOverlapToRemoveTicks | Gets or sets a value that indicates whether auto-generated range ticks are trimmed if more than the specified percentage of the label lingers outside of the axis bounds.
Public Property QuarterFormatString | Gets or sets the format string used with DateTime labels of quarter range ticks.
Public Property QuarterTick | Gets or sets the AxisTick used to represent a year's quarter range ticks.
Public Property RangeIntervals | Gets or sets an TimeIntervalCollection used with modes Range and AddRange. When no intervals are specified the intervals will be determined dynamically.
Public Property RangeMode | Gets or sets the time label automation mode for range value labels.
Public Property SecondFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the second changes.
Public Property SecondTick | Gets or sets the AxisTick used to represent the instance in time where the second changes.
Public Property WeekFormatString | Gets or sets the format string used with DateTime labels of week range ticks.
Public Property WeekTick | Gets or sets the AxisTick used to represent a week range ticks.
Public Property YearFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the year changes.
Public Property YearTick | Gets or sets the AxisTick used to represent the instance in time where the Year changes.

See Also

Axis.TimeScaleLabelInfo Class | dotnetCHARTING Namespace


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Axis.TimeScaleLabelInfo Constructor

[Visual Basic]
Public Function New()
[C#]
public Axis.TimeScaleLabelInfo();

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class Properties

Axis.TimeScaleLabelInfo Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Axis.TimeScaleLabelInfo Class Members

For a list of all members of this type, see Axis.TimeScaleLabelInfo members.

Public Properties

Public Property DayFormatString | Gets or sets the format string used with DateTime values that represent the instance in time wher%%%(Shortcut to: Element.Hotspot.URL)e the day changes.
Public Property DayTick | Gets or sets the AxisTick used to represent the instance in time where the day changes.
Public Property HourFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the hour changes.
Public Property HourTick | Gets or sets the AxisTick used to represent the instance in time where the hour changes.
Public Property MillisecondFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the millisecond changes.
Public Property MillisecondTick | Gets or sets the axis tick used to represent the instance in time where the millisecond changes.
Public Property MinuteFormatString | Gets or sets the format string used with DateTimevalues that represent the instance in time where the minute changes.
Public Property MinuteTick | Gets or sets the AxisTick used to represent the instance in time where the minute changes.
Public Property Mode | Gets or sets the time label automation mode for single value labels.
Public Property MonthFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the Month changes.
Public Property MonthTick | Gets or sets the AxisTick used to represent the instance in time where the Month changes.
Public Property PercentEdgeOverlapToRemoveTicks | Gets or sets a value that indicates whether auto-generated range ticks are trimmed if more than the specified percentage of the label lingers outside of the axis bounds.
Public Property QuarterFormatString | Gets or sets the format string used with DateTime labels of quarter range ticks.
Public Property QuarterTick | Gets or sets the AxisTick used to represent a year's quarter range ticks.
Public Property RangeIntervals | Gets or sets an TimeIntervalCollection used with modes Range and AddRange. When no intervals are specified the intervals will be determined dynamically.
Public Property RangeMode | Gets or sets the time label automation mode for range value labels.
Public Property SecondFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the second changes.
Public Property SecondTick | Gets or sets the AxisTick used to represent the instance in time where the second changes.
Public Property WeekFormatString | Gets or sets the format string used with DateTime labels of week range ticks.
Public Property WeekTick | Gets or sets the AxisTick used to represent a week range ticks.
Public Property YearFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the year changes.
Public Property YearTick | Gets or sets the AxisTick used to represent the instance in time where the Year changes.

See Also

Axis.TimeScaleLabelInfo Class | dotnetCHARTING Namespace


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DayFormatString Property

Gets or sets the format string used with DateTime values that represent the instance in time wher%%%(Shortcut to: Element.Hotspot.URL)e the day changes.

[Visual Basic]
Public Property DayFormatString As String
[C#]
public string DayFormatString {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DayTick Property

Gets or sets the AxisTick used to represent the instance in time where the day changes.

[Visual Basic]
Public Property DayTick As AxisTick
[C#]
public AxisTick DayTick {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HourFormatString Property

Gets or sets the format string used with DateTime values that represent the instance in time where the hour changes.

[Visual Basic]
Public Property HourFormatString As String
[C#]
public string HourFormatString {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HourTick Property

Gets or sets the AxisTick used to represent the instance in time where the hour changes.

[Visual Basic]
Public Property HourTick As AxisTick
[C#]
public AxisTick HourTick {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MillisecondFormatString Property

Gets or sets the format string used with DateTime values that represent the instance in time where the millisecond changes.

[Visual Basic]
Public Property MillisecondFormatString As String
[C#]
public string MillisecondFormatString {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MillisecondTick Property

Gets or sets the axis tick used to represent the instance in time where the millisecond changes.

[Visual Basic]
Public Property MillisecondTick As AxisTick
[C#]
public AxisTick MillisecondTick {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MinuteFormatString Property

Gets or sets the format string used with DateTimevalues that represent the instance in time where the minute changes.

[Visual Basic]
Public Property MinuteFormatString As String
[C#]
public string MinuteFormatString {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MinuteTick Property

Gets or sets the AxisTick used to represent the instance in time where the minute changes.

[Visual Basic]
Public Property MinuteTick As AxisTick
[C#]
public AxisTick MinuteTick {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Mode Property

Gets or sets the time label automation mode for single value labels.

[Visual Basic]
Public Property Mode As TimeScaleLabelMode
[C#]
public TimeScaleLabelMode Mode {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MonthFormatString Property

Gets or sets the format string used with DateTime values that represent the instance in time where the Month changes.

[Visual Basic]
Public Property MonthFormatString As String
[C#]
public string MonthFormatString {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MonthTick Property

Gets or sets the AxisTick used to represent the instance in time where the Month changes.

[Visual Basic]
Public Property MonthTick As AxisTick
[C#]
public AxisTick MonthTick {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PercentEdgeOverlapToRemoveTicks Property

Gets or sets a value that indicates whether auto-generated range ticks are trimmed if more than the specified percentage of the label lingers outside of the axis bounds.

[Visual Basic]
Public Property PercentEdgeOverlapToRemoveTicks As Integer
[C#]
public int PercentEdgeOverlapToRemoveTicks {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

QuarterFormatString Property

Gets or sets the format string used with DateTime labels of quarter range ticks.

[Visual Basic]
Public Property QuarterFormatString As String
[C#]
public string QuarterFormatString {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

QuarterTick Property

Gets or sets the AxisTick used to represent a year's quarter range ticks.

[Visual Basic]
Public Property QuarterTick As AxisTick
[C#]
public AxisTick QuarterTick {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RangeIntervals Property

Gets or sets an TimeIntervalCollection used with modes Range and AddRange. When no intervals are specified the intervals will be determined dynamically.

[Visual Basic]
Public Property RangeIntervals As TimeIntervalCollection
[C#]
public TimeIntervalCollection RangeIntervals {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RangeMode Property

Gets or sets the time label automation mode for range value labels.

[Visual Basic]
Public Property RangeMode As TimeScaleLabelRangeMode
[C#]
public TimeScaleLabelRangeMode RangeMode {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SecondFormatString Property

Gets or sets the format string used with DateTime values that represent the instance in time where the second changes.

[Visual Basic]
Public Property SecondFormatString As String
[C#]
public string SecondFormatString {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SecondTick Property

Gets or sets the AxisTick used to represent the instance in time where the second changes.

[Visual Basic]
Public Property SecondTick As AxisTick
[C#]
public AxisTick SecondTick {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

WeekFormatString Property

Gets or sets the format string used with DateTime labels of week range ticks.

[Visual Basic]
Public Property WeekFormatString As String
[C#]
public string WeekFormatString {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

WeekTick Property

Gets or sets the AxisTick used to represent a week range ticks.

[Visual Basic]
Public Property WeekTick As AxisTick
[C#]
public AxisTick WeekTick {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

YearFormatString Property

Gets or sets the format string used with DateTime values that represent the instance in time where the year changes.

[Visual Basic]
Public Property YearFormatString As String
[C#]
public string YearFormatString {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

YearTick Property

Gets or sets the AxisTick used to represent the instance in time where the Year changes.

[Visual Basic]
Public Property YearTick As AxisTick
[C#]
public AxisTick YearTick {get; set;}

See Also

Axis.TimeScaleLabelInfo Class | Axis.TimeScaleLabelInfo Members


AxisCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisCollection Class

Contains a collection of Axis objects.

For a list of all members of this type, see AxisCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.AxisCollection
dotnetCHARTING.Axis.ScaleSync

Syntax

[Visual Basic]
Public Class AxisCollection
   Inherits CollectionBase
[C#]
public class AxisCollection : CollectionBase

See Also

AxisCollection Members | dotnetCHARTING Namespace


AxisCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisCollection Class Members

AxisCollection overview

Public Constructors

Public Constructor AxisCollection Constructor Creates a new instance of AxisCollection with the specified list of Axis objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Axis.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified Axis in this collection.
Public Method Insert | Inserts a Axis into this collection at a specified index.
Public Method Remove | Removes a specified Axis from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

AxisCollection Class | dotnetCHARTING Namespace


AxisCollection Constructor

AxisCollection Class | AxisCollection Members

Language

Visual Basic

C#

Show All

axisList
See Also Languages dotnetCHARTING Send comments on this topic.

AxisCollection Constructor

Creates a new instance of AxisCollection with the specified list of Axis objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray axisList() As Axis _
)
[C#]
public AxisCollection(
   params Axis[] axisList
);

Parameters

axisList

See Also

AxisCollection Class | AxisCollection Members


AxisCollection Class Methods

AxisCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisCollection Class Members

For a list of all members of this type, see AxisCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Axis.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified Axis in this collection.
Public Method Insert | Inserts a Axis into this collection at a specified index.
Public Method Remove | Removes a specified Axis from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

AxisCollection Class | dotnetCHARTING Namespace


AxisCollection Class | AxisCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

[Visual Basic] Overloads Public Function Add(Axis) As Integer

[C#] public int Add(Axis);

Adds the specified AxisMarker objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray Axis())

[C#] public void Add(params Axis[]);

Adds a specified AxisCollection to this collection.

[Visual Basic] Overloads Public Sub Add(AxisCollection)

[C#] public void Add(AxisCollection);

See Also

AxisCollection Class | AxisCollection Members


Add(Axis) Method

AxisCollection Class | AxisCollection Members | Overload List

Language

Visual Basic

C#

Show All

axis
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Axis) Method

[Visual Basic]
Overloads Public Function Add( _
   ByVal axis As Axis _
) As Integer
[C#]
public int Add(
   Axis axis
);

Parameters

axis

See Also

AxisCollection Class | AxisCollection Members | Overload List


Add(Axis[]) Method

AxisCollection Class | AxisCollection Members | Overload List

Language

Visual Basic

C#

Show All

axisList
A list of AxisMarker objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Axis[]) Method

Adds the specified AxisMarker objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray axisList() As Axis _
)
[C#]
public void Add(
   params Axis[] axisList
);

Parameters

axisList
A list of AxisMarker objects to add.

See Also

AxisCollection Class | AxisCollection Members | Overload List


Add(AxisCollection) Method

AxisCollection Class | AxisCollection Members | Overload List

Language

Visual Basic

C#

Show All

axisCollection
The AxisCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(AxisCollection) Method

Adds a specified AxisCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal axisCollection As AxisCollection _
)
[C#]
public void Add(
   AxisCollection axisCollection
);

Parameters

axisCollection
The AxisCollection to add.

See Also

AxisCollection Class | AxisCollection Members | Overload List


Contains Method

AxisCollection Class | AxisCollection Members

Language

Visual Basic

C#

Show All

axis
The Axis to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified Axis.

[Visual Basic]
Public Function Contains( _
   ByVal axis As Axis _
) As Boolean
[C#]
public bool Contains(
   Axis axis
);

Parameters

axis
The Axis to find.

Return Type

true if the specified Axis belongs to this collection; otherwise, false.

See Also

AxisCollection Class | AxisCollection Members


IndexOf Method

AxisCollection Class | AxisCollection Members

Language

Visual Basic

C#

Show All

axis
The Axis to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines the index of a specified Axis in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal axis As Axis _
) As Integer
[C#]
public int IndexOf(
   Axis axis
);

Parameters

axis
The Axis to find.

Return Type

The zero-based index of the specified Axis.

See Also

AxisCollection Class | AxisCollection Members


Insert Method

AxisCollection Class | AxisCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the Axis.
axis
The Axis to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a Axis into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal axis As Axis _
)
[C#]
public void Insert(
   int index,
   Axis axis
);

Parameters

index
The zero-based index into the collection at which to insert the Axis.
axis
The Axis to insert into this collection.

See Also

AxisCollection Class | AxisCollection Members


Remove Method

AxisCollection Class | AxisCollection Members

Language

Visual Basic

C#

Show All

axis
The Axis to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified Axis from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal axis As Axis _
)
[C#]
public void Remove(
   Axis axis
);

Parameters

axis
The Axis to remove.

See Also

AxisCollection Class | AxisCollection Members


AxisCollection Class Properties

AxisCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisCollection Class Members

For a list of all members of this type, see AxisCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

AxisCollection Class | dotnetCHARTING Namespace


Item Property

AxisCollection Class | AxisCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Axis
[C#]
public Axis this[
   int index
]; {get; set;}

Parameters

index

See Also

AxisCollection Class | AxisCollection Members


AxisMarker Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Class

Defines objects used to fill a specified section or point on an axis.

For a list of all members of this type, see AxisMarker members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.ScaleRange
dotnetCHARTING.AxisMarker

Syntax

[Visual Basic]
Public Class AxisMarker
   Inherits ScaleRange
   Implements IInstanceID
[C#]
public class AxisMarker : ScaleRange, IInstanceID

Remarks

Each marker displayed on the chart will also have a LegendEntry in the LegendBox.

There are two ways to use AxisMarkers.

  1. Attach to axis
    An AxisMarker can be added to the Markers collection of any axis. In this case, a numeric, time, or text: value or range must be specified.

    When Value is specified, ValueLow and ValueHigh are both set to this value. When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.
  2. Attach to element
    An AxisMarker is instantiated and passed to the AxisMarker property of any element. In such a case, the axis marker is drawn on the Axis where the element's name is displayed.

See Also

AxisMarker Members | dotnetCHARTING Namespace


AxisMarker Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisMarker Class Members

AxisMarker overview

Public Constructors

Public Constructor AxisMarker Constructor Overloaded.

Public Properties

Public Property Background | Gets or sets a Background object used to fill this AxisMarker object's range on a ChartArea.
Public Property BringToFront | Gets or sets a value that indicates whether the AxisMarker is drawn in front of the chart data while in 2D mode.
Public Property CalendarPattern | Gets or set a CalendarPattern used by this axis marker instead of the range values.
Public Property IncludeInAxisScale (Inherited from ScaleRange) | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it.
Public Property InstanceID |
Public Property Label | Gets or sets a Label object drawn next to the AxisMarker on a ChartArea.
Public Property LegendEntry | Gets or sets a LegendEntry that represents this AxisMarker in a LegendBox.
Public Property Line | Gets or sets a Line object drawn on a ChartArea.
Public Property Tick | Gets or sets an AxisTick object that will represent this AxisMarker on the axis where it resides.
Public Property Value | Overridden. Gets or sets the numeric, DateTime, or text value of this AxisMarker.
Public Property ValueHigh | Overridden. Gets or sets the upper bounds of a numeric, DateTime, or text range.
Public Property ValueLow | Overridden. Gets or sets the lower bounds of a numeric, DateTime, or text range.

Public Methods

Public Method ToString (Inherited from ScaleRange)

See Also

AxisMarker Class | dotnetCHARTING Namespace


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Constructor

Overload List

Initialize a new instance of the AxisMarker class.

[Visual Basic] Public Sub New()

[C#] public AxisMarker();

Initialize a new instance of the AxisMarker class with a label and Background.

[Visual Basic] Public Sub New(String,Background)

[C#] public AxisMarker(string,Background);

Initialize a new instance of the AxisMarker class with a label, Background object, and calendar pattern.

[Visual Basic] Public Sub New(String,Background,CalendarPattern)

[C#] public AxisMarker(string,Background,CalendarPattern);

Initialize a new instance of the AxisMarker class with a label, Background object, and axis range.

[Visual Basic] Public Sub New(String,Background,Object,Object)

[C#] public AxisMarker(string,Background,object,object);

Initialize a new instance of the AxisMarker class with a label, colort, and axis range.

[Visual Basic] Public Sub New(String,Color,CalendarPattern)

[C#] public AxisMarker(string,Color,CalendarPattern);

Initialize a new instance of the AxisMarker class with a label, Background object, and a numeric or time value representing a point on an axis..

[Visual Basic] Public Sub New(String,Color,Object)

[C#] public AxisMarker(string,Color,object);

Initialize a new instance of the AxisMarker class with a label, colort, and axis range.

[Visual Basic] Public Sub New(String,Color,Object,Object)

[C#] public AxisMarker(string,Color,object,object);

Initialize a new instance of the AxisMarker class with a label, Background object, and a numeric or time value representing a point on an axis..

[Visual Basic] Public Sub New(String,Line,Object)

[C#] public AxisMarker(string,Line,object);

See Also

AxisMarker Class | AxisMarker Members


AxisMarker Class | AxisMarker Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Constructor()

Initialize a new instance of the AxisMarker class.

[Visual Basic]
Public Function New()
[C#]
public AxisMarker();

See Also

AxisMarker Class | AxisMarker Members | Overload List


AxisMarker Constructor(String,Background)

AxisMarker Class | AxisMarker Members | Overload List

Language

Visual Basic

C#

Show All

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
bg
Background which fills the an area of the chart within a specified range.
See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Constructor(String,Background)

Initialize a new instance of the AxisMarker class with a label and Background.

[Visual Basic]
Public Function New( _
   ByVal label As String, _
   ByVal bg As Background _
)
[C#]
public AxisMarker(
   string label,
   Background bg
);

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
bg
Background which fills the an area of the chart within a specified range.

See Also

AxisMarker Class | AxisMarker Members | Overload List


AxisMarker Constructor(String,Background,CalendarPattern)

AxisMarker Class | AxisMarker Members | Overload List

Language

Visual Basic

C#

Show All

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
bg
Background which fills the an area of the chart within the specified range.
calendarPattern
CalendarPattern of this axis marker.
See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Constructor(String,Background,CalendarPattern)

Initialize a new instance of the AxisMarker class with a label, Background object, and calendar pattern.

[Visual Basic]
Public Function New( _
   ByVal label As String, _
   ByVal bg As Background, _
   ByVal calendarPattern As CalendarPattern _
)
[C#]
public AxisMarker(
   string label,
   Background bg,
   CalendarPattern calendarPattern
);

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
bg
Background which fills the an area of the chart within the specified range.
calendarPattern
CalendarPattern of this axis marker.

See Also

AxisMarker Class | AxisMarker Members | Overload List


AxisMarker Constructor(String,Background,Object,Object)

AxisMarker Class | AxisMarker Members | Overload List

Language

Visual Basic

C#

Show All

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
bg
Background which fills the an area of the chart within the specified range.
valueLow
Numeric, DateTime, or Text low axis range.
valueHigh
Numeric, DateTime, or Text high axis range..
See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Constructor(String,Background,Object,Object)

Initialize a new instance of the AxisMarker class with a label, Background object, and axis range.

[Visual Basic]
Public Function New( _
   ByVal label As String, _
   ByVal bg As Background, _
   ByVal valueLow As Object, _
   ByVal valueHigh As Object _
)
[C#]
public AxisMarker(
   string label,
   Background bg,
   object valueLow,
   object valueHigh
);

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
bg
Background which fills the an area of the chart within the specified range.
valueLow
Numeric, DateTime, or Text low axis range.
valueHigh
Numeric, DateTime, or Text high axis range..

See Also

AxisMarker Class | AxisMarker Members | Overload List


AxisMarker Constructor(String,Color,CalendarPattern)

AxisMarker Class | AxisMarker Members | Overload List

Language

Visual Basic

C#

Show All

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
col
The color that fills the an area of the chart within the specified range.
calendarPattern
CalendarPattern of this axis marker.
See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Constructor(String,Color,CalendarPattern)

Initialize a new instance of the AxisMarker class with a label, colort, and axis range.

[Visual Basic]
Public Function New( _
   ByVal label As String, _
   ByVal col As Color, _
   ByVal calendarPattern As CalendarPattern _
)
[C#]
public AxisMarker(
   string label,
   Color col,
   CalendarPattern calendarPattern
);

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
col
The color that fills the an area of the chart within the specified range.
calendarPattern
CalendarPattern of this axis marker.

See Also

AxisMarker Class | AxisMarker Members | Overload List


AxisMarker Constructor(String,Color,Object)

AxisMarker Class | AxisMarker Members | Overload List

Language

Visual Basic

C#

Show All

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
lineColor
The color used to draw line at the specified position.
myValue
Numeric, DateTime, or Text value representing a point on an axis.
See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Constructor(String,Color,Object)

Initialize a new instance of the AxisMarker class with a label, Background object, and a numeric or time value representing a point on an axis..

[Visual Basic]
Public Function New( _
   ByVal label As String, _
   ByVal lineColor As Color, _
   ByVal myValue As Object _
)
[C#]
public AxisMarker(
   string label,
   Color lineColor,
   object myValue
);

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
lineColor
The color used to draw line at the specified position.
myValue
Numeric, DateTime, or Text value representing a point on an axis.

See Also

AxisMarker Class | AxisMarker Members | Overload List


AxisMarker Constructor(String,Color,Object,Object)

AxisMarker Class | AxisMarker Members | Overload List

Language

Visual Basic

C#

Show All

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
col
The color that fills the an area of the chart within the specified range.
valueLow
Numeric, DateTime, or Text low axis range.
valueHigh
Numeric, DateTime, or Text high axis range..
See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Constructor(String,Color,Object,Object)

Initialize a new instance of the AxisMarker class with a label, colort, and axis range.

[Visual Basic]
Public Function New( _
   ByVal label As String, _
   ByVal col As Color, _
   ByVal valueLow As Object, _
   ByVal valueHigh As Object _
)
[C#]
public AxisMarker(
   string label,
   Color col,
   object valueLow,
   object valueHigh
);

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
col
The color that fills the an area of the chart within the specified range.
valueLow
Numeric, DateTime, or Text low axis range.
valueHigh
Numeric, DateTime, or Text high axis range..

See Also

AxisMarker Class | AxisMarker Members | Overload List


AxisMarker Constructor(String,Line,Object)

AxisMarker Class | AxisMarker Members | Overload List

Language

Visual Basic

C#

Show All

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
line
Line to draw at the specified position.
myValue
Numeric, DateTime, or Text value representing a point on an axis.
See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Constructor(String,Line,Object)

Initialize a new instance of the AxisMarker class with a label, Background object, and a numeric or time value representing a point on an axis..

[Visual Basic]
Public Function New( _
   ByVal label As String, _
   ByVal line As Line, _
   ByVal myValue As Object _
)
[C#]
public AxisMarker(
   string label,
   Line line,
   object myValue
);

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
line
Line to draw at the specified position.
myValue
Numeric, DateTime, or Text value representing a point on an axis.

See Also

AxisMarker Class | AxisMarker Members | Overload List


AxisMarker Class Properties

AxisMarker Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisMarker Class Members

For a list of all members of this type, see AxisMarker members.

Public Properties

Public Property Background | Gets or sets a Background object used to fill this AxisMarker object's range on a ChartArea.
Public Property BringToFront | Gets or sets a value that indicates whether the AxisMarker is drawn in front of the chart data while in 2D mode.
Public Property CalendarPattern | Gets or set a CalendarPattern used by this axis marker instead of the range values.
Public Property IncludeInAxisScale (Inherited from ScaleRange) | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it.
Public Property InstanceID |
Public Property Label | Gets or sets a Label object drawn next to the AxisMarker on a ChartArea.
Public Property LegendEntry | Gets or sets a LegendEntry that represents this AxisMarker in a LegendBox.
Public Property Line | Gets or sets a Line object drawn on a ChartArea.
Public Property Tick | Gets or sets an AxisTick object that will represent this AxisMarker on the axis where it resides.
Public Property Value | Overridden. Gets or sets the numeric, DateTime, or text value of this AxisMarker.
Public Property ValueHigh | Overridden. Gets or sets the upper bounds of a numeric, DateTime, or text range.
Public Property ValueLow | Overridden. Gets or sets the lower bounds of a numeric, DateTime, or text range.

See Also

AxisMarker Class | dotnetCHARTING Namespace


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Background Property

Gets or sets a Background object used to fill this AxisMarker object's range on a ChartArea.

[Visual Basic]
Public Property Background As Background
[C#]
public Background Background {get; set;}

See Also

AxisMarker Class | AxisMarker Members


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

BringToFront Property

Gets or sets a value that indicates whether the AxisMarker is drawn in front of the chart data while in 2D mode.

[Visual Basic]
Public Property BringToFront As Boolean
[C#]
public bool BringToFront {get; set;}

See Also

AxisMarker Class | AxisMarker Members


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CalendarPattern Property

Gets or set a CalendarPattern used by this axis marker instead of the range values.

[Visual Basic]
Public Property CalendarPattern As CalendarPattern
[C#]
public CalendarPattern CalendarPattern {get; set;}

See Also

AxisMarker Class | AxisMarker Members


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InstanceID Property

[Visual Basic]
Public Property InstanceID As Integer
[C#]
public int InstanceID {get; set;}

See Also

AxisMarker Class | AxisMarker Members


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Label Property

Gets or sets a Label object drawn next to the AxisMarker on a ChartArea.

[Visual Basic]
Public Property Label As Label
[C#]
public Label Label {get; set;}

See Also

AxisMarker Class | AxisMarker Members


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntry Property

Gets or sets a LegendEntry that represents this AxisMarker in a LegendBox.

[Visual Basic]
Public Property LegendEntry As LegendEntry
[C#]
public LegendEntry LegendEntry {get; set;}

See Also

AxisMarker Class | AxisMarker Members


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Property

Gets or sets a Line object drawn on a ChartArea.

[Visual Basic]
Public Property Line As Line
[C#]
public Line Line {get; set;}

Remarks

This line is used when ValueHigh and ValueLow are equal or if Value is set.

See Also

AxisMarker Class | AxisMarker Members


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Tick Property

Gets or sets an AxisTick object that will represent this AxisMarker on the axis where it resides.

[Visual Basic]
Public Property Tick As AxisTick
[C#]
public AxisTick Tick {get; set;}

Remarks

By default this tick is null and must be instantiated. If the axis marker is a range, the axis tick will also be a range AxisTick. If a CalendarPattern is used, the tick cannot be used.

See Also

AxisMarker Class | AxisMarker Members


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Value Property

Gets or sets the numeric, DateTime, or text value of this AxisMarker.

[Visual Basic]
Overrides Public Property Value As Object
[C#]
public override object Value {get; set;}

Remarks

When Value is specified, ValueLow and ValueHigh are both set to this value. When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.

See Also

AxisMarker Class | AxisMarker Members


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ValueHigh Property

Gets or sets the upper bounds of a numeric, DateTime, or text range.

[Visual Basic]
Overrides Public Property ValueHigh As Object
[C#]
public override object ValueHigh {get; set;}

Remarks

When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.

See Also

AxisMarker Class | AxisMarker Members


AxisMarker Class | AxisMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ValueLow Property

Gets or sets the lower bounds of a numeric, DateTime, or text range.

[Visual Basic]
Overrides Public Property ValueLow As Object
[C#]
public override object ValueLow {get; set;}

Remarks

When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.

See Also

AxisMarker Class | AxisMarker Members


AxisMarkerCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarkerCollection Class

Contains a collection of AxisMarker objects.

For a list of all members of this type, see AxisMarkerCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.AxisMarkerCollection

Syntax

[Visual Basic]
Public Class AxisMarkerCollection
   Inherits CollectionBase
[C#]
public class AxisMarkerCollection : CollectionBase

See Also

AxisMarkerCollection Members | dotnetCHARTING Namespace


AxisMarkerCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisMarkerCollection Class Members

AxisMarkerCollection overview

Public Constructors

Public Constructor AxisMarkerCollection Constructor Creates a new instance of AxisMarkerCollection with the specified list of AxisMarker objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified AxisMarker.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified AxisMarker in this collection.
Public Method Insert | Inserts a AxisMarker into this collection at a specified index.
Public Method Remove | Removes a specified AxisMarker from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

AxisMarkerCollection Class | dotnetCHARTING Namespace


AxisMarkerCollection Constructor

AxisMarkerCollection Class | AxisMarkerCollection Members

Language

Visual Basic

C#

Show All

axisMarkerList
See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarkerCollection Constructor

Creates a new instance of AxisMarkerCollection with the specified list of AxisMarker objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray axisMarkerList() As AxisMarker _
)
[C#]
public AxisMarkerCollection(
   params AxisMarker[] axisMarkerList
);

Parameters

axisMarkerList

See Also

AxisMarkerCollection Class | AxisMarkerCollection Members


AxisMarkerCollection Class Methods

AxisMarkerCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisMarkerCollection Class Members

For a list of all members of this type, see AxisMarkerCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified AxisMarker.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified AxisMarker in this collection.
Public Method Insert | Inserts a AxisMarker into this collection at a specified index.
Public Method Remove | Removes a specified AxisMarker from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

AxisMarkerCollection Class | dotnetCHARTING Namespace


AxisMarkerCollection Class | AxisMarkerCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

[Visual Basic] Overloads Public Function Add(AxisMarker) As Integer

[C#] public int Add(AxisMarker);

Adds the specified AxisMarker objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray AxisMarker())

[C#] public void Add(params AxisMarker[]);

Adds a specified AxisMarkerCollection to this collection.

[Visual Basic] Overloads Public Sub Add(AxisMarkerCollection)

[C#] public void Add(AxisMarkerCollection);

See Also

AxisMarkerCollection Class | AxisMarkerCollection Members


Add(AxisMarker) Method

AxisMarkerCollection Class | AxisMarkerCollection Members | Overload List

Language

Visual Basic

C#

Show All

axisMarker
See Also Languages dotnetCHARTING Send comments on this topic.

Add(AxisMarker) Method

[Visual Basic]
Overloads Public Function Add( _
   ByVal axisMarker As AxisMarker _
) As Integer
[C#]
public int Add(
   AxisMarker axisMarker
);

Parameters

axisMarker

See Also

AxisMarkerCollection Class | AxisMarkerCollection Members | Overload List


Add(AxisMarker[]) Method

AxisMarkerCollection Class | AxisMarkerCollection Members | Overload List

Language

Visual Basic

C#

Show All

axisMarkerList
A list of AxisMarker objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(AxisMarker[]) Method

Adds the specified AxisMarker objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray axisMarkerList() As AxisMarker _
)
[C#]
public void Add(
   params AxisMarker[] axisMarkerList
);

Parameters

axisMarkerList
A list of AxisMarker objects to add.

See Also

AxisMarkerCollection Class | AxisMarkerCollection Members | Overload List


Add(AxisMarkerCollection) Method

AxisMarkerCollection Class | AxisMarkerCollection Members | Overload List

Language

Visual Basic

C#

Show All

axisMarkerCollection
The AxisMarkerCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(AxisMarkerCollection) Method

Adds a specified AxisMarkerCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal axisMarkerCollection As AxisMarkerCollection _
)
[C#]
public void Add(
   AxisMarkerCollection axisMarkerCollection
);

Parameters

axisMarkerCollection
The AxisMarkerCollection to add.

See Also

AxisMarkerCollection Class | AxisMarkerCollection Members | Overload List


Contains Method

AxisMarkerCollection Class | AxisMarkerCollection Members

Language

Visual Basic

C#

Show All

axisMarker
The AxisMarker to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified AxisMarker.

[Visual Basic]
Public Function Contains( _
   ByVal axisMarker As AxisMarker _
) As Boolean
[C#]
public bool Contains(
   AxisMarker axisMarker
);

Parameters

axisMarker
The AxisMarker to find.

Return Type

true if the specified AxisMarker belongs to this collection; otherwise, false.

See Also

AxisMarkerCollection Class | AxisMarkerCollection Members


IndexOf Method

AxisMarkerCollection Class | AxisMarkerCollection Members

Language

Visual Basic

C#

Show All

axisMarker
The AxisMarker to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines the index of a specified AxisMarker in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal axisMarker As AxisMarker _
) As Integer
[C#]
public int IndexOf(
   AxisMarker axisMarker
);

Parameters

axisMarker
The AxisMarker to find.

Return Type

The zero-based index of the specified AxisMarker.

See Also

AxisMarkerCollection Class | AxisMarkerCollection Members


Insert Method

AxisMarkerCollection Class | AxisMarkerCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the AxisMarker.
axisMarker
The AxisMarker to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a AxisMarker into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal axisMarker As AxisMarker _
)
[C#]
public void Insert(
   int index,
   AxisMarker axisMarker
);

Parameters

index
The zero-based index into the collection at which to insert the AxisMarker.
axisMarker
The AxisMarker to insert into this collection.

See Also

AxisMarkerCollection Class | AxisMarkerCollection Members


Remove Method

AxisMarkerCollection Class | AxisMarkerCollection Members

Language

Visual Basic

C#

Show All

axisMarker
The AxisMarker to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified AxisMarker from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal axisMarker As AxisMarker _
)
[C#]
public void Remove(
   AxisMarker axisMarker
);

Parameters

axisMarker
The AxisMarker to remove.

See Also

AxisMarkerCollection Class | AxisMarkerCollection Members


AxisMarkerCollection Class Properties

AxisMarkerCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisMarkerCollection Class Members

For a list of all members of this type, see AxisMarkerCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

AxisMarkerCollection Class | dotnetCHARTING Namespace


Item Property

AxisMarkerCollection Class | AxisMarkerCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As AxisMarker
[C#]
public AxisMarker this[
   int index
]; {get; set;}

Parameters

index

See Also

AxisMarkerCollection Class | AxisMarkerCollection Members


AxisTick Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisTick Class

Encapsulates an axis tick that includes a Label or ElementMarker, TickLine, and GridLine.

For a list of all members of this type, see AxisTick members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.ScaleRange
dotnetCHARTING.AxisTick

Syntax

[Visual Basic]
Public Class AxisTick
   Inherits ScaleRange
   Implements IInstanceID
[C#]
public class AxisTick : ScaleRange, IInstanceID

Remarks

Appearance
AxisTick objects can appear in three different ways.

  • Normal axis tick with a label.
  • AxisTick where the label is replaced with the AxisTick.Marker object (Icon or Image).
  • Range AxisTick in which case the tick has a low and high value.

Uses
AxisTick objects can also be used in different ways.

  • As an additional axis tick.
  • To override a tick on an axis.
  • To override multiple ticks on an axis.

See Also

AxisTick Members | dotnetCHARTING Namespace


AxisTick Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisTick Class Members

AxisTick overview

Public Constructors

Public Constructor AxisTick Constructor Overloaded.

Public Properties

Public Property GridLine | Gets or sets the properties of the Line drawn on the ChartArea at this AxisTick object's position.
Public Property IncludeInAxisScale (Inherited from ScaleRange) | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it.
Public Property InstanceID (Inherited from ScaleRange) |
Public Property Label | Gets or sets the Label of this AxisTick.
Public Property Line | Gets or sets the tick line of this AxisTick. The property Line.Length will control the length of this tick.
Public Property Marker | Gets or sets an ElementMarker object used instead of the label text.
Public Property OverrideTicks | Gets or sets a value indicating whether this range AxisTick is drawn on an axis or if it's properties are used to override those of other AxisTicks within it's range.
Public Property Value (Inherited from ScaleRange) | Gets or sets the numeric, DateTime, or text value of this ScaleRange.
Public Property ValueHigh (Inherited from ScaleRange) | Gets or sets the upper bounds of a numeric, DateTime, or text range.
Public Property ValueLow (Inherited from ScaleRange) | Gets or sets the lower bounds of a numeric, DateTime, or text range.

Public Methods

Public Method Dispose | Releases all resources used by this AxisTick.
Public Method SetAllColors | Sets the colors of this AxisTick's Label, Line, and GridLine.
Public Method ToString (Inherited from ScaleRange) |

See Also

AxisTick Class | dotnetCHARTING Namespace


AxisTick Class | AxisTick Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisTick Constructor

Overload List

Initializes a new instance of the AxisTick class.

[Visual Basic] Public Sub New()

[C#] public AxisTick();

Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime value.

[Visual Basic] Public Sub New(Object)

[C#] public AxisTick(object);

Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range.

[Visual Basic] Public Sub New(Object,Object)

[C#] public AxisTick(object,object);

Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range and an option to make this axis tick override ticks within it's range instead of appearing on the axis.

[Visual Basic] Public Sub New(Object,Object,Boolean)

[C#] public AxisTick(object,object,bool);

Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range and label.

[Visual Basic] Public Sub New(Object,Object,String)

[C#] public AxisTick(object,object,string);

Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime value and a text label..

[Visual Basic] Public Sub New(Object,String)

[C#] public AxisTick(object,string);

Initializes a new instance of the AxisTick class with text of an original label and new text to override that label with.

[Visual Basic] Public Sub New(String,String)

[C#] public AxisTick(string,string);

See Also

AxisTick Class | AxisTick Members


AxisTick Class | AxisTick Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisTick Constructor()

Initializes a new instance of the AxisTick class.

[Visual Basic]
Public Function New()
[C#]
public AxisTick();

See Also

AxisTick Class | AxisTick Members | Overload List


AxisTick Constructor(Object)

AxisTick Class | AxisTick Members | Overload List

Language

Visual Basic

C#

Show All

val
Axis tick value. The label will automatically represent the value given.
See Also Languages dotnetCHARTING Send comments on this topic.

AxisTick Constructor(Object)

Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime value.

[Visual Basic]
Public Function New( _
   ByVal val As Object _
)
[C#]
public AxisTick(
   object val
);

Parameters

val
Axis tick value. The label will automatically represent the value given.

See Also

AxisTick Class | AxisTick Members | Overload List


AxisTick Constructor(Object,Object)

AxisTick Class | AxisTick Members | Overload List

Language

Visual Basic

C#

Show All

lowValue
Low value.
highValue
High value.
See Also Languages dotnetCHARTING Send comments on this topic.

AxisTick Constructor(Object,Object)

Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range.

[Visual Basic]
Public Function New( _
   ByVal lowValue As Object, _
   ByVal highValue As Object _
)
[C#]
public AxisTick(
   object lowValue,
   object highValue
);

Parameters

lowValue
Low value.
highValue
High value.

See Also

AxisTick Class | AxisTick Members | Overload List


AxisTick Constructor(Object,Object,Boolean)

AxisTick Class | AxisTick Members | Overload List

Language

Visual Basic

C#

Show All

lowValue
Low value.
highValue
High value.
overrideTheTicks
When true, the axis tick will override ticks within it's range, otherwise, it will be a range tick.
See Also Languages dotnetCHARTING Send comments on this topic.

AxisTick Constructor(Object,Object,Boolean)

Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range and an option to make this axis tick override ticks within it's range instead of appearing on the axis.

[Visual Basic]
Public Function New( _
   ByVal lowValue As Object, _
   ByVal highValue As Object, _
   ByVal overrideTheTicks As Boolean _
)
[C#]
public AxisTick(
   object lowValue,
   object highValue,
   bool overrideTheTicks
);

Parameters

lowValue
Low value.
highValue
High value.
overrideTheTicks
When true, the axis tick will override ticks within it's range, otherwise, it will be a range tick.

See Also

AxisTick Class | AxisTick Members | Overload List


AxisTick Constructor(Object,Object,String)

AxisTick Class | AxisTick Members | Overload List

Language

Visual Basic

C#

Show All

lowValue
High value.
highValue
Label text.
labelText
Low value.
See Also Languages dotnetCHARTING Send comments on this topic.

AxisTick Constructor(Object,Object,String)

Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range and label.

[Visual Basic]
Public Function New( _
   ByVal lowValue As Object, _
   ByVal highValue As Object, _
   ByVal labelText As String _
)
[C#]
public AxisTick(
   object lowValue,
   object highValue,
   string labelText
);

Parameters

lowValue
High value.
highValue
Label text.
labelText
Low value.

See Also

AxisTick Class | AxisTick Members | Overload List


AxisTick Constructor(Object,String)

AxisTick Class | AxisTick Members | Overload List

Language

Visual Basic

C#

Show All

val
Axis tick value.
TextOverride
Label text.
See Also Languages dotnetCHARTING Send comments on this topic.

AxisTick Constructor(Object,String)

Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime value and a text label..

[Visual Basic]
Public Function New( _
   ByVal val As Object, _
   ByVal TextOverride As String _
)
[C#]
public AxisTick(
   object val,
   string TextOverride
);

Parameters

val
Axis tick value.
TextOverride
Label text.

See Also

AxisTick Class | AxisTick Members | Overload List


AxisTick Constructor(String,String)

AxisTick Class | AxisTick Members | Overload List

Language

Visual Basic

C#

Show All

originalLabelText
Label text of the axis tick to replace.
newLabelText
New label text.
See Also Languages dotnetCHARTING Send comments on this topic.

AxisTick Constructor(String,String)

Initializes a new instance of the AxisTick class with text of an original label and new text to override that label with.

[Visual Basic]
Public Function New( _
   ByVal originalLabelText As String, _
   ByVal newLabelText As String _
)
[C#]
public AxisTick(
   string originalLabelText,
   string newLabelText
);

Parameters

originalLabelText
Label text of the axis tick to replace.
newLabelText
New label text.

Remarks

Case insensitive.

See Also

AxisTick Class | AxisTick Members | Overload List


AxisTick Class Methods

AxisTick Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisTick Class Members

For a list of all members of this type, see AxisTick members.

Public Methods

Public Method Dispose | Releases all resources used by this AxisTick.
Public Method SetAllColors | Sets the colors of this AxisTick's Label, Line, and GridLine.
Public Method ToString (Inherited from ScaleRange) |

See Also

AxisTick Class | dotnetCHARTING Namespace


AxisTick Class | AxisTick Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Dispose Method

Releases all resources used by this AxisTick.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();

See Also

AxisTick Class | AxisTick Members


SetAllColors Method

AxisTick Class | AxisTick Members

Language

Visual Basic

C#

Show All

color
Color to use.
See Also Languages dotnetCHARTING Send comments on this topic.

SetAllColors Method

Sets the colors of this AxisTick's Label, Line, and GridLine.

[Visual Basic]
Public Sub SetAllColors( _
   ByVal color As Color _
)
[C#]
public void SetAllColors(
   Color color
);

Parameters

color
Color to use.

See Also

AxisTick Class | AxisTick Members


AxisTick Class Properties

AxisTick Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisTick Class Members

For a list of all members of this type, see AxisTick members.

Public Properties

Public Property GridLine | Gets or sets the properties of the Line drawn on the ChartArea at this AxisTick object's position.
Public Property IncludeInAxisScale (Inherited from ScaleRange) | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it.
Public Property InstanceID (Inherited from ScaleRange) |
Public Property Label | Gets or sets the Label of this AxisTick.
Public Property Line | Gets or sets the tick line of this AxisTick. The property Line.Length will control the length of this tick.
Public Property Marker | Gets or sets an ElementMarker object used instead of the label text.
Public Property OverrideTicks | Gets or sets a value indicating whether this range AxisTick is drawn on an axis or if it's properties are used to override those of other AxisTicks within it's range.
Public Property Value (Inherited from ScaleRange) | Gets or sets the numeric, DateTime, or text value of this ScaleRange.
Public Property ValueHigh (Inherited from ScaleRange) | Gets or sets the upper bounds of a numeric, DateTime, or text range.
Public Property ValueLow (Inherited from ScaleRange) | Gets or sets the lower bounds of a numeric, DateTime, or text range.

See Also

AxisTick Class | dotnetCHARTING Namespace


AxisTick Class | AxisTick Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GridLine Property

Gets or sets the properties of the Line drawn on the ChartArea at this AxisTick object's position.

[Visual Basic]
Public Property GridLine As Line
[C#]
public Line GridLine {get; set;}

See Also

AxisTick Class | AxisTick Members


AxisTick Class | AxisTick Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Label Property

Gets or sets the Label of this AxisTick.

[Visual Basic]
Public Property Label As Label
[C#]
public Label Label {get; set;}

See Also

AxisTick Class | AxisTick Members


AxisTick Class | AxisTick Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Property

Gets or sets the tick line of this AxisTick. The property Line.Length will control the length of this tick.

[Visual Basic]
Public Property Line As Line
[C#]
public Line Line {get; set;}

See Also

AxisTick Class | AxisTick Members


AxisTick Class | AxisTick Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Marker Property

Gets or sets an ElementMarker object used instead of the label text.

[Visual Basic]
Public Property Marker As ElementMarker
[C#]
public ElementMarker Marker {get; set;}

See Also

AxisTick Class | AxisTick Members


AxisTick Class | AxisTick Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

OverrideTicks Property

Gets or sets a value indicating whether this range AxisTick is drawn on an axis or if it's properties are used to override those of other AxisTicks within it's range.

[Visual Basic]
Public Property OverrideTicks As Boolean
[C#]
public bool OverrideTicks {get; set;}

See Also

AxisTick Class | AxisTick Members


AxisTickCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisTickCollection Class

Contains a collection of AxisTick objects.

For a list of all members of this type, see AxisTickCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.AxisTickCollection

Syntax

[Visual Basic]
Public Class AxisTickCollection
   Inherits CollectionBase
[C#]
public class AxisTickCollection : CollectionBase

See Also

AxisTickCollection Members | dotnetCHARTING Namespace


AxisTickCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisTickCollection Class Members

AxisTickCollection overview

Public Constructors

Public Constructor AxisTickCollection Constructor Creates a new instance of AxisTickCollection with the specified list of AxisTick objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified AxisTick.
Public Method static (Shared in Visual Basic) FromValues | Overloaded.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified AxisTick in this collection.
Public Method Insert | Inserts a AxisTick into this collection at a specified index.
Public Method Remove | Removes a specified AxisTick from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

AxisTickCollection Class | dotnetCHARTING Namespace


AxisTickCollection Constructor

AxisTickCollection Class | AxisTickCollection Members

Language

Visual Basic

C#

Show All

axisTickList
See Also Languages dotnetCHARTING Send comments on this topic.

AxisTickCollection Constructor

Creates a new instance of AxisTickCollection with the specified list of AxisTick objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray axisTickList() As AxisTick _
)
[C#]
public AxisTickCollection(
   params AxisTick[] axisTickList
);

Parameters

axisTickList

See Also

AxisTickCollection Class | AxisTickCollection Members


AxisTickCollection Class Methods

AxisTickCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisTickCollection Class Members

For a list of all members of this type, see AxisTickCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified AxisTick.
Public Method static (Shared in Visual Basic) FromValues | Overloaded.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified AxisTick in this collection.
Public Method Insert | Inserts a AxisTick into this collection at a specified index.
Public Method Remove | Removes a specified AxisTick from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

AxisTickCollection Class | dotnetCHARTING Namespace


AxisTickCollection Class | AxisTickCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

Adds the specified axisTick object to this collection.

[Visual Basic] Overloads Public Function Add(AxisTick) As Integer

[C#] public int Add(AxisTick);

Adds the specified AxisTick objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray AxisTick())

[C#] public void Add(params AxisTick[]);

Adds a specified AxisTickCollection to this collection.

[Visual Basic] Overloads Public Sub Add(AxisTickCollection)

[C#] public void Add(AxisTickCollection);

See Also

AxisTickCollection Class | AxisTickCollection Members


Add(AxisTick) Method

AxisTickCollection Class | AxisTickCollection Members | Overload List

Language

Visual Basic

C#

Show All

axisTick
See Also Languages dotnetCHARTING Send comments on this topic.

Add(AxisTick) Method

Adds the specified axisTick object to this collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal axisTick As AxisTick _
) As Integer
[C#]
public int Add(
   AxisTick axisTick
);

Parameters

axisTick

See Also

AxisTickCollection Class | AxisTickCollection Members | Overload List


Add(AxisTick[]) Method

AxisTickCollection Class | AxisTickCollection Members | Overload List

Language

Visual Basic

C#

Show All

axisTickList
A list of AxisTick objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(AxisTick[]) Method

Adds the specified AxisTick objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray axisTickList() As AxisTick _
)
[C#]
public void Add(
   params AxisTick[] axisTickList
);

Parameters

axisTickList
A list of AxisTick objects to add.

See Also

AxisTickCollection Class | AxisTickCollection Members | Overload List


Add(AxisTickCollection) Method

AxisTickCollection Class | AxisTickCollection Members | Overload List

Language

Visual Basic

C#

Show All

axisTickCollection
The AxisTickCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(AxisTickCollection) Method

Adds a specified AxisTickCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal axisTickCollection As AxisTickCollection _
)
[C#]
public void Add(
   AxisTickCollection axisTickCollection
);

Parameters

axisTickCollection
The AxisTickCollection to add.

See Also

AxisTickCollection Class | AxisTickCollection Members | Overload List


Contains Method

AxisTickCollection Class | AxisTickCollection Members

Language

Visual Basic

C#

Show All

axisTick
The AxisTick to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified AxisTick.

[Visual Basic]
Public Function Contains( _
   ByVal axisTick As AxisTick _
) As Boolean
[C#]
public bool Contains(
   AxisTick axisTick
);

Parameters

axisTick
The AxisTick to find.

Return Type

true if the specified AxisTick belongs to this collection; otherwise, false.

See Also

AxisTickCollection Class | AxisTickCollection Members


AxisTickCollection Class | AxisTickCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FromValues Method

Overload List

Creates a collection of axis ticks with the specified values.

[Visual Basic] Overloads Public Shared Function FromValues(ParamArray Date()) As AxisTickCollection

[C#] public static AxisTickCollection FromValues(params DateTime[]);

Creates a collection of axis ticks with the specified values.

[Visual Basic] Overloads Public Shared Function FromValues(ParamArray Double()) As AxisTickCollection

[C#] public static AxisTickCollection FromValues(params double[]);

See Also

AxisTickCollection Class | AxisTickCollection Members


FromValues(DateTime[]) Method

AxisTickCollection Class | AxisTickCollection Members | Overload List

Language

Visual Basic

C#

Show All

list
List of %DateTime values.
See Also Languages dotnetCHARTING Send comments on this topic.

FromValues(DateTime[]) Method

Creates a collection of axis ticks with the specified values.

[Visual Basic]
Overloads Public Shared Function FromValues( _
   ByVal ParamArray list() As Date _
) As AxisTickCollection
[C#]
public static AxisTickCollection FromValues(
   params DateTime[] list
);

Parameters

list
List of %DateTime values.

See Also

AxisTickCollection Class | AxisTickCollection Members | Overload List


FromValues(Double[]) Method

AxisTickCollection Class | AxisTickCollection Members | Overload List

Language

Visual Basic

C#

Show All

list
List of double values.
See Also Languages dotnetCHARTING Send comments on this topic.

FromValues(Double[]) Method

Creates a collection of axis ticks with the specified values.

[Visual Basic]
Overloads Public Shared Function FromValues( _
   ByVal ParamArray list() As Double _
) As AxisTickCollection
[C#]
public static AxisTickCollection FromValues(
   params double[] list
);

Parameters

list
List of double values.

See Also

AxisTickCollection Class | AxisTickCollection Members | Overload List


IndexOf Method

AxisTickCollection Class | AxisTickCollection Members

Language

Visual Basic

C#

Show All

axisTick
The AxisTick to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines the index of a specified AxisTick in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal axisTick As AxisTick _
) As Integer
[C#]
public int IndexOf(
   AxisTick axisTick
);

Parameters

axisTick
The AxisTick to find.

Return Type

The zero-based index of the specified AxisTick.

See Also

AxisTickCollection Class | AxisTickCollection Members


Insert Method

AxisTickCollection Class | AxisTickCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the AxisTick.
axisTick
The AxisTick to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a AxisTick into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal axisTick As AxisTick _
)
[C#]
public void Insert(
   int index,
   AxisTick axisTick
);

Parameters

index
The zero-based index into the collection at which to insert the AxisTick.
axisTick
The AxisTick to insert into this collection.

See Also

AxisTickCollection Class | AxisTickCollection Members


Remove Method

AxisTickCollection Class | AxisTickCollection Members

Language

Visual Basic

C#

Show All

axisTick
The AxisTick to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified AxisTick from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal axisTick As AxisTick _
)
[C#]
public void Remove(
   AxisTick axisTick
);

Parameters

axisTick
The AxisTick to remove.

See Also

AxisTickCollection Class | AxisTickCollection Members


AxisTickCollection Class Properties

AxisTickCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisTickCollection Class Members

For a list of all members of this type, see AxisTickCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

AxisTickCollection Class | dotnetCHARTING Namespace


Item Property

AxisTickCollection Class | AxisTickCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As AxisTick
[C#]
public AxisTick this[
   int index
]; {get; set;}

Parameters

index

See Also

AxisTickCollection Class | AxisTickCollection Members


Background Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Background Class

Defines objects used to fill the interior of chart elements such as legend boxes, annotations and other shapes.

For a list of all members of this type, see Background members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.Background

Syntax

[Visual Basic]
Public Class Background
[C#]
public class Background

See Also

Background Members | dotnetCHARTING Namespace


Background Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Background Class Members

Background overview

Public Constructors

Public Constructor Background Constructor Overloaded.

Public Properties

Public Property Bevel | Gets or sets a value that indicates wherer this background will use a bevel shading effect.
Public Property Brush | Gets or sets a brush object that is used to fill objects.
Public Property Color | Gets or sets the primary Color.
Public Property GlassEffect | Gets or sets a value that indicates whether a glass effect is used to fill an object.
Public Property GradientAngle | Gets or sets an angle at which gradients are drawn.( left to right = 0, right to left = 180 )
Public Property HatchColor | Gets or sets a color hatch patterns are drawn with.
Public Property HatchStyle | Gets or sets a hatch pattern.
Public Property ImagePath | Gets or sets the path of a fill image.
Public Property Mode | Gets or sets the fill mode.
Public Property SecondaryColor | Gets or sets the secondary color.

See Also

Background Class | dotnetCHARTING Namespace


Background Class | Background Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Background Constructor

Overload List

Initializes a new instance of the Background class.

[Visual Basic] Public Sub New()

[C#] public Background();

Initializes a new instance of the Background object with a Brush.

[Visual Basic] Public Sub New(Brush)

[C#] public Background(Brush);

Initializes a new instance of the Background object with a color.

[Visual Basic] Public Sub New(Color)

[C#] public Background(Color);

Initializes a new instance of the Background object with gradient colors drawn left to right.

[Visual Basic] Public Sub New(Color,Color)

[C#] public Background(Color,Color);

Initializes a new instance of the Background object with gradient colors drawn at a specified angle.

[Visual Basic] Public Sub New(Color,Color,Single)

[C#] public Background(Color,Color,float);

Initializes a new instance of the Background object with a tiled image.

[Visual Basic] Public Sub New(String)

[C#] public Background(string);

Initializes a new instance of the Background object with an image and a background mode.

[Visual Basic] Public Sub New(String,BackgroundMode)

[C#] public Background(string,BackgroundMode);

See Also

Background Class | Background Members


Background Class | Background Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Background Constructor()

Initializes a new instance of the Background class.

[Visual Basic]
Public Function New()
[C#]
public Background();

See Also

Background Class | Background Members | Overload List


Background Constructor(Brush)

Background Class | Background Members | Overload List

Language

Visual Basic

C#

Show All

brush
Brush object used to to fill the background.
See Also Languages dotnetCHARTING Send comments on this topic.

Background Constructor(Brush)

Initializes a new instance of the Background object with a Brush.

[Visual Basic]
Public Function New( _
   ByVal brush As Brush _
)
[C#]
public Background(
   Brush brush
);

Parameters

brush
Brush object used to to fill the background.

See Also

Background Class | Background Members | Overload List


Background Constructor(Color)

Background Class | Background Members | Overload List

Language

Visual Basic

C#

Show All

myColor
Color to fill with.
See Also Languages dotnetCHARTING Send comments on this topic.

Background Constructor(Color)

Initializes a new instance of the Background object with a color.

[Visual Basic]
Public Function New( _
   ByVal myColor As Color _
)
[C#]
public Background(
   Color myColor
);

Parameters

myColor
Color to fill with.

See Also

Background Class | Background Members | Overload List


Background Constructor(Color,Color)

Background Class | Background Members | Overload List

Language

Visual Basic

C#

Show All

myColor
First color.
secondColor
Second color
See Also Languages dotnetCHARTING Send comments on this topic.

Background Constructor(Color,Color)

Initializes a new instance of the Background object with gradient colors drawn left to right.

[Visual Basic]
Public Function New( _
   ByVal myColor As Color, _
   ByVal secondColor As Color _
)
[C#]
public Background(
   Color myColor,
   Color secondColor
);

Parameters

myColor
First color.
secondColor
Second color

See Also

Background Class | Background Members | Overload List


Background Constructor(Color,Color,Single)

Background Class | Background Members | Overload List

Language

Visual Basic

C#

Show All

myColor
First color.
secondColor
Second color
angle
Specifies an angle ( left to right = 0, right to left = 180 )
See Also Languages dotnetCHARTING Send comments on this topic.

Background Constructor(Color,Color,Single)

Initializes a new instance of the Background object with gradient colors drawn at a specified angle.

[Visual Basic]
Public Function New( _
   ByVal myColor As Color, _
   ByVal secondColor As Color, _
   ByVal angle As Single _
)
[C#]
public Background(
   Color myColor,
   Color secondColor,
   float angle
);

Parameters

myColor
First color.
secondColor
Second color
angle
Specifies an angle ( left to right = 0, right to left = 180 )

See Also

Background Class | Background Members | Overload List


Background Constructor(String)

Background Class | Background Members | Overload List

Language

Visual Basic

C#

Show All

imagePath
Path of an image.
See Also Languages dotnetCHARTING Send comments on this topic.

Background Constructor(String)

Initializes a new instance of the Background object with a tiled image.

[Visual Basic]
Public Function New( _
   ByVal imagePath As String _
)
[C#]
public Background(
   string imagePath
);

Parameters

imagePath
Path of an image.

See Also

Background Class | Background Members | Overload List


Background Constructor(String,BackgroundMode)

Background Class | Background Members | Overload List

Language

Visual Basic

C#

Show All

imagePath
Path of a background image.
backgroundMode
Specifies a BackgroundMode to use with the image.
See Also Languages dotnetCHARTING Send comments on this topic.

Background Constructor(String,BackgroundMode)

Initializes a new instance of the Background object with an image and a background mode.

[Visual Basic]
Public Function New( _
   ByVal imagePath As String, _
   ByVal backgroundMode As BackgroundMode _
)
[C#]
public Background(
   string imagePath,
   BackgroundMode backgroundMode
);

Parameters

imagePath
Path of a background image.
backgroundMode
Specifies a BackgroundMode to use with the image.

Remarks

The

See Also

Background Class | Background Members | Overload List


Background Class Properties

Background Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Background Class Members

For a list of all members of this type, see Background members.

Public Properties

Public Property Bevel | Gets or sets a value that indicates wherer this background will use a bevel shading effect.
Public Property Brush | Gets or sets a brush object that is used to fill objects.
Public Property Color | Gets or sets the primary Color.
Public Property GlassEffect | Gets or sets a value that indicates whether a glass effect is used to fill an object.
Public Property GradientAngle | Gets or sets an angle at which gradients are drawn.( left to right = 0, right to left = 180 )
Public Property HatchColor | Gets or sets a color hatch patterns are drawn with.
Public Property HatchStyle | Gets or sets a hatch pattern.
Public Property ImagePath | Gets or sets the path of a fill image.
Public Property Mode | Gets or sets the fill mode.
Public Property SecondaryColor | Gets or sets the secondary color.

See Also

Background Class | dotnetCHARTING Namespace


Background Class | Background Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Bevel Property

Gets or sets a value that indicates wherer this background will use a bevel shading effect.

[Visual Basic]
Public Property Bevel As Boolean
[C#]
public bool Bevel {get; set;}

See Also

Background Class | Background Members


Background Class | Background Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Brush Property

Gets or sets a brush object that is used to fill objects.

[Visual Basic]
Public Property Brush As Brush
[C#]
public Brush Brush {get; set;}

See Also

Background Class | Background Members


Background Class | Background Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Color Property

Gets or sets the primary Color.

[Visual Basic]
Public Property Color As Color
[C#]
public Color Color {get; set;}

See Also

Background Class | Background Members


Background Class | Background Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GlassEffect Property

Gets or sets a value that indicates whether a glass effect is used to fill an object.

[Visual Basic]
Public Property GlassEffect As Boolean
[C#]
public bool GlassEffect {get; set;}

See Also

Background Class | Background Members


Background Class | Background Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GradientAngle Property

Gets or sets an angle at which gradients are drawn.( left to right = 0, right to left = 180 )

[Visual Basic]
Public Property GradientAngle As Single
[C#]
public float GradientAngle {get; set;}

See Also

Background Class | Background Members


Background Class | Background Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HatchColor Property

Gets or sets a color hatch patterns are drawn with.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}

See Also

Background Class | Background Members


Background Class | Background Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HatchStyle Property

Gets or sets a hatch pattern.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}

Remarks

If not specified, no hatch will is drawn.

See Also

Background Class | Background Members


Background Class | Background Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ImagePath Property

Gets or sets the path of a fill image.

[Visual Basic]
Public Property ImagePath As String
[C#]
public string ImagePath {get; set;}

Remarks

An image fill is used when BackgroundMode.ImageTile, BackgroundMode.ImageStretch or BackgroundMode.Image is used.

See Also

Background Class | Background Members


Background Class | Background Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Mode Property

Gets or sets the fill mode.

[Visual Basic]
Public Property Mode As BackgroundMode
[C#]
public BackgroundMode Mode {get; set;}

Return Type

A BackgroundMode enumeration that indicates how the background is filled.

See Also

Background Class | Background Members


Background Class | Background Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SecondaryColor Property

Gets or sets the secondary color.

[Visual Basic]
Public Property SecondaryColor As Color
[C#]
public Color SecondaryColor {get; set;}

Remarks

The secondary color is used with the primary color to create a gradient fill when using BackgroundMode.Gradient.

See Also

Background Class | Background Members


Box Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Box Class

Represents a box that acts as a container for text and icons. For example a TitleBox or LegendBox.

For a list of all members of this type, see Box members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.Box
dotnetCHARTING.LegendBox
dotnetCHARTING.Annotation

Syntax

[Visual Basic]
Public Class Box
[C#]
public class Box

Remarks

The box object provides the following

  • Defines objects used to fill the interior, shadow, and outline the box.
  • Defines rectangle edge styles.
  • Defines the position, title box icon, LegendBox layout template, and interior label.

See Also

Box Members | dotnetCHARTING Namespace


Box Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Box Class Members

Box overview

Public Constructors

Public Constructor Box Constructor Initializes a new instance of the Box class.

Public Properties

Public Property Background | Gets or sets a background object used to fill the interior of this box.
Public Property CornerBottomLeft | Gets or sets the bottom left corner style.
Public Property CornerBottomRight | Gets or sets the bottom right corner style.
Public Property CornerTopLeft | Gets or sets the top left corner style.
Public Property CornerTopRight | Gets or sets the top right corner style.
Public Property DefaultCorner | Gets or sets the default box corner style.
Public Property IconPath | Gets or sets the icon path of this title box.
Public Property InteriorLine | Gets or sets the interior line of this legend box.
Public Property Label | Gets or sets the Label of this box.
Public Property Line | Gets or sets the exterior line of this box.
Public Property Orientation | Gets or sets this object's orientation around a ChartArea.
Public Property Padding | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls.
Public Property Position | Gets or sets the position of this box.
Public Property Shadow | Gets or sets the Shadow cast under this box.
Public Property Visible | Gets or sets a value that indicates whether this box is visible.

Public Methods

Public Method ClearColors | Serves as a shortcut to make this box invisible.
Public Method GetCoordinates | Gets the coordinates of this box after the chart is rendered.
Public Method GetRectangle | Gets a Rectangle object indicating this boxes position and size after the chart is rendered.

See Also

Box Class | dotnetCHARTING Namespace


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Box Constructor

Initializes a new instance of the Box class.

[Visual Basic]
Public Function New()
[C#]
public Box();

See Also

Box Class | Box Members


Box Class Methods

Box Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Box Class Members

For a list of all members of this type, see Box members.

Public Methods

Public Method ClearColors | Serves as a shortcut to make this box invisible.
Public Method GetCoordinates | Gets the coordinates of this box after the chart is rendered.
Public Method GetRectangle | Gets a Rectangle object indicating this boxes position and size after the chart is rendered.

See Also

Box Class | dotnetCHARTING Namespace


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ClearColors Method

Serves as a shortcut to make this box invisible.

[Visual Basic]
Public Sub ClearColors()
[C#]
public void ClearColors();

Remarks

The following properties are set when invoked:

Background.Color = Color.Empty

Background.Bevel = false

Line.Color = Color.Empty

Shadow.Color = Color.Empty

InteriorLine.Color = Color.Empty

Example

Clears legend colors.

[C#]

Chart.LegendBox.ClearColors();

[Visual Basic]

Chart.LegendBox.ClearColors()

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetCoordinates Method

Gets the coordinates of this box after the chart is rendered.

[Visual Basic]
Public Function GetCoordinates() As Point()
[C#]
public Point[] GetCoordinates();

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetRectangle Method

Gets a Rectangle object indicating this boxes position and size after the chart is rendered.

[Visual Basic]
Public Function GetRectangle() As Rectangle
[C#]
public Rectangle GetRectangle();

See Also

Box Class | Box Members


Box Class Properties

Box Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Box Class Members

For a list of all members of this type, see Box members.

Public Properties

Public Property Background | Gets or sets a background object used to fill the interior of this box.
Public Property CornerBottomLeft | Gets or sets the bottom left corner style.
Public Property CornerBottomRight | Gets or sets the bottom right corner style.
Public Property CornerTopLeft | Gets or sets the top left corner style.
Public Property CornerTopRight | Gets or sets the top right corner style.
Public Property DefaultCorner | Gets or sets the default box corner style.
Public Property IconPath | Gets or sets the icon path of this title box.
Public Property InteriorLine | Gets or sets the interior line of this legend box.
Public Property Label | Gets or sets the Label of this box.
Public Property Line | Gets or sets the exterior line of this box.
Public Property Orientation | Gets or sets this object's orientation around a ChartArea.
Public Property Padding | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls.
Public Property Position | Gets or sets the position of this box.
Public Property Shadow | Gets or sets the Shadow cast under this box.
Public Property Visible | Gets or sets a value that indicates whether this box is visible.

See Also

Box Class | dotnetCHARTING Namespace


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Background Property

Gets or sets a background object used to fill the interior of this box.

[Visual Basic]
Public Property Background As Background
[C#]
public Background Background {get; set;}

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CornerBottomLeft Property

Gets or sets the bottom left corner style.

[Visual Basic]
Public Property CornerBottomLeft As BoxCorner
[C#]
public BoxCorner CornerBottomLeft {get; set;}

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CornerBottomRight Property

Gets or sets the bottom right corner style.

[Visual Basic]
Public Property CornerBottomRight As BoxCorner
[C#]
public BoxCorner CornerBottomRight {get; set;}

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CornerTopLeft Property

Gets or sets the top left corner style.

[Visual Basic]
Public Property CornerTopLeft As BoxCorner
[C#]
public BoxCorner CornerTopLeft {get; set;}

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CornerTopRight Property

Gets or sets the top right corner style.

[Visual Basic]
Public Property CornerTopRight As BoxCorner
[C#]
public BoxCorner CornerTopRight {get; set;}

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultCorner Property

Gets or sets the default box corner style.

[Visual Basic]
Public Property DefaultCorner As BoxCorner
[C#]
public BoxCorner DefaultCorner {get; set;}

Remarks

Explicitly set corners will not be overridden.

Example

Usage example.

[Visual Basic]

Chart.LegendBox.DefaultCorner = BoxCorner.Round

[C#]

Chart.LegendBox.DefaultCorner = BoxCorner.Round;

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

IconPath Property

Gets or sets the icon path of this title box.

[Visual Basic]
Public Property IconPath As String
[C#]
public string IconPath {get; set;}

Remarks

Only the title box supports this feature.

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InteriorLine Property

Gets or sets the interior line of this legend box.

[Visual Basic]
Public Property InteriorLine As Line
[C#]
public Line InteriorLine {get; set;}

Remarks

Multiple column legend boxes draw this line to separate columns.

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Label Property

Gets or sets the Label of this box.

[Visual Basic]
Public Property Label As Label
[C#]
public Label Label {get; set;}

Remarks

When the box text is not determined by this label, it's font and color properties will be used for any text that appears in the box. When used as a TitleBox and the position is set to FullWithLegend, the font properties of ChartArea.LegendBox.Label will be used for the legend entries and the Chart.TitleBox.Label properties and text will be used for the title.

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Property

Gets or sets the exterior line of this box.

[Visual Basic]
Public Property Line As Line
[C#]
public Line Line {get; set;}

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Orientation Property

Gets or sets this object's orientation around a ChartArea.

[Visual Basic]
Public Property Orientation As Orientation
[C#]
public Orientation Orientation {get; set;}

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Padding Property

Gets or sets a value in pixels that represents the padding between objects within the box and the box walls.

[Visual Basic]
Public Property Padding As Integer
[C#]
public int Padding {get; set;}

Remarks

Legend boxes also use this property to set the padding between entries.

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Position Property

Gets or sets the position of this box.

[Visual Basic]
Public Overridable Property Position As Object
[C#]
public virtual object Position {get; set;}

Return Type

TitleBoxPosition, LegendBoxPosition enumeration, or Point.

Example

Show 3 uses of the property.

[Visual Basic]

'Title position
Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend
'Legend box position
Chart.LegendBox.Position = LegendBoxPosition.Top
'Absolute legend position in pixels
Chart.LegendBox.Position = New Point(10,15)

[C#]

//Title position
Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend;
//Legend box position
Chart.LegendBox.Position = LegendBoxPosition.Top;
//Absolute legend position in pixels
Chart.LegendBox.Position = New Point(10,15);

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Shadow Property

Gets or sets the Shadow cast under this box.

[Visual Basic]
Public Property Shadow As Shadow
[C#]
public Shadow Shadow {get; set;}

See Also

Box Class | Box Members


Box Class | Box Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Visible Property

Gets or sets a value that indicates whether this box is visible.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

Box Class | Box Members


CalendarPattern Members | dotnetCHARTING Namespace | AxisMarker Class | Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CalendarPattern Class

Specifies a calendar pattern such as weekends in a week.

For a list of all members of this type, see CalendarPattern members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.CalendarPattern

Syntax

[Visual Basic]
Public Class CalendarPattern
[C#]
public class CalendarPattern

Remarks

The pattern is represented by an array of boolean values. CalendarPattern.PatternFromString can be used to quickly create patterns using simple strings. A week pattern would look like this: "0000000". A zero for each day of the week. To indicate weekends the pattern will be "1000001". The time units must also be specified.

Each one or zero represents a day:
myCalendarPattern.PatternUnit = TimeInterval.Day

The entire pattern represents a week:
myCalendarPattern.CalendarUnit = TimeInterval.Week

The above calendar pattern will flag each saturday and sunday in a given, time span.

See Also

CalendarPattern Members | dotnetCHARTING Namespace | AxisMarker Class | Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)


CalendarPattern Class | dotnetCHARTING Namespace | AxisMarker Class | Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)

See Also dotnetCHARTING Send comments on this topic.

CalendarPattern Class Members

CalendarPattern overview

Public Constructors

Public Constructor CalendarPattern Constructor Overloaded.

Public Properties

Public Property AdjustmentUnit | Gets or sets a values by which the time interval is offset on the axis.
Public Property CalendarUnit | Gets or sets a TimeInterval that represents the time unit of the entire Pattern.
Public Property Pattern | Gets or sets the calendar pattern.
Public Property PatternUnit | Gets or sets a TimeInterval that represents the time unit of each Boolean value in the Pattern.
Public Property static (Shared in Visual Basic) Weekdays | Gets a calendar pattern instance representing weekdays.
Public Property static (Shared in Visual Basic) Weekends | Gets a calendar pattern instance representing weekends.

Public Methods

Public Method Invert | Inverts this CalendarPattern.
Public Method static (Shared in Visual Basic) PatternFromString | Gets a boolean array from a string of ones (1) and zeros (0).

See Also

CalendarPattern Class | dotnetCHARTING Namespace | AxisMarker Class | Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)


CalendarPattern Class | CalendarPattern Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CalendarPattern Constructor

Overload List

Initializes a new instance of the CalendarPattern class.

[Visual Basic] Public Sub New()

[C#] public CalendarPattern();

Initializes a new instance of the CalendarPattern class with time units and a pattern.

[Visual Basic] Public Sub New(TimeInterval,TimeInterval,Boolean())

[C#] public CalendarPattern(TimeInterval,TimeInterval,bool[]);

Initializes a new instance of the CalendarPattern class with time units and a string pattern.

[Visual Basic] Public Sub New(TimeInterval,TimeInterval,String)

[C#] public CalendarPattern(TimeInterval,TimeInterval,string);

See Also

CalendarPattern Class | CalendarPattern Members


CalendarPattern Class | CalendarPattern Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CalendarPattern Constructor()

Initializes a new instance of the CalendarPattern class.

[Visual Basic]
Public Function New()
[C#]
public CalendarPattern();

See Also

CalendarPattern Class | CalendarPattern Members | Overload List


CalendarPattern Constructor(TimeInterval,TimeInterval,Boolean[])

CalendarPattern Class | CalendarPattern Members | Overload List

Language

Visual Basic

C#

Show All

mappedTimeUnit
wholeTimeUnit
timePattern
See Also Languages dotnetCHARTING Send comments on this topic.

CalendarPattern Constructor(TimeInterval,TimeInterval,Boolean[])

Initializes a new instance of the CalendarPattern class with time units and a pattern.

[Visual Basic]
Public Function New( _
   ByVal mappedTimeUnit As TimeInterval, _
   ByVal wholeTimeUnit As TimeInterval, _
   ByVal timePattern() As Boolean _
)
[C#]
public CalendarPattern(
   TimeInterval mappedTimeUnit,
   TimeInterval wholeTimeUnit,
   bool[] timePattern
);

Parameters

mappedTimeUnit
wholeTimeUnit
timePattern

Example

This instantiates a new CallendarPattern of a week marking the saturday and sunday. It uses the PatternFromString method to simplify adding a pattern by using a string.

[C#]

CalendarPattern newPattern = new CalendarPattern(TimeInterval.Day,TimeInterval.Week,CalendarPattern.PatternFromString("1000001"));

See Also

CalendarPattern Class | CalendarPattern Members | Overload List


CalendarPattern Constructor(TimeInterval,TimeInterval,String)

CalendarPattern Class | CalendarPattern Members | Overload List

Language

Visual Basic

C#

Show All

mappedTimeUnit
wholeTimeUnit
timePattern
See Also Languages dotnetCHARTING Send comments on this topic.

CalendarPattern Constructor(TimeInterval,TimeInterval,String)

Initializes a new instance of the CalendarPattern class with time units and a string pattern.

[Visual Basic]
Public Function New( _
   ByVal mappedTimeUnit As TimeInterval, _
   ByVal wholeTimeUnit As TimeInterval, _
   ByVal timePattern As String _
)
[C#]
public CalendarPattern(
   TimeInterval mappedTimeUnit,
   TimeInterval wholeTimeUnit,
   string timePattern
);

Parameters

mappedTimeUnit
wholeTimeUnit
timePattern

Example

This instantiates a new CallendarPattern of a week marking the saturday and sunday.

[C#]

CalendarPattern newPattern = new CalendarPattern(TimeInterval.Day,TimeInterval.Week,"1000001");

See Also

CalendarPattern Class | CalendarPattern Members | Overload List


CalendarPattern Class Methods

CalendarPattern Class | dotnetCHARTING Namespace | AxisMarker Class | Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)

See Also dotnetCHARTING Send comments on this topic.

CalendarPattern Class Members

For a list of all members of this type, see CalendarPattern members.

Public Methods

Public Method Invert | Inverts this CalendarPattern.
Public Method static (Shared in Visual Basic) PatternFromString | Gets a boolean array from a string of ones (1) and zeros (0).

See Also

CalendarPattern Class | dotnetCHARTING Namespace | AxisMarker Class | Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)


CalendarPattern Class | CalendarPattern Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Invert Method

Inverts this CalendarPattern.

[Visual Basic]
Public Sub Invert()
[C#]
public void Invert();

Remarks

If the pattern is "0011", after this operation it will become "1100".

See Also

CalendarPattern Class | CalendarPattern Members


PatternFromString Method

CalendarPattern Class | CalendarPattern Members

Language

Visual Basic

C#

Show All

str
A pattern in a string form. A string of "1100" will return [ true, true, false, false ]. The boolean array can be used to set the Pattern property of this CalendPattern.
See Also Languages dotnetCHARTING Send comments on this topic.

PatternFromString Method

Gets a boolean array from a string of ones (1) and zeros (0).

[Visual Basic]
Public Shared Function PatternFromString( _
   ByVal str As String _
) As Boolean()
[C#]
public static bool[] PatternFromString(
   string str
);

Parameters

str
A pattern in a string form. A string of "1100" will return [ true, true, false, false ]. The boolean array can be used to set the Pattern property of this CalendPattern.

Return Type

bool[]

See Also

CalendarPattern Class | CalendarPattern Members


CalendarPattern Class Properties

CalendarPattern Class | dotnetCHARTING Namespace | AxisMarker Class | Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)

See Also dotnetCHARTING Send comments on this topic.

CalendarPattern Class Members

For a list of all members of this type, see CalendarPattern members.

Public Properties

Public Property AdjustmentUnit | Gets or sets a values by which the time interval is offset on the axis.
Public Property CalendarUnit | Gets or sets a TimeInterval that represents the time unit of the entire Pattern.
Public Property Pattern | Gets or sets the calendar pattern.
Public Property PatternUnit | Gets or sets a TimeInterval that represents the time unit of each Boolean value in the Pattern.
Public Property static (Shared in Visual Basic) Weekdays | Gets a calendar pattern instance representing weekdays.
Public Property static (Shared in Visual Basic) Weekends | Gets a calendar pattern instance representing weekends.

See Also

CalendarPattern Class | dotnetCHARTING Namespace | AxisMarker Class | Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)


CalendarPattern Class | CalendarPattern Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AdjustmentUnit Property

Gets or sets a values by which the time interval is offset on the axis.

[Visual Basic]
Public Property AdjustmentUnit As TimeInterval
[C#]
public TimeInterval AdjustmentUnit {get; set;}

Remarks

This property can be useful with axis markers because tick marks may appear at the beginning of a time unit like month. The calendar pattern may need to be adjusted to properly correspond to axis ticks.

See Also

CalendarPattern Class | CalendarPattern Members


CalendarPattern Class | CalendarPattern Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CalendarUnit Property

Gets or sets a TimeInterval that represents the time unit of the entire Pattern.

[Visual Basic]
Public Property CalendarUnit As TimeInterval
[C#]
public TimeInterval CalendarUnit {get; set;}

See Also

CalendarPattern Class | CalendarPattern Members


CalendarPattern Class | CalendarPattern Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Pattern Property

Gets or sets the calendar pattern.

[Visual Basic]
Public Property Pattern As Boolean()
[C#]
public bool[] Pattern {get; set;}

See Also

CalendarPattern Class | CalendarPattern Members


CalendarPattern Class | CalendarPattern Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PatternUnit Property

Gets or sets a TimeInterval that represents the time unit of each Boolean value in the Pattern.

[Visual Basic]
Public Property PatternUnit As TimeInterval
[C#]
public TimeInterval PatternUnit {get; set;}

See Also

CalendarPattern Class | CalendarPattern Members


CalendarPattern Class | CalendarPattern Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Weekdays Property

Gets a calendar pattern instance representing weekdays.

[Visual Basic]
Public Shared ReadOnly Property Weekdays As CalendarPattern
[C#]
public static CalendarPattern Weekdays {get;}

See Also

CalendarPattern Class | CalendarPattern Members


CalendarPattern Class | CalendarPattern Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Weekends Property

Gets a calendar pattern instance representing weekends.

[Visual Basic]
Public Shared ReadOnly Property Weekends As CalendarPattern
[C#]
public static CalendarPattern Weekends {get;}

See Also

CalendarPattern Class | CalendarPattern Members


Chart Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Chart Class

The .netCHARTING control.

For a list of all members of this type, see Chart members.

Object Model

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
dotnetCHARTING.Chart

Syntax

[Visual Basic]
Public Class Chart
   Inherits WebControl
[C#]
public class Chart : WebControl

See Also

Chart Members | dotnetCHARTING Namespace


Chart Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Chart Class Members

Chart overview

Public Constructors

Public Constructor Chart Constructor Initializes a new empty instance of the Chart control.

Public Properties

Public Property AccessKey (Inherited from System.Web.UI.WebControls.WebControl)
Public Property AlternateText | Gets or sets text displayed in place of a chart when images can't be viewed. This property can also be used as a tooltip for the chart in browsers that support this feature.
Public Property Annotations | A collection of Annotation objects drawn on the chart.
Public Property Attributes (Inherited from System.Web.UI.WebControls.WebControl)
Public Property AutoNameLabels | Gets or sets a value which indicates whether elements and series are automatically named when no names are provided.
Public Property AxisCollection | Contains a collection of calculated Axis objects.
Public Property BackColor (Inherited from System.Web.UI.WebControls.WebControl)
Public Property Background | Gets or sets the Background of this chart.
Public Property BindingContainer (Inherited from System.Web.UI.Control)
Public Property BorderColor (Inherited from System.Web.UI.WebControls.WebControl)
Public Property BorderStyle (Inherited from System.Web.UI.WebControls.WebControl)
Public Property BorderWidth (Inherited from System.Web.UI.WebControls.WebControl)
Public Property CacheDuration | Gets or sets the number of minutes an image is cached and displayed on a page before a new one is generated.
Public Property CalculateEmptyElement | Gets or sets a value indicating whether the values of empty elements are percieved as 0 or omitted in calculations performed with the Chart.SeriesCollection.Add(Calculation calc) shortcut.
Public Property ChartArea | Gets or sets the main ChartArea of the image.
Public Property ChartAreaLayout | Gets or sets chart area layout options.
Public Property ChartAreaSpacing | Gets or sets a value in pixels that defines the spacing between boxes like chart areas and legends.
Public Property CleanupMinimumAge | Gets or sets the minimum number of minutes images are stored in the TempDirectory before they are deleted.
Public Property CleanupPeriod | Gets or sets the number of minutes images are stored in the TempDirectory folder before they are deleted.
Public Property ClientID (Inherited from System.Web.UI.Control)
Public Property ClipGauges | Gets or sets a value which determines if gauges should be clipped (cut) to display only the active area.
Public Property Controls (Inherited from System.Web.UI.Control)
Public Property ControlStyle (Inherited from System.Web.UI.WebControls.WebControl)
Public Property ControlStyleCreated (Inherited from System.Web.UI.WebControls.WebControl)
Public Property CssClass (Inherited from System.Web.UI.WebControls.WebControl)
Public Property DatabaseCultureName | Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.
Public Property DataGrid | Gets or sets the control ID of a datagrid control that will be populated with the charted data.
Public Property DataGridFormatString Gets or sets the format string which determines number formatting in the datagrid.

Public Property DataGridSeriesHeader | Gets or sets the header label of the DataGrid control specified by the DataGrid property.
Public Property DataGridTranspose | Gets or sets a value indicating whether the data with which the specified DataGrid control is populated will be transposed.
Public Property DateGrouping | Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Public Property DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property Debug | Gets or sets a value that indicates whether debug messages are displayed below the chart.
Public Property DefaultAxis | Gets or sets an Axis object whose properties will trickle down to all other axes on the chart unless otherwise specified.
Public Property DefaultBox | Gets a base box object that is used as a vehicle for property settings which will become the defaults settings of all elements on the chart that derive from box.
Public Property DefaultChartArea | Gets a ChartArea object whose property settings will propagate to all other ChartArea objects on the chart image.
Public Property DefaultCultureName | Gets or sets the default culture name which determines number and date formatting.
Public Property DefaultElement | Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.
Public Property DefaultFormatString Gets or sets the default format string which determines number and date formatting.

See Chart.DefaultAxis.FormatString.
Public Property DefaultLegendBox | Gets a LegendBox object whose property settings will propagate to all other LegendBox objects on the chart image.
Public Property DefaultSeries | Gets or sets a Series object whose properties will trickle to all other series on the chart unless otherwise specified.
Public Property DefaultShadow | Gets or sets a shadow object whose properties will trickle to all other objects with shadows.
Public Property DefaultTitleBox | Gets a Box object whose property settings will propagate to all title boxes on the chart image.
Public Property Depth | Gets or sets depth of the chart when Use3D is true.
Public Property DisableBrowserCache | Gets or sets a value indicating whether disable browser cache.
Public Property DonutHoleSize | Gets or sets a percentage value which determines the relative thickness of the donut ring when ChartType.Donut is used.
Public Property DrillDownChain Gets or sets the drill down chain which activates automatic time based drill down if date grouping used.

If Limit or SplitByLimit used with ShowOther option, setting drill down chain to "Other" or "OtherAll" activates automatic drill down to other elements or series.

"OtherAll" shows all other elements or series in the second level.
"Other" shows the next number of elements or series has been set in limit or splitByLimit propertes.

Public Property DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property EmptyElementText | Gets or sets the default text of empty element labels. See Chart.DefaultSeries.DefaultElement.SmartLabel
Public Property Enabled (Inherited from System.Web.UI.WebControls.WebControl)
Public Property EnableViewState (Inherited from System.Web.UI.Control)
Public Property ExplodedSliceAmount | Gets or sets the relative percentage an exploded slice should be pulled out from the pie or donut.
Public Property ExtraChartAreas | Gets a collection of additional ChartArea objects added to the chart.
Public Property ExtraLegendBoxes | Gets a collection of additional LegendBox objects added to the chart.
Public Property FileManager | Gets or sets the chart's instance of the FileManager which facilitates saving images.
Public Property FileName | See Chart.FileManager.FileName.
Public Property FileQuality | Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)
Public Property Font (Inherited from System.Web.UI.WebControls.WebControl)
Public Property ForeColor (Inherited from System.Web.UI.WebControls.WebControl)
Public Property GanttCompleteHatchStyle | Gets or sets the hatch style drawn on columns and cylinders when an element's Complete value is set.
Public Property HatchStylePalette | Gets or sets a hatch style palette that will trickle to all series on the chart. The hatch patterns will not show on chart elements if a hatch color is not specified. The default hatch color can be specified with the Chart.DefaultSeries.DefaultElement.HatchColor property.
Public Property HatchStylePaletteName | Gets or sets a predefined HatchStylePalette that defines element and series hatch style.
Public Property Height | Overridden. Gets or sets the height of the chart image.
Public Property Hotspot | Gets or sets the Hotspot property of the chart image.
Public Property ID (Inherited from System.Web.UI.Control)
Public Property ImageFormat | Gets or sets an ImageFormat enumeration specifying the generated image's file type.
Public Property ImageMapName | Returns a string for the image map name generated for the current chart image.
Public Property ImageMapText | Returns a string for the image map generated for the current chart image.
Public Property LegendBox | Gets or sets a LegendBox object that represents the legend box.
Public Property LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property Margin | Gets or sets a string which automatically sets multiple margins as a shortcut.
Public Property MarginBottom | Gets or sets the bottom margin of the chart image.
Public Property MarginLeft | Gets or sets the left margin of the chart image.
Public Property MarginRight | Gets or sets the right margin of the chart image.
Public Property MarginTop | Gets or sets the top margin of the chart image.
Public Property MaximumBubbleSize | Gets or sets a value which controls the maximum size of bubbles when ChartType.Bubble is used.
Public Property Mentor | Gets or sets a value that indicates whether the mentor is shown under the chart control. The mentor also requires that Chart.Debug is set to true.
Public Property NamingContainer (Inherited from System.Web.UI.Control)
Public Property NoDataLabel | Gets or sets a label shown on the chart when no data is available.
Public Property OverlapFooter | Gets or sets a value indicating whether the 'unlicensed chart' footer overlaps the chart or moves it up.
Public Property Page (Inherited from System.Web.UI.Control)
Public Property Palette | Gets or sets an array of colors that define element and series colors.
Public Property PaletteName | Gets or sets a predefined Palette that defines element and series colors.
Public Property Parent (Inherited from System.Web.UI.Control)
Public Property PieLabelMode | See DefaultSeries.DefaultElement.SmartLabel.PieLabelMode.
Public Property PopulateDateGroupingSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to !:SubValues or not. By default, such values are not added to the element subvalues.
Public Property PrinterOptimizedText | Gets or sets a value that indicates whether text rendered on the chart optimized for printing.
Public Property RadarLabelMode | See DefaultSeries.DefaultElement.SmartLabel.RadarLabelMode.
Public Property ReloadPeriod | Gets or sets a TimeSpan object that determines how often the page containing this chart will automatically reload.
Public Property Series | Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.
Public Property SeriesCollection | Gets a SeriesCollection object which represents the data this chart will render.
Public Property ShadingEffect | See ShadingEffectMode.
Public Property ShadingEffectMode | Gets or sets a ShadingEffectMode enumeration indicating how elements on the chart are shaded.
Public Property ShowDateInTitle | Gets or sets a value which indicates whether specified dates are shown in the title.
Public Property Site (Inherited from System.Web.UI.Control)
Public Property Size | Sets a string that automatically sets the Height and Width of the chart image.
Public Property SmartLabelLine | See Chart.DefaultSeries.DefaultElement.SmartLabel.Line.
Public Property SmartPalette | Gets or sets a NameColorCollection object that specifies the colors of elements and series with specific names.
Public Property SmartPaletteAutoSync | Gets or sets a boolean which controls smart palette synchronization.
Public Property StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property StartDayOfWeek | Gets or sets a DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.
Public Property Style (Inherited from System.Web.UI.WebControls.WebControl)
Public Property TabIndex (Inherited from System.Web.UI.WebControls.WebControl)
Public Property TempDirectory | Gets or sets the directory where images generated by the control are temporarily stored.
Public Property TemplateSourceDirectory (Inherited from System.Web.UI.Control)
Public Property Title Gets or sets the chart title.

Equivalent to Chart.TitleBox.Label.Text.
Public Property TitleBox | Gets or sets a Box object that represents the title box.
Public Property ToolTip | Overridden. Gets or sets the Tooltip of the entinre chart image.
Public Property TotalSeries | Return the total number of series in the seriesCollection. This property usually used in conjunction with SplitByLimit.
Public Property Transpose | Gets or sets a value indicating whether data added to this chart's SeriesCollection property is automatically transposed.
Public Property Type | Gets or sets the ChartType of this Chart.
Public Property UniqueID (Inherited from System.Web.UI.Control)
Public Property URL | Gets or sets the URL of the entinre chart image.
Public Property URLTarget | Gets or sets the target of the URL link.
Public Property Use3D | Gets or sets a value indicating whether chart elements are rendered in 3D.
Public Property UseFile | Gets or sets a value indicating whether the generated image is saved as a file in the TempDirectory folder or streamed directly to the browser.
Public Property Visible (Inherited from System.Web.UI.Control)
Public Property Width | Overridden. Gets or sets the width of the chart image.
Public Property XAxis | Gets or Sets the main XAxis which all series inherit by default.
Public Property YAxis | Gets or Sets the main YAxis which all series inherit by default.

Public Methods

Public Method ApplyStyle (Inherited from System.Web.UI.WebControls.WebControl) |
Public Method CopyBaseAttributes (Inherited from System.Web.UI.WebControls.WebControl) |
Public Method DataBind (Inherited from System.Web.UI.Control) |
Public Method Dispose (Inherited from System.Web.UI.Control) |
Public Method FindControl (Inherited from System.Web.UI.Control) |
Public Method GetChartBitmap | Obtains a Bitmap of the generated chart.
Public Method GetLegendBitmap | Obtains a Bitmap of the legend generated by the chart.
Public Method HasControls (Inherited from System.Web.UI.Control) |
Public Method LoadState | Overloaded.
Public Method MergeStyle (Inherited from System.Web.UI.WebControls.WebControl) |
Public Method RenderBeginTag (Inherited from System.Web.UI.WebControls.WebControl) |
Public Method RenderControl (Inherited from System.Web.UI.Control) |
Public Method RenderEndTag (Inherited from System.Web.UI.WebControls.WebControl) |
Public Method ResolveUrl (Inherited from System.Web.UI.Control) |
Public Method SaveState | Overloaded.
Public Method SetRenderMethodDelegate (Inherited from System.Web.UI.Control) |

Public Events

Public Event DataBinding (Inherited from System.Web.UI.Control) |
Public Event Disposed (Inherited from System.Web.UI.Control) |
Public Event Init (Inherited from System.Web.UI.Control) |
Public Event Load (Inherited from System.Web.UI.Control) |
Public Event PostDataProcessing | Occurs when the the chart is completed the data processing.
Public Event PreRender (Inherited from System.Web.UI.Control) |
Public Event Unload (Inherited from System.Web.UI.Control) |

See Also

Chart Class | dotnetCHARTING Namespace


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Chart Constructor

Initializes a new empty instance of the Chart control.

[Visual Basic]
Public Function New()
[C#]
public Chart();

See Also

Chart Class | Chart Members


Chart Class Methods

Chart Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Chart Class Members

For a list of all members of this type, see Chart members.

Public Methods

Public Method ApplyStyle (Inherited from System.Web.UI.WebControls.WebControl) |
Public Method CopyBaseAttributes (Inherited from System.Web.UI.WebControls.WebControl) |
Public Method DataBind (Inherited from System.Web.UI.Control) |
Public Method Dispose (Inherited from System.Web.UI.Control) |
Public Method FindControl (Inherited from System.Web.UI.Control) |
Public Method GetChartBitmap | Obtains a Bitmap of the generated chart.
Public Method GetLegendBitmap | Obtains a Bitmap of the legend generated by the chart.
Public Method HasControls (Inherited from System.Web.UI.Control) |
Public Method LoadState | Overloaded.
Public Method MergeStyle (Inherited from System.Web.UI.WebControls.WebControl) |
Public Method RenderBeginTag (Inherited from System.Web.UI.WebControls.WebControl) |
Public Method RenderControl (Inherited from System.Web.UI.Control) |
Public Method RenderEndTag (Inherited from System.Web.UI.WebControls.WebControl) |
Public Method ResolveUrl (Inherited from System.Web.UI.Control) |
Public Method SaveState | Overloaded.
Public Method SetRenderMethodDelegate (Inherited from System.Web.UI.Control) |

See Also

Chart Class | dotnetCHARTING Namespace


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetChartBitmap Method

Obtains a Bitmap of the generated chart.

[Visual Basic]
Public Function GetChartBitmap() As Bitmap
[C#]
public Bitmap GetChartBitmap();

Return Type

A Bitmap of the chart.

Remarks

When invoked, the Point properties of all elements drawn on the chart will be populated.

Example

[C#]

//Get the bitmap and add a line to the image
Bitmap bmp = Chart.GetChartBitmap();
Graphics g = Graphics.FromImage(bmp);
g.DrawLine(Pens.Red,36,150,480,150);
g.DrawString("This is my line",new Font("Arial",12,FontStyle.Bold),new SolidBrush(Color.Black),new Point(40,150));
g.Dispose();

//Save the image and set the image path to ImageUrl.
string ImagePath = Chart.FileManager.SaveImage(bmp);
Image1.ImageUrl = ImagePath;

//For complete code see PostRenderDrawing.aspx sample

[Visual Basic]

'Get the bitmap and add a line to the image
Dim bmp As Bitmap = Chart.GetChartBitmap()
Dim g As Graphics = Graphics.FromImage(bmp)
g.DrawLine(Pens.Red, 36, 150, 480, 150)
g.DrawString("This is my line", new Font("Arial", 12, FontStyle.Bold), new SolidBrush(Color.Black), new PointF(40F, 150F))
g.Dispose()

'Save the image and set the image path to ImageUrl.
Dim ImagePath As String = Chart.FileManager.SaveImage(bmp)
Image1.ImageUrl = ImagePath

'For complete code see PostRenderDrawing.aspx sample

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetLegendBitmap Method

Obtains a Bitmap of the legend generated by the chart.

[Visual Basic]
Public Function GetLegendBitmap() As Bitmap
[C#]
public Bitmap GetLegendBitmap();

Return Type

A Bitmap of the legend.

Remarks

When invoked, the Point properties of all elements drawn on the chart will be populated.

Example

[C#]

//Save the legend as a separate image file
System.Web.UI.WebControls.Image ImageLegend = new System.Web.UI.WebControls.Image();
ImageLegend.ImageUrl = Chart.FileManager.SaveImage(Chart.GetLegendBitmap());
Controls.Add(ImageLegend);

//For complete code see SaveLegendImage.aspx sample

[Visual Basic]

' Save the legend as a separate image file
Dim ImageLegend As System.Web.UI.WebControls.Image = new System.Web.UI.WebControls.Image()
ImageLegend.ImageUrl = Chart.FileManager.SaveImage(Chart.GetLegendBitmap())
Controls.Add(ImageLegend)

'For complete code see SaveLegendImage.aspx sample.

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LoadState Method

Overload List

Imports a chart object from the specified xml file.

[Visual Basic] Overloads Public Sub LoadState(String)

[C#] public void LoadState(string);

Imports a chart object from the specified xml file.

[Visual Basic] Overloads Public Function LoadState(String,Boolean) As Object

[C#] public object LoadState(string,bool);

Set the chart object from the specified xml file.

[Visual Basic] Overloads Public Sub LoadState(String,Chart)

[C#] public void LoadState(string,Chart);

Set the chart object from the specified xml file.

[Visual Basic] Overloads Public Sub LoadState(String,Chart,Boolean)

[C#] public void LoadState(string,Chart,bool);

See Also

Chart Class | Chart Members


LoadState(String) Method

Chart Class | Chart Members | Overload List

Language

Visual Basic

C#

Show All

xmlDataOrFileName
Path of XML file or XML data to load.
See Also Languages dotnetCHARTING Send comments on this topic.

LoadState(String) Method

Imports a chart object from the specified xml file.

[Visual Basic]
Overloads Public Sub LoadState( _
   ByVal xmlDataOrFileName As String _
)
[C#]
public void LoadState(
   string xmlDataOrFileName
);

Parameters

xmlDataOrFileName
Path of XML file or XML data to load.

Return Type

A chart object.

Remarks

This property takes either a raw xml string or an xml file name. For an xml file name it takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.

Example

This examples demonstrate different ways of accessing the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.

[C#]

Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml");
Chart.LoadState("/app/temp/chart.xml");
Chart.LoadState("chart.xml");

[Visual Basic]

Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml")
Chart.LoadState("/app/temp/chart.xml")
Chart.LoadState("chart.xml")

See Also

Chart Class | Chart Members | Overload List


LoadState(String,Boolean) Method

Chart Class | Chart Members | Overload List

Language

Visual Basic

C#

Show All

xmlDataOrFileName
Path of XML file or XML data to load.
clear
Determine whether clear the chart object before loading the data.
See Also Languages dotnetCHARTING Send comments on this topic.

LoadState(String,Boolean) Method

Imports a chart object from the specified xml file.

[Visual Basic]
Overloads Public Function LoadState( _
   ByVal xmlDataOrFileName As String, _
   ByVal clear As Boolean _
) As Object
[C#]
public object LoadState(
   string xmlDataOrFileName,
   bool clear
);

Parameters

xmlDataOrFileName
Path of XML file or XML data to load.
clear
Determine whether clear the chart object before loading the data.

Return Type

A chart object.

Remarks

This property takes either a raw xml string or an xml file name. For an xml file name it takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.

Example

This examples demonstrate different ways of accessing the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.

[C#]

Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml");
Chart.LoadState("/app/temp/chart.xml");
Chart.LoadState("chart.xml");

[Visual Basic]

Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml")
Chart.LoadState("/app/temp/chart.xml")
Chart.LoadState("chart.xml")

See Also

Chart Class | Chart Members | Overload List


LoadState(String,Chart) Method

Chart Class | Chart Members | Overload List

Language

Visual Basic

C#

Show All

xmlDataOrFileName
Path of XML file or XML data to load.
chartObject
The chart object that be loaded with XML data.
See Also Languages dotnetCHARTING Send comments on this topic.

LoadState(String,Chart) Method

Set the chart object from the specified xml file.

[Visual Basic]
Overloads Public Sub LoadState( _
   ByVal xmlDataOrFileName As String, _
   ByVal chartObject As Chart _
)
[C#]
public void LoadState(
   string xmlDataOrFileName,
   Chart chartObject
);

Parameters

xmlDataOrFileName
Path of XML file or XML data to load.
chartObject
The chart object that be loaded with XML data.

Remarks

This first parameter takes either a raw xml string or an xml file name. For an xml file name it takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.

Example

This examples demonstrate different ways of accessing the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.

[C#]

Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml");
Chart.LoadState("/app/temp/chart.xml");
Chart.LoadState("chart.xml");

[Visual Basic]

Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml")
Chart.LoadState("/app/temp/chart.xml")
Chart.LoadState("chart.xml")

See Also

Chart Class | Chart Members | Overload List


LoadState(String,Chart,Boolean) Method

Chart Class | Chart Members | Overload List

Language

Visual Basic

C#

Show All

xmlDataOrFileName
Path of XML file or XML data to load.
chartObject
The chart object that be loaded with XML data.
clear
Determine whether clear the chart object before loading the data.
See Also Languages dotnetCHARTING Send comments on this topic.

LoadState(String,Chart,Boolean) Method

Set the chart object from the specified xml file.

[Visual Basic]
Overloads Public Sub LoadState( _
   ByVal xmlDataOrFileName As String, _
   ByVal chartObject As Chart, _
   ByVal clear As Boolean _
)
[C#]
public void LoadState(
   string xmlDataOrFileName,
   Chart chartObject,
   bool clear
);

Parameters

xmlDataOrFileName
Path of XML file or XML data to load.
chartObject
The chart object that be loaded with XML data.
clear
Determine whether clear the chart object before loading the data.

Remarks

This first parameter takes either a raw xml string or an xml file name. For an xml file name it takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.

Example

This examples demonstrate different ways of accessing the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.

[C#]

Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml",chartObject,false);
Chart.LoadState("/app/temp/chart.xml",chartObject,false);
Chart.LoadState("chart.xml",chartObject,false);

[Visual Basic]

Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml",chartObject,false)
Chart.LoadState("/app/temp/chart.xml",chartObject,false)
Chart.LoadState("chart.xml",chartObject,false)

See Also

Chart Class | Chart Members | Overload List


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SaveState Method

Overload List

Saves this chart instance to an xml string.

[Visual Basic] Overloads Public Function SaveState() As String

[C#] public string SaveState();

Saves the chart instance to an xml string.

[Visual Basic] Overloads Public Function SaveState(Chart) As String

[C#] public string SaveState(Chart);

Saves this chart instance to an xml file.

[Visual Basic] Overloads Public Sub SaveState(String)

[C#] public void SaveState(string);

Saves the chart instance to an xml file.

[Visual Basic] Overloads Public Sub SaveState(String,Chart)

[C#] public void SaveState(string,Chart);

See Also

Chart Class | Chart Members


Chart Class | Chart Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SaveState() Method

Saves this chart instance to an xml string.

[Visual Basic]
Overloads Public Function SaveState() As String
[C#]
public string SaveState();

Return Type

The xml string which represent the current chart object.

See Also

Chart Class | Chart Members | Overload List


SaveState(Chart) Method

Chart Class | Chart Members | Overload List

Language

Visual Basic

C#

Show All

chartObject
The chart object is being serialized.
See Also Languages dotnetCHARTING Send comments on this topic.

SaveState(Chart) Method

Saves the chart instance to an xml string.

[Visual Basic]
Overloads Public Function SaveState( _
   ByVal chartObject As Chart _
) As String
[C#]
public string SaveState(
   Chart chartObject
);

Parameters

chartObject
The chart object is being serialized.

Return Type

The xml string which represent the chart object.

See Also

Chart Class | Chart Members | Overload List


SaveState(String) Method

Chart Class | Chart Members | Overload List

Language

Visual Basic

C#

Show All

xmlFilePath
Path of XML file.
See Also Languages dotnetCHARTING Send comments on this topic.

SaveState(String) Method

Saves this chart instance to an xml file.

[Visual Basic]
Overloads Public Sub SaveState( _
   ByVal xmlFilePath As String _
)
[C#]
public void SaveState(
   string xmlFilePath
);

Parameters

xmlFilePath
Path of XML file.

Remarks

This first parameter takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.

Example

This examples demonstrate different ways of saving in the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.

[C#]

Chart.SaveState("c://inetpub/wwwroot/app/temp/chart.xml",chartObj);
Chart.SaveState("/app/temp/chart.xml",chartObj);
Chart.SaveState("chart.xml",chartObj);

[Visual Basic]

Chart.SaveState("c://inetpub/wwwroot/app/temp/chart.xml",chartObj)
Chart.SaveState("/app/temp/chart.xml",chartObj)
Chart.SaveState("chart.xml",chartObj)

See Also

Chart Class | Chart Members | Overload List


SaveState(String,Chart) Method

Chart Class | Chart Members | Overload List

Language

Visual Basic

C#

Show All

xmlFilePath
Path of the XML file.
chartObject
The chart object is being serialized.
See Also Languages dotnetCHARTING Send comments on this topic.

SaveState(String,Chart) Method

Saves the chart instance to an xml file.

[Visual Basic]
Overloads Public Sub SaveState( _
   ByVal xmlFilePath As String, _
   ByVal chartObject As Chart _
)
[C#]
public void SaveState(
   string xmlFilePath,
   Chart chartObject
);

Parameters

xmlFilePath
Path of the XML file.
chartObject
The chart object is being serialized.

Remarks

This first parameter takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.

Example

This examples demonstrate different ways of saving in the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.

[C#]

Chart.SaveState("c://inetpub/wwwroot/app/temp/chart.xml",chartObj);
Chart.SaveState("/app/temp/chart.xml",chartObj);
Chart.SaveState("chart.xml",chartObj);

[Visual Basic]

Chart.SaveState("c://inetpub/wwwroot/app/temp/chart.xml",chartObj)
Chart.SaveState("/app/temp/chart.xml",chartObj)
Chart.SaveState("chart.xml",chartObj)

See Also

Chart Class | Chart Members | Overload List


Chart Class Properties

Chart Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Chart Class Members

For a list of all members of this type, see Chart members.

Public Properties

Public Property AccessKey (Inherited from System.Web.UI.WebControls.WebControl)
Public Property AlternateText | Gets or sets text displayed in place of a chart when images can't be viewed. This property can also be used as a tooltip for the chart in browsers that support this feature.
Public Property Annotations | A collection of Annotation objects drawn on the chart.
Public Property Attributes (Inherited from System.Web.UI.WebControls.WebControl)
Public Property AutoNameLabels | Gets or sets a value which indicates whether elements and series are automatically named when no names are provided.
Public Property AxisCollection | Contains a collection of calculated Axis objects.
Public Property BackColor (Inherited from System.Web.UI.WebControls.WebControl)
Public Property Background | Gets or sets the Background of this chart.
Public Property BindingContainer (Inherited from System.Web.UI.Control)
Public Property BorderColor (Inherited from System.Web.UI.WebControls.WebControl)
Public Property BorderStyle (Inherited from System.Web.UI.WebControls.WebControl)
Public Property BorderWidth (Inherited from System.Web.UI.WebControls.WebControl)
Public Property CacheDuration | Gets or sets the number of minutes an image is cached and displayed on a page before a new one is generated.
Public Property CalculateEmptyElement | Gets or sets a value indicating whether the values of empty elements are percieved as 0 or omitted in calculations performed with the Chart.SeriesCollection.Add(Calculation calc) shortcut.
Public Property ChartArea | Gets or sets the main ChartArea of the image.
Public Property ChartAreaLayout | Gets or sets chart area layout options.
Public Property ChartAreaSpacing | Gets or sets a value in pixels that defines the spacing between boxes like chart areas and legends.
Public Property CleanupMinimumAge | Gets or sets the minimum number of minutes images are stored in the TempDirectory before they are deleted.
Public Property CleanupPeriod | Gets or sets the number of minutes images are stored in the TempDirectory folder before they are deleted.
Public Property ClientID (Inherited from System.Web.UI.Control)
Public Property ClipGauges | Gets or sets a value which determines if gauges should be clipped (cut) to display only the active area.
Public Property Controls (Inherited from System.Web.UI.Control)
Public Property ControlStyle (Inherited from System.Web.UI.WebControls.WebControl)
Public Property ControlStyleCreated (Inherited from System.Web.UI.WebControls.WebControl)
Public Property CssClass (Inherited from System.Web.UI.WebControls.WebControl)
Public Property DatabaseCultureName | Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.
Public Property DataGrid | Gets or sets the control ID of a datagrid control that will be populated with the charted data.
Public Property DataGridFormatString Gets or sets the format string which determines number formatting in the datagrid.

Public Property DataGridSeriesHeader | Gets or sets the header label of the DataGrid control specified by the DataGrid property.
Public Property DataGridTranspose | Gets or sets a value indicating whether the data with which the specified DataGrid control is populated will be transposed.
Public Property DateGrouping | Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Public Property DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property Debug | Gets or sets a value that indicates whether debug messages are displayed below the chart.
Public Property DefaultAxis | Gets or sets an Axis object whose properties will trickle down to all other axes on the chart unless otherwise specified.
Public Property DefaultBox | Gets a base box object that is used as a vehicle for property settings which will become the defaults settings of all elements on the chart that derive from box.
Public Property DefaultChartArea | Gets a ChartArea object whose property settings will propagate to all other ChartArea objects on the chart image.
Public Property DefaultCultureName | Gets or sets the default culture name which determines number and date formatting.
Public Property DefaultElement | Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.
Public Property DefaultFormatString Gets or sets the default format string which determines number and date formatting.

See Chart.DefaultAxis.FormatString.
Public Property DefaultLegendBox | Gets a LegendBox object whose property settings will propagate to all other LegendBox objects on the chart image.
Public Property DefaultSeries | Gets or sets a Series object whose properties will trickle to all other series on the chart unless otherwise specified.
Public Property DefaultShadow | Gets or sets a shadow object whose properties will trickle to all other objects with shadows.
Public Property DefaultTitleBox | Gets a Box object whose property settings will propagate to all title boxes on the chart image.
Public Property Depth | Gets or sets depth of the chart when Use3D is true.
Public Property DisableBrowserCache | Gets or sets a value indicating whether disable browser cache.
Public Property DonutHoleSize | Gets or sets a percentage value which determines the relative thickness of the donut ring when ChartType.Donut is used.
Public Property DrillDownChain Gets or sets the drill down chain which activates automatic time based drill down if date grouping used.

If Limit or SplitByLimit used with ShowOther option, setting drill down chain to "Other" or "OtherAll" activates automatic drill down to other elements or series.

"OtherAll" shows all other elements or series in the second level.
"Other" shows the next number of elements or series has been set in limit or splitByLimit propertes.

Public Property DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property EmptyElementText | Gets or sets the default text of empty element labels. See Chart.DefaultSeries.DefaultElement.SmartLabel
Public Property Enabled (Inherited from System.Web.UI.WebControls.WebControl)
Public Property EnableViewState (Inherited from System.Web.UI.Control)
Public Property ExplodedSliceAmount | Gets or sets the relative percentage an exploded slice should be pulled out from the pie or donut.
Public Property ExtraChartAreas | Gets a collection of additional ChartArea objects added to the chart.
Public Property ExtraLegendBoxes | Gets a collection of additional LegendBox objects added to the chart.
Public Property FileManager | Gets or sets the chart's instance of the FileManager which facilitates saving images.
Public Property FileName | See Chart.FileManager.FileName.
Public Property FileQuality | Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)
Public Property Font (Inherited from System.Web.UI.WebControls.WebControl)
Public Property ForeColor (Inherited from System.Web.UI.WebControls.WebControl)
Public Property GanttCompleteHatchStyle | Gets or sets the hatch style drawn on columns and cylinders when an element's Complete value is set.
Public Property HatchStylePalette | Gets or sets a hatch style palette that will trickle to all series on the chart. The hatch patterns will not show on chart elements if a hatch color is not specified. The default hatch color can be specified with the Chart.DefaultSeries.DefaultElement.HatchColor property.
Public Property HatchStylePaletteName | Gets or sets a predefined HatchStylePalette that defines element and series hatch style.
Public Property Height | Overridden. Gets or sets the height of the chart image.
Public Property Hotspot | Gets or sets the Hotspot property of the chart image.
Public Property ID (Inherited from System.Web.UI.Control)
Public Property ImageFormat | Gets or sets an ImageFormat enumeration specifying the generated image's file type.
Public Property ImageMapName | Returns a string for the image map name generated for the current chart image.
Public Property ImageMapText | Returns a string for the image map generated for the current chart image.
Public Property LegendBox | Gets or sets a LegendBox object that represents the legend box.
Public Property LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property Margin | Gets or sets a string which automatically sets multiple margins as a shortcut.
Public Property MarginBottom | Gets or sets the bottom margin of the chart image.
Public Property MarginLeft | Gets or sets the left margin of the chart image.
Public Property MarginRight | Gets or sets the right margin of the chart image.
Public Property MarginTop | Gets or sets the top margin of the chart image.
Public Property MaximumBubbleSize | Gets or sets a value which controls the maximum size of bubbles when ChartType.Bubble is used.
Public Property Mentor | Gets or sets a value that indicates whether the mentor is shown under the chart control. The mentor also requires that Chart.Debug is set to true.
Public Property NamingContainer (Inherited from System.Web.UI.Control)
Public Property NoDataLabel | Gets or sets a label shown on the chart when no data is available.
Public Property OverlapFooter | Gets or sets a value indicating whether the 'unlicensed chart' footer overlaps the chart or moves it up.
Public Property Page (Inherited from System.Web.UI.Control)
Public Property Palette | Gets or sets an array of colors that define element and series colors.
Public Property PaletteName | Gets or sets a predefined Palette that defines element and series colors.
Public Property Parent (Inherited from System.Web.UI.Control)
Public Property PieLabelMode | See DefaultSeries.DefaultElement.SmartLabel.PieLabelMode.
Public Property PopulateDateGroupingSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to !:SubValues or not. By default, such values are not added to the element subvalues.
Public Property PrinterOptimizedText | Gets or sets a value that indicates whether text rendered on the chart optimized for printing.
Public Property RadarLabelMode | See DefaultSeries.DefaultElement.SmartLabel.RadarLabelMode.
Public Property ReloadPeriod | Gets or sets a TimeSpan object that determines how often the page containing this chart will automatically reload.
Public Property Series | Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.
Public Property SeriesCollection | Gets a SeriesCollection object which represents the data this chart will render.
Public Property ShadingEffect | See ShadingEffectMode.
Public Property ShadingEffectMode | Gets or sets a ShadingEffectMode enumeration indicating how elements on the chart are shaded.
Public Property ShowDateInTitle | Gets or sets a value which indicates whether specified dates are shown in the title.
Public Property Site (Inherited from System.Web.UI.Control)
Public Property Size | Sets a string that automatically sets the Height and Width of the chart image.
Public Property SmartLabelLine | See Chart.DefaultSeries.DefaultElement.SmartLabel.Line.
Public Property SmartPalette | Gets or sets a NameColorCollection object that specifies the colors of elements and series with specific names.
Public Property SmartPaletteAutoSync | Gets or sets a boolean which controls smart palette synchronization.
Public Property StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property StartDayOfWeek | Gets or sets a DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.
Public Property Style (Inherited from System.Web.UI.WebControls.WebControl)
Public Property TabIndex (Inherited from System.Web.UI.WebControls.WebControl)
Public Property TempDirectory | Gets or sets the directory where images generated by the control are temporarily stored.
Public Property TemplateSourceDirectory (Inherited from System.Web.UI.Control)
Public Property Title Gets or sets the chart title.

Equivalent to Chart.TitleBox.Label.Text.
Public Property TitleBox | Gets or sets a Box object that represents the title box.
Public Property ToolTip | Overridden. Gets or sets the Tooltip of the entinre chart image.
Public Property TotalSeries | Return the total number of series in the seriesCollection. This property usually used in conjunction with SplitByLimit.
Public Property Transpose | Gets or sets a value indicating whether data added to this chart's SeriesCollection property is automatically transposed.
Public Property Type | Gets or sets the ChartType of this Chart.
Public Property UniqueID (Inherited from System.Web.UI.Control)
Public Property URL | Gets or sets the URL of the entinre chart image.
Public Property URLTarget | Gets or sets the target of the URL link.
Public Property Use3D | Gets or sets a value indicating whether chart elements are rendered in 3D.
Public Property UseFile | Gets or sets a value indicating whether the generated image is saved as a file in the TempDirectory folder or streamed directly to the browser.
Public Property Visible (Inherited from System.Web.UI.Control)
Public Property Width | Overridden. Gets or sets the width of the chart image.
Public Property XAxis | Gets or Sets the main XAxis which all series inherit by default.
Public Property YAxis | Gets or Sets the main YAxis which all series inherit by default.

See Also

Chart Class | dotnetCHARTING Namespace


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AlternateText Property

Gets or sets text displayed in place of a chart when images can't be viewed. This property can also be used as a tooltip for the chart in browsers that support this feature.

[Visual Basic]
Public Property AlternateText As String
[C#]
public string AlternateText {get; set;}

Example

[C#]

Chart.AlternateText = "The image can't be displayed.";

[Visual Basic]

Chart.AlternateText = "The image can't be displayed."

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Annotations Property

A collection of Annotation objects drawn on the chart.

[Visual Basic]
Public ReadOnly Property Annotations As AnnotationCollection
[C#]
public AnnotationCollection Annotations {get;}

Example

The following code snippet demonstrates how an annotation is added to the chart.

[C#]

Annotation a2 = new Annotation("Annotation text.");

//set the position
a2.Position = new Point(60,40);

// We'll add a link so when this text is clicked it takes us to a web site.
a2.URL = "http://www.dotnetcharting.com";

// Make sure the annotation doesn't create a rectangle for the text and wrap it.
a2.DynamicSize = false;

// In order for the annotation not to draw the background, outline and so
// on... We'll use a shortcut to clear the colors.
a2.ClearColors();

// Add the annotation to a chart.
Chart.Annotations.Add(a2);

[Visual Basic]

Dim a2 As Annotation = new Annotation("Annotation text.")

'set the position
a2.Position = new Point(60,40)

'We'll add a link so when this text is clicked it takes us to a web site.
a2.URL = "http://www.dotnetcharting.com"

' Make sure the annotation doesn't create a rectangle for the text and wrap it.
a2.DynamicSize = false

'In order for the annotation not to draw the background, outline and so
'on... We'll use a shortcut to clear the colors.
a2.ClearColors()

'Add the annotation to a chart.
Chart.Annotations.Add(a2)

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AutoNameLabels Property

Gets or sets a value which indicates whether elements and series are automatically named when no names are provided.

[Visual Basic]
Public Property AutoNameLabels As Boolean
[C#]
public bool AutoNameLabels {get; set;}

Example

[C#]

Chart.AutoNameLabels = true;

[Visual Basic]

Chart.AutoNameLabels = true

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisCollection Property

Contains a collection of calculated Axis objects.

[Visual Basic]
Public ReadOnly Property AxisCollection As AxisCollection
[C#]
public AxisCollection AxisCollection {get;}

Remarks

Axes added to this collection must be calculated from axes on the chart, otherwise they are ignored.

Example

[C#]

//Using the built in axis calculation to convert units and add Fahrenheit temperature axis.
Axis F=Chart.YAxis.Calculate("Fahrenheit", Temperature.Celsius,Temperature.Fahrenheit);
F.Orientation = Orientation.Right;
Chart.AxisCollection.Add(F);

//For complete code see UnitConversion.aspx sample.

[Visual Basic]

'Using the built in axis calculation to convert units and add Fahrenheit temperature axis.
Dim F As Axis
F=Chart.YAxis.Calculate("Fahrenheit", Temperature.Celsius,Temperature.Fahrenheit)
F.Orientation = Orientation.Right
Chart.AxisCollection.Add(F)

'For complete code see UnitConversion.aspx sample.

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Background Property

Gets or sets the Background of this chart.

[Visual Basic]
Public Property Background As Background
[C#]
public Background Background {get; set;}

Example

[C#]

Chart.Background = new Background(Color.Ivory);

[Visual Basic]

Chart.Background = new Background(Color.Ivory)

See Also

Chart Class | Chart Members


Chart Class | Chart Members | CachePeriod Property | CachePeriod Property | CachePeriod Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CacheDuration Property

Gets or sets the number of minutes an image is cached and displayed on a page before a new one is generated.

[Visual Basic]
Public Property CacheDuration As Integer
[C#]
public int CacheDuration {get; set;}

Remarks

When set, a given chart image will be generated on the first hit and on all subsequent hits within the cache duration period the same image will be returned with no rendering work by the chart control.

Example

[C#]

//Used the already generated image for upto 45 minutes.
Chart.CacheDuration = 45;

[Visual Basic]

'Used the already generated image for upto 45 minutes.
Chart.CacheDuration = 45

See Also

Chart Class | Chart Members | CachePeriod Property | CachePeriod Property | CachePeriod Property


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CalculateEmptyElement Property

Gets or sets a value indicating whether the values of empty elements are percieved as 0 or omitted in calculations performed with the Chart.SeriesCollection.Add(Calculation calc) shortcut.

[Visual Basic]
Public Property CalculateEmptyElement As Boolean
[C#]
public bool CalculateEmptyElement {get; set;}

Remarks

If this property is set to false, in all calculations (average,min,median,mode etc.) only the applicable elements are counted. If set to true, such elements are given 0 values and included in the calculation. This case occurs when you have multiple series and are calculating derived series from them. Defaults to true.

Example

[C#]

Chart.CalculateEmptyElement = true;

[Visual Basic]

Chart.CalculateEmptyElement = true

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChartArea Property

Gets or sets the main ChartArea of the image.

[Visual Basic]
Public Property ChartArea As ChartArea
[C#]
public ChartArea ChartArea {get; set;}

Example

[C#]

ChartArea chartAreaObj= new ChartArea();
 chartAreaObj.Background.Color = Color.LightBlue;
 chartAreaObj.Line.Color=Color.Yellow;
 chartAreaObj.InteriorLine.Color=Color.Blue;
 chartAreaObj.Label.Text="Customized chart area";
 Chart.ChartArea = chartAreaObj;

[Visual Basic]

Dim chartAreaObj As ChartArea = new ChartArea()
chartAreaObj.Background.Color = Color.LightBlue
chartAreaObj.Line.Color=Color.Yellow
chartAreaObj.InteriorLine.Color=Color.Blue
chartAreaObj.Label.Text="Customized chart area"
Chart.ChartArea = chartAreaObj

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChartAreaLayout Property

Gets or sets chart area layout options.

[Visual Basic]
Public ReadOnly Property ChartAreaLayout As ChartAreaLayout
[C#]
public ChartAreaLayout ChartAreaLayout {get;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChartAreaSpacing Property

Gets or sets a value in pixels that defines the spacing between boxes like chart areas and legends.

[Visual Basic]
Public Property ChartAreaSpacing As Integer
[C#]
public int ChartAreaSpacing {get; set;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CleanupMinimumAge Property

Gets or sets the minimum number of minutes images are stored in the TempDirectory before they are deleted.

[Visual Basic]
Public Property CleanupMinimumAge As Integer
[C#]
public int CleanupMinimumAge {get; set;}

Remarks

When .netCHARTING renders a chart a temporary file is created in the directory set by the TempDirectory property. The CleanupMinimumAge ensures that only files older than this age, in minutes, will be deleted.

Example

[C#]

//delete all temp files older than 10 minutes
Chart.CleanupMinimumAge = 10;

[Visual Basic]

'delete all temp files older than 10 minutes
Chart.CleanupMinimumAge = 10

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CleanupPeriod Property

Gets or sets the number of minutes images are stored in the TempDirectory folder before they are deleted.

[Visual Basic]
Public Property CleanupPeriod As Integer
[C#]
public int CleanupPeriod {get; set;}

Remarks

When .netCHARTING renders a chart a temporary file is created in the directory set by the TempDirectory property. The CleanUpPeriod property determines how frequently (in minutes) this directory is cleaned by deleting old temporary files. The default is 15 minutes and the property can be set to 0 in order to disable the cleanup in which case temp files are not automatically deleted.

Any files that start with 'dnc-' will be deleted in the temp directory.

Example

[C#]

//delete old files every 30 minutes
Chart.CleanupPeriod = 30;

[Visual Basic]

'delete old files every 30 minutes
Chart.CleanupPeriod = 30

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ClipGauges Property

Gets or sets a value which determines if gauges should be clipped (cut) to display only the active area.

[Visual Basic]
Public Property ClipGauges As Boolean
[C#]
public bool ClipGauges {get; set;}

Example

[C#]

Chart.ClipGauges = false;

[Visual Basic]

Chart.ClipGauges = false

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DatabaseCultureName Property

Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.

[Visual Basic]
Public Property DatabaseCultureName As String
[C#]
public string DatabaseCultureName {get; set;}

Remarks

See the CultureInfo class for possible names of a culture.

Example

[C#]

Chart.DataBaseCultureName = "en-GB";

[Visual Basic]

Chart.DataBaseCultureName = "en-GB"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataGrid Property

Gets or sets the control ID of a datagrid control that will be populated with the charted data.

[Visual Basic]
Public Property DataGrid As String
[C#]
public string DataGrid {get; set;}

Remarks

This property accepts a control ID for a datagrid. If set, the data represented in the chart is populated in the datagrid of the same name. You must also define a datagrid control with an appropriately named ID within the same script. This property is useful when displaying tabular chart data along with your charts.

Example

[C#]

Chart.DataGrid = "myChartData";

[Visual Basic]

Chart.DataGrid = "myChartData"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataGridFormatString Property

Gets or sets the format string which determines number formatting in the datagrid.

[Visual Basic]
Public Property DataGridFormatString As String
[C#]
public string DataGridFormatString {get; set;}

Remarks

See 'Formatting Types' in your msdn documentation for a complete list of options.

Some shortcuts are also provided for specific settings including "C" or "currency" , "E" or "scientific" , "F" or "fixed" , "G" or "general" and "N,2" for normal and the number after the comma determines the number of decimal places.

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataGridSeriesHeader Property

Gets or sets the header label of the DataGrid control specified by the DataGrid property.

[Visual Basic]
Public Property DataGridSeriesHeader As String
[C#]
public string DataGridSeriesHeader {get; set;}

Remarks

This property controls the header label used for the datagrid series name column. If set to "none" the series name column will be removed. If set to "%XAxisLabel", xAxis label set as the header label of the datagrid.

Example

[C#]

Chart.DataGridSeriesHeader = "Sales for 2003";

[Visual Basic]

Chart.DataGridSeriesHeader = "Sales for 2003"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataGridTranspose Property

Gets or sets a value indicating whether the data with which the specified DataGrid control is populated will be transposed.

[Visual Basic]
Public Property DataGridTranspose As Boolean
[C#]
public bool DataGridTranspose {get; set;}

Example

[C#]

Chart.DataGridTranspose = true;

[Visual Basic]

Chart.DataGridTranspose = true

See Also

Chart Class | Chart Members


Chart Class | Chart Members | DateGrouping Property | DateGrouping Property | DateGrouping Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DateGrouping Property

Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.

[Visual Basic]
Public Property DateGrouping As TimeInterval
[C#]
public TimeInterval DateGrouping {get; set;}

Remarks

Controls how the values of a given series are grouped by date. In order to use this option the first column returned by the SqlStatement must be a date/time. Options include Minutes, Hours, Days, Weeks, Months, Quarters and Years where any StartDate and EndDate can be used and the chart will show all values sequentially. There are additional options for Hour/Minute, Day/Hour, Week/Day, Month/Day, Year/Quarter and Year/Month in these cases there are 2 special considerations 1) only a single day / week / month / or year is charted and 2) if the date range is greater than the period type (e.g. 1 day / 1 week / 1 month / 1 year) values are totalled over that period. There are also shortcuts for the grouping cases of Hour (Hours/Minute), Day (Day/Hour), Week(Week/Day), Month (Month/Day) and Year (Year/Month). See all time interval options. This feature automatically groups multiple data points over a given date range into the specific date grouping you select. When DateGrouping is enabled you must ensure that each series within a given chart returns date/time data for the first column returned by the SqlStatement.

Example

[C#]

Chart.DateGrouping = TimeInterval.Days;

[Visual Basic]

Chart.DateGrouping = TimeInterval.Days

See Also

Chart Class | Chart Members | DateGrouping Property | DateGrouping Property | DateGrouping Property


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DateGroupingCalculation Property

Gets or sets an enum which determines how values are grouped to create a single element value.

[Visual Basic]
Public Property DateGroupingCalculation As Calculation
[C#]
public Calculation DateGroupingCalculation {get; set;}

Remarks

When dategrouping is used, if an element has more than one value, a Calculation is performed on those values.

Example

[C#]

Chart.DateGroupingCalculation = Calculation.Average;

[Visual Basic]

Chart.DateGroupingCalculation = Calculation.Average

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DateGroupingSort Property

Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.

[Visual Basic]
Public Property DateGroupingSort As Boolean
[C#]
public bool DateGroupingSort {get; set;}

Remarks

When dategrouping is used and StartDate or EndDate is not set, the data is sorted by the xAxis field by default. Setting this property to true will maintain the sort order of the data as it is provided.

Example

[C#]

Chart.DateGroupingSort = true;

[Visual Basic]

Chart.DateGroupingSort = true

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Debug Property

Gets or sets a value that indicates whether debug messages are displayed below the chart.

[Visual Basic]
Public Property Debug As Boolean
[C#]
public bool Debug {get; set;}

Remarks

This property controls if error text is returned below the generated image if a problem occurs. This is typically used for debug purposes when initially developing charts. This is provided as a property so that your end users are not exposed to developer level errors. This property defaults to false

Example

[C#]

Chart.Debug = true;

[Visual Basic]

Chart.Debug = true

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultAxis Property

Gets or sets an Axis object whose properties will trickle down to all other axes on the chart unless otherwise specified.

[Visual Basic]
Public Property DefaultAxis As Axis
[C#]
public Axis DefaultAxis {get; set;}

Example

[C#]

Axis AxisObj = new Axis();
 AxisObj.Line.Color = Color.Yellow;
 AxisObj.Line.Width = 3;
 Chart.DefaultAxis = AxisObj;

[Visual Basic]

Dim AxisObj As Axis = new Axis()
AxisObj.Line.Color = Color.Yellow
AxisObj.Line.Width = 3
Chart.DefaultAxis = AxisObj

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultBox Property

Gets a base box object that is used as a vehicle for property settings which will become the defaults settings of all elements on the chart that derive from box.

[Visual Basic]
Public ReadOnly Property DefaultBox As Box
[C#]
public Box DefaultBox {get;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultChartArea Property

Gets a ChartArea object whose property settings will propagate to all other ChartArea objects on the chart image.

[Visual Basic]
Public ReadOnly Property DefaultChartArea As ChartArea
[C#]
public ChartArea DefaultChartArea {get;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultCultureName Property

Gets or sets the default culture name which determines number and date formatting.

[Visual Basic]
Public Property DefaultCultureName As String
[C#]
public string DefaultCultureName {get; set;}

Remarks

Equivalent to Chart.DefaultAxis.CultureName. See the CultureInfo class for possible names of a culture.

Example

[C#]

Chart.DefaultCultureName = "en-GB";

[Visual Basic]

Chart.DefaultCultureName = "en-GB"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultElement Property

Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.

[Visual Basic]
Public Property DefaultElement As Element
[C#]
public Element DefaultElement {get; set;}

Example

[C#]

Chart.DefaultElement.SmartLabel.Text = "%Name";

[Visual Basic]

Chart.DefaultElement.SmartLabel.Text = "%Name"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultFormatString Property

Gets or sets the default format string which determines number and date formatting.

See Chart.DefaultAxis.FormatString.

[Visual Basic]
Public Property DefaultFormatString As String
[C#]
public string DefaultFormatString {get; set;}

Remarks

Equivalent to Chart.DefaultAxis.FormatString.

See 'Formatting Types' in your msdn documentation for a complete list of options.

Some shortcuts are also provided for specific settings including "C" or "currency" , "E" or "scientific" , "F" or "fixed" , "G" or "general" and "N,2" for normal and the number after the comma determines the number of decimal places.

Example

[C#]

Chart.DefaultFormatString = "n,2";
Chart.DefaultFormatString = "MM";

[Visual Basic]

Chart.DefaultFormatString = "n,2"
Chart.DefaultFormatString = "MM"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultLegendBox Property

Gets a LegendBox object whose property settings will propagate to all other LegendBox objects on the chart image.

[Visual Basic]
Public ReadOnly Property DefaultLegendBox As LegendBox
[C#]
public LegendBox DefaultLegendBox {get;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultSeries Property

Gets or sets a Series object whose properties will trickle to all other series on the chart unless otherwise specified.

[Visual Basic]
Public Property DefaultSeries As Series
[C#]
public Series DefaultSeries {get; set;}

Example

[C#]

Chart.DefaultSeries.Type = SeriesType.AreaLine;

[Visual Basic]

Chart.DefaultSeries.Type = SeriesType.AreaLine

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultShadow Property

Gets or sets a shadow object whose properties will trickle to all other objects with shadows.

[Visual Basic]
Public Property DefaultShadow As Shadow
[C#]
public Shadow DefaultShadow {get; set;}

Example

[C#]

Shadow shadowObj = new Shadow();
shadowObj.Color = Color.Blue;
shadowObj.Depth = 5;
shadowObj.Soft =true;
Chart.DefaultShadow = shadowObj;

[Visual Basic]

Dim shadowObj As Shadow = new Shadow()
shadowObj.Color = Color.Blue
shadowObj.Depth = 5
shadowObj.Soft =true
Chart.DefaultShadow = shadowObj

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultTitleBox Property

Gets a Box object whose property settings will propagate to all title boxes on the chart image.

[Visual Basic]
Public ReadOnly Property DefaultTitleBox As Box
[C#]
public Box DefaultTitleBox {get;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Depth Property

Gets or sets depth of the chart when Use3D is true.

[Visual Basic]
Public Property Depth As Unit
[C#]
public Unit Depth {get; set;}

Example

[C#]

Chart.Depth = 12;

[Visual Basic]

Chart.Depth = Unit.Parse(12)

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DisableBrowserCache Property

Gets or sets a value indicating whether disable browser cache.

[Visual Basic]
Public Property DisableBrowserCache As Boolean
[C#]
public bool DisableBrowserCache {get; set;}

Example

[C#]

Chart.DisableBrowserCache = true;

[Visual Basic]

Chart.DisableBrowserCache = true

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DonutHoleSize Property

Gets or sets a percentage value which determines the relative thickness of the donut ring when ChartType.Donut is used.

[Visual Basic]
Public Property DonutHoleSize As Double
[C#]
public double DonutHoleSize {get; set;}

Example

[C#]

Chart.DonutHoleSize = 60;

[Visual Basic]

Chart.DonutHoleSize = 60

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DrillDownChain Property

Gets or sets the drill down chain which activates automatic time based drill down if date grouping used.

If Limit or SplitByLimit used with ShowOther option, setting drill down chain to "Other" or "OtherAll" activates automatic drill down to other elements or series.

"OtherAll" shows all other elements or series in the second level.
"Other" shows the next number of elements or series has been set in limit or splitByLimit propertes.

[Visual Basic]
Public Property DrillDownChain As String
[C#]
public string DrillDownChain {get; set;}

Remarks

When using automated drill down with DateGrouping, this property controls the drill down chain, or hierarchy, that is followed. In addition you can override names to be displayed for the different drill down levels.

Example

This samples demonstrate drill down with dategrouping.

For complete drill down samples see Features/Drilldown samples.

[C#]

Chart.DrillDownChain = "Year,Month,Day";
Chart.DrillDownChain = "Year=Current Year,Month=My Month,Day=One day";

[Visual Basic]

Chart.DrillDownChain = "Year,Month,Day"
Chart.DrillDownChain = "Year=Current Year,Month=My Month,Day=One day"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DrillDownIntoSeries Property

When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.

[Visual Basic]
Public Property DrillDownIntoSeries As Boolean
[C#]
public bool DrillDownIntoSeries {get; set;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

EmptyElementText Property

Gets or sets the default text of empty element labels. See Chart.DefaultSeries.DefaultElement.SmartLabel

[Visual Basic]
Public Property EmptyElementText As String
[C#]
public string EmptyElementText {get; set;}

Example

[C#]

Chart.EmptyElementText = "N/A";

[Visual Basic]

Chart.EmptyElementText = "N/A"

See Also

Chart Class | Chart Members


Chart Class | Chart Members | ExplodeSlice

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ExplodedSliceAmount Property

Gets or sets the relative percentage an exploded slice should be pulled out from the pie or donut.

[Visual Basic]
Public Property ExplodedSliceAmount As Double
[C#]
public double ExplodedSliceAmount {get; set;}

Example

[C#]

Chart.ExplodedSliceAmount = 30;

[Visual Basic]

Chart.ExplodedSliceAmount = 30

See Also

Chart Class | Chart Members | ExplodeSlice


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ExtraChartAreas Property

Gets a collection of additional ChartArea objects added to the chart.

[Visual Basic]
Public ReadOnly Property ExtraChartAreas As ChartAreaCollection
[C#]
public ChartAreaCollection ExtraChartAreas {get;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ExtraLegendBoxes Property

Gets a collection of additional LegendBox objects added to the chart.

[Visual Basic]
Public ReadOnly Property ExtraLegendBoxes As LegendBoxCollection
[C#]
public LegendBoxCollection ExtraLegendBoxes {get;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FileManager Property

Gets or sets the chart's instance of the FileManager which facilitates saving images.

[Visual Basic]
Public Property FileManager As FileManager
[C#]
public FileManager FileManager {get; set;}

Example

[C#]

//Get the bitmap and add a line to the image
Bitmap bmp = Chart.GetChartBitmap();
Graphics g = Graphics.FromImage(bmp);
g.DrawLine(Pens.Red,36,150,480,150);
g.DrawString("This is my line",new Font("Arial",12,FontStyle.Bold),new SolidBrush(Color.Black),new Point(40,150));
g.Dispose();

//Save the image and set the image path to ImageUrl.
string ImagePath = Chart.FileManager.SaveImage(bmp);
Image1.ImageUrl = ImagePath;

[Visual Basic]

'Get the bitmap and add a line to the image
Dim bmp As Bitmap = Chart.GetChartBitmap()
Dim g As Graphics = Graphics.FromImage(bmp)
g.DrawLine(Pens.Red, 36, 150, 480, 150)
g.DrawString("This is my line", new Font("Arial", 12, FontStyle.Bold), new SolidBrush(Color.Black), new PointF(40F, 150F))
g.Dispose()

'Save the image and set the image path to ImageUrl.
Dim ImagePath As String = Chart.FileManager.SaveImage(bmp)
Image1.ImageUrl = ImagePath

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FileName Property

See Chart.FileManager.FileName.

[Visual Basic]
Public Property FileName As String
[C#]
public string FileName {get; set;}

Example

[C#]

Chart.FileName = "sales1";

//With default image format, the generated file will be "sales1.png"

[Visual Basic]

Chart.FileName = "sales1"

'With default image format, the generated file will be "sales1.png"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FileQuality Property

Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)

[Visual Basic]
Public Property FileQuality As Long
[C#]
public long FileQuality {get; set;}

Example

[C#]

Chart.FileQuality = 95;

[Visual Basic]

Chart.FileQuality = 95

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GanttCompleteHatchStyle Property

Gets or sets the hatch style drawn on columns and cylinders when an element's Complete value is set.

[Visual Basic]
Public Property GanttCompleteHatchStyle As HatchStyle
[C#]
public HatchStyle GanttCompleteHatchStyle {get; set;}

Remarks

Typically used with Gantt charts to indicate what percentage of a task has been completed.

Example

[C#]

//Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
Chart.GanttCompleteHatchStyle = HatchStyle.DiagonalCross;

[Visual Basic]

'Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
Chart.GanttCompleteHatchStyle = HatchStyle.DiagonalCross

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HatchStylePalette Property

Gets or sets a hatch style palette that will trickle to all series on the chart. The hatch patterns will not show on chart elements if a hatch color is not specified. The default hatch color can be specified with the Chart.DefaultSeries.DefaultElement.HatchColor property.

[Visual Basic]
Public Property HatchStylePalette As HatchStyle()
[C#]
public HatchStyle[] HatchStylePalette {get; set;}

Remarks

For a complete list of hatch styles see HatchStyle enumeration.

Example

[C#]

Chart.HatchStylePalette = new HatchStylePalette [] {HatchStyle.Cross,HatchStyle.Divot,HatchStyle.Horizontal};

[Visual Basic]

Chart.HatchStylePalette = New HatchStylePalette [] {HatchStyle.Cross,HatchStyle.Divot,HatchStyle.Horizontal}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HatchStylePaletteName Property

Gets or sets a predefined HatchStylePalette that defines element and series hatch style.

[Visual Basic]
Public Property HatchStylePaletteName As HatchStylePalette
[C#]
public HatchStylePalette HatchStylePaletteName {get; set;}

Example

[C#]

Chart.PaletteName = dotnetCHARTING.HatchStylePalette.One;

[Visual Basic]

Chart.PaletteName = dotnetCHARTING.HatchStylePalette.One

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Height Property

Gets or sets the height of the chart image.

[Visual Basic]
Overrides Public Property Height As Unit
[C#]
public override Unit Height {get; set;}

Example

[C#]

Chart.Height = 350;

[Visual Basic]

Chart.Height = Unit.Parse(350)

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hotspot Property

Gets or sets the Hotspot property of the chart image.

[Visual Basic]
Public Property Hotspot As Hotspot
[C#]
public Hotspot Hotspot {get; set;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ImageFormat Property

Gets or sets an ImageFormat enumeration specifying the generated image's file type.

[Visual Basic]
Public Property ImageFormat As ImageFormat
[C#]
public ImageFormat ImageFormat {get; set;}

Example

[C#]

Chart.ImageFormat = ImageFormat.Jpg;

[Visual Basic]

Chart.ImageFormat = ImageFormat.Jpg

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ImageMapName Property

Returns a string for the image map name generated for the current chart image.

[Visual Basic]
Public ReadOnly Property ImageMapName As String
[C#]
public string ImageMapName {get;}

Example

[C#]

ImageMapLabel.Text = Chart.ImageMapName; //read only

[Visual Basic]

ImageMapLabel.Text = Chart.ImageMapName //read only

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ImageMapText Property

Returns a string for the image map generated for the current chart image.

[Visual Basic]
Public ReadOnly Property ImageMapText As String
[C#]
public string ImageMapText {get;}

Example

[C#]

ImageMapLabel.Text = Chart.ImageMapText //read only

[Visual Basic]

ImageMapLabel.Text = Chart.ImageMapText //read only

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendBox Property

Gets or sets a LegendBox object that represents the legend box.

[Visual Basic]
Public Property LegendBox As LegendBox
[C#]
public LegendBox LegendBox {get; set;}

Remarks

Notes

- To hide the legend box use Chart.LegendBox.Position = LegendBoxPosition.None.

- When Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend is set the legend box will disappear.

Example

[C#]

Chart.LegendBox.Background = new Background(System.Drawing.Color.SkyBlue);
Chart.LegendBox.CornerBottomLeft = BoxCorner.Square;
Chart.LegendBox.CornerBottomRight = BoxCorner.Square;
Chart.LegendBox.CornerTopLeft = BoxCorner.Square;
Chart.LegendBox.CornerTopRight = BoxCorner.Cut;
Chart.LegendBox.IconPath="icon.gif";
Chart.LegendBox.Label =  new dotnetCHARTING.Label("",new Font("Arial",10),Color.DarkSlateBlue);
Chart.LegendBox.Line = new Line(Color.Blue);
Chart.LegendBox.Position = LegendBoxPosition.Top;

//For complete code, see LegendBox.aspx sample

[Visual Basic]

Chart.LegendBox.Background = new Background(System.Drawing.Color.SkyBlue)
Chart.LegendBox.CornerBottomLeft = BoxCorner.Square
Chart.LegendBox.CornerBottomRight = BoxCorner.Square
Chart.LegendBox.CornerTopLeft = BoxCorner.Square
Chart.LegendBox.CornerTopRight = BoxCorner.Cut
Chart.LegendBox.IconPath="icon.gif"
Chart.LegendBox.Label = new dotnetCHARTING.Label("",new Font("Arial",10),Color.DarkSlateBlue)
Chart.LegendBox.Line = new Line(Color.Blue)
Chart.LegendBox.Position = LegendBoxPosition.Top

'For complete code, see LegendBox.aspx sample

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LimitPrimarySeries Property

In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.

[Visual Basic]
Public Property LimitPrimarySeries As String
[C#]
public string LimitPrimarySeries {get; set;}

See Also

Chart Class | Chart Members


Margin Property

Chart Class | Chart Members

Language

Visual Basic

C#

Show All

value
See Also Languages dotnetCHARTING Send comments on this topic.

Margin Property

Gets or sets a string which automatically sets multiple margins as a shortcut.

[Visual Basic]
Public WriteOnly Property Margin( _
   ByVal value As String _
)
[C#]
public void Margin(
   string value
); {set;}

Parameters

value

Remarks

Controls the margins or amount of space in pixels that will be left around the charting elements including the Legend and title box. This property can be used in conjunction with the Chart.Background property to easily implement attractive custom borders or just pad the chart as you please. The property accepts margins "Left, Top, Right, Bottom" in pixels.

Example

[C#]

Chart.Margin = "10"; //set all 4 Margins to 10
Chart.Margin = "10,20"; // set MarginLeft and MarginRight to 10 and MarginTop and Bottom to 20
Chart.Margin = "5,10,15"; // set MarginLeft to 5, MarginTop to 10 and MarginRight to 15
Chart.Margin = "5,10,15,20"; // set MarginLeft to 5, MarginTop to 10, MarginRight to 15 and MarginBottom to 20

[Visual Basic]

Chart.Margin = "10" 'set all 4 Margins to 10
Chart.Margin = "10,20" 'set MarginLeft and MarginRight to 10 and MarginTop and Bottom to 20
Chart.Margin = "5,10,15" 'set MarginLeft to 5, MarginTop to 10 and MarginRight to 15
Chart.Margin = "5,10,15,20" 'set MarginLeft to 5, MarginTop to 10, MarginRight to 15 and MarginBottom to 20

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MarginBottom Property

Gets or sets the bottom margin of the chart image.

[Visual Basic]
Public Property MarginBottom As Integer
[C#]
public int MarginBottom {get; set;}

Example

[C#]

Chart.MarginBottom = 20;

[Visual Basic]

Chart.MarginBottom = 20

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MarginLeft Property

Gets or sets the left margin of the chart image.

[Visual Basic]
Public Property MarginLeft As Integer
[C#]
public int MarginLeft {get; set;}

Example

[C#]

Chart.MarginLeft = 20;

[Visual Basic]

Chart.MarginLeft = 20

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MarginRight Property

Gets or sets the right margin of the chart image.

[Visual Basic]
Public Property MarginRight As Integer
[C#]
public int MarginRight {get; set;}

Example

[C#]

Chart.MarginRight = 20;

[Visual Basic]

Chart.MarginRight = 20

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MarginTop Property

Gets or sets the top margin of the chart image.

[Visual Basic]
Public Property MarginTop As Integer
[C#]
public int MarginTop {get; set;}

Example

[C#]

Chart.MarginTop = 20;

[Visual Basic]

Chart.MarginTop = 20

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MaximumBubbleSize Property

Gets or sets a value which controls the maximum size of bubbles when ChartType.Bubble is used.

[Visual Basic]
Public Property MaximumBubbleSize As Integer
[C#]
public int MaximumBubbleSize {get; set;}

Remarks

When not set, the maximum size is determined dynamically.

Example

[C#]

Chart.MaximumBubbleSize = 120;

[Visual Basic]

Chart.MaximumBubbleSize = 120

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Mentor Property

Gets or sets a value that indicates whether the mentor is shown under the chart control. The mentor also requires that Chart.Debug is set to true.

[Visual Basic]
Public Property Mentor As Boolean
[C#]
public bool Mentor {get; set;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

NoDataLabel Property

Gets or sets a label shown on the chart when no data is available.

[Visual Basic]
Public Property NoDataLabel As Label
[C#]
public Label NoDataLabel {get; set;}

Example

[C#]

Chart.NoDataLabel.Text = "No Data Text";
Chart.NoDataLabel.Color = Color.Red;

[Visual Basic]

Chart.NoDataLabel.Text = "No Data Text"
Chart.NoDataLabel.Color = Color.Red

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

OverlapFooter Property

Gets or sets a value indicating whether the 'unlicensed chart' footer overlaps the chart or moves it up.

[Visual Basic]
Public Property OverlapFooter As Boolean
[C#]
public bool OverlapFooter {get; set;}

Remarks

If set to false, the rendered chart will exactly match that of a production licensed chart (which does not have the footer or branding in the top right). If set to true, the chart will be resized slightly so that the footer does not overlap the chart. In all cases the final rendered image will be exactly what you set for Chart.Size or Chart.Height and Chart.Width.

Example

[C#]

Chart.OverlapFooter = true;

[Visual Basic]

Chart.OverlapFooter = true

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Palette Property

Gets or sets an array of colors that define element and series colors.

[Visual Basic]
Public Property Palette As Color()
[C#]
public Color[] Palette {get; set;}

Example

[C#]

Color[] MyColorObjectArray = new Color[3]{Color.Red,Color.Blue,Color.Yellow};
Chart.Palette = MyColorObjectArray;

[Visual Basic]

Dim MyColorObjectArray() As Color = {Color.Red,Color.Blue,Color.Yellow}
Chart.Palette = MyColorObjectArray

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PaletteName Property

Gets or sets a predefined Palette that defines element and series colors.

[Visual Basic]
Public Property PaletteName As Palette
[C#]
public Palette PaletteName {get; set;}

Example

[C#]

Chart.PaletteName = dotnetCHARTING.Palette.Spring;

[Visual Basic]

Chart.PaletteName = dotnetCHARTING.Palette.Spring

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PieLabelMode Property

See DefaultSeries.DefaultElement.SmartLabel.PieLabelMode.

[Visual Basic]
Public Property PieLabelMode As PieLabelMode
[C#]
public PieLabelMode PieLabelMode {get; set;}

Example

[C#]

//Dispalys label inside the pie slice.
Chart.PieLabelMode = PieLabelMode.Inside;

[Visual Basic]

'Dispalys label inside the pie slice.
Chart.PieLabelMode = PieLabelMode.Inside

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PopulateDateGroupingSubValues Property

When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to !:SubValues or not. By default, such values are not added to the element subvalues.

[Visual Basic]
Public Property PopulateDateGroupingSubValues As Boolean
[C#]
public bool PopulateDateGroupingSubValues {get; set;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PrinterOptimizedText Property

Gets or sets a value that indicates whether text rendered on the chart optimized for printing.

[Visual Basic]
Public Property PrinterOptimizedText As Boolean
[C#]
public bool PrinterOptimizedText {get; set;}

Example

[C#]

Chart.PrinterOptimizedText = true;

[Visual Basic]

Chart.PrinterOptimizedText = true

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RadarLabelMode Property

See DefaultSeries.DefaultElement.SmartLabel.RadarLabelMode.

[Visual Basic]
Public Property RadarLabelMode As RadarLabelMode
[C#]
public RadarLabelMode RadarLabelMode {get; set;}

Example

[C#]

Chart.RadarLabelMode = RadarLabelMode.Outside;

[Visual Basic]

Chart.RadarLabelMode = RadarLabelMode.Outside

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ReloadPeriod Property

Gets or sets a TimeSpan object that determines how often the page containing this chart will automatically reload.

[Visual Basic]
Public Property ReloadPeriod As TimeSpan
[C#]
public TimeSpan ReloadPeriod {get; set;}

Example

[C#]

//Reload the page each one minute
Chart.ReloadPeriod = new TimeSpan(0,1,0)

[Visual Basic]

'Reload the page each one minute
Chart.ReloadPeriod = new TimeSpan(0,1,0)

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Series Property

Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.

[Visual Basic]
Public Property Series As Series
[C#]
public Series Series {get; set;}

Example

[C#]

//Adding series programatically
Chart.Series.Name="Vancouver";
Chart.Series.Type = SeriesType.Cylinder;
Chart.Series.Element  = new Element("Mon",2);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Tue",4);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Wed",5);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Thr",6);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Fri",5);
Chart.Series.Elements.Add();
Chart.SeriesCollection.Add();

[Visual Basic]

'Adding series programatically
Chart.Series.Name="Vancouver"
Chart.Series.Type = SeriesType.Cylinder
Chart.Series.Element = new Element("Mon",2)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Tue",4)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Wed",5)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Thr",6)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Fri",5)
Chart.Series.Elements.Add()
Chart.SeriesCollection.Add()

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SeriesCollection Property

Gets a SeriesCollection object which represents the data this chart will render.

[Visual Basic]
Public ReadOnly Property SeriesCollection As SeriesCollection
[C#]
public SeriesCollection SeriesCollection {get;}

Example

[C#]

//Adding series programatically
Series sr =new Series();
sr.Name ="Vancouver";
sr.Type = SeriesType.Cylinder;
Element el= new Element("E 1",2);
sr.Elements.Add(el);
Chart.SeriesCollection.Add(sr);

[Visual Basic]

'Adding series programatically
Dim sr As Series =new Series()
sr.Name ="Vancouver"
sr.Type = SeriesType.Cylinder
Dim el As Element = new Element("E 1",2)
sr.Elements.Add(el)
Chart.SeriesCollection.Add(sr)

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ShadingEffect Property

See ShadingEffectMode.

[Visual Basic]
Public Property ShadingEffect As Boolean
[C#]
public bool ShadingEffect {get; set;}

Example

[C#]

Chart.ShadingEffect = true;

[Visual Basic]

Chart.ShadingEffect = true

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ShadingEffectMode Property

Gets or sets a ShadingEffectMode enumeration indicating how elements on the chart are shaded.

[Visual Basic]
Public Property ShadingEffectMode As ShadingEffectMode
[C#]
public ShadingEffectMode ShadingEffectMode {get; set;}

Remarks

2D Columns, and Bubbles can use mode One, Two, and Three. 3D Columns, 2D Pies, and 2D Donuts can only use mode 'One'.

Example

[C#]

Chart.ShadingEffectMode = ShadingEffectMode.One;

[Visual Basic]

Chart.ShadingEffectMode = ShadingEffectMode.One

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ShowDateInTitle Property

Gets or sets a value which indicates whether specified dates are shown in the title.

[Visual Basic]
Public Property ShowDateInTitle As Boolean
[C#]
public bool ShowDateInTitle {get; set;}

Remarks

Applicable when Chart.DefaultSeries.Start/EndDate or Chart.Series.Start/EndDate are set.

Example

[C#]

Chart.ShowDateInTitle = true;

[Visual Basic]

Chart.ShowDateInTitle = true

See Also

Chart Class | Chart Members


Size Property

Chart Class | Chart Members

Language

Visual Basic

C#

Show All

value
See Also Languages dotnetCHARTING Send comments on this topic.

Size Property

Sets a string that automatically sets the Height and Width of the chart image.

[Visual Basic]
Public WriteOnly Property Size( _
   ByVal value As String _
)
[C#]
public void Size(
   string value
); {set;}

Parameters

value

Return Type

This property accepts a string formatted as "WidthXHeight".

Example

[C#]

Chart.Size = "640X480";

[Visual Basic]

Chart.Size = "640X480"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartLabelLine Property

See Chart.DefaultSeries.DefaultElement.SmartLabel.Line.

[Visual Basic]
Public Property SmartLabelLine As Line
[C#]
public Line SmartLabelLine {get; set;}

Example

[C#]

//Import Drawing2D namespace: <%@ Import Namespace="System.Drawing.Drawing2D" %>
Line LineObj = new Line(Color.Red);
LineObj.DashStyle = DashStyle.DashDot;
LineObj.EndCap = LineCap.ArrowAnchor;
Chart.SmartLabelLine = LineObj;

[Visual Basic]

'Import Drawing2D namespace: <%@ Import Namespace="System.Drawing.Drawing2D" %>
Dim LineObj As Line = new Line(Color.Red)
LineObj.DashStyle = DashStyle.DashDot
LineObj.EndCap = LineCap.ArrowAnchor
Chart.SmartLabelLine = LineObj

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartPalette Property

Gets or sets a NameColorCollection object that specifies the colors of elements and series with specific names.

[Visual Basic]
Public Property SmartPalette As SmartPalette
[C#]
public SmartPalette SmartPalette {get; set;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartPaletteAutoSync Property

Gets or sets a boolean which controls smart palette synchronization.

[Visual Basic]
Public Property SmartPaletteAutoSync As Boolean
[C#]
public bool SmartPaletteAutoSync {get; set;}

See Also

Chart Class | Chart Members


Chart Class | Chart Members | DateGrouping Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StartDateOfYear Property

Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.

[Visual Basic]
Public Property StartDateOfYear As Date
[C#]
public DateTime StartDateOfYear {get; set;}

Remarks

This property determine the start month of the year. The default is January.

Example

This example change the year duration from Jan-Dec to Mar-Feb. Beside month, other values are ignored.

[C#]

de.StartDateOfYear = new DateTime(2004,3,1);

[Visual Basic]

de.StartDateOfYear = New DateTime(2004, 3, 1)

See Also

Chart Class | Chart Members | DateGrouping Property


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StartDayOfWeek Property

Gets or sets a DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.

[Visual Basic]
Public Property StartDayOfWeek As DayOfWeek
[C#]
public DayOfWeek StartDayOfWeek {get; set;}

Example

[C#]

Chart.DateGrouping = TimeInterval.Weeks;
Chart.StartDayOfWeek = DayOfWeek.Monday;

//For complete code, see StartDayOfWeek.aspx sample.

[Visual Basic]

Chart.DateGrouping = TimeInterval.Weeks
Chart.StartDayOfWeek = DayOfWeek.Monday

'For complete code, see StartDayOfWeek.aspx sample.

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TempDirectory Property

Gets or sets the directory where images generated by the control are temporarily stored.

[Visual Basic]
Public Property TempDirectory As String
[C#]
public string TempDirectory {get; set;}

Remarks

This property takes either an absolute path 'c:/inetpub/wwwroot/app/tmp', a relative path ('tmp', '../tmp',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/tmp).

Example

This examples demonstrate different ways of accessing the same folder: 'c:/inetpub/wwwroot/app/tmp' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.

[C#]

Chart.TempDirectory = "c://inetpub/wwwroot/app/tmp";
Chart.TempDirectory = "/app/tmp";
Chart.TempDirectory = "tmp";

[Visual Basic]

Chart.TempDirectory = "c://inetpub/wwwroot/app/tmp"
Chart.TempDirectory = "/app/tmp"
Chart.TempDirectory = "tmp"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Title Property

Gets or sets the chart title.

Equivalent to Chart.TitleBox.Label.Text.

[Visual Basic]
Public Property Title As String
[C#]
public string Title {get; set;}

Example

[C#]

Chart.Title = "Chart of Sales for 2003";

[Visual Basic]

Chart.Title = "Chart of Sales for 2003"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TitleBox Property

Gets or sets a Box object that represents the title box.

[Visual Basic]
Public Property TitleBox As Box
[C#]
public Box TitleBox {get; set;}

Remarks

Notes

- To hide the title box use Chart.TitleBox.Position = TitleBoxPosition.None.

- Setting Chart.TitleBox.Icon = "...IconPath..." draws the image inside the title box.
- When no title, or icon is provided and TitleBoxPosition.FullWithLegend is not set, the title box is automatically hidden.

Example

[C#]

Chart.TitleBox.Background = new Background(System.Drawing.Color.SkyBlue);
Chart.TitleBox.CornerBottomLeft = BoxCorner.Square;
Chart.TitleBox.CornerBottomRight = BoxCorner.Square;
Chart.TitleBox.CornerTopLeft = BoxCorner.Cut;
Chart.TitleBox.CornerTopRight = BoxCorner.Cut;
Chart.TitleBox.IconPath="icon.gif";
Chart.TitleBox.Label =  new dotnetCHARTING.Label("Orders By Customers",new Font("Arial",10),Color.DarkSlateBlue);
Chart.TitleBox.Line = new Line(Color.Blue);
Chart.TitleBox.Position = TitleBoxPosition.Center;
Chart.TitleBox.Shadow.Color = Color.LightBlue;
Chart.TitleBox.Shadow.Depth=40;

//For complete code, see TitleBox.aspx sample

[Visual Basic]

Chart.TitleBox.Background = new Background(System.Drawing.Color.SkyBlue)
Chart.TitleBox.CornerBottomLeft = BoxCorner.Square
Chart.TitleBox.CornerBottomRight = BoxCorner.Square
Chart.TitleBox.CornerTopLeft = BoxCorner.Cut
Chart.TitleBox.CornerTopRight = BoxCorner.Cut
Chart.TitleBox.IconPath="icon.gif"
Chart.TitleBox.Label = new dotnetCHARTING.Label("Orders By Customers",new Font("Arial",10),Color.DarkSlateBlue)
Chart.TitleBox.Line = new Line(Color.Blue)
Chart.TitleBox.Position = TitleBoxPosition.Center
Chart.TitleBox.Shadow.Color = Color.LightBlue
Chart.TitleBox.Shadow.Depth=40

'For complete code, see TitleBox.aspx sample

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ToolTip Property

Gets or sets the Tooltip of the entinre chart image.

[Visual Basic]
Overrides Public Property ToolTip As String
[C#]
public override string ToolTip {get; set;}

Example

[C#]

Chart.ToolTip = "Sales Report";

[Visual Basic]

Chart.ToolTip = "Sales Report"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TotalSeries Property

Return the total number of series in the seriesCollection. This property usually used in conjunction with SplitByLimit.

[Visual Basic]
Public ReadOnly Property TotalSeries As Integer
[C#]
public int TotalSeries {get;}

Example

[C#]

int pageSize=3;
    int totalPage = Chart.Total%pageSize==0?Chart.Total/pageSize:(Chart.Total/pageSize)+1;
    if(totalPage>currentPage)
    {
        //Display "Next" button.
    }

[Visual Basic]

Dim pageSize As Integer = 3
    Dim totalPage As Integer = Chart.Total / pageSize;
    If Chart.Total Mod pageSize > 0 Then
        totalPage = totalPage + 1)
    End If
    If totalPage > currentPage Then
        'Display "Next" button.
    End If

See Also

Chart Class | Chart Members


Chart Class | Chart Members | Transpose(SeriesCollection) Method | Transpose(SeriesCollection) Method

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Transpose Property

Gets or sets a value indicating whether data added to this chart's SeriesCollection property is automatically transposed.

[Visual Basic]
Public Property Transpose As Boolean
[C#]
public bool Transpose {get; set;}

Example

[C#]

Chart.Transpose = true;

[Visual Basic]

Chart.Transpose = true

See Also

Chart Class | Chart Members | Transpose(SeriesCollection) Method | Transpose(SeriesCollection) Method


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Type Property

Gets or sets the ChartType of this Chart.

[Visual Basic]
Public Property Type As ChartType
[C#]
public ChartType Type {get; set;}

Example

[C#]

Chart.Type = ChartType.Pie;

[Visual Basic]

Chart.Type = ChartType.Pie

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URL Property

Gets or sets the URL of the entinre chart image.

[Visual Basic]
Public Property URL As String
[C#]
public string URL {get; set;}

Example

[C#]

Chart.URL = "http://www.yahoo.com";

[Visual Basic]

Chart.URL = "http://www.yahoo.com"

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URLTarget Property

Gets or sets the target of the URL link.

[Visual Basic]
Public Property URLTarget As String
[C#]
public string URLTarget {get; set;}

Example

[C#]

Chart.URLTarget = "_blank";

[Visual Basic]

Chart.URLTarget = "_blank"

See Also

Chart Class | Chart Members


Chart Class | Chart Members | Depth Property | Depth Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Use3D Property

Gets or sets a value indicating whether chart elements are rendered in 3D.

[Visual Basic]
Public Property Use3D As Boolean
[C#]
public bool Use3D {get; set;}

Example

[C#]

Chart.Use3D = true;

[Visual Basic]

Chart.Use3D = true

See Also

Chart Class | Chart Members | Depth Property | Depth Property


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

UseFile Property

Gets or sets a value indicating whether the generated image is saved as a file in the TempDirectory folder or streamed directly to the browser.

[Visual Basic]
Public Property UseFile As Boolean
[C#]
public bool UseFile {get; set;}

Remarks

.netCHARTING supports streaming images in addition to returning a reference to a generated file. There are differences in the way the control can be used between these two image return methods. When using a file reference, you are free to treat the page as you normally would, including HTML and any other web content on the page.

If you are streaming the image back, only the control call should exist on the page because no other HTML will render. This is not a limitation of .netCHARTING but rather specific to the HTTP implementation which serves each request separately (as such a request to a web site with 3 images is actually 4 unique requests and the browser does the job of assembling those 4 items into the web page you see.

Becauase streaming images does not allow HTML, setting url and tooltip properties of elements on the chart will have no effect.

Example

[C#]

Chart.UseFile = true;

[Visual Basic]

Chart.UseFile = true

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Width Property

Gets or sets the width of the chart image.

[Visual Basic]
Overrides Public Property Width As Unit
[C#]
public override Unit Width {get; set;}

Example

[C#]

Chart.Width = 600;

[Visual Basic]

Chart.Width = Unit.Parse(600)

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

XAxis Property

Gets or Sets the main XAxis which all series inherit by default.

[Visual Basic]
Public Property XAxis As Axis
[C#]
public Axis XAxis {get; set;}

Example

[C#]

//Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
 Axis xAxisObj = new Axis();
 xAxisObj.Line.StartCap = LineCap.RoundAnchor;
 xAxisObj.Line.EndCap = LineCap.ArrowAnchor;
 xAxisObj.Line.Width =3;
 xAxisObj.Label.Text="customized xAxis";
 Chart.XAxis = xAxisObj;

[Visual Basic]

'Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
 Dim xAxisObj As Axis = new Axis()
xAxisObj.Line.StartCap = LineCap.RoundAnchor
xAxisObj.Line.EndCap = LineCap.ArrowAnchor
xAxisObj.Line.Width = 3
xAxisObj.Label.Text="customized xAxis"
Chart.XAxis = xAxisObj

See Also

Chart Class | Chart Members


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

YAxis Property

Gets or Sets the main YAxis which all series inherit by default.

[Visual Basic]
Public Property YAxis As Axis
[C#]
public Axis YAxis {get; set;}

Example

[C#]

//Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
 Axis yAxisObj = new Axis();
 yAxisObj.Line.StartCap = LineCap.RoundAnchor;
 yAxisObj.Line.EndCap = LineCap.ArrowAnchor;
 yAxisObj.Line.Width =3;
 yAxisObj.Label.Text="customized yAxis";
 Chart.YAxis = yAxisObj;

[Visual Basic]

'Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
Dim yAxisObj As Axis = new Axis()
yAxisObj.Line.StartCap = LineCap.RoundAnchor
yAxisObj.Line.EndCap = LineCap.ArrowAnchor
yAxisObj.Line.Width = 3
yAxisObj.Label.Text="customized yAxis"
Chart.YAxis = yAxisObj

See Also

Chart Class | Chart Members


Chart Class Events

Chart Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Chart Class Members

For a list of all members of this type, see Chart members.

Public Events

Public Event DataBinding (Inherited from System.Web.UI.Control) |
Public Event Disposed (Inherited from System.Web.UI.Control) |
Public Event Init (Inherited from System.Web.UI.Control) |
Public Event Load (Inherited from System.Web.UI.Control) |
Public Event PostDataProcessing | Occurs when the the chart is completed the data processing.
Public Event PreRender (Inherited from System.Web.UI.Control) |
Public Event Unload (Inherited from System.Web.UI.Control) |

See Also

Chart Class | dotnetCHARTING Namespace


Chart Class | Chart Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PostDataProcessing Event

Occurs when the the chart is completed the data processing.

[Visual Basic]
Public Event PostDataProcessing() As PostDataProcessingEventHandler
[C#]
public event PostDataProcessingEventHandler PostDataProcessing();

Remarks

This event is very useful for customizing and displaying the processed data specially when using SplitByLimit which generates more than one series from a series.

Example

The follwoing sample, get a data table and displays with a datagrid. For complete sample see features/PostDataProcessing.aspx

[C#]

//This line should add in Page_Load method
Chart.PostDataProcessing +=new PostDataProcessingEventHandler(OnPostDataProcessing);

//The method handling the PostDataProcessing event
void OnPostDataProcessing(Object sender)
{
    DataTable dt = Chart.SeriesCollection.GetProcessedDataTable("%YValue");
    chartdatagrid.DataSource = new DataView(dt);
    chartdatagrid.DataBind();

}

[Visual Basic]

'This line should add in Page_Load method
AddHandler Chart.PostDataProcessing, AddressOf OnPostDataProcessing

'The method handling the PostDataProcessing event
Sub OnPostDataProcessing(sender As [Object])
   Dim dt As DataTable = Chart.SeriesCollection.GetProcessedDataTable("%YValue")
   chartdatagrid.DataSource = New DataView(dt)
   chartdatagrid.DataBind()
End Sub 'OnPostDataProcessing

See Also

Chart Class | Chart Members


ChartArea Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChartArea Class

Represents an area on which series and elements are plotted.

For a list of all members of this type, see ChartArea members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.ChartArea

Syntax

[Visual Basic]
Public Class ChartArea
[C#]
public class ChartArea

See Also

ChartArea Members | dotnetCHARTING Namespace


ChartArea Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ChartArea Class Members

ChartArea overview

Public Constructors

Public Constructor ChartArea Constructor Overloaded.

Public Properties

Public Property Background | Gets or sets a background object used to fill the interior of this chart area.
Public Property DateGrouping | Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Public Property DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property DefaultElement | Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.
Public Property DefaultSeries | Gets or sets a Series object whose properties will trickle to all other series in this chart area unless otherwise specified.
Public Property DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property GridPosition | Gets or sets the layout column and row position of this ChartArea.
Public Property HeightPercentage | Gets or sets a value that specifies what percentage of the full height available for ChartAreas this ChartArea will occupy.
Public Property IncludeGroupingDataInSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to !:SubValues or not. By default, such values are not added to the element subvalues.
Public Property InteriorLine | Gets or sets a line object which is drawn inside the chart area.
Public Property Label | Gets or sets a label object which draws a string inside the chart area.
Public Property LegendBox | Gets or sets a LegendBox object associated with this chart area.
Public Property LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property Line | Gets or sets the Line object used to draw the outline of this chart area.
Public Property Padding | Gets or sets the padding or spacing of chart objects plotted on this ChartArea. This applies only to radar, pie, and gauge charts.
Public Property Series | Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.
Public Property SeriesCollection | Adds Series or SeriesCollection objects to the chart area.
Public Property Shadow | Gets or sets the Shadow cast under this box.
Public Property StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property StartDayOfWeek | Gets or sets a DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.
Public Property Title | Gets or sets the ChartArea's title. Equivalent to ChartArea.TitleBox.Label.Text.
Public Property TitleBox | Gets or sets a title box (dotnetCHARTING.Box) object associated with this ChartArea.
Public Property ValueLabel | Gets or sets a label that specifies the font and color of element labels drawn on the chart. Equivalent to: Chart.DefaultSeries.DefaultElement.SmartLabel
Public Property Visible | Gets or sets a value that indicates whether this chart area is visible.
Public Property WidthPercentage | Gets or sets a value that specifies what percentage of the full width available for ChartAreas this ChartArea will occupy.
Public Property XAxis | Gets or sets the X axis of this chart area.
Public Property YAxis | Gets or sets the Y axis of this chart area.

Public Methods

Public Method ClearColors | Serves as a shortcut to make the ChartArea transparent.
Public Method GetCoordinates | Gets the coordinates of this ChartArea after the chart is rendered.
Public Method GetRectangle | Gets a Rectangle object indicating this ChartArea's position and size after the chart is rendered.

See Also

ChartArea Class | dotnetCHARTING Namespace


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChartArea Constructor

Overload List

Initializes a new instance of the ChartArea class.

[Visual Basic] Public Sub New()

[C#] public ChartArea();

Initializes a new instance of the ChartArea class with a Series.

[Visual Basic] Public Sub New(Series)

[C#] public ChartArea(Series);

Initializes a new instance of the ChartArea class with a SeriesCollection.

[Visual Basic] Public Sub New(SeriesCollection)

[C#] public ChartArea(SeriesCollection);

Initializes a new instance of the ChartArea class with a title.

[Visual Basic] Public Sub New(String)

[C#] public ChartArea(string);

Initializes a new instance of the ChartArea class with a title and SeriesCollection.

[Visual Basic] Public Sub New(String,Series)

[C#] public ChartArea(string,Series);

Initializes a new instance of the ChartArea class with a title and SeriesCollection.

[Visual Basic] Public Sub New(String,SeriesCollection)

[C#] public ChartArea(string,SeriesCollection);

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChartArea Constructor()

Initializes a new instance of the ChartArea class.

[Visual Basic]
Public Function New()
[C#]
public ChartArea();

See Also

ChartArea Class | ChartArea Members | Overload List


ChartArea Constructor(Series)

ChartArea Class | ChartArea Members | Overload List

Language

Visual Basic

C#

Show All

s
A series of data plotted in this chart area.
See Also Languages dotnetCHARTING Send comments on this topic.

ChartArea Constructor(Series)

Initializes a new instance of the ChartArea class with a Series.

[Visual Basic]
Public Function New( _
   ByVal s As Series _
)
[C#]
public ChartArea(
   Series s
);

Parameters

s
A series of data plotted in this chart area.

See Also

ChartArea Class | ChartArea Members | Overload List


ChartArea Constructor(SeriesCollection)

ChartArea Class | ChartArea Members | Overload List

Language

Visual Basic

C#

Show All

sc
Data plotted in this chart area.
See Also Languages dotnetCHARTING Send comments on this topic.

ChartArea Constructor(SeriesCollection)

Initializes a new instance of the ChartArea class with a SeriesCollection.

[Visual Basic]
Public Function New( _
   ByVal sc As SeriesCollection _
)
[C#]
public ChartArea(
   SeriesCollection sc
);

Parameters

sc
Data plotted in this chart area.

See Also

ChartArea Class | ChartArea Members | Overload List


ChartArea Constructor(String)

ChartArea Class | ChartArea Members | Overload List

Language

Visual Basic

C#

Show All

title
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.
See Also Languages dotnetCHARTING Send comments on this topic.

ChartArea Constructor(String)

Initializes a new instance of the ChartArea class with a title.

[Visual Basic]
Public Function New( _
   ByVal title As String _
)
[C#]
public ChartArea(
   string title
);

Parameters

title
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.

See Also

ChartArea Class | ChartArea Members | Overload List


ChartArea Constructor(String,Series)

ChartArea Class | ChartArea Members | Overload List

Language

Visual Basic

C#

Show All

title
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.
s
A series of data plotted in this chart area.
See Also Languages dotnetCHARTING Send comments on this topic.

ChartArea Constructor(String,Series)

Initializes a new instance of the ChartArea class with a title and SeriesCollection.

[Visual Basic]
Public Function New( _
   ByVal title As String, _
   ByVal s As Series _
)
[C#]
public ChartArea(
   string title,
   Series s
);

Parameters

title
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.
s
A series of data plotted in this chart area.

See Also

ChartArea Class | ChartArea Members | Overload List


ChartArea Constructor(String,SeriesCollection)

ChartArea Class | ChartArea Members | Overload List

Language

Visual Basic

C#

Show All

title
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.
sc
Data plotted in this chart area.
See Also Languages dotnetCHARTING Send comments on this topic.

ChartArea Constructor(String,SeriesCollection)

Initializes a new instance of the ChartArea class with a title and SeriesCollection.

[Visual Basic]
Public Function New( _
   ByVal title As String, _
   ByVal sc As SeriesCollection _
)
[C#]
public ChartArea(
   string title,
   SeriesCollection sc
);

Parameters

title
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.
sc
Data plotted in this chart area.

See Also

ChartArea Class | ChartArea Members | Overload List


ChartArea Class Methods

ChartArea Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ChartArea Class Members

For a list of all members of this type, see ChartArea members.

Public Methods

Public Method ClearColors | Serves as a shortcut to make the ChartArea transparent.
Public Method GetCoordinates | Gets the coordinates of this ChartArea after the chart is rendered.
Public Method GetRectangle | Gets a Rectangle object indicating this ChartArea's position and size after the chart is rendered.

See Also

ChartArea Class | dotnetCHARTING Namespace


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ClearColors Method

Serves as a shortcut to make the ChartArea transparent.

[Visual Basic]
Public Sub ClearColors()
[C#]
public void ClearColors();

Remarks

The following properties are set:

Background.Color = Color.Empty

Background.Bevel = false

Line.Color = Color.Empty

Shadow.Color = Color.Empty

InteriorLine.Color = Color.Empty

For each axis

AlternateGridBackground.Color = Color.Empty;

AlternateGridBackground.Mode = BackgroundMode.Color;

AlternateGridBackground.Bevel = false;

GridLine.Color = Color.Empty;

ZeroLine.Color = Color.Empty;

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetCoordinates Method

Gets the coordinates of this ChartArea after the chart is rendered.

[Visual Basic]
Public Function GetCoordinates() As Point()
[C#]
public Point[] GetCoordinates();

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetRectangle Method

Gets a Rectangle object indicating this ChartArea's position and size after the chart is rendered.

[Visual Basic]
Public Function GetRectangle() As Rectangle
[C#]
public Rectangle GetRectangle();

See Also

ChartArea Class | ChartArea Members


ChartArea Class Properties

ChartArea Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ChartArea Class Members

For a list of all members of this type, see ChartArea members.

Public Properties

Public Property Background | Gets or sets a background object used to fill the interior of this chart area.
Public Property DateGrouping | Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Public Property DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property DefaultElement | Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.
Public Property DefaultSeries | Gets or sets a Series object whose properties will trickle to all other series in this chart area unless otherwise specified.
Public Property DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property GridPosition | Gets or sets the layout column and row position of this ChartArea.
Public Property HeightPercentage | Gets or sets a value that specifies what percentage of the full height available for ChartAreas this ChartArea will occupy.
Public Property IncludeGroupingDataInSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to !:SubValues or not. By default, such values are not added to the element subvalues.
Public Property InteriorLine | Gets or sets a line object which is drawn inside the chart area.
Public Property Label | Gets or sets a label object which draws a string inside the chart area.
Public Property LegendBox | Gets or sets a LegendBox object associated with this chart area.
Public Property LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property Line | Gets or sets the Line object used to draw the outline of this chart area.
Public Property Padding | Gets or sets the padding or spacing of chart objects plotted on this ChartArea. This applies only to radar, pie, and gauge charts.
Public Property Series | Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.
Public Property SeriesCollection | Adds Series or SeriesCollection objects to the chart area.
Public Property Shadow | Gets or sets the Shadow cast under this box.
Public Property StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property StartDayOfWeek | Gets or sets a DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.
Public Property Title | Gets or sets the ChartArea's title. Equivalent to ChartArea.TitleBox.Label.Text.
Public Property TitleBox | Gets or sets a title box (dotnetCHARTING.Box) object associated with this ChartArea.
Public Property ValueLabel | Gets or sets a label that specifies the font and color of element labels drawn on the chart. Equivalent to: Chart.DefaultSeries.DefaultElement.SmartLabel
Public Property Visible | Gets or sets a value that indicates whether this chart area is visible.
Public Property WidthPercentage | Gets or sets a value that specifies what percentage of the full width available for ChartAreas this ChartArea will occupy.
Public Property XAxis | Gets or sets the X axis of this chart area.
Public Property YAxis | Gets or sets the Y axis of this chart area.

See Also

ChartArea Class | dotnetCHARTING Namespace


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Background Property

Gets or sets a background object used to fill the interior of this chart area.

[Visual Basic]
Public Property Background As Background
[C#]
public Background Background {get; set;}

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members | DateGrouping Property | DateGrouping Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DateGrouping Property

Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.

[Visual Basic]
Public Property DateGrouping As TimeInterval
[C#]
public TimeInterval DateGrouping {get; set;}

Remarks

Controls how the values of a given series are grouped by date. In order to use this option the second column returned by the SqlStatement must be a date/time. Options include Minutes, Hours, Days, Weeks, Months, Quarters and Years where any StartDate and EndDate can be used and the chart will show all values sequentially. There are additional options for Hour/Minute, Day/Hour, Week/Day, Month/Day, Year/Quarter and Year/Month in these cases there are 2 special considerations 1) only a single day / week / month / or year is charted and 2) if the date range is greater than the period type (e.g. 1 day / 1 week / 1 month / 1 year) values are totalled over that period. There are also shortcuts for the grouping cases of Hour (Hours/Minute), Day (Day/Hour), Week(Week/Day), Month (Month/Day) and Year (Year/Month). See all time interval options. This feature automatically groups multiple data points over a given date range into the specific date grouping you select. When DateGrouping is enabled you must ensure that each series within a given chart returns date/time data for the second column returned by the SqlStatement.

Example

[C#]

            [C#]
Chart.DateGrouping = TimeInterval.Days;

[C#]

            [Visual Basic]
Chart.DateGrouping = TimeInterval.Days

See Also

ChartArea Class | ChartArea Members | DateGrouping Property | DateGrouping Property


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DateGroupingCalculation Property

Gets or sets an enum which determines how values are grouped to create a single element value.

[Visual Basic]
Public Property DateGroupingCalculation As Calculation
[C#]
public Calculation DateGroupingCalculation {get; set;}

Remarks

When dategrouping is used, if an element has more than one value, a Calculation is performed on those values.

Example

[C#]

            [C#]
Chart.DateGroupingCalculation = Calculation.Average;

[C#]

            [Visual Basic]
Chart.DateGroupingCalculation = Calculation.Average

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DateGroupingSort Property

Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.

[Visual Basic]
Public Property DateGroupingSort As Boolean
[C#]
public bool DateGroupingSort {get; set;}

Remarks

When dategrouping is used and StartDate or EndDate is not set, the data is sorted by the xAxis field by default. Setting this property to true will maintain the sort order of the data as it is provided.

Example

[C#]

            [C#]
Chart.DateGroupingSort = true;

[C#]

            [Visual Basic]
Chart.DateGroupingSort = true

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultElement Property

Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.

[Visual Basic]
Public Property DefaultElement As Element
[C#]
public Element DefaultElement {get; set;}

Example

[C#]

myChartArea.DefaultElement.SmartLabel.Text = "%Name";

[Visual Basic]

myChartArea.DefaultElement.SmartLabel.Text = "%Name"

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultSeries Property

Gets or sets a Series object whose properties will trickle to all other series in this chart area unless otherwise specified.

[Visual Basic]
Public Property DefaultSeries As Series
[C#]
public Series DefaultSeries {get; set;}

Example

[C#]

myChartArea.DefaultSeries.Type = SeriesType.AreaLine;

[Visual Basic]

myChartArea.DefaultSeries.Type = SeriesType.AreaLine

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DrillDownIntoSeries Property

When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.

[Visual Basic]
Public Property DrillDownIntoSeries As Boolean
[C#]
public bool DrillDownIntoSeries {get; set;}

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GridPosition Property

Gets or sets the layout column and row position of this ChartArea.

[Visual Basic]
Public Property GridPosition As Point
[C#]
public Point GridPosition {get; set;}

Remarks

The default (top-left) position is 0,0. To place another ChartArea to the right of it, the position would be 1,0.

The format is: ( Column, Row ) or ( X , Y )

Example

ChartArea.GridPosition = new Point(1,0);

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HeightPercentage Property

Gets or sets a value that specifies what percentage of the full height available for ChartAreas this ChartArea will occupy.

[Visual Basic]
Public Property HeightPercentage As Integer
[C#]
public int HeightPercentage {get; set;}

Remarks

Values range from 0 to 100. This property should be used with multiple vertical chart area charts.

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

IncludeGroupingDataInSubValues Property

When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to !:SubValues or not. By default, such values are not added to the element subvalues.

[Visual Basic]
Public Property IncludeGroupingDataInSubValues As Boolean
[C#]
public bool IncludeGroupingDataInSubValues {get; set;}

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InteriorLine Property

Gets or sets a line object which is drawn inside the chart area.

[Visual Basic]
Public Property InteriorLine As Line
[C#]
public Line InteriorLine {get; set;}

Remarks

The interior line can be seen when the chart is drawn in 3D.

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Label Property

Gets or sets a label object which draws a string inside the chart area.

[Visual Basic]
Public Property Label As Label
[C#]
public Label Label {get; set;}

Remarks

The label will be drawn in the upper left corner of the chart.

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendBox Property

Gets or sets a LegendBox object associated with this chart area.

[Visual Basic]
Public Property LegendBox As LegendBox
[C#]
public LegendBox LegendBox {get; set;}

Remarks

This property is null by default. By instantiating a new LegendBox, LegendEntry objects of the series or element in this chart area will appear in this LegendBox. Otherwise, they would appear in the main chart area's legend box (Chart.ChartArea.LegendBox).

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LimitPrimarySeries Property

In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.

[Visual Basic]
Public Property LimitPrimarySeries As String
[C#]
public string LimitPrimarySeries {get; set;}

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Property

Gets or sets the Line object used to draw the outline of this chart area.

[Visual Basic]
Public Property Line As Line
[C#]
public Line Line {get; set;}

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members | Column, Cylinder Spacing

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Padding Property

Gets or sets the padding or spacing of chart objects plotted on this ChartArea. This applies only to radar, pie, and gauge charts.

[Visual Basic]
Public Property Padding As Integer
[C#]
public int Padding {get; set;}

Remarks

To control column and cylinder spacing see link below.

See Also

ChartArea Class | ChartArea Members | Column, Cylinder Spacing


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Series Property

Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.

[Visual Basic]
Public Property Series As Series
[C#]
public Series Series {get; set;}

Example

[C#]

            [C#]
//Adding series programatically
Chart.Series.Name="Vancouver";
Chart.Series.Type = SeriesType.Cylinder;
Chart.Series.Element  = new Element("Mon",2);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Tue",4);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Wed",5);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Thr",6);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Fri",5);
Chart.Series.Elements.Add();
Chart.SeriesCollection.Add();

[C#]

            [Visual Basic]
'Adding series programatically
Chart.Series.Name="Vancouver"
Chart.Series.Type = SeriesType.Cylinder
Chart.Series.Element  = new Element("Mon",2)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Tue",4)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Wed",5)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Thr",6)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Fri",5)
Chart.Series.Elements.Add()
Chart.SeriesCollection.Add()

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SeriesCollection Property

Adds Series or SeriesCollection objects to the chart area.

[Visual Basic]
Public ReadOnly Property SeriesCollection As SeriesCollection
[C#]
public SeriesCollection SeriesCollection {get;}

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Shadow Property

Gets or sets the Shadow cast under this box.

[Visual Basic]
Public Property Shadow As Shadow
[C#]
public Shadow Shadow {get; set;}

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members | DateGrouping Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StartDateOfYear Property

Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.

[Visual Basic]
Public Property StartDateOfYear As Date
[C#]
public DateTime StartDateOfYear {get; set;}

Remarks

This property determine the start month of the year. The default is January.

Example

This example change the year duration from Jan-Dec to Mar-Feb. Beside month, other values are ignored.

[C#]

de.StartDateOfYear = new DateTime(2004,3,1);

[Visual Basic]

de.StartDateOfYear = New DateTime(2004, 3, 1)

See Also

ChartArea Class | ChartArea Members | DateGrouping Property


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StartDayOfWeek Property

Gets or sets a DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.

[Visual Basic]
Public Property StartDayOfWeek As DayOfWeek
[C#]
public DayOfWeek StartDayOfWeek {get; set;}

Example

[C#]

            [C#]
Chart.DateGrouping = TimeInterval.Weeks;
Chart.StartDayOfWeek = DayOfWeek.Monday;

//For complete code, see StartDayOfWeek.aspx sample.

[C#]

            [Visual Basic]
Chart.DateGrouping = TimeInterval.Weeks
Chart.StartDayOfWeek = DayOfWeek.Monday

'For complete code, see StartDayOfWeek.aspx sample.

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Title Property

Gets or sets the ChartArea's title.

Equivalent to ChartArea.TitleBox.Label.Text.

[Visual Basic]
Public Property Title As String
[C#]
public string Title {get; set;}

Example

[C#]

ChartArea.Title = "Chart of Sales for 2003";

[Visual Basic]

ChartArea.Title = "Chart of Sales for 2003"

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TitleBox Property

Gets or sets a title box (dotnetCHARTING.Box) object associated with this ChartArea.

[Visual Basic]
Public Property TitleBox As Box
[C#]
public Box TitleBox {get; set;}

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Visible Property

Gets or sets a value that indicates whether this chart area is visible.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

WidthPercentage Property

Gets or sets a value that specifies what percentage of the full width available for ChartAreas this ChartArea will occupy.

[Visual Basic]
Public Property WidthPercentage As Integer
[C#]
public int WidthPercentage {get; set;}

Remarks

Values range from 0 to 100. This property should be used with multiple horizontal chart area charts.

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

XAxis Property

Gets or sets the X axis of this chart area.

[Visual Basic]
Public Property XAxis As Axis
[C#]
public Axis XAxis {get; set;}

Remarks

When the axis is specified, series plotted on this area will automatically use this x axis, unless otherwise specified.

See Also

ChartArea Class | ChartArea Members


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

YAxis Property

Gets or sets the Y axis of this chart area.

[Visual Basic]
Public Property YAxis As Axis
[C#]
public Axis YAxis {get; set;}

Remarks

When the axis is specified, series plotted on this area will automatically use this y axis, unless otherwise specified.

See Also

ChartArea Class | ChartArea Members


ChartAreaCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChartAreaCollection Class

Contains a collection of ChartArea objects.

For a list of all members of this type, see ChartAreaCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.ChartAreaCollection

Syntax

[Visual Basic]
Public Class ChartAreaCollection
   Inherits CollectionBase
[C#]
public class ChartAreaCollection : CollectionBase

See Also

ChartAreaCollection Members | dotnetCHARTING Namespace


ChartAreaCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ChartAreaCollection Class Members

ChartAreaCollection overview

Public Constructors

Public Constructor ChartAreaCollection Constructor Creates a new instance of ChartAreaCollection with the specified list of ChartArea objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified ChartArea.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified ChartArea in this collection.
Public Method Insert | Inserts a ChartArea into this collection at a specified index.
Public Method Remove | Removes a specified ChartArea from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

ChartAreaCollection Class | dotnetCHARTING Namespace


ChartAreaCollection Constructor

ChartAreaCollection Class | ChartAreaCollection Members

Language

Visual Basic

C#

Show All

chartAreaList
See Also Languages dotnetCHARTING Send comments on this topic.

ChartAreaCollection Constructor

Creates a new instance of ChartAreaCollection with the specified list of ChartArea objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray chartAreaList() As ChartArea _
)
[C#]
public ChartAreaCollection(
   params ChartArea[] chartAreaList
);

Parameters

chartAreaList

See Also

ChartAreaCollection Class | ChartAreaCollection Members


ChartAreaCollection Class Methods

ChartAreaCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ChartAreaCollection Class Members

For a list of all members of this type, see ChartAreaCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified ChartArea.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified ChartArea in this collection.
Public Method Insert | Inserts a ChartArea into this collection at a specified index.
Public Method Remove | Removes a specified ChartArea from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

ChartAreaCollection Class | dotnetCHARTING Namespace


ChartAreaCollection Class | ChartAreaCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

[Visual Basic] Overloads Public Function Add(ChartArea) As Integer

[C#] public int Add(ChartArea);

Adds the specified ChartArea objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray ChartArea())

[C#] public void Add(params ChartArea[]);

Adds a specified ChartAreaCollection to this collection.

[Visual Basic] Overloads Public Sub Add(ChartAreaCollection)

[C#] public void Add(ChartAreaCollection);

See Also

ChartAreaCollection Class | ChartAreaCollection Members


Add(ChartArea) Method

ChartAreaCollection Class | ChartAreaCollection Members | Overload List

Language

Visual Basic

C#

Show All

chartArea
See Also Languages dotnetCHARTING Send comments on this topic.

Add(ChartArea) Method

[Visual Basic]
Overloads Public Function Add( _
   ByVal chartArea As ChartArea _
) As Integer
[C#]
public int Add(
   ChartArea chartArea
);

Parameters

chartArea

See Also

ChartAreaCollection Class | ChartAreaCollection Members | Overload List


Add(ChartArea[]) Method

ChartAreaCollection Class | ChartAreaCollection Members | Overload List

Language

Visual Basic

C#

Show All

chartAreaList
A list of ChartArea objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(ChartArea[]) Method

Adds the specified ChartArea objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray chartAreaList() As ChartArea _
)
[C#]
public void Add(
   params ChartArea[] chartAreaList
);

Parameters

chartAreaList
A list of ChartArea objects to add.

See Also

ChartAreaCollection Class | ChartAreaCollection Members | Overload List


Add(ChartAreaCollection) Method

ChartAreaCollection Class | ChartAreaCollection Members | Overload List

Language

Visual Basic

C#

Show All

chartAreaCollection
The ChartAreaCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(ChartAreaCollection) Method

Adds a specified ChartAreaCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal chartAreaCollection As ChartAreaCollection _
)
[C#]
public void Add(
   ChartAreaCollection chartAreaCollection
);

Parameters

chartAreaCollection
The ChartAreaCollection to add.

See Also

ChartAreaCollection Class | ChartAreaCollection Members | Overload List


Contains Method

ChartAreaCollection Class | ChartAreaCollection Members

Language

Visual Basic

C#

Show All

chartArea
The ChartArea to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified ChartArea.

[Visual Basic]
Public Function Contains( _
   ByVal chartArea As ChartArea _
) As Boolean
[C#]
public bool Contains(
   ChartArea chartArea
);

Parameters

chartArea
The ChartArea to find.

Return Type

true if the specified ChartArea belongs to this collection; otherwise, false.

See Also

ChartAreaCollection Class | ChartAreaCollection Members


IndexOf Method

ChartAreaCollection Class | ChartAreaCollection Members

Language

Visual Basic

C#

Show All

chartArea
The ChartArea to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines the index of a specified ChartArea in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal chartArea As ChartArea _
) As Integer
[C#]
public int IndexOf(
   ChartArea chartArea
);

Parameters

chartArea
The ChartArea to find.

Return Type

The zero-based index of the specified ChartArea.

See Also

ChartAreaCollection Class | ChartAreaCollection Members


Insert Method

ChartAreaCollection Class | ChartAreaCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the ChartArea.
chartArea
The ChartArea to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a ChartArea into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal chartArea As ChartArea _
)
[C#]
public void Insert(
   int index,
   ChartArea chartArea
);

Parameters

index
The zero-based index into the collection at which to insert the ChartArea.
chartArea
The ChartArea to insert into this collection.

See Also

ChartAreaCollection Class | ChartAreaCollection Members


Remove Method

ChartAreaCollection Class | ChartAreaCollection Members

Language

Visual Basic

C#

Show All

chartArea
The ChartArea to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified ChartArea from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal chartArea As ChartArea _
)
[C#]
public void Remove(
   ChartArea chartArea
);

Parameters

chartArea
The ChartArea to remove.

See Also

ChartAreaCollection Class | ChartAreaCollection Members


ChartAreaCollection Class Properties

ChartAreaCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ChartAreaCollection Class Members

For a list of all members of this type, see ChartAreaCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

ChartAreaCollection Class | dotnetCHARTING Namespace


Item Property

ChartAreaCollection Class | ChartAreaCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As ChartArea
[C#]
public ChartArea this[
   int index
]; {get; set;}

Parameters

index

See Also

ChartAreaCollection Class | ChartAreaCollection Members


ChartAreaLayout Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChartAreaLayout Class

Encapsulates a set of options that control the layout of multiple chart areas in a single chart image.

For a list of all members of this type, see ChartAreaLayout members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.ChartAreaLayout

Syntax

[Visual Basic]
Public Class ChartAreaLayout
[C#]
public class ChartAreaLayout

See Also

ChartAreaLayout Members | dotnetCHARTING Namespace


ChartAreaLayout Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ChartAreaLayout Class Members

ChartAreaLayout overview

Public Properties

Public Property AlignUnrelatedAxis | Gets or sets a value that indicates whether chart areas oriented opposite to the grid layout mode's priority orientation can be placed next to chart areas that don't share any axes.
Public Property Mode | Gets or sets the a ChartAreaLayoutMode.

See Also

ChartAreaLayout Class | dotnetCHARTING Namespace


ChartAreaLayout Class Properties

ChartAreaLayout Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ChartAreaLayout Class Members

For a list of all members of this type, see ChartAreaLayout members.

Public Properties

Public Property AlignUnrelatedAxis | Gets or sets a value that indicates whether chart areas oriented opposite to the grid layout mode's priority orientation can be placed next to chart areas that don't share any axes.
Public Property Mode | Gets or sets the a ChartAreaLayoutMode.

See Also

ChartAreaLayout Class | dotnetCHARTING Namespace


ChartAreaLayout Class | ChartAreaLayout Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AlignUnrelatedAxis Property

Gets or sets a value that indicates whether chart areas oriented opposite to the grid layout mode's priority orientation can be placed next to chart areas that don't share any axes.

[Visual Basic]
Public Property AlignUnrelatedAxis As Boolean
[C#]
public bool AlignUnrelatedAxis {get; set;}

Remarks

This setting applies only to modes VerticalPriority and HorizontalPriority.

See Also

ChartAreaLayout Class | ChartAreaLayout Members


ChartAreaLayout Class | ChartAreaLayout Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Mode Property

Gets or sets the a ChartAreaLayoutMode.

[Visual Basic]
Public Property Mode As ChartAreaLayoutMode
[C#]
public ChartAreaLayoutMode Mode {get; set;}

See Also

ChartAreaLayout Class | ChartAreaLayout Members


DataEngine Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataEngine Class

Acquires and manipulates data from databases or other sources, then creates a SeriesCollection which is consumed by the chart control.

For a list of all members of this type, see DataEngine members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.DataEngine

Syntax

[Visual Basic]
Public Class DataEngine
[C#]
public class DataEngine

See Also

DataEngine Members | dotnetCHARTING Namespace


DataEngine Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

DataEngine Class Members

DataEngine overview

Public Constructors

Public Constructor DataEngine Constructor Overloaded.

Public Properties

Public Property ChartObject | Sets the Chart object.
Public Property ChartType | Gets or sets the ChartType enumeration that sets the default DataFields for each type.
Public Property CommandTimeout | Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Public Property ConnectionString | Gets or sets the string used to open a SQL Server, Access, or Excel database.
Public Property CultureName | Gets or sets the culture name used when element names are populated with values such as dates.
Public Property Data | Gets or sets a DataTable, DataSet, DataView, OleDbDataReader, SqlDataReader, IDataReader, XML file name, or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.
Public Property DatabaseCultureName | Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.
Public Property DataFields | Gets or sets a value that specifies the 'database column' to 'element value' relationship.
Public Property DateGrouping | Gets or sets the date grouping of data returned from your database.
Public Property DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property EndDate | Gets or sets the ending date used with SqlStatement to query filtered data from a database.
Public Property ErrorMessage | Gets an error message which will be available if this DataEngine instance fails after a call to GetSeries().
Public Property FormatString | Gets or sets the format string used when element names are populated with values such as dates.
Public Property Limit | Gets or sets the limit number of elements returned for each series when data is generated. Gets or sets the limit number of elements returned for each series when data is generated. This property determines the number of elements to include in the limited return. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group position and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum elements.
Public Property LimitMode | Determine the type of limitation. Default is Top.
Public Property LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property OtherElementLabel | Gets or sets the label used for the element or series created when using Limit or SplitByLimit and setting ShowOther to true.
Public Property ParameterCollection | Gets or sets a collection of Parameter objects used in conjunction with the StoredProcedure property.
Public Property PopulateDateGroupingSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to !:SubValues or not. By default, such values are not added to the element subvalues.
Public Property ShowOther | Gets or sets a value that indicates whether the additional series not shown due to the use of SplitByLimit, or elements not shown due to the use of Limit, are aggregated into a single series or element.
Public Property SplitByLimit | Gets or sets the number of series created using SplitBy.
Public Property SqlStatement | The SQL statement used to obtain the charting data.
Public Property StartDate | Gets or sets the starting date used with SqlStatement to query filtered data from a database.
Public Property StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property StartDayOfWeek | Gets or sets a DayOfWeek enumeration that determines the day which will be used as the starting day of the week for the dategrouping functionality.
Public Property StoredProcedure | This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.

Public Methods

Public Method AddParameter | Adds a stored procedure when to use in conjunction with StoredProcedure.
Public Method GetFinancialSeries | See GetSeries.
Public Method GetSeries | Overloaded.

See Also

DataEngine Class | dotnetCHARTING Namespace


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataEngine Constructor

Overload List

Initializes a new instance of the DataEngine class.

[Visual Basic] Public Sub New()

[C#] public DataEngine();

Initializes a new instance of the DataEngine class with a data object.

[Visual Basic] Public Sub New(Object)

[C#] public DataEngine(object);

Initializes a new instance of the DataEngine class with a data object and mapped DataFields.

[Visual Basic] Public Sub New(Object,String)

[C#] public DataEngine(object,string);

Initializes a new instance of the DataEngine class with a connection string.

[Visual Basic] Public Sub New(String)

[C#] public DataEngine(string);

Initializes a new instance of the DataEngine class with a ConnectionString and SqlStatement.

[Visual Basic] Public Sub New(String,String)

[C#] public DataEngine(string,string);

Initializes a new instance of the DataEngine class with a ConnectionString, SqlStatement, and DataFields.

[Visual Basic] Public Sub New(String,String,String)

[C#] public DataEngine(string,string,string);

Initializes a new instance of the DataEngine class with a ConnectionString, SqlStatement, and DateGrouping.

[Visual Basic] Public Sub New(String,String,TimeInterval)

[C#] public DataEngine(string,string,TimeInterval);

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataEngine Constructor()

Initializes a new instance of the DataEngine class.

[Visual Basic]
Public Function New()
[C#]
public DataEngine();

See Also

DataEngine Class | DataEngine Members | Overload List


DataEngine Constructor(Object)

DataEngine Class | DataEngine Members | Overload List

Language

Visual Basic

C#

Show All

dataObj
Supported Data Objects

DataSet

DataTable

DataView

OleDbDataReader

SqlDataReader

IDataReader

String (xml file name)

See Also Languages dotnetCHARTING Send comments on this topic.

DataEngine Constructor(Object)

Initializes a new instance of the DataEngine class with a data object.

[Visual Basic]
Public Function New( _
   ByVal dataObj As Object _
)
[C#]
public DataEngine(
   object dataObj
);

Parameters

dataObj
Supported Data Objects

DataSet

DataTable

DataView

OleDbDataReader

SqlDataReader

IDataReader

String (xml file name)

See Also

DataEngine Class | DataEngine Members | Overload List


DataEngine Constructor(Object,String)

DataEngine Class | DataEngine Members | Overload List

Language

Visual Basic

C#

Show All

dataObj
Supported Data Objects

DataSet

DataTable

DataView

OleDbDataReader

SqlDataReader

IDataReader

String (xml file name)

dataFields
See Gettings Started > Tutorials > Data Fields
See Also Languages dotnetCHARTING Send comments on this topic.

DataEngine Constructor(Object,String)

Initializes a new instance of the DataEngine class with a data object and mapped DataFields.

[Visual Basic]
Public Function New( _
   ByVal dataObj As Object, _
   ByVal dataFields As String _
)
[C#]
public DataEngine(
   object dataObj,
   string dataFields
);

Parameters

dataObj
Supported Data Objects

DataSet

DataTable

DataView

OleDbDataReader

SqlDataReader

IDataReader

String (xml file name)

dataFields
See Gettings Started > Tutorials > Data Fields

See Also

DataEngine Class | DataEngine Members | Overload List


DataEngine Constructor(String)

DataEngine Class | DataEngine Members | Overload List

Language

Visual Basic

C#

Show All

conn
Initial connection string.
See Also Languages dotnetCHARTING Send comments on this topic.

DataEngine Constructor(String)

Initializes a new instance of the DataEngine class with a connection string.

[Visual Basic]
Public Function New( _
   ByVal conn As String _
)
[C#]
public DataEngine(
   string conn
);

Parameters

conn
Initial connection string.

See Also

DataEngine Class | DataEngine Members | Overload List


DataEngine Constructor(String,String)

DataEngine Class | DataEngine Members | Overload List

Language

Visual Basic

C#

Show All

conn
sqlStatement
See Also Languages dotnetCHARTING Send comments on this topic.

DataEngine Constructor(String,String)

Initializes a new instance of the DataEngine class with a ConnectionString and SqlStatement.

[Visual Basic]
Public Function New( _
   ByVal conn As String, _
   ByVal sqlStatement As String _
)
[C#]
public DataEngine(
   string conn,
   string sqlStatement
);

Parameters

conn
sqlStatement

See Also

DataEngine Class | DataEngine Members | Overload List


DataEngine Constructor(String,String,String)

DataEngine Class | DataEngine Members | Overload List

Language

Visual Basic

C#

Show All

conn
Connection String
sqlStatement
Sql statement
dataFields
Data fields
See Also Languages dotnetCHARTING Send comments on this topic.

DataEngine Constructor(String,String,String)

Initializes a new instance of the DataEngine class with a ConnectionString, SqlStatement, and DataFields.

[Visual Basic]
Public Function New( _
   ByVal conn As String, _
   ByVal sqlStatement As String, _
   ByVal dataFields As String _
)
[C#]
public DataEngine(
   string conn,
   string sqlStatement,
   string dataFields
);

Parameters

conn
Connection String
sqlStatement
Sql statement
dataFields
Data fields

See Also

DataEngine Class | DataEngine Members | Overload List


DataEngine Constructor(String,String,TimeInterval)

DataEngine Class | DataEngine Members | Overload List

Language

Visual Basic

C#

Show All

conn
Connection String
sqlStatement
Sql statement
dateGrouping
DateGrouping
See Also Languages dotnetCHARTING Send comments on this topic.

DataEngine Constructor(String,String,TimeInterval)

Initializes a new instance of the DataEngine class with a ConnectionString, SqlStatement, and DateGrouping.

[Visual Basic]
Public Function New( _
   ByVal conn As String, _
   ByVal sqlStatement As String, _
   ByVal dateGrouping As TimeInterval _
)
[C#]
public DataEngine(
   string conn,
   string sqlStatement,
   TimeInterval dateGrouping
);

Parameters

conn
Connection String
sqlStatement
Sql statement
dateGrouping
DateGrouping

See Also

DataEngine Class | DataEngine Members | Overload List


DataEngine Class Methods

DataEngine Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

DataEngine Class Members

For a list of all members of this type, see DataEngine members.

Public Methods

Public Method AddParameter | Adds a stored procedure when to use in conjunction with StoredProcedure.
Public Method GetFinancialSeries | See GetSeries.
Public Method GetSeries | Overloaded.

See Also

DataEngine Class | dotnetCHARTING Namespace


AddParameter Method

DataEngine Class | DataEngine Members

Language

Visual Basic

C#

Show All

paramName
String specifying the parameter name.
paramValue
String pecifying the parameter value.
paramType
A FieldType enumeration specifying the parameter type.
See Also Languages dotnetCHARTING Send comments on this topic.

AddParameter Method

Adds a stored procedure when to use in conjunction with StoredProcedure.

[Visual Basic]
Public Sub AddParameter( _
   ByVal paramName As String, _
   ByVal paramValue As String, _
   ByVal paramType As FieldType _
)
[C#]
public void AddParameter(
   string paramName,
   string paramValue,
   FieldType paramType
);

Parameters

paramName
String specifying the parameter name.
paramValue
String pecifying the parameter value.
paramType
A FieldType enumeration specifying the parameter type.

Remarks

This method is optionally used in conjunction with the StoredProcedure property to specify any number of parameters for the stored proc. A number of field types are supported. de.AddParameter("MyParameter","MyValue",FieldType.Text)

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetFinancialSeries Method

See GetSeries.

[Visual Basic]
Public Function GetFinancialSeries() As SeriesCollection
[C#]
public SeriesCollection GetFinancialSeries();

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetSeries Method

Overload List

Initiates data acquisition and processing based on the specified data engine settings.

[Visual Basic] Overloads Public Function GetSeries() As SeriesCollection

[C#] public SeriesCollection GetSeries();

Initiates data acquisition and processing based on the specified data object.

[Visual Basic] Overloads Public Function GetSeries(Object) As SeriesCollection

[C#] public SeriesCollection GetSeries(object);

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetSeries() Method

Initiates data acquisition and processing based on the specified data engine settings.

[Visual Basic]
Overloads Public Function GetSeries() As SeriesCollection
[C#]
public SeriesCollection GetSeries();

Return Type

A SeriesCollection containting the resulting chart data.

Remarks

When ChartType is set to Financial and DateGrouping is specified, high, low, open, and close element values will be calculated based on the price field. Otherwise they will not be generated.

See Also

DataEngine Class | DataEngine Members | Overload List


GetSeries(Object) Method

DataEngine Class | DataEngine Members | Overload List

Language

Visual Basic

C#

Show All

dataObj
A data object.
See Also Languages dotnetCHARTING Send comments on this topic.

GetSeries(Object) Method

Initiates data acquisition and processing based on the specified data object.

[Visual Basic]
Overloads Public Function GetSeries( _
   ByVal dataObj As Object _
) As SeriesCollection
[C#]
public SeriesCollection GetSeries(
   object dataObj
);

Parameters

dataObj
A data object.

Return Type

A SeriesCollection containting the resulting chart data.

See Also

DataEngine Class | DataEngine Members | Overload List


DataEngine Class Properties

DataEngine Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

DataEngine Class Members

For a list of all members of this type, see DataEngine members.

Public Properties

Public Property ChartObject | Sets the Chart object.
Public Property ChartType | Gets or sets the ChartType enumeration that sets the default DataFields for each type.
Public Property CommandTimeout | Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Public Property ConnectionString | Gets or sets the string used to open a SQL Server, Access, or Excel database.
Public Property CultureName | Gets or sets the culture name used when element names are populated with values such as dates.
Public Property Data | Gets or sets a DataTable, DataSet, DataView, OleDbDataReader, SqlDataReader, IDataReader, XML file name, or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.
Public Property DatabaseCultureName | Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.
Public Property DataFields | Gets or sets a value that specifies the 'database column' to 'element value' relationship.
Public Property DateGrouping | Gets or sets the date grouping of data returned from your database.
Public Property DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property EndDate | Gets or sets the ending date used with SqlStatement to query filtered data from a database.
Public Property ErrorMessage | Gets an error message which will be available if this DataEngine instance fails after a call to GetSeries().
Public Property FormatString | Gets or sets the format string used when element names are populated with values such as dates.
Public Property Limit | Gets or sets the limit number of elements returned for each series when data is generated. Gets or sets the limit number of elements returned for each series when data is generated. This property determines the number of elements to include in the limited return. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group position and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum elements.
Public Property LimitMode | Determine the type of limitation. Default is Top.
Public Property LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property OtherElementLabel | Gets or sets the label used for the element or series created when using Limit or SplitByLimit and setting ShowOther to true.
Public Property ParameterCollection | Gets or sets a collection of Parameter objects used in conjunction with the StoredProcedure property.
Public Property PopulateDateGroupingSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to !:SubValues or not. By default, such values are not added to the element subvalues.
Public Property ShowOther | Gets or sets a value that indicates whether the additional series not shown due to the use of SplitByLimit, or elements not shown due to the use of Limit, are aggregated into a single series or element.
Public Property SplitByLimit | Gets or sets the number of series created using SplitBy.
Public Property SqlStatement | The SQL statement used to obtain the charting data.
Public Property StartDate | Gets or sets the starting date used with SqlStatement to query filtered data from a database.
Public Property StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property StartDayOfWeek | Gets or sets a DayOfWeek enumeration that determines the day which will be used as the starting day of the week for the dategrouping functionality.
Public Property StoredProcedure | This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.

See Also

DataEngine Class | dotnetCHARTING Namespace


ChartObject Property

DataEngine Class | DataEngine Members

Language

Visual Basic

C#

Show All

value
See Also Languages dotnetCHARTING Send comments on this topic.

ChartObject Property

Sets the Chart object.

[Visual Basic]
Public WriteOnly Property ChartObject( _
   ByVal value As Chart _
)
[C#]
public void ChartObject(
   Chart value
); {set;}

Parameters

value

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChartType Property

Gets or sets the ChartType enumeration that sets the default DataFields for each type.

[Visual Basic]
Public Property ChartType As ChartType
[C#]
public ChartType ChartType {get; set;}

Remarks

See Getting Started > Tutorials > DataFields for more info.

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CommandTimeout Property

Gets or sets the wait time before terminating the attempt to execute a command and generating an error.

[Visual Basic]
Public Property CommandTimeout As Integer
[C#]
public int CommandTimeout {get; set;}

Remarks

The time (in seconds) to wait for the command to execute. The default value is 30 seconds.

Example

The follwoing example set the command timeout to 45 seconds.

[C#]

de.CommandTimeout=45;

[Visual Basic]

de.CommandTimeout=45

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ConnectionString Property

Gets or sets the string used to open a SQL Server, Access, or Excel database.

[Visual Basic]
Public Property ConnectionString As String
[C#]
public string ConnectionString {get; set;}

Remarks

Access, Excel and SQL server are supported and automatically detected based on the connection string specified.
See Getting Started > Tutorials > Connecting to data.

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CultureName Property

Gets or sets the culture name used when element names are populated with values such as dates.

[Visual Basic]
Public Property CultureName As String
[C#]
public string CultureName {get; set;}

Remarks

See the CultureInfo class for possible names of a culture.

Example

[C#]

Chart.CultureName = "en-GB";

[Visual Basic]

Chart.CultureName = "en-GB"

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Data Property

Gets or sets a DataTable, DataSet, DataView, OleDbDataReader, SqlDataReader, IDataReader, XML file name, or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.

[Visual Basic]
Public Property Data As Object
[C#]
public object Data {get; set;}

Remarks

When not connecting to a database directly using ConnectionString and SqlStatement, this property offers an alternative method for obtaining database data.

Example

This example sets the data property to a dataTable and defines data fields mapping.

[C#]

DataEngine de = new DataEngine();
de.Data = myDataTable;
de.DataFields = "XAxis=FirstCol,YAxis=SecondCol";
Chart.SeriesCollection.Add(de.GetSeries());

[Visual Basic]

Dim de As New DataEngine()
de.Data = myDataTable
de.DataFields = "XAxis=FirstCol,YAxis=SecondCol"
Chart.SeriesCollection.Add(de.GetSeries())

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DatabaseCultureName Property

Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.

[Visual Basic]
Public Property DatabaseCultureName As String
[C#]
public string DatabaseCultureName {get; set;}

Remarks

See the CultureInfo class for possible names of a culture.

Example

[C#]

de.DataBaseCultureName = "en-GB";

[Visual Basic]

de.DataBaseCultureName = "en-GB"

See Also

DataEngine Class | DataEngine Members


DataFields Property

DataEngine Class | DataEngine Members

Language

Visual Basic

C#

Show All

value
See Also Languages dotnetCHARTING Send comments on this topic.

DataFields Property

Gets or sets a value that specifies the 'database column' to 'element value' relationship.

[Visual Basic]
Public WriteOnly Property DataFields( _
   ByVal value As String _
)
[C#]
public void DataFields(
   string value
); {set;}

Parameters

value

Remarks

See Getting Started > Tutorials > Data Fields for more info.

Example

[C#]

de.DataFields="xAxis=field1,yAxis=field2,splitby=field3,bubblesize=field4";

[Visual Basic]

de.DataFields="xAxis=field1,yAxis=field2,splitby=field3,bubblesize=field4"

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DateGrouping Property

Gets or sets the date grouping of data returned from your database.

[Visual Basic]
Public Property DateGrouping As TimeInterval
[C#]
public TimeInterval DateGrouping {get; set;}

Remarks

Controls how the values of a given series are grouped by date. In order to use this option the first column returned by the SqlStatement must be a date/time. Options include Minutes, Hours, Days, Weeks, Months, Quarters and Years where any StartDate and EndDate can be used and the chart will show all values sequentially. There are additional options for Hour/Minute, Day/Hour, Week/Day, Month/Day, Year/Quarter and Year/Month in these cases there are 2 special considerations 1) only a single day / week / month / or year is charted and 2) if the date range is greater than the period type (e.g. 1 day / 1 week / 1 month / 1 year) values are totalled over that period. There are also shortcuts for the grouping cases of Hour (Hours/Minute), Day (Day/Hour), Week(Week/Day), Month (Month/Day) and Year (Year/Month). See all time interval options. This feature automatically groups multiple data points over a given date range into the specific date grouping you select. When DateGrouping is enabled you must ensure that each series within a given chart returns date/time data for the first column returned by the SqlStatement.
Controls how the values of a given series are grouped by date. In order to use this option the first column returned by the SqlStatement must be a date/time. Options include Minutes, Hours, Days, Weeks, Months, Quarters and Years where any StartDate and EndDate can be used and the chart will show all values sequentially. There are additional options for Hour/Minute, Day/Hour, Week/Day, Month/Day, Year/Quarter and Year/Month in these cases there are 2 special considerations 1) only a single day / week / month / or year is charted and 2) if the date range is greater than the period type (e.g. 1 day / 1 week / 1 month / 1 year) values are totalled over that period. There are also shortcuts for the grouping cases of Hour (Hours/Minute), Day (Day/Hour), Week(Week/Day), Month (Month/Day) and Year (Year/Month). See all time interval options. This feature automatically groups multiple data points over a given date range into the specific date grouping you select. When DateGrouping is enabled you must ensure that each series within a given chart returns date/time data for the first column returned by the SqlStatement.

See Getting Started > Tutorials > Data Engine

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members | DateGrouping Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DateGroupingCalculation Property

Gets or sets an enum which determines how values are grouped to create a single element value.

[Visual Basic]
Public Property DateGroupingCalculation As Calculation
[C#]
public Calculation DateGroupingCalculation {get; set;}

Remarks

When dategrouping is used, if an element has more than one value, a Calculation is performed on those values.

See Also

DataEngine Class | DataEngine Members | DateGrouping Property


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DateGroupingSort Property

Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.

[Visual Basic]
Public Property DateGroupingSort As Boolean
[C#]
public bool DateGroupingSort {get; set;}

Remarks

When dategrouping is used and StartDate or EndDate is not set, the data is sorted by the xAxis field by default. Setting this property to true will maintain the sort order of the data as it is provided.

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DrillDownIntoSeries Property

When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.

[Visual Basic]
Public Property DrillDownIntoSeries As Boolean
[C#]
public bool DrillDownIntoSeries {get; set;}

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members | SqlStatement

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

EndDate Property

Gets or sets the ending date used with SqlStatement to query filtered data from a database.

[Visual Basic]
Public Property EndDate As Date
[C#]
public DateTime EndDate {get; set;}

Remarks

This property is used for the SqlStatement property where the #EndDate# token is replaced with the value set to this property.

See: Getting Started > Tutorials > Data Engine

Example

[C#]

de.EndDate = new DateTime(2004,12,30);

[Visual Basic]

de.EndDate = new DateTime(2004,12,30)

See Also

DataEngine Class | DataEngine Members | SqlStatement


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorMessage Property

Gets an error message which will be available if this DataEngine instance fails after a call to GetSeries().

[Visual Basic]
Public ReadOnly Property ErrorMessage As String
[C#]
public string ErrorMessage {get;}

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FormatString Property

Gets or sets the format string used when element names are populated with values such as dates.

[Visual Basic]
Public Property FormatString As String
[C#]
public string FormatString {get; set;}

Remarks

This property usually used with conjunction of date grouping. If it doesn't set, use an appropriate format for the date grouping. For format information see DateTimeFormatInfo or NumberFormatInfo

Example

The following example shows the tick labels in xAxis as full month name.

[C#]

de.FormatString ="MMMM";

[Visual Basic]

de.FormatString ="MMMM"

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members | LimitMode Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Limit Property

Gets or sets the limit number of elements returned for each series when data is generated. Gets or sets the limit number of elements returned for each series when data is generated. This property determines the number of elements to include in the limited return. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group position and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum elements.

[Visual Basic]
Public Property Limit As String
[C#]
public string Limit {get; set;}

Remarks

If DateGrouping is used, limit has no effect. In such a case, StartDate and EndDate must be used to limit the generated element count.

See Getting Started > Tutorials > Data Engine.

Example

[C#]

de.Limit="3";
de.Limit="2x3";

[Visual Basic]

de.Limit="3"
de.Limit="2x3"

See Also

DataEngine Class | DataEngine Members | LimitMode Property


DataEngine Class | DataEngine Members | Limit Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LimitMode Property

Determine the type of limitation. Default is Top.

[Visual Basic]
Public Property LimitMode As LimitMode
[C#]
public LimitMode LimitMode {get; set;}

Remarks

This property works in conjunction with Limit or SplitByLimit to determine which elements or series should be included or excluded.

Example

[C#]

de.LimitMode =<see cref="LimitMode">LimitMode</see>.Bottom;

[Visual Basic]

de.LimitMode =<see cref="LimitMode">LimitMode</see>.Bottom

See Also

DataEngine Class | DataEngine Members | Limit Property


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LimitPrimarySeries Property

In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.

[Visual Basic]
Public Property LimitPrimarySeries As String
[C#]
public string LimitPrimarySeries {get; set;}

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

OtherElementLabel Property

Gets or sets the label used for the element or series created when using Limit or SplitByLimit and setting ShowOther to true.

[Visual Basic]
Public Property OtherElementLabel As String
[C#]
public string OtherElementLabel {get; set;}

Remarks

See Getting Started > Tutorials > Data Engine for more info.

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members | AddParameter Method | StoredProcedure Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ParameterCollection Property

Gets or sets a collection of Parameter objects used in conjunction with the StoredProcedure property.

[Visual Basic]
Public Property ParameterCollection As ParameterCollection
[C#]
public ParameterCollection ParameterCollection {get; set;}

See Also

DataEngine Class | DataEngine Members | AddParameter Method | StoredProcedure Property


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PopulateDateGroupingSubValues Property

When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to !:SubValues or not. By default, such values are not added to the element subvalues.

[Visual Basic]
Public Property PopulateDateGroupingSubValues As Boolean
[C#]
public bool PopulateDateGroupingSubValues {get; set;}

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ShowOther Property

Gets or sets a value that indicates whether the additional series not shown due to the use of SplitByLimit, or elements not shown due to the use of Limit, are aggregated into a single series or element.

[Visual Basic]
Public Property ShowOther As Boolean
[C#]
public bool ShowOther {get; set;}

Remarks

See Gettings Started > Tutorials > Data Engine for more info.

The default is false.

Example

[C#]

de.ShowOther=true;

[Visual Basic]

de.ShowOther=true

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members | LimitMode Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SplitByLimit Property

Gets or sets the number of series created using SplitBy.

[Visual Basic]
Public Property SplitByLimit As String
[C#]
public string SplitByLimit {get; set;}

Remarks

This property works with conjunction of LimitMode property and determines the number of series to include in the return. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group positon and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum series.

See Getting Started > Tutorials > Data Engine.

Example

[C#]

de.SplitByLimit="3";
de.SplitByLimit="2x3";

[Visual Basic]

de.SplitByLimit="3";
de.SplitByLimit="2x3";

See Also

DataEngine Class | DataEngine Members | LimitMode Property


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SqlStatement Property

The SQL statement used to obtain the charting data.

[Visual Basic]
Public Property SqlStatement As String
[C#]
public string SqlStatement {get; set;}

Remarks

The first column returned is used for the X values, and the second for the Y values. The first also has special handling if dates are returned as the DateGrouping property can be used for intelligent date handling and grouping. The third column is optional and is used only for SplitBy. When a third column is set it is used automatically to create a unique series based on each unique value in this column.

NOTE: All date values in your SQL statements should be wrapped with the pound symbol: #10/25/2002#, regardless if Access or SQL server is used. Also the #StartDate# and #EndDate# tokens can be used in which case the dates set for these properties will be set in place of the tokens before the SqlStatement is executed.

See Getting Started > Tutorials > Queries for more info.

Example

[C#]

de.Series.SqlStatement = "SELECT OrderDate,Total FROM Orders";

//If you are doing a SplitBy you would need another field to correspond to your SplitBy value i.e.
de.Series.SqlStatement = "SELECT OrderDate,Total,Customer FROM Orders";

[Visual Basic]

de.Series.SqlStatement = "SELECT OrderDate,Total FROM Orders"

'If you are doing a SplitBy you would need another field To correspond To your SplitBy value i.e.
de.Series.SqlStatement = "SELECT OrderDate,Total,Customer FROM Orders"

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members | SqlStatement

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StartDate Property

Gets or sets the starting date used with SqlStatement to query filtered data from a database.

[Visual Basic]
Public Property StartDate As Date
[C#]
public DateTime StartDate {get; set;}

Remarks

This property is used for the SqlStatement property where the #StartDate# token is replaced with the value set to this property.

See: Getting Started > Tutorials > Data Engine

Example

[C#]

de.StartDate = new DateTime(2004,12,10);

[Visual Basic]

de.StartDate = new DateTime(2004,12,10)

See Also

DataEngine Class | DataEngine Members | SqlStatement


DataEngine Class | DataEngine Members | DateGrouping Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StartDateOfYear Property

Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.

[Visual Basic]
Public Property StartDateOfYear As Date
[C#]
public DateTime StartDateOfYear {get; set;}

Remarks

This property determine the start month of the year. The default is January.

Example

This example change the year duration from Jan-Dec to Mar-Feb. Beside month, other values are ignored.

[C#]

de.StartDateOfYear = new DateTime(2004,3,1);

[Visual Basic]

de.StartDateOfYear = New DateTime(2004, 3, 1)

See Also

DataEngine Class | DataEngine Members | DateGrouping Property


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StartDayOfWeek Property

Gets or sets a DayOfWeek enumeration that determines the day which will be used as the starting day of the week for the dategrouping functionality.

[Visual Basic]
Public Property StartDayOfWeek As DayOfWeek
[C#]
public DayOfWeek StartDayOfWeek {get; set;}

Remarks

This property used with conjunction of date grouping by weeks. The default is Sunday.

Example

[C#]

de.DateGrouping = TimeInterval.Weeks;
de.StartDayOfWeek = DayOfWeek.Monday;

[Visual Basic]

de.DateGrouping = TimeInterval.Weeks
de.StartDayOfWeek = DayOfWeek.Monday

See Also

DataEngine Class | DataEngine Members


DataEngine Class | DataEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StoredProcedure Property

This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.

[Visual Basic]
Public Property StoredProcedure As String
[C#]
public string StoredProcedure {get; set;}

Remarks

Stored Procedures also work with parameters, see the AddParameter method.
See Getting Started > Tutorials > Connecting to Data for more info.

See Also

DataEngine Class | DataEngine Members


DataSource Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataSource Class

Represents a single or related set of .netCHARTING data-based objects that specify a data source used to parse tokens and populate custom legend boxes with LegendEntry objects.

For a list of all members of this type, see DataSource members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.DataSource

Syntax

[Visual Basic]
Public Class DataSource
[C#]
public class DataSource

See Also

DataSource Members | dotnetCHARTING Namespace


DataSource Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

DataSource Class Members

DataSource overview

Public Properties

Public Property Axis |
Public Property AxisMarker |
Public Property Element |
Public Property GroupIndex |
Public Property ScaleRange |
Public Property Series |
Public Property SeriesCollection |
Public Property SplitInto | Specifies the type of DataSource to split this data source into when it is used to populate a legend box.
Public Property Type |

Public Methods

Public Method static (Shared in Visual Basic) FromAxisMarker | Creates an AxisMarker DataSource object from an AxisMarker object.
Public Method static (Shared in Visual Basic) FromElement | Overloaded.
Public Method static (Shared in Visual Basic) FromElementGroup | Overloaded.
Public Method static (Shared in Visual Basic) FromScaleRange | Creates a DataSource object from an ScaleRange object.
Public Method static (Shared in Visual Basic) FromSeries | Overloaded.
Public Method static (Shared in Visual Basic) FromSeriesCollection | Overloaded.
Public Method static (Shared in Visual Basic) op_Implicit | Overloaded.

See Also

DataSource Class | dotnetCHARTING Namespace


DataSource Class Methods

DataSource Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

DataSource Class Members

For a list of all members of this type, see DataSource members.

Public Methods

Public Method static (Shared in Visual Basic) FromAxisMarker | Creates an AxisMarker DataSource object from an AxisMarker object.
Public Method static (Shared in Visual Basic) FromElement | Overloaded.
Public Method static (Shared in Visual Basic) FromElementGroup | Overloaded.
Public Method static (Shared in Visual Basic) FromScaleRange | Creates a DataSource object from an ScaleRange object.
Public Method static (Shared in Visual Basic) FromSeries | Overloaded.
Public Method static (Shared in Visual Basic) FromSeriesCollection | Overloaded.
Public Method static (Shared in Visual Basic) op_Implicit | Overloaded.

See Also

DataSource Class | dotnetCHARTING Namespace


FromAxisMarker Method

DataSource Class | DataSource Members

Language

Visual Basic

C#

Show All

sourceAxis
Axis containing the axis marker.
sourceMarker
See Also Languages dotnetCHARTING Send comments on this topic.

FromAxisMarker Method

Creates an AxisMarker DataSource object from an AxisMarker object.

[Visual Basic]
Public Shared Function FromAxisMarker( _
   ByVal sourceAxis As Axis, _
   ByVal sourceMarker As AxisMarker _
) As DataSource
[C#]
public static DataSource FromAxisMarker(
   Axis sourceAxis,
   AxisMarker sourceMarker
);

Parameters

sourceAxis
Axis containing the axis marker.
sourceMarker

See Also

DataSource Class | DataSource Members


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FromElement Method

Overload List

Creates a DataSource object from an element Element.

[Visual Basic] Overloads Public Shared Function FromElement(Element) As DataSource

[C#] public static DataSource FromElement(Element);

Creates a DataSource object class from a SeriesColleciton, Series, and Element.

[Visual Basic] Overloads Public Shared Function FromElement(SeriesCollection,Integer,Integer) As DataSource

[C#] public static DataSource FromElement(SeriesCollection,int,int);

Creates a DataSource object from a SeriesColleciton, Series, and Element.

[Visual Basic] Overloads Public Shared Function FromElement(SeriesCollection,Integer,Integer,DataSourceType) As DataSource

[C#] public static DataSource FromElement(SeriesCollection,int,int,DataSourceType);

Creates a DataSource object from a SeriesColleciton, Series, and Element.

[Visual Basic] Overloads Public Shared Function FromElement(SeriesCollection,Integer,String) As DataSource

[C#] public static DataSource FromElement(SeriesCollection,int,string);

Creates a DataSource object from a SeriesColleciton, Series, and Element.

[Visual Basic] Overloads Public Shared Function FromElement(SeriesCollection,Integer,String,DataSourceType) As DataSource

[C#] public static DataSource FromElement(SeriesCollection,int,string,DataSourceType);

Creates a DataSource object from a SeriesColleciton, Series, and Element.

[Visual Basic] Overloads Public Shared Function FromElement(SeriesCollection,String,String) As DataSource

[C#] public static DataSource FromElement(SeriesCollection,string,string);

Creates a DataSource object from a SeriesColleciton, Series, and Element.

[Visual Basic] Overloads Public Shared Function FromElement(SeriesCollection,String,String,DataSourceType) As DataSource

[C#] public static DataSource FromElement(SeriesCollection,string,string,DataSourceType);

See Also

DataSource Class | DataSource Members


FromElement(Element) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

e
The element.
See Also Languages dotnetCHARTING Send comments on this topic.

FromElement(Element) Method

Creates a DataSource object from an element Element.

[Visual Basic]
Overloads Public Shared Function FromElement( _
   ByVal e As Element _
) As DataSource
[C#]
public static DataSource FromElement(
   Element e
);

Parameters

e
The element.

See Also

DataSource Class | DataSource Members | Overload List


FromElement(SeriesCollection,Int32,Int32) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementIndex
Index of the element in the specified series.
See Also Languages dotnetCHARTING Send comments on this topic.

FromElement(SeriesCollection,Int32,Int32) Method

Creates a DataSource object class from a SeriesColleciton, Series, and Element.

[Visual Basic]
Overloads Public Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer, _
   ByVal sourceElementIndex As Integer _
) As DataSource
[C#]
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex,
   int sourceElementIndex
);

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementIndex
Index of the element in the specified series.

See Also

DataSource Class | DataSource Members | Overload List


FromElement(SeriesCollection,Int32,Int32,DataSourceType) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementIndex
Index of the element in the specified series.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
See Also Languages dotnetCHARTING Send comments on this topic.

FromElement(SeriesCollection,Int32,Int32,DataSourceType) Method

Creates a DataSource object from a SeriesColleciton, Series, and Element.

[Visual Basic]
Overloads Public Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer, _
   ByVal sourceElementIndex As Integer, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
[C#]
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex,
   int sourceElementIndex,
   DataSourceType splitIntoType
);

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementIndex
Index of the element in the specified series.
splitIntoType
Split into type when this DataSource is used to populate a legend box.

See Also

DataSource Class | DataSource Members | Overload List


FromElement(SeriesCollection,Int32,String) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementName
Name of the given element.
See Also Languages dotnetCHARTING Send comments on this topic.

FromElement(SeriesCollection,Int32,String) Method

Creates a DataSource object from a SeriesColleciton, Series, and Element.

[Visual Basic]
Overloads Public Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer, _
   ByVal sourceElementName As String _
) As DataSource
[C#]
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex,
   string sourceElementName
);

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementName
Name of the given element.

See Also

DataSource Class | DataSource Members | Overload List


FromElement(SeriesCollection,Int32,String,DataSourceType) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementName
Name of the given element.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
See Also Languages dotnetCHARTING Send comments on this topic.

FromElement(SeriesCollection,Int32,String,DataSourceType) Method

Creates a DataSource object from a SeriesColleciton, Series, and Element.

[Visual Basic]
Overloads Public Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer, _
   ByVal sourceElementName As String, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
[C#]
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex,
   string sourceElementName,
   DataSourceType splitIntoType
);

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementName
Name of the given element.
splitIntoType
Split into type when this DataSource is used to populate a legend box.

See Also

DataSource Class | DataSource Members | Overload List


FromElement(SeriesCollection,String,String) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesName
Name of the series that contains the given element.
sourceElementName
Name of the given element.
See Also Languages dotnetCHARTING Send comments on this topic.

FromElement(SeriesCollection,String,String) Method

Creates a DataSource object from a SeriesColleciton, Series, and Element.

[Visual Basic]
Overloads Public Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesName As String, _
   ByVal sourceElementName As String _
) As DataSource
[C#]
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   string sourceSeriesName,
   string sourceElementName
);

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesName
Name of the series that contains the given element.
sourceElementName
Name of the given element.

See Also

DataSource Class | DataSource Members | Overload List


FromElement(SeriesCollection,String,String,DataSourceType) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesName
Name of the series that contains the given element.
sourceElementName
Name of the given element.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
See Also Languages dotnetCHARTING Send comments on this topic.

FromElement(SeriesCollection,String,String,DataSourceType) Method

Creates a DataSource object from a SeriesColleciton, Series, and Element.

[Visual Basic]
Overloads Public Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesName As String, _
   ByVal sourceElementName As String, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
[C#]
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   string sourceSeriesName,
   string sourceElementName,
   DataSourceType splitIntoType
);

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesName
Name of the series that contains the given element.
sourceElementName
Name of the given element.
splitIntoType
Split into type when this DataSource is used to populate a legend box.

See Also

DataSource Class | DataSource Members | Overload List


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FromElementGroup Method

Overload List

Creates an Element Group DataSource object from a SeriesColleciton, and Element index.

[Visual Basic] Overloads Public Shared Function FromElementGroup(SeriesCollection,Integer) As DataSource

[C#] public static DataSource FromElementGroup(SeriesCollection,int);

Creates a DataSource object from a SeriesColleciton, and Element index.

[Visual Basic] Overloads Public Shared Function FromElementGroup(SeriesCollection,Integer,DataSourceType) As DataSource

[C#] public static DataSource FromElementGroup(SeriesCollection,int,DataSourceType);

Creates an Element Group DataSource object from a SeriesColleciton, and Element name.

[Visual Basic] Overloads Public Shared Function FromElementGroup(SeriesCollection,String) As DataSource

[C#] public static DataSource FromElementGroup(SeriesCollection,string);

Creates an Element Group DataSource object from a SeriesColleciton, and Element name.

[Visual Basic] Overloads Public Shared Function FromElementGroup(SeriesCollection,String,DataSourceType) As DataSource

[C#] public static DataSource FromElementGroup(SeriesCollection,string,DataSourceType);

See Also

DataSource Class | DataSource Members


FromElementGroup(SeriesCollection,Int32) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupIndex
Index of the element in each series that makes up the group.
See Also Languages dotnetCHARTING Send comments on this topic.

FromElementGroup(SeriesCollection,Int32) Method

Creates an Element Group DataSource object from a SeriesColleciton, and Element index.

[Visual Basic]
Overloads Public Shared Function FromElementGroup( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceGroupIndex As Integer _
) As DataSource
[C#]
public static DataSource FromElementGroup(
   SeriesCollection sourceSeriesCollection,
   int sourceGroupIndex
);

Parameters

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupIndex
Index of the element in each series that makes up the group.

See Also

DataSource Class | DataSource Members | Overload List


FromElementGroup(SeriesCollection,Int32,DataSourceType) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupIndex
Index of the element in each series that makes up the group.
splitIntoType
Name of the given element.
See Also Languages dotnetCHARTING Send comments on this topic.

FromElementGroup(SeriesCollection,Int32,DataSourceType) Method

Creates a DataSource object from a SeriesColleciton, and Element index.

[Visual Basic]
Overloads Public Shared Function FromElementGroup( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceGroupIndex As Integer, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
[C#]
public static DataSource FromElementGroup(
   SeriesCollection sourceSeriesCollection,
   int sourceGroupIndex,
   DataSourceType splitIntoType
);

Parameters

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupIndex
Index of the element in each series that makes up the group.
splitIntoType
Name of the given element.

See Also

DataSource Class | DataSource Members | Overload List


FromElementGroup(SeriesCollection,String) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupName
Index of the element in each series that makes up the group.
See Also Languages dotnetCHARTING Send comments on this topic.

FromElementGroup(SeriesCollection,String) Method

Creates an Element Group DataSource object from a SeriesColleciton, and Element name.

[Visual Basic]
Overloads Public Shared Function FromElementGroup( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceGroupName As String _
) As DataSource
[C#]
public static DataSource FromElementGroup(
   SeriesCollection sourceSeriesCollection,
   string sourceGroupName
);

Parameters

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupName
Index of the element in each series that makes up the group.

See Also

DataSource Class | DataSource Members | Overload List


FromElementGroup(SeriesCollection,String,DataSourceType) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupName
Name of the element in each series that makes up the group.
splitIntoType
Name of the given element.
See Also Languages dotnetCHARTING Send comments on this topic.

FromElementGroup(SeriesCollection,String,DataSourceType) Method

Creates an Element Group DataSource object from a SeriesColleciton, and Element name.

[Visual Basic]
Overloads Public Shared Function FromElementGroup( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceGroupName As String, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
[C#]
public static DataSource FromElementGroup(
   SeriesCollection sourceSeriesCollection,
   string sourceGroupName,
   DataSourceType splitIntoType
);

Parameters

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupName
Name of the element in each series that makes up the group.
splitIntoType
Name of the given element.

See Also

DataSource Class | DataSource Members | Overload List


FromScaleRange Method

DataSource Class | DataSource Members

Language

Visual Basic

C#

Show All

sourceAxis
Axis containing the scale range.
sr
Given ScaleRange object.
See Also Languages dotnetCHARTING Send comments on this topic.

FromScaleRange Method

Creates a DataSource object from an ScaleRange object.

[Visual Basic]
Public Shared Function FromScaleRange( _
   ByVal sourceAxis As Axis, _
   ByVal sr As ScaleRange _
) As DataSource
[C#]
public static DataSource FromScaleRange(
   Axis sourceAxis,
   ScaleRange sr
);

Parameters

sourceAxis
Axis containing the scale range.
sr
Given ScaleRange object.

See Also

DataSource Class | DataSource Members


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FromSeries Method

Overload List

Creates a DataSource object from a Series.

[Visual Basic] Overloads Public Shared Function FromSeries(Series) As DataSource

[C#] public static DataSource FromSeries(Series);

Creates a DataSource object from a SeriesColleciton, and Series.

[Visual Basic] Overloads Public Shared Function FromSeries(SeriesCollection,Integer) As DataSource

[C#] public static DataSource FromSeries(SeriesCollection,int);

Creates a DataSource object from a SeriesColleciton, and Series.

[Visual Basic] Overloads Public Shared Function FromSeries(SeriesCollection,Integer,DataSourceType) As DataSource

[C#] public static DataSource FromSeries(SeriesCollection,int,DataSourceType);

Creates a DataSource object from a SeriesColleciton, and Series.

[Visual Basic] Overloads Public Shared Function FromSeries(SeriesCollection,String) As DataSource

[C#] public static DataSource FromSeries(SeriesCollection,string);

Creates a DataSource object from a SeriesColleciton, and Series.

[Visual Basic] Overloads Public Shared Function FromSeries(SeriesCollection,String,DataSourceType) As DataSource

[C#] public static DataSource FromSeries(SeriesCollection,string,DataSourceType);

See Also

DataSource Class | DataSource Members


FromSeries(Series) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

series
The series.
See Also Languages dotnetCHARTING Send comments on this topic.

FromSeries(Series) Method

Creates a DataSource object from a Series.

[Visual Basic]
Overloads Public Shared Function FromSeries( _
   ByVal series As Series _
) As DataSource
[C#]
public static DataSource FromSeries(
   Series series
);

Parameters

series
The series.

See Also

DataSource Class | DataSource Members | Overload List


FromSeries(SeriesCollection,Int32) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesIndex
Index of the given series.
See Also Languages dotnetCHARTING Send comments on this topic.

FromSeries(SeriesCollection,Int32) Method

Creates a DataSource object from a SeriesColleciton, and Series.

[Visual Basic]
Overloads Public Shared Function FromSeries( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer _
) As DataSource
[C#]
public static DataSource FromSeries(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex
);

Parameters

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesIndex
Index of the given series.

See Also

DataSource Class | DataSource Members | Overload List


FromSeries(SeriesCollection,Int32,DataSourceType) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesIndex
Index of the given series.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
See Also Languages dotnetCHARTING Send comments on this topic.

FromSeries(SeriesCollection,Int32,DataSourceType) Method

Creates a DataSource object from a SeriesColleciton, and Series.

[Visual Basic]
Overloads Public Shared Function FromSeries( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
[C#]
public static DataSource FromSeries(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex,
   DataSourceType splitIntoType
);

Parameters

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesIndex
Index of the given series.
splitIntoType
Split into type when this DataSource is used to populate a legend box.

See Also

DataSource Class | DataSource Members | Overload List


FromSeries(SeriesCollection,String) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesName
Name of the given series.
See Also Languages dotnetCHARTING Send comments on this topic.

FromSeries(SeriesCollection,String) Method

Creates a DataSource object from a SeriesColleciton, and Series.

[Visual Basic]
Overloads Public Shared Function FromSeries( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesName As String _
) As DataSource
[C#]
public static DataSource FromSeries(
   SeriesCollection sourceSeriesCollection,
   string sourceSeriesName
);

Parameters

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesName
Name of the given series.

See Also

DataSource Class | DataSource Members | Overload List


FromSeries(SeriesCollection,String,DataSourceType) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesName
Name of the given series.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
See Also Languages dotnetCHARTING Send comments on this topic.

FromSeries(SeriesCollection,String,DataSourceType) Method

Creates a DataSource object from a SeriesColleciton, and Series.

[Visual Basic]
Overloads Public Shared Function FromSeries( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesName As String, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
[C#]
public static DataSource FromSeries(
   SeriesCollection sourceSeriesCollection,
   string sourceSeriesName,
   DataSourceType splitIntoType
);

Parameters

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesName
Name of the given series.
splitIntoType
Split into type when this DataSource is used to populate a legend box.

See Also

DataSource Class | DataSource Members | Overload List


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FromSeriesCollection Method

Overload List

Creates a DataSource object from a SeriesColleciton.

[Visual Basic] Overloads Public Shared Function FromSeriesCollection(SeriesCollection) As DataSource

[C#] public static DataSource FromSeriesCollection(SeriesCollection);

Creates a DataSource object from a SeriesColleciton.

[Visual Basic] Overloads Public Shared Function FromSeriesCollection(SeriesCollection,DataSourceType) As DataSource

[C#] public static DataSource FromSeriesCollection(SeriesCollection,DataSourceType);

See Also

DataSource Class | DataSource Members


FromSeriesCollection(SeriesCollection) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
Given SeriesCollection.
See Also Languages dotnetCHARTING Send comments on this topic.

FromSeriesCollection(SeriesCollection) Method

Creates a DataSource object from a SeriesColleciton.

[Visual Basic]
Overloads Public Shared Function FromSeriesCollection( _
   ByVal sourceSeriesCollection As SeriesCollection _
) As DataSource
[C#]
public static DataSource FromSeriesCollection(
   SeriesCollection sourceSeriesCollection
);

Parameters

sourceSeriesCollection
Given SeriesCollection.

See Also

DataSource Class | DataSource Members | Overload List


FromSeriesCollection(SeriesCollection,DataSourceType) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sourceSeriesCollection
Given SeriesCollection.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
See Also Languages dotnetCHARTING Send comments on this topic.

FromSeriesCollection(SeriesCollection,DataSourceType) Method

Creates a DataSource object from a SeriesColleciton.

[Visual Basic]
Overloads Public Shared Function FromSeriesCollection( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
[C#]
public static DataSource FromSeriesCollection(
   SeriesCollection sourceSeriesCollection,
   DataSourceType splitIntoType
);

Parameters

sourceSeriesCollection
Given SeriesCollection.
splitIntoType
Split into type when this DataSource is used to populate a legend box.

See Also

DataSource Class | DataSource Members | Overload List


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Implicit Method

Overload List

[Visual Basic] Overloads Public Shared Function op_Implicit(AxisMarker) As DataSource

[C#] public static DataSource op_Implicit(AxisMarker);

[Visual Basic] Overloads Public Shared Function op_Implicit(Element) As DataSource

[C#] public static DataSource op_Implicit(Element);

[Visual Basic] Overloads Public Shared Function op_Implicit(Series) As DataSource

[C#] public static DataSource op_Implicit(Series);

[Visual Basic] Overloads Public Shared Function op_Implicit(SeriesCollection) As DataSource

[C#] public static DataSource op_Implicit(SeriesCollection);

See Also

DataSource Class | DataSource Members


op_Implicit(AxisMarker) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

am
See Also Languages dotnetCHARTING Send comments on this topic.

op_Implicit(AxisMarker) Method

[Visual Basic]
Overloads Public Shared Function op_Implicit( _
   ByVal am As AxisMarker _
) As DataSource
[C#]
public static DataSource op_Implicit(
   AxisMarker am
);

Parameters

am

See Also

DataSource Class | DataSource Members | Overload List


op_Implicit(Element) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

e
See Also Languages dotnetCHARTING Send comments on this topic.

op_Implicit(Element) Method

[Visual Basic]
Overloads Public Shared Function op_Implicit( _
   ByVal e As Element _
) As DataSource
[C#]
public static DataSource op_Implicit(
   Element e
);

Parameters

e

See Also

DataSource Class | DataSource Members | Overload List


op_Implicit(Series) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

s
See Also Languages dotnetCHARTING Send comments on this topic.

op_Implicit(Series) Method

[Visual Basic]
Overloads Public Shared Function op_Implicit( _
   ByVal s As Series _
) As DataSource
[C#]
public static DataSource op_Implicit(
   Series s
);

Parameters

s

See Also

DataSource Class | DataSource Members | Overload List


op_Implicit(SeriesCollection) Method

DataSource Class | DataSource Members | Overload List

Language

Visual Basic

C#

Show All

sc
See Also Languages dotnetCHARTING Send comments on this topic.

op_Implicit(SeriesCollection) Method

[Visual Basic]
Overloads Public Shared Function op_Implicit( _
   ByVal sc As SeriesCollection _
) As DataSource
[C#]
public static DataSource op_Implicit(
   SeriesCollection sc
);

Parameters

sc

See Also

DataSource Class | DataSource Members | Overload List


DataSource Class Properties

DataSource Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

DataSource Class Members

For a list of all members of this type, see DataSource members.

Public Properties

Public Property Axis |
Public Property AxisMarker |
Public Property Element |
Public Property GroupIndex |
Public Property ScaleRange |
Public Property Series |
Public Property SeriesCollection |
Public Property SplitInto | Specifies the type of DataSource to split this data source into when it is used to populate a legend box.
Public Property Type |

See Also

DataSource Class | dotnetCHARTING Namespace


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Axis Property

[Visual Basic]
Public Property Axis As Axis
[C#]
public Axis Axis {get; set;}

See Also

DataSource Class | DataSource Members


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Property

[Visual Basic]
Public Property AxisMarker As AxisMarker
[C#]
public AxisMarker AxisMarker {get; set;}

See Also

DataSource Class | DataSource Members


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Element Property

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}

See Also

DataSource Class | DataSource Members


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GroupIndex Property

[Visual Basic]
Public Property GroupIndex As Integer
[C#]
public int GroupIndex {get; set;}

See Also

DataSource Class | DataSource Members


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ScaleRange Property

[Visual Basic]
Public Property ScaleRange As ScaleRange
[C#]
public ScaleRange ScaleRange {get; set;}

See Also

DataSource Class | DataSource Members


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Series Property

[Visual Basic]
Public Property Series As Series
[C#]
public Series Series {get; set;}

See Also

DataSource Class | DataSource Members


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SeriesCollection Property

[Visual Basic]
Public Property SeriesCollection As SeriesCollection
[C#]
public SeriesCollection SeriesCollection {get; set;}

See Also

DataSource Class | DataSource Members


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SplitInto Property

Specifies the type of DataSource to split this data source into when it is used to populate a legend box.

[Visual Basic]
Public Property SplitInto As DataSourceType
[C#]
public DataSourceType SplitInto {get; set;}

See Also

DataSource Class | DataSource Members


DataSource Class | DataSource Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Type Property

[Visual Basic]
Public Property Type As DataSourceType
[C#]
public DataSourceType Type {get; set;}

See Also

DataSource Class | DataSource Members


Element Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Element Class

Represents a element object or data point on the chart.

For a list of all members of this type, see Element members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.Element

Syntax

[Visual Basic]
Public Class Element
   Implements IInstanceID
[C#]
public class Element : IInstanceID

Remarks

The Element object contains properties that describe it's value such as YValue, YDateTime, BubbleSize etc.. It also defines defines objects and properties that specify the element's behavior and appearance.

Element properties that don't describe it's value can be set simultaneously for all element in a Series by setting them with Series.DefaultElement.___ For example:(Chart.DefaultSeries.DefaultElement.SmartLabel.Text = "YValue").

See also 20Model.html">Data Model Tutorial

See Also

Element Members | dotnetCHARTING Namespace


Element Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Element Class Members

Element overview

Public Constructors

Public Constructor Element Constructor Overloaded.

Public Properties

Public Property Annotation | Gets or sets this element's Annotation.
Public Property AxisMarker | Gets or sets this element's AxisMarker.
Public Property BubbleSize | Gets or sets the bubble size of this element.
Public Property Close | Gets or sets the financial closing price of this element.
Public Property Color | Gets or sets this element's color.
Public Property Complete | Gets or sets the percent complete value of this element.
Public Property CustomAttributes | Gets a collection of custom attributes associated with this element.
Public Property DefaultSubValue | Gets or sets a default SubValue object used to propagate its property settings to all SubValue objects in the SubValues collection.
Public Property ErrorHighValue | Gets of sets the high error value. When set, a single SubValue is drawn above the element's value. When ErrorLowValue is also set, a range SubValue is drawn between the two values.
Public Property ErrorLowValue | Gets of sets the low error value. When set, a single SubValue is drawn below the element's YValue value or range. When ErrorHighValue is also set, a range SubValue is drawn between the two values.
Public Property ErrorMinusOffset | Gets of sets the negative error offset. When set, a single SubValue is drawn below the element's value.
Public Property ErrorMinusPercent | Gets or sets the negative error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn below the element's value. When ErrorPlusPercent is also set, a range SubValue is drawn between the two points.
Public Property ErrorOffset | Gets or sets the error offset. The offset represents a range, +/- the value of the offset with respect to the element's YValue value or range.
Public Property ErrorPercent | Gets or sets the error offset based on the specified percentage of the element's YValue value or range. The offset represents a range, +/- the percentage of the element's YValue value or range.
Public Property ErrorPlusOffset | Gets of sets the positive error offset. When set, a single SubValue is drawn above the element's value.
Public Property ErrorPlusPercent | Gets or sets the positive error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn above the element's value. When ErrorMinusPercent is also set, a range SubValue is drawn between the two points.
Public Property ExplodeSlice | Gets or sets a value indicating whether the pie slice represented by this element is exploded.
Public Property ForceMarker | Gets or sets a value indicating whether this element's ElementMarker is drawn when the parent Series object's SeriesType omits the ElementMarker by default.
Public Property HatchColor | Gets or sets this element's HatchStyle color.
Public Property HatchStyle | Gets or sets this element's hatch style.
Public Property High | Gets or sets the financial high price of this element.
Public Property Hotspot | Gets or sets the Hotspot of this Element.
Public Property InstanceID |
Public Property LabelTemplate | Gets or sets this element's SmartLabel.Text property.
Public Property LegendEntry | Gets or sets this element's LegendEntry.
Public Property Length | Gets or sets a percent value representing this element's needle length.
Public Property Low | Gets or sets the financial low price of this element.
Public Property Marker | Gets or sets this element's Marker.
Public Property Name | Gets or sets this element's name.
Public Property Open | Gets or sets the financial open price of this element.
Public Property Point | Gets the element's pixel coordinate on a chart image.
Public Property SecondaryColor | Gets or sets this element's secondary color.
Public Property ShowValue | Gets or sets a value that indicates whether this element's SmartLabel is visible.
Public Property SmartLabel | Gets or sets this element's SmartLabel.
Public Property SubValues | Gets a collection of SubValue objects drawn on this Element.
Public Property TakeColorFrom | Gets or sets a Series or Element object from which this element's color will be inherited.
Public Property ToolTip | Gets or sets this elements tool tip. (Shortcut to: Element.Hotspot.Tooltip)
Public Property Transparency | Gets or sets the element color's transparency.
Public Property URL | Gets or sets the element's link URL. (Shortcut to: Element.Hotspot.URL)
Public Property URLTarget | Gets or sets the URL target of this element's link URL. (Shortcut to: Element.Hotspot.URLTarget)
Public Property Volume | Gets or sets the financial volume of this element.
Public Property XAxisTick | Gets or sets an AxisTick object that will placed on the x axis at the position of this element's x value. If the x axis is a category axis, AxisTick will not have any effect.
Public Property XDateTime | Gets or sets the X DateTime value of this element.
Public Property XDateTimeStart | Gets or sets the initial X DateTime value of this element.
Public Property XValue | Gets or sets the X value of this element.
Public Property XValueStart | Gets or sets the initial X value of this element.
Public Property YAxisTick | Gets or sets an AxisTick object that will placed on the y axis at the position of this element's y value. If the x axis is a category axis, AxisTick will not have any effect.
Public Property YDateTime | Gets or sets the Y DateTime value of this element.
Public Property YDateTimeStart | Gets or sets the initial Y DateTime value of this element.
Public Property YValue | Gets or sets the y value of this element.
Public Property YValueStart | Gets or sets the initial Y value of this element.

Public Methods

Public Method static (Shared in Visual Basic) Add | Overloaded.
Public Method static (Shared in Visual Basic) Divide | Overloaded.
Public Method static (Shared in Visual Basic) Multiply | Overloaded.
Public Method static (Shared in Visual Basic) op_Addition | Overloaded.
Public Method static (Shared in Visual Basic) op_Division | Overloaded.
Public Method static (Shared in Visual Basic) op_Multiply | Overloaded.
Public Method static (Shared in Visual Basic) op_Subtraction | Overloaded.
Public Method static (Shared in Visual Basic) Subtract | Overloaded.

See Also

Element Class | dotnetCHARTING Namespace


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor

Overload List

Initializes a new instance of the Element class.

[Visual Basic] Public Sub New()

[C#] public Element();

Initialize a new instance of the Element class with (YDateTimeStart, YDateTime) or (XDateTime, YDateTime) as the initial element value types.

[Visual Basic] Public Sub New(String,Date,Date)

[C#] public Element(string,DateTime,DateTime);

Initialize a new instance of the Element class with (YDateTimeStart, YDateTime, Complete) or (XDateTime, YDateTime, BubbleSize) as the initial element value types.

[Visual Basic] Public Sub New(String,Date,Date,Double)

[C#] public Element(string,DateTime,DateTime,double);

Initialize a new instance of the Element class with (XDateTime, YValue) or (XDateTime, Close) as the initial element value types.

[Visual Basic] Public Sub New(String,Date,Double)

[C#] public Element(string,DateTime,double);

Initialize a new instance of the Element class with (XDateTime, YValue, BubbleSize) or (XDateTime, Close, Volume) as the initial element value types.

[Visual Basic] Public Sub New(String,Date,Double,Double)

[C#] public Element(string,DateTime,double,double);

Initialize a new instance of the Element class with (XDateTime, High, Low, Open, Close) as the initial element value types.

[Visual Basic] Public Sub New(String,Date,Double,Double,Double,Double)

[C#] public Element(string,DateTime,double,double,double,double);

Initialize a new instance of the Element class with (XDateTime, High, Low, Open, Close, Volume) as the initial element value types.

[Visual Basic] Public Sub New(String,Date,Double,Double,Double,Double,Double)

[C#] public Element(string,DateTime,double,double,double,double,double);

Initialize a new instance of the Element class with (YValue) as the initial element value type.

[Visual Basic] Public Sub New(String,Double)

[C#] public Element(string,double);

Initialize a new instance of the Element class with (XValue, YDateTime) as the initial element value types.

[Visual Basic] Public Sub New(String,Double,Date)

[C#] public Element(string,double,DateTime);

Initialize a new instance of the Element class with (XValue, YDateTime, BubbleSize) as the initial element value types.

[Visual Basic] Public Sub New(String,Double,Date,Double)

[C#] public Element(string,double,DateTime,double);

Initialize a new instance of the Element class with (YValueStart, YValue) or (XValue, YValue) as the initial element value types.

[Visual Basic] Public Sub New(String,Double,Double)

[C#] public Element(string,double,double);

Initialize a new instance of the Element class with (YValueStart, YValue, Complete) or (XValue, YValue, BubbleSize) as the initial element value types.

[Visual Basic] Public Sub New(String,Double,Double,Double)

[C#] public Element(string,double,double,double);

See Also

Element Class | Element Members


Element Class | Element Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor()

Initializes a new instance of the Element class.

[Visual Basic]
Public Function New()
[C#]
public Element();

See Also

Element Class | Element Members | Overload List


Element Constructor(String,DateTime,DateTime)

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of this element.
dateTime1
Sets YDateTimeStart and XDateTime
dateTime2
Sets YDateTime
See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor(String,DateTime,DateTime)

Initialize a new instance of the Element class with (YDateTimeStart, YDateTime) or (XDateTime, YDateTime) as the initial element value types.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal dateTime2 As Date _
)
[C#]
public Element(
   string name,
   DateTime dateTime1,
   DateTime dateTime2
);

Parameters

name
Name of this element.
dateTime1
Sets YDateTimeStart and XDateTime
dateTime2
Sets YDateTime

See Also

Element Class | Element Members | Overload List


Element Constructor(String,DateTime,DateTime,Double)

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of this element.
dateTime1
Sets YDateTimeStart and XDateTime
dateTime2
Set YDateTime
double1
Sets Complete and BubbleSize
See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor(String,DateTime,DateTime,Double)

Initialize a new instance of the Element class with (YDateTimeStart, YDateTime, Complete) or (XDateTime, YDateTime, BubbleSize) as the initial element value types.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal dateTime2 As Date, _
   ByVal double1 As Double _
)
[C#]
public Element(
   string name,
   DateTime dateTime1,
   DateTime dateTime2,
   double double1
);

Parameters

name
Name of this element.
dateTime1
Sets YDateTimeStart and XDateTime
dateTime2
Set YDateTime
double1
Sets Complete and BubbleSize

See Also

Element Class | Element Members | Overload List


Element Constructor(String,DateTime,Double)

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets YValue and Close
See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor(String,DateTime,Double)

Initialize a new instance of the Element class with (XDateTime, YValue) or (XDateTime, Close) as the initial element value types.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal double1 As Double _
)
[C#]
public Element(
   string name,
   DateTime dateTime1,
   double double1
);

Parameters

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets YValue and Close

See Also

Element Class | Element Members | Overload List


Element Constructor(String,DateTime,Double,Double)

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets Yvalue and Close
double2
Sets BubbleSize and Volume
See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor(String,DateTime,Double,Double)

Initialize a new instance of the Element class with (XDateTime, YValue, BubbleSize) or (XDateTime, Close, Volume) as the initial element value types.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal double1 As Double, _
   ByVal double2 As Double _
)
[C#]
public Element(
   string name,
   DateTime dateTime1,
   double double1,
   double double2
);

Parameters

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets Yvalue and Close
double2
Sets BubbleSize and Volume

See Also

Element Class | Element Members | Overload List


Element Constructor(String,DateTime,Double,Double,Double,Double)

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets High
double2
Sets Low
double3
Sets Open
double4
Sets Close
See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor(String,DateTime,Double,Double,Double,Double)

Initialize a new instance of the Element class with (XDateTime, High, Low, Open, Close) as the initial element value types.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal double1 As Double, _
   ByVal double2 As Double, _
   ByVal double3 As Double, _
   ByVal double4 As Double _
)
[C#]
public Element(
   string name,
   DateTime dateTime1,
   double double1,
   double double2,
   double double3,
   double double4
);

Parameters

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets High
double2
Sets Low
double3
Sets Open
double4
Sets Close

See Also

Element Class | Element Members | Overload List


Element Constructor(String,DateTime,Double,Double,Double,Double,Double)

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets High
double2
Sets Low
double3
Sets Open
double4
Sets Close
double5
Sets Volume
See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor(String,DateTime,Double,Double,Double,Double,Double)

Initialize a new instance of the Element class with (XDateTime, High, Low, Open, Close, Volume) as the initial element value types.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal double1 As Double, _
   ByVal double2 As Double, _
   ByVal double3 As Double, _
   ByVal double4 As Double, _
   ByVal double5 As Double _
)
[C#]
public Element(
   string name,
   DateTime dateTime1,
   double double1,
   double double2,
   double double3,
   double double4,
   double double5
);

Parameters

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets High
double2
Sets Low
double3
Sets Open
double4
Sets Close
double5
Sets Volume

See Also

Element Class | Element Members | Overload List


Element Constructor(String,Double)

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of this element.
double1
Sets YValue
See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor(String,Double)

Initialize a new instance of the Element class with (YValue) as the initial element value type.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal double1 As Double _
)
[C#]
public Element(
   string name,
   double double1
);

Parameters

name
Name of this element.
double1
Sets YValue

See Also

Element Class | Element Members | Overload List


Element Constructor(String,Double,DateTime)

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of this element.
double1
Sets XValue
dateTime1
Sets YDateTime
See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor(String,Double,DateTime)

Initialize a new instance of the Element class with (XValue, YDateTime) as the initial element value types.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal double1 As Double, _
   ByVal dateTime1 As Date _
)
[C#]
public Element(
   string name,
   double double1,
   DateTime dateTime1
);

Parameters

name
Name of this element.
double1
Sets XValue
dateTime1
Sets YDateTime

See Also

Element Class | Element Members | Overload List


Element Constructor(String,Double,DateTime,Double)

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of this element.
double1
Sets XValue
dateTime1
Sets YDateTime
double2
Sets BubbleSize
See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor(String,Double,DateTime,Double)

Initialize a new instance of the Element class with (XValue, YDateTime, BubbleSize) as the initial element value types.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal double1 As Double, _
   ByVal dateTime1 As Date, _
   ByVal double2 As Double _
)
[C#]
public Element(
   string name,
   double double1,
   DateTime dateTime1,
   double double2
);

Parameters

name
Name of this element.
double1
Sets XValue
dateTime1
Sets YDateTime
double2
Sets BubbleSize

See Also

Element Class | Element Members | Overload List


Element Constructor(String,Double,Double)

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of this element.
double1
Sets YValueStart and XValue
double2
Sets YValue
See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor(String,Double,Double)

Initialize a new instance of the Element class with (YValueStart, YValue) or (XValue, YValue) as the initial element value types.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal double1 As Double, _
   ByVal double2 As Double _
)
[C#]
public Element(
   string name,
   double double1,
   double double2
);

Parameters

name
Name of this element.
double1
Sets YValueStart and XValue
double2
Sets YValue

See Also

Element Class | Element Members | Overload List


Element Constructor(String,Double,Double,Double)

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of this element.
double1
Sets YValueStart and XValue
double2
Sets YValue
double3
Sets Complete and BubbleSize
See Also Languages dotnetCHARTING Send comments on this topic.

Element Constructor(String,Double,Double,Double)

Initialize a new instance of the Element class with (YValueStart, YValue, Complete) or (XValue, YValue, BubbleSize) as the initial element value types.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal double1 As Double, _
   ByVal double2 As Double, _
   ByVal double3 As Double _
)
[C#]
public Element(
   string name,
   double double1,
   double double2,
   double double3
);

Parameters

name
Name of this element.
double1
Sets YValueStart and XValue
double2
Sets YValue
double3
Sets Complete and BubbleSize

See Also

Element Class | Element Members | Overload List


Element Class Methods

Element Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Element Class Members

For a list of all members of this type, see Element members.

Public Methods

Public Method static (Shared in Visual Basic) Add | Overloaded.
Public Method static (Shared in Visual Basic) Divide | Overloaded.
Public Method static (Shared in Visual Basic) Multiply | Overloaded.
Public Method static (Shared in Visual Basic) op_Addition | Overloaded.
Public Method static (Shared in Visual Basic) op_Division | Overloaded.
Public Method static (Shared in Visual Basic) op_Multiply | Overloaded.
Public Method static (Shared in Visual Basic) op_Subtraction | Overloaded.
Public Method static (Shared in Visual Basic) Subtract | Overloaded.

See Also

Element Class | dotnetCHARTING Namespace


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

Adds a value to all values of an element.

[Visual Basic] Overloads Public Shared Function Add(Double,Element) As Element

[C#] public static Element Add(double,Element);

Adds a value to all values of an element.

[Visual Basic] Overloads Public Shared Function Add(Element,Double) As Element

[C#] public static Element Add(Element,double);

Adds the values of two elements.

[Visual Basic] Overloads Public Shared Function Add(Element,Element) As Element

[C#] public static Element Add(Element,Element);

See Also

Element Class | Element Members


Add(Double,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A value.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Double,Element) Method

Adds a value to all values of an element.

[Visual Basic]
Overloads Public Shared Function Add( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element Add(
   double lhs,
   Element rhs
);

Parameters

lhs
A value.
rhs
An element.

See Also

Element Class | Element Members | Overload List


Add(Element,Double) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
A value.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Element,Double) Method

Adds a value to all values of an element.

[Visual Basic]
Overloads Public Shared Function Add( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
[C#]
public static Element Add(
   Element lhs,
   double rhs
);

Parameters

lhs
An element.
rhs
A value.

See Also

Element Class | Element Members | Overload List


Add(Element,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Element,Element) Method

Adds the values of two elements.

[Visual Basic]
Overloads Public Shared Function Add( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element Add(
   Element lhs,
   Element rhs
);

Parameters

lhs
An element.
rhs
An element.

Remarks

All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

See Also

Element Class | Element Members | Overload List


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Divide Method

Overload List

Divider a number by an element.

[Visual Basic] Overloads Public Shared Function Divide(Double,Element) As Element

[C#] public static Element Divide(double,Element);

Divides an element by a number.

[Visual Basic] Overloads Public Shared Function Divide(Element,Double) As Element

[C#] public static Element Divide(Element,double);

Divides an element by another.

[Visual Basic] Overloads Public Shared Function Divide(Element,Element) As Element

[C#] public static Element Divide(Element,Element);

See Also

Element Class | Element Members


Divide(Double,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A numeric value.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

Divide(Double,Element) Method

Divider a number by an element.

[Visual Basic]
Overloads Public Shared Function Divide( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element Divide(
   double lhs,
   Element rhs
);

Parameters

lhs
A numeric value.
rhs
An element.

See Also

Element Class | Element Members | Overload List


Divide(Element,Double) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
A numeric value.
See Also Languages dotnetCHARTING Send comments on this topic.

Divide(Element,Double) Method

Divides an element by a number.

[Visual Basic]
Overloads Public Shared Function Divide( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
[C#]
public static Element Divide(
   Element lhs,
   double rhs
);

Parameters

lhs
An element.
rhs
A numeric value.

See Also

Element Class | Element Members | Overload List


Divide(Element,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

Divide(Element,Element) Method

Divides an element by another.

[Visual Basic]
Overloads Public Shared Function Divide( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element Divide(
   Element lhs,
   Element rhs
);

Parameters

lhs
An element.
rhs
An element.

Remarks

All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

See Also

Element Class | Element Members | Overload List


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Multiply Method

Overload List

Multiplies an element by a specified numeric value.

[Visual Basic] Overloads Public Shared Function Multiply(Double,Element) As Element

[C#] public static Element Multiply(double,Element);

Multiplies an element by a specified numeric value.

[Visual Basic] Overloads Public Shared Function Multiply(Element,Double) As Element

[C#] public static Element Multiply(Element,double);

Multiplies two elements.

[Visual Basic] Overloads Public Shared Function Multiply(Element,Element) As Element

[C#] public static Element Multiply(Element,Element);

See Also

Element Class | Element Members


Multiply(Double,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A numeric value.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

Multiply(Double,Element) Method

Multiplies an element by a specified numeric value.

[Visual Basic]
Overloads Public Shared Function Multiply( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element Multiply(
   double lhs,
   Element rhs
);

Parameters

lhs
A numeric value.
rhs
An element.

See Also

Element Class | Element Members | Overload List


Multiply(Element,Double) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
A numeric value.
See Also Languages dotnetCHARTING Send comments on this topic.

Multiply(Element,Double) Method

Multiplies an element by a specified numeric value.

[Visual Basic]
Overloads Public Shared Function Multiply( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
[C#]
public static Element Multiply(
   Element lhs,
   double rhs
);

Parameters

lhs
An element.
rhs
A numeric value.

See Also

Element Class | Element Members | Overload List


Multiply(Element,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

Multiply(Element,Element) Method

Multiplies two elements.

[Visual Basic]
Overloads Public Shared Function Multiply( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element Multiply(
   Element lhs,
   Element rhs
);

Parameters

lhs
An element.
rhs
An element.

Remarks

All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

See Also

Element Class | Element Members | Overload List


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Addition Method

Overload List

Adds a value to all values of an element.

[Visual Basic] Overloads Public Shared Function op_Addition(Double,Element) As Element

[C#] public static Element op_Addition(double,Element);

Adds a value to all values of an element.

[Visual Basic] Overloads Public Shared Function op_Addition(Element,Double) As Element

[C#] public static Element op_Addition(Element,double);

Adds the values of two elements.

[Visual Basic] Overloads Public Shared Function op_Addition(Element,Element) As Element

[C#] public static Element op_Addition(Element,Element);

See Also

Element Class | Element Members


op_Addition(Double,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A value.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Addition(Double,Element) Method

Adds a value to all values of an element.

[Visual Basic]
Overloads Public Shared Function op_Addition( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element op_Addition(
   double lhs,
   Element rhs
);

Parameters

lhs
A value.
rhs
An element.

See Also

Element Class | Element Members | Overload List


op_Addition(Element,Double) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
A value.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Addition(Element,Double) Method

Adds a value to all values of an element.

[Visual Basic]
Overloads Public Shared Function op_Addition( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
[C#]
public static Element op_Addition(
   Element lhs,
   double rhs
);

Parameters

lhs
An element.
rhs
A value.

See Also

Element Class | Element Members | Overload List


op_Addition(Element,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Addition(Element,Element) Method

Adds the values of two elements.

[Visual Basic]
Overloads Public Shared Function op_Addition( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element op_Addition(
   Element lhs,
   Element rhs
);

Parameters

lhs
An element.
rhs
An element.

Remarks

All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

See Also

Element Class | Element Members | Overload List


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Division Method

Overload List

Divider a number by an element.

[Visual Basic] Overloads Public Shared Function op_Division(Double,Element) As Element

[C#] public static Element op_Division(double,Element);

Divides an element by a number.

[Visual Basic] Overloads Public Shared Function op_Division(Element,Double) As Element

[C#] public static Element op_Division(Element,double);

Divides an element by another.

[Visual Basic] Overloads Public Shared Function op_Division(Element,Element) As Element

[C#] public static Element op_Division(Element,Element);

See Also

Element Class | Element Members


op_Division(Double,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A numeric value.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Division(Double,Element) Method

Divider a number by an element.

[Visual Basic]
Overloads Public Shared Function op_Division( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element op_Division(
   double lhs,
   Element rhs
);

Parameters

lhs
A numeric value.
rhs
An element.

See Also

Element Class | Element Members | Overload List


op_Division(Element,Double) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
A numeric value.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Division(Element,Double) Method

Divides an element by a number.

[Visual Basic]
Overloads Public Shared Function op_Division( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
[C#]
public static Element op_Division(
   Element lhs,
   double rhs
);

Parameters

lhs
An element.
rhs
A numeric value.

See Also

Element Class | Element Members | Overload List


op_Division(Element,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Division(Element,Element) Method

Divides an element by another.

[Visual Basic]
Overloads Public Shared Function op_Division( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element op_Division(
   Element lhs,
   Element rhs
);

Parameters

lhs
An element.
rhs
An element.

Remarks

All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

See Also

Element Class | Element Members | Overload List


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Multiply Method

Overload List

Multiplies an element by a specified numeric value.

[Visual Basic] Overloads Public Shared Function op_Multiply(Double,Element) As Element

[C#] public static Element op_Multiply(double,Element);

Multiplies an element by a specified numeric value.

[Visual Basic] Overloads Public Shared Function op_Multiply(Element,Double) As Element

[C#] public static Element op_Multiply(Element,double);

Multiplies two elements.

[Visual Basic] Overloads Public Shared Function op_Multiply(Element,Element) As Element

[C#] public static Element op_Multiply(Element,Element);

See Also

Element Class | Element Members


op_Multiply(Double,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A numeric value.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Multiply(Double,Element) Method

Multiplies an element by a specified numeric value.

[Visual Basic]
Overloads Public Shared Function op_Multiply( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element op_Multiply(
   double lhs,
   Element rhs
);

Parameters

lhs
A numeric value.
rhs
An element.

See Also

Element Class | Element Members | Overload List


op_Multiply(Element,Double) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
A numeric value.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Multiply(Element,Double) Method

Multiplies an element by a specified numeric value.

[Visual Basic]
Overloads Public Shared Function op_Multiply( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
[C#]
public static Element op_Multiply(
   Element lhs,
   double rhs
);

Parameters

lhs
An element.
rhs
A numeric value.

See Also

Element Class | Element Members | Overload List


op_Multiply(Element,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Multiply(Element,Element) Method

Multiplies two elements.

[Visual Basic]
Overloads Public Shared Function op_Multiply( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element op_Multiply(
   Element lhs,
   Element rhs
);

Parameters

lhs
An element.
rhs
An element.

Remarks

All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

See Also

Element Class | Element Members | Overload List


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Subtraction Method

Overload List

Subtracts all values of an element from specified value.

[Visual Basic] Overloads Public Shared Function op_Subtraction(Double,Element) As Element

[C#] public static Element op_Subtraction(double,Element);

Subtracts a value from all values of an element.

[Visual Basic] Overloads Public Shared Function op_Subtraction(Element,Double) As Element

[C#] public static Element op_Subtraction(Element,double);

Subtracts an element from another.

[Visual Basic] Overloads Public Shared Function op_Subtraction(Element,Element) As Element

[C#] public static Element op_Subtraction(Element,Element);

See Also

Element Class | Element Members


op_Subtraction(Double,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A value.
rhs
An element
See Also Languages dotnetCHARTING Send comments on this topic.

op_Subtraction(Double,Element) Method

Subtracts all values of an element from specified value.

[Visual Basic]
Overloads Public Shared Function op_Subtraction( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element op_Subtraction(
   double lhs,
   Element rhs
);

Parameters

lhs
A value.
rhs
An element

See Also

Element Class | Element Members | Overload List


op_Subtraction(Element,Double) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
A value.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Subtraction(Element,Double) Method

Subtracts a value from all values of an element.

[Visual Basic]
Overloads Public Shared Function op_Subtraction( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
[C#]
public static Element op_Subtraction(
   Element lhs,
   double rhs
);

Parameters

lhs
An element.
rhs
A value.

See Also

Element Class | Element Members | Overload List


op_Subtraction(Element,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Subtraction(Element,Element) Method

Subtracts an element from another.

[Visual Basic]
Overloads Public Shared Function op_Subtraction( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element op_Subtraction(
   Element lhs,
   Element rhs
);

Parameters

lhs
An element.
rhs
An element.

Remarks

All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

See Also

Element Class | Element Members | Overload List


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Subtract Method

Overload List

Subtracts all values of an element from specified value.

[Visual Basic] Overloads Public Shared Function Subtract(Double,Element) As Element

[C#] public static Element Subtract(double,Element);

Subtracts a value from all values of an element.

[Visual Basic] Overloads Public Shared Function Subtract(Element,Double) As Element

[C#] public static Element Subtract(Element,double);

Subtracts an element from another.

[Visual Basic] Overloads Public Shared Function Subtract(Element,Element) As Element

[C#] public static Element Subtract(Element,Element);

See Also

Element Class | Element Members


Subtract(Double,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A value.
rhs
An element
See Also Languages dotnetCHARTING Send comments on this topic.

Subtract(Double,Element) Method

Subtracts all values of an element from specified value.

[Visual Basic]
Overloads Public Shared Function Subtract( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element Subtract(
   double lhs,
   Element rhs
);

Parameters

lhs
A value.
rhs
An element

See Also

Element Class | Element Members | Overload List


Subtract(Element,Double) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
A value.
See Also Languages dotnetCHARTING Send comments on this topic.

Subtract(Element,Double) Method

Subtracts a value from all values of an element.

[Visual Basic]
Overloads Public Shared Function Subtract( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
[C#]
public static Element Subtract(
   Element lhs,
   double rhs
);

Parameters

lhs
An element.
rhs
A value.

See Also

Element Class | Element Members | Overload List


Subtract(Element,Element) Method

Element Class | Element Members | Overload List

Language

Visual Basic

C#

Show All

lhs
An element.
rhs
An element.
See Also Languages dotnetCHARTING Send comments on this topic.

Subtract(Element,Element) Method

Subtracts an element from another.

[Visual Basic]
Overloads Public Shared Function Subtract( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
[C#]
public static Element Subtract(
   Element lhs,
   Element rhs
);

Parameters

lhs
An element.
rhs
An element.

Remarks

All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

See Also

Element Class | Element Members | Overload List


Element Class Properties

Element Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Element Class Members

For a list of all members of this type, see Element members.

Public Properties

Public Property Annotation | Gets or sets this element's Annotation.
Public Property AxisMarker | Gets or sets this element's AxisMarker.
Public Property BubbleSize | Gets or sets the bubble size of this element.
Public Property Close | Gets or sets the financial closing price of this element.
Public Property Color | Gets or sets this element's color.
Public Property Complete | Gets or sets the percent complete value of this element.
Public Property CustomAttributes | Gets a collection of custom attributes associated with this element.
Public Property DefaultSubValue | Gets or sets a default SubValue object used to propagate its property settings to all SubValue objects in the SubValues collection.
Public Property ErrorHighValue | Gets of sets the high error value. When set, a single SubValue is drawn above the element's value. When ErrorLowValue is also set, a range SubValue is drawn between the two values.
Public Property ErrorLowValue | Gets of sets the low error value. When set, a single SubValue is drawn below the element's YValue value or range. When ErrorHighValue is also set, a range SubValue is drawn between the two values.
Public Property ErrorMinusOffset | Gets of sets the negative error offset. When set, a single SubValue is drawn below the element's value.
Public Property ErrorMinusPercent | Gets or sets the negative error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn below the element's value. When ErrorPlusPercent is also set, a range SubValue is drawn between the two points.
Public Property ErrorOffset | Gets or sets the error offset. The offset represents a range, +/- the value of the offset with respect to the element's YValue value or range.
Public Property ErrorPercent | Gets or sets the error offset based on the specified percentage of the element's YValue value or range. The offset represents a range, +/- the percentage of the element's YValue value or range.
Public Property ErrorPlusOffset | Gets of sets the positive error offset. When set, a single SubValue is drawn above the element's value.
Public Property ErrorPlusPercent | Gets or sets the positive error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn above the element's value. When ErrorMinusPercent is also set, a range SubValue is drawn between the two points.
Public Property ExplodeSlice | Gets or sets a value indicating whether the pie slice represented by this element is exploded.
Public Property ForceMarker | Gets or sets a value indicating whether this element's ElementMarker is drawn when the parent Series object's SeriesType omits the ElementMarker by default.
Public Property HatchColor | Gets or sets this element's HatchStyle color.
Public Property HatchStyle | Gets or sets this element's hatch style.
Public Property High | Gets or sets the financial high price of this element.
Public Property Hotspot | Gets or sets the Hotspot of this Element.
Public Property InstanceID |
Public Property LabelTemplate | Gets or sets this element's SmartLabel.Text property.
Public Property LegendEntry | Gets or sets this element's LegendEntry.
Public Property Length | Gets or sets a percent value representing this element's needle length.
Public Property Low | Gets or sets the financial low price of this element.
Public Property Marker | Gets or sets this element's Marker.
Public Property Name | Gets or sets this element's name.
Public Property Open | Gets or sets the financial open price of this element.
Public Property Point | Gets the element's pixel coordinate on a chart image.
Public Property SecondaryColor | Gets or sets this element's secondary color.
Public Property ShowValue | Gets or sets a value that indicates whether this element's SmartLabel is visible.
Public Property SmartLabel | Gets or sets this element's SmartLabel.
Public Property SubValues | Gets a collection of SubValue objects drawn on this Element.
Public Property TakeColorFrom | Gets or sets a Series or Element object from which this element's color will be inherited.
Public Property ToolTip | Gets or sets this elements tool tip. (Shortcut to: Element.Hotspot.Tooltip)
Public Property Transparency | Gets or sets the element color's transparency.
Public Property URL | Gets or sets the element's link URL. (Shortcut to: Element.Hotspot.URL)
Public Property URLTarget | Gets or sets the URL target of this element's link URL. (Shortcut to: Element.Hotspot.URLTarget)
Public Property Volume | Gets or sets the financial volume of this element.
Public Property XAxisTick | Gets or sets an AxisTick object that will placed on the x axis at the position of this element's x value. If the x axis is a category axis, AxisTick will not have any effect.
Public Property XDateTime | Gets or sets the X DateTime value of this element.
Public Property XDateTimeStart | Gets or sets the initial X DateTime value of this element.
Public Property XValue | Gets or sets the X value of this element.
Public Property XValueStart | Gets or sets the initial X value of this element.
Public Property YAxisTick | Gets or sets an AxisTick object that will placed on the y axis at the position of this element's y value. If the x axis is a category axis, AxisTick will not have any effect.
Public Property YDateTime | Gets or sets the Y DateTime value of this element.
Public Property YDateTimeStart | Gets or sets the initial Y DateTime value of this element.
Public Property YValue | Gets or sets the y value of this element.
Public Property YValueStart | Gets or sets the initial Y value of this element.

See Also

Element Class | dotnetCHARTING Namespace


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Annotation Property

Gets or sets this element's Annotation.

[Visual Basic]
Public Property Annotation As Annotation
[C#]
public Annotation Annotation {get; set;}

Remarks

The annotation's position will be the same as this element's position, usless specified. Element tokens can be used by this annotation's text to describe the element.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AxisMarker Property

Gets or sets this element's AxisMarker.

[Visual Basic]
Public Property AxisMarker As AxisMarker
[C#]
public AxisMarker AxisMarker {get; set;}

Remarks

This axis marker will highlight a section of the axis on which this element's name appears.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

BubbleSize Property

Gets or sets the bubble size of this element.

[Visual Basic]
Public Property BubbleSize As Double
[C#]
public double BubbleSize {get; set;}

Remarks

This Element value type is used by ChartType.Bubble only.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Close Property

Gets or sets the financial closing price of this element.

[Visual Basic]
Public Property Close As Double
[C#]
public double Close {get; set;}

Remarks

This element value type is used by ChartType.Financial only.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Color Property

Gets or sets this element's color.

[Visual Basic]
Public Property Color As Color
[C#]
public Color Color {get; set;}

Remarks

This color will also trickle to this element's SmartLabel.Color property, unless specified. When this element instance is the DefaultElement of a Series, this color will trickle to that series' Line.Color property, unless specified.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Complete Property

Gets or sets the percent complete value of this element.

[Visual Basic]
Public Property Complete As Integer
[C#]
public int Complete {get; set;}

Remarks

This Element value type is used by ChartType.Combo, ComboHorizontal, and ComboSideBySide with Column and Cylinder SeriesType. Primarily used to create Gantt charts.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CustomAttributes Property

Gets a collection of custom attributes associated with this element.

[Visual Basic]
Public ReadOnly Property CustomAttributes As ListCollection
[C#]
public ListCollection CustomAttributes {get;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultSubValue Property

Gets or sets a default SubValue object used to propagate its property settings to all SubValue objects in the SubValues collection.

[Visual Basic]
Public Property DefaultSubValue As SubValue
[C#]
public SubValue DefaultSubValue {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorHighValue Property

Gets of sets the high error value. When set, a single SubValue is drawn above the element's value. When ErrorLowValue is also set, a range SubValue is drawn between the two values.

[Visual Basic]
Public Property ErrorHighValue As Double
[C#]
public double ErrorHighValue {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorLowValue Property

Gets of sets the low error value. When set, a single SubValue is drawn below the element's YValue value or range. When ErrorHighValue is also set, a range SubValue is drawn between the two values.

[Visual Basic]
Public Property ErrorLowValue As Double
[C#]
public double ErrorLowValue {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorMinusOffset Property

Gets of sets the negative error offset. When set, a single SubValue is drawn below the element's value.

[Visual Basic]
Public Property ErrorMinusOffset As Double
[C#]
public double ErrorMinusOffset {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorMinusPercent Property

Gets or sets the negative error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn below the element's value. When ErrorPlusPercent is also set, a range SubValue is drawn between the two points.

[Visual Basic]
Public Property ErrorMinusPercent As Double
[C#]
public double ErrorMinusPercent {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorOffset Property

Gets or sets the error offset. The offset represents a range, +/- the value of the offset with respect to the element's YValue value or range.

[Visual Basic]
Public Property ErrorOffset As Double
[C#]
public double ErrorOffset {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorPercent Property

Gets or sets the error offset based on the specified percentage of the element's YValue value or range. The offset represents a range, +/- the percentage of the element's YValue value or range.

[Visual Basic]
Public Property ErrorPercent As Double
[C#]
public double ErrorPercent {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorPlusOffset Property

Gets of sets the positive error offset. When set, a single SubValue is drawn above the element's value.

[Visual Basic]
Public Property ErrorPlusOffset As Double
[C#]
public double ErrorPlusOffset {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorPlusPercent Property

Gets or sets the positive error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn above the element's value. When ErrorMinusPercent is also set, a range SubValue is drawn between the two points.

[Visual Basic]
Public Property ErrorPlusPercent As Double
[C#]
public double ErrorPlusPercent {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ExplodeSlice Property

Gets or sets a value indicating whether the pie slice represented by this element is exploded.

[Visual Basic]
Public Property ExplodeSlice As Boolean
[C#]
public bool ExplodeSlice {get; set;}

Remarks

When a pie slice represents a series, that series' DefaultElement.ExplodeSlice property indicates whether the slice is exploded.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ForceMarker Property

Gets or sets a value indicating whether this element's ElementMarker is drawn when the parent Series object's SeriesType omits the ElementMarker by default.

[Visual Basic]
Public Property ForceMarker As Boolean
[C#]
public bool ForceMarker {get; set;}

Remarks

Only SeriesTypes: Line (when Use3D = false), Spline, and Marker draw ElementMarkers by default.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HatchColor Property

Gets or sets this element's HatchStyle color.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HatchStyle Property

Gets or sets this element's hatch style.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}

Remarks

Hatch styles are filled using HatchColor. By default the color is transparent and may need to be specified before the hatch appears.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

High Property

Gets or sets the financial high price of this element.

[Visual Basic]
Public Property High As Double
[C#]
public double High {get; set;}

Remarks

This element value type is used by ChartType.Financial only.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hotspot Property

Gets or sets the Hotspot of this Element.

[Visual Basic]
Public Property Hotspot As Hotspot
[C#]
public Hotspot Hotspot {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InstanceID Property

[Visual Basic]
Public Property InstanceID As Integer
[C#]
public int InstanceID {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelTemplate Property

Gets or sets this element's SmartLabel.Text property.

[Visual Basic]
Public Property LabelTemplate As String
[C#]
public string LabelTemplate {get; set;}

Remarks

Element tokens can be used to describe this element.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntry Property

Gets or sets this element's LegendEntry.

[Visual Basic]
Public Property LegendEntry As LegendEntry
[C#]
public LegendEntry LegendEntry {get; set;}

Remarks

The legend entry represents this element in the LegendBox. Most charts types will only show legend entries of series, not individual elements. Changing this behavior to show the element's legend entries is done by setting the series' Palette or PaletteName properties.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Length Property

Gets or sets a percent value representing this element's needle length.

[Visual Basic]
Public Property Length As Integer
[C#]
public int Length {get; set;}

Remarks

Applies to gauge charts.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Low Property

Gets or sets the financial low price of this element.

[Visual Basic]
Public Property Low As Double
[C#]
public double Low {get; set;}

Remarks

This element value type is used by ChartType.Financial only.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Marker Property

Gets or sets this element's Marker.

[Visual Basic]
Public Property Marker As ElementMarker
[C#]
public ElementMarker Marker {get; set;}

Remarks

Only SeriesType options: Line (when Use3D = false), Spline, and Marker draw ElementMarkers by default. For other SeriesTypes, ForceMarker must be true.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Name Property

Gets or sets this element's name.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Remarks

The name property represents the element on label axes.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Open Property

Gets or sets the financial open price of this element.

[Visual Basic]
Public Property Open As Double
[C#]
public double Open {get; set;}

Remarks

This element value type is used by ChartType.Financial only.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Point Property

Gets the element's pixel coordinate on a chart image.

[Visual Basic]
Public ReadOnly Property Point As PointF
[C#]
public PointF Point {get;}

Remarks

This position is only available after the chart is rendered.

See Also

Element Class | Element Members


Element Class | Element Members | SeriesTypeFinancial Enumeration

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SecondaryColor Property

Gets or sets this element's secondary color.

[Visual Basic]
Public Property SecondaryColor As Color
[C#]
public Color SecondaryColor {get; set;}

Remarks

The secondary color is used with financial series types to indicate that the closing price (Close) is lower than the opening price (Open).

See Also

Element Class | Element Members | SeriesTypeFinancial Enumeration


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ShowValue Property

Gets or sets a value that indicates whether this element's SmartLabel is visible.

[Visual Basic]
Public Property ShowValue As Boolean
[C#]
public bool ShowValue {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartLabel Property

Gets or sets this element's SmartLabel.

[Visual Basic]
Public Property SmartLabel As SmartLabel
[C#]
public SmartLabel SmartLabel {get; set;}

Remarks

By default this label is hidden unless ShowValue is true.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SubValues Property

Gets a collection of SubValue objects drawn on this Element.

[Visual Basic]
Public ReadOnly Property SubValues As SubValueCollection
[C#]
public SubValueCollection SubValues {get;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TakeColorFrom Property

Gets or sets a Series or Element object from which this element's color will be inherited.

[Visual Basic]
Public Property TakeColorFrom As Object
[C#]
public object TakeColorFrom {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ToolTip Property

Gets or sets this elements tool tip. (Shortcut to: Element.Hotspot.Tooltip)

[Visual Basic]
Public Property ToolTip As String
[C#]
public string ToolTip {get; set;}

Remarks

Element tokens can be used to describe this element.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Transparency Property

Gets or sets the element color's transparency.

[Visual Basic]
Public Property Transparency As Integer
[C#]
public int Transparency {get; set;}

Remarks

A value of 0 will have no transparency and 100 will be completely transparent.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URL Property

Gets or sets the element's link URL. (Shortcut to: Element.Hotspot.URL)

[Visual Basic]
Public Property URL As String
[C#]
public string URL {get; set;}

Remarks

The chart will create an image map with the specified url for this element. Element tokens can be used to describe this element in the url.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URLTarget Property

Gets or sets the URL target of this element's link URL. (Shortcut to: Element.Hotspot.URLTarget)

[Visual Basic]
Public Property URLTarget As String
[C#]
public string URLTarget {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Volume Property

Gets or sets the financial volume of this element.

[Visual Basic]
Public Property Volume As Double
[C#]
public double Volume {get; set;}

Remarks

This element value type is used by ChartType.Financial only.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

XAxisTick Property

Gets or sets an AxisTick object that will placed on the x axis at the position of this element's x value. If the x axis is a category axis, AxisTick will not have any effect.

[Visual Basic]
Public Property XAxisTick As AxisTick
[C#]
public AxisTick XAxisTick {get; set;}

Remarks

This value is null by default.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

XDateTime Property

Gets or sets the X DateTime value of this element.

[Visual Basic]
Public Property XDateTime As Date
[C#]
public DateTime XDateTime {get; set;}

Remarks

This Element value is used with value x axes.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

XDateTimeStart Property

Gets or sets the initial X DateTime value of this element.

[Visual Basic]
Public Property XDateTimeStart As Date
[C#]
public DateTime XDateTimeStart {get; set;}

Remarks

Not yet implemented.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

XValue Property

Gets or sets the X value of this element.

[Visual Basic]
Public Property XValue As Double
[C#]
public double XValue {get; set;}

Remarks

This Element value is used with value x axes.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

XValueStart Property

Gets or sets the initial X value of this element.

[Visual Basic]
Public Property XValueStart As Double
[C#]
public double XValueStart {get; set;}

Remarks

Not yet implemented.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

YAxisTick Property

Gets or sets an AxisTick object that will placed on the y axis at the position of this element's y value. If the x axis is a category axis, AxisTick will not have any effect.

[Visual Basic]
Public Property YAxisTick As AxisTick
[C#]
public AxisTick YAxisTick {get; set;}

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

YDateTime Property

Gets or sets the Y DateTime value of this element.

[Visual Basic]
Public Property YDateTime As Date
[C#]
public DateTime YDateTime {get; set;}

Remarks

Using ChartType.ComboHorizontal the YDateTime value type corresponds to the x axis because this allows the element to be interchangeable between the vertical and horizontal combo chart.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

YDateTimeStart Property

Gets or sets the initial Y DateTime value of this element.

[Visual Basic]
Public Property YDateTimeStart As Date
[C#]
public DateTime YDateTimeStart {get; set;}

Remarks

Using ChartType.ComboHorizontal the YDateTimeStart value type corresponds to the x axis because this allows the element to be interchangeable between the vertical and horizontal combo chart.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

YValue Property

Gets or sets the y value of this element.

[Visual Basic]
Public Property YValue As Double
[C#]
public double YValue {get; set;}

Remarks

YValue is the main value container for elements. It is used at times when the element's value would not officially be considered the y value such as: pie slice value. Using ChartType.ComboHorizontal the YValue type value corresponds to the x axis because this allows the element to be interchangable between the vertical and horizontal combo chart.

This Element value type is used by all chart types except ChartType.Financial.

See Also

Element Class | Element Members


Element Class | Element Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

YValueStart Property

Gets or sets the initial Y value of this element.

[Visual Basic]
Public Property YValueStart As Double
[C#]
public double YValueStart {get; set;}

Remarks

Using ChartType.ComboHorizontal, the YValueStart type value corresponds to the x axis because this allows the element to be interchangable between the vertical and horizontal combo chart.

This Element value type is used by all chart types except ChartType.Financial.

See Also

Element Class | Element Members


ElementCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ElementCollection Class

Contains a collection of Element objects.

For a list of all members of this type, see ElementCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.ElementCollection

Syntax

[Visual Basic]
Public Class ElementCollection
   Inherits CollectionBase
[C#]
public class ElementCollection : CollectionBase

See Also

ElementCollection Members | dotnetCHARTING Namespace


ElementCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ElementCollection Class Members

ElementCollection overview

Public Constructors

Public Constructor ElementCollection Constructor

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the Element at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Element.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified Element in this collection.
Public Method Insert | Inserts a element into this collection at a specified index.
Public Method Remove | Removes a specified element from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

ElementCollection Class | dotnetCHARTING Namespace


ElementCollection Class | ElementCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ElementCollection Constructor

[Visual Basic]
Public Function New()
[C#]
public ElementCollection();

See Also

ElementCollection Class | ElementCollection Members


ElementCollection Class Methods

ElementCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ElementCollection Class Members

For a list of all members of this type, see ElementCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Element.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified Element in this collection.
Public Method Insert | Inserts a element into this collection at a specified index.
Public Method Remove | Removes a specified element from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

ElementCollection Class | dotnetCHARTING Namespace


ElementCollection Class | ElementCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

Provided as a shortcut for adding element the chart SeriesCollection.

[Visual Basic] Overloads Public Function Add() As Integer

[C#] public int Add();

Adds an element to the collection based on the specified calculation.

[Visual Basic] Overloads Public Function Add(Calculation) As Integer

[C#] public int Add(Calculation);

Adds an element to the collection based on the specified collection with the specified name.

[Visual Basic] Overloads Public Function Add(Calculation,String) As Integer

[C#] public int Add(Calculation,string);

Adds a specified Element class to this collection.

[Visual Basic] Overloads Public Function Add(Element) As Integer

[C#] public int Add(Element);

Adds the specified Elements to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray Element())

[C#] public void Add(params Element[]);

Adds a specified ElementCollection to this collection.

[Visual Basic] Overloads Public Function Add(ElementCollection) As Integer

[C#] public int Add(ElementCollection);

See Also

ElementCollection Class | ElementCollection Members


ElementCollection Class | ElementCollection Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add() Method

Provided as a shortcut for adding element the chart SeriesCollection.

[Visual Basic]
Overloads Public Function Add() As Integer
[C#]
public int Add();

Example

[C#]

[C#]
Chart.Series.Element.YValue = 10;
Chart.Series.Element.Name = "Element 1";
Chart.Series.Elements.Add();
Chart.SeriesCollection.Add();

[C#]

[Visual Basic]
Chart.Series.Element.YValue = 10
Chart.Series.Element.Name = "Element 1"
Chart.Series.Elements.Add()
Chart.SeriesCollection.Add()

See Also

ElementCollection Class | ElementCollection Members | Overload List


Add(Calculation) Method

ElementCollection Class | ElementCollection Members | Overload List

Language

Visual Basic

C#

Show All

calc
Calculation to perform on the collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Calculation) Method

Adds an element to the collection based on the specified calculation.

[Visual Basic]
Overloads Public Function Add( _
   ByVal calc As Calculation _
) As Integer
[C#]
public int Add(
   Calculation calc
);

Parameters

calc
Calculation to perform on the collection.

Return Type

Numeric index of the added element.

Remarks

This method must be used through Chart.Series.Elements.Add(...).

See Also

ElementCollection Class | ElementCollection Members | Overload List


Add(Calculation,String) Method

ElementCollection Class | ElementCollection Members | Overload List

Language

Visual Basic

C#

Show All

calc
Calculation to perform on the elements.
text
Name of the new element.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Calculation,String) Method

Adds an element to the collection based on the specified collection with the specified name.

[Visual Basic]
Overloads Public Function Add( _
   ByVal calc As Calculation, _
   ByVal text As String _
) As Integer
[C#]
public int Add(
   Calculation calc,
   string text
);

Parameters

calc
Calculation to perform on the elements.
text
Name of the new element.

Return Type

Numeric index of the added element.

See Also

ElementCollection Class | ElementCollection Members | Overload List


Add(Element) Method

ElementCollection Class | ElementCollection Members | Overload List

Language

Visual Basic

C#

Show All

element
The Element to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Element) Method

Adds a specified Element class to this collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal element As Element _
) As Integer
[C#]
public int Add(
   Element element
);

Parameters

element
The Element to add.

Return Type

The zero-based index of the added Element.

See Also

ElementCollection Class | ElementCollection Members | Overload List


Add(Element[]) Method

ElementCollection Class | ElementCollection Members | Overload List

Language

Visual Basic

C#

Show All

elements
List of elements to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Element[]) Method

Adds the specified Elements to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray elements() As Element _
)
[C#]
public void Add(
   params Element[] elements
);

Parameters

elements
List of elements to add.

See Also

ElementCollection Class | ElementCollection Members | Overload List


Add(ElementCollection) Method

ElementCollection Class | ElementCollection Members | Overload List

Language

Visual Basic

C#

Show All

elementCollection
ElementCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(ElementCollection) Method

Adds a specified ElementCollection to this collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal elementCollection As ElementCollection _
) As Integer
[C#]
public int Add(
   ElementCollection elementCollection
);

Parameters

elementCollection
ElementCollection to add.

See Also

ElementCollection Class | ElementCollection Members | Overload List


Contains Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

Show All

element
The Element to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified Element.

[Visual Basic]
Public Function Contains( _
   ByVal element As Element _
) As Boolean
[C#]
public bool Contains(
   Element element
);

Parameters

element
The Element to find.

Return Type

true if the specified Element belongs to this collection; otherwise, false.

See Also

ElementCollection Class | ElementCollection Members


IndexOf Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

Show All

e
The AxisTick to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines the index of a specified Element in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal e As Element _
) As Integer
[C#]
public int IndexOf(
   Element e
);

Parameters

e
The AxisTick to find.

Return Type

The zero-based index of the specified AxisTick.

See Also

ElementCollection Class | ElementCollection Members


Insert Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the element.
element
The element to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a element into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal element As Element _
)
[C#]
public void Insert(
   int index,
   Element element
);

Parameters

index
The zero-based index into the collection at which to insert the element.
element
The element to insert into this collection.

See Also

ElementCollection Class | ElementCollection Members


Remove Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

Show All

element
The element to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified element from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal element As Element _
)
[C#]
public void Remove(
   Element element
);

Parameters

element
The element to remove.

See Also

ElementCollection Class | ElementCollection Members


ElementCollection Class Properties

ElementCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ElementCollection Class Members

For a list of all members of this type, see ElementCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the Element at a specified index.

See Also

ElementCollection Class | dotnetCHARTING Namespace


Item Property

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the Element at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Element
[C#]
public Element this[
   int index
]; {get; set;}

Parameters

index

See Also

ElementCollection Class | ElementCollection Members


ElementMarker Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ElementMarker Class

Defines a graphical object with a specified shape, size, and color or an image used to mark and identify Element objects.

For a list of all members of this type, see ElementMarker members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.ElementMarker

Syntax

[Visual Basic]
Public Class ElementMarker
[C#]
public class ElementMarker

See Also

ElementMarker Members | dotnetCHARTING Namespace


ElementMarker Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ElementMarker Class Members

ElementMarker overview

Public Constructors

Public Constructor ElementMarker Constructor Overloaded.

Public Properties

Public Property Color | Gets or sets the color of this element marker.
Public Property ImagePath | Gets or sets the image path of this marker.
Public Property Size | Gets or sets the size of this element marker.
Public Property Type | Gets or sets a predefined shape for this marker.
Public Property Visible | Gets or sets a value indicating whether the marker is visible.

See Also

ElementMarker Class | dotnetCHARTING Namespace


ElementMarker Class | ElementMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ElementMarker Constructor

Overload List

Initializes an instance of ElementMarker.

[Visual Basic] Public Sub New()

[C#] public ElementMarker();

Initializes an instance of ElementMarker with a built in icon (ElementMarkerType).

[Visual Basic] Public Sub New(ElementMarkerType)

[C#] public ElementMarker(ElementMarkerType);

Initializes an instance of ElementMarker with a built in icon (ElementMarkerType), and size.

[Visual Basic] Public Sub New(ElementMarkerType,Integer)

[C#] public ElementMarker(ElementMarkerType,int);

Initializes an instance of ElementMarker with a built in icon (ElementMarkerType), size, and color.

[Visual Basic] Public Sub New(ElementMarkerType,Integer,Color)

[C#] public ElementMarker(ElementMarkerType,int,Color);

Initializes an instance of ElementMarker with an image.

[Visual Basic] Public Sub New(String)

[C#] public ElementMarker(string);

Initializes an instance of ElementMarker with an image and size.

[Visual Basic] Public Sub New(String,Integer)

[C#] public ElementMarker(string,int);

See Also

ElementMarker Class | ElementMarker Members


ElementMarker Class | ElementMarker Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ElementMarker Constructor()

Initializes an instance of ElementMarker.

[Visual Basic]
Public Function New()
[C#]
public ElementMarker();

Remarks

This element marker will be empty.

See Also

ElementMarker Class | ElementMarker Members | Overload List


ElementMarker Constructor(ElementMarkerType)

ElementMarker Class | ElementMarker Members | Overload List

Language

Visual Basic

C#

Show All

dType
Element marker type of this marker.
See Also Languages dotnetCHARTING Send comments on this topic.

ElementMarker Constructor(ElementMarkerType)

Initializes an instance of ElementMarker with a built in icon (ElementMarkerType).

[Visual Basic]
Public Function New( _
   ByVal dType As ElementMarkerType _
)
[C#]
public ElementMarker(
   ElementMarkerType dType
);

Parameters

dType
Element marker type of this marker.

See Also

ElementMarker Class | ElementMarker Members | Overload List


ElementMarker Constructor(ElementMarkerType,Int32)

ElementMarker Class | ElementMarker Members | Overload List

Language

Visual Basic

C#

Show All

dType
Element marker type of this marker.
size
The size of this marker.
See Also Languages dotnetCHARTING Send comments on this topic.

ElementMarker Constructor(ElementMarkerType,Int32)

Initializes an instance of ElementMarker with a built in icon (ElementMarkerType), and size.

[Visual Basic]
Public Function New( _
   ByVal dType As ElementMarkerType, _
   ByVal size As Integer _
)
[C#]
public ElementMarker(
   ElementMarkerType dType,
   int size
);

Parameters

dType
Element marker type of this marker.
size
The size of this marker.

See Also

ElementMarker Class | ElementMarker Members | Overload List


ElementMarker Constructor(ElementMarkerType,Int32,Color)

ElementMarker Class | ElementMarker Members | Overload List

Language

Visual Basic

C#

Show All

dType
Element marker type of this marker.
size
The size of this marker.
color
The color of this marker.
See Also Languages dotnetCHARTING Send comments on this topic.

ElementMarker Constructor(ElementMarkerType,Int32,Color)

Initializes an instance of ElementMarker with a built in icon (ElementMarkerType), size, and color.

[Visual Basic]
Public Function New( _
   ByVal dType As ElementMarkerType, _
   ByVal size As Integer, _
   ByVal color As Color _
)
[C#]
public ElementMarker(
   ElementMarkerType dType,
   int size,
   Color color
);

Parameters

dType
Element marker type of this marker.
size
The size of this marker.
color
The color of this marker.

See Also

ElementMarker Class | ElementMarker Members | Overload List


ElementMarker Constructor(String)

ElementMarker Class | ElementMarker Members | Overload List

Language

Visual Basic

C#

Show All

imagePath
Absolute path of an image.
See Also Languages dotnetCHARTING Send comments on this topic.

ElementMarker Constructor(String)

Initializes an instance of ElementMarker with an image.

[Visual Basic]
Public Function New( _
   ByVal imagePath As String _
)
[C#]
public ElementMarker(
   string imagePath
);

Parameters

imagePath
Absolute path of an image.

See Also

ElementMarker Class | ElementMarker Members | Overload List


ElementMarker Constructor(String,Int32)

ElementMarker Class | ElementMarker Members | Overload List

Language

Visual Basic

C#

Show All

imagePath
Absolute path of an image.
maxSize
Maximum width or height of the image.
See Also Languages dotnetCHARTING Send comments on this topic.

ElementMarker Constructor(String,Int32)

Initializes an instance of ElementMarker with an image and size.

[Visual Basic]
Public Function New( _
   ByVal imagePath As String, _
   ByVal maxSize As Integer _
)
[C#]
public ElementMarker(
   string imagePath,
   int maxSize
);

Parameters

imagePath
Absolute path of an image.
maxSize
Maximum width or height of the image.

See Also

ElementMarker Class | ElementMarker Members | Overload List


ElementMarker Class Properties

ElementMarker Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ElementMarker Class Members

For a list of all members of this type, see ElementMarker members.

Public Properties

Public Property Color | Gets or sets the color of this element marker.
Public Property ImagePath | Gets or sets the image path of this marker.
Public Property Size | Gets or sets the size of this element marker.
Public Property Type | Gets or sets a predefined shape for this marker.
Public Property Visible | Gets or sets a value indicating whether the marker is visible.

See Also

ElementMarker Class | dotnetCHARTING Namespace


ElementMarker Class | ElementMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Color Property

Gets or sets the color of this element marker.

[Visual Basic]
Public Property Color As Color
[C#]
public Color Color {get; set;}

See Also

ElementMarker Class | ElementMarker Members


ElementMarker Class | ElementMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ImagePath Property

Gets or sets the image path of this marker.

[Visual Basic]
Public Property ImagePath As String
[C#]
public string ImagePath {get; set;}

See Also

ElementMarker Class | ElementMarker Members


ElementMarker Class | ElementMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Size Property

Gets or sets the size of this element marker.

[Visual Basic]
Public Property Size As Integer
[C#]
public int Size {get; set;}

Return Type

Maximum width or height of this marker.

See Also

ElementMarker Class | ElementMarker Members


ElementMarker Class | ElementMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Type Property

Gets or sets a predefined shape for this marker.

[Visual Basic]
Public Property Type As ElementMarkerType
[C#]
public ElementMarkerType Type {get; set;}

See Also

ElementMarker Class | ElementMarker Members


ElementMarker Class | ElementMarker Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Visible Property

Gets or sets a value indicating whether the marker is visible.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

ElementMarker Class | ElementMarker Members


EmptyElement Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

EmptyElement Class

Defines the behavior and appearance of empty elements for a given Series.

For a list of all members of this type, see EmptyElement members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.EmptyElement

Syntax

[Visual Basic]
Public Class EmptyElement
[C#]
public class EmptyElement

See Also

EmptyElement Members | dotnetCHARTING Namespace


EmptyElement Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

EmptyElement Class Members

EmptyElement overview

Public Constructors

Public Constructor EmptyElement Constructor Initializes a new instance of the EmptyElement class.

Public Properties

Public Property Color | Gets or sets the color of empty elements.
Public Property Hotspot | Gets or sets the Hotspot of this EmptyElement.
Public Property Line | Gets or sets a line which substitutes a series' Line object when empty elements are drawn.
Public Property Marker | Gets or sets the marker of empty elements.
Public Property Mode | Gets or sets the empty element mode.
Public Property SmartLabel | Gets or sets the label of empty elements.
Public Property ToolTip | Gets or sets the tool tip of empty elements.
Public Property URL | Gets or sets the URL of empty elements.
Public Property URLTarget | Gets or sets the target of URLs of empty elements.

See Also

EmptyElement Class | dotnetCHARTING Namespace


EmptyElement Class | EmptyElement Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

EmptyElement Constructor

Initializes a new instance of the EmptyElement class.

[Visual Basic]
Public Function New()
[C#]
public EmptyElement();

See Also

EmptyElement Class | EmptyElement Members


EmptyElement Class Properties

EmptyElement Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

EmptyElement Class Members

For a list of all members of this type, see EmptyElement members.

Public Properties

Public Property Color | Gets or sets the color of empty elements.
Public Property Hotspot | Gets or sets the Hotspot of this EmptyElement.
Public Property Line | Gets or sets a line which substitutes a series' Line object when empty elements are drawn.
Public Property Marker | Gets or sets the marker of empty elements.
Public Property Mode | Gets or sets the empty element mode.
Public Property SmartLabel | Gets or sets the label of empty elements.
Public Property ToolTip | Gets or sets the tool tip of empty elements.
Public Property URL | Gets or sets the URL of empty elements.
Public Property URLTarget | Gets or sets the target of URLs of empty elements.

See Also

EmptyElement Class | dotnetCHARTING Namespace


EmptyElement Class | EmptyElement Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Color Property

Gets or sets the color of empty elements.

[Visual Basic]
Public Property Color As Color
[C#]
public Color Color {get; set;}

Remarks

This property will also affect the colors of this empty element's Line, Marker, and SmartLabel objects.

See Also

EmptyElement Class | EmptyElement Members


EmptyElement Class | EmptyElement Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hotspot Property

Gets or sets the Hotspot of this EmptyElement.

[Visual Basic]
Public Property Hotspot As Hotspot
[C#]
public Hotspot Hotspot {get; set;}

See Also

EmptyElement Class | EmptyElement Members


EmptyElement Class | EmptyElement Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Property

Gets or sets a line which substitutes a series' Line object when empty elements are drawn.

[Visual Basic]
Public Property Line As Line
[C#]
public Line Line {get; set;}

See Also

EmptyElement Class | EmptyElement Members


EmptyElement Class | EmptyElement Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Marker Property

Gets or sets the marker of empty elements.

[Visual Basic]
Public Property Marker As ElementMarker
[C#]
public ElementMarker Marker {get; set;}

Remarks

To active this marker the following settings are required:

EmptyElement.Mode = EmptyElementMode.Fill

EmptyElement.Marker = ElementMarkerType.(any other than 'None')

See Also

EmptyElement Class | EmptyElement Members


EmptyElement Class | EmptyElement Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Mode Property

Gets or sets the empty element mode.

[Visual Basic]
Public Property Mode As EmptyElementMode
[C#]
public EmptyElementMode Mode {get; set;}

See Also

EmptyElement Class | EmptyElement Members


EmptyElement Class | EmptyElement Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartLabel Property

Gets or sets the label of empty elements.

[Visual Basic]
Public Property SmartLabel As SmartLabel
[C#]
public SmartLabel SmartLabel {get; set;}

See Also

EmptyElement Class | EmptyElement Members


EmptyElement Class | EmptyElement Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ToolTip Property

Gets or sets the tool tip of empty elements.

[Visual Basic]
Public Property ToolTip As String
[C#]
public string ToolTip {get; set;}

See Also

EmptyElement Class | EmptyElement Members


EmptyElement Class | EmptyElement Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URL Property

Gets or sets the URL of empty elements.

[Visual Basic]
Public Property URL As String
[C#]
public string URL {get; set;}

See Also

EmptyElement Class | EmptyElement Members


EmptyElement Class | EmptyElement Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URLTarget Property

Gets or sets the target of URLs of empty elements.

[Visual Basic]
Public Property URLTarget As String
[C#]
public string URLTarget {get; set;}

See Also

EmptyElement Class | EmptyElement Members


FileManager Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FileManager Class

Facilitates saving bitmap images and cleanup.

For a list of all members of this type, see FileManager members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.FileManager

Syntax

[Visual Basic]
Public Class FileManager
[C#]
public class FileManager

See Also

FileManager Members | dotnetCHARTING Namespace


FileManager Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

FileManager Class Members

FileManager overview

Public Properties

Public Property Cached | Gets a value indicating whether a chart will be renderd or a cached image will be used.
Public Property CachePeriod | Gets or sets a TimeSpan object that determines the amount of time an image is cached and displayed on a page before a new one is generated.
Public Property CleanupMinimumAge | Gets or sets a TimeSpan object that determines the minimum amount of time images are stored in the TempDirectory folder before they are deleted.
Public Property CleanupPeriod | Gets or sets a TimeSpan object that determines the amount of time the TempDirectory folder would be checked for deleting old image files.
Public Property FileName | Sets the file name to save an image as, or gets the file name of an image that has been saved in the TempDirectory after a chart is generated.
Public Property FileQuality | Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)
Public Property ImageFormat | Gets or sets a ImageFormat Enumeration specifying the image file type.
Public Property TempDirectory | Gets or sets the directory where images generated by the control are temporarily stored.

Public Methods

Public Method SaveImage Overloaded.

See Also

FileManager Class | dotnetCHARTING Namespace


FileManager Class Methods

FileManager Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

FileManager Class Members

For a list of all members of this type, see FileManager members.

Public Methods

Public Method SaveImage Overloaded.

See Also

FileManager Class | dotnetCHARTING Namespace


FileManager Class | FileManager Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SaveImage Method

Overload List

Saves a Bitmap in the TempDirectory and displays it in the chart control.

[Visual Basic] Overloads Public Function SaveImage(Bitmap) As String

[C#] public string SaveImage(Bitmap);

Saves a Bitmap in the TempDirectory and displays it in the chart control.

[Visual Basic] Overloads Public Function SaveImage(Bitmap,Boolean) As String

[C#] public string SaveImage(Bitmap,bool);

See Also

FileManager Class | FileManager Members


SaveImage(Bitmap) Method

FileManager Class | FileManager Members | Overload List

Language

Visual Basic

C#

Show All

bmp
Bitmap to save.
See Also Languages dotnetCHARTING Send comments on this topic.

SaveImage(Bitmap) Method

Saves a Bitmap in the TempDirectory and displays it in the chart control.

[Visual Basic]
Overloads Public Function SaveImage( _
   ByVal bmp As Bitmap _
) As String
[C#]
public string SaveImage(
   Bitmap bmp
);

Parameters

bmp
Bitmap to save.

Return Type

Path of the saved bitmap.

See Also

FileManager Class | FileManager Members | Overload List


SaveImage(Bitmap,Boolean) Method

FileManager Class | FileManager Members | Overload List

Language

Visual Basic

C#

Show All

bmp
Bitmap to save.
fileSaved
for later chart display.
See Also Languages dotnetCHARTING Send comments on this topic.

SaveImage(Bitmap,Boolean) Method

Saves a Bitmap in the TempDirectory and displays it in the chart control.

[Visual Basic]
Overloads Public Function SaveImage( _
   ByVal bmp As Bitmap, _
   ByVal fileSaved As Boolean _
) As String
[C#]
public string SaveImage(
   Bitmap bmp,
   bool fileSaved
);

Parameters

bmp
Bitmap to save.
fileSaved
for later chart display.

Return Type

Path of the saved bitmap.

See Also

FileManager Class | FileManager Members | Overload List


FileManager Class Properties

FileManager Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

FileManager Class Members

For a list of all members of this type, see FileManager members.

Public Properties

Public Property Cached | Gets a value indicating whether a chart will be renderd or a cached image will be used.
Public Property CachePeriod | Gets or sets a TimeSpan object that determines the amount of time an image is cached and displayed on a page before a new one is generated.
Public Property CleanupMinimumAge | Gets or sets a TimeSpan object that determines the minimum amount of time images are stored in the TempDirectory folder before they are deleted.
Public Property CleanupPeriod | Gets or sets a TimeSpan object that determines the amount of time the TempDirectory folder would be checked for deleting old image files.
Public Property FileName | Sets the file name to save an image as, or gets the file name of an image that has been saved in the TempDirectory after a chart is generated.
Public Property FileQuality | Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)
Public Property ImageFormat | Gets or sets a ImageFormat Enumeration specifying the image file type.
Public Property TempDirectory | Gets or sets the directory where images generated by the control are temporarily stored.

See Also

FileManager Class | dotnetCHARTING Namespace


FileManager Class | FileManager Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Cached Property

Gets a value indicating whether a chart will be renderd or a cached image will be used.

[Visual Basic]
Public ReadOnly Property Cached As Boolean
[C#]
public bool Cached {get;}

Remarks

If false no special processing is required because a cached image will be displayed.

See Also

FileManager Class | FileManager Members


FileManager Class | FileManager Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CachePeriod Property

Gets or sets a TimeSpan object that determines the amount of time an image is cached and displayed on a page before a new one is generated.

[Visual Basic]
Public Property CachePeriod As TimeSpan
[C#]
public TimeSpan CachePeriod {get; set;}

Remarks

When set, a given chart image will be generated on the first hit and on all subsequent hits within the cache duration period, the same image will be returned with no rendering work by the chart control.

See Also

FileManager Class | FileManager Members


FileManager Class | FileManager Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CleanupMinimumAge Property

Gets or sets a TimeSpan object that determines the minimum amount of time images are stored in the TempDirectory folder before they are deleted.

[Visual Basic]
Public Property CleanupMinimumAge As TimeSpan
[C#]
public TimeSpan CleanupMinimumAge {get; set;}

See Also

FileManager Class | FileManager Members


FileManager Class | FileManager Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CleanupPeriod Property

Gets or sets a TimeSpan object that determines the amount of time the TempDirectory folder would be checked for deleting old image files.

[Visual Basic]
Public Property CleanupPeriod As TimeSpan
[C#]
public TimeSpan CleanupPeriod {get; set;}

Example

This example sets the cleanup period every 30 minutes.

[C#]

Chart.FileManager.CleanupPeriod= new TimeSpan(0,30,0);

[Visual Basic]

Chart.FileManager.CleanupPeriod= New TimeSpan(0,30,0)

See Also

FileManager Class | FileManager Members


FileManager Class | FileManager Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FileName Property

Sets the file name to save an image as, or gets the file name of an image that has been saved in the TempDirectory after a chart is generated.

[Visual Basic]
Public Property FileName As String
[C#]
public string FileName {get; set;}

Remarks

When empty, a random name will be created. In order for the cleanup system to include custom file names they must start with 'dnc-', the mask is: 'dnc-*.*'.

Example

[C#]

Chart.FileManager.FileName="saleChart";

[Visual Basic]

Chart.FileManager.FileName="saleChart"

See Also

FileManager Class | FileManager Members


FileManager Class | FileManager Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FileQuality Property

Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)

[Visual Basic]
Public Property FileQuality As Long
[C#]
public long FileQuality {get; set;}

Example

[C#]

Chart.FileManager.FileQuality=75;

[Visual Basic]

Chart.FileManager.FileQuality=75

See Also

FileManager Class | FileManager Members


FileManager Class | FileManager Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ImageFormat Property

Gets or sets a ImageFormat Enumeration specifying the image file type.

[Visual Basic]
Public Property ImageFormat As ImageFormat
[C#]
public ImageFormat ImageFormat {get; set;}

Example

[C#]

Chart.FileManager.ImageFormat=ImageFormat.Png;

[Visual Basic]

Chart.FileManager.ImageFormat=ImageFormat.Png

See Also

FileManager Class | FileManager Members


FileManager Class | FileManager Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TempDirectory Property

Gets or sets the directory where images generated by the control are temporarily stored.

[Visual Basic]
Public Property TempDirectory As String
[C#]
public string TempDirectory {get; set;}

Remarks

This property takes either an absolute path 'c:/inetpub/wwwroot/app/tmp', a relative path ('tmp', '../tmp',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/tmp).

Example

This examples demonstrate different ways of accessing the same folder: 'c:/inetpub/wwwroot/app/tmp' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.

[C#]

Chart.FileManager.TempDirectory = "c://inetpub/wwwroot/app/tmp";
Chart.FileManager.TempDirectory = "/app/tmp";
Chart.FileManager.TempDirectory = "tmp";

[Visual Basic]

Chart.FileManager.TempDirectory = "c://inetpub/wwwroot/app/tmp"
Chart.FileManager.TempDirectory = "/app/tmp"
Chart.FileManager.TempDirectory = "tmp"

See Also

FileManager Class | FileManager Members


FinancialEngine Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FinancialEngine Class

Provides a set of methods that perform financial analysis of series and series collections.

For a list of all members of this type, see FinancialEngine members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.FinancialEngine

Syntax

[Visual Basic]
Public NotInheritable Class FinancialEngine
[C#]
public sealed class FinancialEngine

See Also

FinancialEngine Members | dotnetCHARTING Namespace


FinancialEngine Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

FinancialEngine Class Members

FinancialEngine overview

Public Methods

Public Method static (Shared in Visual Basic) AcumulateDistributeOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) AroonDown | Overloaded.
Public Method static (Shared in Visual Basic) AroonDownOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) AroonOscillator | Overloaded.
Public Method static (Shared in Visual Basic) AroonOscillatorOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) AroonUp | Overloaded.
Public Method static (Shared in Visual Basic) AroonUpOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) BalanceOfPowerOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) BollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) ChaikinMoneyFlowOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) ChaikinOscillator | Overloaded.
Public Method static (Shared in Visual Basic) ChaikinVolatility | Overloaded.
Public Method static (Shared in Visual Basic) CommodityChannelIdxOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) CrossingExtremeSignal | Overloaded.
Public Method static (Shared in Visual Basic) CrossingSignal | Overloaded.
Public Method static (Shared in Visual Basic) DStochastic | Overloaded.
Public Method static (Shared in Visual Basic) ExponentiallyWeightedMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) ExtremeValueDSignal | Overloaded.
Public Method static (Shared in Visual Basic) ExtremeValueKSignal | Overloaded.
Public Method static (Shared in Visual Basic) GeometricMean | Overloaded.
Public Method static (Shared in Visual Basic) GeometricMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) HighestPeriod | Overloaded.
Public Method static (Shared in Visual Basic) InterQuartileRange | Overloaded.
Public Method static (Shared in Visual Basic) Kairi | Overloaded.
Public Method static (Shared in Visual Basic) KFastStochastic | Overloaded.
Public Method static (Shared in Visual Basic) LinearMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) LowerBollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) LowestPeriod | Overloaded.
Public Method static (Shared in Visual Basic) Mean | Overloaded.
Public Method static (Shared in Visual Basic) MeanDeviation | Overloaded.
Public Method static (Shared in Visual Basic) Median | Overloaded.
Public Method static (Shared in Visual Basic) MedianMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) MedianPrice | Overloaded.
Public Method static (Shared in Visual Basic) Momentum | Overloaded.
Public Method static (Shared in Visual Basic) MomentumPercent | Overloaded.
Public Method static (Shared in Visual Basic) MoneyFlowIdxOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) NegativeVolumeIndex | Overloaded.
Public Method static (Shared in Visual Basic) OnBalanceVolume | Overloaded.
Public Method static (Shared in Visual Basic) Percentile25 | Overloaded.
Public Method static (Shared in Visual Basic) Percentile50 | Overloaded.
Public Method static (Shared in Visual Basic) Percentile75 | Overloaded.
Public Method static (Shared in Visual Basic) PositiveVolumeIndex | Overloaded.
Public Method static (Shared in Visual Basic) Range | Overloaded.
Public Method static (Shared in Visual Basic) RateOfChange | Overloaded.
Public Method static (Shared in Visual Basic) SimpleMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) StandardDeviation | Overloaded.
Public Method static (Shared in Visual Basic) TriangularMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) TypicalPrice | Overloaded.
Public Method static (Shared in Visual Basic) UpperBollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) Variance | Overloaded.
Public Method static (Shared in Visual Basic) WeightedMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) ZScore | Overloaded.

See Also

FinancialEngine Class | dotnetCHARTING Namespace


FinancialEngine Class Methods

FinancialEngine Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

FinancialEngine Class Members

For a list of all members of this type, see FinancialEngine members.

Public Methods

Public Method static (Shared in Visual Basic) AcumulateDistributeOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) AroonDown | Overloaded.
Public Method static (Shared in Visual Basic) AroonDownOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) AroonOscillator | Overloaded.
Public Method static (Shared in Visual Basic) AroonOscillatorOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) AroonUp | Overloaded.
Public Method static (Shared in Visual Basic) AroonUpOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) BalanceOfPowerOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) BollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) ChaikinMoneyFlowOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) ChaikinOscillator | Overloaded.
Public Method static (Shared in Visual Basic) ChaikinVolatility | Overloaded.
Public Method static (Shared in Visual Basic) CommodityChannelIdxOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) CrossingExtremeSignal | Overloaded.
Public Method static (Shared in Visual Basic) CrossingSignal | Overloaded.
Public Method static (Shared in Visual Basic) DStochastic | Overloaded.
Public Method static (Shared in Visual Basic) ExponentiallyWeightedMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) ExtremeValueDSignal | Overloaded.
Public Method static (Shared in Visual Basic) ExtremeValueKSignal | Overloaded.
Public Method static (Shared in Visual Basic) GeometricMean | Overloaded.
Public Method static (Shared in Visual Basic) GeometricMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) HighestPeriod | Overloaded.
Public Method static (Shared in Visual Basic) InterQuartileRange | Overloaded.
Public Method static (Shared in Visual Basic) Kairi | Overloaded.
Public Method static (Shared in Visual Basic) KFastStochastic | Overloaded.
Public Method static (Shared in Visual Basic) LinearMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) LowerBollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) LowestPeriod | Overloaded.
Public Method static (Shared in Visual Basic) Mean | Overloaded.
Public Method static (Shared in Visual Basic) MeanDeviation | Overloaded.
Public Method static (Shared in Visual Basic) Median | Overloaded.
Public Method static (Shared in Visual Basic) MedianMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) MedianPrice | Overloaded.
Public Method static (Shared in Visual Basic) Momentum | Overloaded.
Public Method static (Shared in Visual Basic) MomentumPercent | Overloaded.
Public Method static (Shared in Visual Basic) MoneyFlowIdxOverPeriod | Overloaded.
Public Method static (Shared in Visual Basic) NegativeVolumeIndex | Overloaded.
Public Method static (Shared in Visual Basic) OnBalanceVolume | Overloaded.
Public Method static (Shared in Visual Basic) Percentile25 | Overloaded.
Public Method static (Shared in Visual Basic) Percentile50 | Overloaded.
Public Method static (Shared in Visual Basic) Percentile75 | Overloaded.
Public Method static (Shared in Visual Basic) PositiveVolumeIndex | Overloaded.
Public Method static (Shared in Visual Basic) Range | Overloaded.
Public Method static (Shared in Visual Basic) RateOfChange | Overloaded.
Public Method static (Shared in Visual Basic) SimpleMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) StandardDeviation | Overloaded.
Public Method static (Shared in Visual Basic) TriangularMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) TypicalPrice | Overloaded.
Public Method static (Shared in Visual Basic) UpperBollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) Variance | Overloaded.
Public Method static (Shared in Visual Basic) WeightedMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) ZScore | Overloaded.

See Also

FinancialEngine Class | dotnetCHARTING Namespace


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AcumulateDistributeOverPeriod Method

Overload List

Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.

[Visual Basic] Overloads Public Shared Function AcumulateDistributeOverPeriod(Series,Integer) As Series

[C#] public static Series AcumulateDistributeOverPeriod(Series,int);

Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.

[Visual Basic] Overloads Public Shared Function AcumulateDistributeOverPeriod(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection AcumulateDistributeOverPeriod(SeriesCollection,int);

Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.

[Visual Basic] Overloads Public Shared Function AcumulateDistributeOverPeriod(String,Series,Integer) As Series

[C#] public static Series AcumulateDistributeOverPeriod(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


AcumulateDistributeOverPeriod(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A series where the first term is the most recent period, the second term is the previous period and so on.
lengthOfPeriod
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AcumulateDistributeOverPeriod(Series,Int32) Method

Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.

[Visual Basic]
Overloads Public Shared Function AcumulateDistributeOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series AcumulateDistributeOverPeriod(
   Series s,
   int lengthOfPeriod
);

Parameters

s
A series where the first term is the most recent period, the second term is the previous period and so on.
lengthOfPeriod
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.

Remarks

The accumulation/distribution indicator illustrates the degree to which an asset is being accumulated or distributed by the market over each of these collection of periods. The indicator uses the closing price's proximity to the high or low over the period to determine if accumulation or reduction is taking place in the market. The proximity measure if then multiplied by the volume over the period in order to give more weight to moves with correspondingly higher volume.

Interpretation

A divergence between the price action and the AccumulationDistribution indicator can signal that a trend is nearing completion, a trends continuation and break-outs from trading ranges. The actual value of this indicator is of no significance, what is significant is its change in value relative to the previous periods which can warn of a possible break-out during a trading range (falling/rising indicator), the continuation of a trend (higher highs in uptrend, or lower lows in downtrend) or a change/completion of a trend (divergence between the price action and the direction of the indicator).

Example

Say for example we know that:

  1. Highs = {3, 4, 3, 4, 5} (i.e. 3 is the latest high)
  2. Lows = {2, 1, 2, 1, 3} (i.e. 2 is the latest low)
  3. Volume = {300, 290, 295, 285, 290} (i.e. 300 is the volume in the latest period.

Now if the lengthOfPeriod considered is 4, then this method will return an array of length two where the first term is the accumulation\distribution indicator (evaluated using AccumulationDistribution) when:

  1. Highs = {3, 4, 3, 4} (i.e. above highs with last element removed)
  2. Lows = {2, 1, 2, 1} (i.e. above highs with last element removed)
  3. Volume = {300, 290, 295, 285} (i.e. above highs with last element removed)
and the second term is the accumulation/distribution indicator when:
  1. Highs = {4, 3, 4, 5} (i.e. the window moves one position back)
  2. Lows = {1, 2, 1, 3} (i.e. the window moves one position back)
  3. Volume = {290, 295, 285, 290} (i.e. the window moves one position back)

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


AcumulateDistributeOverPeriod(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AcumulateDistributeOverPeriod(SeriesCollection,Int32) Method

Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.

[Visual Basic]
Overloads Public Shared Function AcumulateDistributeOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection AcumulateDistributeOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.

Remarks

The accumulation/distribution indicator illustrates the degree to which an asset is being accumulated or distributed by the market over each of these collection of periods. The indicator uses the closing price's proximity to the high or low over the period to determine if accumulation or reduction is taking place in the market. The proximity measure if then multiplied by the volume over the period in order to give more weight to moves with correspondingly higher volume.

Interpretation

A divergence between the price action and the AccumulationDistribution indicator can signal that a trend is nearing completion, a trends continuation and break-outs from trading ranges. The actual value of this indicator is of no significance, what is significant is its change in value relative to the previous periods which can warn of a possible break-out during a trading range (falling/rising indicator), the continuation of a trend (higher highs in uptrend, or lower lows in downtrend) or a change/completion of a trend (divergence between the price action and the direction of the indicator).

Example

Say for example we know that:

  1. Highs = {3, 4, 3, 4, 5} (i.e. 3 is the latest high)
  2. Lows = {2, 1, 2, 1, 3} (i.e. 2 is the latest low)
  3. Volume = {300, 290, 295, 285, 290} (i.e. 300 is the volume in the latest period.

Now if the lengthOfPeriod considered is 4, then this method will return an array of length two where the first term is the accumulation\distribution indicator (evaluated using AccumulationDistribution) when:

  1. Highs = {3, 4, 3, 4} (i.e. above highs with last element removed)
  2. Lows = {2, 1, 2, 1} (i.e. above highs with last element removed)
  3. Volume = {300, 290, 295, 285} (i.e. above highs with last element removed)
and the second term is the accumulation/distribution indicator when:
  1. Highs = {4, 3, 4, 5} (i.e. the window moves one position back)
  2. Lows = {1, 2, 1, 3} (i.e. the window moves one position back)
  3. Volume = {290, 295, 285, 290} (i.e. the window moves one position back)

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


AcumulateDistributeOverPeriod(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term is the most recent period, the second term is the previous period and so on.
lengthOfPeriod
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AcumulateDistributeOverPeriod(String,Series,Int32) Method

Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.

[Visual Basic]
Overloads Public Shared Function AcumulateDistributeOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series AcumulateDistributeOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term is the most recent period, the second term is the previous period and so on.
lengthOfPeriod
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.

Remarks

The accumulation/distribution indicator illustrates the degree to which an asset is being accumulated or distributed by the market over each of these collection of periods. The indicator uses the closing price's proximity to the high or low over the period to determine if accumulation or reduction is taking place in the market. The proximity measure if then multiplied by the volume over the period in order to give more weight to moves with correspondingly higher volume.

Interpretation

A divergence between the price action and the AccumulationDistribution indicator can signal that a trend is nearing completion, a trends continuation and break-outs from trading ranges. The actual value of this indicator is of no significance, what is significant is its change in value relative to the previous periods which can warn of a possible break-out during a trading range (falling/rising indicator), the continuation of a trend (higher highs in uptrend, or lower lows in downtrend) or a change/completion of a trend (divergence between the price action and the direction of the indicator).

Example

Say for example we know that:

  1. Highs = {3, 4, 3, 4, 5} (i.e. 3 is the latest high)
  2. Lows = {2, 1, 2, 1, 3} (i.e. 2 is the latest low)
  3. Volume = {300, 290, 295, 285, 290} (i.e. 300 is the volume in the latest period.

Now if the lengthOfPeriod considered is 4, then this method will return an array of length two where the first term is the accumulation\distribution indicator (evaluated using AccumulationDistribution(string, Series)) when:

  1. Highs = {3, 4, 3, 4} (i.e. above highs with last element removed)
  2. Lows = {2, 1, 2, 1} (i.e. above highs with last element removed)
  3. Volume = {300, 290, 295, 285} (i.e. above highs with last element removed)
and the second term is the accumulation/distribution indicator when:
  1. Highs = {4, 3, 4, 5} (i.e. the window moves one position back)
  2. Lows = {1, 2, 1, 3} (i.e. the window moves one position back)
  3. Volume = {290, 295, 285, 290} (i.e. the window moves one position back)

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AroonDown Method

Overload List

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function AroonDown(Series) As Element

[C#] public static Element AroonDown(Series);

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function AroonDown(SeriesCollection) As Series

[C#] public static Series AroonDown(SeriesCollection);

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function AroonDown(String,Series) As Element

[C#] public static Element AroonDown(string,Series);

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function AroonDown(String,SeriesCollection) As Series

[C#] public static Series AroonDown(string,SeriesCollection);

See Also

FinancialEngine Class | FinancialEngine Members


AroonDown(Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.

Language

Visual Basic

C#

Show All

s
A financial series.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonDown(Series) Method

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function AroonDown( _
   ByVal s As Series _
) As Element
[C#]
public static Element AroonDown(
   Series s
);

Parameters

s
A financial series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


AroonDown(SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonDown(SeriesCollection) Method

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function AroonDown( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series AroonDown(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


AroonDown(String,Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonDown(String,Series) Method

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function AroonDown( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element AroonDown(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


AroonDown(String,SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonDown(String,SeriesCollection) Method

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function AroonDown( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series AroonDown(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AroonDownOverPeriod Method

Overload List

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function AroonDownOverPeriod(Series,Integer) As Series

[C#] public static Series AroonDownOverPeriod(Series,int);

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function AroonDownOverPeriod(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection AroonDownOverPeriod(SeriesCollection,int);

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function AroonDownOverPeriod(String,Series,Integer) As Series

[C#] public static Series AroonDownOverPeriod(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


AroonDownOverPeriod(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of FinancialAroonDownOverPeriod indicator and calculates the Aroon Down indicator for a single period.

Language

Visual Basic

C#

Show All

s
A financial series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonDownOverPeriod(Series,Int32) Method

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function AroonDownOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series AroonDownOverPeriod(
   Series s,
   int lengthOfPeriod
);

Parameters

s
A financial series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Remarks

The indicator for each period will return a value between 0 and 100, where a higher value indicates that the lowest low was achieved more recently. Persistent values between 70 and 100 are said to indicate weakness in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Up indicator, indicates an downward trend.

Evaluation of the Aroon Down Indicator

The Aroon Down indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of FinancialAroonDownOverPeriod indicator and calculates the Aroon Down indicator for a single period.


AroonDownOverPeriod(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of FinancialAroonDownOverPeriod indicator and calculates the Aroon Down indicator for a single period.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonDownOverPeriod(SeriesCollection,Int32) Method

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function AroonDownOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection AroonDownOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Remarks

The indicator for each period will return a value between 0 and 100, where a higher value indicates that the lowest low was achieved more recently. Persistent values between 70 and 100 are said to indicate weakness in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Up indicator, indicates an downward trend.

Evaluation of the Aroon Down Indicator

The Aroon Down indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of FinancialAroonDownOverPeriod indicator and calculates the Aroon Down indicator for a single period.


AroonDownOverPeriod(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of FinancialAroonDownOverPeriod indicator and calculates the Aroon Down indicator for a single period.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonDownOverPeriod(String,Series,Int32) Method

Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function AroonDownOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series AroonDownOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Remarks

The indicator for each period will return a value between 0 and 100, where a higher value indicates that the lowest low was achieved more recently. Persistent values between 70 and 100 are said to indicate weakness in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Up indicator, indicates an downward trend.

Evaluation of the Aroon Down Indicator

The Aroon Down indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of FinancialAroonDownOverPeriod indicator and calculates the Aroon Down indicator for a single period.


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AroonOscillator Method

Overload List

Evaluates the Aroon Oscillator over the a given period.

[Visual Basic] Overloads Public Shared Function AroonOscillator(Series) As Element

[C#] public static Element AroonOscillator(Series);

Evaluates the Aroon Oscillator over the a given period.

[Visual Basic] Overloads Public Shared Function AroonOscillator(SeriesCollection) As Series

[C#] public static Series AroonOscillator(SeriesCollection);

Evaluates the Aroon Oscillator over the a given period.

[Visual Basic] Overloads Public Shared Function AroonOscillator(String,Series) As Element

[C#] public static Element AroonOscillator(string,Series);

Evaluates the Aroon Oscillator over the a given period.

[Visual Basic] Overloads Public Shared Function AroonOscillator(String,SeriesCollection) As Series

[C#] public static Series AroonOscillator(string,SeriesCollection);

See Also

FinancialEngine Class | FinancialEngine Members


AroonOscillator(Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List | calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.

Language

Visual Basic

C#

Show All

s
A series where the first term is the traded low of the asset within the most recent trading period, the second term is the traded low of the asset within the previous period and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonOscillator(Series) Method

Evaluates the Aroon Oscillator over the a given period.

[Visual Basic]
Overloads Public Shared Function AroonOscillator( _
   ByVal s As Series _
) As Element
[C#]
public static Element AroonOscillator(
   Series s
);

Parameters

s
A series where the first term is the traded low of the asset within the most recent trading period, the second term is the traded low of the asset within the previous period and so on.

Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.


AroonOscillator(SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List | calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonOscillator(SeriesCollection) Method

Evaluates the Aroon Oscillator over the a given period.

[Visual Basic]
Overloads Public Shared Function AroonOscillator( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series AroonOscillator(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.


AroonOscillator(String,Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List | calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A series where the first term is the traded low of the asset within the most recent trading period, the second term is the traded low of the asset within the previous period and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonOscillator(String,Series) Method

Evaluates the Aroon Oscillator over the a given period.

[Visual Basic]
Overloads Public Shared Function AroonOscillator( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element AroonOscillator(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A series where the first term is the traded low of the asset within the most recent trading period, the second term is the traded low of the asset within the previous period and so on.

Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.


AroonOscillator(String,SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List | calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonOscillator(String,SeriesCollection) Method

Evaluates the Aroon Oscillator over the a given period.

[Visual Basic]
Overloads Public Shared Function AroonOscillator( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series AroonOscillator(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AroonOscillatorOverPeriod Method

Overload List

Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.

[Visual Basic] Overloads Public Shared Function AroonOscillatorOverPeriod(Series,Integer) As Series

[C#] public static Series AroonOscillatorOverPeriod(Series,int);

Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.

[Visual Basic] Overloads Public Shared Function AroonOscillatorOverPeriod(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection AroonOscillatorOverPeriod(SeriesCollection,int);

Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.

[Visual Basic] Overloads Public Shared Function AroonOscillatorOverPeriod(String,Series,Integer) As Series

[C#] public static Series AroonOscillatorOverPeriod(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


AroonOscillatorOverPeriod(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonOscillatorOverPeriod(Series,Int32) Method

Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.

[Visual Basic]
Overloads Public Shared Function AroonOscillatorOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series AroonOscillatorOverPeriod(
   Series s,
   int lengthOfPeriod
);

Parameters

s
A series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Type

A series where the first term is the value of the Aroon Oscillator for the most recent period, the second term is the value of the Aroon Oscillator for the previous period and so on.

Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator)

where 'Aroon Up Indicator' and `Aroon Down Indicator' are evaluated using.

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

The Aroon Down indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


AroonOscillatorOverPeriod(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonOscillatorOverPeriod(SeriesCollection,Int32) Method

Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.

[Visual Basic]
Overloads Public Shared Function AroonOscillatorOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection AroonOscillatorOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Type

A series where the first term is the value of the Aroon Oscillator for the most recent period, the second term is the value of the Aroon Oscillator for the previous period and so on.

Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator)

where 'Aroon Up Indicator' and `Aroon Down Indicator' are evaluated using.

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

The Aroon Down indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


AroonOscillatorOverPeriod(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonOscillatorOverPeriod(String,Series,Int32) Method

Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.

[Visual Basic]
Overloads Public Shared Function AroonOscillatorOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series AroonOscillatorOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Type

A series where the first term is the value of the Aroon Oscillator for the most recent period, the second term is the value of the Aroon Oscillator for the previous period and so on.

Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator)

where 'Aroon Up Indicator' and `Aroon Down Indicator' are evaluated using.

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

The Aroon Down indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AroonUp Method

Overload List

Evaluates the Aroon Up indicator which measures the relative time since the last highest high.

[Visual Basic] Overloads Public Shared Function AroonUp(Series) As Element

[C#] public static Element AroonUp(Series);

Evaluates the Aroon Up indicator which measures the relative time since the last highest high.

[Visual Basic] Overloads Public Shared Function AroonUp(SeriesCollection) As Series

[C#] public static Series AroonUp(SeriesCollection);

Evaluates the Aroon Up indicator which measures the relative time since the last highest high.

[Visual Basic] Overloads Public Shared Function AroonUp(String,Series) As Element

[C#] public static Element AroonUp(string,Series);

Evaluates the Aroon Up indicator which measures the relative time since the last highest high.

[Visual Basic] Overloads Public Shared Function AroonUp(String,SeriesCollection) As Series

[C#] public static Series AroonUp(string,SeriesCollection);

See Also

FinancialEngine Class | FinancialEngine Members


AroonUp(Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.

Language

Visual Basic

C#

Show All

s
A series of the trading highs over the last n-periods where the k-th terms of the array if the trading high on the k-th previous period.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonUp(Series) Method

Evaluates the Aroon Up indicator which measures the relative time since the last highest high.

[Visual Basic]
Overloads Public Shared Function AroonUp( _
   ByVal s As Series _
) As Element
[C#]
public static Element AroonUp(
   Series s
);

Parameters

s
A series of the trading highs over the last n-periods where the k-th terms of the array if the trading high on the k-th previous period.

Remarks

The indicator will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


AroonUp(SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonUp(SeriesCollection) Method

Evaluates the Aroon Up indicator which measures the relative time since the last highest high.

[Visual Basic]
Overloads Public Shared Function AroonUp( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series AroonUp(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

The indicator will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


AroonUp(String,Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A series of the trading highs over the last n-periods where the k-th terms of the array if the trading high on the k-th previous period.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonUp(String,Series) Method

Evaluates the Aroon Up indicator which measures the relative time since the last highest high.

[Visual Basic]
Overloads Public Shared Function AroonUp( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element AroonUp(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A series of the trading highs over the last n-periods where the k-th terms of the array if the trading high on the k-th previous period.

Remarks

The indicator will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


AroonUp(String,SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonUp(String,SeriesCollection) Method

Evaluates the Aroon Up indicator which measures the relative time since the last highest high.

[Visual Basic]
Overloads Public Shared Function AroonUp( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series AroonUp(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

The indicator will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AroonUpOverPeriod Method

Overload List

Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function AroonUpOverPeriod(Series,Integer) As Series

[C#] public static Series AroonUpOverPeriod(Series,int);

Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function AroonUpOverPeriod(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection AroonUpOverPeriod(SeriesCollection,int);

Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function AroonUpOverPeriod(String,Series,Integer) As Series

[C#] public static Series AroonUpOverPeriod(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


AroonUpOverPeriod(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of AroonUpOverPeriod indicator and calculates the Aroon Up indicator for a single period.

Language

Visual Basic

C#

Show All

s
An financial series of the trading highs over the last n-periods where the k-th term of the array if the trading high on the k-th previous period.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonUpOverPeriod(Series,Int32) Method

Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function AroonUpOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series AroonUpOverPeriod(
   Series s,
   int lengthOfPeriod
);

Parameters

s
An financial series of the trading highs over the last n-periods where the k-th term of the array if the trading high on the k-th previous period.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Type

Returnsa series where the first term is the values of the Aroon Up indicator over the earliest set of consecutive periods and the second term is the value of the next set of the periods (i.e. the windows is moving one place along), and so on.

Remarks

This indicator for each period will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range(i.e. 0-30) of the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of AroonUpOverPeriod indicator and calculates the Aroon Up indicator for a single period.


AroonUpOverPeriod(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of AroonUpOverPeriod indicator and calculates the Aroon Up indicator for a single period.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonUpOverPeriod(SeriesCollection,Int32) Method

Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function AroonUpOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection AroonUpOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Type

Returnsa series where the first term is the values of the Aroon Up indicator over the earliest set of consecutive periods and the second term is the value of the next set of the periods (i.e. the windows is moving one place along), and so on.

Remarks

This indicator for each period will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range(i.e. 0-30) of the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of AroonUpOverPeriod indicator and calculates the Aroon Up indicator for a single period.


AroonUpOverPeriod(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of AroonUpOverPeriod indicator and calculates the Aroon Up indicator for a single period.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An financial series of the trading highs over the last n-periods where the k-th term of the array if the trading high on the k-th previous period.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

AroonUpOverPeriod(String,Series,Int32) Method

Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function AroonUpOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series AroonUpOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An financial series of the trading highs over the last n-periods where the k-th term of the array if the trading high on the k-th previous period.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Type

Returnsa series where the first term is the values of the Aroon Up indicator over the earliest set of consecutive periods and the second term is the value of the next set of the periods (i.e. the windows is moving one place along), and so on.

Remarks

This indicator for each period will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range(i.e. 0-30) of the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | This indicator is a special case of AroonUpOverPeriod indicator and calculates the Aroon Up indicator for a single period.


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

BalanceOfPowerOverPeriod Method

Overload List

Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.

[Visual Basic] Overloads Public Shared Function BalanceOfPowerOverPeriod(Series) As Series

[C#] public static Series BalanceOfPowerOverPeriod(Series);

Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.

[Visual Basic] Overloads Public Shared Function BalanceOfPowerOverPeriod(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection BalanceOfPowerOverPeriod(SeriesCollection);

Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.

[Visual Basic] Overloads Public Shared Function BalanceOfPowerOverPeriod(String,Series) As Series

[C#] public static Series BalanceOfPowerOverPeriod(string,Series);

See Also

FinancialEngine Class | FinancialEngine Members


BalanceOfPowerOverPeriod(Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

BalanceOfPowerOverPeriod(Series) Method

Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.

[Visual Basic]
Overloads Public Shared Function BalanceOfPowerOverPeriod( _
   ByVal s As Series _
) As Series
[C#]
public static Series BalanceOfPowerOverPeriod(
   Series s
);

Parameters

s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.

Return Type

A series is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if any elements from the highs, lows, closes or opens are strictly negative.

Remarks

An array is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.

Interpretation

The BOP indicator for each trading day lies within the range [-1,1]. When the BOP indicator is towards the high if its range it will signifies that the Bulls are in control, conversely when the indicator is towards the lows of its range it signifies that the bear are in control. If the indicator move from a high positive range to a lower positive range it signifies that the buying pressure is decreasing. Conversely, if the indicator move from a low negative range to a higher negative range it signifies that the selling pressure is decreasing.

Evaluation

The BOP indicator for each trading days is evaluated by the following formulae:

BOP = (Close - Open)/(High - Low)

where close is the days closing price, open is the days opening price, high is the highest traded price during the day and low is the lowest traded price during the day.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


BalanceOfPowerOverPeriod(SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

BalanceOfPowerOverPeriod(SeriesCollection) Method

Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.

[Visual Basic]
Overloads Public Shared Function BalanceOfPowerOverPeriod( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection BalanceOfPowerOverPeriod(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Return Type

A series is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if any elements from the highs, lows, closes or opens are strictly negative.

Remarks

An array is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.

Interpretation

The BOP indicator for each trading day lies within the range [-1,1]. When the BOP indicator is towards the high if its range it will signifies that the Bulls are in control, conversely when the indicator is towards the lows of its range it signifies that the bear are in control. If the indicator move from a high positive range to a lower positive range it signifies that the buying pressure is decreasing. Conversely, if the indicator move from a low negative range to a higher negative range it signifies that the selling pressure is decreasing.

Evaluation

The BOP indicator for each trading days is evaluated by the following formulae:

BOP = (Close - Open)/(High - Low)

where close is the days closing price, open is the days opening price, high is the highest traded price during the day and low is the lowest traded price during the day.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


BalanceOfPowerOverPeriod(String,Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

BalanceOfPowerOverPeriod(String,Series) Method

Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.

[Visual Basic]
Overloads Public Shared Function BalanceOfPowerOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series BalanceOfPowerOverPeriod(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.

Return Type

A series is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if any elements from the highs, lows, closes or opens are strictly negative.

Remarks

An array is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.

Interpretation

The BOP indicator for each trading day lies within the range [-1,1]. When the BOP indicator is towards the high if its range it will signifies that the Bulls are in control, conversely when the indicator is towards the lows of its range it signifies that the bear are in control. If the indicator move from a high positive range to a lower positive range it signifies that the buying pressure is decreasing. Conversely, if the indicator move from a low negative range to a higher negative range it signifies that the selling pressure is decreasing.

Evaluation

The BOP indicator for each trading days is evaluated by the following formulae:

BOP = (Close - Open)/(High - Low)

where close is the days closing price, open is the days opening price, high is the highest traded price during the day and low is the lowest traded price during the day.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

BollingerBands Method

Overload List

Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.

[Visual Basic] Overloads Public Shared Function BollingerBands(Series,ElementValue,Double,Integer) As SeriesCollection

[C#] public static SeriesCollection BollingerBands(Series,ElementValue,double,int);

Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.

[Visual Basic] Overloads Public Shared Function BollingerBands(SeriesCollection,ElementValue,Double,Integer) As SeriesCollection

[C#] public static SeriesCollection BollingerBands(SeriesCollection,ElementValue,double,int);

See Also

FinancialEngine Class | FinancialEngine Members


BollingerBands(Series,ElementValue,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

BollingerBands(Series,ElementValue,Double,Int32) Method

Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.

[Visual Basic]
Overloads Public Shared Function BollingerBands( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection BollingerBands(
   Series s,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Remarks

Further Details

Bollinger Bands are a type of envelope that are plotted at standard deviation levels above and below the corresponding (simple) moving average. This produces an effect of having the bands widen during periods of higher volatility and contract during less volatile periods. Bollinger Bands indicate the relative supply and demand for a given asset. If the asset to move close to the top of the envelope then it indicates that there is strong demand for the asset, conversely if the asset hugs the bottom of the trading range then it indicates that there is oversupply of the asset.

Since the Bollinger Bands will nearly always be combined with other indicators when forming a trading system the number of periods used in the evaluation of the standard deviation of the stocks and the moving average will vary. For those without design restrictions a popular choice of the number of time periods is around 20-23.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


BollingerBands(SeriesCollection,ElementValue,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

BollingerBands(SeriesCollection,ElementValue,Double,Int32) Method

Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.

[Visual Basic]
Overloads Public Shared Function BollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection BollingerBands(
   SeriesCollection sc,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Remarks

Further Details

Bollinger Bands are a type of envelope that are plotted at standard deviation levels above and below the corresponding (simple) moving average. This produces an effect of having the bands widen during periods of higher volatility and contract during less volatile periods. Bollinger Bands indicate the relative supply and demand for a given asset. If the asset to move close to the top of the envelope then it indicates that there is strong demand for the asset, conversely if the asset hugs the bottom of the trading range then it indicates that there is oversupply of the asset.

Since the Bollinger Bands will nearly always be combined with other indicators when forming a trading system the number of periods used in the evaluation of the standard deviation of the stocks and the moving average will vary. For those without design restrictions a popular choice of the number of time periods is around 20-23.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinMoneyFlowOverPeriod Method

Overload List

Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.

[Visual Basic] Overloads Public Shared Function ChaikinMoneyFlowOverPeriod(Series,Integer) As Series

[C#] public static Series ChaikinMoneyFlowOverPeriod(Series,int);

Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.

[Visual Basic] Overloads Public Shared Function ChaikinMoneyFlowOverPeriod(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection ChaikinMoneyFlowOverPeriod(SeriesCollection,int);

Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.

[Visual Basic] Overloads Public Shared Function ChaikinMoneyFlowOverPeriod(String,Series,Integer) As Series

[C#] public static Series ChaikinMoneyFlowOverPeriod(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


ChaikinMoneyFlowOverPeriod(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A financial series.
lengthOfPeriod
An integer which represents the number of periods over which the indicator is calculated.
See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinMoneyFlowOverPeriod(Series,Int32) Method

Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.

[Visual Basic]
Overloads Public Shared Function ChaikinMoneyFlowOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series ChaikinMoneyFlowOverPeriod(
   Series s,
   int lengthOfPeriod
);

Parameters

s
A financial series.
lengthOfPeriod
An integer which represents the number of periods over which the indicator is calculated.

Remarks

In particular, this method returns an array where the 1st term of the CMF indicator for the latest period, the second term of the CMF in the previous period and so on. Please note that the CMF will be evaluated for all periods for which there is sufficient data (see example below for more details).

Remark: The form in which the Chaikin Money Flow (CMF) in provided here is particularly suitable when wishing to integrated this functionality within a Client side GUI Charting Application.

Details of Chaikin Money Flow (CMF)

Chaikin Money Flow (CMF) is a volume weighted average of Accumulation/Distribution over a specified period, which is usually taken to be 21 days. The CMF offers a volume weighted indicator on the following two principles:

  • The nearer the close is to the high the more accumulation is taking place.
  • The nearer the close is to the low the more distribution is taking place.

Evaluation

The CMF indicator is evaluated for the following steps:

  • Evaluate the Volume Weighted Accumulation/Distribution over each of the days within the period considered for the calculation. The Volume Weighted Accumulation/Distribution on each day is given by:

    (((Close - Low)-(High - Close))/(High - Low)) * Volume
  • Sum the Volume Weighted Accumulation/Distribution over the period and the divide the result by the sum of the volume over the period.

Example of Application

Within this example we illustrate the way this method works when we consider a given 10 period in which the length of period over which the CHM is evaluated is 4. In this case the result will be an array of 7 elements as follows:

  • result[0]: CMF calculated over the last four periods
  • result[1]: CMF calculated over previous four periods
  • ...
  • result[7]: CMF calculated using the periods between the earliest period and the fourth from earliest period.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ChaikinMoneyFlowOverPeriod(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the number of periods over which the indicator is calculated.
See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinMoneyFlowOverPeriod(SeriesCollection,Int32) Method

Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.

[Visual Basic]
Overloads Public Shared Function ChaikinMoneyFlowOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection ChaikinMoneyFlowOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the number of periods over which the indicator is calculated.

Remarks

In particular, this method returns an array where the 1st term of the CMF indicator for the latest period, the second term of the CMF in the previous period and so on. Please note that the CMF will be evaluated for all periods for which there is sufficient data (see example below for more details).

Remark: The form in which the Chaikin Money Flow (CMF) in provided here is particularly suitable when wishing to integrated this functionality within a Client side GUI Charting Application.

Details of Chaikin Money Flow (CMF)

Chaikin Money Flow (CMF) is a volume weighted average of Accumulation/Distribution over a specified period, which is usually taken to be 21 days. The CMF offers a volume weighted indicator on the following two principles:

  • The nearer the close is to the high the more accumulation is taking place.
  • The nearer the close is to the low the more distribution is taking place.

Evaluation

The CMF indicator is evaluated for the following steps:

  • Evaluate the Volume Weighted Accumulation/Distribution over each of the days within the period considered for the calculation. The Volume Weighted Accumulation/Distribution on each day is given by:

    (((Close - Low)-(High - Close))/(High - Low)) * Volume
  • Sum the Volume Weighted Accumulation/Distribution over the period and the divide the result by the sum of the volume over the period.

Example of Application

Within this example we illustrate the way this method works when we consider a given 10 period in which the length of period over which the CHM is evaluated is 4. In this case the result will be an array of 7 elements as follows:

  • result[0]: CMF calculated over the last four periods
  • result[1]: CMF calculated over previous four periods
  • ...
  • result[7]: CMF calculated using the periods between the earliest period and the fourth from earliest period.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ChaikinMoneyFlowOverPeriod(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
lengthOfPeriod
An integer which represents the number of periods over which the indicator is calculated.
See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinMoneyFlowOverPeriod(String,Series,Int32) Method

Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.

[Visual Basic]
Overloads Public Shared Function ChaikinMoneyFlowOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series ChaikinMoneyFlowOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
lengthOfPeriod
An integer which represents the number of periods over which the indicator is calculated.

Remarks

In particular, this method returns an array where the 1st term of the CMF indicator for the latest period, the second term of the CMF in the previous period and so on. Please note that the CMF will be evaluated for all periods for which there is sufficient data (see example below for more details).

Remark: The form in which the Chaikin Money Flow (CMF) in provided here is particularly suitable when wishing to integrated this functionality within a Client side GUI Charting Application.

Details of Chaikin Money Flow (CMF)

Chaikin Money Flow (CMF) is a volume weighted average of Accumulation/Distribution over a specified period, which is usually taken to be 21 days. The CMF offers a volume weighted indicator on the following two principles:

  • The nearer the close is to the high the more accumulation is taking place.
  • The nearer the close is to the low the more distribution is taking place.

Evaluation

The CMF indicator is evaluated for the following steps:

  • Evaluate the Volume Weighted Accumulation/Distribution over each of the days within the period considered for the calculation. The Volume Weighted Accumulation/Distribution on each day is given by:

    (((Close - Low)-(High - Close))/(High - Low)) * Volume
  • Sum the Volume Weighted Accumulation/Distribution over the period and the divide the result by the sum of the volume over the period.

Example of Application

Within this example we illustrate the way this method works when we consider a given 10 period in which the length of period over which the CHM is evaluated is 4. In this case the result will be an array of 7 elements as follows:

  • result[0]: CMF calculated over the last four periods
  • result[1]: CMF calculated over previous four periods
  • ...
  • result[7]: CMF calculated using the periods between the earliest period and the fourth from earliest period.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinOscillator Method

Overload List

This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.

[Visual Basic] Overloads Public Shared Function ChaikinOscillator(Series,Double) As Series

[C#] public static Series ChaikinOscillator(Series,double);

This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.

[Visual Basic] Overloads Public Shared Function ChaikinOscillator(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection ChaikinOscillator(SeriesCollection,int);

This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.

[Visual Basic] Overloads Public Shared Function ChaikinOscillator(String,Series,Double) As Series

[C#] public static Series ChaikinOscillator(string,Series,double);

See Also

FinancialEngine Class | FinancialEngine Members


ChaikinOscillator(Series,Double) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A financial series.
smoothingFactor
The number between 0 and 1. The lower the number the more sensitive the indicator is.
See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinOscillator(Series,Double) Method

This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.

[Visual Basic]
Overloads Public Shared Function ChaikinOscillator( _
   ByVal s As Series, _
   ByVal smoothingFactor As Double _
) As Series
[C#]
public static Series ChaikinOscillator(
   Series s,
   double smoothingFactor
);

Parameters

s
A financial series.
smoothingFactor
The number between 0 and 1. The lower the number the more sensitive the indicator is.

Return Type

A series where the first term is the value of the oscillator using the last 10 days data, the previous term is the value of the oscillator on the previous period and so on.

Remarks

The Chaikin Oscillator presents the information contained within the A/D indicator in the convenient form of an oscillator. That is, the Chaikin Oscillator is simply the Moving Average Convergence Divergence indicator (MACD) applied to the Accumulation/Distribution Line.

Interpretation

A sell signal is when price action develops a higher high into overbought zones and the Chaikin Oscillator diverges with a lower high and begins to fall. Conversely, a buy signal is generated when price action develops a lower low into oversold zones and the oscillator diverges with a higher low and begins to rise. The Chaikin Oscillator can also be used to time entry to existing trends by either buying the dip (when the oscillator turns down) or selling the rally (when the oscillator turns up).

Evaluation

The Chaiken Oscillator for a given period is given by:

EMA_3(Accumulate/Distribution) - EMA_10(Accumulate/Distribution),

where EMA_3 and EMA_10 is the exponential moving average over 3 and 10 days respectively; and Accumulate/Distribution is the corresponding indicator over those 3 or 10 days respectively.

Illustration

If we are provided within the high, low and volume over the last 15 periods, then we will be able to evaluate the Chaikin Oscillator on the previous 5 trading days. Since the evaluation of the oscillator on a given period requires knowledge of the 10 previous periods data.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ChaikinOscillator(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
smoothingFactor
The number between 0 and 1. The lower the number the more sensitive the indicator is.
See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinOscillator(SeriesCollection,Int32) Method

This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.

[Visual Basic]
Overloads Public Shared Function ChaikinOscillator( _
   ByVal sc As SeriesCollection, _
   ByVal smoothingFactor As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection ChaikinOscillator(
   SeriesCollection sc,
   int smoothingFactor
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
smoothingFactor
The number between 0 and 1. The lower the number the more sensitive the indicator is.

Return Type

A series where the first term is the value of the oscillator using the last 10 days data, the previous term is the value of the oscillator on the previous period and so on.

Remarks

The Chaikin Oscillator presents the information contained within the A/D indicator in the convenient form of an oscillator. That is, the Chaikin Oscillator is simply the Moving Average Convergence Divergence indicator (MACD) applied to the Accumulation/Distribution Line.

Interpretation

A sell signal is when price action develops a higher high into overbought zones and the Chaikin Oscillator diverges with a lower high and begins to fall. Conversely, a buy signal is generated when price action develops a lower low into oversold zones and the oscillator diverges with a higher low and begins to rise. The Chaikin Oscillator can also be used to time entry to existing trends by either buying the dip (when the oscillator turns down) or selling the rally (when the oscillator turns up).

Evaluation

The Chaiken Oscillator for a given period is given by:

EMA_3(Accumulate/Distribution) - EMA_10(Accumulate/Distribution),

where EMA_3 and EMA_10 is the exponential moving average over 3 and 10 days respectively; and Accumulate/Distribution is the corresponding indicator over those 3 or 10 days respectively.

Illustration

If we are provided within the high, low and volume over the last 15 periods, then we will be able to evaluate the Chaikin Oscillator on the previous 5 trading days. Since the evaluation of the oscillator on a given period requires knowledge of the 10 previous periods data.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ChaikinOscillator(String,Series,Double) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
smoothingFactor
The number between 0 and 1. The lower the number the more sensitive the indicator is.
See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinOscillator(String,Series,Double) Method

This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.

[Visual Basic]
Overloads Public Shared Function ChaikinOscillator( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal smoothingFactor As Double _
) As Series
[C#]
public static Series ChaikinOscillator(
   string seriesName,
   Series s,
   double smoothingFactor
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
smoothingFactor
The number between 0 and 1. The lower the number the more sensitive the indicator is.

Return Type

A series where the first term is the value of the oscillator using the last 10 days data, the previous term is the value of the oscillator on the previous period and so on.

Remarks

The Chaikin Oscillator presents the information contained within the A/D indicator in the convenient form of an oscillator. That is, the Chaikin Oscillator is simply the Moving Average Convergence Divergence indicator (MACD) applied to the Accumulation/Distribution Line.

Interpretation

A sell signal is when price action develops a higher high into overbought zones and the Chaikin Oscillator diverges with a lower high and begins to fall. Conversely, a buy signal is generated when price action develops a lower low into oversold zones and the oscillator diverges with a higher low and begins to rise. The Chaikin Oscillator can also be used to time entry to existing trends by either buying the dip (when the oscillator turns down) or selling the rally (when the oscillator turns up).

Evaluation

The Chaiken Oscillator for a given period is given by:

EMA_3(Accumulate/Distribution) - EMA_10(Accumulate/Distribution),

where EMA_3 and EMA_10 is the exponential moving average over 3 and 10 days respectively; and Accumulate/Distribution is the corresponding indicator over those 3 or 10 days respectively.

Illustration

If we are provided within the high, low and volume over the last 15 periods, then we will be able to evaluate the Chaikin Oscillator on the previous 5 trading days. Since the evaluation of the oscillator on a given period requires knowledge of the 10 previous periods data.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinVolatility Method

Overload List

Chaikin's Volatility indicator compares the spread between a security's high and low prices.

[Visual Basic] Overloads Public Shared Function ChaikinVolatility(Series,Integer,Integer) As Series

[C#] public static Series ChaikinVolatility(Series,int,int);

Chaikin's Volatility indicator compares the spread between a security's high and low prices.

[Visual Basic] Overloads Public Shared Function ChaikinVolatility(SeriesCollection,Integer,Integer) As SeriesCollection

[C#] public static SeriesCollection ChaikinVolatility(SeriesCollection,int,int);

Chaikin's Volatility indicator compares the spread between a security's high and low prices.

[Visual Basic] Overloads Public Shared Function ChaikinVolatility(String,Series,Integer,Integer) As Series

[C#] public static Series ChaikinVolatility(string,Series,int,int);

See Also

FinancialEngine Class | FinancialEngine Members


ChaikinVolatility(Series,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A financial series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
noOfPeriods
An integer which represents the number of previous time periods used over which the comparing moving average is taken.
See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinVolatility(Series,Int32,Int32) Method

Chaikin's Volatility indicator compares the spread between a security's high and low prices.

[Visual Basic]
Overloads Public Shared Function ChaikinVolatility( _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer, _
   ByVal noOfPeriods As Integer _
) As Series
[C#]
public static Series ChaikinVolatility(
   Series s,
   int lengthOfMA,
   int noOfPeriods
);

Parameters

s
A financial series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
noOfPeriods
An integer which represents the number of previous time periods used over which the comparing moving average is taken.

Exceptions

Exception | Description
ArgumentException | Thrown if either parameter is strictly negative or arrays closes or volumes are empty.

Remarks

It quantifies volatility as a widening of the range between the high and the low price.

Indicator Formula

The formula for this indicator is:

  1. chaikinVolatility = ((H-LAverage - H-LAverage_n_periods_ago)/H-LAverage_n_periods_ago)*100

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ChaikinVolatility(SeriesCollection,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
noOfPeriods
An integer which represents the number of previous time periods used over which the comparing moving average is taken.
See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinVolatility(SeriesCollection,Int32,Int32) Method

Chaikin's Volatility indicator compares the spread between a security's high and low prices.

[Visual Basic]
Overloads Public Shared Function ChaikinVolatility( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer, _
   ByVal noOfPeriods As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection ChaikinVolatility(
   SeriesCollection sc,
   int lengthOfMA,
   int noOfPeriods
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
noOfPeriods
An integer which represents the number of previous time periods used over which the comparing moving average is taken.

Exceptions

Exception | Description
ArgumentException | Thrown if either parameter is strictly negative or arrays closes or volumes are empty.

Remarks

It quantifies volatility as a widening of the range between the high and the low price.

Indicator Formula

The formula for this indicator is:

  1. chaikinVolatility = ((H-LAverage - H-LAverage_n_periods_ago)/H-LAverage_n_periods_ago)*100

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ChaikinVolatility(String,Series,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
noOfPeriods
An integer which represents the number of previous time periods used over which the comparing moving average is taken.
See Also Languages dotnetCHARTING Send comments on this topic.

ChaikinVolatility(String,Series,Int32,Int32) Method

Chaikin's Volatility indicator compares the spread between a security's high and low prices.

[Visual Basic]
Overloads Public Shared Function ChaikinVolatility( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer, _
   ByVal noOfPeriods As Integer _
) As Series
[C#]
public static Series ChaikinVolatility(
   string seriesName,
   Series s,
   int lengthOfMA,
   int noOfPeriods
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
noOfPeriods
An integer which represents the number of previous time periods used over which the comparing moving average is taken.

Exceptions

Exception | Description
ArgumentException | Thrown if either parameter is strictly negative or arrays closes or volumes are empty.

Remarks

It quantifies volatility as a widening of the range between the high and the low price.

Indicator Formula

The formula for this indicator is:

  1. chaikinVolatility = ((H-LAverage - H-LAverage_n_periods_ago)/H-LAverage_n_periods_ago)*100

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CommodityChannelIdxOverPeriod Method

Overload List

This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.

[Visual Basic] Overloads Public Shared Function CommodityChannelIdxOverPeriod(Series,Integer) As Series

[C#] public static Series CommodityChannelIdxOverPeriod(Series,int);

This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.

[Visual Basic] Overloads Public Shared Function CommodityChannelIdxOverPeriod(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection CommodityChannelIdxOverPeriod(SeriesCollection,int);

This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.

[Visual Basic] Overloads Public Shared Function CommodityChannelIdxOverPeriod(String,Series,Integer) As Series

[C#] public static Series CommodityChannelIdxOverPeriod(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


CommodityChannelIdxOverPeriod(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

CommodityChannelIdxOverPeriod(Series,Int32) Method

This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.

[Visual Basic]
Overloads Public Shared Function CommodityChannelIdxOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series CommodityChannelIdxOverPeriod(
   Series s,
   int lengthOfPeriod
);

Parameters

s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Exceptions

Exception | Description
ArgumentException | Thrown if any elements from the highs, lows or closes are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.

Remarks

The CCI measures the variation of a security's price from its statistical mean. High values show that prices are unusually high compared to average prices whereas low values indicate that prices are unusually low. The CCI can be used effectively on any type of security, but clearly it is most applicable where the security has should a strong degree on mean reversion.

Lambert originally commended that the CCI was designed to capture the trade cycle (i.e. low-to-low or high-to-high) turns in commodity markets. The system assumes that commodities move in cycles and uses 1/3 of the cycle period for the evaluation of the CCI. We allow the uses to specify the length of the calculation period used but we advise that you take the calculation cycle to be approximately one third of your estimate for the length of the trade cycle.

Calculation Period: the number of days used in the evaluation of the CCI. In Donald Lambert's original system this was taken to be one third of the estimate length of the trade cycle.

Remark: Within the evaluation procedure (step 2), we multiply the result by the constant 0.015. The constant was originally used in Lambert's system and has been found to ensure that around 70-80 percent of all the values given by the CCI lie the range [-100,+100]. Hence, the constant is just used to calibrate the indicator with respect to the range [-100, +100].

Interpretation
Significant signals are generated when either the CCI starts to diverge from the price action which will signify a correlation in the price, or when the CCI extended (typically above 100 or below -100) which indicates oversold or over brought conditions.

Further details concerning the CCI can be found in an article by Donald Lambert that appeared in the October 1980 issue of Commodities (now known as Futures) Magazine.

Evaluation Procedure
We summaries our basic evaluation procedure by the following three steps:

  • First evaluate the simple moving average (SMA) of the Typical Price Indicator (see Filters) over the calculation period.
  • Evaluate the SMA over the calculation period of the absolute value on each on the calculation period days between the Typical Price on that day and the SMA found in step 1 above, and multiply the result by 0.015.
  • Divide todays typical price minus the SMA of the typical price found in step 1, by the result given by step 2.

    • See Also

    FinancialEngine Class | FinancialEngine Members | Overload List


CommodityChannelIdxOverPeriod(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

CommodityChannelIdxOverPeriod(SeriesCollection,Int32) Method

This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.

[Visual Basic]
Overloads Public Shared Function CommodityChannelIdxOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection CommodityChannelIdxOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Exceptions

Exception | Description
ArgumentException | Thrown if any elements from the highs, lows or closes are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.

Remarks

The CCI measures the variation of a security's price from its statistical mean. High values show that prices are unusually high compared to average prices whereas low values indicate that prices are unusually low. The CCI can be used effectively on any type of security, but clearly it is most applicable where the security has should a strong degree on mean reversion.

Lambert originally commended that the CCI was designed to capture the trade cycle (i.e. low-to-low or high-to-high) turns in commodity markets. The system assumes that commodities move in cycles and uses 1/3 of the cycle period for the evaluation of the CCI. We allow the uses to specify the length of the calculation period used but we advise that you take the calculation cycle to be approximately one third of your estimate for the length of the trade cycle.

Calculation Period: the number of days used in the evaluation of the CCI. In Donald Lambert's original system this was taken to be one third of the estimate length of the trade cycle.

Remark: Within the evaluation procedure (step 2), we multiply the result by the constant 0.015. The constant was originally used in Lambert's system and has been found to ensure that around 70-80 percent of all the values given by the CCI lie the range [-100,+100]. Hence, the constant is just used to calibrate the indicator with respect to the range [-100, +100].

Interpretation
Significant signals are generated when either the CCI starts to diverge from the price action which will signify a correlation in the price, or when the CCI extended (typically above 100 or below -100) which indicates oversold or over brought conditions.

Further details concerning the CCI can be found in an article by Donald Lambert that appeared in the October 1980 issue of Commodities (now known as Futures) Magazine.

Evaluation Procedure
We summaries our basic evaluation procedure by the following three steps:

  • First evaluate the simple moving average (SMA) of the Typical Price Indicator (see Filters) over the calculation period.
  • Evaluate the SMA over the calculation period of the absolute value on each on the calculation period days between the Typical Price on that day and the SMA found in step 1 above, and multiply the result by 0.015.
  • Divide todays typical price minus the SMA of the typical price found in step 1, by the result given by step 2.

    • See Also

    FinancialEngine Class | FinancialEngine Members | Overload List


CommodityChannelIdxOverPeriod(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

CommodityChannelIdxOverPeriod(String,Series,Int32) Method

This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.

[Visual Basic]
Overloads Public Shared Function CommodityChannelIdxOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series CommodityChannelIdxOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Exceptions

Exception | Description
ArgumentException | Thrown if any elements from the highs, lows or closes are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.

Remarks

The CCI measures the variation of a security's price from its statistical mean. High values show that prices are unusually high compared to average prices whereas low values indicate that prices are unusually low. The CCI can be used effectively on any type of security, but clearly it is most applicable where the security has should a strong degree on mean reversion.

Lambert originally commended that the CCI was designed to capture the trade cycle (i.e. low-to-low or high-to-high) turns in commodity markets. The system assumes that commodities move in cycles and uses 1/3 of the cycle period for the evaluation of the CCI. We allow the uses to specify the length of the calculation period used but we advise that you take the calculation cycle to be approximately one third of your estimate for the length of the trade cycle.

Calculation Period: the number of days used in the evaluation of the CCI. In Donald Lambert's original system this was taken to be one third of the estimate length of the trade cycle.

Remark: Within the evaluation procedure (step 2), we multiply the result by the constant 0.015. The constant was originally used in Lambert's system and has been found to ensure that around 70-80 percent of all the values given by the CCI lie the range [-100,+100]. Hence, the constant is just used to calibrate the indicator with respect to the range [-100, +100].

Interpretation
Significant signals are generated when either the CCI starts to diverge from the price action which will signify a correlation in the price, or when the CCI extended (typically above 100 or below -100) which indicates oversold or over brought conditions.

Further details concerning the CCI can be found in an article by Donald Lambert that appeared in the October 1980 issue of Commodities (now known as Futures) Magazine.

Evaluation Procedure
We summaries our basic evaluation procedure by the following three steps:

  • First evaluate the simple moving average (SMA) of the Typical Price Indicator (see Filters) over the calculation period.
  • Evaluate the SMA over the calculation period of the absolute value on each on the calculation period days between the Typical Price on that day and the SMA found in step 1 above, and multiply the result by 0.015.
  • Divide todays typical price minus the SMA of the typical price found in step 1, by the result given by step 2.

    • See Also

    FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CrossingExtremeSignal Method

Overload List

This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast K Stochastic crosses the slow D Stochastic either above or below the extremal values.

[Visual Basic] Overloads Public Shared Function CrossingExtremeSignal(Series,Double,Double,Integer,Integer,Integer) As Series

[C#] public static Series CrossingExtremeSignal(Series,double,double,int,int,int);

This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast K Stochastic crosses the slow D Stochastic either above or below the extremal values.

[Visual Basic] Overloads Public Shared Function CrossingExtremeSignal(SeriesCollection,Double,Double,Integer,Integer,Integer) As SeriesCollection

[C#] public static SeriesCollection CrossingExtremeSignal(SeriesCollection,double,double,int,int,int);

This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast K Stochastic crosses the slow D Stochastic either above or below the extremal values.

[Visual Basic] Overloads Public Shared Function CrossingExtremeSignal(String,Series,Double,Double,Integer,Integer,Integer) As Series

[C#] public static Series CrossingExtremeSignal(string,Series,double,double,int,int,int);

See Also

FinancialEngine Class | FinancialEngine Members


CrossingExtremeSignal(Series,Double,Double,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

.
lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

CrossingExtremeSignal(Series,Double,Double,Int32,Int32,Int32) Method

This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast K Stochastic crosses the slow D Stochastic either above or below the extremal values.

[Visual Basic]
Overloads Public Shared Function CrossingExtremeSignal( _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series CrossingExtremeSignal(
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

.
lengthOfMA
The number of periods over which the moving average is considered.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Trading System Rules

This system generates buy and sell signals respectively when one of the following is triggered:

  1. Buy Signal: When the fast K Stochastic crosses above the slow D Stochastic and this crossing takes place at a value lower than the extremumLow, then a buy signal is generated.
  2. Sell Signal: When the fast K Stochastic crosses above the slow D Stochastic and this crossing takes place at a value higher than the extremumHigh, then a sell signal in generated.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


CrossingExtremeSignal(SeriesCollection,Double,Double,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

.
lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

CrossingExtremeSignal(SeriesCollection,Double,Double,Int32,Int32,Int32) Method

This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast K Stochastic crosses the slow D Stochastic either above or below the extremal values.

[Visual Basic]
Overloads Public Shared Function CrossingExtremeSignal( _
   ByVal sc As SeriesCollection, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection CrossingExtremeSignal(
   SeriesCollection sc,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

.
lengthOfMA
The number of periods over which the moving average is considered.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Trading System Rules

This system generates buy and sell signals respectively when one of the following is triggered:

  1. Buy Signal: When the fast K Stochastic crosses above the slow D Stochastic and this crossing takes place at a value lower than the extremumLow, then a buy signal is generated.
  2. Sell Signal: When the fast K Stochastic crosses above the slow D Stochastic and this crossing takes place at a value higher than the extremumHigh, then a sell signal in generated.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


CrossingExtremeSignal(String,Series,Double,Double,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

.
lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

CrossingExtremeSignal(String,Series,Double,Double,Int32,Int32,Int32) Method

This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast K Stochastic crosses the slow D Stochastic either above or below the extremal values.

[Visual Basic]
Overloads Public Shared Function CrossingExtremeSignal( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series CrossingExtremeSignal(
   string seriesName,
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

seriesName
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

.
lengthOfMA
The number of periods over which the moving average is considered.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Trading System Rules

This system generates buy and sell signals respectively when one of the following is triggered:

  1. Buy Signal: When the fast K Stochastic crosses above the slow D Stochastic and this crossing takes place at a value lower than the extremumLow, then a buy signal is generated.
  2. Sell Signal: When the fast K Stochastic crosses above the slow D Stochastic and this crossing takes place at a value higher than the extremumHigh, then a sell signal in generated.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CrossingSignal Method

Overload List

Implements a general framework for producing trading signals based on the crossing of two Stochastics.

[Visual Basic] Overloads Public Shared Function CrossingSignal(Series,Integer,Integer,Integer) As Series

[C#] public static Series CrossingSignal(Series,int,int,int);

Implements a general framework for producing trading signals based on the crossing of two Stochastics.

[Visual Basic] Overloads Public Shared Function CrossingSignal(SeriesCollection,Integer,Integer,Integer) As SeriesCollection

[C#] public static SeriesCollection CrossingSignal(SeriesCollection,int,int,int);

Implements a general framework for producing trading signals based on the crossing of two Stochastics.

[Visual Basic] Overloads Public Shared Function CrossingSignal(String,Series,Integer,Integer,Integer) As Series

[C#] public static Series CrossingSignal(string,Series,int,int,int);

See Also

FinancialEngine Class | FinancialEngine Members


CrossingSignal(Series,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
The name of the series which will be displayed on the chart, i.e. its label.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

CrossingSignal(Series,Int32,Int32,Int32) Method

Implements a general framework for producing trading signals based on the crossing of two Stochastics.

[Visual Basic]
Overloads Public Shared Function CrossingSignal( _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series CrossingSignal(
   Series s,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

s
The name of the series which will be displayed on the chart, i.e. its label.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
lengthOfMA
The number of periods over which the moving average is considered.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Methodology

Buy when the Stochastic K, crosses above the MA D and sell when the Stochastic K falls below the MA of Stochastic D. Since this approach is prone to being whip-sawed we use two (general) Stochastics so that a MA of the %K Stochastic of the first Stochastic and an even more smoothed second Stochastic. In this case a sell signal is generated if the first (more sensitive) Stochastic cross below the second (smoothed) Stochastic, and a buy signal is generated if the first Stochastic crosses above the second Stochastic.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


CrossingSignal(SeriesCollection,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

CrossingSignal(SeriesCollection,Int32,Int32,Int32) Method

Implements a general framework for producing trading signals based on the crossing of two Stochastics.

[Visual Basic]
Overloads Public Shared Function CrossingSignal( _
   ByVal sc As SeriesCollection, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection CrossingSignal(
   SeriesCollection sc,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
lengthOfMA
The number of periods over which the moving average is considered.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Methodology

Buy when the Stochastic K, crosses above the MA D and sell when the Stochastic K falls below the MA of Stochastic D. Since this approach is prone to being whip-sawed we use two (general) Stochastics so that a MA of the %K Stochastic of the first Stochastic and an even more smoothed second Stochastic. In this case a sell signal is generated if the first (more sensitive) Stochastic cross below the second (smoothed) Stochastic, and a buy signal is generated if the first Stochastic crosses above the second Stochastic.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


CrossingSignal(String,Series,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
s
The name of the series which will be displayed on the chart, i.e. its label.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

CrossingSignal(String,Series,Int32,Int32,Int32) Method

Implements a general framework for producing trading signals based on the crossing of two Stochastics.

[Visual Basic]
Overloads Public Shared Function CrossingSignal( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series CrossingSignal(
   string seriesName,
   Series s,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

seriesName
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
s
The name of the series which will be displayed on the chart, i.e. its label.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
lengthOfMA
The number of periods over which the moving average is considered.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Methodology

Buy when the Stochastic K, crosses above the MA D and sell when the Stochastic K falls below the MA of Stochastic D. Since this approach is prone to being whip-sawed we use two (general) Stochastics so that a MA of the %K Stochastic of the first Stochastic and an even more smoothed second Stochastic. In this case a sell signal is generated if the first (more sensitive) Stochastic cross below the second (smoothed) Stochastic, and a buy signal is generated if the first Stochastic crosses above the second Stochastic.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DStochastic Method

Overload List

Evaluate the (general) %D Stochastic.

[Visual Basic] Overloads Public Shared Function DStochastic(Series,Integer,Integer,Integer) As Series

[C#] public static Series DStochastic(Series,int,int,int);

Evaluate the (general) %D Stochastic.

[Visual Basic] Overloads Public Shared Function DStochastic(SeriesCollection,Integer,Integer,Integer) As SeriesCollection

[C#] public static SeriesCollection DStochastic(SeriesCollection,int,int,int);

Evaluate the (general) %D Stochastic.

[Visual Basic] Overloads Public Shared Function DStochastic(String,Series,Integer,Integer,Integer) As Series

[C#] public static Series DStochastic(string,Series,int,int,int);

See Also

FinancialEngine Class | FinancialEngine Members


DStochastic(Series,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
The name of the series which will be displayed on the chart, i.e. its label.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

DStochastic(Series,Int32,Int32,Int32) Method

Evaluate the (general) %D Stochastic.

[Visual Basic]
Overloads Public Shared Function DStochastic( _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series DStochastic(
   Series s,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

s
The name of the series which will be displayed on the chart, i.e. its label.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.

Remarks

This is just the moving average of the (fast) When the simple moving average is used and the moving average is take over three days, the resulting indicator to referred to as the K Stochastic.

As one would expect the Moving Average D of the K Stochastic depends on:

  • MA Method - This is the method by which the moving average of the Stochastic K is evaluated. We offer a range of methods for the evaluation of the moving average, these include: simple, exponential, geometric, weighted, linearly weighted and exponentially weighted.

Remark When the simple moving average is used and it is evaluated over 3-days, then the D Stochastic reduces to what is known as the slow K Stochastic.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


DStochastic(SeriesCollection,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

DStochastic(SeriesCollection,Int32,Int32,Int32) Method

Evaluate the (general) %D Stochastic.

[Visual Basic]
Overloads Public Shared Function DStochastic( _
   ByVal sc As SeriesCollection, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection DStochastic(
   SeriesCollection sc,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.

Remarks

This is just the moving average of the (fast) When the simple moving average is used and the moving average is take over three days, the resulting indicator to referred to as the K Stochastic.

As one would expect the Moving Average D of the K Stochastic depends on:

  • MA Method - This is the method by which the moving average of the Stochastic K is evaluated. We offer a range of methods for the evaluation of the moving average, these include: simple, exponential, geometric, weighted, linearly weighted and exponentially weighted.

Remark When the simple moving average is used and it is evaluated over 3-days, then the D Stochastic reduces to what is known as the slow K Stochastic.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


DStochastic(String,Series,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
s
The name of the series which will be displayed on the chart, i.e. its label.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

DStochastic(String,Series,Int32,Int32,Int32) Method

Evaluate the (general) %D Stochastic.

[Visual Basic]
Overloads Public Shared Function DStochastic( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series DStochastic(
   string seriesName,
   Series s,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

seriesName
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
s
The name of the series which will be displayed on the chart, i.e. its label.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.

Remarks

This is just the moving average of the (fast) When the simple moving average is used and the moving average is take over three days, the resulting indicator to referred to as the K Stochastic.

As one would expect the Moving Average D of the K Stochastic depends on:

  • MA Method - This is the method by which the moving average of the Stochastic K is evaluated. We offer a range of methods for the evaluation of the moving average, these include: simple, exponential, geometric, weighted, linearly weighted and exponentially weighted.

Remark When the simple moving average is used and it is evaluated over 3-days, then the D Stochastic reduces to what is known as the slow K Stochastic.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ExponentiallyWeightedMovingAverage Method

Overload List

Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function ExponentiallyWeightedMovingAverage(Series,ElementValue,Double,Integer) As Series

[C#] public static Series ExponentiallyWeightedMovingAverage(Series,ElementValue,double,int);

Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function ExponentiallyWeightedMovingAverage(SeriesCollection,ElementValue,Double,Integer) As SeriesCollection

[C#] public static SeriesCollection ExponentiallyWeightedMovingAverage(SeriesCollection,ElementValue,double,int);

Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function ExponentiallyWeightedMovingAverage(String,Series,ElementValue,Double,Integer) As Series

[C#] public static Series ExponentiallyWeightedMovingAverage(string,Series,ElementValue,double,int);

See Also

FinancialEngine Class | FinancialEngine Members


ExponentiallyWeightedMovingAverage(Series,ElementValue,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A series where the first value corresponds to the value of the asset in the tth period, and the second value corresponds to the value of the asset in the t-1-th period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

ExponentiallyWeightedMovingAverage(Series,ElementValue,Double,Int32) Method

Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series ExponentiallyWeightedMovingAverage(
   Series s,
   ElementValue elementValue,
   double smoothingFactor,
   int lengthOfMA
);

Parameters

s
A series where the first value corresponds to the value of the asset in the tth period, and the second value corresponds to the value of the asset in the t-1-th period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ExponentiallyWeightedMovingAverage(SeriesCollection,ElementValue,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

ExponentiallyWeightedMovingAverage(SeriesCollection,ElementValue,Double,Int32) Method

Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection ExponentiallyWeightedMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   double smoothingFactor,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ExponentiallyWeightedMovingAverage(String,Series,ElementValue,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first value corresponds to the value of the asset in the tth period, and the second value corresponds to the value of the asset in the t-1-th period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

ExponentiallyWeightedMovingAverage(String,Series,ElementValue,Double,Int32) Method

Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series ExponentiallyWeightedMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   double smoothingFactor,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first value corresponds to the value of the asset in the tth period, and the second value corresponds to the value of the asset in the t-1-th period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ExtremeValueDSignal Method

Overload List

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic] Overloads Public Shared Function ExtremeValueDSignal(Series,Double,Double,Integer,Integer,Integer) As Series

[C#] public static Series ExtremeValueDSignal(Series,double,double,int,int,int);

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic] Overloads Public Shared Function ExtremeValueDSignal(SeriesCollection,Double,Double,Integer,Integer,Integer) As SeriesCollection

[C#] public static SeriesCollection ExtremeValueDSignal(SeriesCollection,double,double,int,int,int);

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic] Overloads Public Shared Function ExtremeValueDSignal(String,Series,Double,Double,Integer,Integer,Integer) As Series

[C#] public static Series ExtremeValueDSignal(string,Series,double,double,int,int,int);

See Also

FinancialEngine Class | FinancialEngine Members


ExtremeValueDSignal(Series,Double,Double,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

ExtremeValueDSignal(Series,Double,Double,Int32,Int32,Int32) Method

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic]
Overloads Public Shared Function ExtremeValueDSignal( _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series ExtremeValueDSignal(
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Note, that the general ides of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the Oscillator the Stochastic %D falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ExtremeValueDSignal(SeriesCollection,Double,Double,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

ExtremeValueDSignal(SeriesCollection,Double,Double,Int32,Int32,Int32) Method

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic]
Overloads Public Shared Function ExtremeValueDSignal( _
   ByVal sc As SeriesCollection, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection ExtremeValueDSignal(
   SeriesCollection sc,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Note, that the general ides of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the Oscillator the Stochastic %D falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ExtremeValueDSignal(String,Series,Double,Double,Int32,Int32,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.
See Also Languages dotnetCHARTING Send comments on this topic.

ExtremeValueDSignal(String,Series,Double,Double,Int32,Int32,Int32) Method

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic]
Overloads Public Shared Function ExtremeValueDSignal( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series ExtremeValueDSignal(
   string seriesName,
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
);

Parameters

seriesName
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage.

lengthOfMA
The number of periods over which the moving average is considered.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Note, that the general ides of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the Oscillator the Stochastic %D falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ExtremeValueKSignal Method

Overload List

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic] Overloads Public Shared Function ExtremeValueKSignal(Series,Double,Double,Integer) As Series

[C#] public static Series ExtremeValueKSignal(Series,double,double,int);

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic] Overloads Public Shared Function ExtremeValueKSignal(SeriesCollection,Double,Double,Integer) As SeriesCollection

[C#] public static SeriesCollection ExtremeValueKSignal(SeriesCollection,double,double,int);

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic] Overloads Public Shared Function ExtremeValueKSignal(String,Series,Double,Double,Integer) As Series

[C#] public static Series ExtremeValueKSignal(string,Series,double,double,int);

See Also

FinancialEngine Class | FinancialEngine Members


ExtremeValueKSignal(Series,Double,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

ExtremeValueKSignal(Series,Double,Double,Int32) Method

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic]
Overloads Public Shared Function ExtremeValueKSignal( _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer _
) As Series
[C#]
public static Series ExtremeValueKSignal(
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods
);

Parameters

s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Note, that the general ideea of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the the Stochastic %K falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ExtremeValueKSignal(SeriesCollection,Double,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

ExtremeValueKSignal(SeriesCollection,Double,Double,Int32) Method

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic]
Overloads Public Shared Function ExtremeValueKSignal( _
   ByVal sc As SeriesCollection, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection ExtremeValueKSignal(
   SeriesCollection sc,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Note, that the general ideea of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the the Stochastic %K falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ExtremeValueKSignal(String,Series,Double,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

ExtremeValueKSignal(String,Series,Double,Double,Int32) Method

Implements a general framework for producing extreme value trading signals using Stochastic indicators.

[Visual Basic]
Overloads Public Shared Function ExtremeValueKSignal( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer _
) As Series
[C#]
public static Series ExtremeValueKSignal(
   string seriesName,
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods
);

Parameters

seriesName
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
s
The name of the series which will be displayed on the chart, i.e. its label.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.

Return Type

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.

Remarks

Note, that the general ideea of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the the Stochastic %K falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMean Method

Overload List

Calculates the geometric mean of the series's elements values.

[Visual Basic] Overloads Public Shared Function GeometricMean(Series,ElementValue) As Element

[C#] public static Element GeometricMean(Series,ElementValue);

Calculates the geometric mean of the series's elements values.

[Visual Basic] Overloads Public Shared Function GeometricMean(SeriesCollection,ElementValue) As Series

[C#] public static Series GeometricMean(SeriesCollection,ElementValue);

Calculates the geometric mean of the series's elements values.

[Visual Basic] Overloads Public Shared Function GeometricMean(String,Series,ElementValue) As Element

[C#] public static Element GeometricMean(string,Series,ElementValue);

Calculates the geometric mean of the series's elements values.

[Visual Basic] Overloads Public Shared Function GeometricMean(String,SeriesCollection,ElementValue) As Series

[C#] public static Series GeometricMean(string,SeriesCollection,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


GeometricMean(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the arithmetic mean of the series.

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMean(Series,ElementValue) Method

Calculates the geometric mean of the series's elements values.

[Visual Basic]
Overloads Public Shared Function GeometricMean( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element GeometricMean(
   Series s,
   ElementValue elementValue
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the arithmetic mean of the series.


GeometricMean(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the arithmetic mean of the series.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMean(SeriesCollection,ElementValue) Method

Calculates the geometric mean of the series's elements values.

[Visual Basic]
Overloads Public Shared Function GeometricMean( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series GeometricMean(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the arithmetic mean of the series.


GeometricMean(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the arithmetic mean of the series.

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMean(String,Series,ElementValue) Method

Calculates the geometric mean of the series's elements values.

[Visual Basic]
Overloads Public Shared Function GeometricMean( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element GeometricMean(
   string elementName,
   Series s,
   ElementValue elementValue
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the arithmetic mean of the series.


GeometricMean(String,SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the arithmetic mean of the series.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMean(String,SeriesCollection,ElementValue) Method

Calculates the geometric mean of the series's elements values.

[Visual Basic]
Overloads Public Shared Function GeometricMean( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series GeometricMean(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the arithmetic mean of the series.


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMovingAverage Method

Overload List

Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function GeometricMovingAverage(Series,ElementValue,Integer) As Series

[C#] public static Series GeometricMovingAverage(Series,ElementValue,int);

Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function GeometricMovingAverage(SeriesCollection,ElementValue,Integer) As SeriesCollection

[C#] public static SeriesCollection GeometricMovingAverage(SeriesCollection,ElementValue,int);

Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function GeometricMovingAverage(String,Series,ElementValue,Integer) As Series

[C#] public static Series GeometricMovingAverage(string,Series,ElementValue,int);

See Also

FinancialEngine Class | FinancialEngine Members


GeometricMovingAverage(Series,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A series containing the values of the time series being considered. Where the first element gives the last historical value, the second term the previous periods value and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMovingAverage(Series,ElementValue,Int32) Method

Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function GeometricMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series GeometricMovingAverage(
   Series s,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

s
A series containing the values of the time series being considered. Where the first element gives the last historical value, the second term the previous periods value and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day Geometric Moving Average (i.e. passing the length of the GMA of 5), then this method will evaluate the Geometric Moving Average (GMA) for all days for which the closing price on that day and the four previous days is known.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


GeometricMovingAverage(SeriesCollection,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMovingAverage(SeriesCollection,ElementValue,Int32) Method

Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function GeometricMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection GeometricMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day Geometric Moving Average (i.e. passing the length of the GMA of 5), then this method will evaluate the Geometric Moving Average (GMA) for all days for which the closing price on that day and the four previous days is known.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


GeometricMovingAverage(String,Series,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series containing the values of the time series being considered. Where the first element gives the last historical value, the second term the previous periods value and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMovingAverage(String,Series,ElementValue,Int32) Method

Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function GeometricMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series GeometricMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series containing the values of the time series being considered. Where the first element gives the last historical value, the second term the previous periods value and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day Geometric Moving Average (i.e. passing the length of the GMA of 5), then this method will evaluate the Geometric Moving Average (GMA) for all days for which the closing price on that day and the four previous days is known.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HighestPeriod Method

Overload List

Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.

[Visual Basic] Overloads Public Shared Function HighestPeriod(Series,Integer) As Series

[C#] public static Series HighestPeriod(Series,int);

Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.

[Visual Basic] Overloads Public Shared Function HighestPeriod(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection HighestPeriod(SeriesCollection,int);

Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.

[Visual Basic] Overloads Public Shared Function HighestPeriod(String,Series,Integer) As Series

[C#] public static Series HighestPeriod(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


HighestPeriod(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

HighestPeriod(Series,Int32) Method

Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.

[Visual Basic]
Overloads Public Shared Function HighestPeriod( _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
[C#]
public static Series HighestPeriod(
   Series s,
   int noOfDays
);

Parameters

s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Type

a series where the first term is the high calculated for the most recent trading period, the second term is the high for the previous trading period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


HighestPeriod(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

HighestPeriod(SeriesCollection,Int32) Method

Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.

[Visual Basic]
Overloads Public Shared Function HighestPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal noOfDays As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection HighestPeriod(
   SeriesCollection sc,
   int noOfDays
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.

Return Type

a series where the first term is the high calculated for the most recent trading period, the second term is the high for the previous trading period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


HighestPeriod(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

HighestPeriod(String,Series,Int32) Method

Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.

[Visual Basic]
Overloads Public Shared Function HighestPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
[C#]
public static Series HighestPeriod(
   string seriesName,
   Series s,
   int noOfDays
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Type

a series where the first term is the high calculated for the most recent trading period, the second term is the high for the previous trading period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InterQuartileRange Method

Overload List

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic] Overloads Public Shared Function InterQuartileRange(Series,ElementValue) As Element

[C#] public static Element InterQuartileRange(Series,ElementValue);

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic] Overloads Public Shared Function InterQuartileRange(SeriesCollection,ElementValue) As Series

[C#] public static Series InterQuartileRange(SeriesCollection,ElementValue);

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic] Overloads Public Shared Function InterQuartileRange(String,Series,ElementValue) As Element

[C#] public static Element InterQuartileRange(string,Series,ElementValue);

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic] Overloads Public Shared Function InterQuartileRange(String,SeriesCollection,ElementValue) As Series

[C#] public static Series InterQuartileRange(string,SeriesCollection,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


InterQuartileRange(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

InterQuartileRange(Series,ElementValue) Method

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic]
Overloads Public Shared Function InterQuartileRange( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element InterQuartileRange(
   Series s,
   ElementValue elementValue
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


InterQuartileRange(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

InterQuartileRange(SeriesCollection,ElementValue) Method

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic]
Overloads Public Shared Function InterQuartileRange( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series InterQuartileRange(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


InterQuartileRange(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

InterQuartileRange(String,Series,ElementValue) Method

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic]
Overloads Public Shared Function InterQuartileRange( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element InterQuartileRange(
   string elementName,
   Series s,
   ElementValue elementValue
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


InterQuartileRange(String,SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

InterQuartileRange(String,SeriesCollection,ElementValue) Method

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic]
Overloads Public Shared Function InterQuartileRange( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series InterQuartileRange(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Kairi Method

Overload List

Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.

[Visual Basic] Overloads Public Shared Function Kairi(Series,ElementValue,Series) As Series

[C#] public static Series Kairi(Series,ElementValue,Series);

Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.

[Visual Basic] Overloads Public Shared Function Kairi(Series,ElementValue,SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection Kairi(Series,ElementValue,SeriesCollection);

Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.

[Visual Basic] Overloads Public Shared Function Kairi(String,Series,ElementValue,Series) As Series

[C#] public static Series Kairi(string,Series,ElementValue,Series);

See Also

FinancialEngine Class | FinancialEngine Members


Kairi(Series,ElementValue,Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
movingAverageSeries
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

Kairi(Series,ElementValue,Series) Method

Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.

[Visual Basic]
Overloads Public Shared Function Kairi( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal movingAverageSeries As Series _
) As Series
[C#]
public static Series Kairi(
   Series s,
   ElementValue elementValue,
   Series movingAverageSeries
);

Parameters

s
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
movingAverageSeries
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.

Return Type

An series where the first term returns the Kairi indicator expressed as decimal format (i.e. 0.01 = 1 percent) for the most recent period, the second term returns the Kairi indicator for the previous period and so on.

Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

Application

The Kairi Indicator can be used in order to take advantage of an over extended trending market. For example, in an upwardly trending market when the price gets say more than 10% above the simple moving average, the asset could be sold and repurchased when the next hits the simple moving average again.

The Kairi Indicator could also be used in order to detect market tops and bottom. The idea being that market tops and bottoms often occur when the price is at an extreme value in relation to its moving average. That is, the Kairi Indicator should take an extreme value at market tops and bottoms.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Kairi(Series,ElementValue,SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
movingAverages
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

Kairi(Series,ElementValue,SeriesCollection) Method

Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.

[Visual Basic]
Overloads Public Shared Function Kairi( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal movingAverages As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection Kairi(
   Series s,
   ElementValue elementValue,
   SeriesCollection movingAverages
);

Parameters

s
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
movingAverages
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.

Return Type

An series where the first term returns the Kairi indicator expressed as decimal format (i.e. 0.01 = 1 percent) for the most recent period, the second term returns the Kairi indicator for the previous period and so on.

Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

Application

The Kairi Indicator can be used in order to take advantage of an over extended trending market. For example, in an upwardly trending market when the price gets say more than 10% above the simple moving average, the asset could be sold and repurchased when the next hits the simple moving average again.

The Kairi Indicator could also be used in order to detect market tops and bottom. The idea being that market tops and bottoms often occur when the price is at an extreme value in relation to its moving average. That is, the Kairi Indicator should take an extreme value at market tops and bottoms.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Kairi(String,Series,ElementValue,Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
movingAverageSeries
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

Kairi(String,Series,ElementValue,Series) Method

Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.

[Visual Basic]
Overloads Public Shared Function Kairi( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal movingAverageSeries As Series _
) As Series
[C#]
public static Series Kairi(
   string seriesName,
   Series s,
   ElementValue elementValue,
   Series movingAverageSeries
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
movingAverageSeries
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.

Return Type

An series where the first term returns the Kairi indicator expressed as decimal format (i.e. 0.01 = 1 percent) for the most recent period, the second term returns the Kairi indicator for the previous period and so on.

Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

Application

The Kairi Indicator can be used in order to take advantage of an over extended trending market. For example, in an upwardly trending market when the price gets say more than 10% above the simple moving average, the asset could be sold and repurchased when the next hits the simple moving average again.

The Kairi Indicator could also be used in order to detect market tops and bottom. The idea being that market tops and bottoms often occur when the price is at an extreme value in relation to its moving average. That is, the Kairi Indicator should take an extreme value at market tops and bottoms.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

KFastStochastic Method

Overload List

Evaluation of the Fast

Indicator variables

The Stochastic K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

[Visual Basic] Overloads Public Shared Function KFastStochastic(Series,Integer) As Series

[C#] public static Series KFastStochastic(Series,int);

Evaluation of the Fast

Indicator variables

The Stochastic K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

[Visual Basic] Overloads Public Shared Function KFastStochastic(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection KFastStochastic(SeriesCollection,int);

Evaluation of the Fast

Indicator variables

The Stochastic K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

[Visual Basic] Overloads Public Shared Function KFastStochastic(String,Series,Integer) As Series

[C#] public static Series KFastStochastic(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


KFastStochastic(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfPeriods
An integer which represents the number of previous time periods used over which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

KFastStochastic(Series,Int32) Method

Evaluation of the Fast

Indicator variables

The Stochastic K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

[Visual Basic]
Overloads Public Shared Function KFastStochastic( _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer _
) As Series
[C#]
public static Series KFastStochastic(
   Series s,
   int noOfPeriods
);

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfPeriods
An integer which represents the number of previous time periods used over which the closing price is compared.

Return Type

A series where the first term is the KFastStochastic calculated for the most recent period, the second term is the KFastStochastic calculated for the previous period and so on.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


KFastStochastic(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfPeriods
An integer which represents the number of previous time periods used over which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

KFastStochastic(SeriesCollection,Int32) Method

Evaluation of the Fast

Indicator variables

The Stochastic K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

[Visual Basic]
Overloads Public Shared Function KFastStochastic( _
   ByVal sc As SeriesCollection, _
   ByVal noOfPeriods As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection KFastStochastic(
   SeriesCollection sc,
   int noOfPeriods
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfPeriods
An integer which represents the number of previous time periods used over which the closing price is compared.

Return Type

A series where the first term is the KFastStochastic calculated for the most recent period, the second term is the KFastStochastic calculated for the previous period and so on.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


KFastStochastic(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfPeriods
An integer which represents the number of previous time periods used over which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

KFastStochastic(String,Series,Int32) Method

Evaluation of the Fast

Indicator variables

The Stochastic K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

[Visual Basic]
Overloads Public Shared Function KFastStochastic( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer _
) As Series
[C#]
public static Series KFastStochastic(
   string seriesName,
   Series s,
   int noOfPeriods
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfPeriods
An integer which represents the number of previous time periods used over which the closing price is compared.

Return Type

A series where the first term is the KFastStochastic calculated for the most recent period, the second term is the KFastStochastic calculated for the previous period and so on.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LinearMovingAverage Method

Overload List

Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic] Overloads Public Shared Function LinearMovingAverage(Series,ElementValue,Integer) As Series

[C#] public static Series LinearMovingAverage(Series,ElementValue,int);

Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic] Overloads Public Shared Function LinearMovingAverage(SeriesCollection,ElementValue,Integer) As SeriesCollection

[C#] public static SeriesCollection LinearMovingAverage(SeriesCollection,ElementValue,int);

Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic] Overloads Public Shared Function LinearMovingAverage(String,Series,ElementValue,Integer) As Series

[C#] public static Series LinearMovingAverage(string,Series,ElementValue,int);

See Also

FinancialEngine Class | FinancialEngine Members


LinearMovingAverage(Series,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A series where the first element is the price on the earliest period, the second element is the price on the next earliest period and on so.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

LinearMovingAverage(Series,ElementValue,Int32) Method

Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic]
Overloads Public Shared Function LinearMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series LinearMovingAverage(
   Series s,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

s
A series where the first element is the price on the earliest period, the second element is the price on the next earliest period and on so.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series priceSeries is empty or if its length is less than the lengthofMA.

Remarks

The Linearly Weighted Moving Average(LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


LinearMovingAverage(SeriesCollection,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

LinearMovingAverage(SeriesCollection,ElementValue,Int32) Method

Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic]
Overloads Public Shared Function LinearMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection LinearMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Type

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series priceSeries is empty or if its length is less than the lengthofMA.

Remarks

The Linearly Weighted Moving Average(LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


LinearMovingAverage(String,Series,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first element is the price on the earliest period, the second element is the price on the next earliest period and on so.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

LinearMovingAverage(String,Series,ElementValue,Int32) Method

Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic]
Overloads Public Shared Function LinearMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series LinearMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first element is the price on the earliest period, the second element is the price on the next earliest period and on so.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series priceSeries is empty or if its length is less than the lengthofMA.

Remarks

The Linearly Weighted Moving Average(LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LowerBollingerBands Method

Overload List

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function LowerBollingerBands(Series,ElementValue,Double,Integer) As Series

[C#] public static Series LowerBollingerBands(Series,ElementValue,double,int);

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function LowerBollingerBands(SeriesCollection,ElementValue,Double,Integer) As SeriesCollection

[C#] public static SeriesCollection LowerBollingerBands(SeriesCollection,ElementValue,double,int);

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function LowerBollingerBands(String,Series,ElementValue,Double,Integer) As Series

[C#] public static Series LowerBollingerBands(string,Series,ElementValue,double,int);

See Also

FinancialEngine Class | FinancialEngine Members


LowerBollingerBands(Series,ElementValue,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

LowerBollingerBands(Series,ElementValue,Double,Int32) Method

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function LowerBollingerBands( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series LowerBollingerBands(
   Series s,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

s
A series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


LowerBollingerBands(SeriesCollection,ElementValue,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

LowerBollingerBands(SeriesCollection,ElementValue,Double,Int32) Method

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function LowerBollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection LowerBollingerBands(
   SeriesCollection sc,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


LowerBollingerBands(String,Series,ElementValue,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

LowerBollingerBands(String,Series,ElementValue,Double,Int32) Method

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function LowerBollingerBands( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series LowerBollingerBands(
   string seriesName,
   Series s,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LowestPeriod Method

Overload List

Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.

[Visual Basic] Overloads Public Shared Function LowestPeriod(Series,Integer) As Series

[C#] public static Series LowestPeriod(Series,int);

Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.

[Visual Basic] Overloads Public Shared Function LowestPeriod(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection LowestPeriod(SeriesCollection,int);

Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.

[Visual Basic] Overloads Public Shared Function LowestPeriod(String,Series,Integer) As Series

[C#] public static Series LowestPeriod(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


LowestPeriod(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

LowestPeriod(Series,Int32) Method

Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.

[Visual Basic]
Overloads Public Shared Function LowestPeriod( _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
[C#]
public static Series LowestPeriod(
   Series s,
   int noOfDays
);

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Type

A series where the first term is the low calculated for the most recent trading period, the second term is the low for the previous trading period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


LowestPeriod(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

LowestPeriod(SeriesCollection,Int32) Method

Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.

[Visual Basic]
Overloads Public Shared Function LowestPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal noOfDays As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection LowestPeriod(
   SeriesCollection sc,
   int noOfDays
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.

Return Type

A series where the first term is the low calculated for the most recent trading period, the second term is the low for the previous trading period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


LowestPeriod(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

LowestPeriod(String,Series,Int32) Method

Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.

[Visual Basic]
Overloads Public Shared Function LowestPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
[C#]
public static Series LowestPeriod(
   string seriesName,
   Series s,
   int noOfDays
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Type

A series where the first term is the low calculated for the most recent trading period, the second term is the low for the previous trading period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Mean Method

Overload List

Calculates the arithmetic mean of the elements values of the series.

[Visual Basic] Overloads Public Shared Function Mean(Series,ElementValue) As Element

[C#] public static Element Mean(Series,ElementValue);

Calculates the arithmetic mean of the elements values of the series.

[Visual Basic] Overloads Public Shared Function Mean(SeriesCollection,ElementValue) As Series

[C#] public static Series Mean(SeriesCollection,ElementValue);

Calculates the arithmetic mean of the elements values of the series.

[Visual Basic] Overloads Public Shared Function Mean(String,Series,ElementValue) As Element

[C#] public static Element Mean(string,Series,ElementValue);

Calculates the arithmetic mean of the elements values of the series.

[Visual Basic] Overloads Public Shared Function Mean(String,SeriesCollection,ElementValue) As Series

[C#] public static Series Mean(string,SeriesCollection,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


Mean(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the geometric mean of the series.

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Mean(Series,ElementValue) Method

Calculates the arithmetic mean of the elements values of the series.

[Visual Basic]
Overloads Public Shared Function Mean( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Mean(
   Series s,
   ElementValue elementValue
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the geometric mean of the series.


Mean(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the geometric mean of the series.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Mean(SeriesCollection,ElementValue) Method

Calculates the arithmetic mean of the elements values of the series.

[Visual Basic]
Overloads Public Shared Function Mean( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Mean(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the geometric mean of the series.


Mean(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the geometric mean of the series.

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High . In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Mean(String,Series,ElementValue) Method

Calculates the arithmetic mean of the elements values of the series.

[Visual Basic]
Overloads Public Shared Function Mean( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Mean(
   string elementName,
   Series s,
   ElementValue elementValue
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High . In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the geometric mean of the series.


Mean(String,SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the geometric mean of the series.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Mean(String,SeriesCollection,ElementValue) Method

Calculates the arithmetic mean of the elements values of the series.

[Visual Basic]
Overloads Public Shared Function Mean( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Mean(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Evaluates the geometric mean of the series.


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MeanDeviation Method

Overload List

Calculates the mean deviation of the series's element values.

[Visual Basic] Overloads Public Shared Function MeanDeviation(Series,ElementValue) As Element

[C#] public static Element MeanDeviation(Series,ElementValue);

Calculates the mean deviation of the series's element values.

[Visual Basic] Overloads Public Shared Function MeanDeviation(SeriesCollection,ElementValue) As Series

[C#] public static Series MeanDeviation(SeriesCollection,ElementValue);

Calculates the mean deviation of the series's element values.

[Visual Basic] Overloads Public Shared Function MeanDeviation(String,Series,ElementValue) As Element

[C#] public static Element MeanDeviation(string,Series,ElementValue);

Calculates the mean deviation of the series's element values.

[Visual Basic] Overloads Public Shared Function MeanDeviation(String,SeriesCollection,ElementValue) As Series

[C#] public static Series MeanDeviation(string,SeriesCollection,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


MeanDeviation(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

MeanDeviation(Series,ElementValue) Method

Calculates the mean deviation of the series's element values.

[Visual Basic]
Overloads Public Shared Function MeanDeviation( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element MeanDeviation(
   Series s,
   ElementValue elementValue
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


MeanDeviation(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

MeanDeviation(SeriesCollection,ElementValue) Method

Calculates the mean deviation of the series's element values.

[Visual Basic]
Overloads Public Shared Function MeanDeviation( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series MeanDeviation(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


MeanDeviation(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

MeanDeviation(String,Series,ElementValue) Method

Calculates the mean deviation of the series's element values.

[Visual Basic]
Overloads Public Shared Function MeanDeviation( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element MeanDeviation(
   string elementName,
   Series s,
   ElementValue elementValue
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


MeanDeviation(String,SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

MeanDeviation(String,SeriesCollection,ElementValue) Method

Calculates the mean deviation of the series's element values.

[Visual Basic]
Overloads Public Shared Function MeanDeviation( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series MeanDeviation(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Median Method

Overload List

Calculates the mean deviation of the series's element YValues.

[Visual Basic] Overloads Public Shared Function Median(Series,ElementValue) As Element

[C#] public static Element Median(Series,ElementValue);

Calculates the mean deviation of the series's element YValues.

[Visual Basic] Overloads Public Shared Function Median(SeriesCollection,ElementValue) As Series

[C#] public static Series Median(SeriesCollection,ElementValue);

Calculates the mean deviation of the series's element YValues.

[Visual Basic] Overloads Public Shared Function Median(String,Series,ElementValue) As Element

[C#] public static Element Median(string,Series,ElementValue);

Calculates the mean deviation of the series's element YValues.

[Visual Basic] Overloads Public Shared Function Median(String,SeriesCollection,ElementValue) As Series

[C#] public static Series Median(string,SeriesCollection,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


Median(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | A measure of the deviation of the elements of the data set considered.

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Median(Series,ElementValue) Method

Calculates the mean deviation of the series's element YValues.

[Visual Basic]
Overloads Public Shared Function Median( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Median(
   Series s,
   ElementValue elementValue
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | A measure of the deviation of the elements of the data set considered.


Median(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | A measure of the deviation of the elements of the data set considered.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Median(SeriesCollection,ElementValue) Method

Calculates the mean deviation of the series's element YValues.

[Visual Basic]
Overloads Public Shared Function Median( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Median(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | A measure of the deviation of the elements of the data set considered.


Median(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | A measure of the deviation of the elements of the data set considered.

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Median(String,Series,ElementValue) Method

Calculates the mean deviation of the series's element YValues.

[Visual Basic]
Overloads Public Shared Function Median( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Median(
   string elementName,
   Series s,
   ElementValue elementValue
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | A measure of the deviation of the elements of the data set considered.


Median(String,SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | A measure of the deviation of the elements of the data set considered.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Median(String,SeriesCollection,ElementValue) Method

Calculates the mean deviation of the series's element YValues.

[Visual Basic]
Overloads Public Shared Function Median( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Median(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | A measure of the deviation of the elements of the data set considered.


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MedianMovingAverage Method

Overload List

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic] Overloads Public Shared Function MedianMovingAverage(Series,ElementValue,Series,ElementValue,Integer) As Series

[C#] public static Series MedianMovingAverage(Series,ElementValue,Series,ElementValue,int);

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic] Overloads Public Shared Function MedianMovingAverage(SeriesCollection,ElementValue,ElementValue,Integer) As Series

[C#] public static Series MedianMovingAverage(SeriesCollection,ElementValue,ElementValue,int);

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic] Overloads Public Shared Function MedianMovingAverage(String,Series,ElementValue,Series,ElementValue,Integer) As Series

[C#] public static Series MedianMovingAverage(string,Series,ElementValue,Series,ElementValue,int);

See Also

FinancialEngine Class | FinancialEngine Members


MedianMovingAverage(Series,ElementValue,Series,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

highSeries
An array where the first element corresponds to the highest market price during the last trading period, the second element corresponds to the highest market price in the previous period, and so on.
highSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lowSeries
An array where the first element corresponds to the lowest market price during the last trading period, the second term corresponds to the lowest market price in the previous period, and so on.
lowSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

MedianMovingAverage(Series,ElementValue,Series,ElementValue,Int32) Method

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic]
Overloads Public Shared Function MedianMovingAverage( _
   ByVal highSeries As Series, _
   ByVal highSeriesElementValue As ElementValue, _
   ByVal lowSeries As Series, _
   ByVal lowSeriesElementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series MedianMovingAverage(
   Series highSeries,
   ElementValue highSeriesElementValue,
   Series lowSeries,
   ElementValue lowSeriesElementValue,
   int lengthOfMA
);

Parameters

highSeries
An array where the first element corresponds to the highest market price during the last trading period, the second element corresponds to the highest market price in the previous period, and so on.
highSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lowSeries
An array where the first element corresponds to the lowest market price during the last trading period, the second term corresponds to the lowest market price in the previous period, and so on.
lowSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Type

A series where the first term is the value of the Median Moving Average for the most recent period, the second term is the value of the Median Moving Average for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series historicalHigh and historicalLow are of different lengths or if one of these arrays is empty.

Remarks

For example, if we are considering a trading asset and the periods considered are days then by passing an series containing the closing daily prices of a given asset, and by choosing to use the 5-day median moving average (i.e. passing a length of the MA of 5), then we will evaluate the Median Moving Average(GMA) for all days for which the closing price on that day and the four previous days is known.

Remark: This indicator is particularly appropriate for traded assets where the opening and closing prices are unreliable. Such an instance are FTSE stocks which in the first hour of trading experience relatively low volumes and the closing prices are settled through an auction process. Hence for the FTSE market the quoted market price at the beginning and end of the market may not be indicative of where a given stock is trading within a given period. In such markets it may be more appropriate to use the Median Moving Average which will smooth out the effect of uncharacteristic shifts at the ends of the trading day.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


MedianMovingAverage(SeriesCollection,ElementValue,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
highSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lowSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

MedianMovingAverage(SeriesCollection,ElementValue,ElementValue,Int32) Method

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic]
Overloads Public Shared Function MedianMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal highSeriesElementValue As ElementValue, _
   ByVal lowSeriesElementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series MedianMovingAverage(
   SeriesCollection sc,
   ElementValue highSeriesElementValue,
   ElementValue lowSeriesElementValue,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
highSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lowSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


MedianMovingAverage(String,Series,ElementValue,Series,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
highSeries
An array where the first element corresponds to the highest market price during the last trading period, the second element corresponds to the highest market price in the previous period, and so on.
highSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lowSeries
An array where the first element corresponds to the lowest market price during the last trading period, the second term corresponds to the lowest market price in the previous period, and so on.
lowSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

MedianMovingAverage(String,Series,ElementValue,Series,ElementValue,Int32) Method

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic]
Overloads Public Shared Function MedianMovingAverage( _
   ByVal seriesName As String, _
   ByVal highSeries As Series, _
   ByVal highSeriesElementValue As ElementValue, _
   ByVal lowSeries As Series, _
   ByVal lowSeriesElementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series MedianMovingAverage(
   string seriesName,
   Series highSeries,
   ElementValue highSeriesElementValue,
   Series lowSeries,
   ElementValue lowSeriesElementValue,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
highSeries
An array where the first element corresponds to the highest market price during the last trading period, the second element corresponds to the highest market price in the previous period, and so on.
highSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lowSeries
An array where the first element corresponds to the lowest market price during the last trading period, the second term corresponds to the lowest market price in the previous period, and so on.
lowSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Type

A series where the first term is the value of the Median Moving Average for the most recent period, the second term is the value of the Median Moving Average for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series historicalHigh and historicalLow are of different lengths or if one of these arrays is empty.

Remarks

For example, if we are considering a trading asset and the periods considered are days then by passing an series containing the closing daily prices of a given asset, and by choosing to use the 5-day median moving average (i.e. passing a length of the MA of 5), then we will evaluate the Median Moving Average(GMA) for all days for which the closing price on that day and the four previous days is known.

Remark: This indicator is particularly appropriate for traded assets where the opening and closing prices are unreliable. Such an instance are FTSE stocks which in the first hour of trading experience relatively low volumes and the closing prices are settled through an auction process. Hence for the FTSE market the quoted market price at the beginning and end of the market may not be indicative of where a given stock is trading within a given period. In such markets it may be more appropriate to use the Median Moving Average which will smooth out the effect of uncharacteristic shifts at the ends of the trading day.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MedianPrice Method

Overload List

Evaluates the Median Price of an asset for a given trading period.

[Visual Basic] Overloads Public Shared Function MedianPrice(Series) As Series

[C#] public static Series MedianPrice(Series);

Evaluates the Median Price of an asset for a given trading period.

[Visual Basic] Overloads Public Shared Function MedianPrice(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection MedianPrice(SeriesCollection);

Evaluates the Median Price of an asset for a given trading period.

[Visual Basic] Overloads Public Shared Function MedianPrice(String,Series) As Series

[C#] public static Series MedianPrice(string,Series);

See Also

FinancialEngine Class | FinancialEngine Members


MedianPrice(Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
The financial series under consideration.
See Also Languages dotnetCHARTING Send comments on this topic.

MedianPrice(Series) Method

Evaluates the Median Price of an asset for a given trading period.

[Visual Basic]
Overloads Public Shared Function MedianPrice( _
   ByVal s As Series _
) As Series
[C#]
public static Series MedianPrice(
   Series s
);

Parameters

s
The financial series under consideration.

Remarks

The Median price is just the midpoint of the trading periods range, where the period considered is generally a day, however the Median price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


MedianPrice(SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

MedianPrice(SeriesCollection) Method

Evaluates the Median Price of an asset for a given trading period.

[Visual Basic]
Overloads Public Shared Function MedianPrice( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection MedianPrice(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

The Median price is just the midpoint of the trading periods range, where the period considered is generally a day, however the Median price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


MedianPrice(String,Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
The financial series under consideration.
See Also Languages dotnetCHARTING Send comments on this topic.

MedianPrice(String,Series) Method

Evaluates the Median Price of an asset for a given trading period.

[Visual Basic]
Overloads Public Shared Function MedianPrice( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series MedianPrice(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
The financial series under consideration.

Remarks

The Median price is just the midpoint of the trading periods range, where the period considered is generally a day, however the Median price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Momentum Method

Overload List

We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.

[Visual Basic] Overloads Public Shared Function Momentum(Series,Integer) As Series

[C#] public static Series Momentum(Series,int);

We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.

[Visual Basic] Overloads Public Shared Function Momentum(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection Momentum(SeriesCollection,int);

We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.

[Visual Basic] Overloads Public Shared Function Momentum(String,Series,Integer) As Series

[C#] public static Series Momentum(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


Momentum(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series of length greate or equal to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

Momentum(Series,Int32) Method

We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.

[Visual Basic]
Overloads Public Shared Function Momentum( _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
[C#]
public static Series Momentum(
   Series s,
   int noOfDays
);

Parameters

s
An series of length greate or equal to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Type

A series where the first term is the momentum for the most recent trading period, the second term is the momentum for the previous trading period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if either parameter is strictly negative.

Remarks

The Momentum indicator as the name suggests is the velocity with which the price is rising or falling, and hence will reflect how aggressively the asset is being purchased or sold.

Remark: Extended values and/or turning points of the momentum are good indicators of oversold or over brought conditions(respectively).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Momentum(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

Momentum(SeriesCollection,Int32) Method

We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.

[Visual Basic]
Overloads Public Shared Function Momentum( _
   ByVal sc As SeriesCollection, _
   ByVal noOfDays As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection Momentum(
   SeriesCollection sc,
   int noOfDays
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.

Return Type

A series where the first term is the momentum for the most recent trading period, the second term is the momentum for the previous trading period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if either parameter is strictly negative.

Remarks

The Momentum indicator as the name suggests is the velocity with which the price is rising or falling, and hence will reflect how aggressively the asset is being purchased or sold.

Remark: Extended values and/or turning points of the momentum are good indicators of oversold or over brought conditions(respectively).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Momentum(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of length greate or equal to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

Momentum(String,Series,Int32) Method

We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.

[Visual Basic]
Overloads Public Shared Function Momentum( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
[C#]
public static Series Momentum(
   string seriesName,
   Series s,
   int noOfDays
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of length greate or equal to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Type

A series where the first term is the momentum for the most recent trading period, the second term is the momentum for the previous trading period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if either parameter is strictly negative.

Remarks

The Momentum indicator as the name suggests is the velocity with which the price is rising or falling, and hence will reflect how aggressively the asset is being purchased or sold.

Remark: Extended values and/or turning points of the momentum are good indicators of oversold or over brought conditions(respectively).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MomentumPercent Method

Overload List

We calculate the momentum pergentage over a given period.

[Visual Basic] Overloads Public Shared Function MomentumPercent(Series,Integer) As Series

[C#] public static Series MomentumPercent(Series,int);

We calculate the momentum pergentage over a given period.

[Visual Basic] Overloads Public Shared Function MomentumPercent(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection MomentumPercent(SeriesCollection,int);

We calculate the momentum pergentage over a given period.

[Visual Basic] Overloads Public Shared Function MomentumPercent(String,Series,Integer) As Series

[C#] public static Series MomentumPercent(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


MomentumPercent(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

MomentumPercent(Series,Int32) Method

We calculate the momentum pergentage over a given period.

[Visual Basic]
Overloads Public Shared Function MomentumPercent( _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
[C#]
public static Series MomentumPercent(
   Series s,
   int noOfDays
);

Parameters

s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Exceptions

Exception | Description
ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


MomentumPercent(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

MomentumPercent(SeriesCollection,Int32) Method

We calculate the momentum pergentage over a given period.

[Visual Basic]
Overloads Public Shared Function MomentumPercent( _
   ByVal sc As SeriesCollection, _
   ByVal noOfDays As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection MomentumPercent(
   SeriesCollection sc,
   int noOfDays
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.

Exceptions

Exception | Description
ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


MomentumPercent(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

MomentumPercent(String,Series,Int32) Method

We calculate the momentum pergentage over a given period.

[Visual Basic]
Overloads Public Shared Function MomentumPercent( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
[C#]
public static Series MomentumPercent(
   string seriesName,
   Series s,
   int noOfDays
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Exceptions

Exception | Description
ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MoneyFlowIdxOverPeriod Method

Overload List

Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function MoneyFlowIdxOverPeriod(Series,Integer) As Series

[C#] public static Series MoneyFlowIdxOverPeriod(Series,int);

Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function MoneyFlowIdxOverPeriod(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection MoneyFlowIdxOverPeriod(SeriesCollection,int);

Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function MoneyFlowIdxOverPeriod(String,Series,Integer) As Series

[C#] public static Series MoneyFlowIdxOverPeriod(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


MoneyFlowIdxOverPeriod(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

MoneyFlowIdxOverPeriod(Series,Int32) Method

Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function MoneyFlowIdxOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series MoneyFlowIdxOverPeriod(
   Series s,
   int lengthOfPeriod
);

Parameters

s
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Exceptions

Exception | Description
ArgumentException | Thrown if any elements from the arrays high, low, close or volume are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.

Remarks

The MFI is related to the Directional Movement Indicator of Wellas Wilder, but the MFI system also takes into account the volume as well as the price action.

Interpretation

Divergence of the indicator within a continuing trend indicates that a reversal is imminent. The MFI also is a good means to signal market tops and bottoms. A reasonable rule is a market top is given more significance when the MFI is above 80 and a market bottom is given more significance when the MFI is below 20.

Evaluation

The Money Flow Index (MFI) is evaluated over a given user defined number of trading periods. The evaluation of the MFI follows the below steps:

  • Evaluates the Money Flow on each day. The Money Flow is the product of the Typical Value Indicator (see Filters) for that day and the volume.
  • Each day is either classified as either a Positive Money Flow day, Negative Money Flow day or no Flow day. If the typical price increases then the day is a said to be a Positive Money Day, if it decreasing then it is said to be a negative money day and if it stays then same then it is said the be a no flow day.
  • The Positive Money and Negative Money Flow's are calculated by summing the Money Flow over the Positive Money Flow Days or the Negative Money Flow days respectively.
  • The Money Flow Index (MFI) is evaluated by dividing the Positive Money Flow by the Negative Money Flow.

    • See Also

    FinancialEngine Class | FinancialEngine Members | Overload List


MoneyFlowIdxOverPeriod(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

MoneyFlowIdxOverPeriod(SeriesCollection,Int32) Method

Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function MoneyFlowIdxOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection MoneyFlowIdxOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Exceptions

Exception | Description
ArgumentException | Thrown if any elements from the arrays high, low, close or volume are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.

Remarks

The MFI is related to the Directional Movement Indicator of Wellas Wilder, but the MFI system also takes into account the volume as well as the price action.

Interpretation

Divergence of the indicator within a continuing trend indicates that a reversal is imminent. The MFI also is a good means to signal market tops and bottoms. A reasonable rule is a market top is given more significance when the MFI is above 80 and a market bottom is given more significance when the MFI is below 20.

Evaluation

The Money Flow Index (MFI) is evaluated over a given user defined number of trading periods. The evaluation of the MFI follows the below steps:

  • Evaluates the Money Flow on each day. The Money Flow is the product of the Typical Value Indicator (see Filters) for that day and the volume.
  • Each day is either classified as either a Positive Money Flow day, Negative Money Flow day or no Flow day. If the typical price increases then the day is a said to be a Positive Money Day, if it decreasing then it is said to be a negative money day and if it stays then same then it is said the be a no flow day.
  • The Positive Money and Negative Money Flow's are calculated by summing the Money Flow over the Positive Money Flow Days or the Negative Money Flow days respectively.
  • The Money Flow Index (MFI) is evaluated by dividing the Positive Money Flow by the Negative Money Flow.

    • See Also

    FinancialEngine Class | FinancialEngine Members | Overload List


MoneyFlowIdxOverPeriod(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

MoneyFlowIdxOverPeriod(String,Series,Int32) Method

Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function MoneyFlowIdxOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
[C#]
public static Series MoneyFlowIdxOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Exceptions

Exception | Description
ArgumentException | Thrown if any elements from the arrays high, low, close or volume are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.

Remarks

The MFI is related to the Directional Movement Indicator of Wellas Wilder, but the MFI system also takes into account the volume as well as the price action.

Interpretation

Divergence of the indicator within a continuing trend indicates that a reversal is imminent. The MFI also is a good means to signal market tops and bottoms. A reasonable rule is a market top is given more significance when the MFI is above 80 and a market bottom is given more significance when the MFI is below 20.

Evaluation

The Money Flow Index (MFI) is evaluated over a given user defined number of trading periods. The evaluation of the MFI follows the below steps:

  • Evaluates the Money Flow on each day. The Money Flow is the product of the Typical Value Indicator (see Filters) for that day and the volume.
  • Each day is either classified as either a Positive Money Flow day, Negative Money Flow day or no Flow day. If the typical price increases then the day is a said to be a Positive Money Day, if it decreasing then it is said to be a negative money day and if it stays then same then it is said the be a no flow day.
  • The Positive Money and Negative Money Flow's are calculated by summing the Money Flow over the Positive Money Flow Days or the Negative Money Flow days respectively.
  • The Money Flow Index (MFI) is evaluated by dividing the Positive Money Flow by the Negative Money Flow.

    • See Also

    FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

NegativeVolumeIndex Method

Overload List

We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.

[Visual Basic] Overloads Public Shared Function NegativeVolumeIndex(Series) As Series

[C#] public static Series NegativeVolumeIndex(Series);

We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.

[Visual Basic] Overloads Public Shared Function NegativeVolumeIndex(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection NegativeVolumeIndex(SeriesCollection);

We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.

[Visual Basic] Overloads Public Shared Function NegativeVolumeIndex(String,Series) As Series

[C#] public static Series NegativeVolumeIndex(string,Series);

See Also

FinancialEngine Class | FinancialEngine Members


NegativeVolumeIndex(Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

NegativeVolumeIndex(Series) Method

We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.

[Visual Basic]
Overloads Public Shared Function NegativeVolumeIndex( _
   ByVal s As Series _
) As Series
[C#]
public static Series NegativeVolumeIndex(
   Series s
);

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty or contain negative values.

Remarks

Indicator Formula

The formula for this indicator is:

If the volume is less then the yesterday volume then: NVI = Yesterday's NVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's NVI)
If today's volume is greater than or equal to yesterday's volume then:
NVI = Yesterday's NVI
Allways the first element of an financial array will be a value of the most recent period considered.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


NegativeVolumeIndex(SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

NegativeVolumeIndex(SeriesCollection) Method

We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.

[Visual Basic]
Overloads Public Shared Function NegativeVolumeIndex( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection NegativeVolumeIndex(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Exceptions

Exception | Description
ArgumentException | Thrown if the series contain negative values.

Remarks

Indicator Formula

The formula for this indicator is:

If the volume is less then the yesterday volume then: NVI = Yesterday's NVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's NVI)
If today's volume is greater than or equal to yesterday's volume then:
NVI = Yesterday's NVI
Allways the first element of an financial array will be a value of the most recent period considered.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


NegativeVolumeIndex(String,Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

NegativeVolumeIndex(String,Series) Method

We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.

[Visual Basic]
Overloads Public Shared Function NegativeVolumeIndex( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series NegativeVolumeIndex(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empti or contain negative values.

Remarks

Indicator Formula

The formula for this indicator is:

If the volume is less then the yesterday volume then: NVI = Yesterday's NVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's NVI)
If today's volume is greater than or equal to yesterday's volume then:
NVI = Yesterday's NVI
Allways the first element of an financial array will be a value of the most recent period considered.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

OnBalanceVolume Method

Overload List

On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.

[Visual Basic] Overloads Public Shared Function OnBalanceVolume(Series) As Series

[C#] public static Series OnBalanceVolume(Series);

On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.

[Visual Basic] Overloads Public Shared Function OnBalanceVolume(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection OnBalanceVolume(SeriesCollection);

On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.

[Visual Basic] Overloads Public Shared Function OnBalanceVolume(String,Series) As Series

[C#] public static Series OnBalanceVolume(string,Series);

See Also

FinancialEngine Class | FinancialEngine Members


OnBalanceVolume(Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

OnBalanceVolume(Series) Method

On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.

[Visual Basic]
Overloads Public Shared Function OnBalanceVolume( _
   ByVal s As Series _
) As Series
[C#]
public static Series OnBalanceVolume(
   Series s
);

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.

Remarks

Indicator Formula

The formula for this indicator is:

If today's close is greater than yesterday's close then:
OBV = Yesterday's OBV + Today's Volume
If today's close is less than yesterday's close then:
OBV = Yesterday's OBV - Today's Volume
If today's close is equal to yesterday's close then:
OBV = Yesterday's OBV

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


OnBalanceVolume(SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

OnBalanceVolume(SeriesCollection) Method

On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.

[Visual Basic]
Overloads Public Shared Function OnBalanceVolume( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection OnBalanceVolume(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Indicator Formula

The formula for this indicator is:

If today's close is greater than yesterday's close then:
OBV = Yesterday's OBV + Today's Volume
If today's close is less than yesterday's close then:
OBV = Yesterday's OBV - Today's Volume
If today's close is equal to yesterday's close then:
OBV = Yesterday's OBV

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


OnBalanceVolume(String,Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

OnBalanceVolume(String,Series) Method

On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.

[Visual Basic]
Overloads Public Shared Function OnBalanceVolume( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series OnBalanceVolume(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.

Remarks

Indicator Formula

The formula for this indicator is:

If today's close is greater than yesterday's close then:
OBV = Yesterday's OBV + Today's Volume
If today's close is less than yesterday's close then:
OBV = Yesterday's OBV - Today's Volume
If today's close is equal to yesterday's close then:
OBV = Yesterday's OBV

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Percentile25 Method

Overload List

Calculates the first percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile25(Series,ElementValue) As Element

[C#] public static Element Percentile25(Series,ElementValue);

Calculates the first percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile25(SeriesCollection,ElementValue) As Series

[C#] public static Series Percentile25(SeriesCollection,ElementValue);

Calculates the first percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile25(String,Series,ElementValue) As Element

[C#] public static Element Percentile25(string,Series,ElementValue);

Calculates the first percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile25(String,SeriesCollection,ElementValue) As Series

[C#] public static Series Percentile25(string,SeriesCollection,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


Percentile25(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile25(Series,ElementValue) Method

Calculates the first percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile25( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Percentile25(
   Series s,
   ElementValue elementValue
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Percentile25(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile25(SeriesCollection,ElementValue) Method

Calculates the first percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile25( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Percentile25(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Percentile25(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile25(String,Series,ElementValue) Method

Calculates the first percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile25( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Percentile25(
   string elementName,
   Series s,
   ElementValue elementValue
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Percentile25(String,SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile25(String,SeriesCollection,ElementValue) Method

Calculates the first percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile25( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Percentile25(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Percentile50 Method

Overload List

Calculates the second percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile50(Series,ElementValue) As Element

[C#] public static Element Percentile50(Series,ElementValue);

Calculates the second percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile50(SeriesCollection,ElementValue) As Series

[C#] public static Series Percentile50(SeriesCollection,ElementValue);

Calculates the second percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile50(String,Series,ElementValue) As Element

[C#] public static Element Percentile50(string,Series,ElementValue);

Calculates the second percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile50(String,SeriesCollection,ElementValue) As Series

[C#] public static Series Percentile50(string,SeriesCollection,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


Percentile50(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile50(Series,ElementValue) Method

Calculates the second percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile50( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Percentile50(
   Series s,
   ElementValue elementValue
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Percentile50(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile50(SeriesCollection,ElementValue) Method

Calculates the second percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile50( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Percentile50(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Percentile50(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile50(String,Series,ElementValue) Method

Calculates the second percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile50( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Percentile50(
   string elementName,
   Series s,
   ElementValue elementValue
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Percentile50(String,SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile50(String,SeriesCollection,ElementValue) Method

Calculates the second percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile50( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Percentile50(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Percentile75 Method

Overload List

Calculates the third percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile75(Series,ElementValue) As Element

[C#] public static Element Percentile75(Series,ElementValue);

Calculates the third percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile75(SeriesCollection,ElementValue) As Series

[C#] public static Series Percentile75(SeriesCollection,ElementValue);

Calculates the third percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile75(String,Series,ElementValue) As Element

[C#] public static Element Percentile75(string,Series,ElementValue);

Calculates the third percentile of the series.

[Visual Basic] Overloads Public Shared Function Percentile75(String,SeriesCollection,ElementValue) As Series

[C#] public static Series Percentile75(string,SeriesCollection,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


Percentile75(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A FinancialEngine series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile75(Series,ElementValue) Method

Calculates the third percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile75( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Percentile75(
   Series s,
   ElementValue elementValue
);

Parameters

s
A FinancialEngine series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Percentile75(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile75(SeriesCollection,ElementValue) Method

Calculates the third percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile75( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Percentile75(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Percentile75(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile75(String,Series,ElementValue) Method

Calculates the third percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile75( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Percentile75(
   string elementName,
   Series s,
   ElementValue elementValue
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Percentile75(String,SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile75(String,SeriesCollection,ElementValue) Method

Calculates the third percentile of the series.

[Visual Basic]
Overloads Public Shared Function Percentile75( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Percentile75(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PositiveVolumeIndex Method

Overload List

We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.

[Visual Basic] Overloads Public Shared Function PositiveVolumeIndex(Series) As Series

[C#] public static Series PositiveVolumeIndex(Series);

We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.

[Visual Basic] Overloads Public Shared Function PositiveVolumeIndex(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection PositiveVolumeIndex(SeriesCollection);

We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.

[Visual Basic] Overloads Public Shared Function PositiveVolumeIndex(String,Series) As Series

[C#] public static Series PositiveVolumeIndex(string,Series);

See Also

FinancialEngine Class | FinancialEngine Members


PositiveVolumeIndex(Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

PositiveVolumeIndex(Series) Method

We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.

[Visual Basic]
Overloads Public Shared Function PositiveVolumeIndex( _
   ByVal s As Series _
) As Series
[C#]
public static Series PositiveVolumeIndex(
   Series s
);

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.

Remarks

Indicator Formula

The formula for this indicator is:

If the volume is greater then the yesterday volume then:
PVI = Yesterday's PVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's PVI)
If today's volume is less than or equal to yesterday's volume then:
PVI = Yesterday's PVI
Allways the first element of an financial array will be a value of the most recent period considered.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


PositiveVolumeIndex(SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

PositiveVolumeIndex(SeriesCollection) Method

We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.

[Visual Basic]
Overloads Public Shared Function PositiveVolumeIndex( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection PositiveVolumeIndex(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Indicator Formula

The formula for this indicator is:

If the volume is greater then the yesterday volume then:
PVI = Yesterday's PVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's PVI)
If today's volume is less than or equal to yesterday's volume then:
PVI = Yesterday's PVI
Allways the first element of an financial array will be a value of the most recent period considered.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


PositiveVolumeIndex(String,Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

PositiveVolumeIndex(String,Series) Method

We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.

[Visual Basic]
Overloads Public Shared Function PositiveVolumeIndex( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series PositiveVolumeIndex(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.

Remarks

Indicator Formula

The formula for this indicator is:

If the volume is greater then the yesterday volume then:
PVI = Yesterday's PVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's PVI)
If today's volume is less than or equal to yesterday's volume then:
PVI = Yesterday's PVI
Allways the first element of an financial array will be a value of the most recent period considered.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Range Method

Overload List

Calculates the range of the series's elements values.

[Visual Basic] Overloads Public Shared Function Range(Series,ElementValue) As Element

[C#] public static Element Range(Series,ElementValue);

Calculates the range of the series's elements values.

[Visual Basic] Overloads Public Shared Function Range(SeriesCollection,ElementValue) As Series

[C#] public static Series Range(SeriesCollection,ElementValue);

Calculates the range of the series's elements values.

[Visual Basic] Overloads Public Shared Function Range(String,Series,ElementValue) As Element

[C#] public static Element Range(string,Series,ElementValue);

Calculates the range of the series's elements values.

[Visual Basic] Overloads Public Shared Function Range(String,SeriesCollection,ElementValue) As Series

[C#] public static Series Range(string,SeriesCollection,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


Range(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Range(Series,ElementValue) Method

Calculates the range of the series's elements values.

[Visual Basic]
Overloads Public Shared Function Range( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Range(
   Series s,
   ElementValue elementValue
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Range(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Range(SeriesCollection,ElementValue) Method

Calculates the range of the series's elements values.

[Visual Basic]
Overloads Public Shared Function Range( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Range(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Range(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Range(String,Series,ElementValue) Method

Calculates the range of the series's elements values.

[Visual Basic]
Overloads Public Shared Function Range( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Range(
   string elementName,
   Series s,
   ElementValue elementValue
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


Range(String,SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Range(String,SeriesCollection,ElementValue) Method

Calculates the range of the series's elements values.

[Visual Basic]
Overloads Public Shared Function Range( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Range(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RateOfChange Method

Overload List

Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.

[Visual Basic] Overloads Public Shared Function RateOfChange(Series,Integer) As Series

[C#] public static Series RateOfChange(Series,int);

Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.

[Visual Basic] Overloads Public Shared Function RateOfChange(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection RateOfChange(SeriesCollection,int);

Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.

[Visual Basic] Overloads Public Shared Function RateOfChange(String,Series,Integer) As Series

[C#] public static Series RateOfChange(string,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


RateOfChange(Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
numberDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

RateOfChange(Series,Int32) Method

Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.

[Visual Basic]
Overloads Public Shared Function RateOfChange( _
   ByVal s As Series, _
   ByVal numberDays As Integer _
) As Series
[C#]
public static Series RateOfChange(
   Series s,
   int numberDays
);

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
numberDays
The number of days before to which the closing price is compared.

Return Type

A series where the first term is the rate of change for the most recent period, the second term is the rate of change for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if either parameter is strictly negative.

Remarks

The (n-day) rate of change (ROC) is just the last closing price divided by the closing price n-days ago.

As with the case with the momentum indicator the rate of change (ROC) indicator on extended values and/or turning points indicates oversold or over brought conditions (respectively).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


RateOfChange(SeriesCollection,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
numberDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

RateOfChange(SeriesCollection,Int32) Method

Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.

[Visual Basic]
Overloads Public Shared Function RateOfChange( _
   ByVal sc As SeriesCollection, _
   ByVal numberDays As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection RateOfChange(
   SeriesCollection sc,
   int numberDays
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
numberDays
The number of days before to which the closing price is compared.

Return Type

A series where the first term is the rate of change for the most recent period, the second term is the rate of change for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if either parameter is strictly negative.

Remarks

The (n-day) rate of change (ROC) is just the last closing price divided by the closing price n-days ago.

As with the case with the momentum indicator the rate of change (ROC) indicator on extended values and/or turning points indicates oversold or over brought conditions (respectively).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


RateOfChange(String,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
numberDays
The number of days before to which the closing price is compared.
See Also Languages dotnetCHARTING Send comments on this topic.

RateOfChange(String,Series,Int32) Method

Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.

[Visual Basic]
Overloads Public Shared Function RateOfChange( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal numberDays As Integer _
) As Series
[C#]
public static Series RateOfChange(
   string seriesName,
   Series s,
   int numberDays
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
numberDays
The number of days before to which the closing price is compared.

Return Type

A series where the first term is the rate of change for the most recent period, the second term is the rate of change for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if either parameter is strictly negative.

Remarks

The (n-day) rate of change (ROC) is just the last closing price divided by the closing price n-days ago.

As with the case with the momentum indicator the rate of change (ROC) indicator on extended values and/or turning points indicates oversold or over brought conditions (respectively).

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SimpleMovingAverage Method

Overload List

Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function SimpleMovingAverage(Series,ElementValue,Integer) As Series

[C#] public static Series SimpleMovingAverage(Series,ElementValue,int);

Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function SimpleMovingAverage(SeriesCollection,ElementValue,Integer) As SeriesCollection

[C#] public static SeriesCollection SimpleMovingAverage(SeriesCollection,ElementValue,int);

Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function SimpleMovingAverage(String,Series,ElementValue,Integer) As Series

[C#] public static Series SimpleMovingAverage(string,Series,ElementValue,int);

See Also

FinancialEngine Class | FinancialEngine Members


SimpleMovingAverage(Series,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A series where the first term is the most recent historical price, the second term is the previous historical price and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

SimpleMovingAverage(Series,ElementValue,Int32) Method

Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function SimpleMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series SimpleMovingAverage(
   Series s,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

s
A series where the first term is the most recent historical price, the second term is the previous historical price and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day moving average (i.e. passing a length of the MA of 5), then this method will evaluate the Moving Average (MA) for all days for which the closing price on that day and the four previous days is known.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


SimpleMovingAverage(SeriesCollection,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

SimpleMovingAverage(SeriesCollection,ElementValue,Int32) Method

Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function SimpleMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection SimpleMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day moving average (i.e. passing a length of the MA of 5), then this method will evaluate the Moving Average (MA) for all days for which the closing price on that day and the four previous days is known.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


SimpleMovingAverage(String,Series,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term is the most recent historical price, the second term is the previous historical price and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

SimpleMovingAverage(String,Series,ElementValue,Int32) Method

Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function SimpleMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series SimpleMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term is the most recent historical price, the second term is the previous historical price and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day moving average (i.e. passing a length of the MA of 5), then this method will evaluate the Moving Average (MA) for all days for which the closing price on that day and the four previous days is known.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StandardDeviation Method

Overload List

Calculates the sample standard variance of the series's elements values.

[Visual Basic] Overloads Public Shared Function StandardDeviation(Series,ElementValue) As Element

[C#] public static Element StandardDeviation(Series,ElementValue);

Calculates the sample standard variance of the series's elements values.

[Visual Basic] Overloads Public Shared Function StandardDeviation(SeriesCollection,ElementValue) As Series

[C#] public static Series StandardDeviation(SeriesCollection,ElementValue);

Calculates the sample standard variance of the series's elements values.

[Visual Basic] Overloads Public Shared Function StandardDeviation(String,Series,ElementValue) As Element

[C#] public static Element StandardDeviation(string,Series,ElementValue);

Calculates the sample standard variance of the series's elements values.

[Visual Basic] Overloads Public Shared Function StandardDeviation(String,SeriesCollection,ElementValue) As Series

[C#] public static Series StandardDeviation(string,SeriesCollection,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


StandardDeviation(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered.

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

StandardDeviation(Series,ElementValue) Method

Calculates the sample standard variance of the series's elements values.

[Visual Basic]
Overloads Public Shared Function StandardDeviation( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element StandardDeviation(
   Series s,
   ElementValue elementValue
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance in which the deviation is measured in units which are the squares of the units of the observations.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered.


StandardDeviation(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

StandardDeviation(SeriesCollection,ElementValue) Method

Calculates the sample standard variance of the series's elements values.

[Visual Basic]
Overloads Public Shared Function StandardDeviation( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series StandardDeviation(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance in which the deviation is measured in units which are the squares of the units of the observations.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered.


StandardDeviation(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered.

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

StandardDeviation(String,Series,ElementValue) Method

Calculates the sample standard variance of the series's elements values.

[Visual Basic]
Overloads Public Shared Function StandardDeviation( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element StandardDeviation(
   string elementName,
   Series s,
   ElementValue elementValue
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance in which the deviation is measured in units which are the squares of the units of the observations.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered.


StandardDeviation(String,SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

StandardDeviation(String,SeriesCollection,ElementValue) Method

Calculates the sample standard variance of the series's elements values.

[Visual Basic]
Overloads Public Shared Function StandardDeviation( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series StandardDeviation(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance in which the deviation is measured in units which are the squares of the units of the observations.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered.


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TriangularMovingAverage Method

Overload List

Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function TriangularMovingAverage(Series,ElementValue,Integer) As Series

[C#] public static Series TriangularMovingAverage(Series,ElementValue,int);

Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function TriangularMovingAverage(SeriesCollection,ElementValue,Integer) As SeriesCollection

[C#] public static SeriesCollection TriangularMovingAverage(SeriesCollection,ElementValue,int);

Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function TriangularMovingAverage(String,Series,ElementValue,Integer) As Series

[C#] public static Series TriangularMovingAverage(string,Series,ElementValue,int);

See Also

FinancialEngine Class | FinancialEngine Members


TriangularMovingAverage(Series,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first term corresponds to value of the market variable (for example, closing price) in the last period, the second term corresponds to the value of the market variable in the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

TriangularMovingAverage(Series,ElementValue,Int32) Method

Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function TriangularMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series TriangularMovingAverage(
   Series s,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

s
An series where the first term corresponds to value of the market variable (for example, closing price) in the last period, the second term corresponds to the value of the market variable in the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the value of the MA corresponding to the most recent period, the second term is the value of the MA on the previous period and so on.

Remarks

Further Explanation

The TMA is a special case of the WeightedMovingAverage, where the term triangular is motivated by the way in which the weights are chosen for the elements of the time series array. For example, for a 7-period TMA, that is when the time series has length 7, the corresponding weights of the time series elements are: 1, 2, 3, 4, 3, 2, 1. In the case of the 6 period TMA the weights would be 1, 2, 3, 3, 2, 1.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


TriangularMovingAverage(SeriesCollection,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

TriangularMovingAverage(SeriesCollection,ElementValue,Int32) Method

Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function TriangularMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection TriangularMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the value of the MA corresponding to the most recent period, the second term is the value of the MA on the previous period and so on.

Remarks

Further Explanation

The TMA is a special case of the WeightedMovingAverage, where the term triangular is motivated by the way in which the weights are chosen for the elements of the time series array. For example, for a 7-period TMA, that is when the time series has length 7, the corresponding weights of the time series elements are: 1, 2, 3, 4, 3, 2, 1. In the case of the 6 period TMA the weights would be 1, 2, 3, 3, 2, 1.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


TriangularMovingAverage(String,Series,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term corresponds to value of the market variable (for example, closing price) in the last period, the second term corresponds to the value of the market variable in the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

TriangularMovingAverage(String,Series,ElementValue,Int32) Method

Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function TriangularMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series TriangularMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term corresponds to value of the market variable (for example, closing price) in the last period, the second term corresponds to the value of the market variable in the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the value of the MA corresponding to the most recent period, the second term is the value of the MA on the previous period and so on.

Remarks

Further Explanation

The TMA is a special case of the WeightedMovingAverage, where the term triangular is motivated by the way in which the weights are chosen for the elements of the time series array. For example, for a 7-period TMA, that is when the time series has length 7, the corresponding weights of the time series elements are: 1, 2, 3, 4, 3, 2, 1. In the case of the 6 period TMA the weights would be 1, 2, 3, 3, 2, 1.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TypicalPrice Method

Overload List

Evaluates the Typical Price of an asset within a given trading period.

[Visual Basic] Overloads Public Shared Function TypicalPrice(Series) As Series

[C#] public static Series TypicalPrice(Series);

Evaluates the Typical Price of an asset within a given trading period.

[Visual Basic] Overloads Public Shared Function TypicalPrice(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection TypicalPrice(SeriesCollection);

Evaluates the Typical Price of an asset within a given trading period.

[Visual Basic] Overloads Public Shared Function TypicalPrice(String,Series) As Series

[C#] public static Series TypicalPrice(string,Series);

See Also

FinancialEngine Class | FinancialEngine Members


TypicalPrice(Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
The financial series.
See Also Languages dotnetCHARTING Send comments on this topic.

TypicalPrice(Series) Method

Evaluates the Typical Price of an asset within a given trading period.

[Visual Basic]
Overloads Public Shared Function TypicalPrice( _
   ByVal s As Series _
) As Series
[C#]
public static Series TypicalPrice(
   Series s
);

Parameters

s
The financial series.

Remarks

The typical price is just the arithmetic average of the high, low and closing price for the trading period considered. Generally speaking the period considered will be a single trading day, however the typical price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.

Applications

The Typical Price is often used in place of the closing price in the development of trading systems in which either another intra-day system is used from the intra-period timing of trades, or when the trading party is given discretion on intra-period trading decisions.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


TypicalPrice(SeriesCollection) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

TypicalPrice(SeriesCollection) Method

Evaluates the Typical Price of an asset within a given trading period.

[Visual Basic]
Overloads Public Shared Function TypicalPrice( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection TypicalPrice(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

The typical price is just the arithmetic average of the high, low and closing price for the trading period considered. Generally speaking the period considered will be a single trading day, however the typical price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.

Applications

The Typical Price is often used in place of the closing price in the development of trading systems in which either another intra-day system is used from the intra-period timing of trades, or when the trading party is given discretion on intra-period trading decisions.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


TypicalPrice(String,Series) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
The financial series.
See Also Languages dotnetCHARTING Send comments on this topic.

TypicalPrice(String,Series) Method

Evaluates the Typical Price of an asset within a given trading period.

[Visual Basic]
Overloads Public Shared Function TypicalPrice( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series TypicalPrice(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
The financial series.

Remarks

The typical price is just the arithmetic average of the high, low and closing price for the trading period considered. Generally speaking the period considered will be a single trading day, however the typical price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.

Applications

The Typical Price is often used in place of the closing price in the development of trading systems in which either another intra-day system is used from the intra-period timing of trades, or when the trading party is given discretion on intra-period trading decisions.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

UpperBollingerBands Method

Overload List

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function UpperBollingerBands(Series,ElementValue,Double,Integer) As Series

[C#] public static Series UpperBollingerBands(Series,ElementValue,double,int);

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function UpperBollingerBands(SeriesCollection,ElementValue,Double,Integer) As SeriesCollection

[C#] public static SeriesCollection UpperBollingerBands(SeriesCollection,ElementValue,double,int);

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function UpperBollingerBands(String,Series,ElementValue,Double,Integer) As Series

[C#] public static Series UpperBollingerBands(string,Series,ElementValue,double,int);

See Also

FinancialEngine Class | FinancialEngine Members


UpperBollingerBands(Series,ElementValue,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

UpperBollingerBands(Series,ElementValue,Double,Int32) Method

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function UpperBollingerBands( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series UpperBollingerBands(
   Series s,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

s
An series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


UpperBollingerBands(SeriesCollection,ElementValue,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

UpperBollingerBands(SeriesCollection,ElementValue,Double,Int32) Method

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function UpperBollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection UpperBollingerBands(
   SeriesCollection sc,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


UpperBollingerBands(String,Series,ElementValue,Double,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

UpperBollingerBands(String,Series,ElementValue,Double,Int32) Method

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function UpperBollingerBands( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series UpperBollingerBands(
   string seriesName,
   Series s,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Variance Method

Overload List

Calculates the sample variance of the series's elements values.

[Visual Basic] Overloads Public Shared Function Variance(Series,ElementValue) As Element

[C#] public static Element Variance(Series,ElementValue);

Calculates the sample variance of the series's elements values.

[Visual Basic] Overloads Public Shared Function Variance(SeriesCollection,ElementValue) As Series

[C#] public static Series Variance(SeriesCollection,ElementValue);

Calculates the sample variance of the series's elements values.

[Visual Basic] Overloads Public Shared Function Variance(String,Series,ElementValue) As Element

[C#] public static Element Variance(string,Series,ElementValue);

Calculates the sample variance of the series's elements values.

[Visual Basic] Overloads Public Shared Function Variance(String,SeriesCollection,ElementValue) As Series

[C#] public static Series Variance(string,SeriesCollection,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


Variance(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | StandardDeviation(Series,ElementValue) Method

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Variance(Series,ElementValue) Method

Calculates the sample variance of the series's elements values.

[Visual Basic]
Overloads Public Shared Function Variance( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Variance(
   Series s,
   ElementValue elementValue
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | StandardDeviation(Series,ElementValue) Method


Variance(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | StandardDeviation(SeriesCollection,ElementValue) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Variance(SeriesCollection,ElementValue) Method

Calculates the sample variance of the series's elements values.

[Visual Basic]
Overloads Public Shared Function Variance( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Variance(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | StandardDeviation(SeriesCollection,ElementValue) Method


Variance(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | StandardDeviation(String,Series,ElementValue) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Variance(String,Series,ElementValue) Method

Calculates the sample variance of the series's elements values.

[Visual Basic]
Overloads Public Shared Function Variance( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
[C#]
public static Element Variance(
   string elementName,
   Series s,
   ElementValue elementValue
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | StandardDeviation(String,Series,ElementValue) Method


Variance(String,SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List | StandardDeviation(String,SeriesCollection,ElementValue) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

Variance(String,SeriesCollection,ElementValue) Method

Calculates the sample variance of the series's elements values.

[Visual Basic]
Overloads Public Shared Function Variance( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series Variance(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List | StandardDeviation(String,SeriesCollection,ElementValue) Method


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage Method

Overload List

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(Series,ElementValue,Double()) As Series

[C#] public static Series WeightedMovingAverage(Series,ElementValue,double[]);

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(Series,Series,ElementValue,Integer) As Series

[C#] public static Series WeightedMovingAverage(Series,Series,ElementValue,int);

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(SeriesCollection,ElementValue,Double()) As SeriesCollection

[C#] public static SeriesCollection WeightedMovingAverage(SeriesCollection,ElementValue,double[]);

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(SeriesCollection,ElementValue,Series,Integer) As SeriesCollection

[C#] public static SeriesCollection WeightedMovingAverage(SeriesCollection,ElementValue,Series,int);

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(String,Series,ElementValue,Double()) As Series

[C#] public static Series WeightedMovingAverage(string,Series,ElementValue,double[]);

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(String,Series,ElementValue,Series,Integer) As Series

[C#] public static Series WeightedMovingAverage(string,Series,ElementValue,Series,int);

See Also

FinancialEngine Class | FinancialEngine Members


WeightedMovingAverage(Series,ElementValue,Double[]) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(Series,ElementValue,Double[]) Method

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal weights() As Double _
) As Series
[C#]
public static Series WeightedMovingAverage(
   Series s,
   ElementValue elementValue,
   double[] weights
);

Parameters

s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.

Remarks

I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to FinancialWeightedMovingAverage

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


WeightedMovingAverage(Series,Series,ElementValue,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
weightSeries
A series which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(Series,Series,ElementValue,Int32) Method

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal s As Series, _
   ByVal weightSeries As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series WeightedMovingAverage(
   Series s,
   Series weightSeries,
   ElementValue elementValue,
   int lengthOfMA
);

Parameters

s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
weightSeries
A series which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weights and series differ or if either series is empty.

Remarks

That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


WeightedMovingAverage(SeriesCollection,ElementValue,Double[]) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(SeriesCollection,ElementValue,Double[]) Method

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal weights() As Double _
) As SeriesCollection
[C#]
public static SeriesCollection WeightedMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   double[] weights
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.

Remarks

I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to WeightedMovingAverage

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


WeightedMovingAverage(SeriesCollection,ElementValue,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weightSeries
A series which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(SeriesCollection,ElementValue,Series,Int32) Method

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal weightSeries As Series, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection WeightedMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   Series weightSeries,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weightSeries
A series which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weights and series differ or if either series is empty.

Remarks

That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


WeightedMovingAverage(String,Series,ElementValue,Double[]) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(String,Series,ElementValue,Double[]) Method

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal weights() As Double _
) As Series
[C#]
public static Series WeightedMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   double[] weights
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.

Remarks

I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to

(historicalPrices,
            weights, lengthOfMovingAverage)
.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


WeightedMovingAverage(String,Series,ElementValue,Series,Int32) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weightSeries
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(String,Series,ElementValue,Series,Int32) Method

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal weightSeries As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series WeightedMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   Series weightSeries,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weightSeries
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weights and series differ or if either series is empty.

Remarks

That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine Class | FinancialEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ZScore Method

Overload List

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic] Overloads Public Shared Function ZScore(Series,ElementValue) As Series

[C#] public static Series ZScore(Series,ElementValue);

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic] Overloads Public Shared Function ZScore(SeriesCollection,ElementValue) As SeriesCollection

[C#] public static SeriesCollection ZScore(SeriesCollection,ElementValue);

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic] Overloads Public Shared Function ZScore(String,Series,ElementValue) As Series

[C#] public static Series ZScore(string,Series,ElementValue);

See Also

FinancialEngine Class | FinancialEngine Members


ZScore(Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

ZScore(Series,ElementValue) Method

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic]
Overloads Public Shared Function ZScore( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series ZScore(
   Series s,
   ElementValue elementValue
);

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ZScore(SeriesCollection,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

ZScore(SeriesCollection,ElementValue) Method

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic]
Overloads Public Shared Function ZScore( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As SeriesCollection
[C#]
public static SeriesCollection ZScore(
   SeriesCollection sc,
   ElementValue elementValue
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


ZScore(String,Series,ElementValue) Method

FinancialEngine Class | FinancialEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
See Also Languages dotnetCHARTING Send comments on this topic.

ZScore(String,Series,ElementValue) Method

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic]
Overloads Public Shared Function ZScore( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Series
[C#]
public static Series ZScore(
   string seriesName,
   Series s,
   ElementValue elementValue
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.

Remarks

The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.

See Also

FinancialEngine Class | FinancialEngine Members | Overload List


FinancialEngine.Options Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FinancialEngine.Options Class

Defines a set of static options used with FinancialEngine calculations.

For a list of all members of this type, see FinancialEngine.Options members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.FinancialEngine.Options

Syntax

[Visual Basic]
Public NotInheritable Class FinancialEngine.Options
[C#]
public sealed class FinancialEngine.Options

See Also

FinancialEngine.Options Members | dotnetCHARTING Namespace


FinancialEngine.Options Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

FinancialEngine.Options Class Members

FinancialEngine.Options overview

Public Properties

Public Property static (Shared in Visual Basic) MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
Public Property static (Shared in Visual Basic) PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.

Public Methods

Public Method static (Shared in Visual Basic) Reset Resets the options to default settings.

See Also

FinancialEngine.Options Class | dotnetCHARTING Namespace


FinancialEngine.Options Class Methods

FinancialEngine.Options Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

FinancialEngine.Options Class Members

For a list of all members of this type, see FinancialEngine.Options members.

Public Methods

Public Method static (Shared in Visual Basic) Reset Resets the options to default settings.

See Also

FinancialEngine.Options Class | dotnetCHARTING Namespace


FinancialEngine.Options Class | FinancialEngine.Options Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Reset Method

Resets the options to default settings.

[Visual Basic]
Public Shared Sub Reset()
[C#]
public static void Reset();

See Also

FinancialEngine.Options Class | FinancialEngine.Options Members


FinancialEngine.Options Class Properties

FinancialEngine.Options Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

FinancialEngine.Options Class Members

For a list of all members of this type, see FinancialEngine.Options members.

Public Properties

Public Property static (Shared in Visual Basic) MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
Public Property static (Shared in Visual Basic) PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.

See Also

FinancialEngine.Options Class | dotnetCHARTING Namespace


FinancialEngine.Options Class | FinancialEngine.Options Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MatchColors Property

Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.

[Visual Basic]
Public Shared Property MatchColors As Boolean
[C#]
public static bool MatchColors {get; set;}

See Also

FinancialEngine.Options Class | FinancialEngine.Options Members


FinancialEngine.Options Class | FinancialEngine.Options Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PopulateSubValues Property

Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.

[Visual Basic]
Public Shared Property PopulateSubValues As Boolean
[C#]
public static bool PopulateSubValues {get; set;}

See Also

FinancialEngine.Options Class | FinancialEngine.Options Members


ForecastEngine Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ForecastEngine Class

Provides a set of methods that find the best fit curve of a data set.

For a list of all members of this type, see ForecastEngine members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.ForecastEngine

Syntax

[Visual Basic]
Public NotInheritable Class ForecastEngine
[C#]
public sealed class ForecastEngine

See Also

ForecastEngine Members | dotnetCHARTING Namespace


ForecastEngine Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ForecastEngine Class Members

ForecastEngine overview

Public Methods

Public Method static (Shared in Visual Basic) TrendLine | Overloaded.
Public Method static (Shared in Visual Basic) TrendLineExponential | Overloaded.
Public Method static (Shared in Visual Basic) TrendLineLogarithmic | Overloaded.
Public Method static (Shared in Visual Basic) TrendLinePolynomial | Overloaded.
Public Method static (Shared in Visual Basic) TrendLinePower | Overloaded.

See Also

ForecastEngine Class | dotnetCHARTING Namespace


ForecastEngine Class Methods

ForecastEngine Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ForecastEngine Class Members

For a list of all members of this type, see ForecastEngine members.

Public Methods

Public Method static (Shared in Visual Basic) TrendLine | Overloaded.
Public Method static (Shared in Visual Basic) TrendLineExponential | Overloaded.
Public Method static (Shared in Visual Basic) TrendLineLogarithmic | Overloaded.
Public Method static (Shared in Visual Basic) TrendLinePolynomial | Overloaded.
Public Method static (Shared in Visual Basic) TrendLinePower | Overloaded.

See Also

ForecastEngine Class | dotnetCHARTING Namespace


ForecastEngine Class | ForecastEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TrendLine Method

Overload List

Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.

[Visual Basic] Overloads Public Shared Function TrendLine(Series,Series,Integer) As Series

[C#] public static Series TrendLine(Series,Series,int);

Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.

[Visual Basic] Overloads Public Shared Function TrendLine(SeriesCollection,Series,Integer) As SeriesCollection

[C#] public static SeriesCollection TrendLine(SeriesCollection,Series,int);

Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.

[Visual Basic] Overloads Public Shared Function TrendLine(String,Series,Series,Integer) As Series

[C#] public static Series TrendLine(string,Series,Series,int);

See Also

ForecastEngine Class | ForecastEngine Members


TrendLine(Series,Series,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
deviations
A series wich contains the standard deviations of the given data point.
mwt
When this parameter is 0 the standard deviation will not be considered.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLine(Series,Series,Int32) Method

Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.

[Visual Basic]
Overloads Public Shared Function TrendLine( _
   ByVal s As Series, _
   ByVal deviations As Series, _
   ByVal mwt As Integer _
) As Series
[C#]
public static Series TrendLine(
   Series s,
   Series deviations,
   int mwt
);

Parameters

s
A statistical series.
deviations
A series wich contains the standard deviations of the given data point.
mwt
When this parameter is 0 the standard deviation will not be considered.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLine(SeriesCollection,Series,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
deviations
A series wich contains the standard deviations of the given data point.
mwt
When this parameter is 0 the standard deviation will not be considered.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLine(SeriesCollection,Series,Int32) Method

Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.

[Visual Basic]
Overloads Public Shared Function TrendLine( _
   ByVal sc As SeriesCollection, _
   ByVal deviations As Series, _
   ByVal mwt As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection TrendLine(
   SeriesCollection sc,
   Series deviations,
   int mwt
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
deviations
A series wich contains the standard deviations of the given data point.
mwt
When this parameter is 0 the standard deviation will not be considered.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLine(String,Series,Series,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
deviations
A series wich contains the standard deviations of the given data point.
mwt
When this parameter is 0 the standard deviation will not be considered.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLine(String,Series,Series,Int32) Method

Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.

[Visual Basic]
Overloads Public Shared Function TrendLine( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal deviations As Series, _
   ByVal mwt As Integer _
) As Series
[C#]
public static Series TrendLine(
   string seriesName,
   Series s,
   Series deviations,
   int mwt
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
deviations
A series wich contains the standard deviations of the given data point.
mwt
When this parameter is 0 the standard deviation will not be considered.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


ForecastEngine Class | ForecastEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineExponential Method

Overload List

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic] Overloads Public Shared Function TrendLineExponential(Series) As Series

[C#] public static Series TrendLineExponential(Series);

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic] Overloads Public Shared Function TrendLineExponential(Series,Double,Integer,Integer) As Series

[C#] public static Series TrendLineExponential(Series,double,int,int);

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic] Overloads Public Shared Function TrendLineExponential(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection TrendLineExponential(SeriesCollection);

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic] Overloads Public Shared Function TrendLineExponential(SeriesCollection,Double,Integer,Integer) As SeriesCollection

[C#] public static SeriesCollection TrendLineExponential(SeriesCollection,double,int,int);

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic] Overloads Public Shared Function TrendLineExponential(String,Series) As Series

[C#] public static Series TrendLineExponential(string,Series);

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic] Overloads Public Shared Function TrendLineExponential(String,Series,Double,Integer,Integer) As Series

[C#] public static Series TrendLineExponential(string,Series,double,int,int);

See Also

ForecastEngine Class | ForecastEngine Members


TrendLineExponential(Series) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineExponential(Series) Method

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic]
Overloads Public Shared Function TrendLineExponential( _
   ByVal s As Series _
) As Series
[C#]
public static Series TrendLineExponential(
   Series s
);

Parameters

s
A statistical series.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLineExponential(Series,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineExponential(Series,Double,Int32,Int32) Method

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic]
Overloads Public Shared Function TrendLineExponential( _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
[C#]
public static Series TrendLineExponential(
   Series s,
   double step,
   int forward,
   int backward
);

Parameters

s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLineExponential(SeriesCollection) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineExponential(SeriesCollection) Method

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic]
Overloads Public Shared Function TrendLineExponential( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection TrendLineExponential(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLineExponential(SeriesCollection,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineExponential(SeriesCollection,Double,Int32,Int32) Method

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic]
Overloads Public Shared Function TrendLineExponential( _
   ByVal sc As SeriesCollection, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection TrendLineExponential(
   SeriesCollection sc,
   double step,
   int forward,
   int backward
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLineExponential(String,Series) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineExponential(String,Series) Method

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic]
Overloads Public Shared Function TrendLineExponential( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series TrendLineExponential(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLineExponential(String,Series,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineExponential(String,Series,Double,Int32,Int32) Method

Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).

[Visual Basic]
Overloads Public Shared Function TrendLineExponential( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
[C#]
public static Series TrendLineExponential(
   string seriesName,
   Series s,
   double step,
   int forward,
   int backward
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


ForecastEngine Class | ForecastEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineLogarithmic Method

Overload List

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic] Overloads Public Shared Function TrendLineLogarithmic(Series) As Series

[C#] public static Series TrendLineLogarithmic(Series);

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic] Overloads Public Shared Function TrendLineLogarithmic(Series,Double,Integer,Integer) As Series

[C#] public static Series TrendLineLogarithmic(Series,double,int,int);

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic] Overloads Public Shared Function TrendLineLogarithmic(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection TrendLineLogarithmic(SeriesCollection);

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic] Overloads Public Shared Function TrendLineLogarithmic(SeriesCollection,Double,Integer,Integer) As SeriesCollection

[C#] public static SeriesCollection TrendLineLogarithmic(SeriesCollection,double,int,int);

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic] Overloads Public Shared Function TrendLineLogarithmic(String,Series) As Series

[C#] public static Series TrendLineLogarithmic(string,Series);

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic] Overloads Public Shared Function TrendLineLogarithmic(String,Series,Double,Integer,Integer) As Series

[C#] public static Series TrendLineLogarithmic(string,Series,double,int,int);

See Also

ForecastEngine Class | ForecastEngine Members


TrendLineLogarithmic(Series) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineLogarithmic(Series) Method

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic]
Overloads Public Shared Function TrendLineLogarithmic( _
   ByVal s As Series _
) As Series
[C#]
public static Series TrendLineLogarithmic(
   Series s
);

Parameters

s
A statistical series.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLineLogarithmic(Series,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineLogarithmic(Series,Double,Int32,Int32) Method

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic]
Overloads Public Shared Function TrendLineLogarithmic( _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
[C#]
public static Series TrendLineLogarithmic(
   Series s,
   double step,
   int forward,
   int backward
);

Parameters

s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLineLogarithmic(SeriesCollection) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineLogarithmic(SeriesCollection) Method

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic]
Overloads Public Shared Function TrendLineLogarithmic( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection TrendLineLogarithmic(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLineLogarithmic(SeriesCollection,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineLogarithmic(SeriesCollection,Double,Int32,Int32) Method

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic]
Overloads Public Shared Function TrendLineLogarithmic( _
   ByVal sc As SeriesCollection, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection TrendLineLogarithmic(
   SeriesCollection sc,
   double step,
   int forward,
   int backward
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLineLogarithmic(String,Series) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineLogarithmic(String,Series) Method

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic]
Overloads Public Shared Function TrendLineLogarithmic( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series TrendLineLogarithmic(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLineLogarithmic(String,Series,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLineLogarithmic(String,Series,Double,Int32,Int32) Method

Find the best fit for the function f(x) = a + b * ln(x).

[Visual Basic]
Overloads Public Shared Function TrendLineLogarithmic( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
[C#]
public static Series TrendLineLogarithmic(
   string seriesName,
   Series s,
   double step,
   int forward,
   int backward
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


ForecastEngine Class | ForecastEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePolynomial Method

Overload List

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.

[Visual Basic] Overloads Public Shared Function TrendLinePolynomial(Series,Integer) As Series

[C#] public static Series TrendLinePolynomial(Series,int);

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.

[Visual Basic] Overloads Public Shared Function TrendLinePolynomial(Series,Integer,Double,Integer,Integer) As Series

[C#] public static Series TrendLinePolynomial(Series,int,double,int,int);

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.

[Visual Basic] Overloads Public Shared Function TrendLinePolynomial(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection TrendLinePolynomial(SeriesCollection,int);

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.

[Visual Basic] Overloads Public Shared Function TrendLinePolynomial(SeriesCollection,Integer,Double,Integer,Integer) As SeriesCollection

[C#] public static SeriesCollection TrendLinePolynomial(SeriesCollection,int,double,int,int);

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.

[Visual Basic] Overloads Public Shared Function TrendLinePolynomial(String,Series,Integer) As Series

[C#] public static Series TrendLinePolynomial(string,Series,int);

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.

[Visual Basic] Overloads Public Shared Function TrendLinePolynomial(String,Series,Integer,Double,Integer,Integer) As Series

[C#] public static Series TrendLinePolynomial(string,Series,int,double,int,int);

See Also

ForecastEngine Class | ForecastEngine Members


TrendLinePolynomial(Series,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List | Allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Language

Visual Basic

C#

Show All

s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePolynomial(Series,Int32) Method

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.

[Visual Basic]
Overloads Public Shared Function TrendLinePolynomial( _
   ByVal s As Series, _
   ByVal degree As Integer _
) As Series
[C#]
public static Series TrendLinePolynomial(
   Series s,
   int degree
);

Parameters

s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).

Remarks

For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

See Also

ForecastEngine Class | ForecastEngine Members | Overload List | Allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.


TrendLinePolynomial(Series,Int32,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePolynomial(Series,Int32,Double,Int32,Int32) Method

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.

[Visual Basic]
Overloads Public Shared Function TrendLinePolynomial( _
   ByVal s As Series, _
   ByVal degree As Integer, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
[C#]
public static Series TrendLinePolynomial(
   Series s,
   int degree,
   double step,
   int forward,
   int backward
);

Parameters

s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Remarks

For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

Remark: The difference between this method and TrendLinePolynomial, is that it allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Where the extended values are evaluated?

The parameters step, forward, backward allows the position and number of additional points above and/or below the range of the values in the x-coordinate of the original data set to be given. The forward parameter specifies the number of the additional evaluation points of the fitted function which are greater than the values of the x-coordinates of the original data set. Similarly, the backward parameter specifies the number of the additional evaluation points of the fitted function which are lower than the values of the x-coordinates of the original data set. The step specifies the distance in the x-coordinate between each of the additional data points, where the first additional data point either above or below is exactly a distance of step from the points of the original data set which the highest and lowest values in the x-coordinate.

For example, consider the data set x = 1, 2, 3; y = 1, 2, 3. Now if step = 1, forward = 2, and backward = 3, then this method when applied will return a two dimensional array. This two dimensional array will have the following structure: { { -2, f(-2) } { -1, f(-1) } { 0, f(0) }{ 1, 1 } { 2, 2 }{ 3, 3 } { 4, f(4) } { 5, f(5) } }, where f(-2), f(-1), f(0), f(4), f(5) correspond to the value of the fitted functions at the points x = -2, -1, 0, 4, 5, respectively.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLinePolynomial(SeriesCollection,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List | Allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePolynomial(SeriesCollection,Int32) Method

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.

[Visual Basic]
Overloads Public Shared Function TrendLinePolynomial( _
   ByVal sc As SeriesCollection, _
   ByVal degree As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection TrendLinePolynomial(
   SeriesCollection sc,
   int degree
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).

Remarks

For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

See Also

ForecastEngine Class | ForecastEngine Members | Overload List | Allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.


TrendLinePolynomial(SeriesCollection,Int32,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePolynomial(SeriesCollection,Int32,Double,Int32,Int32) Method

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.

[Visual Basic]
Overloads Public Shared Function TrendLinePolynomial( _
   ByVal sc As SeriesCollection, _
   ByVal degree As Integer, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection TrendLinePolynomial(
   SeriesCollection sc,
   int degree,
   double step,
   int forward,
   int backward
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Remarks

For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

Remark: The difference between this method and TrendLinePolynomial, is that it allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Where the extended values are evaluated?

The parameters step, forward, backward allows the position and number of additional points above and/or below the range of the values in the x-coordinate of the original data set to be given. The forward parameter specifies the number of the additional evaluation points of the fitted function which are greater than the values of the x-coordinates of the original data set. Similarly, the backward parameter specifies the number of the additional evaluation points of the fitted function which are lower than the values of the x-coordinates of the original data set. The step specifies the distance in the x-coordinate between each of the additional data points, where the first additional data point either above or below is exactly a distance of step from the points of the original data set which the highest and lowest values in the x-coordinate.

For example, consider the data set x = 1, 2, 3; y = 1, 2, 3. Now if step = 1, forward = 2, and backward = 3, then this method when applied will return a two dimensional array. This two dimensional array will have the following structure: { { -2, f(-2) } { -1, f(-1) } { 0, f(0) }{ 1, 1 } { 2, 2 }{ 3, 3 } { 4, f(4) } { 5, f(5) } }, where f(-2), f(-1), f(0), f(4), f(5) correspond to the value of the fitted functions at the points x = -2, -1, 0, 4, 5, respectively.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLinePolynomial(String,Series,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List | Allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePolynomial(String,Series,Int32) Method

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.

[Visual Basic]
Overloads Public Shared Function TrendLinePolynomial( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal degree As Integer _
) As Series
[C#]
public static Series TrendLinePolynomial(
   string seriesName,
   Series s,
   int degree
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).

Remarks

For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

See Also

ForecastEngine Class | ForecastEngine Members | Overload List | Allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.


TrendLinePolynomial(String,Series,Int32,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePolynomial(String,Series,Int32,Double,Int32,Int32) Method

Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.

[Visual Basic]
Overloads Public Shared Function TrendLinePolynomial( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal degree As Integer, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
[C#]
public static Series TrendLinePolynomial(
   string seriesName,
   Series s,
   int degree,
   double step,
   int forward,
   int backward
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Remarks

For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

Remark: The difference between this method and TrendLinePolynomial, is that it allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Where the extended values are evaluated?

The parameters step, forward, backward allows the position and number of additional points above and/or below the range of the values in the x-coordinate of the original data set to be given. The forward parameter specifies the number of the additional evaluation points of the fitted function which are greater than the values of the x-coordinates of the original data set. Similarly, the backward parameter specifies the number of the additional evaluation points of the fitted function which are lower than the values of the x-coordinates of the original data set. The step specifies the distance in the x-coordinate between each of the additional data points, where the first additional data point either above or below is exactly a distance of step from the points of the original data set which the highest and lowest values in the x-coordinate.

For example, consider the data set x = 1, 2, 3; y = 1, 2, 3. Now if step = 1, forward = 2, and backward = 3, then this method when applied will return a two dimensional array. This two dimensional array will have the following structure: { { -2, f(-2) } { -1, f(-1) } { 0, f(0) }{ 1, 1 } { 2, 2 }{ 3, 3 } { 4, f(4) } { 5, f(5) } }, where f(-2), f(-1), f(0), f(4), f(5) correspond to the value of the fitted functions at the points x = -2, -1, 0, 4, 5, respectively.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


ForecastEngine Class | ForecastEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePower Method

Overload List

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic] Overloads Public Shared Function TrendLinePower(Series) As Series

[C#] public static Series TrendLinePower(Series);

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic] Overloads Public Shared Function TrendLinePower(Series,Double,Integer,Integer) As Series

[C#] public static Series TrendLinePower(Series,double,int,int);

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic] Overloads Public Shared Function TrendLinePower(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection TrendLinePower(SeriesCollection);

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic] Overloads Public Shared Function TrendLinePower(SeriesCollection,Double,Integer,Integer) As SeriesCollection

[C#] public static SeriesCollection TrendLinePower(SeriesCollection,double,int,int);

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic] Overloads Public Shared Function TrendLinePower(String,Series) As Series

[C#] public static Series TrendLinePower(string,Series);

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic] Overloads Public Shared Function TrendLinePower(String,Series,Double,Integer,Integer) As Series

[C#] public static Series TrendLinePower(string,Series,double,int,int);

See Also

ForecastEngine Class | ForecastEngine Members


TrendLinePower(Series) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePower(Series) Method

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic]
Overloads Public Shared Function TrendLinePower( _
   ByVal s As Series _
) As Series
[C#]
public static Series TrendLinePower(
   Series s
);

Parameters

s
A statistical series.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLinePower(Series,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePower(Series,Double,Int32,Int32) Method

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic]
Overloads Public Shared Function TrendLinePower( _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
[C#]
public static Series TrendLinePower(
   Series s,
   double step,
   int forward,
   int backward
);

Parameters

s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLinePower(SeriesCollection) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePower(SeriesCollection) Method

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic]
Overloads Public Shared Function TrendLinePower( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection TrendLinePower(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLinePower(SeriesCollection,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePower(SeriesCollection,Double,Int32,Int32) Method

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic]
Overloads Public Shared Function TrendLinePower( _
   ByVal sc As SeriesCollection, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection TrendLinePower(
   SeriesCollection sc,
   double step,
   int forward,
   int backward
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLinePower(String,Series) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePower(String,Series) Method

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic]
Overloads Public Shared Function TrendLinePower( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series TrendLinePower(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


TrendLinePower(String,Series,Double,Int32,Int32) Method

ForecastEngine Class | ForecastEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
See Also Languages dotnetCHARTING Send comments on this topic.

TrendLinePower(String,Series,Double,Int32,Int32) Method

Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).

[Visual Basic]
Overloads Public Shared Function TrendLinePower( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
[C#]
public static Series TrendLinePower(
   string seriesName,
   Series s,
   double step,
   int forward,
   int backward
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Type

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

See Also

ForecastEngine Class | ForecastEngine Members | Overload List


ForecastEngine.Advanced Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ForecastEngine.Advanced Class

This class contains advanced methods for calculating the best fitting curve of a data set. It allows the user to construct his own function.

For a list of all members of this type, see ForecastEngine.Advanced members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.ForecastEngine.Advanced

Syntax

[Visual Basic]
Public NotInheritable Class ForecastEngine.Advanced
[C#]
public sealed class ForecastEngine.Advanced

See Also

ForecastEngine.Advanced Members | dotnetCHARTING Namespace


ForecastEngine.Advanced Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ForecastEngine.Advanced Class Members

ForecastEngine.Advanced overview

Public Methods

Public Method static (Shared in Visual Basic) GeneralLinear | Overloaded.
Public Method static (Shared in Visual Basic) NonLinearModel | Overloaded.

See Also

ForecastEngine.Advanced Class | dotnetCHARTING Namespace


ForecastEngine.Advanced Class Methods

ForecastEngine.Advanced Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ForecastEngine.Advanced Class Members

For a list of all members of this type, see ForecastEngine.Advanced members.

Public Methods

Public Method static (Shared in Visual Basic) GeneralLinear | Overloaded.
Public Method static (Shared in Visual Basic) NonLinearModel | Overloaded.

See Also

ForecastEngine.Advanced Class | dotnetCHARTING Namespace


ForecastEngine.Advanced Class | ForecastEngine.Advanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GeneralLinear Method

Overload List

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic] Overloads Public Shared Function GeneralLinear(Series,Series) As Series

[C#] public static Series GeneralLinear(Series,Series);

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic] Overloads Public Shared Function GeneralLinear(Series,Series,Double,Double,Double) As Series

[C#] public static Series GeneralLinear(Series,Series,double,double,double);

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic] Overloads Public Shared Function GeneralLinear(SeriesCollection,Series) As SeriesCollection

[C#] public static SeriesCollection GeneralLinear(SeriesCollection,Series);

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic] Overloads Public Shared Function GeneralLinear(SeriesCollection,Series,Double,Double,Double) As SeriesCollection

[C#] public static SeriesCollection GeneralLinear(SeriesCollection,Series,double,double,double);

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic] Overloads Public Shared Function GeneralLinear(String,Series,Series) As Series

[C#] public static Series GeneralLinear(string,Series,Series);

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic] Overloads Public Shared Function GeneralLinear(String,Series,Series,Double,Double,Double) As Series

[C#] public static Series GeneralLinear(string,Series,Series,double,double,double);

See Also

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members


GeneralLinear(Series,Series) Method

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
See Also Languages dotnetCHARTING Send comments on this topic.

GeneralLinear(Series,Series) Method

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic]
Overloads Public Shared Function GeneralLinear( _
   ByVal s As Series, _
   ByVal sigma As Series _
) As Series
[C#]
public static Series GeneralLinear(
   Series s,
   Series sigma
);

Parameters

s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.

Return Type

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.

Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

See Also

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List


GeneralLinear(Series,Series,Double,Double,Double) Method

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
xMin
The XValue of the starting point of the evaluation of best fitting curve.
xMax
The XValue of the ending point of the evaluation of best fitting curve.
interval
The distance between two points.
See Also Languages dotnetCHARTING Send comments on this topic.

GeneralLinear(Series,Series,Double,Double,Double) Method

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic]
Overloads Public Shared Function GeneralLinear( _
   ByVal s As Series, _
   ByVal sigma As Series, _
   ByVal xMin As Double, _
   ByVal xMax As Double, _
   ByVal interval As Double _
) As Series
[C#]
public static Series GeneralLinear(
   Series s,
   Series sigma,
   double xMin,
   double xMax,
   double interval
);

Parameters

s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
xMin
The XValue of the starting point of the evaluation of best fitting curve.
xMax
The XValue of the ending point of the evaluation of best fitting curve.
interval
The distance between two points.

Return Type

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.

Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

See Also

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List


GeneralLinear(SeriesCollection,Series) Method

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
See Also Languages dotnetCHARTING Send comments on this topic.

GeneralLinear(SeriesCollection,Series) Method

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic]
Overloads Public Shared Function GeneralLinear( _
   ByVal sc As SeriesCollection, _
   ByVal sigma As Series _
) As SeriesCollection
[C#]
public static SeriesCollection GeneralLinear(
   SeriesCollection sc,
   Series sigma
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.

Return Type

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.

Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

See Also

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List


GeneralLinear(SeriesCollection,Series,Double,Double,Double) Method

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
xMin
The XValue of the starting point of the evaluation of best fitting curve.
xMax
The XValue of the ending point of the evaluation of best fitting curve.
interval
The distance between two points.
See Also Languages dotnetCHARTING Send comments on this topic.

GeneralLinear(SeriesCollection,Series,Double,Double,Double) Method

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic]
Overloads Public Shared Function GeneralLinear( _
   ByVal sc As SeriesCollection, _
   ByVal sigma As Series, _
   ByVal xMin As Double, _
   ByVal xMax As Double, _
   ByVal interval As Double _
) As SeriesCollection
[C#]
public static SeriesCollection GeneralLinear(
   SeriesCollection sc,
   Series sigma,
   double xMin,
   double xMax,
   double interval
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
xMin
The XValue of the starting point of the evaluation of best fitting curve.
xMax
The XValue of the ending point of the evaluation of best fitting curve.
interval
The distance between two points.

Return Type

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.

Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

See Also

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List


GeneralLinear(String,Series,Series) Method

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
See Also Languages dotnetCHARTING Send comments on this topic.

GeneralLinear(String,Series,Series) Method

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic]
Overloads Public Shared Function GeneralLinear( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal sigma As Series _
) As Series
[C#]
public static Series GeneralLinear(
   string seriesName,
   Series s,
   Series sigma
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.

Return Type

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.

Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

See Also

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List


GeneralLinear(String,Series,Series,Double,Double,Double) Method

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
xMin
The XValue of the starting point of the evaluation of best fitting curve.
xMax
The XValue of the ending point of the evaluation of best fitting curve.
interval
The distance between two points.
See Also Languages dotnetCHARTING Send comments on this topic.

GeneralLinear(String,Series,Series,Double,Double,Double) Method

Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.

[Visual Basic]
Overloads Public Shared Function GeneralLinear( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal sigma As Series, _
   ByVal xMin As Double, _
   ByVal xMax As Double, _
   ByVal interval As Double _
) As Series
[C#]
public static Series GeneralLinear(
   string seriesName,
   Series s,
   Series sigma,
   double xMin,
   double xMax,
   double interval
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
xMin
The XValue of the starting point of the evaluation of best fitting curve.
xMax
The XValue of the ending point of the evaluation of best fitting curve.
interval
The distance between two points.

Return Type

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.

Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

See Also

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List


ForecastEngine.Advanced Class | ForecastEngine.Advanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

NonLinearModel Method

Overload List

Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.

[Visual Basic] Overloads Public Shared Function NonLinearModel(Series,Series,Double(),Boolean()) As Series

[C#] public static Series NonLinearModel(Series,Series,double[],bool[]);

Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.

[Visual Basic] Overloads Public Shared Function NonLinearModel(SeriesCollection,Series,Double(),Boolean()) As SeriesCollection

[C#] public static SeriesCollection NonLinearModel(SeriesCollection,Series,double[],bool[]);

Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.

[Visual Basic] Overloads Public Shared Function NonLinearModel(String,Series,Series,Double(),Boolean()) As Series

[C#] public static Series NonLinearModel(string,Series,Series,double[],bool[]);

See Also

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members


NonLinearModel(Series,Series,Double[],Boolean[]) Method

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
deviations
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
a
The parameters/state of the model.
vary
False to indicate the corresponding modelParameters[k] is to be held fixed.
See Also Languages dotnetCHARTING Send comments on this topic.

NonLinearModel(Series,Series,Double[],Boolean[]) Method

Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.

[Visual Basic]
Overloads Public Shared Function NonLinearModel( _
   ByVal s As Series, _
   ByVal deviations As Series, _
   ByVal a() As Double, _
   ByVal vary() As Boolean _
) As Series
[C#]
public static Series NonLinearModel(
   Series s,
   Series deviations,
   double[] a,
   bool[] vary
);

Parameters

s
A statistical series.
deviations
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
a
The parameters/state of the model.
vary
False to indicate the corresponding modelParameters[k] is to be held fixed.

Remarks

This examlpe finds the real valued function of best fit, of the type considered in accordance with the least squares approach. That is, for the functon f, which depends on the parameters (or variables a[]), we find the variables such that:

E = sum_k {(y[k] - f(x[k],a)) / s[k]}^2

is minimal, where:

  1. x[] - are the domain points, i.e. the points at which the values of the real valued function are evaluated.
  2. y[] - are the values of the data points at the domain values.
  3. a[] - the models parameters, that is the variables which the function which is being fitted depends on.
  4. s[] - the scale (or weight) which is applied to each error. That is, s[k] is the scale applied the error for the k-th data set point.

Remark: The implemention of the function interface, implements two methods which return the value and the gradient of the function f(x,a), and not the functional E given above.

Features of the Algorithm

The algorithm for the non-linear framework finds the local minimum in accordance with the least squares approach. This mean that the initial point given from which the minimum is sort lies within the same basin of attraction of the global minimum. In practice, this means in particularly when a non-linear function with many terms is considered that the initial starting point is very carefully chosen. This is not a consequence of our implementation but the nature of the algorithm and problem at hand. The algorithms is of greedy type and essentially uses an abstraction of calculus based methods in which the best point in a neighbourhood of a point a chosen at each step.

Remark: As a side note, the reason why the linear algorithm work so well is that it is based on a simplex algorithm which is combinatorial in nature.

See Also

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List


NonLinearModel(SeriesCollection,Series,Double[],Boolean[]) Method

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
deviations
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
a
The parameters/state of the model.
vary
False to indicate the corresponding modelParameters[k] is to be held fixed.
See Also Languages dotnetCHARTING Send comments on this topic.

NonLinearModel(SeriesCollection,Series,Double[],Boolean[]) Method

Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.

[Visual Basic]
Overloads Public Shared Function NonLinearModel( _
   ByVal sc As SeriesCollection, _
   ByVal deviations As Series, _
   ByVal a() As Double, _
   ByVal vary() As Boolean _
) As SeriesCollection
[C#]
public static SeriesCollection NonLinearModel(
   SeriesCollection sc,
   Series deviations,
   double[] a,
   bool[] vary
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
deviations
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
a
The parameters/state of the model.
vary
False to indicate the corresponding modelParameters[k] is to be held fixed.

Remarks

This examlpe finds the real valued function of best fit, of the type considered in accordance with the least squares approach. That is, for the functon f, which depends on the parameters (or variables a[]), we find the variables such that:

E = sum_k {(y[k] - f(x[k],a)) / s[k]}^2

is minimal, where:

  1. x[] - are the domain points, i.e. the points at which the values of the real valued function are evaluated.
  2. y[] - are the values of the data points at the domain values.
  3. a[] - the models parameters, that is the variables which the function which is being fitted depends on.
  4. s[] - the scale (or weight) which is applied to each error. That is, s[k] is the scale applied the error for the k-th data set point.

Remark: The implemention of the function interface, implements two methods which return the value and the gradient of the function f(x,a), and not the functional E given above.

Features of the Algorithm

The algorithm for the non-linear framework finds the local minimum in accordance with the least squares approach. This mean that the initial point given from which the minimum is sort lies within the same basin of attraction of the global minimum. In practice, this means in particularly when a non-linear function with many terms is considered that the initial starting point is very carefully chosen. This is not a consequence of our implementation but the nature of the algorithm and problem at hand. The algorithms is of greedy type and essentially uses an abstraction of calculus based methods in which the best point in a neighbourhood of a point a chosen at each step.

Remark: As a side note, the reason why the linear algorithm work so well is that it is based on a simplex algorithm which is combinatorial in nature.

See Also

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List


NonLinearModel(String,Series,Series,Double[],Boolean[]) Method

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
deviations
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
a
The parameters/state of the model.
vary
False to indicate the corresponding modelParameters[k] is to be held fixed.
See Also Languages dotnetCHARTING Send comments on this topic.

NonLinearModel(String,Series,Series,Double[],Boolean[]) Method

Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.

[Visual Basic]
Overloads Public Shared Function NonLinearModel( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal deviations As Series, _
   ByVal a() As Double, _
   ByVal vary() As Boolean _
) As Series
[C#]
public static Series NonLinearModel(
   string seriesName,
   Series s,
   Series deviations,
   double[] a,
   bool[] vary
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
deviations
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
a
The parameters/state of the model.
vary
False to indicate the corresponding modelParameters[k] is to be held fixed.

Remarks

This examlpe finds the real valued function of best fit, of the type considered in accordance with the least squares approach. That is, for the functon f, which depends on the parameters (or variables a[]), we find the variables such that:

E = sum_k {(y[k] - f(x[k],a)) / s[k]}^2

is minimal, where:

  1. x[] - are the domain points, i.e. the points at which the values of the real valued function are evaluated.
  2. y[] - are the values of the data points at the domain values.
  3. a[] - the models parameters, that is the variables which the function which is being fitted depends on.
  4. s[] - the scale (or weight) which is applied to each error. That is, s[k] is the scale applied the error for the k-th data set point.

Remark: The implemention of the function interface, implements two methods which return the value and the gradient of the function f(x,a), and not the functional E given above.

Features of the Algorithm

The algorithm for the non-linear framework finds the local minimum in accordance with the least squares approach. This mean that the initial point given from which the minimum is sort lies within the same basin of attraction of the global minimum. In practice, this means in particularly when a non-linear function with many terms is considered that the initial starting point is very carefully chosen. This is not a consequence of our implementation but the nature of the algorithm and problem at hand. The algorithms is of greedy type and essentially uses an abstraction of calculus based methods in which the best point in a neighbourhood of a point a chosen at each step.

Remark: As a side note, the reason why the linear algorithm work so well is that it is based on a simplex algorithm which is combinatorial in nature.

See Also

ForecastEngine.Advanced Class | ForecastEngine.Advanced Members | Overload List


ForecastEngine.Options Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ForecastEngine.Options Class

Defines a set of static options used with FinancialEngine calculations.

For a list of all members of this type, see ForecastEngine.Options members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.ForecastEngine.Options

Syntax

[Visual Basic]
Public NotInheritable Class ForecastEngine.Options
[C#]
public sealed class ForecastEngine.Options

See Also

ForecastEngine.Options Members | dotnetCHARTING Namespace


ForecastEngine.Options Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ForecastEngine.Options Class Members

ForecastEngine.Options overview

Public Properties

Public Property static (Shared in Visual Basic) MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
Public Property static (Shared in Visual Basic) ModelFunction | This attribute allows the basis of functions which describes a factor model.
Public Property static (Shared in Visual Basic) NonLinearModelFunction | This attribute holds the basis of functions which describes a factor model.
Public Property static (Shared in Visual Basic) PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.

Public Methods

Public Method static (Shared in Visual Basic) AddAbsoluteSum | Adds a sum of absolute functions to be used as basis element.
Public Method static (Shared in Visual Basic) AddConstantTerm | Adds a constant function on one real variable to the function basis.
Public Method static (Shared in Visual Basic) AddCosineSum | Adds a sum a Cosine functions to an elements of the function basis.
Public Method static (Shared in Visual Basic) AddExponentialSum | Adds a sum of exponential functions to be used as basis elements.
Public Method static (Shared in Visual Basic) AddLogarithmicSum | Adds a sum of (natural) log functions to be used as basis elements.
Public Method static (Shared in Visual Basic) AddNonLinearConstantTerm | Adds a (linear) constant function on one real variable to the function basis.
Public Method static (Shared in Visual Basic) AddNonLinearCosineSum | Adds a sum a Cosine functions as an element of the function basis.
Public Method static (Shared in Visual Basic) AddNonLinearExponentialSum | Adds a sum of exponential functions to be used as non-linear basis elements.
Public Method static (Shared in Visual Basic) AddNonLinearLogarithmicSum | Adds a sum of (natural) log functions to be used as non-linear basis elements.
Public Method static (Shared in Visual Basic) AddNonLinearSineSum | Adds a sum of Sine functions to the used as non-linear basis elements.
Public Method static (Shared in Visual Basic) AddNonLinearTangentSum | Adds a sum of Tangent functions to the used as non-linear basis elements.
Public Method static (Shared in Visual Basic) AddPowerTerm | Add a power term as an element of the function basis.
Public Method static (Shared in Visual Basic) AddRationalSumOfPowerTerms | Adds a rational expression where the numerator and denominator are both themselves a sum of power terms as defined within AddSumOfPowerTerms to the function basis.
Public Method static (Shared in Visual Basic) AddSineSum | Adds a sum of Sine functions to the used as basis elements.
Public Method static (Shared in Visual Basic) AddStepSum | Adds a sum of step functions to be used as a basis element.
Public Method static (Shared in Visual Basic) AddSumOfNonLinearPowerTerms | Adds a sum of power terms as an element of the function basis.
Public Method static (Shared in Visual Basic) AddSumOfPowerTerms | Adds a sum of power terms as an element of the function basis.
Public Method static (Shared in Visual Basic) AddTangentSum | Adds a sum of Tangent functions to the used as basis elements.
Public Method static (Shared in Visual Basic) Reset | Resets the options to default settings.

See Also

ForecastEngine.Options Class | dotnetCHARTING Namespace


ForecastEngine.Options Class Methods

ForecastEngine.Options Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ForecastEngine.Options Class Members

For a list of all members of this type, see ForecastEngine.Options members.

Public Methods

Public Method static (Shared in Visual Basic) AddAbsoluteSum | Adds a sum of absolute functions to be used as basis element.
Public Method static (Shared in Visual Basic) AddConstantTerm | Adds a constant function on one real variable to the function basis.
Public Method static (Shared in Visual Basic) AddCosineSum | Adds a sum a Cosine functions to an elements of the function basis.
Public Method static (Shared in Visual Basic) AddExponentialSum | Adds a sum of exponential functions to be used as basis elements.
Public Method static (Shared in Visual Basic) AddLogarithmicSum | Adds a sum of (natural) log functions to be used as basis elements.
Public Method static (Shared in Visual Basic) AddNonLinearConstantTerm | Adds a (linear) constant function on one real variable to the function basis.
Public Method static (Shared in Visual Basic) AddNonLinearCosineSum | Adds a sum a Cosine functions as an element of the function basis.
Public Method static (Shared in Visual Basic) AddNonLinearExponentialSum | Adds a sum of exponential functions to be used as non-linear basis elements.
Public Method static (Shared in Visual Basic) AddNonLinearLogarithmicSum | Adds a sum of (natural) log functions to be used as non-linear basis elements.
Public Method static (Shared in Visual Basic) AddNonLinearSineSum | Adds a sum of Sine functions to the used as non-linear basis elements.
Public Method static (Shared in Visual Basic) AddNonLinearTangentSum | Adds a sum of Tangent functions to the used as non-linear basis elements.
Public Method static (Shared in Visual Basic) AddPowerTerm | Add a power term as an element of the function basis.
Public Method static (Shared in Visual Basic) AddRationalSumOfPowerTerms | Adds a rational expression where the numerator and denominator are both themselves a sum of power terms as defined within AddSumOfPowerTerms to the function basis.
Public Method static (Shared in Visual Basic) AddSineSum | Adds a sum of Sine functions to the used as basis elements.
Public Method static (Shared in Visual Basic) AddStepSum | Adds a sum of step functions to be used as a basis element.
Public Method static (Shared in Visual Basic) AddSumOfNonLinearPowerTerms | Adds a sum of power terms as an element of the function basis.
Public Method static (Shared in Visual Basic) AddSumOfPowerTerms | Adds a sum of power terms as an element of the function basis.
Public Method static (Shared in Visual Basic) AddTangentSum | Adds a sum of Tangent functions to the used as basis elements.
Public Method static (Shared in Visual Basic) Reset | Resets the options to default settings.

See Also

ForecastEngine.Options Class | dotnetCHARTING Namespace


AddAbsoluteSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

absCoeff
An array where the k-th term is the coefficient of the whole k-th absolute function term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th absolute function term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the absolute function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the absolute function term within the k-th element of the sum (i.e. n as shown above).
See Also Languages dotnetCHARTING Send comments on this topic.

AddAbsoluteSum Method

Adds a sum of absolute functions to be used as basis element.

[Visual Basic]
Public Shared Sub AddAbsoluteSum( _
   ByVal absCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
[C#]
public static void AddAbsoluteSum(
   double[] absCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
);

Parameters

absCoeff
An array where the k-th term is the coefficient of the whole k-th absolute function term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th absolute function term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the absolute function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the absolute function term within the k-th element of the sum (i.e. n as shown above).

Remarks

Where each of the elements of this sum takes the following form:

absCoeff * Absn(coefficient * x + constant)

where the Abs is the absolute functions given by:

  1. Abs(x) = x, if x > 0
  2. Abs(x) = -x, if x < 0

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddConstantTerm Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

constant
The constant value taken by the constant function.
See Also Languages dotnetCHARTING Send comments on this topic.

AddConstantTerm Method

Adds a constant function on one real variable to the function basis.

[Visual Basic]
Public Shared Sub AddConstantTerm( _
   ByVal constant As Double _
)
[C#]
public static void AddConstantTerm(
   double constant
);

Parameters

constant
The constant value taken by the constant function.

Remarks

The constant function takes the form:

f(x) = constant

where x is the variable and constant is a real number.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddCosineSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

cosCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of Cosine terms (i.e. a_k).
coefficient
An array where the k-th term is the coefficient of the Cosine term of the (k+1)-th term of the sum of the Cosine terms (i.e. b_k).
constant
An array where the k-th term is the constant shift in the x-axis of the Cosine term of the (k+1)-th term of the sum of Cosine terms (i.e. c_k).
exponent
An array where the k-th term is the exponent of the Cosine term within the (k+1)-th term of the sum of the Cosine terms (i.e. n_k).
See Also Languages dotnetCHARTING Send comments on this topic.

AddCosineSum Method

Adds a sum a Cosine functions to an elements of the function basis.

[Visual Basic]
Public Shared Sub AddCosineSum( _
   ByVal cosCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
[C#]
public static void AddCosineSum(
   double[] cosCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
);

Parameters

cosCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of Cosine terms (i.e. a_k).
coefficient
An array where the k-th term is the coefficient of the Cosine term of the (k+1)-th term of the sum of the Cosine terms (i.e. b_k).
constant
An array where the k-th term is the constant shift in the x-axis of the Cosine term of the (k+1)-th term of the sum of Cosine terms (i.e. c_k).
exponent
An array where the k-th term is the exponent of the Cosine term within the (k+1)-th term of the sum of the Cosine terms (i.e. n_k).

Remarks

Please note that the k-th term of the sum which makes up the basis function will take to form:

k-th Term = a_k * (Cosn_k (b_k * x + c_k)),

where the Cosine function is in terms of radians, and a_k, n_k, b_k, c_k are real numbers. Please, in order to construct the sum you just sum over k starting at 0.

Notes on the Radian measure

Radians are a means by which to describe the angle and are related to the more commonly used degrees as follows:

360 degrees = 2 * Pi * radians

therefore, 1 radian = 180 / Pi degrees = 57.295... degrees.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddExponentialSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

expCoeff
An array where the k-th term is the coefficient of the whole k-th exponential term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th exponential term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the exponential function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the exponential term within the k-th element of the sum (i.e. n as shown above).
See Also Languages dotnetCHARTING Send comments on this topic.

AddExponentialSum Method

Adds a sum of exponential functions to be used as basis elements.

[Visual Basic]
Public Shared Sub AddExponentialSum( _
   ByVal expCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
[C#]
public static void AddExponentialSum(
   double[] expCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
);

Parameters

expCoeff
An array where the k-th term is the coefficient of the whole k-th exponential term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th exponential term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the exponential function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the exponential term within the k-th element of the sum (i.e. n as shown above).

Remarks

Where each of the elements of the sum given will take the following form:

expCoeff * expn (coefficient * x + constant))

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddLogarithmicSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

logCoeff
An array where the k-th term is the coefficient of the whole k-th logarithm term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th logarithm term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the logarithm function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the logarithm term within the k-th element of the sum (i.e. n as shown above).
See Also Languages dotnetCHARTING Send comments on this topic.

AddLogarithmicSum Method

Adds a sum of (natural) log functions to be used as basis elements.

[Visual Basic]
Public Shared Sub AddLogarithmicSum( _
   ByVal logCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
[C#]
public static void AddLogarithmicSum(
   double[] logCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
);

Parameters

logCoeff
An array where the k-th term is the coefficient of the whole k-th logarithm term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th logarithm term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the logarithm function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the logarithm term within the k-th element of the sum (i.e. n as shown above).

Remarks

Where each of the elements of the sum given will take the following form:

logCoeff * logn (coefficient * x + constant))

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddNonLinearConstantTerm Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

constant
The constant value taken by the constant function.
See Also Languages dotnetCHARTING Send comments on this topic.

AddNonLinearConstantTerm Method

Adds a (linear) constant function on one real variable to the function basis.

[Visual Basic]
Public Shared Sub AddNonLinearConstantTerm( _
   ByVal constant As Double _
)
[C#]
public static void AddNonLinearConstantTerm(
   double constant
);

Parameters

constant
The constant value taken by the constant function.

Remarks

The constant function takes the form:

f(x, a_1) = a_1 * constant

where a_1 is a real variable and constant is a real number given.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddNonLinearCosineSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

cosCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of Cosine terms (i.e. a_k).
coefficient
An array where the k-th term is the coefficient of the Cosine term of the (k+1)-th term of the sum of the Cosine terms (i.e. b_k).
constant
An array where the k-th term is the constant shift in the x-axis of the Cosine term of the (k+1)-th term of the sum of Cosine terms (i.e. c_k).
exponent
An array where the k-th term is the exponent of the Cosine term within the (k+1)-th term of the sum of the Cosine terms (i.e. n_k).
See Also Languages dotnetCHARTING Send comments on this topic.

AddNonLinearCosineSum Method

Adds a sum a Cosine functions as an element of the function basis.

[Visual Basic]
Public Shared Sub AddNonLinearCosineSum( _
   ByVal cosCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
[C#]
public static void AddNonLinearCosineSum(
   double[] cosCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
);

Parameters

cosCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of Cosine terms (i.e. a_k).
coefficient
An array where the k-th term is the coefficient of the Cosine term of the (k+1)-th term of the sum of the Cosine terms (i.e. b_k).
constant
An array where the k-th term is the constant shift in the x-axis of the Cosine term of the (k+1)-th term of the sum of Cosine terms (i.e. c_k).
exponent
An array where the k-th term is the exponent of the Cosine term within the (k+1)-th term of the sum of the Cosine terms (i.e. n_k).

Remarks

Please note that the k-th term of the sum which makes up the basis function will take to form:

k-th Term = r_k * a_(4k) * (Cosn_k + a_(4k+1) (b_k * a_(4k+2) * x + c_k + a_(4k+3))), (*)

where the Cosine function is in terms of radians, and r_k, n_k, b_k, c_k are real numbers which are given by the parameters and

a_(4k), a_(4k+1), a_(4k+2), a_(4k+3),
             a_(4k+4)
, are the variables which are to be fitted. In order to construct the sum you just sum over k starting at 0. That is, the term from which the basis elements will be constructed is:

f(x, a_0, ..., a_4, ...., a_(4n+3)) = (sum of k of n-terms given by (*) above),

where a_0,....., a_(4n+3) are the variables of the function which are to be fitted, and x is the variable which will not be fitted.

Example

In order to clarify the above explanation we provide an explicit example. In particular, in order to represent the following sum of cosine terms:

f(x, a_0, a_1, ..., a_7) = a_0 * Cos2 * a_1 (b_0 * a_2 * x + a_3) + a_4 * Cos(1 * a_5) (b_1 * a_6 * x + 2 + a_7),

you are required to pass the following parameters:

Notes on the Radian measure

Radians are a means by which to describe the angle and are related to the more commonly used degrees as follows:

360 degrees = 2 * Pi * radians

therefore, 1 radian = 180 / Pi degrees = 57.295... degrees.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddNonLinearExponentialSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

expCoeff
An array where the k-th term is the coefficient of the whole k-th exponential term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th exponential term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the exponential function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the exponential term within the k-th element of the sum (i.e. n as shown above).
See Also Languages dotnetCHARTING Send comments on this topic.

AddNonLinearExponentialSum Method

Adds a sum of exponential functions to be used as non-linear basis elements.

[Visual Basic]
Public Shared Sub AddNonLinearExponentialSum( _
   ByVal expCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
[C#]
public static void AddNonLinearExponentialSum(
   double[] expCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
);

Parameters

expCoeff
An array where the k-th term is the coefficient of the whole k-th exponential term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th exponential term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the exponential function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the exponential term within the k-th element of the sum (i.e. n as shown above).

Remarks

Where each of the elements of the sum given will take the following form:

expCoeff * expn (coefficient * x + constant))

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddNonLinearLogarithmicSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

logCoeff
An array where the k-th term is the coefficient of the whole k-th logarithm term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th logarithm term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the logarithm function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the logarithm term within the k-th element of the sum (i.e. n as shown above).
See Also Languages dotnetCHARTING Send comments on this topic.

AddNonLinearLogarithmicSum Method

Adds a sum of (natural) log functions to be used as non-linear basis elements.

[Visual Basic]
Public Shared Sub AddNonLinearLogarithmicSum( _
   ByVal logCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
[C#]
public static void AddNonLinearLogarithmicSum(
   double[] logCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
);

Parameters

logCoeff
An array where the k-th term is the coefficient of the whole k-th logarithm term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th logarithm term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the logarithm function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the logarithm term within the k-th element of the sum (i.e. n as shown above).

Remarks

Where each of the elements of the sum given will take the following form:

logCoeff * logn (coefficient * x + constant))

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddNonLinearSineSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

sinCoeff
An array where the k-th term is the coefficient of the whole k-th cosine term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th sine term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the sine function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the sine term within the k-th element of the sum (i.e. n as shown above).
See Also Languages dotnetCHARTING Send comments on this topic.

AddNonLinearSineSum Method

Adds a sum of Sine functions to the used as non-linear basis elements.

[Visual Basic]
Public Shared Sub AddNonLinearSineSum( _
   ByVal sinCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
[C#]
public static void AddNonLinearSineSum(
   double[] sinCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
);

Parameters

sinCoeff
An array where the k-th term is the coefficient of the whole k-th cosine term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th sine term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the sine function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the sine term within the k-th element of the sum (i.e. n as shown above).

Remarks

Please note that each term of the sum which makes up the basis function will take to form:

sinCoeff * (sinn (coefficient * x + constant)),

where the Sine function is in terms of radians.

Notes on the Radian measure

Radians are a means by which to describe the angle and are related to the more commonly used degrees as follows:

360 degrees = 2 * Pi * radians

therefore, 1 radian = 180 / Pi degrees = 57.295... degrees.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddNonLinearTangentSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

tanCoeff
An array where the k-th term is the coefficient of the whole k-th tangent term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th tangent term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the tangent function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the tangent term within the k-th element of the sum (i.e. n as shown above).
See Also Languages dotnetCHARTING Send comments on this topic.

AddNonLinearTangentSum Method

Adds a sum of Tangent functions to the used as non-linear basis elements.

[Visual Basic]
Public Shared Sub AddNonLinearTangentSum( _
   ByVal tanCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
[C#]
public static void AddNonLinearTangentSum(
   double[] tanCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
);

Parameters

tanCoeff
An array where the k-th term is the coefficient of the whole k-th tangent term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th tangent term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the tangent function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the tangent term within the k-th element of the sum (i.e. n as shown above).

Remarks

Please note that each term of the cum which makes up the basis function will take to form:

tanCoeff * (tann (coefficient * x + constant)),

where the Tangent function is in terms of radians.

Notes on the Radian measure

Radians are a means by which to describe the angle and are related to the more commonly used degrees as follows:

360 degrees = 2 * Pi * radians

therefore, 1 radian = 180 / Pi degrees = 57.295... degrees.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddPowerTerm Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

coefficient
A double which is the coefficient of the term (i.e. a_1 above).
exponent
A double which is the exponent of the variable of the term (i.e. n above).
See Also Languages dotnetCHARTING Send comments on this topic.

AddPowerTerm Method

Add a power term as an element of the function basis.

[Visual Basic]
Public Shared Sub AddPowerTerm( _
   ByVal coefficient As Double, _
   ByVal exponent As Double _
)
[C#]
public static void AddPowerTerm(
   double coefficient,
   double exponent
);

Parameters

coefficient
A double which is the coefficient of the term (i.e. a_1 above).
exponent
A double which is the exponent of the variable of the term (i.e. n above).

Remarks

This elements will take the follow form:

a_1 * x^n,

where a_1, n are arbitrary real numbers.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddRationalSumOfPowerTerms Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

upperRationalCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. a_k) which make up the numerator.
upperRationalExp
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. n_k) which make up the numerator.
lowerRationalCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. b_k) which make up the denominator.
lowerRationalExp
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. m_k) which make up the denominator.
See Also Languages dotnetCHARTING Send comments on this topic.

AddRationalSumOfPowerTerms Method

Adds a rational expression where the numerator and denominator are both themselves a sum of power terms as defined within AddSumOfPowerTerms to the function basis.

[Visual Basic]
Public Shared Sub AddRationalSumOfPowerTerms( _
   ByVal upperRationalCoeff() As Double, _
   ByVal upperRationalExp() As Double, _
   ByVal lowerRationalCoeff() As Double, _
   ByVal lowerRationalExp() As Double _
)
[C#]
public static void AddRationalSumOfPowerTerms(
   double[] upperRationalCoeff,
   double[] upperRationalExp,
   double[] lowerRationalCoeff,
   double[] lowerRationalExp
);

Parameters

upperRationalCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. a_k) which make up the numerator.
upperRationalExp
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. n_k) which make up the numerator.
lowerRationalCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. b_k) which make up the denominator.
lowerRationalExp
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. m_k) which make up the denominator.

Remarks

That is, the rational sum of the power terms takes the form:

( (a_1 * x^n_1) + ... + (a_p * x^n_p) ) / ( (b_1 * x^m_1) + ... + (b_q * x^m_q) ),

where a_1,..., a_n, n_1,..., n_p, b_1,..., b_q are real numbers and x is the real variable.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddSineSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

sinCoeff
An array where the k-th term is the coefficient of the whole k-th cosine term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th sine term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the sine function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the sine term within the k-th element of the sum (i.e. n as shown above).
See Also Languages dotnetCHARTING Send comments on this topic.

AddSineSum Method

Adds a sum of Sine functions to the used as basis elements.

[Visual Basic]
Public Shared Sub AddSineSum( _
   ByVal sinCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
[C#]
public static void AddSineSum(
   double[] sinCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
);

Parameters

sinCoeff
An array where the k-th term is the coefficient of the whole k-th cosine term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th sine term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the sine function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the sine term within the k-th element of the sum (i.e. n as shown above).

Remarks

Please note that each term of the sum which makes up the basis function will take to form:

sinCoeff * (sinn (coefficient * x + constant)),

where the Sine function is in terms of radians.

Notes on the Radian measure

Radians are a means by which to describe the angle and are related to the more commonly used degrees as follows:

360 degrees = 2 * Pi * radians

therefore, 1 radian = 180 / Pi degrees = 57.295... degrees.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddStepSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

stepCoeff
An array where the k-th term is the coefficient of the whole k-th step function term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th step function term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the step function of the k-th term within the sum (i.e. the constant term as shown above).
See Also Languages dotnetCHARTING Send comments on this topic.

AddStepSum Method

Adds a sum of step functions to be used as a basis element.

[Visual Basic]
Public Shared Sub AddStepSum( _
   ByVal stepCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double _
)
[C#]
public static void AddStepSum(
   double[] stepCoeff,
   double[] coefficient,
   double[] constant
);

Parameters

stepCoeff
An array where the k-th term is the coefficient of the whole k-th step function term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th step function term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the step function of the k-th term within the sum (i.e. the constant term as shown above).

Remarks

Where each of the elements of the sum takes the following form:

stepCoeff * Step(coefficient * x + constant),

where the Step(x) is given by:

  1. Step(x) = 0, if x lequ; 0
  2. Step(x) = 1, if x > 0

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddSumOfNonLinearPowerTerms Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

powerTermCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. a_k).
powerTermExponents
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. n_k).
See Also Languages dotnetCHARTING Send comments on this topic.

AddSumOfNonLinearPowerTerms Method

Adds a sum of power terms as an element of the function basis.

[Visual Basic]
Public Shared Sub AddSumOfNonLinearPowerTerms( _
   ByVal powerTermCoeff() As Double, _
   ByVal powerTermExponents() As Double _
)
[C#]
public static void AddSumOfNonLinearPowerTerms(
   double[] powerTermCoeff,
   double[] powerTermExponents
);

Parameters

powerTermCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. a_k).
powerTermExponents
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. n_k).

Remarks

The sum of power terms will take the follow form:

f(x, a_1,..., a_n, a'_1,..., a'_n) = (b_1 * a_1 * x^(p_1 * a'_1)) + ... + (b_n * a_n x^(p_n * a'_n)),

where b_1,..., b_n, p_1,..., p_n are arbitrary real numbers and x and a_1,..., a_n, a'_1, ..., a'_n are rael varibles.

Remark: This term is a direct generalization of the sum of poqwer terms as contained within the Linear Factor model.

Ordering of the Variables

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddSumOfPowerTerms Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

powerTermCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. a_k).
powerTermExponents
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. n_k).
See Also Languages dotnetCHARTING Send comments on this topic.

AddSumOfPowerTerms Method

Adds a sum of power terms as an element of the function basis.

[Visual Basic]
Public Shared Sub AddSumOfPowerTerms( _
   ByVal powerTermCoeff() As Double, _
   ByVal powerTermExponents() As Double _
)
[C#]
public static void AddSumOfPowerTerms(
   double[] powerTermCoeff,
   double[] powerTermExponents
);

Parameters

powerTermCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. a_k).
powerTermExponents
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. n_k).

Remarks

The sum of power terms will take the follow form:

(a_1 * x^n_1) + ... + (a_m * x^n_p),

where a_1,..., a_n, n_1,..., n_p are arbitrary real numbers.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


AddTangentSum Method

ForecastEngine.Options Class | ForecastEngine.Options Members

Language

Visual Basic

C#

Show All

tanCoeff
An array where the k-th term is the coefficient of the whole k-th tangent term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th tangent term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the tangent function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the tangent term within the k-th element of the sum (i.e. n as shown above).
See Also Languages dotnetCHARTING Send comments on this topic.

AddTangentSum Method

Adds a sum of Tangent functions to the used as basis elements.

[Visual Basic]
Public Shared Sub AddTangentSum( _
   ByVal tanCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
[C#]
public static void AddTangentSum(
   double[] tanCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
);

Parameters

tanCoeff
An array where the k-th term is the coefficient of the whole k-th tangent term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th tangent term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the tangent function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the tangent term within the k-th element of the sum (i.e. n as shown above).

Remarks

Please note that each term of the cum which makes up the basis function will take to form:

tanCoeff * (tann (coefficient * x + constant)),

where the Tangent function is in terms of radians.

Notes on the Radian measure

Radians are a means by which to describe the angle and are related to the more commonly used degrees as follows:

360 degrees = 2 * Pi * radians

therefore, 1 radian = 180 / Pi degrees = 57.295... degrees.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


ForecastEngine.Options Class | ForecastEngine.Options Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Reset Method

Resets the options to default settings.

[Visual Basic]
Public Shared Sub Reset()
[C#]
public static void Reset();

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


ForecastEngine.Options Class Properties

ForecastEngine.Options Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ForecastEngine.Options Class Members

For a list of all members of this type, see ForecastEngine.Options members.

Public Properties

Public Property static (Shared in Visual Basic) MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
Public Property static (Shared in Visual Basic) ModelFunction | This attribute allows the basis of functions which describes a factor model.
Public Property static (Shared in Visual Basic) NonLinearModelFunction | This attribute holds the basis of functions which describes a factor model.
Public Property static (Shared in Visual Basic) PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.

See Also

ForecastEngine.Options Class | dotnetCHARTING Namespace


ForecastEngine.Options Class | ForecastEngine.Options Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MatchColors Property

Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.

[Visual Basic]
Public Shared Property MatchColors As Boolean
[C#]
public static bool MatchColors {get; set;}

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


ForecastEngine.Options Class | ForecastEngine.Options Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ModelFunction Property

This attribute allows the basis of functions which describes a factor model.

[Visual Basic]
Public Shared Property ModelFunction As FactorModel
[C#]
public static FactorModel ModelFunction {get; set;}

Remarks

A factor model is a real vector space of functions from which a function will be selected in accordance with some criteria. That is, we allow the basis of functions f_1(x), f_2(x) , ..., f_n(x), which span the factor model, i.e. any element of the factor model can be represented as:

a_1 * f_1(x) + a_2 * f_2(x) + ... + a_n * f_n(x)

where a_1, ..., a_n are real numbers. Note that the above representation is unique.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


ForecastEngine.Options Class | ForecastEngine.Options Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

NonLinearModelFunction Property

This attribute holds the basis of functions which describes a factor model.

[Visual Basic]
Public Shared Property NonLinearModelFunction As NonLinearFactorModel
[C#]
public static NonLinearFactorModel NonLinearModelFunction {get; set;}

Remarks

A factor model is a real vector space of functions from which a function will be selected in accordance with some criteria. That is, we allow the basis of functions f_1, f_2,..., f_n, which span the factor model, i.e. any element of the factor model can be represented as:

f_1(x, a_1, ...., a_n) + f_2(x, a'_1,...., a'_n) + ... + f_n(x, a''_1, ....., a''_n)

where x and a_1,..., a_n, a'_1,..., a'_n,..., a''_1,..., a''_n are real variables. For example the term f_1(x, a_1, a_2, a_3), could correspond to:

f_1(x, a_1, a_2, a_3) = a_1 Sin(a_2 x + a_3)

where a_1, a_2, a_3, are the variables which are to be fitted using the fitting algorithm.

Ordering of the Variables

Once the non-linear factor has been built (using this class) and fitted using the the non linear model algorithm, the values of the a_k which generate the best fitted curve in accordance with the least squares approach will be returned within an array.

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


ForecastEngine.Options Class | ForecastEngine.Options Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PopulateSubValues Property

Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.

[Visual Basic]
Public Shared Property PopulateSubValues As Boolean
[C#]
public static bool PopulateSubValues {get; set;}

See Also

ForecastEngine.Options Class | ForecastEngine.Options Members


Hotspot Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hotspot Class

Represents a hotspot on the image and provides events such as tool tips and redirect URL when clicked.

For a list of all members of this type, see Hotspot members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.Hotspot

Syntax

[Visual Basic]
Public Class Hotspot
[C#]
public class Hotspot

Remarks

For more information, see tutorial:
Getting Started > General Tutorials > Interactivity - Hotspots

Example

[Visual Basic] This sample demonstrates how to use hotspots.

<%@ Page Language="VB" Description="dotnetCHARTING Component" %>
<%@ Register TagPrefix="dotnet" Namespace="dotnetCHARTING" Assembly="dotnetCHARTING"%>
<%@ Import Namespace="System.Drawing" %>
<%@ Import Namespace="System.Drawing.Drawing2D" %>
<HTML>
    <HEAD>
        <TITLE>.netCHARTING Sample</TITLE>
        <script runat="server">

Sub Page_Load(sender As [Object], e As EventArgs)

   Chart.Type = ChartType.Combo
   Chart.Width = Unit.Parse(600)
   Chart.Height = Unit.Parse(350)
   Chart.TempDirectory = "temp"
   Chart.Debug = True
   Chart.Title = "Hotspots"

   ' This sample demonstrates how to use hotspots.
   Chart.DefaultElement.Hotspot.Attributes.OnMouseOver.StatusBarMessage = "%Name: %Value"
   Chart.DefaultElement.Hotspot.Attributes.Custom.Add("OnClick", "alert('%Name Clicked')")
   Chart.DefaultElement.Hotspot.ToolTip = "%Name: %Value"

   ' *DYNAMIC DATA NOTE*
   ' This sample uses random data to populate the chart. To populate
   ' a chart with database data see the following resources:
   ' - Classic samples folder
   ' - Help File > Data Tutorials
   ' - Sample: features/DataEngine.aspx
   Dim mySC As SeriesCollection = getRandomData()

   ' Add the random data.
   Chart.SeriesCollection.Add(mySC)
End Sub 'Page_Load

Function getRandomData() As SeriesCollection
   Dim SC As New SeriesCollection()
   Dim myR As New Random(1)
   Dim a As Integer
   For a = 0 To 3
      Dim s As New Series()
      s.Name = "Series " +Convert.ToString(a + 1)
      Dim b As Integer
      For b = 0 To 3
         Dim e As New Element()
         e.Name = "Element " +Convert.ToString(b + 1)
         e.YValue = myR.Next(50)
         s.Elements.Add(e)
      Next b
      SC.Add(s)
   Next a

   ' Set Different Colors for our Series
   SC(0).DefaultElement.Color = Color.FromArgb(49, 255, 49)
   SC(1).DefaultElement.Color = Color.FromArgb(255, 255, 0)
   SC(2).DefaultElement.Color = Color.FromArgb(255, 99, 49)
   SC(3).DefaultElement.Color = Color.FromArgb(0, 156, 255)

   Return SC
End Function 'getRandomData

</script>
    </HEAD>
    <BODY>
        <DIV align="center">
            <dotnet:Chart id="Chart" runat="server" Width="568px" Height="344px">
            </dotnet:Chart>
        </DIV>
    </BODY>
</HTML>

[C#] This sample demonstrates how to use hotspots.

<%@ Page Language="C#" Description="dotnetCHARTING Component" %>
<%@ Register TagPrefix="dotnet"  Namespace="dotnetCHARTING" Assembly="dotnetCHARTING"%>
<%@ Import Namespace="System.Drawing" %>
<%@ Import Namespace="System.Drawing.Drawing2D" %>
<HTML>
    <HEAD>
        <TITLE>.netCHARTING Sample</TITLE>
        <script runat="server">

void Page_Load(Object sender,EventArgs e)
{

    Chart.Type = ChartType.Combo;//Horizontal;
    Chart.Width = 600;
    Chart.Height = 350;
    Chart.TempDirectory = "temp";
    Chart.Debug = true;
    Chart.Title = "Hotspots";

    // This sample demonstrates how to use hotspots.

    Chart.DefaultElement.Hotspot.Attributes.OnMouseOver.StatusBarMessage = "%Name: %Value";
    Chart.DefaultElement.Hotspot.Attributes.Custom.Add("OnClick","alert('%Name Clicked')");
    Chart.DefaultElement.Hotspot.ToolTip = "%Name: %Value";

    // *DYNAMIC DATA NOTE*
    // This sample uses random data to populate the chart. To populate
    // a chart with database data see the following resources:
    // - Classic samples folder
    // - Help File > Data Tutorials
    // - Sample: features/DataEngine.aspx
    SeriesCollection mySC = getRandomData();

    // Add the random data.
    Chart.SeriesCollection.Add(mySC);

}

SeriesCollection getRandomData()
{
    SeriesCollection SC = new SeriesCollection();
    Random myR = new Random(1);
    for(int a = 0; a < 4; a++)
    {
        Series s = new Series();
        s.Name = "Series " + (a+1);
        for(int b = 0; b < 4; b++)
        {
            Element e = new Element();
            e.Name = "Element " + (b+1);
            e.YValue = myR.Next(50);
            s.Elements.Add(e);
        }
        SC.Add(s);
    }

    // Set Different Colors for our Series
    SC[0].DefaultElement.Color = Color.FromArgb(49,255,49);
    SC[1].DefaultElement.Color = Color.FromArgb(255,255,0);
    SC[2].DefaultElement.Color = Color.FromArgb(255,99,49);
    SC[3].DefaultElement.Color = Color.FromArgb(0,156,255);

    return SC;
}
        </script>
    </HEAD>
    <BODY>
        <DIV align="center">
            <dotnet:Chart id="Chart" runat="server" Width="568px" Height="344px">
            </dotnet:Chart>
        </DIV>
    </BODY>
</HTML>

See Also

Hotspot Members | dotnetCHARTING Namespace


Hotspot Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Hotspot Class Members

Hotspot overview

Public Constructors

Public Constructor Hotspot Constructor Creates an instance of the HotSpot object.

Public Properties

Public Property Attributes | Gets the HtmlAttributes of this Hotspot.
Public Property ToolTip | Gets or sets the tool tip text shown when mouse pointer is over the object this Hotspot represents.
Public Property URL | Gets or sets the URL redirected to when the object this Hotspot represents is clicked.
Public Property URLTarget | Gets or sets the URL target of the URL property.

See Also

Hotspot Class | dotnetCHARTING Namespace


Hotspot Class | Hotspot Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hotspot Constructor

Creates an instance of the HotSpot object.

[Visual Basic]
Public Function New()
[C#]
public Hotspot();

See Also

Hotspot Class | Hotspot Members


Hotspot Class Properties

Hotspot Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Hotspot Class Members

For a list of all members of this type, see Hotspot members.

Public Properties

Public Property Attributes | Gets the HtmlAttributes of this Hotspot.
Public Property ToolTip | Gets or sets the tool tip text shown when mouse pointer is over the object this Hotspot represents.
Public Property URL | Gets or sets the URL redirected to when the object this Hotspot represents is clicked.
Public Property URLTarget | Gets or sets the URL target of the URL property.

See Also

Hotspot Class | dotnetCHARTING Namespace


Hotspot Class | Hotspot Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Attributes Property

Gets the HtmlAttributes of this Hotspot.

[Visual Basic]
Public Property Attributes As Hotspot.HtmlAttributes
[C#]
public Hotspot.HtmlAttributes Attributes {get; set;}

See Also

Hotspot Class | Hotspot Members


Hotspot Class | Hotspot Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ToolTip Property

Gets or sets the tool tip text shown when mouse pointer is over the object this Hotspot represents.

[Visual Basic]
Public Property ToolTip As String
[C#]
public string ToolTip {get; set;}

See Also

Hotspot Class | Hotspot Members


Hotspot Class | Hotspot Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URL Property

Gets or sets the URL redirected to when the object this Hotspot represents is clicked.

[Visual Basic]
Public Property URL As String
[C#]
public string URL {get; set;}

See Also

Hotspot Class | Hotspot Members


Hotspot Class | Hotspot Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URLTarget Property

Gets or sets the URL target of the URL property.

[Visual Basic]
Public Property URLTarget As String
[C#]
public string URLTarget {get; set;}

See Also

Hotspot Class | Hotspot Members


Hotspot.HtmlAttribute Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hotspot.HtmlAttribute Class

Encapsulates a number of pre-defined javascript actions and their values.

For a list of all members of this type, see Hotspot.HtmlAttribute members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.Hotspot.HtmlAttribute

Syntax

[Visual Basic]
Public Class Hotspot.HtmlAttribute
[C#]
public class Hotspot.HtmlAttribute

See Also

Hotspot.HtmlAttribute Members | dotnetCHARTING Namespace


Hotspot.HtmlAttribute Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Hotspot.HtmlAttribute Class Members

Hotspot.HtmlAttribute overview

Public Constructors

Public Constructor Hotspot.HtmlAttribute Constructor

Public Properties

Public Property Alert | Gets or sets the text of a javascript alert pop-up.
Public Property Redirect | Gets or sets the url the browser redirects to.
Public Property RedirectFrame | Gets or sets the url the current frame redirects to.
Public Property StatusBarMessage | Gets or sets the status bar text message of the browser window.

See Also

Hotspot.HtmlAttribute Class | dotnetCHARTING Namespace


Hotspot.HtmlAttribute Class | Hotspot.HtmlAttribute Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hotspot.HtmlAttribute Constructor

[Visual Basic]
Public Function New()
[C#]
public Hotspot.HtmlAttribute();

See Also

Hotspot.HtmlAttribute Class | Hotspot.HtmlAttribute Members


Hotspot.HtmlAttribute Class Properties

Hotspot.HtmlAttribute Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Hotspot.HtmlAttribute Class Members

For a list of all members of this type, see Hotspot.HtmlAttribute members.

Public Properties

Public Property Alert | Gets or sets the text of a javascript alert pop-up.
Public Property Redirect | Gets or sets the url the browser redirects to.
Public Property RedirectFrame | Gets or sets the url the current frame redirects to.
Public Property StatusBarMessage | Gets or sets the status bar text message of the browser window.

See Also

Hotspot.HtmlAttribute Class | dotnetCHARTING Namespace


Hotspot.HtmlAttribute Class | Hotspot.HtmlAttribute Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Alert Property

Gets or sets the text of a javascript alert pop-up.

[Visual Basic]
Public Property Alert As String
[C#]
public string Alert {get; set;}

See Also

Hotspot.HtmlAttribute Class | Hotspot.HtmlAttribute Members


Hotspot.HtmlAttribute Class | Hotspot.HtmlAttribute Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Redirect Property

Gets or sets the url the browser redirects to.

[Visual Basic]
Public Property Redirect As String
[C#]
public string Redirect {get; set;}

See Also

Hotspot.HtmlAttribute Class | Hotspot.HtmlAttribute Members


Hotspot.HtmlAttribute Class | Hotspot.HtmlAttribute Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RedirectFrame Property

Gets or sets the url the current frame redirects to.

[Visual Basic]
Public Property RedirectFrame As String
[C#]
public string RedirectFrame {get; set;}

See Also

Hotspot.HtmlAttribute Class | Hotspot.HtmlAttribute Members


Hotspot.HtmlAttribute Class | Hotspot.HtmlAttribute Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StatusBarMessage Property

Gets or sets the status bar text message of the browser window.

[Visual Basic]
Public Property StatusBarMessage As String
[C#]
public string StatusBarMessage {get; set;}

See Also

Hotspot.HtmlAttribute Class | Hotspot.HtmlAttribute Members


Hotspot.HtmlAttributes Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hotspot.HtmlAttributes Class

Encapsulates a set of html event attributes and their values.

For a list of all members of this type, see Hotspot.HtmlAttributes members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.Hotspot.HtmlAttributes

Syntax

[Visual Basic]
Public Class Hotspot.HtmlAttributes
[C#]
public class Hotspot.HtmlAttributes

See Also

Hotspot.HtmlAttributes Members | dotnetCHARTING Namespace


Hotspot.HtmlAttributes Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Hotspot.HtmlAttributes Class Members

Hotspot.HtmlAttributes overview

Public Constructors

Public Constructor Hotspot.HtmlAttributes Constructor

Public Properties

Public Property Custom | Gets or sets a ListCollection of custom html attributes.
Public Property OnClick | Gets or sets the html OnClick attribute.
Public Property OnDoubleClick | Gets or sets the html OnDoubleClick attribute.
Public Property OnMouseOver | Gets or sets the html OnMouseOver attribute.

See Also

Hotspot.HtmlAttributes Class | dotnetCHARTING Namespace


Hotspot.HtmlAttributes Class | Hotspot.HtmlAttributes Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hotspot.HtmlAttributes Constructor

[Visual Basic]
Public Function New()
[C#]
public Hotspot.HtmlAttributes();

See Also

Hotspot.HtmlAttributes Class | Hotspot.HtmlAttributes Members


Hotspot.HtmlAttributes Class Properties

Hotspot.HtmlAttributes Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Hotspot.HtmlAttributes Class Members

For a list of all members of this type, see Hotspot.HtmlAttributes members.

Public Properties

Public Property Custom | Gets or sets a ListCollection of custom html attributes.
Public Property OnClick | Gets or sets the html OnClick attribute.
Public Property OnDoubleClick | Gets or sets the html OnDoubleClick attribute.
Public Property OnMouseOver | Gets or sets the html OnMouseOver attribute.

See Also

Hotspot.HtmlAttributes Class | dotnetCHARTING Namespace


Hotspot.HtmlAttributes Class | Hotspot.HtmlAttributes Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Custom Property

Gets or sets a ListCollection of custom html attributes.

[Visual Basic]
Public Property Custom As ListCollection
[C#]
public ListCollection Custom {get; set;}

See Also

Hotspot.HtmlAttributes Class | Hotspot.HtmlAttributes Members


Hotspot.HtmlAttributes Class | Hotspot.HtmlAttributes Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

OnClick Property

Gets or sets the html OnClick attribute.

[Visual Basic]
Public Property OnClick As Hotspot.HtmlAttribute
[C#]
public Hotspot.HtmlAttribute OnClick {get; set;}

See Also

Hotspot.HtmlAttributes Class | Hotspot.HtmlAttributes Members


Hotspot.HtmlAttributes Class | Hotspot.HtmlAttributes Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

OnDoubleClick Property

Gets or sets the html OnDoubleClick attribute.

[Visual Basic]
Public Property OnDoubleClick As Hotspot.HtmlAttribute
[C#]
public Hotspot.HtmlAttribute OnDoubleClick {get; set;}

See Also

Hotspot.HtmlAttributes Class | Hotspot.HtmlAttributes Members


Hotspot.HtmlAttributes Class | Hotspot.HtmlAttributes Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

OnMouseOver Property

Gets or sets the html OnMouseOver attribute.

[Visual Basic]
Public Property OnMouseOver As Hotspot.HtmlAttribute
[C#]
public Hotspot.HtmlAttribute OnMouseOver {get; set;}

See Also

Hotspot.HtmlAttributes Class | Hotspot.HtmlAttributes Members


HotspotCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HotspotCollection Class

Contains a collection of Hotspot objects.

For a list of all members of this type, see HotspotCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.HotspotCollection

Syntax

[Visual Basic]
Public Class HotspotCollection
   Inherits CollectionBase
[C#]
public class HotspotCollection : CollectionBase

See Also

HotspotCollection Members | dotnetCHARTING Namespace


HotspotCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

HotspotCollection Class Members

HotspotCollection overview

Public Constructors

Public Constructor HotspotCollection Constructor Creates a new instance of HotspotCollection with the specified list of Hotspot objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Hotspot.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines index of a specified Hotspot in this collection.
Public Method Insert | Inserts a Hotspot into this collection at a specified index.
Public Method Remove | Removes a specified Hotspot from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

HotspotCollection Class | dotnetCHARTING Namespace


HotspotCollection Constructor

HotspotCollection Class | HotspotCollection Members

Language

Visual Basic

C#

Show All

hotspotList
See Also Languages dotnetCHARTING Send comments on this topic.

HotspotCollection Constructor

Creates a new instance of HotspotCollection with the specified list of Hotspot objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray hotspotList() As Hotspot _
)
[C#]
public HotspotCollection(
   params Hotspot[] hotspotList
);

Parameters

hotspotList

See Also

HotspotCollection Class | HotspotCollection Members


HotspotCollection Class Methods

HotspotCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

HotspotCollection Class Members

For a list of all members of this type, see HotspotCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Hotspot.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines index of a specified Hotspot in this collection.
Public Method Insert | Inserts a Hotspot into this collection at a specified index.
Public Method Remove | Removes a specified Hotspot from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

HotspotCollection Class | dotnetCHARTING Namespace


HotspotCollection Class | HotspotCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

[Visual Basic] Overloads Public Function Add(Hotspot) As Integer

[C#] public int Add(Hotspot);

Adds the specified Hotspot objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray Hotspot())

[C#] public void Add(params Hotspot[]);

Adds a specified HotspotCollection to this collection.

[Visual Basic] Overloads Public Sub Add(HotspotCollection)

[C#] public void Add(HotspotCollection);

See Also

HotspotCollection Class | HotspotCollection Members


Add(Hotspot) Method

HotspotCollection Class | HotspotCollection Members | Overload List

Language

Visual Basic

C#

Show All

hotspot
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Hotspot) Method

[Visual Basic]
Overloads Public Function Add( _
   ByVal hotspot As Hotspot _
) As Integer
[C#]
public int Add(
   Hotspot hotspot
);

Parameters

hotspot

See Also

HotspotCollection Class | HotspotCollection Members | Overload List


Add(Hotspot[]) Method

HotspotCollection Class | HotspotCollection Members | Overload List

Language

Visual Basic

C#

Show All

hotspotList
A list of Hotspot objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Hotspot[]) Method

Adds the specified Hotspot objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray hotspotList() As Hotspot _
)
[C#]
public void Add(
   params Hotspot[] hotspotList
);

Parameters

hotspotList
A list of Hotspot objects to add.

See Also

HotspotCollection Class | HotspotCollection Members | Overload List


Add(HotspotCollection) Method

HotspotCollection Class | HotspotCollection Members | Overload List

Language

Visual Basic

C#

Show All

hotspotCollection
The HotspotCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(HotspotCollection) Method

Adds a specified HotspotCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal hotspotCollection As HotspotCollection _
)
[C#]
public void Add(
   HotspotCollection hotspotCollection
);

Parameters

hotspotCollection
The HotspotCollection to add.

See Also

HotspotCollection Class | HotspotCollection Members | Overload List


Contains Method

HotspotCollection Class | HotspotCollection Members

Language

Visual Basic

C#

Show All

hotspot
The Hotspot to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified Hotspot.

[Visual Basic]
Public Function Contains( _
   ByVal hotspot As Hotspot _
) As Boolean
[C#]
public bool Contains(
   Hotspot hotspot
);

Parameters

hotspot
The Hotspot to find.

Return Type

true if the specified Hotspot belongs to this collection; otherwise, false.

See Also

HotspotCollection Class | HotspotCollection Members


IndexOf Method

HotspotCollection Class | HotspotCollection Members

Language

Visual Basic

C#

Show All

hotspot
The Hotspot to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines index of a specified Hotspot in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal hotspot As Hotspot _
) As Integer
[C#]
public int IndexOf(
   Hotspot hotspot
);

Parameters

hotspot
The Hotspot to find.

Return Type

The zero-based index of the specified Hotspot.

See Also

HotspotCollection Class | HotspotCollection Members


Insert Method

HotspotCollection Class | HotspotCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the Hotspot.
hotspot
The Hotspot to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a Hotspot into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal hotspot As Hotspot _
)
[C#]
public void Insert(
   int index,
   Hotspot hotspot
);

Parameters

index
The zero-based index into the collection at which to insert the Hotspot.
hotspot
The Hotspot to insert into this collection.

See Also

HotspotCollection Class | HotspotCollection Members


Remove Method

HotspotCollection Class | HotspotCollection Members

Language

Visual Basic

C#

Show All

hotspot
The Hotspot to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified Hotspot from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal hotspot As Hotspot _
)
[C#]
public void Remove(
   Hotspot hotspot
);

Parameters

hotspot
The Hotspot to remove.

See Also

HotspotCollection Class | HotspotCollection Members


HotspotCollection Class Properties

HotspotCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

HotspotCollection Class Members

For a list of all members of this type, see HotspotCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

HotspotCollection Class | dotnetCHARTING Namespace


Item Property

HotspotCollection Class | HotspotCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Hotspot
[C#]
public Hotspot this[
   int index
]; {get; set;}

Parameters

index

See Also

HotspotCollection Class | HotspotCollection Members


Label Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Label Class

Represents a label consisting of text, a font, and a color.

For a list of all members of this type, see Label members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.Label
dotnetCHARTING.SmartLabel

Syntax

[Visual Basic]
Public Class Label
[C#]
public class Label

See Also

Label Members | dotnetCHARTING Namespace


Label Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Label Class Members

Label overview

Public Constructors

Public Constructor Label Constructor Overloaded.

Public Properties

Public Property Alignment | Gets or sets the alignment of this label.
Public Property Color | Gets or sets the color of this label.
Public Property Font | Gets or sets the font for this label.
Public Property LineAlignment | Gets or sets the line alignment of this label.
Public Property Text | Gets or sets the text for this label.
Public Property Truncation | Gets or sets properties used to dynamically shorten this label when it reaches a maximum length.

Public Methods

Public Method Dispose

See Also

Label Class | dotnetCHARTING Namespace


Label Class | Label Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Label Constructor

Overload List

Initializes a new instance of the Label class.

[Visual Basic] Public Sub New()

[C#] public Label();

Initializes a new instance of the Label class with a font.

[Visual Basic] Public Sub New(Font)

[C#] public Label(Font);

Initializes a new instance of the Label class with text.

[Visual Basic] Public Sub New(String)

[C#] public Label(string);

Initializes a new instance of the Label class with text, and a font.

[Visual Basic] Public Sub New(String,Font)

[C#] public Label(string,Font);

Initializes a new instance of the Label class with text, font, and a color.

[Visual Basic] Public Sub New(String,Font,Color)

[C#] public Label(string,Font,Color);

See Also

Label Class | Label Members


Label Class | Label Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Label Constructor()

Initializes a new instance of the Label class.

[Visual Basic]
Public Function New()
[C#]
public Label();

See Also

Label Class | Label Members | Overload List


Label Constructor(Font)

Label Class | Label Members | Overload List

Language

Visual Basic

C#

Show All

font
Font of this label.
See Also Languages dotnetCHARTING Send comments on this topic.

Label Constructor(Font)

Initializes a new instance of the Label class with a font.

[Visual Basic]
Public Function New( _
   ByVal font As Font _
)
[C#]
public Label(
   Font font
);

Parameters

font
Font of this label.

See Also

Label Class | Label Members | Overload List


Label Constructor(String)

Label Class | Label Members | Overload List

Language

Visual Basic

C#

Show All

text
Text of this label.
See Also Languages dotnetCHARTING Send comments on this topic.

Label Constructor(String)

Initializes a new instance of the Label class with text.

[Visual Basic]
Public Function New( _
   ByVal text As String _
)
[C#]
public Label(
   string text
);

Parameters

text
Text of this label.

See Also

Label Class | Label Members | Overload List


Label Constructor(String,Font)

Label Class | Label Members | Overload List

Language

Visual Basic

C#

Show All

text
Text of this label.
font
Font of this label.
See Also Languages dotnetCHARTING Send comments on this topic.

Label Constructor(String,Font)

Initializes a new instance of the Label class with text, and a font.

[Visual Basic]
Public Function New( _
   ByVal text As String, _
   ByVal font As Font _
)
[C#]
public Label(
   string text,
   Font font
);

Parameters

text
Text of this label.
font
Font of this label.

See Also

Label Class | Label Members | Overload List


Label Constructor(String,Font,Color)

Label Class | Label Members | Overload List

Language

Visual Basic

C#

Show All

text
Text of this label.
font
Font of this label.
color
Color of this label.
See Also Languages dotnetCHARTING Send comments on this topic.

Label Constructor(String,Font,Color)

Initializes a new instance of the Label class with text, font, and a color.

[Visual Basic]
Public Function New( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal color As Color _
)
[C#]
public Label(
   string text,
   Font font,
   Color color
);

Parameters

text
Text of this label.
font
Font of this label.
color
Color of this label.

See Also

Label Class | Label Members | Overload List


Label Class Methods

Label Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Label Class Members

For a list of all members of this type, see Label members.

Public Methods

Public Method Dispose

See Also

Label Class | dotnetCHARTING Namespace


Label Class | Label Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Dispose Method

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();

See Also

Label Class | Label Members


Label Class Properties

Label Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Label Class Members

For a list of all members of this type, see Label members.

Public Properties

Public Property Alignment | Gets or sets the alignment of this label.
Public Property Color | Gets or sets the color of this label.
Public Property Font | Gets or sets the font for this label.
Public Property LineAlignment | Gets or sets the line alignment of this label.
Public Property Text | Gets or sets the text for this label.
Public Property Truncation | Gets or sets properties used to dynamically shorten this label when it reaches a maximum length.

See Also

Label Class | dotnetCHARTING Namespace


Label Class | Label Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Alignment Property

Gets or sets the alignment of this label.

[Visual Basic]
Public Property Alignment As StringAlignment
[C#]
public StringAlignment Alignment {get; set;}

See Also

Label Class | Label Members


Label Class | Label Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Color Property

Gets or sets the color of this label.

[Visual Basic]
Public Property Color As Color
[C#]
public Color Color {get; set;}

See Also

Label Class | Label Members


Label Class | Label Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Font Property

Gets or sets the font for this label.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}

See Also

Label Class | Label Members


Label Class | Label Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LineAlignment Property

Gets or sets the line alignment of this label.

[Visual Basic]
Public Property LineAlignment As StringAlignment
[C#]
public StringAlignment LineAlignment {get; set;}

See Also

Label Class | Label Members


Label Class | Label Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Text Property

Gets or sets the text for this label.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

Label Class | Label Members


Label Class | Label Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Truncation Property

Gets or sets properties used to dynamically shorten this label when it reaches a maximum length.

[Visual Basic]
Public Property Truncation As Truncation
[C#]
public Truncation Truncation {get; set;}

See Also

Label Class | Label Members


LabelAlignmentCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelAlignmentCollection Class

Contains a collection of LabelAlignment objects.

For a list of all members of this type, see LabelAlignmentCollection members.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.LabelAlignmentCollection

Syntax

[Visual Basic]
Public Class LabelAlignmentCollection
   Inherits CollectionBase
[C#]
public class LabelAlignmentCollection : CollectionBase

See Also

LabelAlignmentCollection Members | dotnetCHARTING Namespace


LabelAlignmentCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LabelAlignmentCollection Class Members

LabelAlignmentCollection overview

Public Constructors

Public Constructor LabelAlignmentCollection Constructor

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Adds a specified LabelAlignment enumeration to this collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified LabelAlignment.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method Insert | Inserts a LabelAlignment enumeration into this collection at a specified index.
Public Method Remove | Removes a specified label alignment from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

LabelAlignmentCollection Class | dotnetCHARTING Namespace


LabelAlignmentCollection Class | LabelAlignmentCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelAlignmentCollection Constructor

[Visual Basic]
Public Function New()
[C#]
public LabelAlignmentCollection();

See Also

LabelAlignmentCollection Class | LabelAlignmentCollection Members


LabelAlignmentCollection Class Methods

LabelAlignmentCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LabelAlignmentCollection Class Members

For a list of all members of this type, see LabelAlignmentCollection members.

Public Methods

Public Method Add | Adds a specified LabelAlignment enumeration to this collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified LabelAlignment.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method Insert | Inserts a LabelAlignment enumeration into this collection at a specified index.
Public Method Remove | Removes a specified label alignment from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

LabelAlignmentCollection Class | dotnetCHARTING Namespace


Add Method

LabelAlignmentCollection Class | LabelAlignmentCollection Members

Language

Visual Basic

C#

Show All

_LabelAlignment
The LabelAlignment to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Adds a specified LabelAlignment enumeration to this collection.

[Visual Basic]
Public Function Add( _
   ByVal _LabelAlignment As LabelAlignment _
) As Integer
[C#]
public int Add(
   LabelAlignment _LabelAlignment
);

Parameters

_LabelAlignment
The LabelAlignment to add.

Return Type

The zero-based index of the added LabelAlignment.

See Also

LabelAlignmentCollection Class | LabelAlignmentCollection Members


Contains Method

LabelAlignmentCollection Class | LabelAlignmentCollection Members

Language

Visual Basic

C#

Show All

_LabelAlignment
The LabelAlignment to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified LabelAlignment.

[Visual Basic]
Public Function Contains( _
   ByVal _LabelAlignment As LabelAlignment _
) As Boolean
[C#]
public bool Contains(
   LabelAlignment _LabelAlignment
);

Parameters

_LabelAlignment
The LabelAlignment to find.

Return Type

true if the specified LabelAlignment belongs to this collection; otherwise, false.

See Also

LabelAlignmentCollection Class | LabelAlignmentCollection Members


Insert Method

LabelAlignmentCollection Class | LabelAlignmentCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the label alignment.
_LabelAlignment
The label alignment to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a LabelAlignment enumeration into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal _LabelAlignment As LabelAlignment _
)
[C#]
public void Insert(
   int index,
   LabelAlignment _LabelAlignment
);

Parameters

index
The zero-based index into the collection at which to insert the label alignment.
_LabelAlignment
The label alignment to insert into this collection.

See Also

LabelAlignmentCollection Class | LabelAlignmentCollection Members


Remove Method

LabelAlignmentCollection Class | LabelAlignmentCollection Members

Language

Visual Basic

C#

Show All

_LabelAlignment
The label alignment to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified label alignment from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal _LabelAlignment As LabelAlignment _
)
[C#]
public void Remove(
   LabelAlignment _LabelAlignment
);

Parameters

_LabelAlignment
The label alignment to remove.

See Also

LabelAlignmentCollection Class | LabelAlignmentCollection Members


LabelAlignmentCollection Class Properties

LabelAlignmentCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LabelAlignmentCollection Class Members

For a list of all members of this type, see LabelAlignmentCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

LabelAlignmentCollection Class | dotnetCHARTING Namespace


Item Property

LabelAlignmentCollection Class | LabelAlignmentCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As LabelAlignment
[C#]
public LabelAlignment this[
   int index
]; {get; set;}

Parameters

index

See Also

LabelAlignmentCollection Class | LabelAlignmentCollection Members


LabelOverrideCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelOverrideCollection Class

Contains a collection of LabelOverride objects.

For a list of all members of this type, see LabelOverrideCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.LabelOverrideCollection

Syntax

[Visual Basic]
Public Class LabelOverrideCollection
   Inherits CollectionBase
[C#]
public class LabelOverrideCollection : CollectionBase

See Also

LabelOverrideCollection Members | dotnetCHARTING Namespace


LabelOverrideCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LabelOverrideCollection Class Members

LabelOverrideCollection overview

Public Constructors

Public Constructor LabelOverrideCollection Constructor

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Adds a specified LabelOverride class to this collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified LabelOverride.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method Insert | Inserts a label override into this collection at a specified index.
Public Method Remove | Removes a specified label override from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

LabelOverrideCollection Class | dotnetCHARTING Namespace


LabelOverrideCollection Class | LabelOverrideCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelOverrideCollection Constructor

[Visual Basic]
Public Function New()
[C#]
public LabelOverrideCollection();

See Also

LabelOverrideCollection Class | LabelOverrideCollection Members


LabelOverrideCollection Class Methods

LabelOverrideCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LabelOverrideCollection Class Members

For a list of all members of this type, see LabelOverrideCollection members.

Public Methods

Public Method Add | Adds a specified LabelOverride class to this collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified LabelOverride.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method Insert | Inserts a label override into this collection at a specified index.
Public Method Remove | Removes a specified label override from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

LabelOverrideCollection Class | dotnetCHARTING Namespace


Add Method

LabelOverrideCollection Class | LabelOverrideCollection Members

Language

Visual Basic

C#

Show All

labelOverride
The LabelOverride to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Adds a specified LabelOverride class to this collection.

[Visual Basic]
Public Function Add( _
   ByVal labelOverride As LabelOverride _
) As Integer
[C#]
public int Add(
   LabelOverride labelOverride
);

Parameters

labelOverride
The LabelOverride to add.

Return Type

The zero-based index of the added LabelOverride.

See Also

LabelOverrideCollection Class | LabelOverrideCollection Members


Contains Method

LabelOverrideCollection Class | LabelOverrideCollection Members

Language

Visual Basic

C#

Show All

labelOverride
The LabelOverride to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified LabelOverride.

[Visual Basic]
Public Function Contains( _
   ByVal labelOverride As LabelOverride _
) As Boolean
[C#]
public bool Contains(
   LabelOverride labelOverride
);

Parameters

labelOverride
The LabelOverride to find.

Return Type

true if the specified LabelOverride belongs to this collection; otherwise, false.

See Also

LabelOverrideCollection Class | LabelOverrideCollection Members


Insert Method

LabelOverrideCollection Class | LabelOverrideCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the label override.
labelOverride
The label override to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a label override into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal labelOverride As LabelOverride _
)
[C#]
public void Insert(
   int index,
   LabelOverride labelOverride
);

Parameters

index
The zero-based index into the collection at which to insert the label override.
labelOverride
The label override to insert into this collection.

See Also

LabelOverrideCollection Class | LabelOverrideCollection Members


Remove Method

LabelOverrideCollection Class | LabelOverrideCollection Members

Language

Visual Basic

C#

Show All

labelOverride
The label override marker to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified label override from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal labelOverride As LabelOverride _
)
[C#]
public void Remove(
   LabelOverride labelOverride
);

Parameters

labelOverride
The label override marker to remove.

See Also

LabelOverrideCollection Class | LabelOverrideCollection Members


LabelOverrideCollection Class Properties

LabelOverrideCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LabelOverrideCollection Class Members

For a list of all members of this type, see LabelOverrideCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

LabelOverrideCollection Class | dotnetCHARTING Namespace


Item Property

LabelOverrideCollection Class | LabelOverrideCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As LabelOverride
[C#]
public LabelOverride this[
   int index
]; {get; set;}

Parameters

index

See Also

LabelOverrideCollection Class | LabelOverrideCollection Members


LegendBox Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendBox Class

Encapsulates a collection of LegendEntry objects.

For a list of all members of this type, see LegendBox members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.Box
dotnetCHARTING.LegendBox

Syntax

[Visual Basic]
Public Class LegendBox
   Inherits Box
[C#]
public class LegendBox : Box

Remarks

The legend box has many options such as positioning, source of entries and more. See legend box tutorial for more info.

See Also

LegendBox Members | dotnetCHARTING Namespace


LegendBox Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LegendBox Class Members

LegendBox overview

Public Constructors

Public Constructor LegendBox Constructor Initializes a new instance of the LegendBox class.

Public Properties

Public Property Background (Inherited from Box) | Gets or sets a background object used to fill the interior of this box.
Public Property CornerBottomLeft (Inherited from Box) | Gets or sets the bottom left corner style.
Public Property CornerBottomRight (Inherited from Box) | Gets or sets the bottom right corner style.
Public Property CornerTopLeft (Inherited from Box) | Gets or sets the top left corner style.
Public Property CornerTopRight (Inherited from Box) | Gets or sets the top right corner style.
Public Property DataSource | Source of objects to populate the legend with.
Public Property DefaultCorner (Inherited from Box) | Gets or sets the default box corner style.
Public Property DefaultEntry | Gets or sets a LegendEntry that behaves as a vehicle for property settings that will propagate to all entries in this LegendBox.
Public Property ExtraEntries | Gets a collection of additional LegendEntry objects that are added to this LegendBox.
Public Property HeaderEntry | Gets or sets a LegendEntry that is used as a header of this LegendBox.
Public Property IconPath (Inherited from Box) | Gets or sets the icon path of this title box.
Public Property InteriorLine (Inherited from Box) | Gets or sets the interior line of this legend box.
Public Property Label | Obsolete, please use LegendBox.LabelStyle instead.
Public Property LabelStyle | Gets or sets a Label object that encapsulates default label style properties applied to legend entries drawn in this LegendBox.
Public Property Line (Inherited from Box) | Gets or sets the exterior line of this box.
Public Property ListTopToBottom | Gets or sets a value that indicates whether legend entries are listed top to bottom in multi-column legend boxes.
Public Property Orientation (Inherited from Box) | Gets or sets this object's orientation around a ChartArea.
Public Property Padding (Inherited from Box) | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls.
Public Property Position (Inherited from Box) | Gets or sets the position of this box.
Public Property Shadow (Inherited from Box) | Gets or sets the Shadow cast under this box.
Public Property Template | Gets or sets the legend entry column layout of this legend box.
Public Property Visible (Inherited from Box) | Gets or sets a value that indicates whether this box is visible.

Public Methods

Public Method ClearColors (Inherited from Box) | Serves as a shortcut to make this box invisible.
Public Method GetCoordinates (Inherited from Box) | Gets the coordinates of this box after the chart is rendered.
Public Method GetRectangle (Inherited from Box) | Gets a Rectangle object indicating this boxes position and size after the chart is rendered.

See Also

LegendBox Class | dotnetCHARTING Namespace


LegendBox Class | LegendBox Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendBox Constructor

Initializes a new instance of the LegendBox class.

[Visual Basic]
Public Function New()
[C#]
public LegendBox();

See Also

LegendBox Class | LegendBox Members


LegendBox Class Properties

LegendBox Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LegendBox Class Members

For a list of all members of this type, see LegendBox members.

Public Properties

Public Property Background (Inherited from Box) | Gets or sets a background object used to fill the interior of this box.
Public Property CornerBottomLeft (Inherited from Box) | Gets or sets the bottom left corner style.
Public Property CornerBottomRight (Inherited from Box) | Gets or sets the bottom right corner style.
Public Property CornerTopLeft (Inherited from Box) | Gets or sets the top left corner style.
Public Property CornerTopRight (Inherited from Box) | Gets or sets the top right corner style.
Public Property DataSource | Source of objects to populate the legend with.
Public Property DefaultCorner (Inherited from Box) | Gets or sets the default box corner style.
Public Property DefaultEntry | Gets or sets a LegendEntry that behaves as a vehicle for property settings that will propagate to all entries in this LegendBox.
Public Property ExtraEntries | Gets a collection of additional LegendEntry objects that are added to this LegendBox.
Public Property HeaderEntry | Gets or sets a LegendEntry that is used as a header of this LegendBox.
Public Property IconPath (Inherited from Box) | Gets or sets the icon path of this title box.
Public Property InteriorLine (Inherited from Box) | Gets or sets the interior line of this legend box.
Public Property Label | Obsolete, please use LegendBox.LabelStyle instead.
Public Property LabelStyle | Gets or sets a Label object that encapsulates default label style properties applied to legend entries drawn in this LegendBox.
Public Property Line (Inherited from Box) | Gets or sets the exterior line of this box.
Public Property ListTopToBottom | Gets or sets a value that indicates whether legend entries are listed top to bottom in multi-column legend boxes.
Public Property Orientation (Inherited from Box) | Gets or sets this object's orientation around a ChartArea.
Public Property Padding (Inherited from Box) | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls.
Public Property Position (Inherited from Box) | Gets or sets the position of this box.
Public Property Shadow (Inherited from Box) | Gets or sets the Shadow cast under this box.
Public Property Template | Gets or sets the legend entry column layout of this legend box.
Public Property Visible (Inherited from Box) | Gets or sets a value that indicates whether this box is visible.

See Also

LegendBox Class | dotnetCHARTING Namespace


LegendBox Class | LegendBox Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataSource Property

Source of objects to populate the legend with.

[Visual Basic]
Public Property DataSource As DataSource
[C#]
public DataSource DataSource {get; set;}

Remarks

This DataSource is used with custom legend boxes added to Chart.ExtraLegendBoxes.

See Also

LegendBox Class | LegendBox Members


LegendBox Class | LegendBox Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultEntry Property

Gets or sets a LegendEntry that behaves as a vehicle for property settings that will propagate to all entries in this LegendBox.

[Visual Basic]
Public Property DefaultEntry As LegendEntry
[C#]
public LegendEntry DefaultEntry {get; set;}

Remarks

The property settings of this object will not overwrite properties explicitly set for any given LegendEntry.

See Also

LegendBox Class | LegendBox Members


LegendBox Class | LegendBox Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ExtraEntries Property

Gets a collection of additional LegendEntry objects that are added to this LegendBox.

[Visual Basic]
Public ReadOnly Property ExtraEntries As LegendEntryCollection
[C#]
public LegendEntryCollection ExtraEntries {get;}

See Also

LegendBox Class | LegendBox Members


LegendBox Class | LegendBox Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HeaderEntry Property

Gets or sets a LegendEntry that is used as a header of this LegendBox.

[Visual Basic]
Public Property HeaderEntry As LegendEntry
[C#]
public LegendEntry HeaderEntry {get; set;}

Remarks

This entry is not visible by default. To use it, set HeaderEntry.Visible = true. By default this object has different style settings that accentuate the fact that it is a header. Additional headers can be added to the ExtraEntries collection.

See Also

LegendBox Class | LegendBox Members


LegendBox Class | LegendBox Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Label Property

Obsolete, please use LegendBox.LabelStyle instead.

[Visual Basic]
Public Property Label As Label
[C#]
public Label Label {get; set;}

See Also

LegendBox Class | LegendBox Members


LegendBox Class | LegendBox Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelStyle Property

Gets or sets a Label object that encapsulates default label style properties applied to legend entries drawn in this LegendBox.

[Visual Basic]
Public Property LabelStyle As Label
[C#]
public Label LabelStyle {get; set;}

Remarks

This property is the equivalent of LegendBox.DefaultEntry.LabelStyle.

See Also

LegendBox Class | LegendBox Members


LegendBox Class | LegendBox Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ListTopToBottom Property

Gets or sets a value that indicates whether legend entries are listed top to bottom in multi-column legend boxes.

[Visual Basic]
Public Property ListTopToBottom As Boolean
[C#]
public bool ListTopToBottom {get; set;}

Remarks

When false, entries are listed left to right across columns in multi-column legend boxes.

See Also

LegendBox Class | LegendBox Members


LegendBox Class | LegendBox Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Template Property

Gets or sets the legend entry column layout of this legend box.

[Visual Basic]
Public Property Template As String
[C#]
public string Template {get; set;}

Remarks

Three tokens native to the legend box are:

  • %Icon - Draws a LegendEntry object's icon (LegendEntry.Marker).
  • %Name - Writes the legend entry's name (LegendEntry.Name).
  • %Value - Writes the legend entry's value (LegendEntry.Value).

NOTE: Legend entry properties like LegendEntry.Name can contain tokens used with the object the legend entry represents.

Some examples of properly formed templates are:

LegendBox.Template = "%Icon%Name%Value"

LegendBox.Template = "%Name%Icon"

See Also

LegendBox Class | LegendBox Members


LegendBoxCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendBoxCollection Class

Contains a collection of LegendBox objects.

For a list of all members of this type, see LegendBoxCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.LegendBoxCollection

Syntax

[Visual Basic]
Public Class LegendBoxCollection
   Inherits CollectionBase
[C#]
public class LegendBoxCollection : CollectionBase

See Also

LegendBoxCollection Members | dotnetCHARTING Namespace


LegendBoxCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LegendBoxCollection Class Members

LegendBoxCollection overview

Public Constructors

Public Constructor LegendBoxCollection Constructor Creates a new instance of LegendBoxCollection with the specified list of LegendBox objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified LegendBox.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified LegendBox in this collection.
Public Method Insert | Inserts a LegendBox into this collection at a specified index.
Public Method Remove | Removes a specified LegendBox from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

LegendBoxCollection Class | dotnetCHARTING Namespace


LegendBoxCollection Constructor

LegendBoxCollection Class | LegendBoxCollection Members

Language

Visual Basic

C#

Show All

legendBoxList
See Also Languages dotnetCHARTING Send comments on this topic.

LegendBoxCollection Constructor

Creates a new instance of LegendBoxCollection with the specified list of LegendBox objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray legendBoxList() As LegendBox _
)
[C#]
public LegendBoxCollection(
   params LegendBox[] legendBoxList
);

Parameters

legendBoxList

See Also

LegendBoxCollection Class | LegendBoxCollection Members


LegendBoxCollection Class Methods

LegendBoxCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LegendBoxCollection Class Members

For a list of all members of this type, see LegendBoxCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified LegendBox.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified LegendBox in this collection.
Public Method Insert | Inserts a LegendBox into this collection at a specified index.
Public Method Remove | Removes a specified LegendBox from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

LegendBoxCollection Class | dotnetCHARTING Namespace


LegendBoxCollection Class | LegendBoxCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

[Visual Basic] Overloads Public Function Add(LegendBox) As Integer

[C#] public int Add(LegendBox);

Adds the specified LegendBox objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray LegendBox())

[C#] public void Add(params LegendBox[]);

Adds a specified LegendBoxCollection to this collection.

[Visual Basic] Overloads Public Sub Add(LegendBoxCollection)

[C#] public void Add(LegendBoxCollection);

See Also

LegendBoxCollection Class | LegendBoxCollection Members


Add(LegendBox) Method

LegendBoxCollection Class | LegendBoxCollection Members | Overload List

Language

Visual Basic

C#

Show All

legendBox
See Also Languages dotnetCHARTING Send comments on this topic.

Add(LegendBox) Method

[Visual Basic]
Overloads Public Function Add( _
   ByVal legendBox As LegendBox _
) As Integer
[C#]
public int Add(
   LegendBox legendBox
);

Parameters

legendBox

See Also

LegendBoxCollection Class | LegendBoxCollection Members | Overload List


Add(LegendBox[]) Method

LegendBoxCollection Class | LegendBoxCollection Members | Overload List

Language

Visual Basic

C#

Show All

legendBoxList
A list of LegendBox objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(LegendBox[]) Method

Adds the specified LegendBox objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray legendBoxList() As LegendBox _
)
[C#]
public void Add(
   params LegendBox[] legendBoxList
);

Parameters

legendBoxList
A list of LegendBox objects to add.

See Also

LegendBoxCollection Class | LegendBoxCollection Members | Overload List


Add(LegendBoxCollection) Method

LegendBoxCollection Class | LegendBoxCollection Members | Overload List

Language

Visual Basic

C#

Show All

legendBoxCollection
The LegendBoxCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(LegendBoxCollection) Method

Adds a specified LegendBoxCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal legendBoxCollection As LegendBoxCollection _
)
[C#]
public void Add(
   LegendBoxCollection legendBoxCollection
);

Parameters

legendBoxCollection
The LegendBoxCollection to add.

See Also

LegendBoxCollection Class | LegendBoxCollection Members | Overload List


Contains Method

LegendBoxCollection Class | LegendBoxCollection Members

Language

Visual Basic

C#

Show All

legendBox
The LegendBox to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified LegendBox.

[Visual Basic]
Public Function Contains( _
   ByVal legendBox As LegendBox _
) As Boolean
[C#]
public bool Contains(
   LegendBox legendBox
);

Parameters

legendBox
The LegendBox to find.

Return Type

true if the specified LegendBox belongs to this collection; otherwise, false.

See Also

LegendBoxCollection Class | LegendBoxCollection Members


IndexOf Method

LegendBoxCollection Class | LegendBoxCollection Members

Language

Visual Basic

C#

Show All

legendBox
The LegendBox to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines the index of a specified LegendBox in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal legendBox As LegendBox _
) As Integer
[C#]
public int IndexOf(
   LegendBox legendBox
);

Parameters

legendBox
The LegendBox to find.

Return Type

The zero-based index of the specified LegendBox.

See Also

LegendBoxCollection Class | LegendBoxCollection Members


Insert Method

LegendBoxCollection Class | LegendBoxCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the LegendBox.
legendBox
The LegendBox to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a LegendBox into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal legendBox As LegendBox _
)
[C#]
public void Insert(
   int index,
   LegendBox legendBox
);

Parameters

index
The zero-based index into the collection at which to insert the LegendBox.
legendBox
The LegendBox to insert into this collection.

See Also

LegendBoxCollection Class | LegendBoxCollection Members


Remove Method

LegendBoxCollection Class | LegendBoxCollection Members

Language

Visual Basic

C#

Show All

legendBox
The LegendBox to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified LegendBox from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal legendBox As LegendBox _
)
[C#]
public void Remove(
   LegendBox legendBox
);

Parameters

legendBox
The LegendBox to remove.

See Also

LegendBoxCollection Class | LegendBoxCollection Members


LegendBoxCollection Class Properties

LegendBoxCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LegendBoxCollection Class Members

For a list of all members of this type, see LegendBoxCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

LegendBoxCollection Class | dotnetCHARTING Namespace


Item Property

LegendBoxCollection Class | LegendBoxCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As LegendBox
[C#]
public LegendBox this[
   int index
]; {get; set;}

Parameters

index

See Also

LegendBoxCollection Class | LegendBoxCollection Members


LegendEntry Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntry Class

Represents an entry in the legend box.

For a list of all members of this type, see LegendEntry members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.LegendEntry

Syntax

[Visual Basic]
Public Class LegendEntry
[C#]
public class LegendEntry

See Also

LegendEntry Members | dotnetCHARTING Namespace


LegendEntry Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LegendEntry Class Members

LegendEntry overview

Public Constructors

Public Constructor LegendEntry Constructor Overloaded.

Public Properties

Public Property Background | Gets or sets a Background object that influences how the entry's icon is drawn.
Public Property CustomAttributes | Gets or sets a ListCollection that represents additional entry attributes.
Public Property DashStyle | Gets or sets a line DashStyle that influences how the entry's icon is drawn.
Public Property DataSource | Gets or sets a DataSource object used to replace tokens.
Public Property DividerLine | Gets or sets a Line that is drawn under the LegendEntry.
Public Property HeaderMode | Gets or sets an a LegendEntryHeaderMode enumeration that specifies a how this LegendEntry behaves.
Public Property Hotspot | Gets or sets the Hotspot of this LegendEntry.
Public Property LabelStyle | Gets or sets a Label object that defines the font and color of this LegendEntry object's text.
Public Property Marker | Gets or sets an ElementMarker that influences how the entry's icon is drawn.
Public Property Name | Gets or sets the name of this legend entry.
Public Property PaddingTop | Gets or sets a value (in pixels) that specifies additional padding above this LegendEntry object.
Public Property SeriesType | Gets or sets a SeriesType that influences how the entry's icon is drawn.
Public Property SortOrder | Gets or sets a value that represents the sort position of this LegenEntry when sorted with other entries in a LegendBox.
Public Property ToolTip | Gets or sets this legend entry's tool tip.
Public Property URL | Gets or sets the URL of this legend entry.
Public Property URLTarget | Gets or sets the URL target of this legend entry's link.
Public Property Use3D | Gets or sets a value that specifies whether icons represent 2D or 3D series.
Public Property Value | Gets or sets the value of this legend entry.
Public Property Visible | Gets or sets a value which specifies whether the legend entry is visible.

See Also

LegendEntry Class | dotnetCHARTING Namespace


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntry Constructor

Overload List

Initializes a new instance of the LegendEntry class.

[Visual Basic] Public Sub New()

[C#] public LegendEntry();

Initializes a new instance of the LegendEntry class with a Name and Value.

[Visual Basic] Public Sub New(String,String)

[C#] public LegendEntry(string,string);

Initializes a new instance of the LegendEntry class with a Name, Value and icon background.

[Visual Basic] Public Sub New(String,String,Background)

[C#] public LegendEntry(string,string,Background);

Initializes a new instance of the LegendEntry class with a Name, Value and icon color.

[Visual Basic] Public Sub New(String,String,Color)

[C#] public LegendEntry(string,string,Color);

Initializes a new instance of the LegendEntry class with a Name, Value and icon background.

[Visual Basic] Public Sub New(String,String,String)

[C#] public LegendEntry(string,string,string);

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntry Constructor()

Initializes a new instance of the LegendEntry class.

[Visual Basic]
Public Function New()
[C#]
public LegendEntry();

See Also

LegendEntry Class | LegendEntry Members | Overload List


LegendEntry Constructor(String,String)

LegendEntry Class | LegendEntry Members | Overload List

Language

Visual Basic

C#

Show All

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.
See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntry Constructor(String,String)

Initializes a new instance of the LegendEntry class with a Name and Value.

[Visual Basic]
Public Function New( _
   ByVal nameString As String, _
   ByVal valueString As String _
)
[C#]
public LegendEntry(
   string nameString,
   string valueString
);

Parameters

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.

See Also

LegendEntry Class | LegendEntry Members | Overload List


LegendEntry Constructor(String,String,Background)

LegendEntry Class | LegendEntry Members | Overload List

Language

Visual Basic

C#

Show All

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.
iconBackground
Sets the LegendEntry.Background.Color property.
See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntry Constructor(String,String,Background)

Initializes a new instance of the LegendEntry class with a Name, Value and icon background.

[Visual Basic]
Public Function New( _
   ByVal nameString As String, _
   ByVal valueString As String, _
   ByVal iconBackground As Background _
)
[C#]
public LegendEntry(
   string nameString,
   string valueString,
   Background iconBackground
);

Parameters

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.
iconBackground
Sets the LegendEntry.Background.Color property.

See Also

LegendEntry Class | LegendEntry Members | Overload List


LegendEntry Constructor(String,String,Color)

LegendEntry Class | LegendEntry Members | Overload List

Language

Visual Basic

C#

Show All

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.
iconBackgroundColor
Sets the LegendEntry.Background.Color property.
See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntry Constructor(String,String,Color)

Initializes a new instance of the LegendEntry class with a Name, Value and icon color.

[Visual Basic]
Public Function New( _
   ByVal nameString As String, _
   ByVal valueString As String, _
   ByVal iconBackgroundColor As Color _
)
[C#]
public LegendEntry(
   string nameString,
   string valueString,
   Color iconBackgroundColor
);

Parameters

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.
iconBackgroundColor
Sets the LegendEntry.Background.Color property.

See Also

LegendEntry Class | LegendEntry Members | Overload List


LegendEntry Constructor(String,String,String)

LegendEntry Class | LegendEntry Members | Overload List

Language

Visual Basic

C#

Show All

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.
iconString
Sets the string representation of the icon.
See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntry Constructor(String,String,String)

Initializes a new instance of the LegendEntry class with a Name, Value and icon background.

[Visual Basic]
Public Function New( _
   ByVal nameString As String, _
   ByVal valueString As String, _
   ByVal iconString As String _
)
[C#]
public LegendEntry(
   string nameString,
   string valueString,
   string iconString
);

Parameters

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.
iconString
Sets the string representation of the icon.

See Also

LegendEntry Class | LegendEntry Members | Overload List


LegendEntry Class Properties

LegendEntry Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LegendEntry Class Members

For a list of all members of this type, see LegendEntry members.

Public Properties

Public Property Background | Gets or sets a Background object that influences how the entry's icon is drawn.
Public Property CustomAttributes | Gets or sets a ListCollection that represents additional entry attributes.
Public Property DashStyle | Gets or sets a line DashStyle that influences how the entry's icon is drawn.
Public Property DataSource | Gets or sets a DataSource object used to replace tokens.
Public Property DividerLine | Gets or sets a Line that is drawn under the LegendEntry.
Public Property HeaderMode | Gets or sets an a LegendEntryHeaderMode enumeration that specifies a how this LegendEntry behaves.
Public Property Hotspot | Gets or sets the Hotspot of this LegendEntry.
Public Property LabelStyle | Gets or sets a Label object that defines the font and color of this LegendEntry object's text.
Public Property Marker | Gets or sets an ElementMarker that influences how the entry's icon is drawn.
Public Property Name | Gets or sets the name of this legend entry.
Public Property PaddingTop | Gets or sets a value (in pixels) that specifies additional padding above this LegendEntry object.
Public Property SeriesType | Gets or sets a SeriesType that influences how the entry's icon is drawn.
Public Property SortOrder | Gets or sets a value that represents the sort position of this LegenEntry when sorted with other entries in a LegendBox.
Public Property ToolTip | Gets or sets this legend entry's tool tip.
Public Property URL | Gets or sets the URL of this legend entry.
Public Property URLTarget | Gets or sets the URL target of this legend entry's link.
Public Property Use3D | Gets or sets a value that specifies whether icons represent 2D or 3D series.
Public Property Value | Gets or sets the value of this legend entry.
Public Property Visible | Gets or sets a value which specifies whether the legend entry is visible.

See Also

LegendEntry Class | dotnetCHARTING Namespace


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Background Property

Gets or sets a Background object that influences how the entry's icon is drawn.

[Visual Basic]
Public Property Background As Background
[C#]
public Background Background {get; set;}

Remarks

This object is used with the following settings
LegendEntry.SeriesType = SeriesType.Column

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CustomAttributes Property

Gets or sets a ListCollection that represents additional entry attributes.

[Visual Basic]
Public Property CustomAttributes As ListCollection
[C#]
public ListCollection CustomAttributes {get; set;}

Remarks

In addition to name, value, and icon, the legend entry can contain further information such as descriptions or comments. These attributes will appear in a legend box when the LegendBox.Template string contains the custom attribute key prefixed with a '%'.

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DashStyle Property

Gets or sets a line DashStyle that influences how the entry's icon is drawn.

[Visual Basic]
Public Property DashStyle As DashStyle
[C#]
public DashStyle DashStyle {get; set;}

Remarks

This object is used with the following settings
LegendEntry.SeriesType = SeriesType.Marker
LegendEntry.In3D = false

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataSource Property

Gets or sets a DataSource object used to replace tokens.

[Visual Basic]
Public Property DataSource As DataSource
[C#]
public DataSource DataSource {get; set;}

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DividerLine Property

Gets or sets a Line that is drawn under the LegendEntry.

[Visual Basic]
Public Property DividerLine As Line
[C#]
public Line DividerLine {get; set;}

Remarks

This line doesn't appear automatically because it's color (LegendEntry.Line.Color) is Color.Empty. To activate it, specify a color for the line. When active, it will add more space between the this entry and the one below it.

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HeaderMode Property

Gets or sets an a LegendEntryHeaderMode enumeration that specifies a how this LegendEntry behaves.

[Visual Basic]
Public Property HeaderMode As LegendEntryHeaderMode
[C#]
public LegendEntryHeaderMode HeaderMode {get; set;}

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hotspot Property

Gets or sets the Hotspot of this LegendEntry.

[Visual Basic]
Public Property Hotspot As Hotspot
[C#]
public Hotspot Hotspot {get; set;}

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelStyle Property

Gets or sets a Label object that defines the font and color of this LegendEntry object's text.

[Visual Basic]
Public Property LabelStyle As Label
[C#]
public Label LabelStyle {get; set;}

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Marker Property

Gets or sets an ElementMarker that influences how the entry's icon is drawn.

[Visual Basic]
Public Property Marker As ElementMarker
[C#]
public ElementMarker Marker {get; set;}

Remarks

To draw only this marker as the icon, set LegendEntry.SeriesType = SeriesType.Marker.

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Name Property

Gets or sets the name of this legend entry.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Remarks

Tokens may be used to describe the object represented by this legend entry.

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PaddingTop Property

Gets or sets a value (in pixels) that specifies additional padding above this LegendEntry object.

[Visual Basic]
Public Property PaddingTop As Integer
[C#]
public int PaddingTop {get; set;}

Remarks

This property is useful when the LegendEntry is a header and starts a new group of entries. Additional spacing may be required between the groups to accentuate the separation between groups.

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SeriesType Property

Gets or sets a SeriesType that influences how the entry's icon is drawn.

[Visual Basic]
Public Property SeriesType As SeriesType
[C#]
public SeriesType SeriesType {get; set;}

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SortOrder Property

Gets or sets a value that represents the sort position of this LegenEntry when sorted with other entries in a LegendBox.

[Visual Basic]
Public Property SortOrder As Integer
[C#]
public int SortOrder {get; set;}

Remarks

The default sort value of all legend entries is zero (0). To indicate that an entry is first in a legend box, set this property to -1.

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ToolTip Property

Gets or sets this legend entry's tool tip.

[Visual Basic]
Public Property ToolTip As String
[C#]
public string ToolTip {get; set;}

Return Type

A string representing the tool tip of this legend entry.

Remarks

Tokens may be used to describe the object represented by this legend entry.

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URL Property

Gets or sets the URL of this legend entry.

[Visual Basic]
Public Property URL As String
[C#]
public string URL {get; set;}

Return Type

A string representing the url of this legend entry.

Remarks

Tokens may be used to describe the object represented by this legend entry.

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

URLTarget Property

Gets or sets the URL target of this legend entry's link.

[Visual Basic]
Public Property URLTarget As String
[C#]
public string URLTarget {get; set;}

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Use3D Property

Gets or sets a value that specifies whether icons represent 2D or 3D series.

[Visual Basic]
Public Property Use3D As Boolean
[C#]
public bool Use3D {get; set;}

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Value Property

Gets or sets the value of this legend entry.

[Visual Basic]
Public Property Value As String
[C#]
public string Value {get; set;}

Remarks

This string specified in the legend box column Template by the token '%Value'.

See Also

LegendEntry Class | LegendEntry Members


LegendEntry Class | LegendEntry Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Visible Property

Gets or sets a value which specifies whether the legend entry is visible.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

LegendEntry Class | LegendEntry Members


LegendEntryCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntryCollection Class

Contains a collection of LegendEntry objects.

For a list of all members of this type, see LegendEntryCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.LegendEntryCollection

Syntax

[Visual Basic]
Public Class LegendEntryCollection
   Inherits CollectionBase
[C#]
public class LegendEntryCollection : CollectionBase

See Also

LegendEntryCollection Members | dotnetCHARTING Namespace


LegendEntryCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LegendEntryCollection Class Members

LegendEntryCollection overview

Public Constructors

Public Constructor LegendEntryCollection Constructor Creates a new instance of LegendEntryCollection with the specified list of LegendEntry objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified LegendEntry.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified LegendEntry in this collection.
Public Method Insert | Inserts a legend entry into this collection at a specified index.
Public Method Remove | Removes a specified legend entry from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

LegendEntryCollection Class | dotnetCHARTING Namespace


LegendEntryCollection Constructor

LegendEntryCollection Class | LegendEntryCollection Members

Language

Visual Basic

C#

Show All

legendEntryList
See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntryCollection Constructor

Creates a new instance of LegendEntryCollection with the specified list of LegendEntry objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray legendEntryList() As LegendEntry _
)
[C#]
public LegendEntryCollection(
   params LegendEntry[] legendEntryList
);

Parameters

legendEntryList

See Also

LegendEntryCollection Class | LegendEntryCollection Members


LegendEntryCollection Class Methods

LegendEntryCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LegendEntryCollection Class Members

For a list of all members of this type, see LegendEntryCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified LegendEntry.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines the index of a specified LegendEntry in this collection.
Public Method Insert | Inserts a legend entry into this collection at a specified index.
Public Method Remove | Removes a specified legend entry from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

LegendEntryCollection Class | dotnetCHARTING Namespace


LegendEntryCollection Class | LegendEntryCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

Adds a specified LegendEntry class to this collection.

[Visual Basic] Overloads Public Function Add(LegendEntry) As Integer

[C#] public int Add(LegendEntry);

Adds the specified LegendEntry objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray LegendEntry())

[C#] public void Add(params LegendEntry[]);

Adds a specified LegendEntryCollection to this collection.

[Visual Basic] Overloads Public Sub Add(LegendEntryCollection)

[C#] public void Add(LegendEntryCollection);

See Also

LegendEntryCollection Class | LegendEntryCollection Members


Add(LegendEntry) Method

LegendEntryCollection Class | LegendEntryCollection Members | Overload List

Language

Visual Basic

C#

Show All

legendEntry
The LegendEntry to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(LegendEntry) Method

Adds a specified LegendEntry class to this collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal legendEntry As LegendEntry _
) As Integer
[C#]
public int Add(
   LegendEntry legendEntry
);

Parameters

legendEntry
The LegendEntry to add.

Return Type

The zero-based index of the added LegendEntry.

See Also

LegendEntryCollection Class | LegendEntryCollection Members | Overload List


Add(LegendEntry[]) Method

LegendEntryCollection Class | LegendEntryCollection Members | Overload List

Language

Visual Basic

C#

Show All

legendEntryList
A list of LegendEntry objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(LegendEntry[]) Method

Adds the specified LegendEntry objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray legendEntryList() As LegendEntry _
)
[C#]
public void Add(
   params LegendEntry[] legendEntryList
);

Parameters

legendEntryList
A list of LegendEntry objects to add.

See Also

LegendEntryCollection Class | LegendEntryCollection Members | Overload List


Add(LegendEntryCollection) Method

LegendEntryCollection Class | LegendEntryCollection Members | Overload List

Language

Visual Basic

C#

Show All

legendEntryCollection
The LegendEntryCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(LegendEntryCollection) Method

Adds a specified LegendEntryCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal legendEntryCollection As LegendEntryCollection _
)
[C#]
public void Add(
   LegendEntryCollection legendEntryCollection
);

Parameters

legendEntryCollection
The LegendEntryCollection to add.

See Also

LegendEntryCollection Class | LegendEntryCollection Members | Overload List


Contains Method

LegendEntryCollection Class | LegendEntryCollection Members

Language

Visual Basic

C#

Show All

legendEntry
The LegendEntry to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified LegendEntry.

[Visual Basic]
Public Function Contains( _
   ByVal legendEntry As LegendEntry _
) As Boolean
[C#]
public bool Contains(
   LegendEntry legendEntry
);

Parameters

legendEntry
The LegendEntry to find.

Return Type

true if the specified LegendEntry belongs to this collection; otherwise, false.

See Also

LegendEntryCollection Class | LegendEntryCollection Members


IndexOf Method

LegendEntryCollection Class | LegendEntryCollection Members

Language

Visual Basic

C#

Show All

legendEntry
The LegendEntry to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines the index of a specified LegendEntry in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal legendEntry As LegendEntry _
) As Integer
[C#]
public int IndexOf(
   LegendEntry legendEntry
);

Parameters

legendEntry
The LegendEntry to find.

Return Type

The zero-based index of the specified LegendEntry.

See Also

LegendEntryCollection Class | LegendEntryCollection Members


Insert Method

LegendEntryCollection Class | LegendEntryCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the legend entry.
legendEntry
The legend entry to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a legend entry into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal legendEntry As LegendEntry _
)
[C#]
public void Insert(
   int index,
   LegendEntry legendEntry
);

Parameters

index
The zero-based index into the collection at which to insert the legend entry.
legendEntry
The legend entry to insert into this collection.

See Also

LegendEntryCollection Class | LegendEntryCollection Members


Remove Method

LegendEntryCollection Class | LegendEntryCollection Members

Language

Visual Basic

C#

Show All

legendEntry
The legend element to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified legend entry from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal legendEntry As LegendEntry _
)
[C#]
public void Remove(
   LegendEntry legendEntry
);

Parameters

legendEntry
The legend element to remove.

See Also

LegendEntryCollection Class | LegendEntryCollection Members


LegendEntryCollection Class Properties

LegendEntryCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LegendEntryCollection Class Members

For a list of all members of this type, see LegendEntryCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

LegendEntryCollection Class | dotnetCHARTING Namespace


Item Property

LegendEntryCollection Class | LegendEntryCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As LegendEntry
[C#]
public LegendEntry this[
   int index
]; {get; set;}

Parameters

index

See Also

LegendEntryCollection Class | LegendEntryCollection Members


Line Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Class

Defines objects used to draw a line or curve.

For a list of all members of this type, see Line members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.Line

Syntax

[Visual Basic]
Public Class Line
[C#]
public class Line

See Also

Line Members | dotnetCHARTING Namespace


Line Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Line Class Members

Line overview

Public Constructors

Public Constructor Line Constructor Overloaded.

Public Properties

Public Property AnchorCapScale | Gets or sets the amount by which to scale the line caps with respect to the width of the line. This feature only works with anchor LineCap members.
Public Property Color | Gets or sets the color of this line.
Public Property DashStyle | Gets or sets the DashStyle of this line.
Public Property EndCap | Gets or sets the LineCap that ends this line.
Public Property Length | Gets or sets the length of this line.
Public Property StartCap | Gets or sets the LineCap that starts this line.
Public Property Width | Gets or sets the width of this line.

See Also

Line Class | dotnetCHARTING Namespace


Line Class | Line Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Constructor

Overload List

Initialize a new instance of the Line.

[Visual Basic] Public Sub New()

[C#] public Line();

Initialize a new instance of the Line class with a color.

[Visual Basic] Public Sub New(Color)

[C#] public Line(Color);

Initialize a new instance of the Line class with a color and DashStyle.

[Visual Basic] Public Sub New(Color,DashStyle)

[C#] public Line(Color,DashStyle);

Initialize a new instance of the Line class with a color and line width.

[Visual Basic] Public Sub New(Color,Integer)

[C#] public Line(Color,int);

Initialize a new instance of the Line class with a color, line width, and .

[Visual Basic] Public Sub New(Color,Integer,DashStyle)

[C#] public Line(Color,int,DashStyle);

See Also

Line Class | Line Members


Line Class | Line Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Constructor()

Initialize a new instance of the Line.

[Visual Basic]
Public Function New()
[C#]
public Line();

See Also

Line Class | Line Members | Overload List


Line Constructor(Color)

Line Class | Line Members | Overload List

Language

Visual Basic

C#

Show All

c
Color of the line.
See Also Languages dotnetCHARTING Send comments on this topic.

Line Constructor(Color)

Initialize a new instance of the Line class with a color.

[Visual Basic]
Public Function New( _
   ByVal c As Color _
)
[C#]
public Line(
   Color c
);

Parameters

c
Color of the line.

See Also

Line Class | Line Members | Overload List


Line Constructor(Color,DashStyle)

Line Class | Line Members | Overload List

Language

Visual Basic

C#

Show All

c
Color of the line.
ds
DashStyle of this line.
See Also Languages dotnetCHARTING Send comments on this topic.

Line Constructor(Color,DashStyle)

Initialize a new instance of the Line class with a color and DashStyle.

[Visual Basic]
Public Function New( _
   ByVal c As Color, _
   ByVal ds As DashStyle _
)
[C#]
public Line(
   Color c,
   DashStyle ds
);

Parameters

c
Color of the line.
ds
DashStyle of this line.

See Also

Line Class | Line Members | Overload List


Line Constructor(Color,Int32)

Line Class | Line Members | Overload List

Language

Visual Basic

C#

Show All

c
Color of the line.
width
Width of the line.
See Also Languages dotnetCHARTING Send comments on this topic.

Line Constructor(Color,Int32)

Initialize a new instance of the Line class with a color and line width.

[Visual Basic]
Public Function New( _
   ByVal c As Color, _
   ByVal width As Integer _
)
[C#]
public Line(
   Color c,
   int width
);

Parameters

c
Color of the line.
width
Width of the line.

See Also

Line Class | Line Members | Overload List


Line Constructor(Color,Int32,DashStyle)

Line Class | Line Members | Overload List | DashStyle

Language

Visual Basic

C#

Show All

c
Color of the line.
width
Width of the line.
ds
DashStyle of this line.
See Also Languages dotnetCHARTING Send comments on this topic.

Line Constructor(Color,Int32,DashStyle)

Initialize a new instance of the Line class with a color, line width, and .

[Visual Basic]
Public Function New( _
   ByVal c As Color, _
   ByVal width As Integer, _
   ByVal ds As DashStyle _
)
[C#]
public Line(
   Color c,
   int width,
   DashStyle ds
);

Parameters

c
Color of the line.
width
Width of the line.
ds
DashStyle of this line.

See Also

Line Class | Line Members | Overload List | DashStyle


Line Class Properties

Line Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Line Class Members

For a list of all members of this type, see Line members.

Public Properties

Public Property AnchorCapScale | Gets or sets the amount by which to scale the line caps with respect to the width of the line. This feature only works with anchor LineCap members.
Public Property Color | Gets or sets the color of this line.
Public Property DashStyle | Gets or sets the DashStyle of this line.
Public Property EndCap | Gets or sets the LineCap that ends this line.
Public Property Length | Gets or sets the length of this line.
Public Property StartCap | Gets or sets the LineCap that starts this line.
Public Property Width | Gets or sets the width of this line.

See Also

Line Class | dotnetCHARTING Namespace


Line Class | Line Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AnchorCapScale Property

Gets or sets the amount by which to scale the line caps with respect to the width of the line. This feature only works with anchor LineCap members.

[Visual Basic]
Public Property AnchorCapScale As Integer
[C#]
public int AnchorCapScale {get; set;}

See Also

Line Class | Line Members


Line Class | Line Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Color Property

Gets or sets the color of this line.

[Visual Basic]
Public Property Color As Color
[C#]
public Color Color {get; set;}

See Also

Line Class | Line Members


Line Class | Line Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DashStyle Property

Gets or sets the DashStyle of this line.

[Visual Basic]
Public Property DashStyle As DashStyle
[C#]
public DashStyle DashStyle {get; set;}

See Also

Line Class | Line Members


Line Class | Line Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

EndCap Property

Gets or sets the LineCap that ends this line.

[Visual Basic]
Public Property EndCap As LineCap
[C#]
public LineCap EndCap {get; set;}

See Also

Line Class | Line Members


Line Class | Line Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Length Property

Gets or sets the length of this line.

[Visual Basic]
Public Property Length As Integer
[C#]
public int Length {get; set;}

Remarks

Only used with the TickLine property and represents the tick line length.

See Also

Line Class | Line Members


Line Class | Line Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StartCap Property

Gets or sets the LineCap that starts this line.

[Visual Basic]
Public Property StartCap As LineCap
[C#]
public LineCap StartCap {get; set;}

See Also

Line Class | Line Members


Line Class | Line Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Width Property

Gets or sets the width of this line.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}

See Also

Line Class | Line Members


ListCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ListCollection Class

A list dictionary variation that allows adding items of the string type using a string.

For a list of all members of this type, see ListCollection members.

Inheritance Hierarchy

System.Object
System.Collections.Specialized.ListDictionary
dotnetCHARTING.ListCollection

Syntax

[Visual Basic]
Public Class ListCollection
   Inherits ListDictionary
[C#]
public class ListCollection : ListDictionary

Remarks

Strings used to add items use the following syntax:

"Key1=Value2,Key2=Value2"

See Also

ListCollection Members | dotnetCHARTING Namespace


ListCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ListCollection Class Members

ListCollection overview

Public Constructors

Public Constructor ListCollection Constructor

Public Properties

Public Property Count (Inherited from System.Collections.Specialized.ListDictionary)
Public Property IsFixedSize (Inherited from System.Collections.Specialized.ListDictionary)
Public Property IsReadOnly (Inherited from System.Collections.Specialized.ListDictionary)
Public Property IsSynchronized (Inherited from System.Collections.Specialized.ListDictionary)
Public Property Item (Inherited from System.Collections.Specialized.ListDictionary)
Public Property Keys (Inherited from System.Collections.Specialized.ListDictionary)
Public Property SyncRoot (Inherited from System.Collections.Specialized.ListDictionary)
Public Property Values (Inherited from System.Collections.Specialized.ListDictionary)

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.Specialized.ListDictionary) |
Public Method Contains (Inherited from System.Collections.Specialized.ListDictionary) |
Public Method CopyTo (Inherited from System.Collections.Specialized.ListDictionary) |
Public Method static (Shared in Visual Basic) FromDictionary | Creates a ListCollection object from a ListDictionary.
Public Method GetEnumerator (Inherited from System.Collections.Specialized.ListDictionary) |
Public Method static (Shared in Visual Basic) op_Implicit | Overloaded.
Public Method Remove (Inherited from System.Collections.Specialized.ListDictionary) |
Public Method ToString | Overridden.

See Also

ListCollection Class | dotnetCHARTING Namespace


ListCollection Class | ListCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ListCollection Constructor

[Visual Basic]
Public Function New()
[C#]
public ListCollection();

See Also

ListCollection Class | ListCollection Members


ListCollection Class Methods

ListCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ListCollection Class Members

For a list of all members of this type, see ListCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.Specialized.ListDictionary) |
Public Method Contains (Inherited from System.Collections.Specialized.ListDictionary) |
Public Method CopyTo (Inherited from System.Collections.Specialized.ListDictionary) |
Public Method static (Shared in Visual Basic) FromDictionary | Creates a ListCollection object from a ListDictionary.
Public Method GetEnumerator (Inherited from System.Collections.Specialized.ListDictionary) |
Public Method static (Shared in Visual Basic) op_Implicit | Overloaded.
Public Method Remove (Inherited from System.Collections.Specialized.ListDictionary) |
Public Method ToString | Overridden.

See Also

ListCollection Class | dotnetCHARTING Namespace


ListCollection Class | ListCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

[Visual Basic] Overloads Public Sub Add(Object,Object)

[C#] public void Add(object,object);

Adds a single or multiple items using a string.

[Visual Basic] Overloads Public Sub Add(String)

[C#] public void Add(string);

See Also

ListCollection Class | ListCollection Members


Add(String) Method

ListCollection Class | ListCollection Members | Overload List

Language

Visual Basic

C#

Show All

str
See Also Languages dotnetCHARTING Send comments on this topic.

Add(String) Method

Adds a single or multiple items using a string.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal str As String _
)
[C#]
public void Add(
   string str
);

Parameters

str

See Also

ListCollection Class | ListCollection Members | Overload List


FromDictionary Method

ListCollection Class | ListCollection Members

Language

Visual Basic

C#

Show All

ld
ListDictionary to instantiate with.
See Also Languages dotnetCHARTING Send comments on this topic.

FromDictionary Method

Creates a ListCollection object from a ListDictionary.

[Visual Basic]
Public Shared Function FromDictionary( _
   ByVal ld As ListDictionary _
) As ListCollection
[C#]
public static ListCollection FromDictionary(
   ListDictionary ld
);

Parameters

ld
ListDictionary to instantiate with.

See Also

ListCollection Class | ListCollection Members


ListCollection Class | ListCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Implicit Method

Overload List

[Visual Basic] Overloads Public Shared Function op_Implicit(ListCollection) As String

[C#] public static string op_Implicit(ListCollection);

[Visual Basic] Overloads Public Shared Function op_Implicit(String) As ListCollection

[C#] public static ListCollection op_Implicit(string);

See Also

ListCollection Class | ListCollection Members


op_Implicit(ListCollection) Method

ListCollection Class | ListCollection Members | Overload List

Language

Visual Basic

C#

Show All

lc
See Also Languages dotnetCHARTING Send comments on this topic.

op_Implicit(ListCollection) Method

[Visual Basic]
Overloads Public Shared Function op_Implicit( _
   ByVal lc As ListCollection _
) As String
[C#]
public static string op_Implicit(
   ListCollection lc
);

Parameters

lc

See Also

ListCollection Class | ListCollection Members | Overload List


op_Implicit(String) Method

ListCollection Class | ListCollection Members | Overload List

Language

Visual Basic

C#

Show All

str
See Also Languages dotnetCHARTING Send comments on this topic.

op_Implicit(String) Method

[Visual Basic]
Overloads Public Shared Function op_Implicit( _
   ByVal str As String _
) As ListCollection
[C#]
public static ListCollection op_Implicit(
   string str
);

Parameters

str

See Also

ListCollection Class | ListCollection Members | Overload List


ListCollection Class | ListCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

ListCollection Class | ListCollection Members


Parameter Members | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property | StoredProcedure Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Parameter Class

Represents an SQL parameter to use with a StoredProcedure.

For a list of all members of this type, see Parameter members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.Parameter

Syntax

[Visual Basic]
Public Class Parameter
[C#]
public class Parameter

See Also

Parameter Members | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property | StoredProcedure Property


Parameter Class | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property | StoredProcedure Property

See Also dotnetCHARTING Send comments on this topic.

Parameter Class Members

Parameter overview

Public Constructors

Public Constructor Parameter Constructor Overloaded.

Public Properties

Public Property Name | Gets or sets the parameter name.
Public Property Type | Gets or sets the parameter's FieldType.
Public Property Value | Gets or sets the parameter's value.

See Also

Parameter Class | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property | StoredProcedure Property


Parameter Class | Parameter Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Parameter Constructor

Overload List

Initializes a new instance of the Parameter class.

[Visual Basic] Public Sub New()

[C#] public Parameter();

Initializes a new instance of the Parameter class with a name, value, and FieldType.

[Visual Basic] Public Sub New(String,String,FieldType)

[C#] public Parameter(string,string,FieldType);

See Also

Parameter Class | Parameter Members


Parameter Class | Parameter Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Parameter Constructor()

Initializes a new instance of the Parameter class.

[Visual Basic]
Public Function New()
[C#]
public Parameter();

See Also

Parameter Class | Parameter Members | Overload List


Parameter Constructor(String,String,FieldType)

Parameter Class | Parameter Members | Overload List

Language

Visual Basic

C#

Show All

pName
Name of the parameter.
pValue
Value of the parameter.
pType
FieldType of the parameter.
See Also Languages dotnetCHARTING Send comments on this topic.

Parameter Constructor(String,String,FieldType)

Initializes a new instance of the Parameter class with a name, value, and FieldType.

[Visual Basic]
Public Function New( _
   ByVal pName As String, _
   ByVal pValue As String, _
   ByVal pType As FieldType _
)
[C#]
public Parameter(
   string pName,
   string pValue,
   FieldType pType
);

Parameters

pName
Name of the parameter.
pValue
Value of the parameter.
pType
FieldType of the parameter.

See Also

Parameter Class | Parameter Members | Overload List


Parameter Class Properties

Parameter Class | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property | StoredProcedure Property

See Also dotnetCHARTING Send comments on this topic.

Parameter Class Members

For a list of all members of this type, see Parameter members.

Public Properties

Public Property Name | Gets or sets the parameter name.
Public Property Type | Gets or sets the parameter's FieldType.
Public Property Value | Gets or sets the parameter's value.

See Also

Parameter Class | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property | StoredProcedure Property


Parameter Class | Parameter Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Name Property

Gets or sets the parameter name.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

See Also

Parameter Class | Parameter Members


Parameter Class | Parameter Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Type Property

Gets or sets the parameter's FieldType.

[Visual Basic]
Public Property Type As FieldType
[C#]
public FieldType Type {get; set;}

See Also

Parameter Class | Parameter Members


Parameter Class | Parameter Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Value Property

Gets or sets the parameter's value.

[Visual Basic]
Public Property Value As String
[C#]
public string Value {get; set;}

See Also

Parameter Class | Parameter Members


ParameterCollection Members | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ParameterCollection Class

Contains a collection of Parameter objects.

For a list of all members of this type, see ParameterCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.ParameterCollection

Syntax

[Visual Basic]
Public Class ParameterCollection
   Inherits CollectionBase
[C#]
public class ParameterCollection : CollectionBase

See Also

ParameterCollection Members | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property


ParameterCollection Class | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property

See Also dotnetCHARTING Send comments on this topic.

ParameterCollection Class Members

ParameterCollection overview

Public Constructors

Public Constructor ParameterCollection Constructor

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Parameter.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method Insert | Inserts a Parameter into this collection at a specified index.
Public Method Remove | Removes a specified Parameter from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

ParameterCollection Class | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property


ParameterCollection Class | ParameterCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ParameterCollection Constructor

[Visual Basic]
Public Function New()
[C#]
public ParameterCollection();

See Also

ParameterCollection Class | ParameterCollection Members


ParameterCollection Class Methods

ParameterCollection Class | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property

See Also dotnetCHARTING Send comments on this topic.

ParameterCollection Class Members

For a list of all members of this type, see ParameterCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Parameter.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method Insert | Inserts a Parameter into this collection at a specified index.
Public Method Remove | Removes a specified Parameter from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

ParameterCollection Class | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property


ParameterCollection Class | ParameterCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

Adds a specified Parameter class to this collection.

[Visual Basic] Overloads Public Function Add(Parameter) As Integer

[C#] public int Add(Parameter);

Adds a specified ParameterCollection to this collection.

[Visual Basic] Overloads Public Function Add(ParameterCollection) As Integer

[C#] public int Add(ParameterCollection);

See Also

ParameterCollection Class | ParameterCollection Members


Add(Parameter) Method

ParameterCollection Class | ParameterCollection Members | Overload List

Language

Visual Basic

C#

Show All

_Parameter
The Parameter to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Parameter) Method

Adds a specified Parameter class to this collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal _Parameter As Parameter _
) As Integer
[C#]
public int Add(
   Parameter _Parameter
);

Parameters

_Parameter
The Parameter to add.

Return Type

The zero-based index of the added Parameter.

See Also

ParameterCollection Class | ParameterCollection Members | Overload List


Add(ParameterCollection) Method

ParameterCollection Class | ParameterCollection Members | Overload List

Language

Visual Basic

C#

Show All

paramCollection
ParameterCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(ParameterCollection) Method

Adds a specified ParameterCollection to this collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal paramCollection As ParameterCollection _
) As Integer
[C#]
public int Add(
   ParameterCollection paramCollection
);

Parameters

paramCollection
ParameterCollection to add.

See Also

ParameterCollection Class | ParameterCollection Members | Overload List


Contains Method

ParameterCollection Class | ParameterCollection Members

Language

Visual Basic

C#

Show All

_Parameter
The Parameter to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified Parameter.

[Visual Basic]
Public Function Contains( _
   ByVal _Parameter As Parameter _
) As Boolean
[C#]
public bool Contains(
   Parameter _Parameter
);

Parameters

_Parameter
The Parameter to find.

Return Type

true if the specified Parameter belongs to this collection; otherwise, false.

See Also

ParameterCollection Class | ParameterCollection Members


Insert Method

ParameterCollection Class | ParameterCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the Parameter.
_Parameter
The Parameter to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a Parameter into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal _Parameter As Parameter _
)
[C#]
public void Insert(
   int index,
   Parameter _Parameter
);

Parameters

index
The zero-based index into the collection at which to insert the Parameter.
_Parameter
The Parameter to insert into this collection.

See Also

ParameterCollection Class | ParameterCollection Members


Remove Method

ParameterCollection Class | ParameterCollection Members

Language

Visual Basic

C#

Show All

_Parameter
The Parameter to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified Parameter from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal _Parameter As Parameter _
)
[C#]
public void Remove(
   Parameter _Parameter
);

Parameters

_Parameter
The Parameter to remove.

See Also

ParameterCollection Class | ParameterCollection Members


ParameterCollection Class Properties

ParameterCollection Class | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property

See Also dotnetCHARTING Send comments on this topic.

ParameterCollection Class Members

For a list of all members of this type, see ParameterCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

ParameterCollection Class | dotnetCHARTING Namespace | DataEngine Class | ParameterCollection Property


Item Property

ParameterCollection Class | ParameterCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Parameter
[C#]
public Parameter this[
   int index
]; {get; set;}

Parameters

index

See Also

ParameterCollection Class | ParameterCollection Members


ScaleRange Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ScaleRange Class

Represents a value or range of values on an axis scale. Values can be numeric, DateTime, and string types.

For a list of all members of this type, see ScaleRange members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.ScaleRange
dotnetCHARTING.AxisTick
dotnetCHARTING.AxisMarker

Syntax

[Visual Basic]
Public Class ScaleRange
   Implements IInstanceID
[C#]
public class ScaleRange : IInstanceID

See Also

ScaleRange Members | dotnetCHARTING Namespace


ScaleRange Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ScaleRange Class Members

ScaleRange overview

Public Constructors

Public Constructor ScaleRange Constructor Instantiates a ScaleRange class with a low and high value.

Public Properties

Public Property IncludeInAxisScale | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it.
Public Property InstanceID |
Public Property Value | Gets or sets the numeric, DateTime, or text value of this ScaleRange.
Public Property ValueHigh | Gets or sets the upper bounds of a numeric, DateTime, or text range.
Public Property ValueLow | Gets or sets the lower bounds of a numeric, DateTime, or text range.

Public Methods

Public Method ToString Overridden.

See Also

ScaleRange Class | dotnetCHARTING Namespace


ScaleRange Constructor

ScaleRange Class | ScaleRange Members

Language

Visual Basic

C#

Show All

lowValue
Low value.
highValue
High value.
See Also Languages dotnetCHARTING Send comments on this topic.

ScaleRange Constructor

Instantiates a ScaleRange class with a low and high value.

[Visual Basic]
Public Function New( _
   ByVal lowValue As Object, _
   ByVal highValue As Object _
)
[C#]
public ScaleRange(
   object lowValue,
   object highValue
);

Parameters

lowValue
Low value.
highValue
High value.

See Also

ScaleRange Class | ScaleRange Members


ScaleRange Class Methods

ScaleRange Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ScaleRange Class Members

For a list of all members of this type, see ScaleRange members.

Public Methods

Public Method ToString Overridden.

See Also

ScaleRange Class | dotnetCHARTING Namespace


ScaleRange Class | ScaleRange Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

ScaleRange Class | ScaleRange Members


ScaleRange Class Properties

ScaleRange Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ScaleRange Class Members

For a list of all members of this type, see ScaleRange members.

Public Properties

Public Property IncludeInAxisScale | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it.
Public Property InstanceID |
Public Property Value | Gets or sets the numeric, DateTime, or text value of this ScaleRange.
Public Property ValueHigh | Gets or sets the upper bounds of a numeric, DateTime, or text range.
Public Property ValueLow | Gets or sets the lower bounds of a numeric, DateTime, or text range.

See Also

ScaleRange Class | dotnetCHARTING Namespace


ScaleRange Class | ScaleRange Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

IncludeInAxisScale Property

Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it.

[Visual Basic]
Public Property IncludeInAxisScale As Boolean
[C#]
public bool IncludeInAxisScale {get; set;}

See Also

ScaleRange Class | ScaleRange Members


ScaleRange Class | ScaleRange Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InstanceID Property

[Visual Basic]
Public Property InstanceID As Integer
[C#]
public int InstanceID {get; set;}

See Also

ScaleRange Class | ScaleRange Members


ScaleRange Class | ScaleRange Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Value Property

Gets or sets the numeric, DateTime, or text value of this ScaleRange.

[Visual Basic]
Public Overridable Property Value As Object
[C#]
public virtual object Value {get; set;}

Remarks

When Value is specified, ValueLow and ValueHigh are both set to this value. When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.

See Also

ScaleRange Class | ScaleRange Members


ScaleRange Class | ScaleRange Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ValueHigh Property

Gets or sets the upper bounds of a numeric, DateTime, or text range.

[Visual Basic]
Public Overridable Property ValueHigh As Object
[C#]
public virtual object ValueHigh {get; set;}

Remarks

When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.

See Also

ScaleRange Class | ScaleRange Members


ScaleRange Class | ScaleRange Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ValueLow Property

Gets or sets the lower bounds of a numeric, DateTime, or text range.

[Visual Basic]
Public Overridable Property ValueLow As Object
[C#]
public virtual object ValueLow {get; set;}

Remarks

When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.

See Also

ScaleRange Class | ScaleRange Members


ScaleRangeCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ScaleRangeCollection Class

Contains a collection of ScaleRange objects.

For a list of all members of this type, see ScaleRangeCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.ScaleRangeCollection

Syntax

[Visual Basic]
Public Class ScaleRangeCollection
   Inherits CollectionBase
[C#]
public class ScaleRangeCollection : CollectionBase

See Also

ScaleRangeCollection Members | dotnetCHARTING Namespace


ScaleRangeCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ScaleRangeCollection Class Members

ScaleRangeCollection overview

Public Constructors

Public Constructor ScaleRangeCollection Constructor Creates a new instance of ScaleRangeCollection with the specified list of ScaleRange objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified ScaleRange.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method Insert | Inserts a ScaleRange into this collection at a specified index.
Public Method Remove | Removes a specified ScaleRange from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

ScaleRangeCollection Class | dotnetCHARTING Namespace


ScaleRangeCollection Constructor

ScaleRangeCollection Class | ScaleRangeCollection Members

Language

Visual Basic

C#

Show All

scaleRangeList
See Also Languages dotnetCHARTING Send comments on this topic.

ScaleRangeCollection Constructor

Creates a new instance of ScaleRangeCollection with the specified list of ScaleRange objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray scaleRangeList() As ScaleRange _
)
[C#]
public ScaleRangeCollection(
   params ScaleRange[] scaleRangeList
);

Parameters

scaleRangeList

See Also

ScaleRangeCollection Class | ScaleRangeCollection Members


ScaleRangeCollection Class Methods

ScaleRangeCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ScaleRangeCollection Class Members

For a list of all members of this type, see ScaleRangeCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified ScaleRange.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method Insert | Inserts a ScaleRange into this collection at a specified index.
Public Method Remove | Removes a specified ScaleRange from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

ScaleRangeCollection Class | dotnetCHARTING Namespace


ScaleRangeCollection Class | ScaleRangeCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

Adds a specified ScaleRange class to this collection.

[Visual Basic] Overloads Public Function Add(ScaleRange) As Integer

[C#] public int Add(ScaleRange);

Adds the specified ScaleRange objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray ScaleRange())

[C#] public void Add(params ScaleRange[]);

Adds a specified ScaleRangeCollection to this collection.

[Visual Basic] Overloads Public Sub Add(ScaleRangeCollection)

[C#] public void Add(ScaleRangeCollection);

See Also

ScaleRangeCollection Class | ScaleRangeCollection Members


Add(ScaleRange) Method

ScaleRangeCollection Class | ScaleRangeCollection Members | Overload List

Language

Visual Basic

C#

Show All

_ScaleRange
The ScaleRange to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(ScaleRange) Method

Adds a specified ScaleRange class to this collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal _ScaleRange As ScaleRange _
) As Integer
[C#]
public int Add(
   ScaleRange _ScaleRange
);

Parameters

_ScaleRange
The ScaleRange to add.

Return Type

The zero-based index of the added ScaleRange.

See Also

ScaleRangeCollection Class | ScaleRangeCollection Members | Overload List


Add(ScaleRange[]) Method

ScaleRangeCollection Class | ScaleRangeCollection Members | Overload List

Language

Visual Basic

C#

Show All

scaleRangeList
A list of ScaleRange objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(ScaleRange[]) Method

Adds the specified ScaleRange objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray scaleRangeList() As ScaleRange _
)
[C#]
public void Add(
   params ScaleRange[] scaleRangeList
);

Parameters

scaleRangeList
A list of ScaleRange objects to add.

See Also

ScaleRangeCollection Class | ScaleRangeCollection Members | Overload List


Add(ScaleRangeCollection) Method

ScaleRangeCollection Class | ScaleRangeCollection Members | Overload List

Language

Visual Basic

C#

Show All

scaleRangeCollection
The ScaleRangeCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(ScaleRangeCollection) Method

Adds a specified ScaleRangeCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal scaleRangeCollection As ScaleRangeCollection _
)
[C#]
public void Add(
   ScaleRangeCollection scaleRangeCollection
);

Parameters

scaleRangeCollection
The ScaleRangeCollection to add.

See Also

ScaleRangeCollection Class | ScaleRangeCollection Members | Overload List


Contains Method

ScaleRangeCollection Class | ScaleRangeCollection Members

Language

Visual Basic

C#

Show All

_ScaleRange
The ScaleRange to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified ScaleRange.

[Visual Basic]
Public Function Contains( _
   ByVal _ScaleRange As ScaleRange _
) As Boolean
[C#]
public bool Contains(
   ScaleRange _ScaleRange
);

Parameters

_ScaleRange
The ScaleRange to find.

Return Type

true if the specified ScaleRange belongs to this collection; otherwise, false.

See Also

ScaleRangeCollection Class | ScaleRangeCollection Members


Insert Method

ScaleRangeCollection Class | ScaleRangeCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the ScaleRange.
_ScaleRange
The ScaleRange to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a ScaleRange into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal _ScaleRange As ScaleRange _
)
[C#]
public void Insert(
   int index,
   ScaleRange _ScaleRange
);

Parameters

index
The zero-based index into the collection at which to insert the ScaleRange.
_ScaleRange
The ScaleRange to insert into this collection.

See Also

ScaleRangeCollection Class | ScaleRangeCollection Members


Remove Method

ScaleRangeCollection Class | ScaleRangeCollection Members

Language

Visual Basic

C#

Show All

_ScaleRange
The ScaleRange to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified ScaleRange from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal _ScaleRange As ScaleRange _
)
[C#]
public void Remove(
   ScaleRange _ScaleRange
);

Parameters

_ScaleRange
The ScaleRange to remove.

See Also

ScaleRangeCollection Class | ScaleRangeCollection Members


ScaleRangeCollection Class Properties

ScaleRangeCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ScaleRangeCollection Class Members

For a list of all members of this type, see ScaleRangeCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

ScaleRangeCollection Class | dotnetCHARTING Namespace


Item Property

ScaleRangeCollection Class | ScaleRangeCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As ScaleRange
[C#]
public ScaleRange this[
   int index
]; {get; set;}

Parameters

index

See Also

ScaleRangeCollection Class | ScaleRangeCollection Members


SerializerObject Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SerializerObject Class

For a list of all members of this type, see SerializerObject members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.SerializerObject

Syntax

[Visual Basic]
Private Class SerializerObject
[C#]
private class SerializerObject

See Also

SerializerObject Members | dotnetCHARTING Namespace


SerializerObject Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SerializerObject Class Members

SerializerObject overview

Public Constructors

Public Constructor SerializerObject Constructor

Public Properties

Public Property InstanceID
Public Property TheObject

See Also

SerializerObject Class | dotnetCHARTING Namespace


SerializerObject Constructor

SerializerObject Class | SerializerObject Members

Language

Visual Basic

C#

Show All

instance
obj
See Also Languages dotnetCHARTING Send comments on this topic.

SerializerObject Constructor

[Visual Basic]
Public Function New( _
   ByVal instance As Integer, _
   ByVal obj As Object _
)
[C#]
public SerializerObject(
   int instance,
   object obj
);

Parameters

instance
obj

See Also

SerializerObject Class | SerializerObject Members


SerializerObject Class Properties

SerializerObject Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SerializerObject Class Members

For a list of all members of this type, see SerializerObject members.

Public Properties

Public Property InstanceID
Public Property TheObject

See Also

SerializerObject Class | dotnetCHARTING Namespace


SerializerObject Class | SerializerObject Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InstanceID Property

[Visual Basic]
Public Property InstanceID As Integer
[C#]
public int InstanceID {get; set;}

See Also

SerializerObject Class | SerializerObject Members


SerializerObject Class | SerializerObject Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TheObject Property

[Visual Basic]
Public Property TheObject As Object
[C#]
public object TheObject {get; set;}

See Also

SerializerObject Class | SerializerObject Members


SerializerObjectCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SerializerObjectCollection Class

Contains a collection of SerializerObject objects.

For a list of all members of this type, see SerializerObjectCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.SerializerObjectCollection

Syntax

[Visual Basic]
Private Class SerializerObjectCollection
   Inherits CollectionBase
[C#]
private class SerializerObjectCollection : CollectionBase

See Also

SerializerObjectCollection Members | dotnetCHARTING Namespace


SerializerObjectCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SerializerObjectCollection Class Members

SerializerObjectCollection overview

Public Constructors

Public Constructor SerializerObjectCollection Constructor Creates a new instance of SerializerObjectCollection with the specified list of SerializerObject objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property FoundObject |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified SerializerObject.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method GetObject | Overloaded.
Public Method IndexOf | Determines index of a specified SerializerObject in this collection.
Public Method Insert | Inserts a SerializerObject into this collection at a specified index.
Public Method Remove | Removes a specified SerializerObject from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

SerializerObjectCollection Class | dotnetCHARTING Namespace


SerializerObjectCollection Constructor

SerializerObjectCollection Class | SerializerObjectCollection Members

Language

Visual Basic

C#

Show All

serializerObjectList
See Also Languages dotnetCHARTING Send comments on this topic.

SerializerObjectCollection Constructor

Creates a new instance of SerializerObjectCollection with the specified list of SerializerObject objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray serializerObjectList() As SerializerObject _
)
[C#]
public SerializerObjectCollection(
   params SerializerObject[] serializerObjectList
);

Parameters

serializerObjectList

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members


SerializerObjectCollection Class Methods

SerializerObjectCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SerializerObjectCollection Class Members

For a list of all members of this type, see SerializerObjectCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified SerializerObject.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method GetObject | Overloaded.
Public Method IndexOf | Determines index of a specified SerializerObject in this collection.
Public Method Insert | Inserts a SerializerObject into this collection at a specified index.
Public Method Remove | Removes a specified SerializerObject from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

SerializerObjectCollection Class | dotnetCHARTING Namespace


SerializerObjectCollection Class | SerializerObjectCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

[Visual Basic] Overloads Public Function Add(SerializerObject) As Integer

[C#] public int Add(SerializerObject);

Adds the specified SerializerObject objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray SerializerObject())

[C#] public void Add(params SerializerObject[]);

Adds a specified SerializerObjectCollection to this collection.

[Visual Basic] Overloads Public Sub Add(SerializerObjectCollection)

[C#] public void Add(SerializerObjectCollection);

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members


Add(SerializerObject) Method

SerializerObjectCollection Class | SerializerObjectCollection Members | Overload List

Language

Visual Basic

C#

Show All

serializerObject
See Also Languages dotnetCHARTING Send comments on this topic.

Add(SerializerObject) Method

[Visual Basic]
Overloads Public Function Add( _
   ByVal serializerObject As SerializerObject _
) As Integer
[C#]
public int Add(
   SerializerObject serializerObject
);

Parameters

serializerObject

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members | Overload List


Add(SerializerObject[]) Method

SerializerObjectCollection Class | SerializerObjectCollection Members | Overload List

Language

Visual Basic

C#

Show All

serializerObjectList
A list of SerializerObject objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(SerializerObject[]) Method

Adds the specified SerializerObject objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray serializerObjectList() As SerializerObject _
)
[C#]
public void Add(
   params SerializerObject[] serializerObjectList
);

Parameters

serializerObjectList
A list of SerializerObject objects to add.

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members | Overload List


Add(SerializerObjectCollection) Method

SerializerObjectCollection Class | SerializerObjectCollection Members | Overload List

Language

Visual Basic

C#

Show All

serializerObjectCollection
The SerializerObjectCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(SerializerObjectCollection) Method

Adds a specified SerializerObjectCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal serializerObjectCollection As SerializerObjectCollection _
)
[C#]
public void Add(
   SerializerObjectCollection serializerObjectCollection
);

Parameters

serializerObjectCollection
The SerializerObjectCollection to add.

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members | Overload List


Contains Method

SerializerObjectCollection Class | SerializerObjectCollection Members

Language

Visual Basic

C#

Show All

serializerObject
The SerializerObject to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified SerializerObject.

[Visual Basic]
Public Function Contains( _
   ByVal serializerObject As SerializerObject _
) As Boolean
[C#]
public bool Contains(
   SerializerObject serializerObject
);

Parameters

serializerObject
The SerializerObject to find.

Return Type

true if the specified SerializerObject belongs to this collection; otherwise, false.

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members


SerializerObjectCollection Class | SerializerObjectCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetObject Method

Overload List

[Visual Basic] Overloads Public Function GetObject(Object,Integer) As Object

[C#] public object GetObject(object,int);

[Visual Basic] Overloads Public Function GetObject(SerializerObject) As Object

[C#] public object GetObject(SerializerObject);

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members


GetObject(Object,Int32) Method

SerializerObjectCollection Class | SerializerObjectCollection Members | Overload List

Language

Visual Basic

C#

Show All

obj
instanceID
See Also Languages dotnetCHARTING Send comments on this topic.

GetObject(Object,Int32) Method

[Visual Basic]
Overloads Public Function GetObject( _
   ByVal obj As Object, _
   ByVal instanceID As Integer _
) As Object
[C#]
public object GetObject(
   object obj,
   int instanceID
);

Parameters

obj
instanceID

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members | Overload List


GetObject(SerializerObject) Method

SerializerObjectCollection Class | SerializerObjectCollection Members | Overload List

Language

Visual Basic

C#

Show All

serO
See Also Languages dotnetCHARTING Send comments on this topic.

GetObject(SerializerObject) Method

[Visual Basic]
Overloads Public Function GetObject( _
   ByVal serO As SerializerObject _
) As Object
[C#]
public object GetObject(
   SerializerObject serO
);

Parameters

serO

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members | Overload List


IndexOf Method

SerializerObjectCollection Class | SerializerObjectCollection Members

Language

Visual Basic

C#

Show All

serializerObject
The SerializerObject to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines index of a specified SerializerObject in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal serializerObject As SerializerObject _
) As Integer
[C#]
public int IndexOf(
   SerializerObject serializerObject
);

Parameters

serializerObject
The SerializerObject to find.

Return Type

The zero-based index of the specified SerializerObject.

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members


Insert Method

SerializerObjectCollection Class | SerializerObjectCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the SerializerObject.
serializerObject
The SerializerObject to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a SerializerObject into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal serializerObject As SerializerObject _
)
[C#]
public void Insert(
   int index,
   SerializerObject serializerObject
);

Parameters

index
The zero-based index into the collection at which to insert the SerializerObject.
serializerObject
The SerializerObject to insert into this collection.

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members


Remove Method

SerializerObjectCollection Class | SerializerObjectCollection Members

Language

Visual Basic

C#

Show All

serializerObject
The SerializerObject to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified SerializerObject from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal serializerObject As SerializerObject _
)
[C#]
public void Remove(
   SerializerObject serializerObject
);

Parameters

serializerObject
The SerializerObject to remove.

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members


SerializerObjectCollection Class Properties

SerializerObjectCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SerializerObjectCollection Class Members

For a list of all members of this type, see SerializerObjectCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property FoundObject |
Public Property Item | Gets or sets the object at a specified index.

See Also

SerializerObjectCollection Class | dotnetCHARTING Namespace


SerializerObjectCollection Class | SerializerObjectCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FoundObject Property

[Visual Basic]
Public ReadOnly Property FoundObject As SerializerObject
[C#]
public SerializerObject FoundObject {get;}

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members


Item Property

SerializerObjectCollection Class | SerializerObjectCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As SerializerObject
[C#]
public SerializerObject this[
   int index
]; {get; set;}

Parameters

index

See Also

SerializerObjectCollection Class | SerializerObjectCollection Members


Series Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Series Class

Encapsulates a group of elements.

For a list of all members of this type, see Series members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.Series

Syntax

[Visual Basic]
Public Class Series
   Implements IInstanceID
[C#]
public class Series : IInstanceID

Remarks

The series represents a group of elements and also:

  • Provides a mechanism for setting default properties of all elements within it.
  • Controls all series specific properties such as it's LegendEntry or 2D line dash style (if applicable).
  • Derives an element based on a Calculation performed on the elements within it.
  • Provides data manipulation methods such as sorting and trimming of it's elements.

See also: Data Model Tutorial

See Also

Series Members | dotnetCHARTING Namespace


Series Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Series Class Members

Series overview

Public Constructors

Public Constructor Series Constructor Overloaded.

Public Properties

Public Property Background | Gets or sets the background object used to fill a gauge face or radar associated with this series.
Public Property CommandTimeout | Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Public Property ConnectionString | Sets the database connection string used when dynamically obtaining charting data from a SQL statement.
Public Property Data | Gets or sets a DataTable, DataSet, DataView, OleDbDataReader, SqlDataReader, IDataReader, XML file name, or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.
Public Property DataFields | Gets or sets a value that specifies the 'database column' to 'chart data' relationship.
Public Property DefaultElement | Gets or sets the an Element object whose properties will trickle to all elements within this series.
Public Property Element | Gets or sets an Element object which facilitates a shortcut for adding elements to the chart.
Public Property Elements | Gets or sets a collection of Element objects associated with this series.
Public Property EmptyElement | Gets or sets an EmptyElement object associated with this series.
Public Property EndDate | The ending date used with SqlStatement to query filtered data from a database.
Public Property HatchStylePalette | Gets or sets the hatch style palette used be the Elements of this series.
Public Property HatchStylePaletteName | Gets or sets a Palette boolean which indicates which static palette will be used be the Elements of this series. Note If used, legend behavior will be different.
Public Property InstanceID |
Public Property Item | Gets or sets an Element of this Series at a specified index.
Public Property LegendEntry | Gets or sets the legend entry properties of this series.
Public Property Limit | Gets or sets the limit number of elements returned for this series when data is generated.
Public Property LimitMode | Determine the type of limitation for Limit and SplitByLimit properties. Default is Top.
Public Property Line | Gets or sets the line properties of this series.
Public Property Name | Gets or sets the name of this series.
Public Property OtherElementText | Controls the label used for the aggregated datapoint / series created when using Limit or SplitByLimit and setting ShowOther to true.
Public Property Palette | Gets or sets the palette which will be used be the Elements of this series. Note If used, legend behavior will be different.
Public Property PaletteName | Gets or sets a Palette boolean which indicates which static palette will be used be the Elements of this series. Note If used, legend behavior will be different.
Public Property ParameterCollection | Gets or sets a collection of Parameter objects used in conjunction with StoredProcedure
Public Property Position | Gets or sets the position of this series in relation to other series when the chart is drawn.
Public Property ShowOther | This property controls if the additional series not shown due to the use of SplitByLimit, or the additional elements not shown due to the use of Limit are aggregated into a single series / element and graphed alongside the top x series / elements.
Public Property SplineTensionPercent | Gets or sets a value between 0 and 100 that specifies the tension of a spline curve.
Public Property SplitByLimit | Gets or sets the number of series created using SplitBy.
Public Property SqlStatement | The SQL statement used to obtain the charting data.
Public Property StartDate | The starting date used with SqlStatement to query filtered data from a database.
Public Property StoredProcedure | This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.
Public Property TotalElements | Return the total number of elements in the elements collection. This property usually used in conjunction with Limit.
Public Property Type | Gets or sets the type of this series.
Public Property Visible | Gets or sets a value which indicates whether the series is visible.
Public Property XAxis | Gets or sets the x axis for this series.
Public Property YAxis | Gets or sets the y axis for this series.

Public Methods

Public Method static (Shared in Visual Basic) Add | Overloaded.
Public Method AddElements | Overloaded.
Public Method AddParameter | Adds a stored procedure when to use in conjunction with StoredProcedure.
Public Method Calculate | Performs a Calculation on current instance of this series.
Public Method static (Shared in Visual Basic) Divide | Overloaded.
Public Method static (Shared in Visual Basic) FromYValues | Overloaded.
Public Method GetSmartPalette | Overloaded.
Public Method static (Shared in Visual Basic) Multiply | Overloaded.
Public Method static (Shared in Visual Basic) op_Addition | Overloaded.
Public Method static (Shared in Visual Basic) op_Division | Overloaded.
Public Method static (Shared in Visual Basic) op_Multiply | Overloaded.
Public Method static (Shared in Visual Basic) op_Subtraction | Overloaded.
Public Method Sort | Overloaded.
Public Method static (Shared in Visual Basic) Subtract | Overloaded.
Public Method Trim | Overloaded.

See Also

Series Class | dotnetCHARTING Namespace


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Series Constructor

Overload List

Initializes a new instance of the Series class.

[Visual Basic] Public Sub New()

[C#] public Series();

Initializes a new instance of the Series class with a name.

[Visual Basic] Public Sub New(String)

[C#] public Series(string);

Initializes a new instance of the Series class with a name and the specified Elements.

[Visual Basic] Public Sub New(String,ParamArray Element())

[C#] public Series(string,params Element[]);

Initializes a new instance of the Series class with a name and the specified elementCollection.

[Visual Basic] Public Sub New(String,ElementCollection)

[C#] public Series(string,ElementCollection);

Initializes a new instance of the Series class with a name and SeriesType.

[Visual Basic] Public Sub New(String,SeriesType)

[C#] public Series(string,SeriesType);

See Also

Series Class | Series Members


Series Class | Series Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Series Constructor()

Initializes a new instance of the Series class.

[Visual Basic]
Public Function New()
[C#]
public Series();

See Also

Series Class | Series Members | Overload List


Series Constructor(String)

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the series.
See Also Languages dotnetCHARTING Send comments on this topic.

Series Constructor(String)

Initializes a new instance of the Series class with a name.

[Visual Basic]
Public Function New( _
   ByVal name As String _
)
[C#]
public Series(
   string name
);

Parameters

name
Name of the series.

See Also

Series Class | Series Members | Overload List


Series Constructor(String,Element[])

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the series.
elementList
List of Element objects added to the series.
See Also Languages dotnetCHARTING Send comments on this topic.

Series Constructor(String,Element[])

Initializes a new instance of the Series class with a name and the specified Elements.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal ParamArray elementList() As Element _
)
[C#]
public Series(
   string name,
   params Element[] elementList
);

Parameters

name
Name of the series.
elementList
List of Element objects added to the series.

See Also

Series Class | Series Members | Overload List


Series Constructor(String,ElementCollection)

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the new series.
elementCollection
Collection of elements assigned to this series.
See Also Languages dotnetCHARTING Send comments on this topic.

Series Constructor(String,ElementCollection)

Initializes a new instance of the Series class with a name and the specified elementCollection.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal elementCollection As ElementCollection _
)
[C#]
public Series(
   string name,
   ElementCollection elementCollection
);

Parameters

name
Name of the new series.
elementCollection
Collection of elements assigned to this series.

Remarks

The ElementCollection object itself is not used by the series. The elements are copied to this series' ElementCollection.

See Also

Series Class | Series Members | Overload List


Series Constructor(String,SeriesType)

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of the series.
seriesType
Series type of the series.
See Also Languages dotnetCHARTING Send comments on this topic.

Series Constructor(String,SeriesType)

Initializes a new instance of the Series class with a name and SeriesType.

[Visual Basic]
Public Function New( _
   ByVal name As String, _
   ByVal seriesType As SeriesType _
)
[C#]
public Series(
   string name,
   SeriesType seriesType
);

Parameters

name
Name of the series.
seriesType
Series type of the series.

See Also

Series Class | Series Members | Overload List


Series Class Methods

Series Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Series Class Members

For a list of all members of this type, see Series members.

Public Methods

Public Method static (Shared in Visual Basic) Add | Overloaded.
Public Method AddElements | Overloaded.
Public Method AddParameter | Adds a stored procedure when to use in conjunction with StoredProcedure.
Public Method Calculate | Performs a Calculation on current instance of this series.
Public Method static (Shared in Visual Basic) Divide | Overloaded.
Public Method static (Shared in Visual Basic) FromYValues | Overloaded.
Public Method GetSmartPalette | Overloaded.
Public Method static (Shared in Visual Basic) Multiply | Overloaded.
Public Method static (Shared in Visual Basic) op_Addition | Overloaded.
Public Method static (Shared in Visual Basic) op_Division | Overloaded.
Public Method static (Shared in Visual Basic) op_Multiply | Overloaded.
Public Method static (Shared in Visual Basic) op_Subtraction | Overloaded.
Public Method Sort | Overloaded.
Public Method static (Shared in Visual Basic) Subtract | Overloaded.
Public Method Trim | Overloaded.

See Also

Series Class | dotnetCHARTING Namespace


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

Adds a value to all elements in the rhs series.

[Visual Basic] Overloads Public Shared Function Add(Double,Series) As Series

[C#] public static Series Add(double,Series);

Adds a value to all elements in the rhs series.

[Visual Basic] Overloads Public Shared Function Add(Series,Double) As Series

[C#] public static Series Add(Series,double);

Adds two Series objects together.

[Visual Basic] Overloads Public Shared Function Add(Series,Series) As Series

[C#] public static Series Add(Series,Series);

See Also

Series Class | Series Members


Add(Double,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A double value.
rhs
A series.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Double,Series) Method

Adds a value to all elements in the rhs series.

[Visual Basic]
Overloads Public Shared Function Add( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series Add(
   double lhs,
   Series rhs
);

Parameters

lhs
A double value.
rhs
A series.

See Also

Series Class | Series Members | Overload List


Add(Series,Double) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A series.
rhs
A double value.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Series,Double) Method

Adds a value to all elements in the rhs series.

[Visual Basic]
Overloads Public Shared Function Add( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
[C#]
public static Series Add(
   Series lhs,
   double rhs
);

Parameters

lhs
A series.
rhs
A double value.

See Also

Series Class | Series Members | Overload List


Add(Series,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Left hand side Series.
rhs
Right hand side Series.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Series,Series) Method

Adds two Series objects together.

[Visual Basic]
Overloads Public Shared Function Add( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series Add(
   Series lhs,
   Series rhs
);

Parameters

lhs
Left hand side Series.
rhs
Right hand side Series.

Remarks

All element values such as YValue, XValue etc. are added based on element names. This means that only elements with the same name will be computed.

See Also

Series Class | Series Members | Overload List


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AddElements Method

Overload List

Adds the specified elements to this series.

[Visual Basic] Overloads Public Sub AddElements(ParamArray Element())

[C#] public void AddElements(params Element[]);

Adds the elements of the specified series to this series.

[Visual Basic] Overloads Public Sub AddElements(Series)

[C#] public void AddElements(Series);

See Also

Series Class | Series Members


AddElements(Element[]) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

elementList
A list of elements to add
See Also Languages dotnetCHARTING Send comments on this topic.

AddElements(Element[]) Method

Adds the specified elements to this series.

[Visual Basic]
Overloads Public Sub AddElements( _
   ByVal ParamArray elementList() As Element _
)
[C#]
public void AddElements(
   params Element[] elementList
);

Parameters

elementList
A list of elements to add

See Also

Series Class | Series Members | Overload List


AddElements(Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

fromSeries
Series whose elements will be added.
See Also Languages dotnetCHARTING Send comments on this topic.

AddElements(Series) Method

Adds the elements of the specified series to this series.

[Visual Basic]
Overloads Public Sub AddElements( _
   ByVal fromSeries As Series _
)
[C#]
public void AddElements(
   Series fromSeries
);

Parameters

fromSeries
Series whose elements will be added.

See Also

Series Class | Series Members | Overload List


AddParameter Method

Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class

Language

Visual Basic

C#

Show All

paramName
paramValue
paramType
See Also Languages dotnetCHARTING Send comments on this topic.

AddParameter Method

Adds a stored procedure when to use in conjunction with StoredProcedure.

[Visual Basic]
Public Sub AddParameter( _
   ByVal paramName As String, _
   ByVal paramValue As String, _
   ByVal paramType As FieldType _
)
[C#]
public void AddParameter(
   string paramName,
   string paramValue,
   FieldType paramType
);

Parameters

paramName
paramValue
paramType

Remarks

This method is optionally used in conjunction with the StoredProcedure property to specify any number of parameters for the stored proc. A number of field types are supported. de.AddParameter("MyParameter","MyValue",FieldType.Text)

See Also

Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class


Calculate Method

Series Class | Series Members

Language

Visual Basic

C#

Show All

name
Name of the returned element.
calculation
The calculation to perform.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate Method

Performs a Calculation on current instance of this series.

[Visual Basic]
Public Function Calculate( _
   ByVal name As String, _
   ByVal calculation As Calculation _
) As Element
[C#]
public Element Calculate(
   string name,
   Calculation calculation
);

Parameters

name
Name of the returned element.
calculation
The calculation to perform.

Return Type

Returns an Element object based on the specified Calculation.

See Also

Series Class | Series Members


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Divide Method

Overload List

Divides the value on the left by the series on the right.

[Visual Basic] Overloads Public Shared Function Divide(Double,Series) As Series

[C#] public static Series Divide(double,Series);

Divides the series on the left by the value on the right.

[Visual Basic] Overloads Public Shared Function Divide(Series,Double) As Series

[C#] public static Series Divide(Series,double);

Divides the element values of the series on the left by the element values of the series on the right.

[Visual Basic] Overloads Public Shared Function Divide(Series,Series) As Series

[C#] public static Series Divide(Series,Series);

See Also

Series Class | Series Members


Divide(Double,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Dividend number.
rhs
Divisor series.
See Also Languages dotnetCHARTING Send comments on this topic.

Divide(Double,Series) Method

Divides the value on the left by the series on the right.

[Visual Basic]
Overloads Public Shared Function Divide( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series Divide(
   double lhs,
   Series rhs
);

Parameters

lhs
Dividend number.
rhs
Divisor series.

See Also

Series Class | Series Members | Overload List


Divide(Series,Double) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Dividend series.
rhs
Divisor number.
See Also Languages dotnetCHARTING Send comments on this topic.

Divide(Series,Double) Method

Divides the series on the left by the value on the right.

[Visual Basic]
Overloads Public Shared Function Divide( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
[C#]
public static Series Divide(
   Series lhs,
   double rhs
);

Parameters

lhs
Dividend series.
rhs
Divisor number.

See Also

Series Class | Series Members | Overload List


Divide(Series,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Dividend series.
rhs
Divisor series.
See Also Languages dotnetCHARTING Send comments on this topic.

Divide(Series,Series) Method

Divides the element values of the series on the left by the element values of the series on the right.

[Visual Basic]
Overloads Public Shared Function Divide( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series Divide(
   Series lhs,
   Series rhs
);

Parameters

lhs
Dividend series.
rhs
Divisor series.

Remarks

All element values such as YValue, XValue etc. are divided based on element names. This means that only elements with the same name will be computed.

See Also

Series Class | Series Members | Overload List


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FromYValues Method

Overload List

Creates a series of element with the specified y values.

[Visual Basic] Overloads Public Shared Function FromYValues(ParamArray Double()) As Series

[C#] public static Series FromYValues(params double[]);

Creates a named series of element with the specified y values.

[Visual Basic] Overloads Public Shared Function FromYValues(String,ParamArray Double()) As Series

[C#] public static Series FromYValues(string,params double[]);

See Also

Series Class | Series Members


FromYValues(Double[]) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

yValues
YValues of resulting elements.
See Also Languages dotnetCHARTING Send comments on this topic.

FromYValues(Double[]) Method

Creates a series of element with the specified y values.

[Visual Basic]
Overloads Public Shared Function FromYValues( _
   ByVal ParamArray yValues() As Double _
) As Series
[C#]
public static Series FromYValues(
   params double[] yValues
);

Parameters

yValues
YValues of resulting elements.

See Also

Series Class | Series Members | Overload List


FromYValues(String,Double[]) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

name
Name of resulting Series.
yValues
YValues of resulting elements.
See Also Languages dotnetCHARTING Send comments on this topic.

FromYValues(String,Double[]) Method

Creates a named series of element with the specified y values.

[Visual Basic]
Overloads Public Shared Function FromYValues( _
   ByVal name As String, _
   ByVal ParamArray yValues() As Double _
) As Series
[C#]
public static Series FromYValues(
   string name,
   params double[] yValues
);

Parameters

name
Name of resulting Series.
yValues
YValues of resulting elements.

See Also

Series Class | Series Members | Overload List


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetSmartPalette Method

Overload List

Generates a SmartPalette object that contains the names of the elements in this Series matched with the specified array of Color objects.

[Visual Basic] Overloads Public Function GetSmartPalette(Color()) As SmartPalette

[C#] public SmartPalette GetSmartPalette(Color[]);

Generates a SmartPalette object that contains the names of the elements in this Series matched with the specified Palette enumeration.

[Visual Basic] Overloads Public Function GetSmartPalette(Palette) As SmartPalette

[C#] public SmartPalette GetSmartPalette(Palette);

See Also

Series Class | Series Members


GetSmartPalette(Color[]) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

colors
See Also Languages dotnetCHARTING Send comments on this topic.

GetSmartPalette(Color[]) Method

Generates a SmartPalette object that contains the names of the elements in this Series matched with the specified array of Color objects.

[Visual Basic]
Overloads Public Function GetSmartPalette( _
   ByVal colors() As Color _
) As SmartPalette
[C#]
public SmartPalette GetSmartPalette(
   Color[] colors
);

Parameters

colors

See Also

Series Class | Series Members | Overload List


GetSmartPalette(Palette) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

palette
See Also Languages dotnetCHARTING Send comments on this topic.

GetSmartPalette(Palette) Method

Generates a SmartPalette object that contains the names of the elements in this Series matched with the specified Palette enumeration.

[Visual Basic]
Overloads Public Function GetSmartPalette( _
   ByVal palette As Palette _
) As SmartPalette
[C#]
public SmartPalette GetSmartPalette(
   Palette palette
);

Parameters

palette

See Also

Series Class | Series Members | Overload List


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Multiply Method

Overload List

Multiplies a series by a value.

[Visual Basic] Overloads Public Shared Function Multiply(Double,Series) As Series

[C#] public static Series Multiply(double,Series);

Multiplies a series by a value.

[Visual Basic] Overloads Public Shared Function Multiply(Series,Double) As Series

[C#] public static Series Multiply(Series,double);

Multiplies two Series objects together.

[Visual Basic] Overloads Public Shared Function Multiply(Series,Series) As Series

[C#] public static Series Multiply(Series,Series);

See Also

Series Class | Series Members


Multiply(Double,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Number multiplied by.
rhs
Series multiplied by.
See Also Languages dotnetCHARTING Send comments on this topic.

Multiply(Double,Series) Method

Multiplies a series by a value.

[Visual Basic]
Overloads Public Shared Function Multiply( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series Multiply(
   double lhs,
   Series rhs
);

Parameters

lhs
Number multiplied by.
rhs
Series multiplied by.

See Also

Series Class | Series Members | Overload List


Multiply(Series,Double) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Series multiplied by.
rhs
Series multiplied by.
See Also Languages dotnetCHARTING Send comments on this topic.

Multiply(Series,Double) Method

Multiplies a series by a value.

[Visual Basic]
Overloads Public Shared Function Multiply( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
[C#]
public static Series Multiply(
   Series lhs,
   double rhs
);

Parameters

lhs
Series multiplied by.
rhs
Series multiplied by.

See Also

Series Class | Series Members | Overload List


Multiply(Series,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Left hand side Series.
rhs
Right hand side Series.
See Also Languages dotnetCHARTING Send comments on this topic.

Multiply(Series,Series) Method

Multiplies two Series objects together.

[Visual Basic]
Overloads Public Shared Function Multiply( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series Multiply(
   Series lhs,
   Series rhs
);

Parameters

lhs
Left hand side Series.
rhs
Right hand side Series.

Remarks

All element values such as YValue, XValue etc. are multiplied based on element names. This means that only elements with the same name will be computed.

See Also

Series Class | Series Members | Overload List


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Addition Method

Overload List

Adds a value to all elements in the rhs series.

[Visual Basic] Overloads Public Shared Function op_Addition(Double,Series) As Series

[C#] public static Series op_Addition(double,Series);

Adds a value to all elements in the rhs series.

[Visual Basic] Overloads Public Shared Function op_Addition(Series,Double) As Series

[C#] public static Series op_Addition(Series,double);

Adds two Series objects together.

[Visual Basic] Overloads Public Shared Function op_Addition(Series,Series) As Series

[C#] public static Series op_Addition(Series,Series);

See Also

Series Class | Series Members


op_Addition(Double,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A double value.
rhs
A series.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Addition(Double,Series) Method

Adds a value to all elements in the rhs series.

[Visual Basic]
Overloads Public Shared Function op_Addition( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series op_Addition(
   double lhs,
   Series rhs
);

Parameters

lhs
A double value.
rhs
A series.

See Also

Series Class | Series Members | Overload List


op_Addition(Series,Double) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
A series.
rhs
A double value.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Addition(Series,Double) Method

Adds a value to all elements in the rhs series.

[Visual Basic]
Overloads Public Shared Function op_Addition( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
[C#]
public static Series op_Addition(
   Series lhs,
   double rhs
);

Parameters

lhs
A series.
rhs
A double value.

See Also

Series Class | Series Members | Overload List


op_Addition(Series,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Left hand side Series.
rhs
Right hand side Series.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Addition(Series,Series) Method

Adds two Series objects together.

[Visual Basic]
Overloads Public Shared Function op_Addition( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series op_Addition(
   Series lhs,
   Series rhs
);

Parameters

lhs
Left hand side Series.
rhs
Right hand side Series.

Remarks

All element values such as YValue, XValue etc. are added based on element names. This means that only elements with the same name will be computed.

See Also

Series Class | Series Members | Overload List


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Division Method

Overload List

Divides the value on the left by the series on the right.

[Visual Basic] Overloads Public Shared Function op_Division(Double,Series) As Series

[C#] public static Series op_Division(double,Series);

Divides the series on the left by the value on the right.

[Visual Basic] Overloads Public Shared Function op_Division(Series,Double) As Series

[C#] public static Series op_Division(Series,double);

Divides the element values of the series on the left by the element values of the series on the right.

[Visual Basic] Overloads Public Shared Function op_Division(Series,Series) As Series

[C#] public static Series op_Division(Series,Series);

See Also

Series Class | Series Members


op_Division(Double,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Dividend number.
rhs
Divisor series.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Division(Double,Series) Method

Divides the value on the left by the series on the right.

[Visual Basic]
Overloads Public Shared Function op_Division( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series op_Division(
   double lhs,
   Series rhs
);

Parameters

lhs
Dividend number.
rhs
Divisor series.

See Also

Series Class | Series Members | Overload List


op_Division(Series,Double) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Dividend series.
rhs
Divisor number.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Division(Series,Double) Method

Divides the series on the left by the value on the right.

[Visual Basic]
Overloads Public Shared Function op_Division( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
[C#]
public static Series op_Division(
   Series lhs,
   double rhs
);

Parameters

lhs
Dividend series.
rhs
Divisor number.

See Also

Series Class | Series Members | Overload List


op_Division(Series,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Dividend series.
rhs
Divisor series.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Division(Series,Series) Method

Divides the element values of the series on the left by the element values of the series on the right.

[Visual Basic]
Overloads Public Shared Function op_Division( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series op_Division(
   Series lhs,
   Series rhs
);

Parameters

lhs
Dividend series.
rhs
Divisor series.

Remarks

All element values such as YValue, XValue etc. are divided based on element names. This means that only elements with the same name will be computed.

See Also

Series Class | Series Members | Overload List


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Multiply Method

Overload List

Multiplies a series by a value.

[Visual Basic] Overloads Public Shared Function op_Multiply(Double,Series) As Series

[C#] public static Series op_Multiply(double,Series);

Multiplies a series by a value.

[Visual Basic] Overloads Public Shared Function op_Multiply(Series,Double) As Series

[C#] public static Series op_Multiply(Series,double);

Multiplies two Series objects together.

[Visual Basic] Overloads Public Shared Function op_Multiply(Series,Series) As Series

[C#] public static Series op_Multiply(Series,Series);

See Also

Series Class | Series Members


op_Multiply(Double,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Number multiplied by.
rhs
Series multiplied by.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Multiply(Double,Series) Method

Multiplies a series by a value.

[Visual Basic]
Overloads Public Shared Function op_Multiply( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series op_Multiply(
   double lhs,
   Series rhs
);

Parameters

lhs
Number multiplied by.
rhs
Series multiplied by.

See Also

Series Class | Series Members | Overload List


op_Multiply(Series,Double) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Series multiplied by.
rhs
Series multiplied by.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Multiply(Series,Double) Method

Multiplies a series by a value.

[Visual Basic]
Overloads Public Shared Function op_Multiply( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
[C#]
public static Series op_Multiply(
   Series lhs,
   double rhs
);

Parameters

lhs
Series multiplied by.
rhs
Series multiplied by.

See Also

Series Class | Series Members | Overload List


op_Multiply(Series,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Left hand side Series.
rhs
Right hand side Series.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Multiply(Series,Series) Method

Multiplies two Series objects together.

[Visual Basic]
Overloads Public Shared Function op_Multiply( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series op_Multiply(
   Series lhs,
   Series rhs
);

Parameters

lhs
Left hand side Series.
rhs
Right hand side Series.

Remarks

All element values such as YValue, XValue etc. are multiplied based on element names. This means that only elements with the same name will be computed.

See Also

Series Class | Series Members | Overload List


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Subtraction Method

Overload List

Subtracts all element values from the left hand side number.

[Visual Basic] Overloads Public Shared Function op_Subtraction(Double,Series) As Series

[C#] public static Series op_Subtraction(double,Series);

Subtracts the number on the right hand side from the element values of the series on the left.

[Visual Basic] Overloads Public Shared Function op_Subtraction(Series,Double) As Series

[C#] public static Series op_Subtraction(Series,double);

Subtracts the element values of series on the right from the series on the left.

[Visual Basic] Overloads Public Shared Function op_Subtraction(Series,Series) As Series

[C#] public static Series op_Subtraction(Series,Series);

See Also

Series Class | Series Members


op_Subtraction(Double,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Number subtracted from.
rhs
Series subtracted by.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Subtraction(Double,Series) Method

Subtracts all element values from the left hand side number.

[Visual Basic]
Overloads Public Shared Function op_Subtraction( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series op_Subtraction(
   double lhs,
   Series rhs
);

Parameters

lhs
Number subtracted from.
rhs
Series subtracted by.

See Also

Series Class | Series Members | Overload List


op_Subtraction(Series,Double) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Series subtracted from.
rhs
Number subtracted by.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Subtraction(Series,Double) Method

Subtracts the number on the right hand side from the element values of the series on the left.

[Visual Basic]
Overloads Public Shared Function op_Subtraction( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
[C#]
public static Series op_Subtraction(
   Series lhs,
   double rhs
);

Parameters

lhs
Series subtracted from.
rhs
Number subtracted by.

See Also

Series Class | Series Members | Overload List


op_Subtraction(Series,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Series subtracted from.
rhs
Series subtracted by.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Subtraction(Series,Series) Method

Subtracts the element values of series on the right from the series on the left.

[Visual Basic]
Overloads Public Shared Function op_Subtraction( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series op_Subtraction(
   Series lhs,
   Series rhs
);

Parameters

lhs
Series subtracted from.
rhs
Series subtracted by.

Remarks

All element values such as YValue, XValue etc. are subtracted based on element names. This means that only elements with the same name will be computed.

See Also

Series Class | Series Members | Overload List


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Sort Method

Overload List

Sorts the Elements based on an element property and order.

[Visual Basic] Overloads Public Sub Sort(ElementValue,String)

[C#] public void Sort(ElementValue,string);

Sorts the Elements based on an element property and order from the start index to the end index.

[Visual Basic] Overloads Public Sub Sort(ElementValue,String,Integer,Integer)

[C#] public void Sort(ElementValue,string,int,int);

See Also

Series Class | Series Members


Sort(ElementValue,String) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

ev
order
See Also Languages dotnetCHARTING Send comments on this topic.

Sort(ElementValue,String) Method

Sorts the Elements based on an element property and order.

[Visual Basic]
Overloads Public Sub Sort( _
   ByVal ev As ElementValue, _
   ByVal order As String _
)
[C#]
public void Sort(
   ElementValue ev,
   string order
);

Parameters

ev
order

See Also

Series Class | Series Members | Overload List


Sort(ElementValue,String,Int32,Int32) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

ev
ElementValue to sort by.
order
Takes "Desc" or "Asc" as inputs. If the string is not recognized "Asc" will be used.
startIndex
Index at which sorting starts.
endIndex
Index at which sorting stops.
See Also Languages dotnetCHARTING Send comments on this topic.

Sort(ElementValue,String,Int32,Int32) Method

Sorts the Elements based on an element property and order from the start index to the end index.

[Visual Basic]
Overloads Public Sub Sort( _
   ByVal ev As ElementValue, _
   ByVal order As String, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
)
[C#]
public void Sort(
   ElementValue ev,
   string order,
   int startIndex,
   int endIndex
);

Parameters

ev
ElementValue to sort by.
order
Takes "Desc" or "Asc" as inputs. If the string is not recognized "Asc" will be used.
startIndex
Index at which sorting starts.
endIndex
Index at which sorting stops.

See Also

Series Class | Series Members | Overload List


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Subtract Method

Overload List

Subtracts all element values from the left hand side number.

[Visual Basic] Overloads Public Shared Function Subtract(Double,Series) As Series

[C#] public static Series Subtract(double,Series);

Subtracts the number on the right hand side from the element values of the series on the left.

[Visual Basic] Overloads Public Shared Function Subtract(Series,Double) As Series

[C#] public static Series Subtract(Series,double);

Subtracts the element values of series on the right from the series on the left.

[Visual Basic] Overloads Public Shared Function Subtract(Series,Series) As Series

[C#] public static Series Subtract(Series,Series);

See Also

Series Class | Series Members


Subtract(Double,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Number subtracted from.
rhs
Series subtracted by.
See Also Languages dotnetCHARTING Send comments on this topic.

Subtract(Double,Series) Method

Subtracts all element values from the left hand side number.

[Visual Basic]
Overloads Public Shared Function Subtract( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series Subtract(
   double lhs,
   Series rhs
);

Parameters

lhs
Number subtracted from.
rhs
Series subtracted by.

See Also

Series Class | Series Members | Overload List


Subtract(Series,Double) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Series subtracted from.
rhs
Number subtracted by.
See Also Languages dotnetCHARTING Send comments on this topic.

Subtract(Series,Double) Method

Subtracts the number on the right hand side from the element values of the series on the left.

[Visual Basic]
Overloads Public Shared Function Subtract( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
[C#]
public static Series Subtract(
   Series lhs,
   double rhs
);

Parameters

lhs
Series subtracted from.
rhs
Number subtracted by.

See Also

Series Class | Series Members | Overload List


Subtract(Series,Series) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Series subtracted from.
rhs
Series subtracted by.
See Also Languages dotnetCHARTING Send comments on this topic.

Subtract(Series,Series) Method

Subtracts the element values of series on the right from the series on the left.

[Visual Basic]
Overloads Public Shared Function Subtract( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
[C#]
public static Series Subtract(
   Series lhs,
   Series rhs
);

Parameters

lhs
Series subtracted from.
rhs
Series subtracted by.

Remarks

All element values such as YValue, XValue etc. are subtracted based on element names. This means that only elements with the same name will be computed.

See Also

Series Class | Series Members | Overload List


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Trim Method

Overload List

Trims elements out of this series based on a specified CalendarPattern and element property.

[Visual Basic] Overloads Public Sub Trim(CalendarPattern,ElementValue)

[C#] public void Trim(CalendarPattern,ElementValue);

Trims elements out of this series based on a specified time range and element property.

[Visual Basic] Overloads Public Sub Trim(Date,Date,ElementValue)

[C#] public void Trim(DateTime,DateTime,ElementValue);

Trims elements out of this series based on a specified numeric range and element property.

[Visual Basic] Overloads Public Sub Trim(Double,Double,ElementValue)

[C#] public void Trim(double,double,ElementValue);

Trims the elements with values outside the specified dotnetCHARTING.ScaleRange.

[Visual Basic] Overloads Public Sub Trim(ScaleRange,ElementValue)

[C#] public void Trim(ScaleRange,ElementValue);

See Also

Series Class | Series Members


Trim(CalendarPattern,ElementValue) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

cp
CalendarPattern used to trim the series.
ev
ElementValue to match against the calendar pattern.
See Also Languages dotnetCHARTING Send comments on this topic.

Trim(CalendarPattern,ElementValue) Method

Trims elements out of this series based on a specified CalendarPattern and element property.

[Visual Basic]
Overloads Public Sub Trim( _
   ByVal cp As CalendarPattern, _
   ByVal ev As ElementValue _
)
[C#]
public void Trim(
   CalendarPattern cp,
   ElementValue ev
);

Parameters

cp
CalendarPattern used to trim the series.
ev
ElementValue to match against the calendar pattern.

See Also

Series Class | Series Members | Overload List


Trim(DateTime,DateTime,ElementValue) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

Low
DateTime minimum of the range.
High
DateTime maximum of the range.
ev
The ElementValue the range is compared to.
See Also Languages dotnetCHARTING Send comments on this topic.

Trim(DateTime,DateTime,ElementValue) Method

Trims elements out of this series based on a specified time range and element property.

[Visual Basic]
Overloads Public Sub Trim( _
   ByVal Low As Date, _
   ByVal High As Date, _
   ByVal ev As ElementValue _
)
[C#]
public void Trim(
   DateTime Low,
   DateTime High,
   ElementValue ev
);

Parameters

Low
DateTime minimum of the range.
High
DateTime maximum of the range.
ev
The ElementValue the range is compared to.

Remarks

The ElementValue specified must be a DateTime property.

See Also

Series Class | Series Members | Overload List


Trim(Double,Double,ElementValue) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

Low
Numeric minimum of the range.
High
Numeric maximum of the range.
ev
The ElementValue the range is compared to.
See Also Languages dotnetCHARTING Send comments on this topic.

Trim(Double,Double,ElementValue) Method

Trims elements out of this series based on a specified numeric range and element property.

[Visual Basic]
Overloads Public Sub Trim( _
   ByVal Low As Double, _
   ByVal High As Double, _
   ByVal ev As ElementValue _
)
[C#]
public void Trim(
   double Low,
   double High,
   ElementValue ev
);

Parameters

Low
Numeric minimum of the range.
High
Numeric maximum of the range.
ev
The ElementValue the range is compared to.

Remarks

The ElementValue specified must be a numeric property.

See Also

Series Class | Series Members | Overload List


Trim(ScaleRange,ElementValue) Method

Series Class | Series Members | Overload List

Language

Visual Basic

C#

Show All

range
Range outside of which to trim elements.
ev
The ElementValue the range is compared to.
See Also Languages dotnetCHARTING Send comments on this topic.

Trim(ScaleRange,ElementValue) Method

Trims the elements with values outside the specified dotnetCHARTING.ScaleRange.

[Visual Basic]
Overloads Public Sub Trim( _
   ByVal range As ScaleRange, _
   ByVal ev As ElementValue _
)
[C#]
public void Trim(
   ScaleRange range,
   ElementValue ev
);

Parameters

range
Range outside of which to trim elements.
ev
The ElementValue the range is compared to.

See Also

Series Class | Series Members | Overload List


Series Class Properties

Series Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Series Class Members

For a list of all members of this type, see Series members.

Public Properties

Public Property Background | Gets or sets the background object used to fill a gauge face or radar associated with this series.
Public Property CommandTimeout | Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Public Property ConnectionString | Sets the database connection string used when dynamically obtaining charting data from a SQL statement.
Public Property Data | Gets or sets a DataTable, DataSet, DataView, OleDbDataReader, SqlDataReader, IDataReader, XML file name, or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.
Public Property DataFields | Gets or sets a value that specifies the 'database column' to 'chart data' relationship.
Public Property DefaultElement | Gets or sets the an Element object whose properties will trickle to all elements within this series.
Public Property Element | Gets or sets an Element object which facilitates a shortcut for adding elements to the chart.
Public Property Elements | Gets or sets a collection of Element objects associated with this series.
Public Property EmptyElement | Gets or sets an EmptyElement object associated with this series.
Public Property EndDate | The ending date used with SqlStatement to query filtered data from a database.
Public Property HatchStylePalette | Gets or sets the hatch style palette used be the Elements of this series.
Public Property HatchStylePaletteName | Gets or sets a Palette boolean which indicates which static palette will be used be the Elements of this series. Note If used, legend behavior will be different.
Public Property InstanceID |
Public Property Item | Gets or sets an Element of this Series at a specified index.
Public Property LegendEntry | Gets or sets the legend entry properties of this series.
Public Property Limit | Gets or sets the limit number of elements returned for this series when data is generated.
Public Property LimitMode | Determine the type of limitation for Limit and SplitByLimit properties. Default is Top.
Public Property Line | Gets or sets the line properties of this series.
Public Property Name | Gets or sets the name of this series.
Public Property OtherElementText | Controls the label used for the aggregated datapoint / series created when using Limit or SplitByLimit and setting ShowOther to true.
Public Property Palette | Gets or sets the palette which will be used be the Elements of this series. Note If used, legend behavior will be different.
Public Property PaletteName | Gets or sets a Palette boolean which indicates which static palette will be used be the Elements of this series. Note If used, legend behavior will be different.
Public Property ParameterCollection | Gets or sets a collection of Parameter objects used in conjunction with StoredProcedure
Public Property Position | Gets or sets the position of this series in relation to other series when the chart is drawn.
Public Property ShowOther | This property controls if the additional series not shown due to the use of SplitByLimit, or the additional elements not shown due to the use of Limit are aggregated into a single series / element and graphed alongside the top x series / elements.
Public Property SplineTensionPercent | Gets or sets a value between 0 and 100 that specifies the tension of a spline curve.
Public Property SplitByLimit | Gets or sets the number of series created using SplitBy.
Public Property SqlStatement | The SQL statement used to obtain the charting data.
Public Property StartDate | The starting date used with SqlStatement to query filtered data from a database.
Public Property StoredProcedure | This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.
Public Property TotalElements | Return the total number of elements in the elements collection. This property usually used in conjunction with Limit.
Public Property Type | Gets or sets the type of this series.
Public Property Visible | Gets or sets a value which indicates whether the series is visible.
Public Property XAxis | Gets or sets the x axis for this series.
Public Property YAxis | Gets or sets the y axis for this series.

See Also

Series Class | dotnetCHARTING Namespace


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Background Property

Gets or sets the background object used to fill a gauge face or radar associated with this series.

[Visual Basic]
Public Property Background As Background
[C#]
public Background Background {get; set;}

Remarks

When using ChartType.Radar (single radar) use Chart.DefaultSeries.Background to control the radar background.

See Also

Series Class | Series Members


Series Class | Series Members | DataEngine Class

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CommandTimeout Property

Gets or sets the wait time before terminating the attempt to execute a command and generating an error.

[Visual Basic]
Public Property CommandTimeout As Integer
[C#]
public int CommandTimeout {get; set;}

Example

The follwoing example set the command timeout to 45 seconds.

[C#]

Chart.Series.CommandTimeout=45;

[Visual Basic]

Chart.Series.CommandTimeout=45

See Also

Series Class | Series Members | DataEngine Class


Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ConnectionString Property

Sets the database connection string used when dynamically obtaining charting data from a SQL statement.

[Visual Basic]
Public Property ConnectionString As String
[C#]
public string ConnectionString {get; set;}

Remarks

This can be overridden or used in combination with the series level connectionstring. Access, Excel and SQL server are supported and automatically detected based on the connection string specified. See Getting Started > Tutorials > Connecting to data.

Example

[C#]

// This will set the Access connection string default for all series.
Chart.DefaultSeries.ConnectionString = @"c:\chartsample.mdb";

//This will set the SQL server connection string default to all series:
Chart.DefaultSeries.ConnectionString ="server=server name or IP;uid=username;pwd=password;database=database name";

[Visual Basic]

'This will Set the Access connection String Default For all series.
Chart.DefaultSeries.ConnectionString = "c:\chartsample.mdb"

'This will Set the SQL server connection String Default To all series:
Chart.DefaultSeries.ConnectionString ="server=server name or IP;uid=username;pwd=password;database=database name"

See Also

Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class


Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Data Property

Gets or sets a DataTable, DataSet, DataView, OleDbDataReader, SqlDataReader, IDataReader, XML file name, or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.

[Visual Basic]
Public Property Data As Object
[C#]
public object Data {get; set;}

Remarks

When not connecting to a database directly using ConnectionString and SqlStatement, this property can be used to supply objects with data.

Example

Adds data based on the myDataTable .

[C#]

Chart.Series.Data = myDataTable;
Chart.Series.DataFields = "XAxis=FirstCol,YAxis=SecondCol";
Chart.SeriesCollection.Add();

[Visual Basic]

Chart.Series.Data = myDataTable
Chart.Series.DataFields = "FirstCol=XAxis,SecondCol=YAxis"
Chart.SeriesCollection.Add()

See Also

Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class


Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataFields Property

Gets or sets a value that specifies the 'database column' to 'chart data' relationship.

[Visual Basic]
Public Property DataFields As String
[C#]
public string DataFields {get; set;}

Remarks

When programmatically setting a datatable or dataset, certain columns are expected with specific names. This property allows you to control the expected names.

See Getting Started > Tutorials > Data Fields for more info.

Example

[C#]

Chart.Series.DataFields="xAxis=field1,yAxis=field2,splitby=field3";

[Visual Basic]

Chart.Series.DataFields="xAxis=field1,yAxis=field2,splitby=field3"

See Also

Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DefaultElement Property

Gets or sets the an Element object whose properties will trickle to all elements within this series.

[Visual Basic]
Public Property DefaultElement As Element
[C#]
public Element DefaultElement {get; set;}

Remarks

The properties of this element instance will trickle down to all elements within this series unless explicitly set for any particular element.

See Also

Series Class | Series Members


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Element Property

Gets or sets an Element object which facilitates a shortcut for adding elements to the chart.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}

Example

Add a single element to the chart collection.

[C#]

Chart.Series.Element.YValue = 10;
Chart.Series.Element.Name = "Element 1";
Chart.Series.Elements.Add();
Chart.SeriesCollection.Add();

[Visual Basic]

Chart.Series.Element.YValue = 10
Chart.Series.Element.Name = "Element 1"
Chart.Series.Elements.Add()
Chart.SeriesCollection.Add()

See Also

Series Class | Series Members


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Elements Property

Gets or sets a collection of Element objects associated with this series.

[Visual Basic]
Public ReadOnly Property Elements As ElementCollection
[C#]
public ElementCollection Elements {get;}

See Also

Series Class | Series Members


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

EmptyElement Property

Gets or sets an EmptyElement object associated with this series.

[Visual Basic]
Public Property EmptyElement As EmptyElement
[C#]
public EmptyElement EmptyElement {get; set;}

Remarks

The properties of this empty element apply to all elements in the Elements collection.

See Also

Series Class | Series Members


Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

EndDate Property

The ending date used with SqlStatement to query filtered data from a database.

[Visual Basic]
Public Property EndDate As Date
[C#]
public DateTime EndDate {get; set;}

Remarks

This property affects the date listed in the title when ShowDateInTitle is used, it is also used for the SqlStatement property where the #EndDate# token is replaced with the value set to this property.

Example

[C#]

Chart.Series.StartDate = new DateTime(2004,12,10);

[Visual Basic]

Chart.Series.StartDate = New DateTime(2004,12,10)

See Also

Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HatchStylePalette Property

Gets or sets the hatch style palette used be the Elements of this series.

[Visual Basic]
Public Property HatchStylePalette As HatchStyle()
[C#]
public HatchStyle[] HatchStylePalette {get; set;}

See Also

Series Class | Series Members


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HatchStylePaletteName Property

Gets or sets a Palette boolean which indicates which static palette will be used be the Elements of this series.

Note If used, legend behavior will be different.

[Visual Basic]
Public Property HatchStylePaletteName As HatchStylePalette
[C#]
public HatchStylePalette HatchStylePaletteName {get; set;}

See Also

Series Class | Series Members


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InstanceID Property

[Visual Basic]
Public Property InstanceID As Integer
[C#]
public int InstanceID {get; set;}

See Also

Series Class | Series Members


Item Property

Series Class | Series Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets an Element of this Series at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Element
[C#]
public Element this[
   int index
]; {get; set;}

Parameters

index

See Also

Series Class | Series Members


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntry Property

Gets or sets the legend entry properties of this series.

[Visual Basic]
Public Property LegendEntry As LegendEntry
[C#]
public LegendEntry LegendEntry {get; set;}

See Also

Series Class | Series Members


Series Class | Series Members | Limit Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Limit Property

Gets or sets the limit number of elements returned for this series when data is generated.

[Visual Basic]
Public Property Limit As String
[C#]
public string Limit {get; set;}

Remarks

This property determines the number of elements to include in the limited return in conjuction with LimitMode property. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group positon and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum elements.

Note: If DateGrouping is used limit has no effect, you can limit the return with the StartDate and EndDate in such a case.

See also: Getting Started > Tutorials > Data Engine.

Example

[C#]

Series.Limit = "10";
Series.Limit = "2x10";

[Visual Basic]

Series.Limit = "10"
Series.Limit = "2x10"

See Also

Series Class | Series Members | Limit Property


Series Class | Series Members | LimitMode

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LimitMode Property

Determine the type of limitation for Limit and SplitByLimit properties. Default is Top.

[Visual Basic]
Public Property LimitMode As LimitMode
[C#]
public LimitMode LimitMode {get; set;}

Remarks

This property works in conjunction with Limit or SplitByLimit to determine which elements or series should be included or excluded.

Example

The following setting returns the number of minimum elements or series.

[C#]

series.LimitMode = LimitMode.Bottom;

[Visual Basic]

series.LimitMode = LimitMode.Bottom

See Also

Series Class | Series Members | LimitMode


Series Class | Series Members | Line Class

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Property

Gets or sets the line properties of this series.

[Visual Basic]
Public Property Line As Line
[C#]
public Line Line {get; set;}

Remarks

This line object is used when the SeriesType of this series is Line, Spline, or AreaLine and Use3D is false.

See Also

Series Class | Series Members | Line Class


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Name Property

Gets or sets the name of this series.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

See Also

Series Class | Series Members


Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

OtherElementText Property

Controls the label used for the aggregated datapoint / series created when using Limit or SplitByLimit and setting ShowOther to true.

[Visual Basic]
Public Property OtherElementText As String
[C#]
public string OtherElementText {get; set;}

Remarks

See Getting Started > Tutorials > Data Engine for more info.

See Also

Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Palette Property

Gets or sets the palette which will be used be the Elements of this series.

Note If used, legend behavior will be different.

[Visual Basic]
Public Property Palette As Color()
[C#]
public Color[] Palette {get; set;}

Remarks

When setting this property, each element will get it's own color. Whereas by default, all elements within a series take their color from Series.DefaultElement.Color. When the chart detects that the elements have been individually colored, each element's LegendEntry will replace the single legend entry of the series in the legend box.

See Also

Series Class | Series Members


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PaletteName Property

Gets or sets a Palette boolean which indicates which static palette will be used be the Elements of this series.

Note If used, legend behavior will be different.

[Visual Basic]
Public Property PaletteName As Palette
[C#]
public Palette PaletteName {get; set;}

Remarks

When setting this property, each element will get it's own color. Whereas by default, all elements within a series take their color from Series.DefaultElement.Color. When the chart detects that the elements have been individually colored, each element's LegendEntry will replace the single legend entry of the series in the legend box.

See Also

Series Class | Series Members


Series Class | Series Members | DataEngine Class | AddParameter Method | DataEngine Class | AddParameter Method | DataEngine Class | AddParameter Method | DataEngine Class | AddParameter Method

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ParameterCollection Property

Gets or sets a collection of Parameter objects used in conjunction with StoredProcedure

[Visual Basic]
Public ReadOnly Property ParameterCollection As ParameterCollection
[C#]
public ParameterCollection ParameterCollection {get;}

See Also

Series Class | Series Members | DataEngine Class | AddParameter Method | DataEngine Class | AddParameter Method | DataEngine Class | AddParameter Method | DataEngine Class | AddParameter Method


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Position Property

Gets or sets the position of this series in relation to other series when the chart is drawn.

[Visual Basic]
Public Property Position As Integer
[C#]
public int Position {get; set;}

Remarks

Series with lower position values will be drawn closer to the front.

See Also

Series Class | Series Members


Series Class | Series Members | ShowOther Property | ShowOther Property | ShowOther Property | ShowOther Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ShowOther Property

This property controls if the additional series not shown due to the use of SplitByLimit, or the additional elements not shown due to the use of Limit are aggregated into a single series / element and graphed alongside the top x series / elements.

[Visual Basic]
Public Property ShowOther As Boolean
[C#]
public bool ShowOther {get; set;}

Remarks

See Gettings Started > Tutorials > Data Engine for more info.

The default is false.

See Also

Series Class | Series Members | ShowOther Property | ShowOther Property | ShowOther Property | ShowOther Property


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SplineTensionPercent Property

Gets or sets a value between 0 and 100 that specifies the tension of a spline curve.

[Visual Basic]
Public Property SplineTensionPercent As Integer
[C#]
public int SplineTensionPercent {get; set;}

See Also

Series Class | Series Members


Series Class | Series Members | DataEngine Class | LimitMode Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SplitByLimit Property

Gets or sets the number of series created using SplitBy.

[Visual Basic]
Public Property SplitByLimit As String
[C#]
public string SplitByLimit {get; set;}

Remarks

This property works with conjunction of LimitMode property and determines the number of series to include in the return. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group positon and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum series.

Example

[C#]

de.SplitByLimit="3";
de.SplitByLimit="2x3";

[Visual Basic]

de.SplitByLimit="3"
de.SplitByLimit="2x3"

See Also

Series Class | Series Members | DataEngine Class | LimitMode Property


Series Class | Series Members | DataEngine Class | SqlStatement Property | DataEngine Class | SqlStatement Property | DataEngine Class | SqlStatement Property

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SqlStatement Property

The SQL statement used to obtain the charting data.

[Visual Basic]
Public Property SqlStatement As String
[C#]
public string SqlStatement {get; set;}

Remarks

The first column returned is used for the X values, and the second for the Y values. The first also has special handling if dates are returned as the DateGrouping property can be used for intelligent date handling and grouping. The third column is optional and is used only for SplitBy. When a third column is set it is used automatically to create a unique series based on each unique value in this column.

NOTE: All date values in your SQL statements should be wrapped with the pound symbol: #10/25/2002#, regardless if Access or SQL server is used. Also the #StartDate# and #EndDate# tokens can be used in which case the dates set for these properties will be set in place of the tokens before the SqlStatement is executed.

Example

[C#]

series.Series.SqlStatement = "SELECT OrderDate,Total FROM Orders";

//If you are doing a SplitBy you would need another field to correspond to your SplitBy value i.e.
series.Series.SqlStatement = "SELECT OrderDate,Total,Customer FROM Orders" ;

[Visual Basic]

series.Series.SqlStatement = "SELECT OrderDate,Total FROM Orders"

'If you are doing a SplitBy you would need another field To correspond To your SplitBy value i.e.
series.Series.SqlStatement = "SELECT OrderDate,Total,Customer FROM Orders"

See Also

Series Class | Series Members | DataEngine Class | SqlStatement Property | DataEngine Class | SqlStatement Property | DataEngine Class | SqlStatement Property


Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StartDate Property

The starting date used with SqlStatement to query filtered data from a database.

[Visual Basic]
Public Property StartDate As Date
[C#]
public DateTime StartDate {get; set;}

Remarks

This property affects the date listed in the title when ShowDateInTitle is used, it is also used for the SqlStatement property where the #StartDate# token is replaced with the value set to this property.

Example

[C#]

Chart.Series.StartDate = new DateTime(2004,12,10);

[Visual Basic]

Chart.Series.StartDate = New DateTime(2004,12,10)

See Also

Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class


Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StoredProcedure Property

This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.

[Visual Basic]
Public Property StoredProcedure As String
[C#]
public string StoredProcedure {get; set;}

Remarks

See the SqlStatement property for details on how the return columns are expected. Stored Procedures also work with parameters, see the AddParameter method.

See Also

Series Class | Series Members | DataEngine Class | DataEngine Class | DataEngine Class | DataEngine Class


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TotalElements Property

Return the total number of elements in the elements collection. This property usually used in conjunction with Limit.

[Visual Basic]
Public ReadOnly Property TotalElements As Integer
[C#]
public int TotalElements {get;}

Example

[C#]

int pageSize=3;
int totalPage = Chart.Total%pageSize==0?Chart.Total/pageSize:(Chart.Total/pageSize)+1;
if(totalPage>currentPage)
{
//Display "Next" button.
}

[Visual Basic]

Dim pageSize As Integer = 3
Dim totalPage As Integer = Chart.Total / pageSize;
If Chart.Total Mod pageSize > 0 Then
totalPage = totalPage + 1)
End If
If totalPage > currentPage Then
'Display "Next" button.
End If

See Also

Series Class | Series Members


Series Class | Series Members | ChartType Enumeration

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Type Property

Gets or sets the type of this series.

[Visual Basic]
Public Property Type As Object
[C#]
public object Type {get; set;}

Remarks

This property accepts string, SeriesType, or !UNRECOGNISED ELEMENT TYPE 'dotnetCHARTING.SeriesTypeFinancial'! enumeration.

See Also

Series Class | Series Members | ChartType Enumeration


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Visible Property

Gets or sets a value which indicates whether the series is visible.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

Remarks

This property is only valid when set through Chart.Series.Visible. Setting this property on a lone Series object would have no effect.

See Also

Series Class | Series Members


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

XAxis Property

Gets or sets the x axis for this series.

[Visual Basic]
Public Property XAxis As Axis
[C#]
public Axis XAxis {get; set;}

See Also

Series Class | Series Members


Series Class | Series Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

YAxis Property

Gets or sets the y axis for this series.

[Visual Basic]
Public Property YAxis As Axis
[C#]
public Axis YAxis {get; set;}

See Also

Series Class | Series Members


SeriesCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SeriesCollection Class

Contains a collection of Series objects.

For a list of all members of this type, see SeriesCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.SeriesCollection

Syntax

[Visual Basic]
Public Class SeriesCollection
   Inherits CollectionBase
   Implements IInstanceID
[C#]
public class SeriesCollection : CollectionBase, IInstanceID

Remarks

This class can also perform calculations and data manipulation on the series it contains.

See also: Data Model Tutorial

See Also

SeriesCollection Members | dotnetCHARTING Namespace


SeriesCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SeriesCollection Class Members

SeriesCollection overview

Public Constructors

Public Constructor SeriesCollection Constructor Overloaded.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property InstanceID |
Public Property Item | Gets or sets the Series at a specified index.
Public Property SmartPalette | Gets or sets a SmartPalette object that will determine the colors of series in this SeriesCollection.

Public Methods

Public Method Add | Overloaded.
Public Method Calculate | Overloaded.
Public Method CalculateElement | Performs a calculation on this collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Series.
Public Method GetAxisSeries | Gets a collection of series associated with the specified axis.
Public Method GetElement | Overloaded.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method GetProcessedDataTable | Overloaded.
Public Method GetSeries | Retrieves the named Series.
Public Method GetSmartPalette | Overloaded.
Public Method GroupByElements | Groups series into even element groups where every element will have a matching element in all other series.
Public Method Insert | Inserts a series into this collection at a specified index.
Public Method Remove | Removes a specified series from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |
Public Method Sort | Sorts the Series based on an element property and order.
Public Method ToString | Overridden.
Public Method Transpose | Overloaded.

See Also

SeriesCollection Class | dotnetCHARTING Namespace


SeriesCollection Class | SeriesCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SeriesCollection Constructor

Overload List

Initializes a new instance of the SeriesCollection class.

[Visual Basic] Public Sub New()

[C#] public SeriesCollection();

Initializes a new instance of the SeriesCollection class and adds the specified series to it.

[Visual Basic] Public Sub New(ParamArray Series())

[C#] public SeriesCollection(params Series[]);

See Also

SeriesCollection Class | SeriesCollection Members


SeriesCollection Class | SeriesCollection Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SeriesCollection Constructor()

Initializes a new instance of the SeriesCollection class.

[Visual Basic]
Public Function New()
[C#]
public SeriesCollection();

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


SeriesCollection Constructor(Series[])

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

seriesList
List of Series to add to the collection.
See Also Languages dotnetCHARTING Send comments on this topic.

SeriesCollection Constructor(Series[])

Initializes a new instance of the SeriesCollection class and adds the specified series to it.

[Visual Basic]
Public Function New( _
   ByVal ParamArray seriesList() As Series _
)
[C#]
public SeriesCollection(
   params Series[] seriesList
);

Parameters

seriesList
List of Series to add to the collection.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


SeriesCollection Class Methods

SeriesCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SeriesCollection Class Members

For a list of all members of this type, see SeriesCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Calculate | Overloaded.
Public Method CalculateElement | Performs a calculation on this collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified Series.
Public Method GetAxisSeries | Gets a collection of series associated with the specified axis.
Public Method GetElement | Overloaded.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method GetProcessedDataTable | Overloaded.
Public Method GetSeries | Retrieves the named Series.
Public Method GetSmartPalette | Overloaded.
Public Method GroupByElements | Groups series into even element groups where every element will have a matching element in all other series.
Public Method Insert | Inserts a series into this collection at a specified index.
Public Method Remove | Removes a specified series from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |
Public Method Sort | Sorts the Series based on an element property and order.
Public Method ToString | Overridden.
Public Method Transpose | Overloaded.

See Also

SeriesCollection Class | dotnetCHARTING Namespace


SeriesCollection Class | SeriesCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

Provided as a shortcut for adding elements, series, and series collections the chart SeriesCollection.

[Visual Basic] Overloads Public Function Add() As Integer

[C#] public int Add();

Adds a series to the collection based on the specified calculation.

[Visual Basic] Overloads Public Function Add(Calculation) As Integer

[C#] public int Add(Calculation);

Adds a series calculated from a specified series.

[Visual Basic] Overloads Public Function Add(Calculation,String) As Integer

[C#] public int Add(Calculation,string);

Adds a specified Series class to this collection.

[Visual Basic] Overloads Public Function Add(Series) As Integer

[C#] public int Add(Series);

Adds the specified Series objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray Series())

[C#] public void Add(params Series[]);

Adds a specified SeriesCollection to this collection.

[Visual Basic] Overloads Public Function Add(SeriesCollection) As Integer

[C#] public int Add(SeriesCollection);

Adds Series of the specified SeriesCollection objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray SeriesCollection())

[C#] public void Add(params SeriesCollection[]);

See Also

SeriesCollection Class | SeriesCollection Members


SeriesCollection Class | SeriesCollection Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add() Method

Provided as a shortcut for adding elements, series, and series collections the chart SeriesCollection.

[Visual Basic]
Overloads Public Function Add() As Integer
[C#]
public int Add();

Example

Adds an element using the shortcut.

[C#]

            [C#]
Chart.Series.Element.YValue = 10;
Chart.Series.Element.Name = "Element 1";
Chart.Series.Elements.Add();
Chart.SeriesCollection.Add();

[C#]

            [Visual Basic]
Chart.Series.Element.YValue = 10
Chart.Series.Element.Name = "Element 1"
Chart.Series.Elements.Add()
Chart.SeriesCollection.Add()

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


Add(Calculation) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

calc
Calculation to perform on the collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Calculation) Method

Adds a series to the collection based on the specified calculation.

[Visual Basic]
Overloads Public Function Add( _
   ByVal calc As Calculation _
) As Integer
[C#]
public int Add(
   Calculation calc
);

Parameters

calc
Calculation to perform on the collection.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


Add(Calculation,String) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

calc
Calculation to perform
fromSeries
Name of the series to derrive a series from.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Calculation,String) Method

Adds a series calculated from a specified series.

[Visual Basic]
Overloads Public Function Add( _
   ByVal calc As Calculation, _
   ByVal fromSeries As String _
) As Integer
[C#]
public int Add(
   Calculation calc,
   string fromSeries
);

Parameters

calc
Calculation to perform
fromSeries
Name of the series to derrive a series from.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


Add(Series) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

series
The Series to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Series) Method

Adds a specified Series class to this collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal series As Series _
) As Integer
[C#]
public int Add(
   Series series
);

Parameters

series
The Series to add.

Return Type

The zero-based index of the added Series.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


Add(Series[]) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

seriesList
A list of Series objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(Series[]) Method

Adds the specified Series objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray seriesList() As Series _
)
[C#]
public void Add(
   params Series[] seriesList
);

Parameters

seriesList
A list of Series objects to add.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


Add(SeriesCollection) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

seriesCollection
The SeriesCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(SeriesCollection) Method

Adds a specified SeriesCollection to this collection.

[Visual Basic]
Overloads Public Function Add( _
   ByVal seriesCollection As SeriesCollection _
) As Integer
[C#]
public int Add(
   SeriesCollection seriesCollection
);

Parameters

seriesCollection
The SeriesCollection to add.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


Add(SeriesCollection[]) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

seriesCollectionList
A list of SeriesCollection objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(SeriesCollection[]) Method

Adds Series of the specified SeriesCollection objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray seriesCollectionList() As SeriesCollection _
)
[C#]
public void Add(
   params SeriesCollection[] seriesCollectionList
);

Parameters

seriesCollectionList
A list of SeriesCollection objects to add.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


SeriesCollection Class | SeriesCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Calculate Method

Overload List

Performs a calculation on this collection.

[Visual Basic] Overloads Public Function Calculate(String,Calculation) As Series

[C#] public Series Calculate(string,Calculation);

Performs a calculation on series in this collection that are bound to the specified axis.

[Visual Basic] Overloads Public Function Calculate(String,Calculation,Axis) As Series

[C#] public Series Calculate(string,Calculation,Axis);

Performs a calculation on this collection with an extra parameter.

[Visual Basic] Overloads Public Function Calculate(String,Calculation,Integer) As Series

[C#] public Series Calculate(string,Calculation,int);

See Also

SeriesCollection Class | SeriesCollection Members


Calculate(String,Calculation) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

label
Name of the returned series.
calc
The calculation to perform on this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate(String,Calculation) Method

Performs a calculation on this collection.

[Visual Basic]
Overloads Public Function Calculate( _
   ByVal label As String, _
   ByVal calc As Calculation _
) As Series
[C#]
public Series Calculate(
   string label,
   Calculation calc
);

Parameters

label
Name of the returned series.
calc
The calculation to perform on this collection.

Return Type

Returns a series based on the specified calculation.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


Calculate(String,Calculation,Axis) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

label
The label of the returned series.
calc
The calculation to perform.
xAxis
The axis bound to data on which the calculation is performed.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate(String,Calculation,Axis) Method

Performs a calculation on series in this collection that are bound to the specified axis.

[Visual Basic]
Overloads Public Function Calculate( _
   ByVal label As String, _
   ByVal calc As Calculation, _
   ByVal xAxis As Axis _
) As Series
[C#]
public Series Calculate(
   string label,
   Calculation calc,
   Axis xAxis
);

Parameters

label
The label of the returned series.
calc
The calculation to perform.
xAxis
The axis bound to data on which the calculation is performed.

Return Type

Returns a series based on the specified calculation.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


Calculate(String,Calculation,Int32) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

label
Name of the returned series.
calc
The calculation to perform on this collection.
ExtraParam
Extra parameter.
See Also Languages dotnetCHARTING Send comments on this topic.

Calculate(String,Calculation,Int32) Method

Performs a calculation on this collection with an extra parameter.

[Visual Basic]
Overloads Public Function Calculate( _
   ByVal label As String, _
   ByVal calc As Calculation, _
   ByVal ExtraParam As Integer _
) As Series
[C#]
public Series Calculate(
   string label,
   Calculation calc,
   int ExtraParam
);

Parameters

label
Name of the returned series.
calc
The calculation to perform on this collection.
ExtraParam
Extra parameter.

Return Type

Returns a series based on the specified calculation.

Remarks

Calculation.TrendLineLinear and Calculation.TrendLineLinearScatter will yield result with extra elements which simulate the continuance of a trend. Supplying the ExtraParam parameter denotes the number of extra elements to create.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


CalculateElement Method

SeriesCollection Class | SeriesCollection Members

Language

Visual Basic

C#

Show All

label
Name of the returned element.
calc
The calculation to perform on this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

CalculateElement Method

Performs a calculation on this collection.

[Visual Basic]
Public Function CalculateElement( _
   ByVal label As String, _
   ByVal calc As Calculation _
) As Element
[C#]
public Element CalculateElement(
   string label,
   Calculation calc
);

Parameters

label
Name of the returned element.
calc
The calculation to perform on this collection.

Return Type

Returns an element based on the specified calculation.

See Also

SeriesCollection Class | SeriesCollection Members


Contains Method

SeriesCollection Class | SeriesCollection Members

Language

Visual Basic

C#

Show All

series
The Series to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified Series.

[Visual Basic]
Public Function Contains( _
   ByVal series As Series _
) As Boolean
[C#]
public bool Contains(
   Series series
);

Parameters

series
The Series to find.

Return Type

true if the specified Series belongs to this collection; otherwise, false.

See Also

SeriesCollection Class | SeriesCollection Members


GetAxisSeries Method

SeriesCollection Class | SeriesCollection Members

Language

Visual Basic

C#

Show All

a
The axis bound to data which will be returned in a series collection.
See Also Languages dotnetCHARTING Send comments on this topic.

GetAxisSeries Method

Gets a collection of series associated with the specified axis.

[Visual Basic]
Public Function GetAxisSeries( _
   ByVal a As Axis _
) As SeriesCollection
[C#]
public SeriesCollection GetAxisSeries(
   Axis a
);

Parameters

a
The axis bound to data which will be returned in a series collection.

Return Type

Returns a series collection.

See Also

SeriesCollection Class | SeriesCollection Members


SeriesCollection Class | SeriesCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetElement Method

Overload List

Gets an Element at the specified series and element index.

[Visual Basic] Overloads Public Function GetElement(Integer,Integer) As Element

[C#] public Element GetElement(int,int);

Gets an Element with the specified name from a named series.

[Visual Basic] Overloads Public Function GetElement(String,String) As Element

[C#] public Element GetElement(string,string);

See Also

SeriesCollection Class | SeriesCollection Members


GetElement(Int32,Int32) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

seriesIndex
Index of the series.
elementIndex
Indes of the element.
See Also Languages dotnetCHARTING Send comments on this topic.

GetElement(Int32,Int32) Method

Gets an Element at the specified series and element index.

[Visual Basic]
Overloads Public Function GetElement( _
   ByVal seriesIndex As Integer, _
   ByVal elementIndex As Integer _
) As Element
[C#]
public Element GetElement(
   int seriesIndex,
   int elementIndex
);

Parameters

seriesIndex
Index of the series.
elementIndex
Indes of the element.

Return Type

Returns an Element at the specified series and element index.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


GetElement(String,String) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
Series name.
elementName
Element name.
See Also Languages dotnetCHARTING Send comments on this topic.

GetElement(String,String) Method

Gets an Element with the specified name from a named series.

[Visual Basic]
Overloads Public Function GetElement( _
   ByVal seriesName As String, _
   ByVal elementName As String _
) As Element
[C#]
public Element GetElement(
   string seriesName,
   string elementName
);

Parameters

seriesName
Series name.
elementName
Element name.

Return Type

Returns an Element with a specified name from a named series.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


SeriesCollection Class | SeriesCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetProcessedDataTable Method

Overload List

Returns a DataTable of processed data.

[Visual Basic] Overloads Public Function GetProcessedDataTable(String) As DataTable

[C#] public DataTable GetProcessedDataTable(string);

Returns a DataTable of processed data.

[Visual Basic] Overloads Public Function GetProcessedDataTable(String,Boolean) As DataTable

[C#] public DataTable GetProcessedDataTable(string,bool);

Returns a DataTable of processed data.

[Visual Basic] Overloads Public Function GetProcessedDataTable(String,Boolean,Boolean) As DataTable

[C#] public DataTable GetProcessedDataTable(string,bool,bool);

Returns a DataTable of processed data.

[Visual Basic] Overloads Public Function GetProcessedDataTable(String,Boolean,Boolean,String) As DataTable

[C#] public DataTable GetProcessedDataTable(string,bool,bool,string);

See Also

SeriesCollection Class | SeriesCollection Members


GetProcessedDataTable(String) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

tokenTemplate
See Also Languages dotnetCHARTING Send comments on this topic.

GetProcessedDataTable(String) Method

Returns a DataTable of processed data.

[Visual Basic]
Overloads Public Function GetProcessedDataTable( _
   ByVal tokenTemplate As String _
) As DataTable
[C#]
public DataTable GetProcessedDataTable(
   string tokenTemplate
);

Parameters

tokenTemplate

Return Type

Returns a data table of the processed data.
Returns a data table of the processed data.

Remarks

This method usually called in PostDataProcessing event handler method when data generated dynamically from a database. Then, the datatable can be displayed with dataGrid or other controls.

Example

The follwoing sample, get a data table and displays with a datagrid. For complete sample see features/PostDataProcessing.aspx

[C#]

//This line should add in Page_Load method
Chart.PostDataProcessing +=new PostDataProcessingEventHandler(OnPostDataProcessing);

//The method handling the PostDataProcessing event
void OnPostDataProcessing(Object sender)
{
    DataTable dt = Chart.SeriesCollection.GetProcessedDataTable("%YValue");
    chartdatagrid.DataSource = new DataView(dt);
    chartdatagrid.DataBind();

}

[Visual Basic]

'This line should add in Page_Load method
AddHandler Chart.PostDataProcessing, AddressOf OnPostDataProcessing

'The method handling the PostDataProcessing event
Sub OnPostDataProcessing(sender As [Object])
   Dim dt As DataTable = Chart.SeriesCollection.GetProcessedDataTable("%YValue")
   chartdatagrid.DataSource = New DataView(dt)
   chartdatagrid.DataBind()
End Sub 'OnPostDataProcessing

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


GetProcessedDataTable(String,Boolean) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

tokenTemplate
transposeData
See Also Languages dotnetCHARTING Send comments on this topic.

GetProcessedDataTable(String,Boolean) Method

Returns a DataTable of processed data.

[Visual Basic]
Overloads Public Function GetProcessedDataTable( _
   ByVal tokenTemplate As String, _
   ByVal transposeData As Boolean _
) As DataTable
[C#]
public DataTable GetProcessedDataTable(
   string tokenTemplate,
   bool transposeData
);

Parameters

tokenTemplate
transposeData

Return Type

Returns a data table of the processed data.
Returns a data table of the processed data.

Remarks

This method usually called in PostDataProcessing event handler method when data generated dynamically from a database. Then, the datatable can be displayed with dataGrid or other controls.

Example

The follwoing sample, get a data table and displays with a datagrid. For complete sample see features/PostDataProcessing.aspx

[C#]

//This line should add in Page_Load method
Chart.PostDataProcessing +=new PostDataProcessingEventHandler(OnPostDataProcessing);

//The method handling the PostDataProcessing event
void OnPostDataProcessing(Object sender)
{
    DataTable dt = Chart.SeriesCollection.GetProcessedDataTable("%YValue",true);
    chartdatagrid.DataSource = new DataView(dt);
    chartdatagrid.DataBind();

}

[Visual Basic]

'This line should add in Page_Load method
AddHandler Chart.PostDataProcessing, AddressOf OnPostDataProcessing

'The method handling the PostDataProcessing event
Sub OnPostDataProcessing(sender As [Object])
   Dim dt As DataTable = Chart.SeriesCollection.GetProcessedDataTable("%YValue", True)
   chartdatagrid.DataSource = New DataView(dt)
   chartdatagrid.DataBind()
End Sub 'OnPostDataProcessing

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


GetProcessedDataTable(String,Boolean,Boolean) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

tokenTemplate
transposeData
addSeriesName
See Also Languages dotnetCHARTING Send comments on this topic.

GetProcessedDataTable(String,Boolean,Boolean) Method

Returns a DataTable of processed data.

[Visual Basic]
Overloads Public Function GetProcessedDataTable( _
   ByVal tokenTemplate As String, _
   ByVal transposeData As Boolean, _
   ByVal addSeriesName As Boolean _
) As DataTable
[C#]
public DataTable GetProcessedDataTable(
   string tokenTemplate,
   bool transposeData,
   bool addSeriesName
);

Parameters

tokenTemplate
transposeData
addSeriesName

Return Type

Returns a data table of the processed data.
Returns a data table of the processed data.

Remarks

This method usually called in PostDataProcessing event handler method when data generated dynamically from a database. Then, the datatable can be displayed with dataGrid or other controls.

Example

The follwoing sample, get a data table and displays with a datagrid. For complete sample see features/PostDataProcessing.aspx

[C#]

//This line should add in Page_Load method
Chart.PostDataProcessing +=new PostDataProcessingEventHandler(OnPostDataProcessing);

//The method handling the PostDataProcessing event
void OnPostDataProcessing(Object sender)
{
    DataTable dt = Chart.SeriesCollection.GetProcessedDataTable("%YValue",true,true);
    chartdatagrid.DataSource = new DataView(dt);
    chartdatagrid.DataBind();

}

[Visual Basic]

'This line should add in Page_Load method
AddHandler Chart.PostDataProcessing, AddressOf OnPostDataProcessing

'The method handling the PostDataProcessing event
Sub OnPostDataProcessing(sender As [Object])
   Dim dt As DataTable = Chart.SeriesCollection.GetProcessedDataTable("%YValue", True, True)
   chartdatagrid.DataSource = New DataView(dt)
   chartdatagrid.DataBind()
End Sub 'OnPostDataProcessing

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


GetProcessedDataTable(String,Boolean,Boolean,String) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

tokenTemplate
transposeData
addSeriesName
header
See Also Languages dotnetCHARTING Send comments on this topic.

GetProcessedDataTable(String,Boolean,Boolean,String) Method

Returns a DataTable of processed data.

[Visual Basic]
Overloads Public Function GetProcessedDataTable( _
   ByVal tokenTemplate As String, _
   ByVal transposeData As Boolean, _
   ByVal addSeriesName As Boolean, _
   ByVal header As String _
) As DataTable
[C#]
public DataTable GetProcessedDataTable(
   string tokenTemplate,
   bool transposeData,
   bool addSeriesName,
   string header
);

Parameters

tokenTemplate
transposeData
addSeriesName
header

Return Type

Returns a data table of the processed data.

Remarks

This method usually called in PostDataProcessing event handler method when data generated dynamically from a database. Then, the datatable can be displayed with dataGrid or other controls.

Example

The follwoing sample, get a data table and displays with a datagrid. For complete sample see features/PostDataProcessing.aspx

[C#]

//This line should add in Page_Load method
Chart.PostDataProcessing +=new PostDataProcessingEventHandler(OnPostDataProcessing);

//The method handling the PostDataProcessing event
void OnPostDataProcessing(Object sender)
{
    DataTable dt = Chart.SeriesCollection.GetProcessedDataTable("%YValue",true,true,"Sales");
    chartdatagrid.DataSource = new DataView(dt);
    chartdatagrid.DataBind();

}

[Visual Basic]

'This line should add in Page_Load method
AddHandler Chart.PostDataProcessing, AddressOf OnPostDataProcessing

'The method handling the PostDataProcessing event
Sub OnPostDataProcessing(sender As [Object])
   Dim dt As DataTable = Chart.SeriesCollection.GetProcessedDataTable("%YValue", True, True, "Sales")
   chartdatagrid.DataSource = New DataView(dt)
   chartdatagrid.DataBind()
End Sub 'OnPostDataProcessing

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


GetSeries Method

SeriesCollection Class | SeriesCollection Members

Language

Visual Basic

C#

Show All

seriesName
Name of the series to get
See Also Languages dotnetCHARTING Send comments on this topic.

GetSeries Method

Retrieves the named Series.

[Visual Basic]
Public Function GetSeries( _
   ByVal seriesName As String _
) As Series
[C#]
public Series GetSeries(
   string seriesName
);

Parameters

seriesName
Name of the series to get

Return Type

The named series.

See Also

SeriesCollection Class | SeriesCollection Members


SeriesCollection Class | SeriesCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GetSmartPalette Method

Overload List

Generates a SmartPalette object that contains the names of series in this SeriesCollection matched with the specified array of color objects.

[Visual Basic] Overloads Public Function GetSmartPalette(Color()) As SmartPalette

[C#] public SmartPalette GetSmartPalette(Color[]);

Generates a SmartPalette object that contains the names of series in this SeriesCollection matched with the specified Palette enumeration.

[Visual Basic] Overloads Public Function GetSmartPalette(Palette) As SmartPalette

[C#] public SmartPalette GetSmartPalette(Palette);

See Also

SeriesCollection Class | SeriesCollection Members


GetSmartPalette(Color[]) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

colors
Array of colors used to generate the SmartPalette.
See Also Languages dotnetCHARTING Send comments on this topic.

GetSmartPalette(Color[]) Method

Generates a SmartPalette object that contains the names of series in this SeriesCollection matched with the specified array of color objects.

[Visual Basic]
Overloads Public Function GetSmartPalette( _
   ByVal colors() As Color _
) As SmartPalette
[C#]
public SmartPalette GetSmartPalette(
   Color[] colors
);

Parameters

colors
Array of colors used to generate the SmartPalette.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


GetSmartPalette(Palette) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

palette
Palette used to generate the SmartPalette object.
See Also Languages dotnetCHARTING Send comments on this topic.

GetSmartPalette(Palette) Method

Generates a SmartPalette object that contains the names of series in this SeriesCollection matched with the specified Palette enumeration.

[Visual Basic]
Overloads Public Function GetSmartPalette( _
   ByVal palette As Palette _
) As SmartPalette
[C#]
public SmartPalette GetSmartPalette(
   Palette palette
);

Parameters

palette
Palette used to generate the SmartPalette object.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


SeriesCollection Class | SeriesCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GroupByElements Method

Groups series into even element groups where every element will have a matching element in all other series.

[Visual Basic]
Public Sub GroupByElements()
[C#]
public void GroupByElements();

Remarks

The result will be series of even number of elements with the same names.

See Also

SeriesCollection Class | SeriesCollection Members


Insert Method

SeriesCollection Class | SeriesCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the series.
series
The series to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a series into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal series As Series _
)
[C#]
public void Insert(
   int index,
   Series series
);

Parameters

index
The zero-based index into the collection at which to insert the series.
series
The series to insert into this collection.

See Also

SeriesCollection Class | SeriesCollection Members


Remove Method

SeriesCollection Class | SeriesCollection Members

Language

Visual Basic

C#

Show All

series
The series to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified series from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal series As Series _
)
[C#]
public void Remove(
   Series series
);

Parameters

series
The series to remove.

See Also

SeriesCollection Class | SeriesCollection Members


Sort Method

SeriesCollection Class | SeriesCollection Members

Language

Visual Basic

C#

Show All

ev
ElementValue to sort by.
order
Takes "Desc" or "Asc" as inputs. If the string is not recognized "Asc" will be used.
See Also Languages dotnetCHARTING Send comments on this topic.

Sort Method

Sorts the Series based on an element property and order.

[Visual Basic]
Public Sub Sort( _
   ByVal ev As ElementValue, _
   ByVal order As String _
)
[C#]
public void Sort(
   ElementValue ev,
   string order
);

Parameters

ev
ElementValue to sort by.
order
Takes "Desc" or "Asc" as inputs. If the string is not recognized "Asc" will be used.

See Also

SeriesCollection Class | SeriesCollection Members


SeriesCollection Class | SeriesCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

SeriesCollection Class | SeriesCollection Members


SeriesCollection Class | SeriesCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Transpose Method

Overload List

Transposes the data of this series collection. Data is transposed by converting the series in this collection to elements and the element groups into series.

[Visual Basic] Overloads Public Sub Transpose()

[C#] public void Transpose();

Transposes the data bound to a specified axis. Data is transposed by converting the series in this collection to elements and the element groups into series.

[Visual Basic] Overloads Public Sub Transpose(Axis)

[C#] public void Transpose(Axis);

See Also

SeriesCollection Class | SeriesCollection Members


SeriesCollection Class | SeriesCollection Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Transpose() Method

Transposes the data of this series collection. Data is transposed by converting the series in this collection to elements and the element groups into series.

[Visual Basic]
Overloads Public Sub Transpose()
[C#]
public void Transpose();

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


Transpose(Axis) Method

SeriesCollection Class | SeriesCollection Members | Overload List

Language

Visual Basic

C#

Show All

xAxis
The axis bound to data that is to be transposed.
See Also Languages dotnetCHARTING Send comments on this topic.

Transpose(Axis) Method

Transposes the data bound to a specified axis. Data is transposed by converting the series in this collection to elements and the element groups into series.

[Visual Basic]
Overloads Public Sub Transpose( _
   ByVal xAxis As Axis _
)
[C#]
public void Transpose(
   Axis xAxis
);

Parameters

xAxis
The axis bound to data that is to be transposed.

See Also

SeriesCollection Class | SeriesCollection Members | Overload List


SeriesCollection Class Properties

SeriesCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SeriesCollection Class Members

For a list of all members of this type, see SeriesCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property InstanceID |
Public Property Item | Gets or sets the Series at a specified index.
Public Property SmartPalette | Gets or sets a SmartPalette object that will determine the colors of series in this SeriesCollection.

See Also

SeriesCollection Class | dotnetCHARTING Namespace


SeriesCollection Class | SeriesCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InstanceID Property

[Visual Basic]
Public Property InstanceID As Integer
[C#]
public int InstanceID {get; set;}

See Also

SeriesCollection Class | SeriesCollection Members


Item Property

SeriesCollection Class | SeriesCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the Series at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Series
[C#]
public Series this[
   int index
]; {get; set;}

Parameters

index

See Also

SeriesCollection Class | SeriesCollection Members


SeriesCollection Class | SeriesCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartPalette Property

Gets or sets a SmartPalette object that will determine the colors of series in this SeriesCollection.

[Visual Basic]
Public Property SmartPalette As SmartPalette
[C#]
public SmartPalette SmartPalette {get; set;}

See Also

SeriesCollection Class | SeriesCollection Members


Shadow Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Shadow Class

Represents a shadow cast by chart objects such as a Box or Annotation.

For a list of all members of this type, see Shadow members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.Shadow

Syntax

[Visual Basic]
Public Class Shadow
[C#]
public class Shadow

See Also

Shadow Members | dotnetCHARTING Namespace


Shadow Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Shadow Class Members

Shadow overview

Public Constructors

Public Constructor Shadow Constructor

Public Properties

Public Property Color | Gets or sets the color of this shadow.
Public Property Depth | Gets or sets the shadow's depth.
Public Property Soft | Gets or sets a value which indicates whether this shadow is soft or solid.

See Also

Shadow Class | dotnetCHARTING Namespace


Shadow Class | Shadow Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Shadow Constructor

[Visual Basic]
Public Function New()
[C#]
public Shadow();

See Also

Shadow Class | Shadow Members


Shadow Class Properties

Shadow Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Shadow Class Members

For a list of all members of this type, see Shadow members.

Public Properties

Public Property Color | Gets or sets the color of this shadow.
Public Property Depth | Gets or sets the shadow's depth.
Public Property Soft | Gets or sets a value which indicates whether this shadow is soft or solid.

See Also

Shadow Class | dotnetCHARTING Namespace


Shadow Class | Shadow Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Color Property

Gets or sets the color of this shadow.

[Visual Basic]
Public Property Color As Color
[C#]
public Color Color {get; set;}

Remarks

Making this color partially transparent will give the shadow a more realistic look.

See Also

Shadow Class | Shadow Members


Shadow Class | Shadow Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Depth Property

Gets or sets the shadow's depth.

[Visual Basic]
Public Property Depth As Integer
[C#]
public int Depth {get; set;}

See Also

Shadow Class | Shadow Members


Shadow Class | Shadow Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Soft Property

Gets or sets a value which indicates whether this shadow is soft or solid.

[Visual Basic]
Public Property Soft As Boolean
[C#]
public bool Soft {get; set;}

See Also

Shadow Class | Shadow Members


SmartLabel Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartLabel Class

Encapsulates a Label object with advanced alignment and collision detection options.

For a list of all members of this type, see SmartLabel members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.Label
dotnetCHARTING.SmartLabel

Syntax

[Visual Basic]
Public Class SmartLabel
   Inherits Label
[C#]
public class SmartLabel : Label

See Also

SmartLabel Members | dotnetCHARTING Namespace


SmartLabel Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SmartLabel Class Members

SmartLabel overview

Public Constructors

Public Constructor SmartLabel Constructor Initializes a new instance of the SmartLabel class.

Public Properties

Public Property Alignment | Gets or sets the primary label alignment.
Public Property AlignmentSecondary | Gets or sets a collection of secondary label alignment options.
Public Property Color (Inherited from Label) | Gets or sets the color of this label.
Public Property DynamicDisplay | Gets or sets a value that indicates whether the label is forced to be drawn even when there is no room. False means labels are always drawn.
Public Property DynamicPosition | Gets or sets a value that indicates whether the label will be positioned using collision detection.
Public Property Font (Inherited from Label) | Gets or sets the font for this label.
Public Property ForceVertical | Gets or sets a value that indicates whether the label is forced to be drawn vertically.
Public Property Line | Gets or sets a Line object that facilitates the DynamicPosition functionality.
Public Property LineAlignment (Inherited from Label) | Gets or sets the line alignment of this label.
Public Property PieLabelMode | Gets or sets a PieLabelMode enumeration for pie and donut charts.
Public Property RadarLabelMode | Gets or sets a RadarLabelMode enumeration for radar charts.
Public Property Text (Inherited from Label) | Gets or sets the text for this label.
Public Property Truncation (Inherited from Label) | Gets or sets properties used to dynamically shorten this label when it reaches a maximum length.

Public Methods

Public Method Dispose (Inherited from Label)

See Also

SmartLabel Class | dotnetCHARTING Namespace


SmartLabel Class | SmartLabel Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartLabel Constructor

Initializes a new instance of the SmartLabel class.

[Visual Basic]
Public Function New()
[C#]
public SmartLabel();

See Also

SmartLabel Class | SmartLabel Members


SmartLabel Class Properties

SmartLabel Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SmartLabel Class Members

For a list of all members of this type, see SmartLabel members.

Public Properties

Public Property Alignment | Gets or sets the primary label alignment.
Public Property AlignmentSecondary | Gets or sets a collection of secondary label alignment options.
Public Property Color (Inherited from Label) | Gets or sets the color of this label.
Public Property DynamicDisplay | Gets or sets a value that indicates whether the label is forced to be drawn even when there is no room. False means labels are always drawn.
Public Property DynamicPosition | Gets or sets a value that indicates whether the label will be positioned using collision detection.
Public Property Font (Inherited from Label) | Gets or sets the font for this label.
Public Property ForceVertical | Gets or sets a value that indicates whether the label is forced to be drawn vertically.
Public Property Line | Gets or sets a Line object that facilitates the DynamicPosition functionality.
Public Property LineAlignment (Inherited from Label) | Gets or sets the line alignment of this label.
Public Property PieLabelMode | Gets or sets a PieLabelMode enumeration for pie and donut charts.
Public Property RadarLabelMode | Gets or sets a RadarLabelMode enumeration for radar charts.
Public Property Text (Inherited from Label) | Gets or sets the text for this label.
Public Property Truncation (Inherited from Label) | Gets or sets properties used to dynamically shorten this label when it reaches a maximum length.

See Also

SmartLabel Class | dotnetCHARTING Namespace


SmartLabel Class | SmartLabel Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Alignment Property

Gets or sets the primary label alignment.

[Visual Basic]
Public Property Alignment As LabelAlignment
[C#]
public LabelAlignment Alignment {get; set;}

Remarks

If the labels doesn't fit well given this alignment, alignments in the AlighmentSecondary collection are iterated (when DynamicDisplay is true) to find the first position that fits correctly.

See Also

SmartLabel Class | SmartLabel Members


SmartLabel Class | SmartLabel Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AlignmentSecondary Property

Gets or sets a collection of secondary label alignment options.

[Visual Basic]
Public ReadOnly Property AlignmentSecondary As LabelAlignmentCollection
[C#]
public LabelAlignmentCollection AlignmentSecondary {get;}

Remarks

When the primary Alignment option does not permit the room necessary to draw this label, the alignment options in this collection are iterated to find one that fits.

See Also

SmartLabel Class | SmartLabel Members


SmartLabel Class | SmartLabel Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DynamicDisplay Property

Gets or sets a value that indicates whether the label is forced to be drawn even when there is no room. False means labels are always drawn.

[Visual Basic]
Public Property DynamicDisplay As Boolean
[C#]
public bool DynamicDisplay {get; set;}

See Also

SmartLabel Class | SmartLabel Members


SmartLabel Class | SmartLabel Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DynamicPosition Property

Gets or sets a value that indicates whether the label will be positioned using collision detection.

[Visual Basic]
Public Property DynamicPosition As Boolean
[C#]
public bool DynamicPosition {get; set;}

Remarks

This causes the labels to be conscious of each other and does not permit them to overlap. When a label is positioned away from the data point it represents, the Line is drawn from the label's new position to the data point.

See Also

SmartLabel Class | SmartLabel Members


SmartLabel Class | SmartLabel Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ForceVertical Property

Gets or sets a value that indicates whether the label is forced to be drawn vertically.

[Visual Basic]
Public Property ForceVertical As Boolean
[C#]
public bool ForceVertical {get; set;}

Remarks

When false, labels will be drawn vertically only on columns and cylinders that are not wide enough to fit the label horizontally. Otherwise, all labels will be vertical.

See Also

SmartLabel Class | SmartLabel Members


SmartLabel Class | SmartLabel Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Property

Gets or sets a Line object that facilitates the DynamicPosition functionality.

[Visual Basic]
Public Property Line As Line
[C#]
public Line Line {get; set;}

Remarks

Lines are used to point to an element when a label can not be placed directly beside it.

See Also

SmartLabel Class | SmartLabel Members


SmartLabel Class | SmartLabel Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PieLabelMode Property

Gets or sets a PieLabelMode enumeration for pie and donut charts.

[Visual Basic]
Public Property PieLabelMode As PieLabelMode
[C#]
public PieLabelMode PieLabelMode {get; set;}

Remarks

This setting will only apply when set through the Chart.DefaultSeries.DefaultElement.SmartLabel instance.

See Also

SmartLabel Class | SmartLabel Members


SmartLabel Class | SmartLabel Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RadarLabelMode Property

Gets or sets a RadarLabelMode enumeration for radar charts.

[Visual Basic]
Public Property RadarLabelMode As RadarLabelMode
[C#]
public RadarLabelMode RadarLabelMode {get; set;}

Remarks

This setting will only apply when set through the Chart.DefaultSeries.DefaultElement.SmartLabel instance.

See Also

SmartLabel Class | SmartLabel Members


SmartPalette Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartPalette Class

Contains a dictionary like collection of string and color pairs where strings refer to series or element names and colors that are assigned to series or elements with those names.

For a list of all members of this type, see SmartPalette members.

Inheritance Hierarchy

System.Object
System.Collections.Specialized.NameObjectCollectionBase
dotnetCHARTING.SmartPalette

Syntax

[Visual Basic]
Public Class SmartPalette
   Inherits NameObjectCollectionBase
[C#]
public class SmartPalette : NameObjectCollectionBase

Remarks

This object can be saved as XML and loaded for any other charts to use. To use a SmartPalette with a given chart, it to the Chart.SmartPalette property.

See Also

SmartPalette Members | dotnetCHARTING Namespace


SmartPalette Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SmartPalette Class Members

SmartPalette overview

Public Constructors

Public Constructor SmartPalette Constructor Overloaded.

Public Properties

Public Property AllKeys | Gets a String array containing all the keys (series or element names) in the SmartPalette.
Public Property AllValues | Gets a Color array containing all the values (series / element colors) in the SmartPalette.
Public Property Count (Inherited from System.Collections.Specialized.NameObjectCollectionBase) |
Public Property HasKeys | Gets a value indicating whether the SmartPalette has entries.
Public Property Item | Overloaded.
Public Property Keys (Inherited from System.Collections.Specialized.NameObjectCollectionBase) |

Public Methods

Public Method Add | Overloaded.
Public Method Clear | Clears the SmartPalette.
Public Method GetEnumerator (Inherited from System.Collections.Specialized.NameObjectCollectionBase) |
Public Method GetObjectData (Inherited from System.Collections.Specialized.NameObjectCollectionBase) |
Public Method LoadState | Imports a SmartPalette object from the specified xml file.
Public Method OnDeserialization (Inherited from System.Collections.Specialized.NameObjectCollectionBase) |
Public Method Remove | Overloaded.
Public Method SaveState | Overloaded.

See Also

SmartPalette Class | dotnetCHARTING Namespace


SmartPalette Class | SmartPalette Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartPalette Constructor

Overload List

Initializes a new instance of the SmartPalette object.

[Visual Basic] Public Sub New()

[C#] public SmartPalette();

[Visual Basic] Public Sub New(String)

[C#] public SmartPalette(string);

See Also

SmartPalette Class | SmartPalette Members


SmartPalette Class | SmartPalette Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SmartPalette Constructor()

Initializes a new instance of the SmartPalette object.

[Visual Basic]
Public Function New()
[C#]
public SmartPalette();

See Also

SmartPalette Class | SmartPalette Members | Overload List


SmartPalette Constructor(String)

SmartPalette Class | SmartPalette Members | Overload List

Language

Visual Basic

C#

Show All

xmlDataOrFileName
See Also Languages dotnetCHARTING Send comments on this topic.

SmartPalette Constructor(String)

[Visual Basic]
Public Function New( _
   ByVal xmlDataOrFileName As String _
)
[C#]
public SmartPalette(
   string xmlDataOrFileName
);

Parameters

xmlDataOrFileName

See Also

SmartPalette Class | SmartPalette Members | Overload List


SmartPalette Class Methods

SmartPalette Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SmartPalette Class Members

For a list of all members of this type, see SmartPalette members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear | Clears the SmartPalette.
Public Method GetEnumerator (Inherited from System.Collections.Specialized.NameObjectCollectionBase) |
Public Method GetObjectData (Inherited from System.Collections.Specialized.NameObjectCollectionBase) |
Public Method LoadState | Imports a SmartPalette object from the specified xml file.
Public Method OnDeserialization (Inherited from System.Collections.Specialized.NameObjectCollectionBase) |
Public Method Remove | Overloaded.
Public Method SaveState | Overloaded.

See Also

SmartPalette Class | dotnetCHARTING Namespace


SmartPalette Class | SmartPalette Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

Adds the items in the specified palette to this palette.

[Visual Basic] Overloads Public Sub Add(SmartPalette)

[C#] public void Add(SmartPalette);

Ads the specified key and color item to this palette.

[Visual Basic] Overloads Public Sub Add(String,Color)

[C#] public void Add(string,Color);

See Also

SmartPalette Class | SmartPalette Members


Add(SmartPalette) Method

SmartPalette Class | SmartPalette Members | Overload List

Language

Visual Basic

C#

Show All

palette
Source palette.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(SmartPalette) Method

Adds the items in the specified palette to this palette.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal palette As SmartPalette _
)
[C#]
public void Add(
   SmartPalette palette
);

Parameters

palette
Source palette.

See Also

SmartPalette Class | SmartPalette Members | Overload List


Add(String,Color) Method

SmartPalette Class | SmartPalette Members | Overload List

Language

Visual Basic

C#

Show All

key
value
See Also Languages dotnetCHARTING Send comments on this topic.

Add(String,Color) Method

Ads the specified key and color item to this palette.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal key As String, _
   ByVal value As Color _
)
[C#]
public void Add(
   string key,
   Color value
);

Parameters

key
value

See Also

SmartPalette Class | SmartPalette Members | Overload List


SmartPalette Class | SmartPalette Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Clear Method

Clears the SmartPalette.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

See Also

SmartPalette Class | SmartPalette Members


LoadState Method

SmartPalette Class | SmartPalette Members

Language

Visual Basic

C#

Show All

xmlDataOrFileName
Path of XML file or XML data to load.
See Also Languages dotnetCHARTING Send comments on this topic.

LoadState Method

Imports a SmartPalette object from the specified xml file.

[Visual Basic]
Public Sub LoadState( _
   ByVal xmlDataOrFileName As String _
)
[C#]
public void LoadState(
   string xmlDataOrFileName
);

Parameters

xmlDataOrFileName
Path of XML file or XML data to load.

See Also

SmartPalette Class | SmartPalette Members


SmartPalette Class | SmartPalette Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Overload List

Removes an item at the specified index from this collection.

[Visual Basic] Overloads Public Sub Remove(Integer)

[C#] public void Remove(int);

Removes an entry with the specified key from the collection.

[Visual Basic] Overloads Public Sub Remove(String)

[C#] public void Remove(string);

See Also

SmartPalette Class | SmartPalette Members


Remove(Int32) Method

SmartPalette Class | SmartPalette Members | Overload List

Language

Visual Basic

C#

Show All

index
The AxisTick to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove(Int32) Method

Removes an item at the specified index from this collection.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal index As Integer _
)
[C#]
public void Remove(
   int index
);

Parameters

index
The AxisTick to remove.

See Also

SmartPalette Class | SmartPalette Members | Overload List


Remove(String) Method

SmartPalette Class | SmartPalette Members | Overload List

Language

Visual Basic

C#

Show All

key
Key of entry to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove(String) Method

Removes an entry with the specified key from the collection.

[Visual Basic]
Overloads Public Sub Remove( _
   ByVal key As String _
)
[C#]
public void Remove(
   string key
);

Parameters

key
Key of entry to remove.

See Also

SmartPalette Class | SmartPalette Members | Overload List


SmartPalette Class | SmartPalette Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SaveState Method

Overload List

Saves the SmartPalette instance to an xml file.

[Visual Basic] Overloads Public Function SaveState() As String

[C#] public string SaveState();

Saves the SmartPalette instance to an xml file.

[Visual Basic] Overloads Public Sub SaveState(String)

[C#] public void SaveState(string);

See Also

SmartPalette Class | SmartPalette Members


SmartPalette Class | SmartPalette Members | Overload List

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SaveState() Method

Saves the SmartPalette instance to an xml file.

[Visual Basic]
Overloads Public Function SaveState() As String
[C#]
public string SaveState();

See Also

SmartPalette Class | SmartPalette Members | Overload List


SaveState(String) Method

SmartPalette Class | SmartPalette Members | Overload List

Language

Visual Basic

C#

Show All

xmlFilePath
See Also Languages dotnetCHARTING Send comments on this topic.

SaveState(String) Method

Saves the SmartPalette instance to an xml file.

[Visual Basic]
Overloads Public Sub SaveState( _
   ByVal xmlFilePath As String _
)
[C#]
public void SaveState(
   string xmlFilePath
);

Parameters

xmlFilePath

See Also

SmartPalette Class | SmartPalette Members | Overload List


SmartPalette Class Properties

SmartPalette Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SmartPalette Class Members

For a list of all members of this type, see SmartPalette members.

Public Properties

Public Property AllKeys | Gets a String array containing all the keys (series or element names) in the SmartPalette.
Public Property AllValues | Gets a Color array containing all the values (series / element colors) in the SmartPalette.
Public Property Count (Inherited from System.Collections.Specialized.NameObjectCollectionBase) |
Public Property HasKeys | Gets a value indicating whether the SmartPalette has entries.
Public Property Item | Overloaded.
Public Property Keys (Inherited from System.Collections.Specialized.NameObjectCollectionBase) |

See Also

SmartPalette Class | dotnetCHARTING Namespace


SmartPalette Class | SmartPalette Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AllKeys Property

Gets a String array containing all the keys (series or element names) in the SmartPalette.

[Visual Basic]
Public ReadOnly Property AllKeys As String()
[C#]
public string[] AllKeys {get;}

See Also

SmartPalette Class | SmartPalette Members


SmartPalette Class | SmartPalette Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AllValues Property

Gets a Color array containing all the values (series / element colors) in the SmartPalette.

[Visual Basic]
Public ReadOnly Property AllValues As Array
[C#]
public Array AllValues {get;}

See Also

SmartPalette Class | SmartPalette Members


SmartPalette Class | SmartPalette Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HasKeys Property

Gets a value indicating whether the SmartPalette has entries.

[Visual Basic]
Public ReadOnly Property HasKeys As Boolean
[C#]
public bool HasKeys {get;}

See Also

SmartPalette Class | SmartPalette Members


SmartPalette Class | SmartPalette Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Overload List

Gets or sets the value associated with the specified key.

[Visual Basic] Overloads Public Item(Integer) As DictionaryEntry

[C#] public DictionaryEntry Item(int);

Gets or sets the Color with the specified key.

[Visual Basic] Overloads Public Item(String) As Color

[C#] public Color Item(string);

See Also

SmartPalette Class | SmartPalette Members


Item(Int32) Property

SmartPalette Class | SmartPalette Members | Overload List

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item(Int32) Property

Gets or sets the value associated with the specified key.

[Visual Basic]
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As DictionaryEntry
[C#]
public DictionaryEntry Item(
   int index
); {get;}

Parameters

index

See Also

SmartPalette Class | SmartPalette Members | Overload List


Item(String) Property

SmartPalette Class | SmartPalette Members | Overload List

Language

Visual Basic

C#

Show All

key
See Also Languages dotnetCHARTING Send comments on this topic.

Item(String) Property

Gets or sets the Color with the specified key.

[Visual Basic]
Overloads Public Property Item( _
   ByVal key As String _
) As Color
[C#]
public Color Item(
   string key
); {get; set;}

Parameters

key

See Also

SmartPalette Class | SmartPalette Members | Overload List


StatisticalEngine Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StatisticalEngine Class

Provides a set of methods that perform statistical analysis of series and series collections.

For a list of all members of this type, see StatisticalEngine members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.StatisticalEngine

Syntax

[Visual Basic]
Public NotInheritable Class StatisticalEngine
[C#]
public sealed class StatisticalEngine

See Also

StatisticalEngine Members | dotnetCHARTING Namespace


StatisticalEngine Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

StatisticalEngine Class Members

StatisticalEngine overview

Public Methods

Public Method static (Shared in Visual Basic) BollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) CFrequencyTableAOL | Overloaded.
Public Method static (Shared in Visual Basic) CFrequencyTableAOR | Overloaded.
Public Method static (Shared in Visual Basic) CFrequencyTableBOL | Overloaded.
Public Method static (Shared in Visual Basic) CFrequencyTableBOR | Overloaded.
Public Method static (Shared in Visual Basic) CorrelationCoefDeterminantion | Overloaded.
Public Method static (Shared in Visual Basic) EstimateX | Overloaded.
Public Method static (Shared in Visual Basic) EstimateY | Overloaded.
Public Method static (Shared in Visual Basic) ExponentiallyWeightedMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) FrequencyTableOL | Overloaded.
Public Method static (Shared in Visual Basic) FrequencyTableOR | Overloaded.
Public Method static (Shared in Visual Basic) GeometricMean | Overloaded.
Public Method static (Shared in Visual Basic) GeometricMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) IQR | Overloaded.
Public Method static (Shared in Visual Basic) Kairi | Overloaded.
Public Method static (Shared in Visual Basic) KendallCorrelationCoef | Overloaded.
Public Method static (Shared in Visual Basic) LeastSquaresEstimateX | Overloaded.
Public Method static (Shared in Visual Basic) LeastSquaresEstimateY | Overloaded.
Public Method static (Shared in Visual Basic) LinearlyWeightedMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) LowerBollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) Mean | Overloaded.
Public Method static (Shared in Visual Basic) MeanDeviation | Overloaded.
Public Method static (Shared in Visual Basic) Median | Overloaded.
Public Method static (Shared in Visual Basic) MedianMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) PearsonCorrelationCoef | Overloaded.
Public Method static (Shared in Visual Basic) Percentile25 | Overloaded.
Public Method static (Shared in Visual Basic) Percentile50 | Overloaded.
Public Method static (Shared in Visual Basic) Percentile75 | Overloaded.
Public Method static (Shared in Visual Basic) Range | Overloaded.
Public Method static (Shared in Visual Basic) Residuals | Overloaded.
Public Method static (Shared in Visual Basic) ResidualsAverage | Overloaded.
Public Method static (Shared in Visual Basic) RFrequencyTableOL | Overloaded.
Public Method static (Shared in Visual Basic) RFrequencyTableOR | Overloaded.
Public Method static (Shared in Visual Basic) SimpleMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) SpearmanRankCorrelationTest | Overloaded.
Public Method static (Shared in Visual Basic) StandardDeviation | Overloaded.
Public Method static (Shared in Visual Basic) TriangularMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) UpperBollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) Variance | Overloaded.
Public Method static (Shared in Visual Basic) WeightedMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) ZScore | Overloaded.

See Also

StatisticalEngine Class | dotnetCHARTING Namespace


StatisticalEngine Class Methods

StatisticalEngine Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

StatisticalEngine Class Members

For a list of all members of this type, see StatisticalEngine members.

Public Methods

Public Method static (Shared in Visual Basic) BollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) CFrequencyTableAOL | Overloaded.
Public Method static (Shared in Visual Basic) CFrequencyTableAOR | Overloaded.
Public Method static (Shared in Visual Basic) CFrequencyTableBOL | Overloaded.
Public Method static (Shared in Visual Basic) CFrequencyTableBOR | Overloaded.
Public Method static (Shared in Visual Basic) CorrelationCoefDeterminantion | Overloaded.
Public Method static (Shared in Visual Basic) EstimateX | Overloaded.
Public Method static (Shared in Visual Basic) EstimateY | Overloaded.
Public Method static (Shared in Visual Basic) ExponentiallyWeightedMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) FrequencyTableOL | Overloaded.
Public Method static (Shared in Visual Basic) FrequencyTableOR | Overloaded.
Public Method static (Shared in Visual Basic) GeometricMean | Overloaded.
Public Method static (Shared in Visual Basic) GeometricMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) IQR | Overloaded.
Public Method static (Shared in Visual Basic) Kairi | Overloaded.
Public Method static (Shared in Visual Basic) KendallCorrelationCoef | Overloaded.
Public Method static (Shared in Visual Basic) LeastSquaresEstimateX | Overloaded.
Public Method static (Shared in Visual Basic) LeastSquaresEstimateY | Overloaded.
Public Method static (Shared in Visual Basic) LinearlyWeightedMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) LowerBollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) Mean | Overloaded.
Public Method static (Shared in Visual Basic) MeanDeviation | Overloaded.
Public Method static (Shared in Visual Basic) Median | Overloaded.
Public Method static (Shared in Visual Basic) MedianMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) PearsonCorrelationCoef | Overloaded.
Public Method static (Shared in Visual Basic) Percentile25 | Overloaded.
Public Method static (Shared in Visual Basic) Percentile50 | Overloaded.
Public Method static (Shared in Visual Basic) Percentile75 | Overloaded.
Public Method static (Shared in Visual Basic) Range | Overloaded.
Public Method static (Shared in Visual Basic) Residuals | Overloaded.
Public Method static (Shared in Visual Basic) ResidualsAverage | Overloaded.
Public Method static (Shared in Visual Basic) RFrequencyTableOL | Overloaded.
Public Method static (Shared in Visual Basic) RFrequencyTableOR | Overloaded.
Public Method static (Shared in Visual Basic) SimpleMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) SpearmanRankCorrelationTest | Overloaded.
Public Method static (Shared in Visual Basic) StandardDeviation | Overloaded.
Public Method static (Shared in Visual Basic) TriangularMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) UpperBollingerBands | Overloaded.
Public Method static (Shared in Visual Basic) Variance | Overloaded.
Public Method static (Shared in Visual Basic) WeightedMovingAverage | Overloaded.
Public Method static (Shared in Visual Basic) ZScore | Overloaded.

See Also

StatisticalEngine Class | dotnetCHARTING Namespace


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

BollingerBands Method

Overload List

Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.

[Visual Basic] Overloads Public Shared Function BollingerBands(Series,Double,Integer) As SeriesCollection

[C#] public static SeriesCollection BollingerBands(Series,double,int);

Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.

[Visual Basic] Overloads Public Shared Function BollingerBands(SeriesCollection,Double,Integer) As SeriesCollection

[C#] public static SeriesCollection BollingerBands(SeriesCollection,double,int);

See Also

StatisticalEngine Class | StatisticalEngine Members


BollingerBands(Series,Double,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

BollingerBands(Series,Double,Int32) Method

Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.

[Visual Basic]
Overloads Public Shared Function BollingerBands( _
   ByVal s As Series, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection BollingerBands(
   Series s,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

s
A statistical series.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Remarks

Further Details

Bollinger Bands are a type of envelope that are plotted at standard deviation levels above and below the corresponding (simple) moving average. This produces an effect of having the bands widen during periods of higher volatility and contract during less volatile periods. Bollinger Bands indicate the relative supply and demand for a given asset. If the asset to move close to the top of the envelope then it indicates that there is strong demand for the asset, conversely if the asset hugs the bottom of the trading range then it indicates that there is oversupply of the asset.

Since the Bollinger Bands will nearly always be combined with other indicators when forming a trading system the number of periods used in the evaluation of the standard deviation of the stocks and the moving average will vary. For those without design restrictions a popular choice of the number of time periods is around 20-23.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


BollingerBands(SeriesCollection,Double,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

BollingerBands(SeriesCollection,Double,Int32) Method

Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.

[Visual Basic]
Overloads Public Shared Function BollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection BollingerBands(
   SeriesCollection sc,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Remarks

Further Details

Bollinger Bands are a type of envelope that are plotted at standard deviation levels above and below the corresponding (simple) moving average. This produces an effect of having the bands widen during periods of higher volatility and contract during less volatile periods. Bollinger Bands indicate the relative supply and demand for a given asset. If the asset to move close to the top of the envelope then it indicates that there is strong demand for the asset, conversely if the asset hugs the bottom of the trading range then it indicates that there is oversupply of the asset.

Since the Bollinger Bands will nearly always be combined with other indicators when forming a trading system the number of periods used in the evaluation of the standard deviation of the stocks and the moving average will vary. For those without design restrictions a popular choice of the number of time periods is around 20-23.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableAOL Method

Overload List

Calculates the cumulative frequency table from above for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic] Overloads Public Shared Function CFrequencyTableAOL(Series,Double()) As Series

[C#] public static Series CFrequencyTableAOL(Series,double[]);

Calculates the cumulative frequency table from above for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic] Overloads Public Shared Function CFrequencyTableAOL(SeriesCollection,Double()) As SeriesCollection

[C#] public static SeriesCollection CFrequencyTableAOL(SeriesCollection,double[]);

[Visual Basic] Overloads Public Shared Function CFrequencyTableAOL(String,Series,Double()) As Series

[C#] public static Series CFrequencyTableAOL(string,Series,double[]);

See Also

StatisticalEngine Class | StatisticalEngine Members


CFrequencyTableAOL(Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableAOL(Series,Double[]) Method

Calculates the cumulative frequency table from above for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic]
Overloads Public Shared Function CFrequencyTableAOL( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series CFrequencyTableAOL(
   Series s,
   double[] boundaries
);

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Exceptions

Exception | Description
ArgumentException | Thrown if data set or boundaries intervals are null.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 1 + 3 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 1 + 3 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 1 + 3 + 1 = 5
  • Cumulative frequency table above 3 is: 1 + 3 + 1 = 5
  • Cumulative frequency table above 4 is: 3 + 1 = 4
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 4, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


CFrequencyTableAOL(SeriesCollection,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableAOL(SeriesCollection,Double[]) Method

Calculates the cumulative frequency table from above for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic]
Overloads Public Shared Function CFrequencyTableAOL( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
[C#]
public static SeriesCollection CFrequencyTableAOL(
   SeriesCollection sc,
   double[] boundaries
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Exceptions

Exception | Description
ArgumentException | Thrown if data set or boundaries intervals are null.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 1 + 3 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 1 + 3 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 1 + 3 + 1 = 5
  • Cumulative frequency table above 3 is: 1 + 3 + 1 = 5
  • Cumulative frequency table above 4 is: 3 + 1 = 4
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 4, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


CFrequencyTableAOL(String,Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableAOL(String,Series,Double[]) Method

[Visual Basic]
Overloads Public Shared Function CFrequencyTableAOL( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series CFrequencyTableAOL(
   string seriesName,
   Series s,
   double[] boundaries
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Thrown if data set or boundaries intervals are null.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 1 + 3 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 1 + 3 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 1 + 3 + 1 = 5
  • Cumulative frequency table above 3 is: 1 + 3 + 1 = 5
  • Cumulative frequency table above 4 is: 3 + 1 = 4
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 4, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableAOR Method

Overload List

Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic] Overloads Public Shared Function CFrequencyTableAOR(Series,Double()) As Series

[C#] public static Series CFrequencyTableAOR(Series,double[]);

Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic] Overloads Public Shared Function CFrequencyTableAOR(SeriesCollection,Double()) As SeriesCollection

[C#] public static SeriesCollection CFrequencyTableAOR(SeriesCollection,double[]);

Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic] Overloads Public Shared Function CFrequencyTableAOR(String,Series,Double()) As Series

[C#] public static Series CFrequencyTableAOR(string,Series,double[]);

See Also

StatisticalEngine Class | StatisticalEngine Members


CFrequencyTableAOR(Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableAOR(Series,Double[]) Method

Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic]
Overloads Public Shared Function CFrequencyTableAOR( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series CFrequencyTableAOR(
   Series s,
   double[] boundaries
);

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Exceptions

Exception | Description
ArgumentException | Thrown if the input data are not given.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open right boundary.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1,2), [2,3), [3,4), [4,5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, and if we assign this data set in accordance with the Open Right Boundary (ORB) convention then we will have:

  • Within the interval (-infinity, 1), we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3, and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 2 + 2 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 2 + 2 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 2 + 2 + 1 = 5
  • Cumulative frequency table above 3 is: 2 + 2 + 1 = 5
  • Cumulative frequency table above 4 is: 2 + 1 = 3
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 3, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


CFrequencyTableAOR(SeriesCollection,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableAOR(SeriesCollection,Double[]) Method

Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic]
Overloads Public Shared Function CFrequencyTableAOR( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
[C#]
public static SeriesCollection CFrequencyTableAOR(
   SeriesCollection sc,
   double[] boundaries
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Exceptions

Exception | Description
ArgumentException | Thrown if the input data are not given.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open right boundary.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1,2), [2,3), [3,4), [4,5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, and if we assign this data set in accordance with the Open Right Boundary (ORB) convention then we will have:

  • Within the interval (-infinity, 1), we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3, and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 2 + 2 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 2 + 2 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 2 + 2 + 1 = 5
  • Cumulative frequency table above 3 is: 2 + 2 + 1 = 5
  • Cumulative frequency table above 4 is: 2 + 1 = 3
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 3, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


CFrequencyTableAOR(String,Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableAOR(String,Series,Double[]) Method

Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic]
Overloads Public Shared Function CFrequencyTableAOR( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series CFrequencyTableAOR(
   string seriesName,
   Series s,
   double[] boundaries
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Exceptions

Exception | Description
ArgumentException | Thrown if data set or boundaries intervals are null.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open right boundary.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1,2), [2,3), [3,4), [4,5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, and if we assign this data set in accordance with the Open Right Boundary (ORB) convention then we will have:

  • Within the interval (-infinity, 1), we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3, and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 2 + 2 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 2 + 2 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 2 + 2 + 1 = 5
  • Cumulative frequency table above 3 is: 2 + 2 + 1 = 5
  • Cumulative frequency table above 4 is: 2 + 1 = 3
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 3, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableBOL Method

Overload List

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic] Overloads Public Shared Function CFrequencyTableBOL(Series,Double()) As Series

[C#] public static Series CFrequencyTableBOL(Series,double[]);

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic] Overloads Public Shared Function CFrequencyTableBOL(SeriesCollection,Double()) As SeriesCollection

[C#] public static SeriesCollection CFrequencyTableBOL(SeriesCollection,double[]);

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic] Overloads Public Shared Function CFrequencyTableBOL(String,Series,Double()) As Series

[C#] public static Series CFrequencyTableBOL(string,Series,double[]);

See Also

StatisticalEngine Class | StatisticalEngine Members


CFrequencyTableBOL(Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableBOL(Series,Double[]) Method

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic]
Overloads Public Shared Function CFrequencyTableBOL( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series CFrequencyTableBOL(
   Series s,
   double[] boundaries
);

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Exceptions

Exception | Description
ArgumentException | Thrown if the input data are not given.
ArgumentException | Thrown if data set or the boundaries intervals are null.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 4
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 4, 5, 5, 6, 7}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


CFrequencyTableBOL(SeriesCollection,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableBOL(SeriesCollection,Double[]) Method

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic]
Overloads Public Shared Function CFrequencyTableBOL( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
[C#]
public static SeriesCollection CFrequencyTableBOL(
   SeriesCollection sc,
   double[] boundaries
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Exceptions

Exception | Description
ArgumentException | Thrown if data set or the boundaries intervals are null.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 4
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 4, 5, 5, 6, 7}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


CFrequencyTableBOL(String,Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableBOL(String,Series,Double[]) Method

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic]
Overloads Public Shared Function CFrequencyTableBOL( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series CFrequencyTableBOL(
   string seriesName,
   Series s,
   double[] boundaries
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Exceptions

Exception | Description
ArgumentException | Thrown if the input data are not given.
ArgumentException | Thrown if data set or the boundaries intervals are null.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 4
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 4, 5, 5, 6, 7}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableBOR Method

Overload List

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic] Overloads Public Shared Function CFrequencyTableBOR(Series,Double()) As Series

[C#] public static Series CFrequencyTableBOR(Series,double[]);

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic] Overloads Public Shared Function CFrequencyTableBOR(SeriesCollection,Double()) As SeriesCollection

[C#] public static SeriesCollection CFrequencyTableBOR(SeriesCollection,double[]);

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic] Overloads Public Shared Function CFrequencyTableBOR(String,Series,Double()) As Series

[C#] public static Series CFrequencyTableBOR(string,Series,double[]);

See Also

StatisticalEngine Class | StatisticalEngine Members


CFrequencyTableBOR(Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableBOR(Series,Double[]) Method

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic]
Overloads Public Shared Function CFrequencyTableBOR( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series CFrequencyTableBOR(
   Series s,
   double[] boundaries
);

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open right boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 3
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 3, 5, 5, 6, 7}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


CFrequencyTableBOR(SeriesCollection,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableBOR(SeriesCollection,Double[]) Method

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic]
Overloads Public Shared Function CFrequencyTableBOR( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
[C#]
public static SeriesCollection CFrequencyTableBOR(
   SeriesCollection sc,
   double[] boundaries
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open right boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 3
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 3, 5, 5, 6, 7}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


CFrequencyTableBOR(String,Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

CFrequencyTableBOR(String,Series,Double[]) Method

Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic]
Overloads Public Shared Function CFrequencyTableBOR( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series CFrequencyTableBOR(
   string seriesName,
   Series s,
   double[] boundaries
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open right boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 3
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 3, 5, 5, 6, 7}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

CorrelationCoefDeterminantion Method

Overload List

Calculates the coefficient of determination for the YValues of the series.

[Visual Basic] Overloads Public Shared Function CorrelationCoefDeterminantion(Series) As Element

[C#] public static Element CorrelationCoefDeterminantion(Series);

Calculates the coefficient of determination for the YValues of the series.

[Visual Basic] Overloads Public Shared Function CorrelationCoefDeterminantion(SeriesCollection) As Series

[C#] public static Series CorrelationCoefDeterminantion(SeriesCollection);

Calculates the coefficient of determination for the YValues of the series.

[Visual Basic] Overloads Public Shared Function CorrelationCoefDeterminantion(String,Series) As Element

[C#] public static Element CorrelationCoefDeterminantion(string,Series);

Calculates the coefficient of determination for the YValues of the series.

[Visual Basic] Overloads Public Shared Function CorrelationCoefDeterminantion(String,SeriesCollection) As Series

[C#] public static Series CorrelationCoefDeterminantion(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


CorrelationCoefDeterminantion(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

CorrelationCoefDeterminantion(Series) Method

Calculates the coefficient of determination for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function CorrelationCoefDeterminantion( _
   ByVal s As Series _
) As Element
[C#]
public static Element CorrelationCoefDeterminantion(
   Series s
);

Parameters

s
A statistical series.

Return Type

The coefficient of determination of the series

Remarks

Explanation of the Coefficient of Determination

The coefficient of determination is the amount of variation in the second variable (i.e. Y) which is explained by the regression line of the second variable Y on the first variable X (see LeastSquaresEstimateY), divided by the total amount of variation of the second variable (i.e. Y).

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


CorrelationCoefDeterminantion(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

CorrelationCoefDeterminantion(SeriesCollection) Method

Calculates the coefficient of determination for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function CorrelationCoefDeterminantion( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series CorrelationCoefDeterminantion(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Explanation of the Coefficient of Determination

The coefficient of determination is the amount of variation in the second variable (i.e. Y) which is explained by the regression line of the second variable Y on the first variable X (see LeastSquaresEstimateY), divided by the total amount of variation of the second variable (i.e. Y).

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


CorrelationCoefDeterminantion(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

CorrelationCoefDeterminantion(String,Series) Method

Calculates the coefficient of determination for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function CorrelationCoefDeterminantion( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element CorrelationCoefDeterminantion(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Return Type

The coefficient of determination of the series

Remarks

Explanation of the Coefficient of Determination

The coefficient of determination is the amount of variation in the second variable (i.e. Y) which is explained by the regression line of the second variable Y on the first variable X (see LeastSquaresEstimateY), divided by the total amount of variation of the second variable (i.e. Y).

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


CorrelationCoefDeterminantion(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

CorrelationCoefDeterminantion(String,SeriesCollection) Method

Calculates the coefficient of determination for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function CorrelationCoefDeterminantion( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series CorrelationCoefDeterminantion(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Explanation of the Coefficient of Determination

The coefficient of determination is the amount of variation in the second variable (i.e. Y) which is explained by the regression line of the second variable Y on the first variable X (see LeastSquaresEstimateY), divided by the total amount of variation of the second variable (i.e. Y).

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

EstimateX Method

Overload List

Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX.

[Visual Basic] Overloads Public Shared Function EstimateX(Series,Double) As Element

[C#] public static Element EstimateX(Series,double);

Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX.

[Visual Basic] Overloads Public Shared Function EstimateX(SeriesCollection,Double) As Series

[C#] public static Series EstimateX(SeriesCollection,double);

Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX.

[Visual Basic] Overloads Public Shared Function EstimateX(String,Series,Double) As Element

[C#] public static Element EstimateX(string,Series,double);

Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX.

[Visual Basic] Overloads Public Shared Function EstimateX(String,SeriesCollection,Double) As Series

[C#] public static Series EstimateX(string,SeriesCollection,double);

See Also

StatisticalEngine Class | StatisticalEngine Members


EstimateX(Series,Double) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
See Also Languages dotnetCHARTING Send comments on this topic.

EstimateX(Series,Double) Method

Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX.

[Visual Basic]
Overloads Public Shared Function EstimateX( _
   ByVal s As Series, _
   ByVal estPoint As Double _
) As Element
[C#]
public static Element EstimateX(
   Series s,
   double estPoint
);

Parameters

s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


EstimateX(SeriesCollection,Double) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
See Also Languages dotnetCHARTING Send comments on this topic.

EstimateX(SeriesCollection,Double) Method

Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX.

[Visual Basic]
Overloads Public Shared Function EstimateX( _
   ByVal sc As SeriesCollection, _
   ByVal estPoint As Double _
) As Series
[C#]
public static Series EstimateX(
   SeriesCollection sc,
   double estPoint
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


EstimateX(String,Series,Double) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
See Also Languages dotnetCHARTING Send comments on this topic.

EstimateX(String,Series,Double) Method

Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX.

[Visual Basic]
Overloads Public Shared Function EstimateX( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal estPoint As Double _
) As Element
[C#]
public static Element EstimateX(
   string elementName,
   Series s,
   double estPoint
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


EstimateX(String,SeriesCollection,Double) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
See Also Languages dotnetCHARTING Send comments on this topic.

EstimateX(String,SeriesCollection,Double) Method

Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX.

[Visual Basic]
Overloads Public Shared Function EstimateX( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal estPoint As Double _
) As Series
[C#]
public static Series EstimateX(
   string seriesName,
   SeriesCollection sc,
   double estPoint
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

EstimateY Method

Overload List

Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY.

[Visual Basic] Overloads Public Shared Function EstimateY(Series,Double) As Element

[C#] public static Element EstimateY(Series,double);

Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY.

[Visual Basic] Overloads Public Shared Function EstimateY(SeriesCollection,Double) As Series

[C#] public static Series EstimateY(SeriesCollection,double);

Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY.

[Visual Basic] Overloads Public Shared Function EstimateY(String,Series,Double) As Element

[C#] public static Element EstimateY(string,Series,double);

Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY.

[Visual Basic] Overloads Public Shared Function EstimateY(String,SeriesCollection,Double) As Series

[C#] public static Series EstimateY(string,SeriesCollection,double);

See Also

StatisticalEngine Class | StatisticalEngine Members


EstimateY(Series,Double) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
See Also Languages dotnetCHARTING Send comments on this topic.

EstimateY(Series,Double) Method

Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY.

[Visual Basic]
Overloads Public Shared Function EstimateY( _
   ByVal s As Series, _
   ByVal estPoint As Double _
) As Element
[C#]
public static Element EstimateY(
   Series s,
   double estPoint
);

Parameters

s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


EstimateY(SeriesCollection,Double) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
See Also Languages dotnetCHARTING Send comments on this topic.

EstimateY(SeriesCollection,Double) Method

Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY.

[Visual Basic]
Overloads Public Shared Function EstimateY( _
   ByVal sc As SeriesCollection, _
   ByVal estPoint As Double _
) As Series
[C#]
public static Series EstimateY(
   SeriesCollection sc,
   double estPoint
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


EstimateY(String,Series,Double) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
See Also Languages dotnetCHARTING Send comments on this topic.

EstimateY(String,Series,Double) Method

Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY.

[Visual Basic]
Overloads Public Shared Function EstimateY( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal estPoint As Double _
) As Element
[C#]
public static Element EstimateY(
   string elementName,
   Series s,
   double estPoint
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


EstimateY(String,SeriesCollection,Double) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
See Also Languages dotnetCHARTING Send comments on this topic.

EstimateY(String,SeriesCollection,Double) Method

Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY.

[Visual Basic]
Overloads Public Shared Function EstimateY( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal estPoint As Double _
) As Series
[C#]
public static Series EstimateY(
   string seriesName,
   SeriesCollection sc,
   double estPoint
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ExponentiallyWeightedMovingAverage Method

Overload List

Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function ExponentiallyWeightedMovingAverage(Series,Double,Integer) As Series

[C#] public static Series ExponentiallyWeightedMovingAverage(Series,double,int);

Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function ExponentiallyWeightedMovingAverage(SeriesCollection,Double,Integer) As SeriesCollection

[C#] public static SeriesCollection ExponentiallyWeightedMovingAverage(SeriesCollection,double,int);

Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function ExponentiallyWeightedMovingAverage(String,Series,Double,Integer) As Series

[C#] public static Series ExponentiallyWeightedMovingAverage(string,Series,double,int);

See Also

StatisticalEngine Class | StatisticalEngine Members


ExponentiallyWeightedMovingAverage(Series,Double,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

ExponentiallyWeightedMovingAverage(Series,Double,Int32) Method

Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal s As Series, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series ExponentiallyWeightedMovingAverage(
   Series s,
   double smoothingFactor,
   int lengthOfMA
);

Parameters

s
A statistical series.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


ExponentiallyWeightedMovingAverage(SeriesCollection,Double,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

ExponentiallyWeightedMovingAverage(SeriesCollection,Double,Int32) Method

Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection ExponentiallyWeightedMovingAverage(
   SeriesCollection sc,
   double smoothingFactor,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


ExponentiallyWeightedMovingAverage(String,Series,Double,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

ExponentiallyWeightedMovingAverage(String,Series,Double,Int32) Method

Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series ExponentiallyWeightedMovingAverage(
   string seriesName,
   Series s,
   double smoothingFactor,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FrequencyTableOL Method

Overload List

Calculates the frequency table with respect to the open left boundary convention for YValues of the series.

[Visual Basic] Overloads Public Shared Function FrequencyTableOL(Series,Double()) As Series

[C#] public static Series FrequencyTableOL(Series,double[]);

Calculates the frequency table with respect to the open left boundary convention for YValues of the series.

[Visual Basic] Overloads Public Shared Function FrequencyTableOL(SeriesCollection,Double()) As SeriesCollection

[C#] public static SeriesCollection FrequencyTableOL(SeriesCollection,double[]);

Calculates the frequency table with respect to the open left boundary convention for YValues of the series.

[Visual Basic] Overloads Public Shared Function FrequencyTableOL(String,Series,Double()) As Series

[C#] public static Series FrequencyTableOL(string,Series,double[]);

See Also

StatisticalEngine Class | StatisticalEngine Members


FrequencyTableOL(Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

FrequencyTableOL(Series,Double[]) Method

Calculates the frequency table with respect to the open left boundary convention for YValues of the series.

[Visual Basic]
Overloads Public Shared Function FrequencyTableOL( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series FrequencyTableOL(
   Series s,
   double[] boundaries
);

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 3, 1, 0, 1, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


FrequencyTableOL(SeriesCollection,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

FrequencyTableOL(SeriesCollection,Double[]) Method

Calculates the frequency table with respect to the open left boundary convention for YValues of the series.

[Visual Basic]
Overloads Public Shared Function FrequencyTableOL( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
[C#]
public static SeriesCollection FrequencyTableOL(
   SeriesCollection sc,
   double[] boundaries
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 3, 1, 0, 1, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


FrequencyTableOL(String,Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

FrequencyTableOL(String,Series,Double[]) Method

Calculates the frequency table with respect to the open left boundary convention for YValues of the series.

[Visual Basic]
Overloads Public Shared Function FrequencyTableOL( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series FrequencyTableOL(
   string seriesName,
   Series s,
   double[] boundaries
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 3, 1, 0, 1, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FrequencyTableOR Method

Overload List

Calculates the frequency table with respect to the open right boundary convention for a discrete data set.

[Visual Basic] Overloads Public Shared Function FrequencyTableOR(Series,Double()) As Series

[C#] public static Series FrequencyTableOR(Series,double[]);

Calculates the frequency table with respect to the open right boundary convention for a discrete data set.

[Visual Basic] Overloads Public Shared Function FrequencyTableOR(SeriesCollection,Double()) As SeriesCollection

[C#] public static SeriesCollection FrequencyTableOR(SeriesCollection,double[]);

Calculates the frequency table with respect to the open right boundary convention for a discrete data set.

[Visual Basic] Overloads Public Shared Function FrequencyTableOR(String,Series,Double()) As Series

[C#] public static Series FrequencyTableOR(string,Series,double[]);

See Also

StatisticalEngine Class | StatisticalEngine Members


FrequencyTableOR(Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

FrequencyTableOR(Series,Double[]) Method

Calculates the frequency table with respect to the open right boundary convention for a discrete data set.

[Visual Basic]
Overloads Public Shared Function FrequencyTableOR( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series FrequencyTableOR(
   Series s,
   double[] boundaries
);

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if you assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 2, 2, 0, 1, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


FrequencyTableOR(SeriesCollection,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

FrequencyTableOR(SeriesCollection,Double[]) Method

Calculates the frequency table with respect to the open right boundary convention for a discrete data set.

[Visual Basic]
Overloads Public Shared Function FrequencyTableOR( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
[C#]
public static SeriesCollection FrequencyTableOR(
   SeriesCollection sc,
   double[] boundaries
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if you assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 2, 2, 0, 1, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


FrequencyTableOR(String,Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

FrequencyTableOR(String,Series,Double[]) Method

Calculates the frequency table with respect to the open right boundary convention for a discrete data set.

[Visual Basic]
Overloads Public Shared Function FrequencyTableOR( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series FrequencyTableOR(
   string seriesName,
   Series s,
   double[] boundaries
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if you assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 2, 2, 0, 1, 1}.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMean Method

Overload List

Calculates the geometric mean of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function GeometricMean(Series) As Element

[C#] public static Element GeometricMean(Series);

Calculates the geometric mean of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function GeometricMean(SeriesCollection) As Series

[C#] public static Series GeometricMean(SeriesCollection);

Calculates the geometric mean of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function GeometricMean(String,Series) As Element

[C#] public static Element GeometricMean(string,Series);

Calculates the geometric mean of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function GeometricMean(String,SeriesCollection) As Series

[C#] public static Series GeometricMean(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


GeometricMean(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | GeometricMean(String,Series) Method

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMean(Series) Method

Calculates the geometric mean of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function GeometricMean( _
   ByVal s As Series _
) As Element
[C#]
public static Element GeometricMean(
   Series s
);

Parameters

s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | GeometricMean(String,Series) Method


GeometricMean(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | GeometricMean(String,SeriesCollection) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMean(SeriesCollection) Method

Calculates the geometric mean of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function GeometricMean( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series GeometricMean(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | GeometricMean(String,SeriesCollection) Method


GeometricMean(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | GeometricMean(Series) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMean(String,Series) Method

Calculates the geometric mean of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function GeometricMean( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element GeometricMean(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | GeometricMean(Series) Method


GeometricMean(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | GeometricMean(SeriesCollection) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMean(String,SeriesCollection) Method

Calculates the geometric mean of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function GeometricMean( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series GeometricMean(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | GeometricMean(SeriesCollection) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMovingAverage Method

Overload List

Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function GeometricMovingAverage(Series,Integer) As Series

[C#] public static Series GeometricMovingAverage(Series,int);

Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function GeometricMovingAverage(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection GeometricMovingAverage(SeriesCollection,int);

Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function GeometricMovingAverage(String,Series,Integer) As Series

[C#] public static Series GeometricMovingAverage(string,Series,int);

See Also

StatisticalEngine Class | StatisticalEngine Members


GeometricMovingAverage(Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMovingAverage(Series,Int32) Method

Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function GeometricMovingAverage( _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series GeometricMovingAverage(
   Series s,
   int lengthOfMA
);

Parameters

s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


GeometricMovingAverage(SeriesCollection,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMovingAverage(SeriesCollection,Int32) Method

Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function GeometricMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection GeometricMovingAverage(
   SeriesCollection sc,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


GeometricMovingAverage(String,Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Simple Moving Average (MA)

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

GeometricMovingAverage(String,Series,Int32) Method

Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function GeometricMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series GeometricMovingAverage(
   string seriesName,
   Series s,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Simple Moving Average (MA)


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

IQR Method

Overload List

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic] Overloads Public Shared Function IQR(Series) As Element

[C#] public static Element IQR(Series);

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic] Overloads Public Shared Function IQR(SeriesCollection) As Series

[C#] public static Series IQR(SeriesCollection);

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic] Overloads Public Shared Function IQR(String,Series) As Element

[C#] public static Element IQR(string,Series);

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic] Overloads Public Shared Function IQR(String,SeriesCollection) As Series

[C#] public static Series IQR(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


IQR(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the range of the series's elements YValues. | IQR(String,Series) Method

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

IQR(Series) Method

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic]
Overloads Public Shared Function IQR( _
   ByVal s As Series _
) As Element
[C#]
public static Element IQR(
   Series s
);

Parameters

s
A statistical series.

Remarks

Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the range of the series's elements YValues. | IQR(String,Series) Method


IQR(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the range of the series's elements YValues. | IQR(String,SeriesCollection) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

IQR(SeriesCollection) Method

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic]
Overloads Public Shared Function IQR( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series IQR(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the range of the series's elements YValues. | IQR(String,SeriesCollection) Method


IQR(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the range of the series's elements YValues. | IQR(Series) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

IQR(String,Series) Method

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic]
Overloads Public Shared Function IQR( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element IQR(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Remarks

Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the range of the series's elements YValues. | IQR(Series) Method


IQR(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the range of the series's elements YValues. | IQR(SeriesCollection) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

IQR(String,SeriesCollection) Method

Calculates the Inter-Quartile Range(IQR) of the currently registered data set.

[Visual Basic]
Overloads Public Shared Function IQR( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series IQR(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the range of the series's elements YValues. | IQR(SeriesCollection) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Kairi Method

Overload List

Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.

[Visual Basic] Overloads Public Shared Function Kairi(Series,Series) As Series

[C#] public static Series Kairi(Series,Series);

Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.

[Visual Basic] Overloads Public Shared Function Kairi(Series,SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection Kairi(Series,SeriesCollection);

Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.

[Visual Basic] Overloads Public Shared Function Kairi(String,Series,Series) As Series

[C#] public static Series Kairi(string,Series,Series);

See Also

StatisticalEngine Class | StatisticalEngine Members


Kairi(Series,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
movingAverageSeries
A series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.
See Also Languages dotnetCHARTING Send comments on this topic.

Kairi(Series,Series) Method

Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.

[Visual Basic]
Overloads Public Shared Function Kairi( _
   ByVal s As Series, _
   ByVal movingAverageSeries As Series _
) As Series
[C#]
public static Series Kairi(
   Series s,
   Series movingAverageSeries
);

Parameters

s
A statistical series.
movingAverageSeries
A series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.

Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


Kairi(Series,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
movingAverages
A collection of series.
See Also Languages dotnetCHARTING Send comments on this topic.

Kairi(Series,SeriesCollection) Method

Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.

[Visual Basic]
Overloads Public Shared Function Kairi( _
   ByVal s As Series, _
   ByVal movingAverages As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection Kairi(
   Series s,
   SeriesCollection movingAverages
);

Parameters

s
A statistical series.
movingAverages
A collection of series.

Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


Kairi(String,Series,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
movingAverageSeries
See Also Languages dotnetCHARTING Send comments on this topic.

Kairi(String,Series,Series) Method

Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.

[Visual Basic]
Overloads Public Shared Function Kairi( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal movingAverageSeries As Series _
) As Series
[C#]
public static Series Kairi(
   string seriesName,
   Series s,
   Series movingAverageSeries
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
movingAverageSeries

Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

KendallCorrelationCoef Method

Overload List

Calculates Kendall's correlation coefficient for the YValues of the series.

[Visual Basic] Overloads Public Shared Function KendallCorrelationCoef(Series) As Element

[C#] public static Element KendallCorrelationCoef(Series);

Calculates Kendall's correlation coefficient for the YValues of the series.

[Visual Basic] Overloads Public Shared Function KendallCorrelationCoef(SeriesCollection) As Series

[C#] public static Series KendallCorrelationCoef(SeriesCollection);

Calculates Kendall's correlation coefficient for the YValues of the series.

[Visual Basic] Overloads Public Shared Function KendallCorrelationCoef(String,Series) As Element

[C#] public static Element KendallCorrelationCoef(string,Series);

Calculates Kendall's correlation coefficient for the YValues of the series.

[Visual Basic] Overloads Public Shared Function KendallCorrelationCoef(String,SeriesCollection) As Series

[C#] public static Series KendallCorrelationCoef(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


KendallCorrelationCoef(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

KendallCorrelationCoef(Series) Method

Calculates Kendall's correlation coefficient for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function KendallCorrelationCoef( _
   ByVal s As Series _
) As Element
[C#]
public static Element KendallCorrelationCoef(
   Series s
);

Parameters

s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


KendallCorrelationCoef(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

KendallCorrelationCoef(SeriesCollection) Method

Calculates Kendall's correlation coefficient for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function KendallCorrelationCoef( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series KendallCorrelationCoef(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


KendallCorrelationCoef(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

KendallCorrelationCoef(String,Series) Method

Calculates Kendall's correlation coefficient for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function KendallCorrelationCoef( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element KendallCorrelationCoef(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


KendallCorrelationCoef(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

KendallCorrelationCoef(String,SeriesCollection) Method

Calculates Kendall's correlation coefficient for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function KendallCorrelationCoef( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series KendallCorrelationCoef(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LeastSquaresEstimateX Method

Overload List

Constructs the regression line of X on Y using the method of least squares.

[Visual Basic] Overloads Public Shared Function LeastSquaresEstimateX(Series) As Series

[C#] public static Series LeastSquaresEstimateX(Series);

Constructs the regression line of X on Y using the method of least squares.

[Visual Basic] Overloads Public Shared Function LeastSquaresEstimateX(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection LeastSquaresEstimateX(SeriesCollection);

Constructs the regression line of X on Y using the method of least squares.

[Visual Basic] Overloads Public Shared Function LeastSquaresEstimateX(String,Series) As Series

[C#] public static Series LeastSquaresEstimateX(string,Series);

See Also

StatisticalEngine Class | StatisticalEngine Members


LeastSquaresEstimateX(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of Y on X, using the method of least squares.

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

LeastSquaresEstimateX(Series) Method

Constructs the regression line of X on Y using the method of least squares.

[Visual Basic]
Overloads Public Shared Function LeastSquaresEstimateX( _
   ByVal s As Series _
) As Series
[C#]
public static Series LeastSquaresEstimateX(
   Series s
);

Parameters

s
A statistical series.

Remarks

That is, the regression line using the least squares method is constructed when the first element of the pairs from which the data set of constructed is plot against the second elements of the pairs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of Y on X, using the method of least squares.


LeastSquaresEstimateX(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of Y on X, using the method of least squares.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

LeastSquaresEstimateX(SeriesCollection) Method

Constructs the regression line of X on Y using the method of least squares.

[Visual Basic]
Overloads Public Shared Function LeastSquaresEstimateX( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection LeastSquaresEstimateX(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

That is, the regression line using the least squares method is constructed when the first element of the pairs from which the data set of constructed is plot against the second elements of the pairs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of Y on X, using the method of least squares.


LeastSquaresEstimateX(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of Y on X, using the method of least squares.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

LeastSquaresEstimateX(String,Series) Method

Constructs the regression line of X on Y using the method of least squares.

[Visual Basic]
Overloads Public Shared Function LeastSquaresEstimateX( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series LeastSquaresEstimateX(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.

Remarks

That is, the regression line using the least squares method is constructed when the first element of the pairs from which the data set of constructed is plot against the second elements of the pairs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of Y on X, using the method of least squares.


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LeastSquaresEstimateY Method

Overload List

Constructs the regression line of Y on X using the method of least squares.

[Visual Basic] Overloads Public Shared Function LeastSquaresEstimateY(Series) As Series

[C#] public static Series LeastSquaresEstimateY(Series);

Constructs the regression line of Y on X using the method of least squares.

[Visual Basic] Overloads Public Shared Function LeastSquaresEstimateY(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection LeastSquaresEstimateY(SeriesCollection);

Constructs the regression line of Y on X using the method of least squares.

[Visual Basic] Overloads Public Shared Function LeastSquaresEstimateY(String,Series) As Series

[C#] public static Series LeastSquaresEstimateY(string,Series);

See Also

StatisticalEngine Class | StatisticalEngine Members


LeastSquaresEstimateY(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of X on Y, using the method of least squares.

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

LeastSquaresEstimateY(Series) Method

Constructs the regression line of Y on X using the method of least squares.

[Visual Basic]
Overloads Public Shared Function LeastSquaresEstimateY( _
   ByVal s As Series _
) As Series
[C#]
public static Series LeastSquaresEstimateY(
   Series s
);

Parameters

s
A statistical series.

Remarks

That is, the regression line using the least squares method is constructed when the second element of the pairs from which the data set of constructed is plot against the first elements of the pairs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of X on Y, using the method of least squares.


LeastSquaresEstimateY(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of X on Y, using the method of least squares.

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

LeastSquaresEstimateY(SeriesCollection) Method

Constructs the regression line of Y on X using the method of least squares.

[Visual Basic]
Overloads Public Shared Function LeastSquaresEstimateY( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection LeastSquaresEstimateY(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

That is, the regression line using the least squares method is constructed when the second element of the pairs from which the data set of constructed is plot against the first elements of the pairs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of X on Y, using the method of least squares.


LeastSquaresEstimateY(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of X on Y, using the method of least squares.

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

LeastSquaresEstimateY(String,Series) Method

Constructs the regression line of Y on X using the method of least squares.

[Visual Basic]
Overloads Public Shared Function LeastSquaresEstimateY( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series LeastSquaresEstimateY(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.

Remarks

That is, the regression line using the least squares method is constructed when the second element of the pairs from which the data set of constructed is plot against the first elements of the pairs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Calculates the regression line of X on Y, using the method of least squares.


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LinearlyWeightedMovingAverage Method

Overload List

Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic] Overloads Public Shared Function LinearlyWeightedMovingAverage(Series,Integer) As Series

[C#] public static Series LinearlyWeightedMovingAverage(Series,int);

Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic] Overloads Public Shared Function LinearlyWeightedMovingAverage(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection LinearlyWeightedMovingAverage(SeriesCollection,int);

Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic] Overloads Public Shared Function LinearlyWeightedMovingAverage(String,Series,Integer) As Series

[C#] public static Series LinearlyWeightedMovingAverage(string,Series,int);

See Also

StatisticalEngine Class | StatisticalEngine Members


LinearlyWeightedMovingAverage(Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

LinearlyWeightedMovingAverage(Series,Int32) Method

Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic]
Overloads Public Shared Function LinearlyWeightedMovingAverage( _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series LinearlyWeightedMovingAverage(
   Series s,
   int lengthOfMA
);

Parameters

s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series s is empty or if its length is less than the lengthofMA.

Remarks

The Linearly Weighted Moving Average (LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


LinearlyWeightedMovingAverage(SeriesCollection,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

LinearlyWeightedMovingAverage(SeriesCollection,Int32) Method

Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic]
Overloads Public Shared Function LinearlyWeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection LinearlyWeightedMovingAverage(
   SeriesCollection sc,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series s is empty or if its length is less than the lengthofMA.

Remarks

The Linearly Weighted Moving Average (LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


LinearlyWeightedMovingAverage(String,Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

LinearlyWeightedMovingAverage(String,Series,Int32) Method

Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.

[Visual Basic]
Overloads Public Shared Function LinearlyWeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series LinearlyWeightedMovingAverage(
   string seriesName,
   Series s,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Type

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series s is empty or if its length is less than the lengthofMA.

Remarks

The Linearly Weighted Moving Average (LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LowerBollingerBands Method

Overload List

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function LowerBollingerBands(Series,Double,Integer) As Series

[C#] public static Series LowerBollingerBands(Series,double,int);

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function LowerBollingerBands(SeriesCollection,Double,Integer) As SeriesCollection

[C#] public static SeriesCollection LowerBollingerBands(SeriesCollection,double,int);

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function LowerBollingerBands(String,Series,Double,Integer) As Series

[C#] public static Series LowerBollingerBands(string,Series,double,int);

See Also

StatisticalEngine Class | StatisticalEngine Members


LowerBollingerBands(Series,Double,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A series where the first term correspond the latest periods values and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

LowerBollingerBands(Series,Double,Int32) Method

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function LowerBollingerBands( _
   ByVal s As Series, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series LowerBollingerBands(
   Series s,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

s
A series where the first term correspond the latest periods values and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


LowerBollingerBands(SeriesCollection,Double,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

LowerBollingerBands(SeriesCollection,Double,Int32) Method

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function LowerBollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection LowerBollingerBands(
   SeriesCollection sc,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


LowerBollingerBands(String,Series,Double,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term correspond the latest periods values and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

LowerBollingerBands(String,Series,Double,Int32) Method

Evaluates the position of the Lower Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function LowerBollingerBands( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series LowerBollingerBands(
   string seriesName,
   Series s,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term correspond the latest periods values and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Mean Method

Overload List

Calculates the arithmetic mean of the elements YValues of the series.

[Visual Basic] Overloads Public Shared Function Mean(Series) As Element

[C#] public static Element Mean(Series);

Calculates the arithmetic mean of the elements YValues of each of the series within the collection of series.

[Visual Basic] Overloads Public Shared Function Mean(SeriesCollection) As Series

[C#] public static Series Mean(SeriesCollection);

Calculates the arithmetic mean of the elements YValues of the series.

[Visual Basic] Overloads Public Shared Function Mean(String,Series) As Element

[C#] public static Element Mean(string,Series);

Calculates the arithmetic mean of the elements YValues of each of the series within the collection of series.

[Visual Basic] Overloads Public Shared Function Mean(String,SeriesCollection) As Series

[C#] public static Series Mean(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


Mean(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the geometric mean of the series. | Mean(String,Series) Method

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Mean(Series) Method

Calculates the arithmetic mean of the elements YValues of the series.

[Visual Basic]
Overloads Public Shared Function Mean( _
   ByVal s As Series _
) As Element
[C#]
public static Element Mean(
   Series s
);

Parameters

s
A statistical series.

Exceptions

Exception | Description
ArgumentException | Thrown if the series s is empty

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the geometric mean of the series. | Mean(String,Series) Method


Mean(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the geometric mean of the series. | Mean(String,Series) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Mean(SeriesCollection) Method

Calculates the arithmetic mean of the elements YValues of each of the series within the collection of series.

[Visual Basic]
Overloads Public Shared Function Mean( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Mean(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the geometric mean of the series. | Mean(String,Series) Method


Mean(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the geometric mean of the series. | Mean(Series) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Mean(String,Series) Method

Calculates the arithmetic mean of the elements YValues of the series.

[Visual Basic]
Overloads Public Shared Function Mean( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element Mean(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Return Type

An element with his YValue representing the arithmetic mean of the elements YValues of the series

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Thrown if the series s is empty.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the geometric mean of the series. | Mean(Series) Method


Mean(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the geometric mean of the series. | Mean(SeriesCollection) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Mean(String,SeriesCollection) Method

Calculates the arithmetic mean of the elements YValues of each of the series within the collection of series.

[Visual Basic]
Overloads Public Shared Function Mean( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Mean(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Exceptions

Exception | Description
ArgumentException | Thrown if the sc does not contain any series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the geometric mean of the series. | Mean(SeriesCollection) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MeanDeviation Method

Overload List

Calculates the mean deviation of the series's element YValues.

[Visual Basic] Overloads Public Shared Function MeanDeviation(Series) As Element

[C#] public static Element MeanDeviation(Series);

Calculates the mean deviation of the series's element YValues.

[Visual Basic] Overloads Public Shared Function MeanDeviation(SeriesCollection) As Series

[C#] public static Series MeanDeviation(SeriesCollection);

Calculates the mean deviation of the series's element YValues.

[Visual Basic] Overloads Public Shared Function MeanDeviation(String,Series) As Element

[C#] public static Element MeanDeviation(string,Series);

Calculates the mean deviation of the series's element YValues.

[Visual Basic] Overloads Public Shared Function MeanDeviation(String,SeriesCollection) As Series

[C#] public static Series MeanDeviation(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


MeanDeviation(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation - a measure of the deviation of the elements of the data set considered. | MeanDeviation(String,Series) Method

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

MeanDeviation(Series) Method

Calculates the mean deviation of the series's element YValues.

[Visual Basic]
Overloads Public Shared Function MeanDeviation( _
   ByVal s As Series _
) As Element
[C#]
public static Element MeanDeviation(
   Series s
);

Parameters

s
A statistical series.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation - a measure of the deviation of the elements of the data set considered. | MeanDeviation(String,Series) Method


MeanDeviation(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation - a measure of the deviation of the elements of the data set considered. | MeanDeviation(String,SeriesCollection) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

MeanDeviation(SeriesCollection) Method

Calculates the mean deviation of the series's element YValues.

[Visual Basic]
Overloads Public Shared Function MeanDeviation( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series MeanDeviation(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation - a measure of the deviation of the elements of the data set considered. | MeanDeviation(String,SeriesCollection) Method


MeanDeviation(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation - a measure of the deviation of the elements of the data set considered. | MeanDeviation(Series) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

MeanDeviation(String,Series) Method

Calculates the mean deviation of the series's element YValues.

[Visual Basic]
Overloads Public Shared Function MeanDeviation( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element MeanDeviation(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation - a measure of the deviation of the elements of the data set considered. | MeanDeviation(Series) Method


MeanDeviation(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation - a measure of the deviation of the elements of the data set considered. | MeanDeviation(SeriesCollection) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

MeanDeviation(String,SeriesCollection) Method

Calculates the mean deviation of the series's element YValues.

[Visual Basic]
Overloads Public Shared Function MeanDeviation( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series MeanDeviation(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation - a measure of the deviation of the elements of the data set considered. | MeanDeviation(SeriesCollection) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Median Method

Overload List

Calculates the median of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Median(Series) As Element

[C#] public static Element Median(Series);

Calculates the median of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Median(SeriesCollection) As Series

[C#] public static Series Median(SeriesCollection);

Calculates the median of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Median(String,Series) As Element

[C#] public static Element Median(string,Series);

Calculates the median of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Median(String,SeriesCollection) As Series

[C#] public static Series Median(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


Median(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series.

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Median(Series) Method

Calculates the median of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Median( _
   ByVal s As Series _
) As Element
[C#]
public static Element Median(
   Series s
);

Parameters

s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series.


Median(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | Median(String,SeriesCollection) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Median(SeriesCollection) Method

Calculates the median of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Median( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Median(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | Median(String,SeriesCollection) Method


Median(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | Median(Series) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Median(String,Series) Method

Calculates the median of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Median( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element Median(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | Median(Series) Method


Median(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | Median(SeriesCollection) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Median(String,SeriesCollection) Method

Calculates the median of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Median( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Median(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Evaluates the arithmetic mean of the series. | Median(SeriesCollection) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MedianMovingAverage Method

Overload List

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic] Overloads Public Shared Function MedianMovingAverage(Series,Series,Integer) As Series

[C#] public static Series MedianMovingAverage(Series,Series,int);

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic] Overloads Public Shared Function MedianMovingAverage(SeriesCollection,Integer) As Series

[C#] public static Series MedianMovingAverage(SeriesCollection,int);

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic] Overloads Public Shared Function MedianMovingAverage(String,Series,Series,Integer) As Series

[C#] public static Series MedianMovingAverage(string,Series,Series,int);

See Also

StatisticalEngine Class | StatisticalEngine Members


MedianMovingAverage(Series,Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

highSeries
A series where the elements corresponds to the highest recorded values.
lowSeries
A series where the elements corresponds to the lowest recorded values.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

MedianMovingAverage(Series,Series,Int32) Method

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic]
Overloads Public Shared Function MedianMovingAverage( _
   ByVal highSeries As Series, _
   ByVal lowSeries As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series MedianMovingAverage(
   Series highSeries,
   Series lowSeries,
   int lengthOfMA
);

Parameters

highSeries
A series where the elements corresponds to the highest recorded values.
lowSeries
A series where the elements corresponds to the lowest recorded values.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Type

A series where the first term is the value of the Median Moving Average for the most recent period, the second term is the value of the Median Moving Average for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series highSeries and lowSeries are of different lengths or if one of these arrays is empty.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


MedianMovingAverage(SeriesCollection,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A colection of two series: a series where the elements corresponds to the highest recorded values and a series where the elements corresponds to the lowest recorded values.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

MedianMovingAverage(SeriesCollection,Int32) Method

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic]
Overloads Public Shared Function MedianMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series MedianMovingAverage(
   SeriesCollection sc,
   int lengthOfMA
);

Parameters

sc
A colection of two series: a series where the elements corresponds to the highest recorded values and a series where the elements corresponds to the lowest recorded values.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Type

A series where the first term is the value of the Median Moving Average for the most recent period, the second term is the value of the Median Moving Average for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series highSeries and lowSeries are of different lengths or if one of these arrays is empty.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


MedianMovingAverage(String,Series,Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series.
highSeries
A series where the elements corresponds to the highest recorded values.
lowSeries
A series where the elements corresponds to the lowest recorded values.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

MedianMovingAverage(String,Series,Series,Int32) Method

Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.

[Visual Basic]
Overloads Public Shared Function MedianMovingAverage( _
   ByVal seriesName As String, _
   ByVal highSeries As Series, _
   ByVal lowSeries As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series MedianMovingAverage(
   string seriesName,
   Series highSeries,
   Series lowSeries,
   int lengthOfMA
);

Parameters

seriesName
The name of the series.
highSeries
A series where the elements corresponds to the highest recorded values.
lowSeries
A series where the elements corresponds to the lowest recorded values.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Type

A series where the first term is the value of the Median Moving Average for the most recent period, the second term is the value of the Median Moving Average for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series highSeries and lowSeries are of different lengths or if one of these arrays is empty.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PearsonCorrelationCoef Method

Overload List

Calculates Pearson's correlation coefficient for the YValues of the series.

[Visual Basic] Overloads Public Shared Function PearsonCorrelationCoef(Series) As Element

[C#] public static Element PearsonCorrelationCoef(Series);

Calculates Pearson's correlation coefficient for the YValues of the series.

[Visual Basic] Overloads Public Shared Function PearsonCorrelationCoef(SeriesCollection) As Series

[C#] public static Series PearsonCorrelationCoef(SeriesCollection);

Calculates Pearson's correlation coefficient for the YValues of the series.

[Visual Basic] Overloads Public Shared Function PearsonCorrelationCoef(String,Series) As Element

[C#] public static Element PearsonCorrelationCoef(string,Series);

Calculates Pearson's correlation coefficient for the YValues of the series.

[Visual Basic] Overloads Public Shared Function PearsonCorrelationCoef(String,SeriesCollection) As Series

[C#] public static Series PearsonCorrelationCoef(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


PearsonCorrelationCoef(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

PearsonCorrelationCoef(Series) Method

Calculates Pearson's correlation coefficient for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function PearsonCorrelationCoef( _
   ByVal s As Series _
) As Element
[C#]
public static Element PearsonCorrelationCoef(
   Series s
);

Parameters

s
A statistical series.

Return Type

Pearson's correlation coefficient of the series

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


PearsonCorrelationCoef(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

PearsonCorrelationCoef(SeriesCollection) Method

Calculates Pearson's correlation coefficient for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function PearsonCorrelationCoef( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series PearsonCorrelationCoef(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


PearsonCorrelationCoef(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

PearsonCorrelationCoef(String,Series) Method

Calculates Pearson's correlation coefficient for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function PearsonCorrelationCoef( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element PearsonCorrelationCoef(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Return Type

Pearson's correlation coefficient of the series

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


PearsonCorrelationCoef(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

PearsonCorrelationCoef(String,SeriesCollection) Method

Calculates Pearson's correlation coefficient for the YValues of the series.

[Visual Basic]
Overloads Public Shared Function PearsonCorrelationCoef( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series PearsonCorrelationCoef(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Percentile25 Method

Overload List

Calculates the first percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile25(Series) As Element

[C#] public static Element Percentile25(Series);

Calculates the first percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile25(SeriesCollection) As Series

[C#] public static Series Percentile25(SeriesCollection);

Calculates the first percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile25(String,Series) As Element

[C#] public static Element Percentile25(string,Series);

Calculates the first percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile25(String,SeriesCollection) As Series

[C#] public static Series Percentile25(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


Percentile25(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The second percentile. | The third percentile. | Percentile25(String,Series) Method

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile25(Series) Method

Calculates the first percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile25( _
   ByVal s As Series _
) As Element
[C#]
public static Element Percentile25(
   Series s
);

Parameters

s
A statistical series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The second percentile. | The third percentile. | Percentile25(String,Series) Method


Percentile25(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The second percentile. | The third percentile. | Percentile25(String,SeriesCollection) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile25(SeriesCollection) Method

Calculates the first percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile25( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Percentile25(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The second percentile. | The third percentile. | Percentile25(String,SeriesCollection) Method


Percentile25(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The second percentile. | The third percentile. | Percentile25(Series) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile25(String,Series) Method

Calculates the first percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile25( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element Percentile25(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The second percentile. | The third percentile. | Percentile25(Series) Method


Percentile25(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The second percentile. | The third percentile. | Percentile25(SeriesCollection) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile25(String,SeriesCollection) Method

Calculates the first percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile25( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Percentile25(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The second percentile. | The third percentile. | Percentile25(SeriesCollection) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Percentile50 Method

Overload List

Calculates the second percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile50(Series) As Element

[C#] public static Element Percentile50(Series);

Calculates the second percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile50(SeriesCollection) As Series

[C#] public static Series Percentile50(SeriesCollection);

Calculates the second percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile50(String,Series) As Element

[C#] public static Element Percentile50(string,Series);

Calculates the second percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile50(String,SeriesCollection) As Series

[C#] public static Series Percentile50(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


Percentile50(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The third percentile. | Percentile50(String,Series) Method

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile50(Series) Method

Calculates the second percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile50( _
   ByVal s As Series _
) As Element
[C#]
public static Element Percentile50(
   Series s
);

Parameters

s
A statistical series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The third percentile. | Percentile50(String,Series) Method


Percentile50(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The third percentile. | Percentile50(String,SeriesCollection) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile50(SeriesCollection) Method

Calculates the second percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile50( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Percentile50(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The third percentile. | Percentile50(String,SeriesCollection) Method


Percentile50(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The third percentile. | Percentile50(Series) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile50(String,Series) Method

Calculates the second percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile50( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element Percentile50(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The third percentile. | Percentile50(Series) Method


Percentile50(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The third percentile. | Percentile50(SeriesCollection) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile50(String,SeriesCollection) Method

Calculates the second percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile50( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Percentile50(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The third percentile. | Percentile50(SeriesCollection) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Percentile75 Method

Overload List

Calculates the third percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile75(Series) As Element

[C#] public static Element Percentile75(Series);

Calculates the third percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile75(SeriesCollection) As Series

[C#] public static Series Percentile75(SeriesCollection);

Calculates the third percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile75(String,Series) As Element

[C#] public static Element Percentile75(string,Series);

Calculates the third percentile of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Percentile75(String,SeriesCollection) As Series

[C#] public static Series Percentile75(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


Percentile75(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The second percentile. | Percentile75(String,Series) Method

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile75(Series) Method

Calculates the third percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile75( _
   ByVal s As Series _
) As Element
[C#]
public static Element Percentile75(
   Series s
);

Parameters

s
A statistical series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The second percentile. | Percentile75(String,Series) Method


Percentile75(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The second percentile. | Percentile75(String,SeriesCollection) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile75(SeriesCollection) Method

Calculates the third percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile75( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Percentile75(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The second percentile. | Percentile75(String,SeriesCollection) Method


Percentile75(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The second percentile. | Percentile75(Series) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile75(String,Series) Method

Calculates the third percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile75( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element Percentile75(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The second percentile. | Percentile75(Series) Method


Percentile75(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The second percentile. | Percentile75(SeriesCollection) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Percentile75(String,SeriesCollection) Method

Calculates the third percentile of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Percentile75( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Percentile75(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | The first percentile. | The second percentile. | Percentile75(SeriesCollection) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Range Method

Overload List

Calculates the range of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Range(Series) As Element

[C#] public static Element Range(Series);

Calculates the range of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Range(SeriesCollection) As Series

[C#] public static Series Range(SeriesCollection);

Calculates the range of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Range(String,Series) As Element

[C#] public static Element Range(string,Series);

Calculates the range of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Range(String,SeriesCollection) As Series

[C#] public static Series Range(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


Range(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Range(String,Series) Method

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Range(Series) Method

Calculates the range of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Range( _
   ByVal s As Series _
) As Element
[C#]
public static Element Range(
   Series s
);

Parameters

s
A statistical series.

Remarks

The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Range(String,Series) Method


Range(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Range(String,SeriesCollection) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Range(SeriesCollection) Method

Calculates the range of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Range( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Range(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Range(String,SeriesCollection) Method


Range(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Range(Series) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Range(String,Series) Method

Calculates the range of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Range( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element Range(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Remarks

The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Range(Series) Method


Range(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Range(SeriesCollection) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Range(String,SeriesCollection) Method

Calculates the range of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Range( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Range(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Range(SeriesCollection) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Residuals Method

Overload List

Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic] Overloads Public Shared Function Residuals(Series) As Series

[C#] public static Series Residuals(Series);

Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic] Overloads Public Shared Function Residuals(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection Residuals(SeriesCollection);

Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic] Overloads Public Shared Function Residuals(String,Series) As Series

[C#] public static Series Residuals(string,Series);

See Also

StatisticalEngine Class | StatisticalEngine Members


Residuals(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Residuals(Series) Method

Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic]
Overloads Public Shared Function Residuals( _
   ByVal s As Series _
) As Series
[C#]
public static Series Residuals(
   Series s
);

Parameters

s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


Residuals(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Residuals(SeriesCollection) Method

Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic]
Overloads Public Shared Function Residuals( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection Residuals(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


Residuals(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Residuals(String,Series) Method

Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic]
Overloads Public Shared Function Residuals( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series Residuals(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ResidualsAverage Method

Overload List

Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic] Overloads Public Shared Function ResidualsAverage(Series) As Element

[C#] public static Element ResidualsAverage(Series);

Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic] Overloads Public Shared Function ResidualsAverage(SeriesCollection) As Series

[C#] public static Series ResidualsAverage(SeriesCollection);

Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic] Overloads Public Shared Function ResidualsAverage(String,Series) As Element

[C#] public static Element ResidualsAverage(string,Series);

Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic] Overloads Public Shared Function ResidualsAverage(String,SeriesCollection) As Series

[C#] public static Series ResidualsAverage(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


ResidualsAverage(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

ResidualsAverage(Series) Method

Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic]
Overloads Public Shared Function ResidualsAverage( _
   ByVal s As Series _
) As Element
[C#]
public static Element ResidualsAverage(
   Series s
);

Parameters

s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


ResidualsAverage(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

ResidualsAverage(SeriesCollection) Method

Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic]
Overloads Public Shared Function ResidualsAverage( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series ResidualsAverage(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


ResidualsAverage(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

ResidualsAverage(String,Series) Method

Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic]
Overloads Public Shared Function ResidualsAverage( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element ResidualsAverage(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


ResidualsAverage(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

ResidualsAverage(String,SeriesCollection) Method

Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.

[Visual Basic]
Overloads Public Shared Function ResidualsAverage( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series ResidualsAverage(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RFrequencyTableOL Method

Overload List

Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic] Overloads Public Shared Function RFrequencyTableOL(Series,Double()) As Series

[C#] public static Series RFrequencyTableOL(Series,double[]);

Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic] Overloads Public Shared Function RFrequencyTableOL(SeriesCollection,Double()) As SeriesCollection

[C#] public static SeriesCollection RFrequencyTableOL(SeriesCollection,double[]);

Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic] Overloads Public Shared Function RFrequencyTableOL(String,Series,Double()) As Series

[C#] public static Series RFrequencyTableOL(string,Series,double[]);

See Also

StatisticalEngine Class | StatisticalEngine Members


RFrequencyTableOL(Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

RFrequencyTableOL(Series,Double[]) Method

Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic]
Overloads Public Shared Function RFrequencyTableOL( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series RFrequencyTableOL(
   Series s,
   double[] boundaries
);

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open left boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open left boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Left Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1], (b_1,b_2], (b_2,b_3], (b_3,b_4], (b_4,b_5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


RFrequencyTableOL(SeriesCollection,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

RFrequencyTableOL(SeriesCollection,Double[]) Method

Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic]
Overloads Public Shared Function RFrequencyTableOL( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
[C#]
public static SeriesCollection RFrequencyTableOL(
   SeriesCollection sc,
   double[] boundaries
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open left boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open left boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Left Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1], (b_1,b_2], (b_2,b_3], (b_3,b_4], (b_4,b_5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


RFrequencyTableOL(String,Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

RFrequencyTableOL(String,Series,Double[]) Method

Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.

[Visual Basic]
Overloads Public Shared Function RFrequencyTableOL( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series RFrequencyTableOL(
   string seriesName,
   Series s,
   double[] boundaries
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open left boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open left boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Left Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1], (b_1,b_2], (b_2,b_3], (b_3,b_4], (b_4,b_5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RFrequencyTableOR Method

Overload List

Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic] Overloads Public Shared Function RFrequencyTableOR(Series,Double()) As Series

[C#] public static Series RFrequencyTableOR(Series,double[]);

Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic] Overloads Public Shared Function RFrequencyTableOR(SeriesCollection,Double()) As SeriesCollection

[C#] public static SeriesCollection RFrequencyTableOR(SeriesCollection,double[]);

Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic] Overloads Public Shared Function RFrequencyTableOR(String,Series,Double()) As Series

[C#] public static Series RFrequencyTableOR(string,Series,double[]);

See Also

StatisticalEngine Class | StatisticalEngine Members


RFrequencyTableOR(Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

RFrequencyTableOR(Series,Double[]) Method

Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic]
Overloads Public Shared Function RFrequencyTableOR( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series RFrequencyTableOR(
   Series s,
   double[] boundaries
);

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open right boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open right boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Right Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1), [b_1,b_2), [b_2,b_3), [b_3,b_4), [b_4,b_5), [b_5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


RFrequencyTableOR(SeriesCollection,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

RFrequencyTableOR(SeriesCollection,Double[]) Method

Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic]
Overloads Public Shared Function RFrequencyTableOR( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
[C#]
public static SeriesCollection RFrequencyTableOR(
   SeriesCollection sc,
   double[] boundaries
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open right boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open right boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Right Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1), [b_1,b_2), [b_2,b_3), [b_3,b_4), [b_4,b_5), [b_5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


RFrequencyTableOR(String,Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
See Also Languages dotnetCHARTING Send comments on this topic.

RFrequencyTableOR(String,Series,Double[]) Method

Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.

[Visual Basic]
Overloads Public Shared Function RFrequencyTableOR( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
[C#]
public static Series RFrequencyTableOR(
   string seriesName,
   Series s,
   double[] boundaries
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.

Remarks

The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open right boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open right boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Right Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1), [b_1,b_2), [b_2,b_3), [b_3,b_4), [b_4,b_5), [b_5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SimpleMovingAverage Method

Overload List

Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function SimpleMovingAverage(Series,Integer) As Series

[C#] public static Series SimpleMovingAverage(Series,int);

Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function SimpleMovingAverage(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection SimpleMovingAverage(SeriesCollection,int);

Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic] Overloads Public Shared Function SimpleMovingAverage(String,Series,Integer) As Series

[C#] public static Series SimpleMovingAverage(string,Series,int);

See Also

StatisticalEngine Class | StatisticalEngine Members


SimpleMovingAverage(Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Geometric Moving Average (GMA) | SimpleMovingAverage(String,Series,Int32) Method | SimpleMovingAverage(SeriesCollection,Int32) Method

Language

Visual Basic

C#

Show All

s
A statistical series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

SimpleMovingAverage(Series,Int32) Method

Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function SimpleMovingAverage( _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series SimpleMovingAverage(
   Series s,
   int lengthOfMA
);

Parameters

s
A statistical series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Geometric Moving Average (GMA) | SimpleMovingAverage(String,Series,Int32) Method | SimpleMovingAverage(SeriesCollection,Int32) Method


SimpleMovingAverage(SeriesCollection,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Geometric Moving Average (GMA) | SimpleMovingAverage(String,Series,Int32) Method | SimpleMovingAverage(Series,Int32) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

SimpleMovingAverage(SeriesCollection,Int32) Method

Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function SimpleMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection SimpleMovingAverage(
   SeriesCollection sc,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Geometric Moving Average (GMA) | SimpleMovingAverage(String,Series,Int32) Method | SimpleMovingAverage(Series,Int32) Method


SimpleMovingAverage(String,Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Geometric Moving Average (GMA) | SimpleMovingAverage(Series,Int32) Method | SimpleMovingAverage(SeriesCollection,Int32) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

SimpleMovingAverage(String,Series,Int32) Method

Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.

[Visual Basic]
Overloads Public Shared Function SimpleMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series SimpleMovingAverage(
   string seriesName,
   Series s,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Type

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the series is empty.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Geometric Moving Average (GMA) | SimpleMovingAverage(Series,Int32) Method | SimpleMovingAverage(SeriesCollection,Int32) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SpearmanRankCorrelationTest Method

Overload List

Calculates Spearson's Rank correlation coefficient for the current data set.

[Visual Basic] Overloads Public Shared Function SpearmanRankCorrelationTest(Series) As Element

[C#] public static Element SpearmanRankCorrelationTest(Series);

Calculates Spearson's Rank correlation coefficient for the current data set.

[Visual Basic] Overloads Public Shared Function SpearmanRankCorrelationTest(SeriesCollection) As Series

[C#] public static Series SpearmanRankCorrelationTest(SeriesCollection);

Calculates Spearson's Rank correlation coefficient for the current data set.

[Visual Basic] Overloads Public Shared Function SpearmanRankCorrelationTest(String,Series) As Element

[C#] public static Element SpearmanRankCorrelationTest(string,Series);

Calculates Spearson's Rank correlation coefficient for the current data set.

[Visual Basic] Overloads Public Shared Function SpearmanRankCorrelationTest(String,SeriesCollection) As Series

[C#] public static Series SpearmanRankCorrelationTest(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


SpearmanRankCorrelationTest(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

SpearmanRankCorrelationTest(Series) Method

Calculates Spearson's Rank correlation coefficient for the current data set.

[Visual Basic]
Overloads Public Shared Function SpearmanRankCorrelationTest( _
   ByVal s As Series _
) As Element
[C#]
public static Element SpearmanRankCorrelationTest(
   Series s
);

Parameters

s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


SpearmanRankCorrelationTest(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

SpearmanRankCorrelationTest(SeriesCollection) Method

Calculates Spearson's Rank correlation coefficient for the current data set.

[Visual Basic]
Overloads Public Shared Function SpearmanRankCorrelationTest( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series SpearmanRankCorrelationTest(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


SpearmanRankCorrelationTest(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

SpearmanRankCorrelationTest(String,Series) Method

Calculates Spearson's Rank correlation coefficient for the current data set.

[Visual Basic]
Overloads Public Shared Function SpearmanRankCorrelationTest( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element SpearmanRankCorrelationTest(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


SpearmanRankCorrelationTest(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

SpearmanRankCorrelationTest(String,SeriesCollection) Method

Calculates Spearson's Rank correlation coefficient for the current data set.

[Visual Basic]
Overloads Public Shared Function SpearmanRankCorrelationTest( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series SpearmanRankCorrelationTest(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StandardDeviation Method

Overload List

Calculates the sample standard variance of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function StandardDeviation(Series) As Element

[C#] public static Element StandardDeviation(Series);

Calculates the sample standard variance of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function StandardDeviation(SeriesCollection) As Series

[C#] public static Series StandardDeviation(SeriesCollection);

Calculates the sample standard variance of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function StandardDeviation(String,Series) As Element

[C#] public static Element StandardDeviation(string,Series);

Calculates the sample standard variance of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function StandardDeviation(String,SeriesCollection) As Series

[C#] public static Series StandardDeviation(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


StandardDeviation(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered. | StandardDeviation(String,Series) Method

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

StandardDeviation(Series) Method

Calculates the sample standard variance of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function StandardDeviation( _
   ByVal s As Series _
) As Element
[C#]
public static Element StandardDeviation(
   Series s
);

Parameters

s
A statistical series.

Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance in which the deviation is measured in units which are the squares of the units of the observations.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered. | StandardDeviation(String,Series) Method


StandardDeviation(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered. | StandardDeviation(String,SeriesCollection) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

StandardDeviation(SeriesCollection) Method

Calculates the sample standard variance of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function StandardDeviation( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series StandardDeviation(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance in which the deviation is measured in units which are the squares of the units of the observations.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered. | StandardDeviation(String,SeriesCollection) Method


StandardDeviation(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered. | StandardDeviation(Series) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

StandardDeviation(String,Series) Method

Calculates the sample standard variance of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function StandardDeviation( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element StandardDeviation(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance in which the deviation is measured in units which are the squares of the units of the observations.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered. | StandardDeviation(Series) Method


StandardDeviation(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered. | StandardDeviation(SeriesCollection) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

StandardDeviation(String,SeriesCollection) Method

Calculates the sample standard variance of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function StandardDeviation( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series StandardDeviation(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance in which the deviation is measured in units which are the squares of the units of the observations.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | Another measure of the deviation of the elements of the data set considered. | StandardDeviation(SeriesCollection) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TriangularMovingAverage Method

Overload List

Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function TriangularMovingAverage(Series,Integer) As Series

[C#] public static Series TriangularMovingAverage(Series,int);

Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function TriangularMovingAverage(SeriesCollection,Integer) As SeriesCollection

[C#] public static SeriesCollection TriangularMovingAverage(SeriesCollection,int);

Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic] Overloads Public Shared Function TriangularMovingAverage(String,Series,Integer) As Series

[C#] public static Series TriangularMovingAverage(string,Series,int);

See Also

StatisticalEngine Class | StatisticalEngine Members


TriangularMovingAverage(Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

TriangularMovingAverage(Series,Int32) Method

Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function TriangularMovingAverage( _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series TriangularMovingAverage(
   Series s,
   int lengthOfMA
);

Parameters

s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


TriangularMovingAverage(SeriesCollection,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

TriangularMovingAverage(SeriesCollection,Int32) Method

Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function TriangularMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection TriangularMovingAverage(
   SeriesCollection sc,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


TriangularMovingAverage(String,Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
See Also Languages dotnetCHARTING Send comments on this topic.

TriangularMovingAverage(String,Series,Int32) Method

Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.

[Visual Basic]
Overloads Public Shared Function TriangularMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series TriangularMovingAverage(
   string seriesName,
   Series s,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

UpperBollingerBands Method

Overload List

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function UpperBollingerBands(Series,Double,Integer) As Series

[C#] public static Series UpperBollingerBands(Series,double,int);

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function UpperBollingerBands(SeriesCollection,Double,Integer) As SeriesCollection

[C#] public static SeriesCollection UpperBollingerBands(SeriesCollection,double,int);

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic] Overloads Public Shared Function UpperBollingerBands(String,Series,Double,Integer) As Series

[C#] public static Series UpperBollingerBands(string,Series,double,int);

See Also

StatisticalEngine Class | StatisticalEngine Members


UpperBollingerBands(Series,Double,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series where the first term correspond the latest periods value and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

UpperBollingerBands(Series,Double,Int32) Method

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function UpperBollingerBands( _
   ByVal s As Series, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series UpperBollingerBands(
   Series s,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

s
An series where the first term correspond the latest periods value and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


UpperBollingerBands(SeriesCollection,Double,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

UpperBollingerBands(SeriesCollection,Double,Int32) Method

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function UpperBollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection UpperBollingerBands(
   SeriesCollection sc,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


UpperBollingerBands(String,Series,Double,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term correspond the latest periods value and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

UpperBollingerBands(String,Series,Double,Int32) Method

Evaluates the position of the Upper Bollinger Band for a given standard deviation level.

[Visual Basic]
Overloads Public Shared Function UpperBollingerBands( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series UpperBollingerBands(
   string seriesName,
   Series s,
   double standardDeviationLevel,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term correspond the latest periods value and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Type

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.

Remarks

Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Variance Method

Overload List

Calculates the sample variance of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Variance(Series) As Element

[C#] public static Element Variance(Series);

Calculates the sample variance of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Variance(SeriesCollection) As Series

[C#] public static Series Variance(SeriesCollection);

Calculates the sample variance of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Variance(String,Series) As Element

[C#] public static Element Variance(string,Series);

Calculates the sample variance of the series's elements YValues.

[Visual Basic] Overloads Public Shared Function Variance(String,SeriesCollection) As Series

[C#] public static Series Variance(string,SeriesCollection);

See Also

StatisticalEngine Class | StatisticalEngine Members


Variance(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation(String,Series) Method | A measure of the deviation of the elements of the data set considered. | Variance(String,Series) Method

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Variance(Series) Method

Calculates the sample variance of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Variance( _
   ByVal s As Series _
) As Element
[C#]
public static Element Variance(
   Series s
);

Parameters

s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation(String,Series) Method | A measure of the deviation of the elements of the data set considered. | Variance(String,Series) Method


Variance(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation(String,Series) Method | A measure of the deviation of the elements of the data set considered. | Variance(String,SeriesCollection) Method

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Variance(SeriesCollection) Method

Calculates the sample variance of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Variance( _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Variance(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation(String,Series) Method | A measure of the deviation of the elements of the data set considered. | Variance(String,SeriesCollection) Method


Variance(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation(String,Series) Method | StatndardDeviation - a measure of the deviation of the elements of the data set considered. | Variance(Series) Method

Language

Visual Basic

C#

Show All

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

Variance(String,Series) Method

Calculates the sample variance of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Variance( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
[C#]
public static Element Variance(
   string elementName,
   Series s
);

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation(String,Series) Method | StatndardDeviation - a measure of the deviation of the elements of the data set considered. | Variance(Series) Method


Variance(String,SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation(String,Series) Method | A measure of the deviation of the elements of the data set considered. | Variance(SeriesCollection) Method

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

Variance(String,SeriesCollection) Method

Calculates the sample variance of the series's elements YValues.

[Visual Basic]
Overloads Public Shared Function Variance( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
[C#]
public static Series Variance(
   string seriesName,
   SeriesCollection sc
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List | StandardDeviation(String,Series) Method | A measure of the deviation of the elements of the data set considered. | Variance(SeriesCollection) Method


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage Method

Overload List

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(Series,Double()) As Series

[C#] public static Series WeightedMovingAverage(Series,double[]);

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(Series,Series,Integer) As Series

[C#] public static Series WeightedMovingAverage(Series,Series,int);

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(SeriesCollection,Double()) As SeriesCollection

[C#] public static SeriesCollection WeightedMovingAverage(SeriesCollection,double[]);

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(SeriesCollection,Series,Integer) As SeriesCollection

[C#] public static SeriesCollection WeightedMovingAverage(SeriesCollection,Series,int);

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(String,Series,Double()) As Series

[C#] public static Series WeightedMovingAverage(string,Series,double[]);

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic] Overloads Public Shared Function WeightedMovingAverage(String,Series,Series,Integer) As Series

[C#] public static Series WeightedMovingAverage(string,Series,Series,int);

See Also

StatisticalEngine Class | StatisticalEngine Members


WeightedMovingAverage(Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(Series,Double[]) Method

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal s As Series, _
   ByVal weights() As Double _
) As Series
[C#]
public static Series WeightedMovingAverage(
   Series s,
   double[] weights
);

Parameters

s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.

Remarks

I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to

(historicalPrices,
            weights, lengthOfMovingAverage)
.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


WeightedMovingAverage(Series,Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
An statistical series
weightSeries
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(Series,Series,Int32) Method

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal s As Series, _
   ByVal weightSeries As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series WeightedMovingAverage(
   Series s,
   Series weightSeries,
   int lengthOfMA
);

Parameters

s
An statistical series
weightSeries
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weightsSeries and s differ or if either series is empty.

Remarks

That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


WeightedMovingAverage(SeriesCollection,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(SeriesCollection,Double[]) Method

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal weights() As Double _
) As SeriesCollection
[C#]
public static SeriesCollection WeightedMovingAverage(
   SeriesCollection sc,
   double[] weights
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.

Remarks

I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to

(historicalPrices,
            weights, lengthOfMovingAverage)
.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


WeightedMovingAverage(SeriesCollection,Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
weightSeries
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(SeriesCollection,Series,Int32) Method

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal weightSeries As Series, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
[C#]
public static SeriesCollection WeightedMovingAverage(
   SeriesCollection sc,
   Series weightSeries,
   int lengthOfMA
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
weightSeries
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weightsSeries and s differ or if either series is empty.

Remarks

That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


WeightedMovingAverage(String,Series,Double[]) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(String,Series,Double[]) Method

Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal weights() As Double _
) As Series
[C#]
public static Series WeightedMovingAverage(
   string seriesName,
   Series s,
   double[] weights
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.

Remarks

I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to

(historicalPrices,
            weights, lengthOfMovingAverage)
.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


WeightedMovingAverage(String,Series,Series,Int32) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An statistical series
weightSeries
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.
See Also Languages dotnetCHARTING Send comments on this topic.

WeightedMovingAverage(String,Series,Series,Int32) Method

Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.

[Visual Basic]
Overloads Public Shared Function WeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal weightSeries As Series, _
   ByVal lengthOfMA As Integer _
) As Series
[C#]
public static Series WeightedMovingAverage(
   string seriesName,
   Series s,
   Series weightSeries,
   int lengthOfMA
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An statistical series
weightSeries
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Type

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.

Exceptions

Exception | Description
ArgumentException | Thrown if the length of the weightsSeries and s differ or if either series is empty.

Remarks

That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine Class | StatisticalEngine Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ZScore Method

Overload List

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic] Overloads Public Shared Function ZScore(Series) As Series

[C#] public static Series ZScore(Series);

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic] Overloads Public Shared Function ZScore(SeriesCollection) As SeriesCollection

[C#] public static SeriesCollection ZScore(SeriesCollection);

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic] Overloads Public Shared Function ZScore(String,Series) As Series

[C#] public static Series ZScore(string,Series);

See Also

StatisticalEngine Class | StatisticalEngine Members


ZScore(Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

ZScore(Series) Method

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic]
Overloads Public Shared Function ZScore( _
   ByVal s As Series _
) As Series
[C#]
public static Series ZScore(
   Series s
);

Parameters

s
A statistical series.

Remarks

The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


ZScore(SeriesCollection) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
See Also Languages dotnetCHARTING Send comments on this topic.

ZScore(SeriesCollection) Method

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic]
Overloads Public Shared Function ZScore( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
[C#]
public static SeriesCollection ZScore(
   SeriesCollection sc
);

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Remarks

The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


ZScore(String,Series) Method

StatisticalEngine Class | StatisticalEngine Members | Overload List

Language

Visual Basic

C#

Show All

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
See Also Languages dotnetCHARTING Send comments on this topic.

ZScore(String,Series) Method

Evaluates the z-score (often referred to as the standardized value) of an element series's element values.

[Visual Basic]
Overloads Public Shared Function ZScore( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
[C#]
public static Series ZScore(
   string seriesName,
   Series s
);

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.

Remarks

The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.

See Also

StatisticalEngine Class | StatisticalEngine Members | Overload List


StatisticalEngine.Options Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StatisticalEngine.Options Class

Defines a set of static options used with StatisticalEngine calculations.

For a list of all members of this type, see StatisticalEngine.Options members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.StatisticalEngine.Options

Syntax

[Visual Basic]
Public NotInheritable Class StatisticalEngine.Options
[C#]
public sealed class StatisticalEngine.Options

See Also

StatisticalEngine.Options Members | dotnetCHARTING Namespace


StatisticalEngine.Options Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

StatisticalEngine.Options Class Members

StatisticalEngine.Options overview

Public Properties

Public Property static (Shared in Visual Basic) MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
Public Property static (Shared in Visual Basic) PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.

Public Methods

Public Method static (Shared in Visual Basic) Reset Resets the options to default settings.

See Also

StatisticalEngine.Options Class | dotnetCHARTING Namespace


StatisticalEngine.Options Class Methods

StatisticalEngine.Options Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

StatisticalEngine.Options Class Members

For a list of all members of this type, see StatisticalEngine.Options members.

Public Methods

Public Method static (Shared in Visual Basic) Reset Resets the options to default settings.

See Also

StatisticalEngine.Options Class | dotnetCHARTING Namespace


StatisticalEngine.Options Class | StatisticalEngine.Options Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Reset Method

Resets the options to default settings.

[Visual Basic]
Public Shared Sub Reset()
[C#]
public static void Reset();

See Also

StatisticalEngine.Options Class | StatisticalEngine.Options Members


StatisticalEngine.Options Class Properties

StatisticalEngine.Options Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

StatisticalEngine.Options Class Members

For a list of all members of this type, see StatisticalEngine.Options members.

Public Properties

Public Property static (Shared in Visual Basic) MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
Public Property static (Shared in Visual Basic) PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.

See Also

StatisticalEngine.Options Class | dotnetCHARTING Namespace


StatisticalEngine.Options Class | StatisticalEngine.Options Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

MatchColors Property

Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.

[Visual Basic]
Public Shared Property MatchColors As Boolean
[C#]
public static bool MatchColors {get; set;}

See Also

StatisticalEngine.Options Class | StatisticalEngine.Options Members


StatisticalEngine.Options Class | StatisticalEngine.Options Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PopulateSubValues Property

Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.

[Visual Basic]
Public Shared Property PopulateSubValues As Boolean
[C#]
public static bool PopulateSubValues {get; set;}

See Also

StatisticalEngine.Options Class | StatisticalEngine.Options Members


SubValue Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SubValue Class

Represents a value relative to or independent of the parent element's value.

For a list of all members of this type, see SubValue members.

Object Model

Inheritance Hierarchy

System.Object
dotnetCHARTING.SubValue

Syntax

[Visual Basic]
Public Class SubValue
[C#]
public class SubValue

See Also

SubValue Members | dotnetCHARTING Namespace


SubValue Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SubValue Class Members

SubValue overview

Public Constructors

Public Constructor SubValue Constructor

Public Properties

Public Property ErrorHigh |
Public Property ErrorHighValue |
Public Property ErrorLow |
Public Property ErrorLowValue |
Public Property ErrorPercentageHigh |
Public Property ErrorPercentageLow |
Public Property Line | Gets or sets a Line object used to draw the lines of this SubValue.
Public Property Marker | Gets or sets an ElementMarker object drawn when the SubValue's type is set to SubValueType.Marker..
Public Property Type | Gets or sets a SubValueType that determines how this sub value is drawn.

Public Methods

Public Method static (Shared in Visual Basic) FromHighLowValue | Creates a new instance of a SubValue object with an independent range based on the specified low and high values.
Public Method static (Shared in Visual Basic) FromOffset | Creates a new instance of a SubValue class with a single value offset from an element's Yvalue.
Public Method static (Shared in Visual Basic) FromPercent | Creates a new instance of a SubValue class with a single value based on the specified percentage of the related element's Yvalue.
Public Method static (Shared in Visual Basic) FromPlusMinusOffset | Overloaded.
Public Method static (Shared in Visual Basic) FromPlusMinusPercent | Overloaded.
Public Method static (Shared in Visual Basic) FromValue | Creates a new instance of a SubValue class with a single independent value.

See Also

SubValue Class | dotnetCHARTING Namespace


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SubValue Constructor

[Visual Basic]
Public Function New()
[C#]
public SubValue();

See Also

SubValue Class | SubValue Members


SubValue Class Methods

SubValue Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SubValue Class Members

For a list of all members of this type, see SubValue members.

Public Methods

Public Method static (Shared in Visual Basic) FromHighLowValue | Creates a new instance of a SubValue object with an independent range based on the specified low and high values.
Public Method static (Shared in Visual Basic) FromOffset | Creates a new instance of a SubValue class with a single value offset from an element's Yvalue.
Public Method static (Shared in Visual Basic) FromPercent | Creates a new instance of a SubValue class with a single value based on the specified percentage of the related element's Yvalue.
Public Method static (Shared in Visual Basic) FromPlusMinusOffset | Overloaded.
Public Method static (Shared in Visual Basic) FromPlusMinusPercent | Overloaded.
Public Method static (Shared in Visual Basic) FromValue | Creates a new instance of a SubValue class with a single independent value.

See Also

SubValue Class | dotnetCHARTING Namespace


FromHighLowValue Method

SubValue Class | SubValue Members

Language

Visual Basic

C#

Show All

high
low
See Also Languages dotnetCHARTING Send comments on this topic.

FromHighLowValue Method

Creates a new instance of a SubValue object with an independent range based on the specified low and high values.

[Visual Basic]
Public Shared Function FromHighLowValue( _
   ByVal high As Double, _
   ByVal low As Double _
) As SubValue
[C#]
public static SubValue FromHighLowValue(
   double high,
   double low
);

Parameters

high
low

See Also

SubValue Class | SubValue Members


FromOffset Method

SubValue Class | SubValue Members

Language

Visual Basic

C#

Show All

offset
See Also Languages dotnetCHARTING Send comments on this topic.

FromOffset Method

Creates a new instance of a SubValue class with a single value offset from an element's Yvalue.

[Visual Basic]
Public Shared Function FromOffset( _
   ByVal offset As Double _
) As SubValue
[C#]
public static SubValue FromOffset(
   double offset
);

Parameters

offset

See Also

SubValue Class | SubValue Members


FromPercent Method

SubValue Class | SubValue Members

Language

Visual Basic

C#

Show All

percent
See Also Languages dotnetCHARTING Send comments on this topic.

FromPercent Method

Creates a new instance of a SubValue class with a single value based on the specified percentage of the related element's Yvalue.

[Visual Basic]
Public Shared Function FromPercent( _
   ByVal percent As Double _
) As SubValue
[C#]
public static SubValue FromPercent(
   double percent
);

Parameters

percent

See Also

SubValue Class | SubValue Members


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FromPlusMinusOffset Method

Overload List

Creates a new instance of a SubValue class with a range offset from an element's Yvalue in both directions. Hence, the resulting range will be twice the specified offset value.

[Visual Basic] Overloads Public Shared Function FromPlusMinusOffset(Double) As SubValue

[C#] public static SubValue FromPlusMinusOffset(double);

Creates a new instance of a SubValue class with a different range offset from an element's Yvalue in both directions. Hence, the resulting range will be the sum of the high and low offset values.

[Visual Basic] Overloads Public Shared Function FromPlusMinusOffset(Double,Double) As SubValue

[C#] public static SubValue FromPlusMinusOffset(double,double);

See Also

SubValue Class | SubValue Members


FromPlusMinusOffset(Double) Method

SubValue Class | SubValue Members | Overload List

Language

Visual Basic

C#

Show All

offset
See Also Languages dotnetCHARTING Send comments on this topic.

FromPlusMinusOffset(Double) Method

Creates a new instance of a SubValue class with a range offset from an element's Yvalue in both directions. Hence, the resulting range will be twice the specified offset value.

[Visual Basic]
Overloads Public Shared Function FromPlusMinusOffset( _
   ByVal offset As Double _
) As SubValue
[C#]
public static SubValue FromPlusMinusOffset(
   double offset
);

Parameters

offset

See Also

SubValue Class | SubValue Members | Overload List


FromPlusMinusOffset(Double,Double) Method

SubValue Class | SubValue Members | Overload List

Language

Visual Basic

C#

Show All

plus
minus
See Also Languages dotnetCHARTING Send comments on this topic.

FromPlusMinusOffset(Double,Double) Method

Creates a new instance of a SubValue class with a different range offset from an element's Yvalue in both directions. Hence, the resulting range will be the sum of the high and low offset values.

[Visual Basic]
Overloads Public Shared Function FromPlusMinusOffset( _
   ByVal plus As Double, _
   ByVal minus As Double _
) As SubValue
[C#]
public static SubValue FromPlusMinusOffset(
   double plus,
   double minus
);

Parameters

plus
minus

See Also

SubValue Class | SubValue Members | Overload List


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FromPlusMinusPercent Method

Overload List

Creates a new instance of a SubValue class with a range based on the specified percentage of the related element's Yvalue in both directions. Hence, the resulting range will be twice the specified percentage.

[Visual Basic] Overloads Public Shared Function FromPlusMinusPercent(Double) As SubValue

[C#] public static SubValue FromPlusMinusPercent(double);

Creates a new instance of a SubValue class with a range based on the specified percentage of the related element's Yvalue in both directions. Hence, the resulting range will be twice the specified percentage.

[Visual Basic] Overloads Public Shared Function FromPlusMinusPercent(Double,Double) As SubValue

[C#] public static SubValue FromPlusMinusPercent(double,double);

See Also

SubValue Class | SubValue Members


FromPlusMinusPercent(Double) Method

SubValue Class | SubValue Members | Overload List

Language

Visual Basic

C#

Show All

percent
See Also Languages dotnetCHARTING Send comments on this topic.

FromPlusMinusPercent(Double) Method

Creates a new instance of a SubValue class with a range based on the specified percentage of the related element's Yvalue in both directions. Hence, the resulting range will be twice the specified percentage.

[Visual Basic]
Overloads Public Shared Function FromPlusMinusPercent( _
   ByVal percent As Double _
) As SubValue
[C#]
public static SubValue FromPlusMinusPercent(
   double percent
);

Parameters

percent

See Also

SubValue Class | SubValue Members | Overload List


FromPlusMinusPercent(Double,Double) Method

SubValue Class | SubValue Members | Overload List

Language

Visual Basic

C#

Show All

minus
plus
See Also Languages dotnetCHARTING Send comments on this topic.

FromPlusMinusPercent(Double,Double) Method

Creates a new instance of a SubValue class with a range based on the specified percentage of the related element's Yvalue in both directions. Hence, the resulting range will be twice the specified percentage.

[Visual Basic]
Overloads Public Shared Function FromPlusMinusPercent( _
   ByVal minus As Double, _
   ByVal plus As Double _
) As SubValue
[C#]
public static SubValue FromPlusMinusPercent(
   double minus,
   double plus
);

Parameters

minus
plus

See Also

SubValue Class | SubValue Members | Overload List


FromValue Method

SubValue Class | SubValue Members

Language

Visual Basic

C#

Show All

val
See Also Languages dotnetCHARTING Send comments on this topic.

FromValue Method

Creates a new instance of a SubValue class with a single independent value.

[Visual Basic]
Public Shared Function FromValue( _
   ByVal val As Double _
) As SubValue
[C#]
public static SubValue FromValue(
   double val
);

Parameters

val

See Also

SubValue Class | SubValue Members


SubValue Class Properties

SubValue Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SubValue Class Members

For a list of all members of this type, see SubValue members.

Public Properties

Public Property ErrorHigh |
Public Property ErrorHighValue |
Public Property ErrorLow |
Public Property ErrorLowValue |
Public Property ErrorPercentageHigh |
Public Property ErrorPercentageLow |
Public Property Line | Gets or sets a Line object used to draw the lines of this SubValue.
Public Property Marker | Gets or sets an ElementMarker object drawn when the SubValue's type is set to SubValueType.Marker..
Public Property Type | Gets or sets a SubValueType that determines how this sub value is drawn.

See Also

SubValue Class | dotnetCHARTING Namespace


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorHigh Property

[Visual Basic]
Public Property ErrorHigh As Double
[C#]
public double ErrorHigh {get; set;}

See Also

SubValue Class | SubValue Members


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorHighValue Property

[Visual Basic]
Public Property ErrorHighValue As Double
[C#]
public double ErrorHighValue {get; set;}

See Also

SubValue Class | SubValue Members


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorLow Property

[Visual Basic]
Public Property ErrorLow As Double
[C#]
public double ErrorLow {get; set;}

See Also

SubValue Class | SubValue Members


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorLowValue Property

[Visual Basic]
Public Property ErrorLowValue As Double
[C#]
public double ErrorLowValue {get; set;}

See Also

SubValue Class | SubValue Members


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorPercentageHigh Property

[Visual Basic]
Public Property ErrorPercentageHigh As Double
[C#]
public double ErrorPercentageHigh {get; set;}

See Also

SubValue Class | SubValue Members


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ErrorPercentageLow Property

[Visual Basic]
Public Property ErrorPercentageLow As Double
[C#]
public double ErrorPercentageLow {get; set;}

See Also

SubValue Class | SubValue Members


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Line Property

Gets or sets a Line object used to draw the lines of this SubValue.

[Visual Basic]
Public Property Line As Line
[C#]
public Line Line {get; set;}

See Also

SubValue Class | SubValue Members


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Marker Property

Gets or sets an ElementMarker object drawn when the SubValue's type is set to SubValueType.Marker..

[Visual Basic]
Public Property Marker As ElementMarker
[C#]
public ElementMarker Marker {get; set;}

See Also

SubValue Class | SubValue Members


SubValue Class | SubValue Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Type Property

Gets or sets a SubValueType that determines how this sub value is drawn.

[Visual Basic]
Public Property Type As SubValueType
[C#]
public SubValueType Type {get; set;}

See Also

SubValue Class | SubValue Members


SubValueCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SubValueCollection Class

Contains a collection of SubValue objects.

For a list of all members of this type, see SubValueCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.SubValueCollection

Syntax

[Visual Basic]
Public Class SubValueCollection
   Inherits CollectionBase
[C#]
public class SubValueCollection : CollectionBase

See Also

SubValueCollection Members | dotnetCHARTING Namespace


SubValueCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SubValueCollection Class Members

SubValueCollection overview

Public Constructors

Public Constructor SubValueCollection Constructor Creates a new instance of SubValueCollection with the specified list of SubValue objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified SubValue.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines index of a specified SubValue in this collection.
Public Method Insert | Inserts a SubValue into this collection at a specified index.
Public Method Remove | Removes a specified SubValue from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

SubValueCollection Class | dotnetCHARTING Namespace


SubValueCollection Constructor

SubValueCollection Class | SubValueCollection Members

Language

Visual Basic

C#

Show All

subValueList
See Also Languages dotnetCHARTING Send comments on this topic.

SubValueCollection Constructor

Creates a new instance of SubValueCollection with the specified list of SubValue objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray subValueList() As SubValue _
)
[C#]
public SubValueCollection(
   params SubValue[] subValueList
);

Parameters

subValueList

See Also

SubValueCollection Class | SubValueCollection Members


SubValueCollection Class Methods

SubValueCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SubValueCollection Class Members

For a list of all members of this type, see SubValueCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified SubValue.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines index of a specified SubValue in this collection.
Public Method Insert | Inserts a SubValue into this collection at a specified index.
Public Method Remove | Removes a specified SubValue from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

SubValueCollection Class | dotnetCHARTING Namespace


SubValueCollection Class | SubValueCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

[Visual Basic] Overloads Public Function Add(SubValue) As Integer

[C#] public int Add(SubValue);

Adds the specified SubValue objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray SubValue())

[C#] public void Add(params SubValue[]);

Adds a specified SubValueCollection to this collection.

[Visual Basic] Overloads Public Sub Add(SubValueCollection)

[C#] public void Add(SubValueCollection);

See Also

SubValueCollection Class | SubValueCollection Members


Add(SubValue) Method

SubValueCollection Class | SubValueCollection Members | Overload List

Language

Visual Basic

C#

Show All

subValue
See Also Languages dotnetCHARTING Send comments on this topic.

Add(SubValue) Method

[Visual Basic]
Overloads Public Function Add( _
   ByVal subValue As SubValue _
) As Integer
[C#]
public int Add(
   SubValue subValue
);

Parameters

subValue

See Also

SubValueCollection Class | SubValueCollection Members | Overload List


Add(SubValue[]) Method

SubValueCollection Class | SubValueCollection Members | Overload List

Language

Visual Basic

C#

Show All

subValueList
A list of SubValue objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(SubValue[]) Method

Adds the specified SubValue objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray subValueList() As SubValue _
)
[C#]
public void Add(
   params SubValue[] subValueList
);

Parameters

subValueList
A list of SubValue objects to add.

See Also

SubValueCollection Class | SubValueCollection Members | Overload List


Add(SubValueCollection) Method

SubValueCollection Class | SubValueCollection Members | Overload List

Language

Visual Basic

C#

Show All

subValueCollection
The SubValueCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(SubValueCollection) Method

Adds a specified SubValueCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal subValueCollection As SubValueCollection _
)
[C#]
public void Add(
   SubValueCollection subValueCollection
);

Parameters

subValueCollection
The SubValueCollection to add.

See Also

SubValueCollection Class | SubValueCollection Members | Overload List


Contains Method

SubValueCollection Class | SubValueCollection Members

Language

Visual Basic

C#

Show All

subValue
The SubValue to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified SubValue.

[Visual Basic]
Public Function Contains( _
   ByVal subValue As SubValue _
) As Boolean
[C#]
public bool Contains(
   SubValue subValue
);

Parameters

subValue
The SubValue to find.

Return Type

true if the specified SubValue belongs to this collection; otherwise, false.

See Also

SubValueCollection Class | SubValueCollection Members


IndexOf Method

SubValueCollection Class | SubValueCollection Members

Language

Visual Basic

C#

Show All

subValue
The SubValue to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines index of a specified SubValue in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal subValue As SubValue _
) As Integer
[C#]
public int IndexOf(
   SubValue subValue
);

Parameters

subValue
The SubValue to find.

Return Type

The zero-based index of the specified SubValue.

See Also

SubValueCollection Class | SubValueCollection Members


Insert Method

SubValueCollection Class | SubValueCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the SubValue.
subValue
The SubValue to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a SubValue into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal subValue As SubValue _
)
[C#]
public void Insert(
   int index,
   SubValue subValue
);

Parameters

index
The zero-based index into the collection at which to insert the SubValue.
subValue
The SubValue to insert into this collection.

See Also

SubValueCollection Class | SubValueCollection Members


Remove Method

SubValueCollection Class | SubValueCollection Members

Language

Visual Basic

C#

Show All

subValue
The SubValue to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified SubValue from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal subValue As SubValue _
)
[C#]
public void Remove(
   SubValue subValue
);

Parameters

subValue
The SubValue to remove.

See Also

SubValueCollection Class | SubValueCollection Members


SubValueCollection Class Properties

SubValueCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SubValueCollection Class Members

For a list of all members of this type, see SubValueCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

SubValueCollection Class | dotnetCHARTING Namespace


Item Property

SubValueCollection Class | SubValueCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As SubValue
[C#]
public SubValue this[
   int index
]; {get; set;}

Parameters

index

See Also

SubValueCollection Class | SubValueCollection Members


TimeIntervalAdvanced Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TimeIntervalAdvanced Class

Represents a time interval and instant at which it occurs.

For a list of all members of this type, see TimeIntervalAdvanced members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.TimeIntervalAdvanced

Syntax

[Visual Basic]
Public Class TimeIntervalAdvanced
[C#]
public class TimeIntervalAdvanced

Remarks

This time is specific down to the millisecond.

See Also

TimeIntervalAdvanced Members | dotnetCHARTING Namespace


TimeIntervalAdvanced Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

TimeIntervalAdvanced Class Members

TimeIntervalAdvanced overview

Public Constructors

Public Constructor TimeIntervalAdvanced Constructor Overloaded.

Public Properties

Public Property static (Shared in Visual Basic) Day | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Days | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Hour | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Hours | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Milliseconds | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Minutes | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Month | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Months | Gets a system-defined TimeIntervalAdvanced object.
Public Property Multiplier | Gets or sets the factor by which this time interval is multiplied.
Public Property static (Shared in Visual Basic) None | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Quarter | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Quarters | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Seconds | Gets a system-defined TimeIntervalAdvanced object.
Public Property Start | Gets or sets a DateTime object representing the time instant at which this interval initially occurs.
Public Property StartDayOfWeek | Gets or sets the day of the week at which this interval initially occurs. Value ranges from zero indicating Sunday, to six, indicating Saturday.
Public Property StartMonth | Gets or sets the month of year at which this interval initially occurs. Value ranges from zero indicating January, to eleven, indicating December.
Public Property TimeSpan | Gets or sets a custom time span between each time instant occurrence.
Public Property static (Shared in Visual Basic) Week | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Weeks | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Year | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Years | Gets a system-defined TimeIntervalAdvanced object.

Public Methods

Public Method static (Shared in Visual Basic) AddTimeInterval | Adds a TimeInterval to the specified DateTime.
Public Method static (Shared in Visual Basic) op_Addition | Overloaded.
Public Method static (Shared in Visual Basic) op_Equality | Overloaded.
Public Method static (Shared in Visual Basic) op_Inequality | Overloaded.
Public Method static (Shared in Visual Basic) op_Subtraction | Subtracts a TimeIntervalAdvanced from a DateTime object.
Public Method static (Shared in Visual Basic) SubtractTimeInterval | Subtracts a TimeInterval from the specified DateTime.

See Also

TimeIntervalAdvanced Class | dotnetCHARTING Namespace


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TimeIntervalAdvanced Constructor

Overload List

Creates a new instance of TimeIntervalAdvanced with a TimeInterval and a factor by which the interval is multiplied.

[Visual Basic] Public Sub New(TimeInterval,Integer)

[C#] public TimeIntervalAdvanced(TimeInterval,int);

Creates a new instance of TimeIntervalAdvanced with a custom time span.

[Visual Basic] Public Sub New(TimeSpan)

[C#] public TimeIntervalAdvanced(TimeSpan);

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Constructor(TimeInterval,Int32)

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List

Language

Visual Basic

C#

Show All

interval
A base TimeInterval enumeration.
factor
Factor by which the to multiple the TimeInterval.
See Also Languages dotnetCHARTING Send comments on this topic.

TimeIntervalAdvanced Constructor(TimeInterval,Int32)

Creates a new instance of TimeIntervalAdvanced with a TimeInterval and a factor by which the interval is multiplied.

[Visual Basic]
Public Function New( _
   ByVal interval As TimeInterval, _
   ByVal factor As Integer _
)
[C#]
public TimeIntervalAdvanced(
   TimeInterval interval,
   int factor
);

Parameters

interval
A base TimeInterval enumeration.
factor
Factor by which the to multiple the TimeInterval.

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List


TimeIntervalAdvanced Constructor(TimeSpan)

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List

Language

Visual Basic

C#

Show All

span
See Also Languages dotnetCHARTING Send comments on this topic.

TimeIntervalAdvanced Constructor(TimeSpan)

Creates a new instance of TimeIntervalAdvanced with a custom time span.

[Visual Basic]
Public Function New( _
   ByVal span As TimeSpan _
)
[C#]
public TimeIntervalAdvanced(
   TimeSpan span
);

Parameters

span

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List


TimeIntervalAdvanced Class Methods

TimeIntervalAdvanced Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

TimeIntervalAdvanced Class Members

For a list of all members of this type, see TimeIntervalAdvanced members.

Public Methods

Public Method static (Shared in Visual Basic) AddTimeInterval | Adds a TimeInterval to the specified DateTime.
Public Method static (Shared in Visual Basic) op_Addition | Overloaded.
Public Method static (Shared in Visual Basic) op_Equality | Overloaded.
Public Method static (Shared in Visual Basic) op_Inequality | Overloaded.
Public Method static (Shared in Visual Basic) op_Subtraction | Subtracts a TimeIntervalAdvanced from a DateTime object.
Public Method static (Shared in Visual Basic) SubtractTimeInterval | Subtracts a TimeInterval from the specified DateTime.

See Also

TimeIntervalAdvanced Class | dotnetCHARTING Namespace


AddTimeInterval Method

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

Visual Basic

C#

Show All

lhs
The date to add to.
rhs
The TimeInterval to add.
See Also Languages dotnetCHARTING Send comments on this topic.

AddTimeInterval Method

Adds a TimeInterval to the specified DateTime.

[Visual Basic]
Public Shared Function AddTimeInterval( _
   ByVal lhs As Date, _
   ByVal rhs As TimeInterval _
) As Date
[C#]
public static DateTime AddTimeInterval(
   DateTime lhs,
   TimeInterval rhs
);

Parameters

lhs
The date to add to.
rhs
The TimeInterval to add.

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Addition Method

Overload List

Adds a TimeIntervalAdvanced to a DateTime object.

[Visual Basic] Overloads Public Shared Function op_Addition(Date,TimeIntervalAdvanced) As Date

[C#] public static DateTime op_Addition(DateTime,TimeIntervalAdvanced);

Adds a TimeIntervalAdvanced to a DateTime object.

[Visual Basic] Overloads Public Shared Function op_Addition(TimeIntervalAdvanced,Date) As Date

[C#] public static DateTime op_Addition(TimeIntervalAdvanced,DateTime);

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


op_Addition(DateTime,TimeIntervalAdvanced) Method

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List

Language

Visual Basic

C#

Show All

lhs
Added to DateTime.
rhs
TimeIntervalAdvanced to add.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Addition(DateTime,TimeIntervalAdvanced) Method

Adds a TimeIntervalAdvanced to a DateTime object.

[Visual Basic]
Overloads Public Shared Function op_Addition( _
   ByVal lhs As Date, _
   ByVal rhs As TimeIntervalAdvanced _
) As Date
[C#]
public static DateTime op_Addition(
   DateTime lhs,
   TimeIntervalAdvanced rhs
);

Parameters

lhs
Added to DateTime.
rhs
TimeIntervalAdvanced to add.

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List


op_Addition(TimeIntervalAdvanced,DateTime) Method

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List

Language

Visual Basic

C#

Show All

lhs
TimeIntervalAdvanced to add.
rhs
Added to DateTime.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Addition(TimeIntervalAdvanced,DateTime) Method

Adds a TimeIntervalAdvanced to a DateTime object.

[Visual Basic]
Overloads Public Shared Function op_Addition( _
   ByVal lhs As TimeIntervalAdvanced, _
   ByVal rhs As Date _
) As Date
[C#]
public static DateTime op_Addition(
   TimeIntervalAdvanced lhs,
   DateTime rhs
);

Parameters

lhs
TimeIntervalAdvanced to add.
rhs
Added to DateTime.

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Equality Method

Overload List

Indicates whether a specified TimeIntervalAdvanced is equal to a specified TimeInterval enumeration.

[Visual Basic] Overloads Public Shared Function op_Equality(TimeIntervalAdvanced,TimeInterval) As Boolean

[C#] public static bool op_Equality(TimeIntervalAdvanced,TimeInterval);

Indicates whether a specified TimeIntervalAdvanced is equal to another TimeIntervalAdvanced.

[Visual Basic] Overloads Public Shared Function op_Equality(TimeIntervalAdvanced,TimeIntervalAdvanced) As Boolean

[C#] public static bool op_Equality(TimeIntervalAdvanced,TimeIntervalAdvanced);

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


op_Equality(TimeIntervalAdvanced,TimeInterval) Method

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List

Language

Visual Basic

C#

Show All

lhs
TimeIntervalAdvanced to compare.
rhs
TimeInterval to compare.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Equality(TimeIntervalAdvanced,TimeInterval) Method

Indicates whether a specified TimeIntervalAdvanced is equal to a specified TimeInterval enumeration.

[Visual Basic]
Overloads Public Shared Function op_Equality( _
   ByVal lhs As TimeIntervalAdvanced, _
   ByVal rhs As TimeInterval _
) As Boolean
[C#]
public static bool op_Equality(
   TimeIntervalAdvanced lhs,
   TimeInterval rhs
);

Parameters

lhs
TimeIntervalAdvanced to compare.
rhs
TimeInterval to compare.

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List


op_Equality(TimeIntervalAdvanced,TimeIntervalAdvanced) Method

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List

Language

Visual Basic

C#

Show All

lhs
left TimeIntervalAdvanced
rhs
right TimeIntervalAdvanced
See Also Languages dotnetCHARTING Send comments on this topic.

op_Equality(TimeIntervalAdvanced,TimeIntervalAdvanced) Method

Indicates whether a specified TimeIntervalAdvanced is equal to another TimeIntervalAdvanced.

[Visual Basic]
Overloads Public Shared Function op_Equality( _
   ByVal lhs As TimeIntervalAdvanced, _
   ByVal rhs As TimeIntervalAdvanced _
) As Boolean
[C#]
public static bool op_Equality(
   TimeIntervalAdvanced lhs,
   TimeIntervalAdvanced rhs
);

Parameters

lhs
left TimeIntervalAdvanced
rhs
right TimeIntervalAdvanced

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

op_Inequality Method

Overload List

Indicates whether a TimeInterval and TimeIntervalAdvanced are not equal.

[Visual Basic] Overloads Public Shared Function op_Inequality(TimeIntervalAdvanced,TimeInterval) As Boolean

[C#] public static bool op_Inequality(TimeIntervalAdvanced,TimeInterval);

Indicates whether two TimeIntervalAdvanced instances are not equal.

[Visual Basic] Overloads Public Shared Function op_Inequality(TimeIntervalAdvanced,TimeIntervalAdvanced) As Boolean

[C#] public static bool op_Inequality(TimeIntervalAdvanced,TimeIntervalAdvanced);

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


op_Inequality(TimeIntervalAdvanced,TimeInterval) Method

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List

Language

Visual Basic

C#

Show All

lhs
rhs
See Also Languages dotnetCHARTING Send comments on this topic.

op_Inequality(TimeIntervalAdvanced,TimeInterval) Method

Indicates whether a TimeInterval and TimeIntervalAdvanced are not equal.

[Visual Basic]
Overloads Public Shared Function op_Inequality( _
   ByVal lhs As TimeIntervalAdvanced, _
   ByVal rhs As TimeInterval _
) As Boolean
[C#]
public static bool op_Inequality(
   TimeIntervalAdvanced lhs,
   TimeInterval rhs
);

Parameters

lhs
rhs

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List


op_Inequality(TimeIntervalAdvanced,TimeIntervalAdvanced) Method

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List

Language

Visual Basic

C#

Show All

lhs
rhs
See Also Languages dotnetCHARTING Send comments on this topic.

op_Inequality(TimeIntervalAdvanced,TimeIntervalAdvanced) Method

Indicates whether two TimeIntervalAdvanced instances are not equal.

[Visual Basic]
Overloads Public Shared Function op_Inequality( _
   ByVal lhs As TimeIntervalAdvanced, _
   ByVal rhs As TimeIntervalAdvanced _
) As Boolean
[C#]
public static bool op_Inequality(
   TimeIntervalAdvanced lhs,
   TimeIntervalAdvanced rhs
);

Parameters

lhs
rhs

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members | Overload List


op_Subtraction Method

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

Visual Basic

C#

Show All

lhs
DateTime to subtract from.
rhs
TimeIntervalAdvanced to subtract.
See Also Languages dotnetCHARTING Send comments on this topic.

op_Subtraction Method

Subtracts a TimeIntervalAdvanced from a DateTime object.

[Visual Basic]
Public Shared Function op_Subtraction( _
   ByVal lhs As Date, _
   ByVal rhs As TimeIntervalAdvanced _
) As Date
[C#]
public static DateTime op_Subtraction(
   DateTime lhs,
   TimeIntervalAdvanced rhs
);

Parameters

lhs
DateTime to subtract from.
rhs
TimeIntervalAdvanced to subtract.

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


SubtractTimeInterval Method

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

Visual Basic

C#

Show All

lhs
The date to subtract from.
rhs
The TimeInterval to add.
See Also Languages dotnetCHARTING Send comments on this topic.

SubtractTimeInterval Method

Subtracts a TimeInterval from the specified DateTime.

[Visual Basic]
Public Shared Function SubtractTimeInterval( _
   ByVal lhs As Date, _
   ByVal rhs As TimeInterval _
) As Date
[C#]
public static DateTime SubtractTimeInterval(
   DateTime lhs,
   TimeInterval rhs
);

Parameters

lhs
The date to subtract from.
rhs
The TimeInterval to add.

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class Properties

TimeIntervalAdvanced Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

TimeIntervalAdvanced Class Members

For a list of all members of this type, see TimeIntervalAdvanced members.

Public Properties

Public Property static (Shared in Visual Basic) Day | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Days | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Hour | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Hours | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Milliseconds | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Minutes | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Month | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Months | Gets a system-defined TimeIntervalAdvanced object.
Public Property Multiplier | Gets or sets the factor by which this time interval is multiplied.
Public Property static (Shared in Visual Basic) None | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Quarter | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Quarters | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Seconds | Gets a system-defined TimeIntervalAdvanced object.
Public Property Start | Gets or sets a DateTime object representing the time instant at which this interval initially occurs.
Public Property StartDayOfWeek | Gets or sets the day of the week at which this interval initially occurs. Value ranges from zero indicating Sunday, to six, indicating Saturday.
Public Property StartMonth | Gets or sets the month of year at which this interval initially occurs. Value ranges from zero indicating January, to eleven, indicating December.
Public Property TimeSpan | Gets or sets a custom time span between each time instant occurrence.
Public Property static (Shared in Visual Basic) Week | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Weeks | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Year | Gets a system-defined TimeIntervalAdvanced object.
Public Property static (Shared in Visual Basic) Years | Gets a system-defined TimeIntervalAdvanced object.

See Also

TimeIntervalAdvanced Class | dotnetCHARTING Namespace


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Day Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Day As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Day {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Days Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Days As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Days {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hour Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Hour As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Hour {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Hours Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Hours As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Hours {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Milliseconds Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Milliseconds As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Milliseconds {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Minutes Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Minutes As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Minutes {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Month Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Month As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Month {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Months Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Months As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Months {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Multiplier Property

Gets or sets the factor by which this time interval is multiplied.

[Visual Basic]
Public Property Multiplier As Integer
[C#]
public int Multiplier {get; set;}

Remarks

If TimeSpan is specified, this property will not have any effect.

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

None Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property None As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced None {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Quarter Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Quarter As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Quarter {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Quarters Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Quarters As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Quarters {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Seconds Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Seconds As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Seconds {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Start Property

Gets or sets a DateTime object representing the time instant at which this interval initially occurs.

[Visual Basic]
Public Property Start As Date
[C#]
public DateTime Start {get; set;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StartDayOfWeek Property

Gets or sets the day of the week at which this interval initially occurs. Value ranges from zero indicating Sunday, to six, indicating Saturday.

[Visual Basic]
Public Property StartDayOfWeek As Integer
[C#]
public int StartDayOfWeek {get; set;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

StartMonth Property

Gets or sets the month of year at which this interval initially occurs. Value ranges from zero indicating January, to eleven, indicating December.

[Visual Basic]
Public Property StartMonth As Integer
[C#]
public int StartMonth {get; set;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TimeSpan Property

Gets or sets a custom time span between each time instant occurrence.

[Visual Basic]
Public Property TimeSpan As TimeSpan
[C#]
public TimeSpan TimeSpan {get; set;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Week Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Week As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Week {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Weeks Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Weeks As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Weeks {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Year Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Year As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Year {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalAdvanced Class | TimeIntervalAdvanced Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Years Property

Gets a system-defined TimeIntervalAdvanced object.

[Visual Basic]
Public Shared ReadOnly Property Years As TimeIntervalAdvanced
[C#]
public static TimeIntervalAdvanced Years {get;}

See Also

TimeIntervalAdvanced Class | TimeIntervalAdvanced Members


TimeIntervalCollection Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TimeIntervalCollection Class

Contains a collection of TimeInterval objects.

For a list of all members of this type, see TimeIntervalCollection members.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.TimeIntervalCollection

Syntax

[Visual Basic]
Public Class TimeIntervalCollection
   Inherits CollectionBase
[C#]
public class TimeIntervalCollection : CollectionBase

See Also

TimeIntervalCollection Members | dotnetCHARTING Namespace


TimeIntervalCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

TimeIntervalCollection Class Members

TimeIntervalCollection overview

Public Constructors

Public Constructor TimeIntervalCollection Constructor Creates a new instance of TimeIntervalCollection with the specified list of TimeInterval objects.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified TimeInterval.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines index of a specified TimeInterval in this collection.
Public Method Insert | Inserts a TimeInterval into this collection at a specified index.
Public Method static (Shared in Visual Basic) op_Implicit |
Public Method Remove | Removes a specified TimeInterval from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

TimeIntervalCollection Class | dotnetCHARTING Namespace


TimeIntervalCollection Constructor

TimeIntervalCollection Class | TimeIntervalCollection Members

Language

Visual Basic

C#

Show All

timeIntervalList
See Also Languages dotnetCHARTING Send comments on this topic.

TimeIntervalCollection Constructor

Creates a new instance of TimeIntervalCollection with the specified list of TimeInterval objects.

[Visual Basic]
Public Function New( _
   ByVal ParamArray timeIntervalList() As TimeInterval _
)
[C#]
public TimeIntervalCollection(
   params TimeInterval[] timeIntervalList
);

Parameters

timeIntervalList

See Also

TimeIntervalCollection Class | TimeIntervalCollection Members


TimeIntervalCollection Class Methods

TimeIntervalCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

TimeIntervalCollection Class Members

For a list of all members of this type, see TimeIntervalCollection members.

Public Methods

Public Method Add | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains | Determines whether this collection contains a specified TimeInterval.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf | Determines index of a specified TimeInterval in this collection.
Public Method Insert | Inserts a TimeInterval into this collection at a specified index.
Public Method static (Shared in Visual Basic) op_Implicit |
Public Method Remove | Removes a specified TimeInterval from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

TimeIntervalCollection Class | dotnetCHARTING Namespace


TimeIntervalCollection Class | TimeIntervalCollection Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Add Method

Overload List

[Visual Basic] Overloads Public Function Add(TimeInterval) As Integer

[C#] public int Add(TimeInterval);

Adds the specified TimeInterval objects to this collection.

[Visual Basic] Overloads Public Sub Add(ParamArray TimeInterval())

[C#] public void Add(params TimeInterval[]);

Adds a specified TimeIntervalCollection to this collection.

[Visual Basic] Overloads Public Sub Add(TimeIntervalCollection)

[C#] public void Add(TimeIntervalCollection);

See Also

TimeIntervalCollection Class | TimeIntervalCollection Members


Add(TimeInterval) Method

TimeIntervalCollection Class | TimeIntervalCollection Members | Overload List

Language

Visual Basic

C#

Show All

timeInterval
See Also Languages dotnetCHARTING Send comments on this topic.

Add(TimeInterval) Method

[Visual Basic]
Overloads Public Function Add( _
   ByVal timeInterval As TimeInterval _
) As Integer
[C#]
public int Add(
   TimeInterval timeInterval
);

Parameters

timeInterval

See Also

TimeIntervalCollection Class | TimeIntervalCollection Members | Overload List


Add(TimeInterval[]) Method

TimeIntervalCollection Class | TimeIntervalCollection Members | Overload List

Language

Visual Basic

C#

Show All

timeIntervalList
A list of TimeInterval objects to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(TimeInterval[]) Method

Adds the specified TimeInterval objects to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal ParamArray timeIntervalList() As TimeInterval _
)
[C#]
public void Add(
   params TimeInterval[] timeIntervalList
);

Parameters

timeIntervalList
A list of TimeInterval objects to add.

See Also

TimeIntervalCollection Class | TimeIntervalCollection Members | Overload List


Add(TimeIntervalCollection) Method

TimeIntervalCollection Class | TimeIntervalCollection Members | Overload List

Language

Visual Basic

C#

Show All

timeIntervalCollection
The TimeIntervalCollection to add.
See Also Languages dotnetCHARTING Send comments on this topic.

Add(TimeIntervalCollection) Method

Adds a specified TimeIntervalCollection to this collection.

[Visual Basic]
Overloads Public Sub Add( _
   ByVal timeIntervalCollection As TimeIntervalCollection _
)
[C#]
public void Add(
   TimeIntervalCollection timeIntervalCollection
);

Parameters

timeIntervalCollection
The TimeIntervalCollection to add.

See Also

TimeIntervalCollection Class | TimeIntervalCollection Members | Overload List


Contains Method

TimeIntervalCollection Class | TimeIntervalCollection Members

Language

Visual Basic

C#

Show All

timeInterval
The TimeInterval to find.
See Also Languages dotnetCHARTING Send comments on this topic.

Contains Method

Determines whether this collection contains a specified TimeInterval.

[Visual Basic]
Public Function Contains( _
   ByVal timeInterval As TimeInterval _
) As Boolean
[C#]
public bool Contains(
   TimeInterval timeInterval
);

Parameters

timeInterval
The TimeInterval to find.

Return Type

true if the specified TimeInterval belongs to this collection; otherwise, false.

See Also

TimeIntervalCollection Class | TimeIntervalCollection Members


IndexOf Method

TimeIntervalCollection Class | TimeIntervalCollection Members

Language

Visual Basic

C#

Show All

timeInterval
The TimeInterval to find.
See Also Languages dotnetCHARTING Send comments on this topic.

IndexOf Method

Determines index of a specified TimeInterval in this collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal timeInterval As TimeInterval _
) As Integer
[C#]
public int IndexOf(
   TimeInterval timeInterval
);

Parameters

timeInterval
The TimeInterval to find.

Return Type

The zero-based index of the specified TimeInterval.

See Also

TimeIntervalCollection Class | TimeIntervalCollection Members


Insert Method

TimeIntervalCollection Class | TimeIntervalCollection Members

Language

Visual Basic

C#

Show All

index
The zero-based index into the collection at which to insert the TimeInterval.
timeInterval
The TimeInterval to insert into this collection.
See Also Languages dotnetCHARTING Send comments on this topic.

Insert Method

Inserts a TimeInterval into this collection at a specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal timeInterval As TimeInterval _
)
[C#]
public void Insert(
   int index,
   TimeInterval timeInterval
);

Parameters

index
The zero-based index into the collection at which to insert the TimeInterval.
timeInterval
The TimeInterval to insert into this collection.

See Also

TimeIntervalCollection Class | TimeIntervalCollection Members


op_Implicit Method

TimeIntervalCollection Class | TimeIntervalCollection Members

Language

Visual Basic

C#

Show All

tic
See Also Languages dotnetCHARTING Send comments on this topic.

op_Implicit Method

[Visual Basic]
Public Shared Function op_Implicit( _
   ByVal tic As TimeIntervalCollection _
) As ArrayList
[C#]
public static ArrayList op_Implicit(
   TimeIntervalCollection tic
);

Parameters

tic

See Also

TimeIntervalCollection Class | TimeIntervalCollection Members


Remove Method

TimeIntervalCollection Class | TimeIntervalCollection Members

Language

Visual Basic

C#

Show All

timeInterval
The TimeInterval to remove.
See Also Languages dotnetCHARTING Send comments on this topic.

Remove Method

Removes a specified TimeInterval from this collection.

[Visual Basic]
Public Sub Remove( _
   ByVal timeInterval As TimeInterval _
)
[C#]
public void Remove(
   TimeInterval timeInterval
);

Parameters

timeInterval
The TimeInterval to remove.

See Also

TimeIntervalCollection Class | TimeIntervalCollection Members


TimeIntervalCollection Class Properties

TimeIntervalCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

TimeIntervalCollection Class Members

For a list of all members of this type, see TimeIntervalCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.CollectionBase) |
Public Property Item | Gets or sets the object at a specified index.

See Also

TimeIntervalCollection Class | dotnetCHARTING Namespace


Item Property

TimeIntervalCollection Class | TimeIntervalCollection Members

Language

Visual Basic

C#

Show All

index
See Also Languages dotnetCHARTING Send comments on this topic.

Item Property

Gets or sets the object at a specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As TimeInterval
[C#]
public TimeInterval this[
   int index
]; {get; set;}

Parameters

index

See Also

TimeIntervalCollection Class | TimeIntervalCollection Members


Truncation Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Truncation Class

Defines properties used to shorten long labels.

For a list of all members of this type, see Truncation members.

Inheritance Hierarchy

System.Object
dotnetCHARTING.Truncation

Syntax

[Visual Basic]
Public Class Truncation
[C#]
public class Truncation

See Also

Truncation Members | dotnetCHARTING Namespace


Truncation Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Truncation Class Members

Truncation overview

Public Constructors

Public Constructor Truncation Constructor Initializes a new instance of the Truncation class.

Public Properties

Public Property Length | Gets or sets the maximum number of characters a label is shortened to.
Public Property Mode | Gets or sets the TruncationMode used to shorten this label.
Public Property Text | Gets or sets a string that defines text inserted into a string at the position it was trimmed. Default is '...'

See Also

Truncation Class | dotnetCHARTING Namespace


Truncation Class | Truncation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Truncation Constructor

Initializes a new instance of the Truncation class.

[Visual Basic]
Public Function New()
[C#]
public Truncation();

See Also

Truncation Class | Truncation Members


Truncation Class Properties

Truncation Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Truncation Class Members

For a list of all members of this type, see Truncation members.

Public Properties

Public Property Length | Gets or sets the maximum number of characters a label is shortened to.
Public Property Mode | Gets or sets the TruncationMode used to shorten this label.
Public Property Text | Gets or sets a string that defines text inserted into a string at the position it was trimmed. Default is '...'

See Also

Truncation Class | dotnetCHARTING Namespace


Truncation Class | Truncation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Length Property

Gets or sets the maximum number of characters a label is shortened to.

[Visual Basic]
Public Property Length As Integer
[C#]
public int Length {get; set;}

See Also

Truncation Class | Truncation Members


Truncation Class | Truncation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Mode Property

Gets or sets the TruncationMode used to shorten this label.

[Visual Basic]
Public Property Mode As TruncationMode
[C#]
public TruncationMode Mode {get; set;}

See Also

Truncation Class | Truncation Members


Truncation Class | Truncation Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Text Property

Gets or sets a string that defines text inserted into a string at the position it was trimmed.

Default is '...'

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

Truncation Class | Truncation Members


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AbsorbedDose Enumeration

Members

Member | Description
Gray |
Yottagray |
Zettagray |
Exagray |
Petagray |
Teragray |
Gigagray |
Megagray |
Kilogray |
Hectogray |
Dekagray |
Decigray |
Centigray |
Milligray |
Microgray |
Nanogray |
Picogray |
Femtogray |
Attogray |
Zeptogray |
Yoctogray |
Rad |
JoulePerKilogram |
JoulePerGram |
JoulePerCentigram |
JoulePerMilligram |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Acceleration Enumeration

Members

Member | Description
MetersPerSecondSquared |
YottametresPerSecondSquared |
ZettametresPerSecondSquared |
ExametresPerSecondSquared |
PetametresPerSecondSquared |
TerametresPerSecondSquared |
GigametresPerSecondSquared |
MegametresPerSecondSquared |
KilometresPerSecondSquared |
HectmetresPerSecondSquared |
DekametresPerSecondSquared |
DecimetresPerSecondSquared |
CentimetresPerSecondSquared |
MillimetresPerSecondSquared |
MicrometresPerSecondSquared |
NanometresPerSecondSquared |
PicometresPerSecondSquared |
FemtometresPerSecondSquared |
AttometresPerSecondSquared |
ZeptometresPerSecondSquared |
YoctometresPerSecondSquared |
Galileo |
Gravity |
InchesPerSecondSquared |
FeetPerSecondSquared |
YardsPerSecondSquared |
MilesPerSecondSquared |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Angle Enumeration

Members

Member | Description
Degrees |
Radians |
Gradians |
Revolution |
Minute |
Second |
Mil |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

AngularVelocity Enumeration

Members

Member | Description
RadiansPerSecond |
RadiansPerMinute |
RadiansPerHour |
RadiansPerDay |
DegreesPerSecond |
DegreesPerMinute |
DegreesPerHour |
DegreesPerDay |
RevolutionsPerSecond |
RevolutionsPerMinute |
RevolutionsPerHour |
RevolutionsPerDay |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Area Enumeration

Members

Member | Description
SquareMeters |
SquareNanometre |
SquareMicrometre |
SquareMillimetre |
SquareCentimetre |
SquareDecimetre |
SquareDecametre |
SquareHectometre |
SquareKilometre |
Are |
Hectares |
SquareYard |
SquareFoot |
SquareInch |
SquareMile |
Acre |
Cuerda |
VarasCastellanasCuad |
VarasConuquerasCuad |
Barn |
SquareChain |
SquarePerch |
SquarePole |
SquareRod |
Rood |
Section |
Township |
Plaza |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

BackgroundMode Enumeration

Specifies a background drawing mode.

Members

Member | Description
Color | Draws a solid color.
Image | Draws a centered image on the background surface.
ImageStretch | Stretches an image across the background surface.
ImageTile | Tiles an image on a background surface.
Gradient | Draws a 2 color gradient.
Brush | Uses the Background.Brush object to fill the surface.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

BoxCorner Enumeration

Specifies a box edge style.

Members

Member | Description
Square | The edge is a corner.
Cut | The edge is cut.
Round | The edge is rounded.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Calculation Enumeration

Specifies a calculation to be performed on a series or series collection.

Members

Member | Description
Sum | Calculates the sum of a series or series collection.
Mean | Calculates the mean of a series or series collection.
Median | Calculates the median of a series or series collection.
Mode | Calculates the mode of a series or series collection.
Average | Calculates the average of a series or series collection.
Minimum | Calculates the minimum of a series or series collection.
Maximum | Calculates the maximum of a series or series collection.
RunningSum | Calculates a running sum of a series or series collection.
RunningMean | Calculates a running mean of a series or series collection.
RunningMedian | Calculates a running median of a series or series collection.
RunningMode | Calculates a running mode of a series or series collection.
RunningAverage | Calculates a running average of a series or series collection.
RunningMinimum | Calculates a running minimum of a series or series collection.
RunningMaximum | Calculates a running maximum of a series or series collection.
TrendLineLinear | Calculates the linear regression of y values within a series collection.
TrendLineLinearScatter | Calculates the linear regression of x and y values within a series collection.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Capacitance Enumeration

Members

Member | Description
Farad |
Yottafarad |
Zettafarad |
Exafarad |
Petafarad |
Terafarad |
Gigafarad |
Megafarad |
Kilofarad |
Hectofarad |
Dekafarad |
Decifarad |
Centifarad |
Millifarad |
Microfarad |
Nanofarad |
Picofarad |
Femtofarad |
Attofarad |
Zeptofarad |
Yoctofarad |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Charge Enumeration

Members

Member | Description
Coulomb |
Yottacoulomb |
Zettacoulomb |
Exacoulomb |
Petacoulomb |
Teracoulomb |
Gigacoulomb |
Megacoulomb |
Kilocoulomb |
Millicoulomb |
Microcoulomb |
Nanocoulomb |
Picocoulomb |
Femtocoulomb |
Attocoulomb |
Zeptocoulomb |
Yoctocoulomb |
Abcoulomb |
AmpereHour |
AmpereMinute |
AmpereSecond |
AFaradayCarbon12Based |
AMillifaradayCarbon12Based |
AMicrofaradayCarbon12Based |
ANanofaradayCarbon12Based |
APicofaradayCarbon12Based |
Franklin |
Statcoulomb |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChartAreaLayoutMode Enumeration

Specifies the positioning behavior of multiple chart areas on a single chart image.

Members

Member | Description
VerticalPriority | Specifies that chart areas layout will be based on axis relationships where x axes will be matched before chart areas are added based on y axis relationships. ChartAreaLayoutRules.EnforceOppositeAxisAlignment affects this setting.
HorizontalPriority | Specifies that chart areas layout will be based on axis relationships where y axes will be matched before chart areas are added based on x axis relationships. ChartAreaLayoutRules.EnforceOppositeAxisAlignment affects this setting.
VerticalSmart | Specifies that chart areas will be laid out vertically in a single column and arranged based on x axis relationships.
HorizontalSmart | Specifies that chart areas will be laid out horizontally in a single row and arranged based on x axis relationships.
Vertical | Specifies that chart areas will be laid out vertically in a single column in the order they were added.
Horizontal | Specifies that chart areas will be laid out horizontally in a single row in the order they were added.
Custom | Specifies that chart areas will be laid out in a grid matrix based on ChartArea.GridPosition.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ChartType Enumeration

Represents the chart type of a chart.

Members

Member | Description
Combo | The combo chart supports virtually every feature. This chart is capable of being every chart you want it to be based on settings of other objects like series and axes. The x axis is a label axis and the y axis is a value axis. Element values used YValue, YValueStart, YDateTime, YDateTimeStart, Complete
ComboSideBySide | Each series is drawn side by side. This chart doesn't support stacked axis scales and unclustered columns. The x axis is a label axis and the y axis is a value axis. Element values used YValue, YValueStart, YDateTime, YDateTimeStart, Complete
ComboHorizontal | This chart supports the bar and cylinder series types. The y axis is a label axis and the x axis is a value axis. Element values used YValue, YValueStart, YDateTime, YDateTimeStart, Complete
Pie | The pie chart draws a single pie where each slice represents a series. Most applications would use Pies rather than Pie Element values used YValue
Pies | Multiple pies where each pie is a series and each slice is an element (suitable for most applications). Pies may also be drawn as donuts. Most applications would use Pies rather than Pie. Pies does not support Series.Palette. Element values used YValue
Donut | See Pie.
Donuts | See Pies.
Radar | Draws a single radar. The time scale is not supported by the radar graph. Element values used YValue
Radars | Draws multiple radars where each radar is a series. The time scale is not supported by radar graph. Element values used YValue
Scatter | Draws scattered data. Markers, lines, and splines are supported. Element values used YValue, YDateTime, XValue, XDateTime
Bubble | Draws scattered data. Markers, lines, and splines are supported. Data Used: YValue, YDateTime, XValue, XDateTime
Financial | Only 3 axes exist for this chart, price, volume and x axis. No more axes can be bound to series but you can calculate as many axes as you would like. HLC Charts can be achieved by providing a high, low, and close but leaving open equal double.NaN. Element values used Open, High, Low, Close, Volume
Gantt | See ComboHorizontal.
Gauges | Draws a gauge for each series. Each element represents a needle. Element values used YValue

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ConcentrationMolar Enumeration

Members

Member | Description
MolesPerLitre |
MolesPerMetreCubed |
MolesPerCentimetreCubed |
MolesPerMilimetreCubed |
KilomolesPerLitre |
KilomolesPerMetreCubed |
KilomolesPerCentimetreCubed |
KilomolesPerMilimetreCubed |
MillimolesPerLitre |
MillimolesPerMetreCubed |
MillimolesPerCentimetreCubed |
MillimolesPerMilimetreCubed |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Current Enumeration

Members

Member | Description
Ampere |
Kiloampere |
Miliampere |
Biot |
Gilbert |
ESUOfCurrentStatampere |
EMUOfCurrentAbampere |
Statampere |
Abampere |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Data Enumeration

Members

Member | Description
Bit |
Nibble |
Byte |
DoubleWord |
Word |
Block |
Kilobit |
KilobitBySIDef |
Megabit |
MegabitBySIDef |
Gigabit |
GigabitBySIDef |
Terabit |
TerabitBySIDef |
Kilobyte |
KilobyteBySIDef |
Megabyte |
MegabyteBySIDef |
Gigabyte |
GigabyteBySIDef |
Terabyte |
TerabyteBySIDef |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataSourceType Enumeration

Specifies a DataSource type to split the parent DataSource into.

Members

Member | Description
None | Specifies no type
Element | Specifies an Element data source type.
Series | Specifies a Series data source type.
SeriesCollection | Specifies an SeriesCollection data source type.
ElementGroup | Specifies an Element Group data source type. Element groups are elements in the same SeriesCollection that share a name.
AxisMarker | Specifies an AxisMarker data source type.
ScaleRange | Specifies a ScaleRange data source type.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DataTransfer Enumeration

Members

Member | Description
BitsPerSecond |
KilobitsPerSecondBySIDef |
KilobitsPerSecond |
MegabitsPerSecondBySIDef |
MegabitsPerSecond |
GigabitsPerSecondBySIDef |
GigabitsPerSecond |
TerabitsPerSecondBySIDef |
TerabitsPerSecond |
BytesPerSecond |
KilobytesPerSecondBySIDef |
KilobytesPerSecond |
MegabytesPerSecondBySIDef |
MegabytesPerSecond |
GigabytesPerSecondBySIDef |
GigabytesPerSecond |
TerabytesPerSecondBySIDef |
TerabytesPerSecond |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Density Enumeration

Members

Member | Description
GramsPerLitre |
GramsPerMetreCubed |
GramsPerCentimetreCubed |
GramsPerMilimetreCubed |
KilogramsPerMetreCubed |
KilogramsPerCentimetreCubed |
KilogramsPerMillimetreCubed |
MilligramsPerMetreCubed |
MilligramsPerCentimetreCubed |
MilligramsPerMilimetreCubed |
YottagramsPerLitre |
ZettagramsPerLitre |
ExagramsPerLitre |
PetagramsPerLitre |
TeragramsPerLitre |
GigagramsPerLitre |
MegagramsPerLitre |
KilogramsPerLitre |
HectogramsPerLitre |
DekagramsPerLitre |
DecigramsPerLitre |
CentigramsPerLitre |
MilligramsPerLitre |
MicrogramsPerLitre |
NanogramsPerLitre |
PicogramsPerLitre |
FemtogramsPerLitre |
AttogramsPerLitre |
ZeptogramsPerLitre |
YoctogramsPerLitre |
OuncesUSPerGallonUS |
PoundsPerFootCubed |
PoundsPerInchCubed |
TonsPerYardCubed |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

DigitalImageResolution Enumeration

Members

Member | Description
DotsPerInch |
PixelsPerInch |
DotsPerMilimetre |
DotsPerMetre |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ElementMarkerType Enumeration

Built in element marker icons.

Members

Member | Description
None | Does not draw a marker
Square | Markers is drawn as a square.
Triangle | Markers is drawn as a triangle.
Circle | Markers is drawn as a circle.
Diamond | Markers is drawn as a diamond.
FourPointStar | Markers is drawn as a four point star.
FivePointStar | Markers is drawn as a five point star.
SixPointStar | Markers is drawn as a six point star.
SevenPointStar | Markers is drawn as a seven point star.
Split | Markers is drawn as a financial split.
ReverseSplit | Markers is drawn as a financial reverse split.
Merger | Markers is drawn as a financial merger.
Dividend | Markers is drawn as a financial dividend paid indicator.
Spinoff | Markers is drawn as a financial spinoff.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ElementValue Enumeration

Specifies a value of an element.

Members

Member | Description
Name | The name of an element.
YValue | Y value of an element.
YValueStart | Initial y value of an element.
XValue | X value of an element.
XValueStart | Initial x value of an element.
YDateTime | Y DateTime value of an element.
YDateTimeStart | Initial y DateTime value of an element.
XDateTime | X DateTime value of an element.
XDateTimeStart | Initial x DateTime value of an element.
BubbleSize | Bubble size value of an element.
Complete | Percent completed value of an element.
Open | Financial open price value of an element.
Close | Financial close price value of an element.
High | Financial high price value of an element.
Low | Financial low price value of an element.
Volume | Financial trade volumn value of an element.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

EmptyElementMode Enumeration

Specifies how empty elements are handled.

Members

Member | Description
None | Empty elements are not shown or marked leaving gaps.
Ignore | Completes empty areas by filling the line, or area. Columns will behave the same as EmptyElementMode.None.
Fill | Fills the empty area with EmptyElement properties of a series.
TreatAsZero | Empty elements will have the value of 0 and not be marked as empty.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Energy Enumeration

Members

Member | Description
Joule |
Yottajoule |
Zettajoule |
Exajoule |
Petajoule |
Terajoule |
Gigajoule |
Megajoule |
Kilojoule |
Hectojoule |
Dekajoule |
Decijoule |
Centijoule |
Millijoule |
Microjoule |
Nanojoule |
Picojoule |
Femtojoule |
Attojoule |
Zeptojoule |
Yoctojoule |
BritishThermalUnit |
Calorie |
CalorieMean |
ElectronVolt |
Erg |
WattSecond |
WattHour |
KilowattSecond |
KilowattHour |
GigawattHour |
ThermEC |
ThermUS |
DyneCentimetre |
FootPoundal |
FootPoundFource |
HorsepowerHour |
OunceForceInch |
PoundForceInch |
TonOfTNTEnergyEquivalent |
AAQuad1015BTU |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

EUCurrency Enumeration

Members

Member | Description
Euro |
BelgianFranc |
DeutschMark |
SpanishPesetas |
FrenchFrancs |
GreekDrachma |
IrishPounds |
ItalianLire |
LuxembourgFrancs |
DutchGuilders |
AustrianSchillings |
PortugueseEscudos |
FinnishMarks |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FieldType Enumeration

Specifies a database field data type.

Members

Member | Description
Text | String data type.
Date | Date data type.
Number | Number data type.
Currency | Currency data type.
Double | Double data type.
Bool | Bool data type.
LongNumber | LongNumber data type.
BigInt | BigInt data type.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FlowMass Enumeration

Members

Member | Description
GramsPerSecond |
GramsPerMinute |
GramsPerHour |
GramsPerDay |
MilligramsPerMinute |
MilligramsPerHour |
MilligramsPerDay |
KilogramsPerMinute |
KilogramsPerHour |
KilogramsPerDay |
YottagramPerSecond |
ZettagramPerSecond |
ExagramPerSecond |
PetagramPerSecond |
TeragramPerSecond |
GigagramPerSecond |
MegagramPerSecond |
KilogramPerSecond |
HectogramPerSecond |
DekagramPerSecond |
DecigramPerSecond |
CentigramPerSecond |
MilligramPerSecond |
MicrogramPerSecond |
NanogramPerSecond |
PicogramPerSecond |
FemtogramPerSecond |
AttogramPerSecond |
ZeptogramPerSecond |
YoctogramPerSecond |
PoundsPerSecond |
PoundsPerMinute |
PoundsPerHour |
PoundsPerDay |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FlowMolar Enumeration

Members

Member | Description
MolesPerSecond |
YottamolesPerSecond |
ZettamolesPerSecond |
ExamolesPerSecond |
PetamolesPerSecond |
TeramolesPerSecond |
GigamolesPerSecond |
MegamolesPerSecond |
KilomolesPerSecond |
HectomolesPerSecond |
DekamolesPerSecond |
DecimolesPerSecond |
CentimolesPerSecond |
MillimolesPerSecond |
MicromolesPerSecond |
NanomolesPerSecond |
PicomolesPerSecond |
FemtomolesPerSecond |
AttomolesPerSecond |
ZeptomolesPerSecond |
YoctomolesPerSecond |
MolesPerMinute |
MolesPerHour |
MolesPerDay |
MillimolesPerMinute |
MillimolesPerHour |
MillimolesPerDay |
KilomolesPerMinute |
KilomolesPerHour |
KilomolesPerDay |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FlowVolumetric Enumeration

Members

Member | Description
LitresPerSecond |
LitresPerMinute |
LitresPerHour |
LitresPerDay |
MillilitresPerSecond |
MillilitresPerMinute |
MillilitresPerHour |
MillilitresPerDay |
KilolitresPerMinute |
KilolitresPerHour |
KilolitresPerDay |
CubicMetresPerSecond |
CubicMetrePerMinute |
CubicMetrePerHour |
CubicMetrePerDay |
CubicCentimetrePerSecond |
CubicCentimetrePerMinute |
CubicCentimetrePerHour |
CubicCentimetrePerDay |
CubicInchesPerSecond |
CubicInchesPerMinute |
CubicInchesPerHour |
CubicInchesPerDay |
CubicFeetPerSecond |
CubicFeetPerMinute |
CubicFeetPerHour |
CubicYardsPerSecond |
CubicYardsPerMinute |
CubicYardsPerHour |
OuncesPerSecond |
OuncesPerMinute |
OuncesPerHour |
OuncesUKPerSecond |
OuncesUKPerMinute |
OuncesUKPerHour |
GallonsPerSecond |
GallonsPerMinute |
GallonsPerHour |
GallonsPerDay |
GallonsUKPerSecond |
GallonsUKPerMinute |
GallonsUKPerHour |
GallonsUKPerDay |
BarrelsPerSecond |
BarrelsPerMinute |
BarrelsPerHour |
BarrelsPerDay |
AAPoundsPerSecondGasolineAt155C |
AAPoundsPerMinuteGasolineAt155C |
AAPoundsPerHourGasolineAt155C |
AAPoundsPerDayGasolineAt155C |
AAKilogramsPerSecondGasolineAt155C |
AAKilogramsPerMinuteGasolineAt155C |
AAKilogramsPerHourGasolineAt155C |
AAKilogramsPerDayGasolineAt155C |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Force Enumeration

Members

Member | Description
Newton |
Yottanewton |
Zettanewton |
Exanewton |
Petanewton |
Teranewton |
Giganewton |
Meganewton |
Kilonewton |
Hectonewton |
Dekanewton |
Decinewton |
Centinewton |
Millinewton |
Micronewton |
Nanonewton |
Piconewton |
Femtonewton |
Attonewton |
Zeptonewton |
Yoctonewton |
Dyne |
GramForce |
KilogramForce |
JouleCentimetre |
JouleMetre |
KipForce |
OunceForce |
PoundForce |
Poundal |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FrequencyWavelength Enumeration

Members

Member | Description
Hertz |
Yottahertz |
Zettahertz |
Exahertz |
Petahertz |
Terahertz |
Gigahertz |
Megahertz |
Kilohertz |
Hectohertz |
Dekahertz |
Decihertz |
Centihertz |
Millihertz |
Microhertz |
Nanohertz |
Picohertz |
Femtohertz |
Attohertz |
Zeptohertz |
Yoctohertz |
CyclesPerSecond |
WavelengthInExametres |
WavelengthInPetametres |
WavelengthInTerametres |
WavelengthInGigametres |
WavelengthInMegametres |
WavelengthInKilometres |
WavelengthInHectometres |
WavelengthInDecametres |
WavelengthInMetres |
WavelengthInDecimetres |
WavelengthInCentimetres |
WavelengthInMillimetres |
WavelengthInMicrometres |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

FuelConsumption Enumeration

Members

Member | Description
MetresPerLitre |
YottametrePerLitre |
ZettametrePerLitre |
ExametrePerLitre |
PetametrePerLitre |
TerametrePerLitre |
GigametrePerLitre |
MegametrePerLitre |
KilometrePerLitre |
HectometrePerLitre |
DekametrePerLitre |
DecimetrePerLitre |
CentimetrePerLitre |
MillimetrePerLitre |
MicrometrePerLitre |
NanometrePerLitre |
PicometrePerLitre |
FemtometrePerLitre |
AttometrePerLitre |
ZeptometrePerLitre |
YoctometrePerLitre |
LitresPerMetre |
ALitresPer100Km |
GallonsUSPerMile |
GallonsUKPerMile |
AGallonsUSPer100mi |
AGallonsUKPer100mi |
MileUSPerLitre |
NauticalMilePerLitre |
KilometresPerGallonUS |
MetresPerGallonUS |
MetresPerGallonUK |
MilesPerGallonUS |
MilesPerGallonUK |
NauticalMilePerGallonUS |
MetresPerCubicMetres |
MetresPerCubicCentimetre |
MetresPerCubicYards |
MetresPerCubicFeet |
MetresPerCubicInches |
MetresPerGallon |
MetresPerQuart |
MetresPerQuartUK |
MetresPerPint |
MetresPerPintUK |
MetresPerCup |
MetresPerCupUK |
MetresPerFluidOunces |
MetresPerFluidOuncesUK |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

HatchStylePalette Enumeration

Specifies a pre-defined hatch style palette.

Members

Member | Description
None | No hatch style palette is specified.
One | Palette one.
Two | Palette two.
Three | Palette three.
Random | A random palette.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Illumination Enumeration

Members

Member | Description
Lux |
Flame |
FootCandle |
CentimetreCandle |
MetreCandle |
Nox |
Phot |
LumenPerCentimetreSquared |
LumenPerMetreSquared |
LumenPerFootSquared |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ImageFormat Enumeration

Specifies file save format.

Members

Member | Description
Png | Saves an image using the W3C Portable Network Graphics (PNG) image format.
Bmp | Saves an image as a bitmap (BMP).
Jpg | Saves an image using the Joint Photographic Experts Group (JPEG) image format.
Emf | Saves an image using the enhanced Windows metafile (EMF) image format.
Wmf | Saves an image using the Windows metafile (WMF) image format.
Tif | Saves an image using the Tag Image File Format (TIFF) image format.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Inductance Enumeration

Members

Member | Description
Henry |
Yottahenry |
Zettahenry |
Exahenry |
Petahenry |
Terahenry |
Gigahenry |
Megahenry |
Kilohenry |
Hectohenry |
Dekahenry |
Decihenry |
Centihenry |
Millihenry |
Microhenry |
Nanohenry |
Picohenry |
Femtohenry |
Attohenry |
Zeptohenry |
Yoctohenry |
Abhenry |
Stathenry |
EMUOfInductanceAbhenry |
ESUOfInductanceStathenry |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelAlignment Enumeration

Specifies alignment of a label.

Members

Member | Description
Automatic | Label is aligned automatically.
Bottom | Label is bottom aligned.
Center | Label is center aligned.
Top | Label is top aligned.
OutsideBottom | Label is below an object such as a column.
OutsideTop | Label is above an object such as a column.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendBoxPosition Enumeration

Specifies the position of the legend box.

Members

Member | Description
Top | The legend box is rendered at the top right side of the graph.
Middle | The legend box is rendered at the middle right side of the graph.
Bottom | The legend box is rendered at the bottom right side of the graph.
BottomMiddle | The legend box is rendered at the bottom middle side of the graph.
None | The legend box is now visible.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LegendEntryHeaderMode Enumeration

Specifies a header mode for element entries.

Members

Member | Description
None | No effect.
RepeatOnEachColumn | Forces the LegendEntry to be repeated at the top of each column in multi-column legend boxes.
StartNewColumn | Causes the LegendEntry to start a new column.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Length Enumeration

Members

Member | Description
Metre |
Yottametre |
Zettametre |
Exametre |
Petametre |
Terametre |
Gigametre |
Megametre |
Kilometre |
Hectometre |
Dekametre |
Decimetre |
Centimetre |
Millimetre |
Micrometre |
Nanometre |
Picometre |
Femtometre |
Attometre |
Zeptometre |
Yoctometre |
MileUS |
MileUSSurveyFoot |
MileRoman |
Yard |
Foot |
Inch |
AstronomicalUnit |
LightYear |
Parsec |
Kiloparsec |
Megaparsec |
Furlong |
VaraCastellana |
VaraConuquera |
VaraDeTarea |
Perch |
Pole |
Rod |
NauticalMile |
League |
Fathom |
Chain |
Link |
Mil |
Caliber |
Famn |
Aln |
Angstroms |
Fermi |
ClothSpan |
ClothNail |
RomanActus |
RussianArchin |
Arpentlin |
Barleycorn |
Ken |
CubitBiblical |
CubitGreek |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LimitMode Enumeration

Controls the type of limitation in Limit or SplitByLimit properties.

Members

Member | Description
Top | Keep only top Limit values.
Bottom | Keep only bottom Limit values.
ExcludeTop | Remove top Limit values.
ExcludeBottom | Remove Bottom Limit values.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LumberVolume Enumeration

Members

Member | Description
CubicMetres |
BoardFeetAprox |
A1000BoardFeet |
StandardCord |
CordOfSoftwoodAprox |
CordOfHardwoodAprox |
SolidContantCord |
Cunit |
SwitchTiesAprox |
CubicYards |
CubicFeet |
HandleBlankAprox |
SkidsAprox |
Mine |
CrossTie |
Pole |
Pallet |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Mass Enumeration

Members

Member | Description
Gram |
Yottagram |
Zettagram |
Exagram |
Petagram |
Teragram |
Gigagram |
Megagram |
Kilogram |
Hectogram |
Dekagram |
Decigram |
Centigram |
Milligram |
Microgram |
Nanogram |
Picogram |
Femtogram |
Attogram |
Zeptogram |
Yoctogram |
PoundMass |
Carat |
Dalton |
Grain |
Ounce |
Slug |
Ton |
LongTon |
MetricTonne |
TroyOunce |
TroyPound |
Stone |
StoneUK |
Pennyweight |
Kip |
Hundredweight |
HunderdweightUK |
Scruple |
Poundal |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Orientation Enumeration

Specifies the orientation of an object.

Members

Member | Description
Left | The object is on the left.
Right | The object is on the right.
Top | The object is on top.
Bottom | The object is on bottom.
TopLeft | The object ( Usually an annotation) on the upper left hand side.
TopRight | The object ( Usually an annotation) on the upper right hand side.
BottomRight | The object ( Usually an annotation) on the bottom right hand side.
BottomLeft | The object ( Usually an annotation) on the bottom left hand side.
None | No orientation is specified.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Palette Enumeration

Specifies a pre-defined palette.

Members

Member | Description
None | No Palette
One | Palette one.
Two | Palette two.
Three | Palette three.
Four | Palette four.
Five | Palette five.
Random | A random palette.
Autumn | Autumn palette.
Bright | Bright palette.
Lavender | Lavender palette.
MidTones | Mid tones palette.
Mixed | Mixed palette.
Pastel | Pastel palette.
Poppies | Poppies palette.
Spring | Spring palette.
WarmEarth | Warm earth palette.
WaterMeadow | Water meadow palette.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Permeability Enumeration

Members

Member | Description
KilogramPerPascalSecondSquareMeter |
APermeability0C |
APermeability23C |
APermeabilityInches0C |
APermeabilityInches23C |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

PieLabelMode Enumeration

Specifies pie label behavior.

Members

Member | Description
Inside | Labels must be inside the pie, if they dont fit they will not be visible.
Outside | Labels are drawn outside the pie with a line pointing to the slice it represents.
Automatic | If labels fit inside a slice they are drawn there otherwise they are drawn outside with a line pointing to the slice it represents.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Power Enumeration

Members

Member | Description
Watt |
YottajoulePerSecond |
ZeptajoulePerSecond |
ExajoulePerSecond |
PetajoulePerSecond |
TerajoulePerSecond |
GigajoulePerSecond |
MegajoulePerSecond |
KilojoulePerSecond |
HectojoulePerSecond |
DekajoulePerSecond |
JoulePerSecond |
DecijoulePerSecond |
CentijoulePerSecond |
MillijoulePerSecond |
MicrojoulePerSecond |
NanojoulePerSecond |
PicojoulePerSecond |
FemtojoulePerSecond |
AttojoulePerSecond |
ZeptojoulePerSecond |
YoctojoulePerSecond |
JoulePerMinute |
JoulePerHour |
KilojoulePerMinute |
KilojoulePerHour |
BTUPerHour |
BTUPerMinute |
BTUPerSecond |
CaloriesPerHour |
CaloriesPerMinute |
CaloriesPerSecond |
KilocaloriePerHour |
KilocaloriePerMinute |
KilocaloriePerSecond |
PoundFootPerHour |
PoundFootPerMinute |
PoundFootPerSecond |
ErgPerSecond |
Yottawatt |
Zettawatt |
Exawatt |
Petawatt |
Terawatt |
Gigawatt |
Megawatt |
Kilowatt |
Hectowatt |
Dekawatt |
Deciwatt |
Centiwatt |
Milliwatt |
Microwatt |
Nanowatt |
Picowatt |
Femtowatt |
Attowatt |
Zeptowatt |
Yoctowatt |
Pherdeste |
AHorsepower550FtLbfS |
HorsepowerBoiler |
HorsepowerElectric |
HorsepowerMetric |
HorsepowerUK |
HorsepowerWater |
HorsepowerBioler |
RefrigerativeTon |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Pressure Enumeration

Members

Member | Description
Pascal |
Yottapascal |
Zettapascal |
Exapascal |
Petapascal |
Terapascal |
Gigapascal |
Megapascal |
Kilopascal |
Hectopascal |
Dekapascal |
Decipascal |
Centipascal |
Millipascal |
Micropascal |
Nanopascal |
Picopascal |
Femtopascal |
Attopascal |
Zeptopascal |
Yoctopascal |
Bar |
Milibar |
Microbar |
Atmosphere |
AInchOfMercury0C |
AAInchOfMercury155C |
InchOfMercuryConventional |
AMillimetresOfMercury0C |
MilllimeterOfMercuryConventional |
ACentimeterOfMercury0C |
CentimeterOfMercuryConventional |
AInchOfWater4C |
AAInchOfWater155C |
InchOfWaterConventional |
AFootOfWater4C |
AAFootOfWater155C |
FootOfWaterConventional |
AMillimetreOfWater4C |
AAMillimetreOfWater155C |
MillimetreOfWaterConventional |
PoundsPerSquareInch |
KilogramsPerSquareInch |
KilogramsPerCentimetreSquared |
KilogramsPerMetreSquared |
GramsPerMetreSquared |
NewtonsPerMetreSquared |
DynesPerCentemetreSquared |
Torr |
PoundsPerSquareFoot |
TonsPerSquareFoot |
TonsPerSquareInch |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RadarLabelMode Enumeration

Specifies how tick labels behave on a radar graph.

Members

Member | Description
None | The labels are not visible.
Normal | The labels are drawn horizontally next to the tick mark.
Angled | The labels are angled based on the tick mark angle.
Inside | The label is on the right side of the tick mark and angled to touch the top of the grid. The label will be within the radar grid.
Outside | The label is on the right side of the tick mark and angled to lie on top of the grid. The label will be outside the radar grid.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

RadarMode Enumeration

Specifies the behavior of the x axis on a circular graph such as radar.

Members

Member | Description
Spider | The x axis tick marks are connected by straight lines resembling a spider web.
Polar | The x axis ticks marks are connected by arcs completing a circle around the chart. Connected data points such as lines will have data points interpolated around the arc.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Radiation Enumeration

Members

Member | Description
GrayPerSecond |
YottagrayPerSecond |
ZettagrayPerSecond |
ExagrayPerSecond |
PetagrayPerSecond |
TeragrayPerSecond |
GigagrayPerSecond |
MegagrayPerSecond |
KilograyPerSecond |
HectograyPerSecond |
DekagrayPerSecond |
DecigrayPerSecond |
CentigrayPerSecond |
MilligrayPerSecond |
MicrograyPerSecond |
NanograyPerSecond |
PicograyPerSecond |
FemtograyPerSecond |
AttograyPerSecond |
ZeptograyPerSecond |
YoctograyPerSecond |
RadPerSecond |
JoulePerKilogramPerSecond |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Scale Enumeration

Indicates the scale of an axis.

Members

Member | Description
Normal | The normal scale will always show 0 on the chart.
Range | The axis will start and end shortly outside the range of element values.
Logarithmic | Logarithmic axis scale.
Time | Time axis scale.
Stacked | Similar to Normal but elements are stacked on top of each other.
FullStacked | Elements are stacked and each stack is equal to 100%.
LogarithmicStacked | Similar to Logarithmic but elements are stacked on top of each other.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ScaleBreakStyle Enumeration

Specifies how a scale break is drawn on a chart.

Members

Member | Description
None | The scale break is not accentuated in any way.
ZigZag | A gap with a zig zag is drawn at the scale break position.
Gap | A gap is drawn at the scale break position.
Line | A line is drawn at the scale break position.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SeriesType Enumeration

Specifies how a series will be shown on the chart.

Members

Member | Description
Marker | Draws elements as element markers.
Line | Draws the series as a line.
Spline | Draws the series as a spline.
AreaLine | Draws the series as an area line.
Column | Draws the series as a bar.
Cylinder | Draws the series as a cylinder.
Bar | See Column.
Bubble | Draws the series elements as bubbles.
AreaSpline | Draws the series as an area spline.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SeriesTypeFinancial Enumeration

Specifies how a financial series will be shown on the chart.

Members

Member | Description
CandleStick | Draws the series with candle sticks.
Bar | Draws the series with bars.
Open | Draws the opening price as a line.
Close | Draws the closing price as a line.
High | Draws the high price as a line.
Low | Draws the low price as a line.
HighLowArea | Draws a range area of highs and lows.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ShadingEffectMode Enumeration

Specifies a shading mode.

Members

Member | Description
None | No shading is applied.
One | Shading style One.
Two | Shading style Two.
Three | Shading style Three.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SubValueType Enumeration

Specifies the how a sub value is drawn.

Members

Member | Description
ErrorBar | Draws a traditional error bar. The width of the cap line is determined by SubValue.Line.Length. If not specified it is dynamically determined based on the element size.
Marker | Draws a marker at the value position of the SubValue. Two markers are drawn then the SubValue represents a range.
Line | Same as the error bar except only the cap lines are drawn.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace | Axis Class | ScaleSync Class

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

SynchronizeScaleMode Enumeration

Specifies an axis scale synchronization mode between two or more axes.

Members

Member | Description
Origin | Synchronizes axes to match the axis origins. The origin is the position on a numeric axis where the value is zero (0). This mode does not apply to time axes.
Full | Synchronizes the complete axis scale (high, and low).
High | Synchronizes the high range values of multiple axes.
Low | Synchronizes the low range values of multiple axes.

See Also

dotnetCHARTING Namespace | Axis Class | ScaleSync Class


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Telecommunications Enumeration

Members

Member | Description
BitsPerSecond |
T0DigitalSignalZeroPayload |
T0DigitalSignalZeroB8ZSPayload |
AT1DigitalSignal1Signal |
AT1DigitalSignal1Payload |
AT1ZB8ZSDigitalSignal1Payload |
AT1CDigitalSignal1CSignal |
AT1CDigitalSignal1CPayload |
AT2DigitalSignal2Signal |
AT3DigitalSignal3Signal |
AT3DigitalSignal3Payload |
AT3ZB8ZSDigitalSignal3Payload |
AT4DigitalSignal4Signal |
AE1EPTASignal1Signal |
AE1EPTASignal1Payload |
AE2EPTASignal2Signal |
AE2EPTASignal2Payload |
AE3EPTASignal3Signal |
AE3EPTASignal3Payload |
H0DigitalBroadbandChannel |
H4DigitalBroadbandChannel |
H11DigitalBroadbandChannel |
H12DigitalBroadbandChannel |
AVirtualTributary1Signal |
AVirtualTributary1Payload |
AVirtualTributary2Signal |
AVirtualTributary2Payload |
AVirtualTributary3Signal |
AVirtualTributary3Payload |
AVirtualTributary6Signal |
AVirtualTributary6Payload |
ASTS1SynchronousTransmissionSignalLevel1Signal |
ASTS1SynchronousTransmissionSignalLevel1Payload |
ASTS3SynchronousTransmissionSignalLevel2Signal |
ASTS3SynchronousTransmissionSignalLevel2Payload |
ASTS3cConcatenatedSynchronousTransmissionSignalLevel2Signal |
ASTS3cConcatenatedSynchronousTransmissionSignalLevel2Payload |
ASTS12SynchronousTransmissionSignal12Signal |
ASTS24SynchronousTransmissionSignal24Signal |
ASTS48SynchronousTransmissionSignal48Signal |
ASTS192SynchronousTransmissionSignal192Signal |
AASTM1SynchronousTransportModule1Signal |
AASTM4SynchronousTransportModule4Signal |
AASTM16SynchronousTransportModule16Signal |
AASTM64SynchronousTransportModule64Signal |
AOC1OpticalCarrier1Signal |
AOC3OpticalCarrier3Signal |
AOC12OpticalCarrier12Signal |
AOC24OpticalCarrier24Signal |
AOC48OpticalCarrier48Signal |
AOC192OpticalCarrier192Signal |
AOC768OpticalCarrier768Signal |
KilobitsPerSecondBySIDef |
KilobitsPerSecond |
MegabitsPerSecondBySIDef |
MegabitsPerSecond |
GigabitsPerSecondBySIDef |
GigabitsPerSecond |
TerabitsPerSecondBySIDef |
TerabitsPerSecond |
BytesPerSecond |
KilobytesPerSecondBySIDef |
KilobytesPerSecond |
MegabytesPerSecondBySIDef |
MegabytesPerSecond |
GigabytesPerSecondBySIDef |
GigabytesPerSecond |
TerabytesPerSecondBySIDef |
TerabytesPerSecond |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Temperature Enumeration

Members

Member | Description
Kelvin |
Celsius |
Fahrenheit |
Rankine |
Reaumur |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TickLabelMode Enumeration

Specifies how tick labels are laid out.

Members

Member | Description
Automatic | Specifies that the best mode is automatically determined.
Angled | Specifies that labels are angled. Only applies to x axes.
Normal | Specifies that labels are drawn horizontally on a single line. If labels will overlap with this setting, they will automatically switch to angled.
Wrapped | Specifies that labels are drawn wrapping horizontally. If labels will overlap with this setting, they will automatically switch to angled.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Time Enumeration

Members

Member | Description
Second |
Minute |
Hour |
Day |
Week |
Month |
Year |
YearMean |
YearTropical |
LeapYear |
Century |
Novennial |
Octennial |
Septennial |
Quinquennial |
Quindecennial |
SiderealHour |
SiderealDay |
SiderealYear |
Shake |
SynodicMonth |
Fortnight |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TimeInterval Enumeration

Specifies a time interval.

Members

Member | Description
Minutes | Specifies minutes.
Hours | Specifies hours.
Days | Specifies days.
Weeks | Specifies weeks.
Months | Specifies months.
Quarters | Specifies quarters (3 months).
Years | Specifies years.
Hour | Specifies hour by minute.
Day | Specifies day by hour.
Week | Specifies week by day.
Month | Specifies month by day.
Quarter | Specifies year by quarter (3 months).
Year | Specifies year by months.
None | Specifies no time interval.
Seconds | Specifies seconds.
Milliseconds | Specified one millisecond.
Second | Specifies second.
Minute | Specifies minute by seconds.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace | TimeLabelAutomationInfo Class | TimeLabelAutomation Property (dotnetCHARTING.Axis)

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TimeScaleLabelMode Enumeration

Specifies the single value time label automation mode.

Members

Member | Description
Default | Specifies no time label automation. Only the Axis.DefaultTick and Axis.FormatString will be used.
Hidden | Specifies hidden time label mode. Single value time labels will not be shown.
Dynamic | Specifies time instance specific label automation mode. Axis ticks will use a format string and axis tick relevant to the instance in time they represent.
Smart | Specifies smart time label automation. Similar to specific except the first tick will indicate the instance in time and take it's default value from the axis default tick.

Remarks

This feature automates choosing different format strings and axis ticks for particular instances in time. These time instance attributes can be modified through the Axis.TimeLabelAutomationMode property.

(Tutorial) See:
Getting Started / General Tutorials / Axis Tutorials / Axis Ticks / Axis Time Label Automation

See Also

dotnetCHARTING Namespace | TimeLabelAutomationInfo Class | TimeLabelAutomation Property (dotnetCHARTING.Axis)


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TimeScaleLabelRangeMode Enumeration

Specifies the range value time label automation mode.

Members

Member | Description
Default | Range time ticks will not be generated unless the time intervals are specified in TimeScaleLabelInfo.RangeIntervals.
Dynamic | Range time ticks are generated based on dynamically determined intervals. If time intervals are specified in TimeScaleLabelInfo.RangeIntervals this mode will behave like Default mode.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TitleBoxPosition Enumeration

Specifies the title box position.

Members

Member | Description
None | Title box not drawn.
Left | Title box is left aligned.
Center | Title box is centered.
Right | Title box is right aligned.
Full | Title box is stretched across the graph area ( Text is centered ).
FullWithLegend | Title box is stretched across the graph area ( Text is left aligned, legend right aligned ).

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Torque Enumeration

Members

Member | Description
NewtonMetre |
KilonewtonMetres |
NetwonCentimetre |
NetwonMelimetre |
DyneMetre |
DyneCentemetre |
DyneMillimetre |
KilogramForceMetre |
GramForceMetre |
KilogramForceCentimetre |
GramForceCentimetre |
KilogramForceMillimetre |
GramForceMillimetre |
OunceFourceFootAvoirdupois |
OunceForceInchAvoirdupois |
PoundForceFoot |
PoundForceInch |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

TruncationMode Enumeration

Specifies how to trim characters from a string that exceeds a maximum number of characters.

Members

Member | Description
Start | The end of a string is removed until the specified number of characters remains. (ABCD..)
Middle | The start and end of a string is removed until the specified number of characters remains. (..EFGH..)
End | The start of a string is removed until the specified number of characters remains. (..IJKL)
StartEnd | The middle of a string is removed until the specified number of characters remains (ABCD..IJKL)
None | No trimming is performed.

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Typography Enumeration

Members

Member | Description
PrinterPoints |
PostScriptPoints |
Ceros |
Centimetres |
Millimetres |
Inches |
AAPicaComputer16 |
PicaPrinterS |
En |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Velocity Enumeration

Members

Member | Description
MetersPerSecond |
LightSpeed |
MachSeaLevel |
AAMach10000Ft |
AAMach20000Ft |
AAMach30000Ft |
AAMach36089Ft |
CentimetrePerHour |
CentimetrePerMinute |
CentimetrePerSecond |
MetrePerHour |
MetrePerMinute |
KilometerPerHour |
KilometerPerMinute |
KilometerPerSecond |
Knots |
FootPerHour |
FootPerMinute |
FootPerSecond |
YardPerHour |
YardPerMinute |
YardPerSecond |
MilePerHour |
MilePerMinute |
MilePerSecond |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ViscosityDynamic Enumeration

Members

Member | Description
PascalSecond |
Yottapoise |
Zettapoise |
Exapoise |
Petapoise |
Terapoise |
Gigapoise |
Megapoise |
Kilopoise |
Hectopoise |
Dekapoise |
Poise |
Decipoise |
Centipoise |
Millipoise |
Micropoise |
Nanopoise |
Picopoise |
Femtopoise |
Attopoise |
Zeptopoise |
Yoctopoise |
PoundalSecondPerSquareFoot |
PoundForceSecondPerSquareFoot |
PoundForceSecondPerSquareInch |
PoundPerFootHour |
PoundPerFootSecond |
SlugPerFootSecond |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ViscosityKinematic Enumeration

Members

Member | Description
MetreSquaredPerSecond |
Yottastokes |
Zettastokes |
Exastokes |
Petastokes |
Terastokes |
Gigastokes |
Megastokes |
Kilostokes |
Hectostokes |
Dekastokes |
Stokes |
Decistokes |
Centistokes |
Millistokes |
Microstokes |
Nanostokes |
Picostokes |
Femtostokes |
Attostokes |
Zeptostokes |
Yoctostokes |
SquareFootPerSecond |

See Also

dotnetCHARTING Namespace


dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Volume Enumeration

Members

Member | Description
Litre |
Yottalitre |
Zettalitre |
Exalitre |
Petalitre |
Teralitre |
Gigalitre |
Megalitre |
Kilolitre |
Hectolitre |
Dekalitre |
Decilitre |
Centilitre |
Millilitre |
Microlitre |
Nanolitre |
Picolitre |
Femtolitre |
Attolitre |
Zeptolitre |
Yoctolitre |
CubicMetres |
CubicCentimetre |
CubicYards |
CubicFeet |
CubicInches |
GillUK |
GillUS |
GallonUK |
GallonUS |
QuartUS |
QuartUK |
PintUS |
PintUK |
CupUS |
CupUK |
MinimUS |
MinimUK |
Dram |
FluidOuncesUS |
FluidOuncesUK |
Tablespoon |
TablespoonAustralia |
MetricTablespoon |
Teaspoon |
MetricTeaspoon |
TazaEspa |
AcreFoot |
BushelUS |
BushelUK |
BarrelUSDry |
BarrelPetroleum |
PeckUS |
PeckUK |
DryPint |
DryQuart |
Hogshead |
Dash |
Pinch |
Smidgen |

See Also

dotnetCHARTING Namespace


LabelOverride Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelOverride Structure

Defines a string find and replace pair used by Axis objects to manipulate tick labels.

For a list of all members of this type, see LabelOverride members.

Inheritance Hierarchy

System.Object
System.ValueType
dotnetCHARTING.LabelOverride

Syntax

[Visual Basic]
Public Structure LabelOverride
   Inherits ValueType
[C#]
public struct LabelOverride : ValueType

Remarks

The key must match the whole label string not just a part of it.

See Also

LabelOverride Members | dotnetCHARTING Namespace


LabelOverride Structure | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LabelOverride Structure Members

LabelOverride overview

Public Constructors

Public Constructor LabelOverride Constructor Overloaded.

Public Fields

Public Field IgnoreCase | Specifies whether the key is case sensitive.
Public Field Key | String to override.
Public Field Value | String to override the key with.

Public Methods

Public Method Equals (Inherited from System.ValueType)
Public Method GetHashCode (Inherited from System.ValueType)
Public Method ToString (Inherited from System.ValueType)

See Also

LabelOverride Structure | dotnetCHARTING Namespace


LabelOverride Structure | LabelOverride Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

LabelOverride Constructor

Overload List

Initialize a new case insensitive instance of the LabelOverride class.

[Visual Basic] Public Sub New(String,String)

[C#] public LabelOverride(string,string);

Initialize a new instance of the LabelOverride class.

[Visual Basic] Public Sub New(String,String,Boolean)

[C#] public LabelOverride(string,string,bool);

See Also

LabelOverride Structure | LabelOverride Members


LabelOverride Constructor(String,String)

LabelOverride Structure | LabelOverride Members | Overload List

Language

Visual Basic

C#

Show All

key
String to override.
val
String to override the key with.
See Also Languages dotnetCHARTING Send comments on this topic.

LabelOverride Constructor(String,String)

Initialize a new case insensitive instance of the LabelOverride class.

[Visual Basic]
Public Function New( _
   ByVal key As String, _
   ByVal val As String _
)
[C#]
public LabelOverride(
   string key,
   string val
);

Parameters

key
String to override.
val
String to override the key with.

See Also

LabelOverride Structure | LabelOverride Members | Overload List


LabelOverride Constructor(String,String,Boolean)

LabelOverride Structure | LabelOverride Members | Overload List

Language

Visual Basic

C#

Show All

key
String to override.
val
String to override the key with.
ignoreCase
Specifies whether the key is case sensitive.
See Also Languages dotnetCHARTING Send comments on this topic.

LabelOverride Constructor(String,String,Boolean)

Initialize a new instance of the LabelOverride class.

[Visual Basic]
Public Function New( _
   ByVal key As String, _
   ByVal val As String, _
   ByVal ignoreCase As Boolean _
)
[C#]
public LabelOverride(
   string key,
   string val,
   bool ignoreCase
);

Parameters

key
String to override.
val
String to override the key with.
ignoreCase
Specifies whether the key is case sensitive.

See Also

LabelOverride Structure | LabelOverride Members | Overload List


LabelOverride Structure Fields

LabelOverride Structure | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LabelOverride Structure Members

For a list of all members of this type, see LabelOverride members.

Public Fields

Public Field IgnoreCase | Specifies whether the key is case sensitive.
Public Field Key | String to override.
Public Field Value | String to override the key with.

See Also

LabelOverride Structure | dotnetCHARTING Namespace


LabelOverride Structure | LabelOverride Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

IgnoreCase Field

Specifies whether the key is case sensitive.

[Visual Basic]
Public IgnoreCase As Boolean
[C#]
public bool IgnoreCase

See Also

LabelOverride Structure | LabelOverride Members


LabelOverride Structure | LabelOverride Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Key Field

String to override.

[Visual Basic]
Public Key As String
[C#]
public string Key

See Also

LabelOverride Structure | LabelOverride Members


LabelOverride Structure | LabelOverride Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

Value Field

String to override the key with.

[Visual Basic]
Public Value As String
[C#]
public string Value

See Also

LabelOverride Structure | LabelOverride Members


IInstanceID Members | dotnetCHARTING Namespace

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

IInstanceID Interface

Summary description for IInstanceID.

For a list of all members of this type, see IInstanceID members.

Syntax

[Visual Basic]
Private Interface IInstanceID
[C#]
private interface IInstanceID

See Also

IInstanceID Members | dotnetCHARTING Namespace


IInstanceID Interface

IInstanceID Interface | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

IInstanceID Interface Members

IInstanceID overview

Public Properties

Property InstanceID

See Also

IInstanceID Interface | dotnetCHARTING Namespace


IInstanceID Interface Properties

IInstanceID Interface | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

IInstanceID Interface Members

For a list of all members of this type, see IInstanceID members.

Public Properties

Property InstanceID

See Also

IInstanceID Interface | dotnetCHARTING Namespace


IInstanceID Interface | IInstanceID Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

InstanceID Property

[Visual Basic]
Overridable Property InstanceID As Integer
[C#]
virtual int InstanceID {get; set;}

See Also

IInstanceID Interface | IInstanceID Members


ChangeValueDelegate Delegate

dotnetCHARTING Namespace

Language

Visual Basic

C#

Show All

s
See Also Languages dotnetCHARTING Send comments on this topic.

ChangeValueDelegate Delegate

[Visual Basic]
Public Delegate Function ChangeValueDelegate( _
   ByVal s As String _
) As String
[C#]
public delegate string ChangeValueDelegate(
   string s
);

Parameters

s

See Also

dotnetCHARTING Namespace


PostDataProcessingEventHandler Delegate

dotnetCHARTING Namespace

Language

Visual Basic

C#

Show All

sender
See Also Languages dotnetCHARTING Send comments on this topic.

PostDataProcessingEventHandler Delegate

[Visual Basic]
Public Delegate Sub PostDataProcessingEventHandler( _
   ByVal sender As Object _
)
[C#]
public delegate void PostDataProcessingEventHandler(
   object sender
);

Parameters

sender

See Also

dotnetCHARTING Namespace


Licensing and Pricing Index

Licensing and Pricing

  • Licensing and Pricing
    Licensing and pricing options.
  • License Agreement
    License agreement.


Licensing And Pricing

.netCHARTING Enterprise Edition Licensing:

  • Development / Trial
    A fully functional developer's version is provided at no charge.
  • Single Web Site : $395 -
    Usage for a single web site (e.g. www.yourdomain.com).
  • Full Server : $995
    Usage for any number of web sites on a single server.
  • WinForms (desktop) License: $395
    In addition to usage in a server and web site environment, .netCHARTING is also available for use in Winforms (desktop) environments.

At .netCHARTING we are pleased to offer "no nonsense" licensing. Each purchase includes:

  1. A production web site or complete server license
  2. Unlimited development servers
  3. Unlimited development workstations
  4. Unlimited test servers
  5. Unlimited Client access / Users
  6. Unlimited CPU's on a given server
  7. 30 days of priority email support
  8. Life time "as available" product support

In addition to saving thousands over competing solutions, our licensing simplifies deployment and testing for your team. You need only purchase a license for each production web site or server where you wish to use .netCHARTING.

Frequently Asked Questions

Questions | Answers
I would like to use .netCHARTING for a single web site but the application is being developed on another site / server / workstation. Will we need to purchase additional licenses? | No, you need only purchase a license for each production web site or production web server you wish to use the product on. Each license includes a free development license which allows you to use the product (branded not for production use) on any number of development systems.
I have noticed a slight change in the rendered chart image between licensed and unlicensed cases due to the footer. Can this be corrected? | Yes. The dimensions of the final chart image will always be exactly what you provide (in pixels) however when the footer is removed the actual chart elements within the image can increase in size. If you would like the charts to draw in actual size as if the license was applied for your development environment you can set the Chart.OverLapFooter property to true.
If we purchase a single web site license will the license work on sub domains of our current domain, i.e SubDomain.Domain.Com? | No, the license is domain specific and will work for YourDomain.com and www.YourDomain.com. A separate subdomain would require another web site license. Alternatively, we have a server license available which enables you to use the product on any number of sites / url's for one physical server.
Can I upgrade a web site license to a server license at a later time? | Yes you can move from a single web site license to a full web server license for the difference in price between what you paid for the web site license and the current web server license price.
We wish to use .netCHARTING in an intranet environment, which license is appropriate? | For an intranet environment if you have a valid domain such as intranet.yourdomain.com you can use a single web site license. For intranets where your users access your site through a server name, IP or other means or where you have multiple sites or different names a server license would be required.
Licensing for server farms or clusters.

For a server farm or clustered environment a license would be required for each node with active load. For example, with a 2 node cluster sharing load for a single url, 2 single web site licenses would be required. If a 3rd node was available as a hot spare with no active load there would be no additional charge to have .netCHARTING installed on that system.

For clustered servers hosting multiple URL's or using IP's / server names, single web server licenses would be required for each active node.

Note

When you purchase .netCHARTING you are asked to provide your web site / server address. If you are purchasing a single site license, your license is bound to this address and allows for the product to work on this site only - licenses may not be transferred. After you purchase, the branding footer and watermark are removed for the site / server you licensed and you are also free to continue using the branded version for development & testing. Unlike the web site license which is domain specific and can not be changed, a server license can be used on another server so long as it is used on only 1 physical server at one time.


License Agreement

This license agreement is a legal agreement between you and Corporate Web Solutions Ltd. / WebAvail Productions Inc. for .netCHARTING. By using this product/key you agree to be bound by the terms of this agreement.

This software/key is protected by national and international copyright laws. This software/key is licensed, not sold.

Granted Rights : This license grants you the right to install this software/key for use on a single (1) web site / server for the address specified when your key was purchased. In addition, you may use the product for testing and development purposes. This product/key is licensed per site or per server. If you hold a server license you are entitled to install the license key on a single server for use with multiple web sites.

Limitations : You may not reverse engineer, decompile, or disassemble .netCHARTING. You may not rent or lease this software/key, you may not transfer your rights under this license agreement. A license may not be used for any URL other than that specified at the time of purchase, licenses can not be transferred to different domains. .netCHARTING is not a desktop development tool and may not be used in any other application outside of a web server environment. .netCHARTING may not be integrated with or incorporated into any software product or script sold or offered to any 3rd party. A single .netCHARTING license may not be used in an ASP environment to service multiple sites aggregated within one domain, each site must have its own unique license or a server license must be purchased.

Ownership : Corporate Web Solutions Ltd. / WebAvail Productions Inc. retains ownership of the software/key.

Liability : In no event shall Corporate Web Solutions Ltd. / WebAvail Productions Inc. be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of information or any other pecuniary loss) arising out of the use of inability to use this software/key, even if Corporate Web Solutions Ltd. / WebAvail Productions Inc. has been advised of the possibility of such damages.

Termination : Without prejudice to any other rights, Corporate Web Solutions Ltd. / WebAvail Productions Inc. may terminate this license agreement if you fail to comply with the terms and conditions of this agreement. In such event, you must destroy all copies of .netCHARTING, any derivative work, and all of its component parts.

General : By installing this software/key you acknowledge that you have read this license agreement, understand it, and agree to be bound by its terms and conditions.


Support Index

Support

  • Online Support
    Online support and resources.
  • Knowledge Base
    Common issues / tips / and answers to user questions.
  • FAQ
    Frequently asked questions.


F A Q

Can .netCHARTING be used from traditional ASP scripts?
No, .netCHARTING requires ASP.NET, please see system requirements for more details. You can still make use of the images generated by .netCHARTING in any language however as they are not specific to any platform.

Do I need to be a developer in order to use .netCHARTING?
No, .netCHARTING includes an easy to use control, if you are familiar with HTML or ASP scripting you should have no trouble producing dynamic charts within minutes of downloading the product! .netCHARTING is unique because in addition to performing charting it also performs the required database operations and groups the data for you automatically.

Can I use .netCHARTING at my ISP in a shared hosting environment?
Yes, it was specifically designed to support xcopy deployment. If your web host supports ASP.NET you will be able to use .netCHARTING. We recommend that you test with the trial version in your hosted environment to confirm the product will work for you.

There is a specific charting type or feature I am interested in, will .netCHARTING support this?
We are continually enhancing .netCHARTING based on client feedback. If you have any feature requests please feel free to email info@dotnetcharting.com, as your suggestions could end up in the next version of .netCHARTING!

Access to "c:\inetpub\wwwroot\dotnetcharting\web\csharp\temp" is denied (where the value in quotes is a path on your system): Write permissions are required on the directory .netCHARTING is configured to create the charts in. See the install section of this document for instructions on granting write permissions.

CreateControl: A generic error occurred in GDI+: This is a similar case to the previous question. You should ensure that the temp directory is set to a valid path and that the directory has permissions set correctly.

Server Error in '/' Application. File or assembly name dotnetCHARTING, or one of its dependencies, was not found: This error indicates that an application is not created on the directory that contains your /bin directory which in turn contains dotnetCHARTING.dll. If you follow the instructions for installation via virtual directory an application is created by default. You can also create an application on the directory see here for instructions.

How do I map my database fields onto the x, y axis and other fields?
Use Series.DataFields or if using the DataEngine DataEngine.DataFields properties. Examples:
Simple Chart: Chart.Series.DataFields = "yAxis=myValueField,xAxis=myNameField";
Financial Chart: Chart.Series.DataFields = "Open=myOpenField, Close=myCloseField, High=myHighField.....";

I have licensing questions, what are the options and restrictions?
Please see pricing and purchase for detailed information on the product licensing.

Can I upgrade a web site license to a server license at a later date?
Yes, for the difference in price between what you paid for the web site license and the current cost of the server license. In this case the server license would replace your web site license.

I installed my license but the chart is still branded 'not for production use' why?

Website License:

  • If you have a 1.x key you must obtain a new key to work with version 2.x from orders@dotnetcharting.com
  • The key must be the bin folder of your application along with the dotnetcharting.dll.
  • Make sure there is only one key in that folder along with the dotnetcharting DLL.
  • The license takes effect when the charts are viewed through the licensed domain in the web browser.
  • The license purchased for a particular domain is specific to YourDomain.com and www.YourDomain.com.
  • The license will not work on sub domains such as 'server1.YourDomain.com' unless a specific key is purchased for such a URL.

Server License:
  • Do you have the server version of .netCHARTING? To check open the zip up and see if it contains an install.txt file.
  • Make sure the license key is located in the correct folder as per the install.txt.
  • Make sure there is only one key in that folder along with the dotnetcharting DLL.
  • If you have a 1.x server key you must get a new key for it to work with version 2.x from orders@dotnetcharting.com
  • Was the .netCHARTING DLL added to the Assembly Cache node in the Microsoft .NET framework Configuration application? (also known as the GAC)
  • Has the assembly entry been added to you machine.config or web.config file according to step 3 install.txt file?
  • Does the version of the above entry match the version of the dll you are using?
  • Please double check the steps detailed in the install.txt were followed exactly.


Trademark And Copyright

.netCHARTING documentation, logo, design and application is copyright 2002, 2003, 2004, 2005 WebAvail Productions Inc. and Corporate Web Solutions Ltd.

All trademarks of products, services, company or organizational names, logos, phrases, service marks, service logos, and/or slogans are trademark(s) or registered trademark(s) and/or service mark(s) of the respective holder(s), where applicable.


Assembly Overview

Namespaces

Namespace | Description
dotnetCHARTING |


Getting Started - dotnetCHARTING

dotnetCHARTING Send comments on this topic.

Getting Started

2002 - 2005 Webavail Productions Inc. & Corporate Web Solutions Ltd.. All Rights Reserved.


Introduction - dotnetCHARTING

dotnetCHARTING Send comments on this topic.

Introduction

2002 - 2005 Webavail Productions Inc. & Corporate Web Solutions Ltd.. All Rights Reserved.


Annotation Class Methods

Annotation Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Annotation Class Members

For a list of all members of this type, see Annotation members.

Public Methods

Public Method ClearColors (Inherited from Box) | Serves as a shortcut to make this box invisible.
Public Method GetCoordinates (Inherited from Box) | Gets the coordinates of this box after the chart is rendered.
Public Method GetRectangle (Inherited from Box) | Gets a Rectangle object indicating this boxes position and size after the chart is rendered.

See Also

Annotation Class | dotnetCHARTING Namespace


Axis.ScaleSync Class Methods

Axis.ScaleSync Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

Axis.ScaleSync Class Members

For a list of all members of this type, see Axis.ScaleSync members.

Public Methods

Public Method Add (Inherited from AxisCollection) | Overloaded.
Public Method Clear (Inherited from System.Collections.CollectionBase) |
Public Method Contains (Inherited from AxisCollection) | Determines whether this collection contains a specified Axis.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) |
Public Method IndexOf (Inherited from AxisCollection) | Determines the index of a specified Axis in this collection.
Public Method Insert (Inherited from AxisCollection) | Inserts a Axis into this collection at a specified index.
Public Method Remove (Inherited from AxisCollection) | Removes a specified Axis from this collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) |

See Also

Axis.ScaleSync Class | dotnetCHARTING Namespace


AxisMarker Class Methods

AxisMarker Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

AxisMarker Class Members

For a list of all members of this type, see AxisMarker members.

Public Methods

Public Method ToString (Inherited from ScaleRange)

See Also

AxisMarker Class | dotnetCHARTING Namespace


ChartArea Class | ChartArea Members

Language

C#

Show All

See Also Languages dotnetCHARTING Send comments on this topic.

ValueLabel Property

Gets or sets a label that specifies the font and color of element labels drawn on the chart.

Equivalent to: Chart.DefaultSeries.DefaultElement.SmartLabel

[Visual Basic]
Public Property ValueLabel As Label
[C#]
public Label ValueLabel {get; set;}

See Also

ChartArea Class | ChartArea Members


LabelOverride Structure Methods

LabelOverride Structure | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LabelOverride Structure Members

For a list of all members of this type, see LabelOverride members.

Public Methods

Public Method Equals (Inherited from System.ValueType)
Public Method GetHashCode (Inherited from System.ValueType)
Public Method ToString (Inherited from System.ValueType)

See Also

LabelOverride Structure | dotnetCHARTING Namespace


LegendBox Class Methods

LegendBox Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

LegendBox Class Members

For a list of all members of this type, see LegendBox members.

Public Methods

Public Method ClearColors (Inherited from Box) | Serves as a shortcut to make this box invisible.
Public Method GetCoordinates (Inherited from Box) | Gets the coordinates of this box after the chart is rendered.
Public Method GetRectangle (Inherited from Box) | Gets a Rectangle object indicating this boxes position and size after the chart is rendered.

See Also

LegendBox Class | dotnetCHARTING Namespace


ListCollection Class Properties

ListCollection Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

ListCollection Class Members

For a list of all members of this type, see ListCollection members.

Public Properties

Public Property Count (Inherited from System.Collections.Specialized.ListDictionary)
Public Property IsFixedSize (Inherited from System.Collections.Specialized.ListDictionary)
Public Property IsReadOnly (Inherited from System.Collections.Specialized.ListDictionary)
Public Property IsSynchronized (Inherited from System.Collections.Specialized.ListDictionary)
Public Property Item (Inherited from System.Collections.Specialized.ListDictionary)
Public Property Keys (Inherited from System.Collections.Specialized.ListDictionary)
Public Property SyncRoot (Inherited from System.Collections.Specialized.ListDictionary)
Public Property Values (Inherited from System.Collections.Specialized.ListDictionary)

See Also

ListCollection Class | dotnetCHARTING Namespace


SmartLabel Class Methods

SmartLabel Class | dotnetCHARTING Namespace

See Also dotnetCHARTING Send comments on this topic.

SmartLabel Class Members

For a list of all members of this type, see SmartLabel members.

Public Methods

Public Method Dispose (Inherited from Label)

See Also

SmartLabel Class | dotnetCHARTING Namespace


Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Axis Marker
Used to mark a line of area of a chart and must be attached to an axis. It can also be attached to an element. The element will in turn carry it onto the axis it's on.

C

Category Axis
An axis with evenly spaced text tick values.

D

Data Fields
A dictionary list that facilitates .netCHARTING data acquisition engine (DataEngine). It defines which database columns map to which element properties.

E

Element
A data single data point plotted on a chart.

Element Group
A group of elements that have the same name. Elements that share names are usually grouped and shown on the same axis tick.

S

Series
A collection of data elements plotted on a chart.

Shadow Axis
An axis that shadows another axis but can manipulate it's ticks to represent the information in a different way.

Smart Category Axis
An axis with evenly spaced text tick values. If the ticks represents numeric or time values they will be ordered sequentially but not spaced based on the actual values.

T

Tokens
A term prefixed with a percent sign that refers to a property of objects such as series and elements. It can be used in labels and will be replaced with the correct information at runtime. Example: '%YValue' - This specifies the y value of an element.

V

Value Axis
An axis with a numeric or time scale. This scale has tick marks that reflect the actual distance between the values.

Virtual Directory
Directory that references one or more physical directories and, optionally, other virtual directories.


Knowledge Base

.netCHARTING offers an extensive Knowledge Base supporting full text search with detailed articles available to address your support and sales questions 24/7.

If you have any technical questions that the KB does not yet have an entry for please contact support@dotnetcharting.com Customer service is available Monday to Friday, 9am to 5pm Pacific.


Quick Start

Quick Start (Recommended Read)

Thank you for downloading .netCHARTING. As you explore the features and functionality of this component you will find it is extremely powerful and capable to creating any charts you need. This software has been developed to be much more flexible than any component you may have worked with before. This will enable you to push the envelope beyond the features you may have seen explored or imagined.

This section with give a general overview of how everything works and is designed to get you started quickly. So without further ado, let's get to it.

Step 1. Installation

Please see the instructions in the installation help topic to get the component installed and to be able to view the accompanying samples.

After the component is installed, take a look at the samples to get a grasp on some of the features available. You may see some interesting ideas that will let your subconscious start working on your project while you get up to speed.

Step 2. Getting/Using Data

.netCHARTING has a simple yet powerful interface for data acquisition and manipulation. Chart data is represented by SeriesCollection, Series, and Element classes. For more information on this model see this topic. When you are familiar with the general data model, you can explore the connecting to data sources and using query strings sections to find out how to populate these classes automatically.

Advanced
At this point you will be able to generate simple charts, however, this is only scratches the surface of what you can do in the data acquisition phase. You can also manipulate, group by dates, limit top x results, and do many other things with your data. When you are ready to explore the more advanced data features, take a look at the other tutorials available in the Data Tutorials section.

Step 3. Chart Type

An important point to remember is that the data model is independent from the chart engine itself. This means that whatever data you get, you can show any type chart with it. Mechanism behind the chart types is quite flexible and a tutorial is available here.

Step 4. Exploring other features

You will now be able to generate basic charts and have a general idea of how to change the chart type. Most of the time, this is not enough to create the exact chart you need. Fortunately, we have covered only about 5% of the functionality available. Moving forward, there are many tutorials at your disposal. You may also visit the support section of our website to download printable PDF versions of some tutorials so that you can review them at your leasure.

Happy Coding!


Samples

An extensive suite of example scripts is included with the bundle which demonstrate how easy it is to use .netCHARTING. These samples use hard coded data in addition to an access database which includes 4000+ sample order records for the year of 2002/2003. The concept of a store was used for this demonstration, however, .netCHARTING can be used to chart any type of data, from any scenario, quickly and easily. With as few as 6 simple lines of script, you can have a complete, dynamic, multiple series chart pulled from your own database! Samples are also included that use a datatable directly, XML, and Excel. SQL server is also supported natively and any other databases can be used with the system by passing your datatable / dataset.

Samples are included with the .netCHARTING bundle and can be located in the /csharp and /vbnet directories in the following categories:

Classic
Samples from previous versions of .netCHARTING designed to work with the latest version

Features
Feature specific samples, showing specific functionality in use.

Samples & Getting Data
The classic samples show a shortcut method of getting data. The features samples mostly generate dynamic data which simulates getting data using the dataEngine class. For more information on the DataEngine see this topic, and sample: features/dataEngine.aspx.

Gallery
Gallery specific samples, showing different charting types with randomly generated data.

If you would like to see a specific sample added please email your request to info@dotnetcharting.com.


Support

Support

Customer satisfaction is of the utmost importance to the .netCHARTING team. It drives development to create the richest possible solutions and compels customer service to pass on their knowledge and experience in the clearest, most effective way.

If you have any sales questions please contact info@dotnetcharting.com

If you have any order or licensing questions please contact orders@dotnetcharting.com

At .netCHARTING we stand behind the quality of our products and support with a total customer satisfaction program including:

  • Fully functional free trial versions prior to purchase
  • 30 days of priority email support after purchase
  • Lifetime "as available" product support
  • Free minor version upgrades
  • No nonsense licensing

If you have any technical questions please contact support@dotnetcharting.com

Before contacting support

In order to provide the best support possible please review the following information before contacting support.

License installation support:
Please review the license installation trouble shooter.

Clients:
Please include your order number (also known as your orderid) within the subject of the email.

If no chart is rendered on your page:
Set Chart.Debug = true to see the specific error or reason your chart was not generated.

Help resources:
There are several help resources available with the downloadable bundle.

  • Dotnetcharting.chm help file included in the download bundle.
  • C# & VB.NET samples covering many scenarios.
  • Complete .netCHARTING gallery including code in C# and VB.NET.


System Requirements

.netCHARTING is designed to be used in a web server environment.

Supported Operating Systems

  • Windows 2000 Server
  • Windows XP Professional
  • Windows 2000 Professional
  • Windows Server 2003
Additional Requirements
  • ASP.NET
Downloads and Links
  • If you are running a supported Operating system but are not yet running ASP.NET you can download it for free directly from Microsoft here.


Test

2002 - 2005 Webavail Productions Inc. & Corporate Web Solutions Ltd.. All Rights Reserved.